Intro

Intro to BigFix Session Inspectors

The BigFix Session Inspector Help File is an online guide to the Inspectors of the Relevance Language™ as applied to BES Sessions, including the BES Console and Web Reports. The BigFix Session Inspectors allow you to access information statistically collated from the BES Database. Using this information, you can then develop interactive displays, Dashboards, Wizards and powerful custom reports for display in the BES Console or the Web Reports program.

This help file will help you to develop presentations using the Session Inspectors. Client Inspectors are not available within the Session context, due to security considerations. However, you can use any of the Core or Regex Inspectors, which are listed in the keyword section of this document. For more information on these Inspectors, see the Windows Inspector Library.

Audience

This guide is for IT managers and other people who want to create customized displays and reports using the BES Databases. IT managers use the BigFix Enterprise Suite (BES) to keep large networks of computers up to date and running smoothly without interruption. The information stored in the BES Database can also be tapped by the Session Inspectors to create interactive displays and detailed reports on all the computers in the network.

You can always create custom reports and displays using a third-party reporting engine or by directly querying the database. However, the BigFix Session Inspectors are typically easier to set up and offer greater power and flexibility. Most importantly, the resulting reports are interactive and offer real-time display updates.

To get the most out of this manual, it helps to have some experience with the BES and the BigFix Relevance Language. For more information, see the BigFix Console Operator’s Guide and the BigFix Relevance Language Reference.


Key phrases

This is a list of the key phrases relevant to this document, sorted alphabetically.

Key Phrase | Plural | Creates a | From a | Form
abbr <string> of <html> | abbrs | <html> | <html> | Named
abbr <string> of <string> | abbrs | <html> | <string> | Named
abbr of <html> | abbrs | <html> | <html> | Plain
abbr of <string> | abbrs | <html> | <string> | Plain
absolute value of <hertz> | absolute values | <hertz> | <hertz> | Plain
absolute value of <integer> | absolute values | <integer> | <integer> | Plain
absolute value of <time interval> | absolute values | <time interval> | <time interval> | Plain
access mode of <access control entry> | access modes | <integer> | <access control entry> | Plain
accessed time of <filesystem object> | accessed times | <time> | <filesystem object> | Plain
account disabled flag of <local user> | account disabled flags | <boolean> | <local user> | Plain
account expiration of <local user> | account expirations | <time> | <local user> | Plain
account lockout duration of <security database> | account lockout durations | <time interval> | <security database> | Plain
account lockout observation window of <security database> | account lockout observation windows | <time interval> | <security database> | Plain
account lockout threshold of <security database> | account lockout thresholds | <integer> | <security database> | Plain
account logon category of <audit policy> | account logon categories | <audit policy category> | <audit policy> | Plain
account management category of <audit policy> | account management categories | <audit policy category> | <audit policy> | Plain
account name of <security identifier> | account names | <string> | <security identifier> | Plain
accounts operator flag of <local user> | accounts operator flags | <boolean> | <local user> | Plain
acronym <string> of <html> | acronyms | <html> | <html> | Named
acronym <string> of <string> | acronyms | <html> | <string> | Named
acronym of <html> | acronyms | <html> | <html> | Plain
acronym of <string> | acronyms | <html> | <string> | Plain
action | actions | <action> | <world> | PlainGlobal
action <integer> | actions | <action> | <world> | NumberedGlobal
action lock state | action lock states | <action lock state> | <world> | PlainGlobal
action of <firewall rule> | actions | <firewall action> | <firewall rule> | Plain
active action | active actions | <action> | <world> | PlainGlobal
active device | active devices | <active device> | <world> | PlainGlobal
active device file | active device files | <file> | <world> | PlainGlobal
active device file <string> | active device files | <file> | <world> | NamedGlobal
active of <action> | actives | <boolean> | <action> | Plain
active of <logged on user> | actives | <boolean> | <logged on user> | Plain
active start time of <action> | active start times | <time> | <action> | Plain
adapter of <network> | adapters | <network adapter> | <network> | Plain
address <string> of <html> | addresss | <html> | <html> | Named
address <string> of <string> | addresss | <html> | <string> | Named
address list of <network adapter> | address lists | <network address list> | <network adapter> | Plain
address of <html> | addresss | <html> | <html> | Plain
address of <network adapter> | addresses | <ipv4 address> | <network adapter> | Plain
address of <network address list> | addresses | <ipv4 address> | <network address list> | Plain
address of <network ip interface> | addresses | <ipv4 address> | <network ip interface> | Plain
address of <string> | addresss | <html> | <string> | Plain
admin privilege of <local user> | admin privileges | <boolean> | <local user> | Plain
administrator <string> of <client> | administrators | <setting> | <client> | Named
administrator of <client> | administrators | <setting> | <client> | Plain
all firewall scope | all firewall scopes | <firewall scope> | <world> | PlainGlobal
allow firewall action | allow firewall actions | <firewall action> | <world> | PlainGlobal
allow inbound echo request of <firewall icmp settings> | allow inbound echo requests | <boolean> | <firewall icmp settings> | Plain
allow inbound mask request of <firewall icmp settings> | allow inbound mask requests | <boolean> | <firewall icmp settings> | Plain
allow inbound router request of <firewall icmp settings> | allow inbound router requests | <boolean> | <firewall icmp settings> | Plain
allow inbound timestamp request of <firewall icmp settings> | allow inbound timestamp requests | <boolean> | <firewall icmp settings> | Plain
allow outbound destination unreachable of <firewall icmp settings> | allow outbound destination unreachables | <boolean> | <firewall icmp settings> | Plain
allow outbound packet too big of <firewall icmp settings> | allow outbound packet too bigs | <boolean> | <firewall icmp settings> | Plain
allow outbound parameter problem of <firewall icmp settings> | allow outbound parameter problems | <boolean> | <firewall icmp settings> | Plain
allow outbound source quench of <firewall icmp settings> | allow outbound source quenches | <boolean> | <firewall icmp settings> | Plain
allow outbound time exceeded of <firewall icmp settings> | allow outbound time exceededs | <boolean> | <firewall icmp settings> | Plain
allow redirect of <firewall icmp settings> | allow redirects | <boolean> | <firewall icmp settings> | Plain
allowed workstations string of <local user> | allowed workstations strings | <string> | <local user> | Plain
ancestor of <filesystem object> | ancestors | <folder> | <filesystem object> | Plain
anchor <string> of <html> | anchors | <html> | <html> | Named
anchor <string> of <string> | anchors | <html> | <string> | Named
anchor of <html> | anchors | <html> | <html> | Plain
anchor of <string> | anchors | <html> | <string> | Plain
ansi code page | ansi code pages | <integer> | <world> | PlainGlobal
any ip version | any ip versions | <ip version> | <world> | PlainGlobal
apparent registration server time | apparent registration server times | <time> | <world> | PlainGlobal
append permission of <access control entry> | append permissions | <boolean> | <access control entry> | Plain
application <string> | applications | <application> | <world> | NamedGlobal
application <string> of <folder> | applications | <application> | <folder> | Named
application <string> of <registry key> | applications | <application> | <registry key> | Named
application <string> of <registry> | applications | <application> | <registry> | Named
application event log | application event logs | <event log> | <world> | PlainGlobal
application folder <string> of <registry key> | application folders | <folder> | <registry key> | Named
application folder <string> of <registry> | application folders | <folder> | <registry> | Named
application folder of <registry key> | application folders | <folder> | <registry key> | Plain
application name of <firewall rule> | application names | <string> | <firewall rule> | Plain
application of <registry key> | applications | <application> | <registry key> | Plain
application of <registry> | applications | <application> | <registry> | Plain
application parameter string of <local user> | application parameter strings | <string> | <local user> | Plain
application usage summary | application usage summaries | <application usage summary> | <world> | PlainGlobal
application usage summary <string> | application usage summaries | <application usage summary> | <world> | NamedGlobal
april | aprils | <month> | <world> | PlainGlobal
april <integer> | aprils | <day of year> | <world> | NumberedGlobal
april <integer> of <integer> | aprils | <date> | <integer> | Numbered
april of <integer> | aprils | <month and year> | <integer> | Plain
archive of <filesystem object> | archives | <boolean> | <filesystem object> | Plain
argument string of <file shortcut> | argument strings | <string> | <file shortcut> | Plain
attribute <integer> of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Numbered
attribute <string> of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Named
attribute of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Plain
attribute permission of <network share> | attribute permissions | <boolean> | <network share> | Plain
audit failure event log event type | audit failure event log event types | <event log event type> | <world> | PlainGlobal
audit failure of <audit policy information> | audit failures | <boolean> | <audit policy information> | Plain
audit level of <local mssql database> | audit levels | <integer> | <local mssql database> | Plain
audit policy | audit policies | <audit policy> | <world> | PlainGlobal
audit success event log event type | audit success event log event types | <event log event type> | <world> | PlainGlobal
audit success of <audit policy information> | audit successes | <boolean> | <audit policy information> | Plain
august | augusts | <month> | <world> | PlainGlobal
august <integer> | augusts | <day of year> | <world> | NumberedGlobal
august <integer> of <integer> | augusts | <date> | <integer> | Numbered
august of <integer> | augusts | <month and year> | <integer> | Plain
authorized application of <firewall profile> | authorized applications | <firewall authorized application> | <firewall profile> | Plain
b <string> of <html> | bs | <html> | <html> | Named
b <string> of <string> | bs | <html> | <string> | Named
b of <html> | bs | <html> | <html> | Plain
b of <string> | bs | <html> | <string> | Plain
backoffice bit <operating system suite mask> | backoffice bits | <boolean> | <world> | Index<operating system suite mask>Global
bad password count of <local user> | bad password counts | <integer> | <local user> | Plain
base <string> of <html> | bases | <html> | <html> | Named
base <string> of <string> | bases | <html> | <string> | Named
base of <html> | bases | <html> | <html> | Plain
base of <string> | bases | <html> | <string> | Plain
bes license | bes licenses | <license> | <world> | PlainGlobal
big <string> of <html> | bigs | <html> | <html> | Named
big <string> of <string> | bigs | <html> | <string> | Named
big of <html> | bigs | <html> | <html> | Plain
big of <string> | bigs | <html> | <string> | Plain
binary operator <string> | binary operators | <binary operator> | <world> | NamedGlobal
binary operator returning <type> | binary operators returning | <binary operator> | <world> | Index<type>Global
bit <integer> | bits | <bit set> | <world> | NumberedGlobal
bit <integer> of <bit set> | bits | <boolean> | <bit set> | Numbered
bit <integer> of <integer> | bits | <boolean> | <integer> | Numbered
bit set <string> | bit sets | <bit set> | <world> | NamedGlobal
blade bit <operating system suite mask> | blade bits | <boolean> | <world> | Index<operating system suite mask>Global
block firewall action | block firewall actions | <firewall action> | <world> | PlainGlobal
blockquote <string> of <html> | blockquotes | <html> | <html> | Named
blockquote <string> of <string> | blockquotes | <html> | <string> | Named
blockquote of <html> | blockquotes | <html> | <html> | Plain
blockquote of <string> | blockquotes | <html> | <string> | Plain
body <string> of <html> | bodys | <html> | <html> | Named
body <string> of <string> | bodys | <html> | <string> | Named
body of <html> | bodys | <html> | <html> | Plain
body of <string> | bodys | <html> | <string> | Plain
boolean <string> | booleans | <boolean> | <world> | NamedGlobal
boolean value <integer> of <wmi select> | boolean values | <boolean> | <wmi select> | Numbered
boolean value of <wmi select> | boolean values | <boolean> | <wmi select> | Plain
boot time of <operating system> | boot times | <time> | <operating system> | Plain
br | brs | <html> | <world> | PlainGlobal
br <string> | brs | <html> | <world> | NamedGlobal
brand id of <processor> | brand ids | <integer> | <processor> | Plain
brand string of <processor> | brand strings | <string> | <processor> | Plain
broadcast address of <network ip interface> | broadcast addresses | <ipv4 address> | <network ip interface> | Plain
broadcast support of <network ip interface> | broadcast supports | <boolean> | <network ip interface> | Plain
build number high of <operating system> | build number highs | <integer> | <operating system> | Plain
build number low of <operating system> | build number lows | <integer> | <operating system> | Plain
build number of <operating system> | build numbers | <integer> | <operating system> | Plain
built in of <firewall open port> | built ins | <boolean> | <firewall open port> | Plain
byte <integer> of <file> | bytes | <integer> | <file> | Numbered
can interact with desktop of <service> | can interact with desktops | <boolean> | <service> | Plain
caption <string> of <html> | captions | <html> | <html> | Named
caption <string> of <string> | captions | <html> | <string> | Named
caption of <html> | captions | <html> | <html> | Plain
caption of <string> | captions | <html> | <string> | Plain
case insensitive regex <string> | case insensitive regexes | <regular expression> | <world> | NamedGlobal
case insensitive regular expression <string> | case insensitive regular expressions | <regular expression> | <world> | NamedGlobal
cast <string> | casts | <cast> | <world> | NamedGlobal
cast from of <type> | casts from | <cast> | <type> | Plain
cast returning <type> | casts returning | <cast> | <world> | Index<type>Global
category of <audit policy> | categories | <audit policy category> | <audit policy> | Plain
category of <event log record> | categories | <integer> | <event log record> | Plain
change notification permission of <access control entry> | change notification permissions | <boolean> | <access control entry> | Plain
character <integer> | characters | <string> | <world> | NumberedGlobal
character <integer> of <string> | characters | <substring> | <string> | Numbered
character of <string> | characters | <substring> | <string> | Plain
checkpoint of <service> | checkpoints | <integer> | <service> | Plain
child node <integer> of <xml dom node> | child nodes | <xml dom node> | <xml dom node> | Numbered
child node of <xml dom node> | child nodes | <xml dom node> | <xml dom node> | Plain
cidr string of <network adapter> | cidr strings | <string> | <network adapter> | Plain
cidr string of <network address list> | cidr strings | <string> | <network address list> | Plain
cidr string of <network ip interface> | cidr strings | <string> | <network ip interface> | Plain
cite <string> of <html> | cites | <html> | <html> | Named
cite <string> of <string> | cites | <html> | <string> | Named
cite of <html> | cites | <html> | <html> | Plain
cite of <string> | cites | <html> | <string> | Plain
class of <active device> | classes | <string> | <active device> | Plain
client | clients | <client> | <world> | PlainGlobal
client cryptography | client cryptographies | <client_cryptography> | <world> | PlainGlobal
client folder of <site> | client folders | <folder> | <site> | Plain
client license | client licenses | <license> | <world> | PlainGlobal
code <string> of <html> | codes | <html> | <html> | Named
code <string> of <string> | codes | <html> | <string> | Named
code of <html> | codes | <html> | <html> | Plain
code of <string> | codes | <html> | <string> | Plain
code page of <local user> | code pages | <integer> | <local user> | Plain
codepage of <file version block> | codepages | <string> | <file version block> | Plain
col <string> of <html> | cols | <html> | <html> | Named
col <string> of <string> | cols | <html> | <string> | Named
col of <html> | cols | <html> | <html> | Plain
col of <string> | cols | <html> | <string> | Plain
colgroup <string> of <html> | colgroups | <html> | <html> | Named
colgroup <string> of <string> | colgroups | <html> | <string> | Named
colgroup of <html> | colgroups | <html> | <html> | Plain
colgroup of <string> | colgroups | <html> | <string> | Plain
comment of <local group> | comments | <string> | <local group> | Plain
comment of <local user> | comments | <string> | <local user> | Plain
comment of <network share> | comments | <string> | <network share> | Plain
common name of <license> | common names | <string> | <license> | Plain
communications bit <operating system suite mask> | communications bits | <boolean> | <world> | Index<operating system suite mask>Global
communications operator flag of <local user> | communications operator flags | <boolean> | <local user> | Plain
competition size of <selected server> | competition sizes | <integer> | <selected server> | Plain
competition weight of <selected server> | competition weights | <integer> | <selected server> | Plain
complete time of <action> | complete times | <time> | <action> | Plain
component <integer> of <distinguished name> | components | <distinguished name component> | <distinguished name> | Numbered
component <integer> of <site version list> | components | <integer> | <site version list> | Numbered
component of <distinguished name> | components | <distinguished name component> | <distinguished name> | Plain
component string of <security identifier> | component strings | <string> | <security identifier> | Plain
compressed of <filesystem object> | compresseds | <boolean> | <filesystem object> | Plain
computer id | computer ids | <integer> | <world> | PlainGlobal
computer name | computer names | <string> | <world> | PlainGlobal
computer of <event log record> | computers | <string> | <event log record> | Plain
concatenation <html> of <html> | concatenations | <html> | <html> | Index<html>
concatenation <html> of <string> | concatenations | <html> | <string> | Index<html>
concatenation <string> of <html> | concatenations | <html> | <html> | Named
concatenation <string> of <string> | concatenations | <string> | <string> | Named
concatenation of <html> | concatenations | <html> | <html> | Plain
concatenation of <string> | concatenations | <string> | <string> | Plain
conjunction of <boolean> | conjunctions | <boolean> | <boolean> | Plain
connection of <network> | connections | <connection> | <network> | Plain
connection status <integer> | connection statuses | <connection status> | <world> | NumberedGlobal
connection status authenticating | connection statuses authenticating | <connection status> | <world> | PlainGlobal
connection status authentication failed | connection statuses authentication failed | <connection status> | <world> | PlainGlobal
connection status authentication succeeded | connection statuses authentication succeeded | <connection status> | <world> | PlainGlobal
connection status connected | connection statuses connected | <connection status> | <world> | PlainGlobal
connection status connecting | connection statuses connecting | <connection status> | <world> | PlainGlobal
connection status disconnected | connection statuses disconnected | <connection status> | <world> | PlainGlobal
connection status disconnecting | connection statuses disconnecting | <connection status> | <world> | PlainGlobal
connection status hardware disabled | connection statuses hardware disabled | <connection status> | <world> | PlainGlobal
connection status hardware malfunction | connection statuses hardware malfunction | <connection status> | <world> | PlainGlobal
connection status media disconnected | connection statuses media disconnected | <connection status> | <world> | PlainGlobal
connection status no hardware present | connection statuses no hardware present | <connection status> | <world> | PlainGlobal
constrained of <action> | constraineds | <boolean> | <action> | Plain
content of <file> | contents | <file content> | <file> | Plain
control of <security descriptor> | controls | <integer> | <security descriptor> | Plain
controller of <action lock state> | controllers | <string> | <action lock state> | Plain
country code of <local user> | country codes | <integer> | <local user> | Plain
create file permission of <access control entry> | create file permissions | <boolean> | <access control entry> | Plain
create folder permission of <access control entry> | create folder permissions | <boolean> | <access control entry> | Plain
create link permission of <access control entry> | create link permissions | <boolean> | <access control entry> | Plain
create permission of <network share> | create permissions | <boolean> | <network share> | Plain
create subkey permission of <access control entry> | create subkey permissions | <boolean> | <access control entry> | Plain
creation time of <filesystem object> | creation times | <time> | <filesystem object> | Plain
cryptography | cryptographies | <cryptography> | <world> | PlainGlobal
csd version of <operating system> | csd versions | <string> | <operating system> | Plain
csidl folder <integer> | csidl folders | <folder> | <world> | NumberedGlobal
current date | current dates | <date> | <world> | PlainGlobal
current day_of_month | current days_of_month | <day of month> | <world> | PlainGlobal
current day_of_week | current days_of_week | <day of week> | <world> | PlainGlobal
current day_of_year | current days_of_year | <day of year> | <world> | PlainGlobal
current firewall profile type | current firewall profile types | <firewall profile type> | <world> | PlainGlobal
current month | current months | <month> | <world> | PlainGlobal
current month_and_year | current months_and_years | <month and year> | <world> | PlainGlobal
current profile of <firewall policy> | current profiles | <firewall profile> | <firewall policy> | Plain
current profile type of <firewall> | current profile types | <firewall profile type> | <firewall> | Plain
current relay | current relays | <current relay> | <world> | PlainGlobal
current site | current sites | <site> | <world> | PlainGlobal
current time_of_day | current times_of_day | <time of day with time zone> | <world> | PlainGlobal
current time_of_day <time zone> | current times_of_day | <time of day with time zone> | <world> | Index<time zone>Global
current user | current users | <logged on user> | <world> | PlainGlobal
current user key <logged on user> of <registry> | current user keys | <registry key> | <registry> | Index<logged on user>
current year | current years | <year> | <world> | PlainGlobal
currently active of <firewall rule> | currently actives | <boolean> | <firewall rule> | Plain
custom firewall scope | custom firewall scopes | <firewall scope> | <world> | PlainGlobal
custom site subscription effective date <string> | custom site subscription effective dates | <time> | <world> | NamedGlobal
customized of <firewall service> | customizeds | <boolean> | <firewall service> | Plain
dacl of <security descriptor> | dacls | <discretionary access control list> | <security descriptor> | Plain
datacenter bit <operating system suite mask> | datacenter bits | <boolean> | <world> | Index<operating system suite mask>Global
date <string> | dates | <date> | <world> | NamedGlobal
date <time zone> of <time> | dates | <date> | <time> | Index<time zone>
date of <bios> | dates | <string> | <bios> | Plain
day | days | <time interval> | <world> | PlainGlobal
day of <day of year> | days | <day of month> | <day of year> | Plain
day_of_month <integer> | days_of_month | <day of month> | <world> | NumberedGlobal
day_of_month <string> | days_of_month | <day of month> | <world> | NamedGlobal
day_of_month of <date> | days_of_month | <day of month> | <date> | Plain
day_of_week <string> | days_of_week | <day of week> | <world> | NamedGlobal
day_of_week of <date> | days_of_week | <day of week> | <date> | Plain
day_of_year of <date> | days_of_year | <day of year> | <date> | Plain
dd <string> of <html> | dds | <html> | <html> | Named
dd <string> of <string> | dds | <html> | <string> | Named
dd of <html> | dds | <html> | <html> | Plain
dd of <string> | dds | <html> | <string> | Plain
december | decembers | <month> | <world> | PlainGlobal
december <integer> | decembers | <day of year> | <world> | NumberedGlobal
december <integer> of <integer> | decembers | <date> | <integer> | Numbered
december of <integer> | decembers | <month and year> | <integer> | Plain
default value of <registry key> | default values | <registry key value> | <registry key> | Plain
default web browser | default web browsers | <application> | <world> | PlainGlobal
definition list <string> of <html> | definition lists | <html> | <html> | Named
definition list <string> of <string> | definition lists | <html> | <string> | Named
definition list of <html> | definition lists | <html> | <html> | Plain
definition list of <string> | definition lists | <html> | <string> | Plain
del <string> of <html> | dels | <html> | <html> | Named
del <string> of <string> | dels | <html> | <string> | Named
del of <html> | dels | <html> | <html> | Plain
del of <string> | dels | <html> | <string> | Plain
delete child permission of <access control entry> | delete child permissions | <boolean> | <access control entry> | Plain
delete permission of <access control entry> | delete permissions | <boolean> | <access control entry> | Plain
delete permission of <network share> | delete permissions | <boolean> | <network share> | Plain
descendant folder of <folder> | descendant folders | <folder> | <folder> | Plain
descendant of <folder> | descendants | <file> | <folder> | Plain
description of <active device> | descriptions | <string> | <active device> | Plain
description of <event log record> | descriptions | <string> | <event log record> | Plain
description of <firewall rule> | descriptions | <string> | <firewall rule> | Plain
description of <network adapter> | descriptions | <string> | <network adapter> | Plain
desired encrypt report of <client_cryptography> | desired encrypt reports | <boolean> | <client_cryptography> | Plain
desired fips mode of <cryptography> | desired fips modes | <boolean> | <cryptography> | Plain
detailed tracking category of <audit policy> | detailed tracking categories | <audit policy category> | <audit policy> | Plain
device key <string> of <registry> | device keys | <registry key> | <registry> | Named
device key of <registry> | device keys | <registry key> | <registry> | Plain
device name of <connection> | device names | <string> | <connection> | Plain
dfn <string> of <html> | dfns | <html> | <html> | Named
dfn <string> of <string> | dfns | <html> | <string> | Named
dfn of <html> | dfns | <html> | <html> | Plain
dfn of <string> | dfns | <html> | <string> | Plain
dhcp enabled of <network adapter> | dhcp enableds | <boolean> | <network adapter> | Plain
dhcp server of <network adapter> | dhcp servers | <ipv4 address> | <network adapter> | Plain
direct object type of <property> | direct object types | <type> | <property> | Plain
disjunction of <boolean> | disjunctions | <boolean> | <boolean> | Plain
display name of <service> | display names | <string> | <service> | Plain
distance of <selected server> | distances | <integer range> | <selected server> | Plain
distinguished name error message of <active directory local computer> | distinguished name error messages | <string> | <active directory local computer> | Plain
distinguished name of <active directory local computer> | distinguished names | <string> | <active directory local computer> | Plain
div <string> of <html> | divs | <html> | <html> | Named
div <string> of <string> | divs | <html> | <string> | Named
div of <html> | divs | <html> | <html> | Plain
div of <string> | divs | <html> | <string> | Plain
divided by zero of <floating point> | divided by zeroes | <boolean> | <floating point> | Plain
dmi | dmis | <dmi> | <world> | PlainGlobal
dns name | dns names | <string> | <world> | PlainGlobal
dns server of <network adapter> | dns servers | <network address list> | <network adapter> | Plain
dns server of <network> | dns servers | <network address list> | <network> | Plain
dns suffix of <network adapter> | dns suffixes | <string> | <network adapter> | Plain
domain firewall profile type | domain firewall profile types | <firewall profile type> | <world> | PlainGlobal
domain name of <security identifier> | domain names | <string> | <security identifier> | Plain
domain profile of <firewall policy> | domain profiles | <firewall profile> | <firewall policy> | Plain
domain user | domain users | <local user> | <world> | PlainGlobal
domain user <string> | domain users | <local user> | <world> | NamedGlobal
download file <string> | download files | <file> | <world> | NamedGlobal
download folder | download folders | <folder> | <world> | PlainGlobal
download path <string> | download paths | <string> | <world> | NamedGlobal
drive <string> | drives | <drive> | <world> | NamedGlobal
drive of <filesystem object> | drives | <drive> | <filesystem object> | Plain
driver key of <active device> | driver keys | <registry key> | <active device> | Plain
driver key of <registry key> | driver keys | <registry key> | <registry key> | Plain
driver key value name of <active device> | driver key value names | <string> | <active device> | Plain
ds access category of <audit policy> | ds access categories | <audit policy category> | <audit policy> | Plain
dt <string> of <html> | dts | <html> | <html> | Named
dt <string> of <string> | dts | <html> | <string> | Named
dt of <html> | dts | <html> | <html> | Plain
dt of <string> | dts | <html> | <string> | Plain
edge traversal allowed of <firewall rule> | edge traversal alloweds | <boolean> | <firewall rule> | Plain
effective access mode for <string> of <access control list> | effective access modes for | <integer> | <access control list> | Named
effective access system security permission for <string> of <access control list> | effective access system security permissions for | <boolean> | <access control list> | Named
effective append permission for <string> of <access control list> | effective append permissions for | <boolean> | <access control list> | Named
effective change notification permission for <string> of <access control list> | effective change notification permissions for | <boolean> | <access control list> | Named
effective create file permission for <string> of <access control list> | effective create file permissions for | <boolean> | <access control list> | Named
effective create folder permission for <string> of <access control list> | effective create folder permissions for | <boolean> | <access control list> | Named
effective create link permission for <string> of <access control list> | effective create link permissions for | <boolean> | <access control list> | Named
effective create subkey permission for <string> of <access control list> | effective create subkey permissions for | <boolean> | <access control list> | Named
effective date of <action lock state> | effective dates | <time> | <action lock state> | Plain
effective date of <setting> | effective dates | <time> | <setting> | Plain
effective delete child permission for <string> of <access control list> | effective delete child permissions for | <boolean> | <access control list> | Named
effective delete permission for <string> of <access control list> | effective delete permissions for | <boolean> | <access control list> | Named
effective enumerate subkeys permission for <string> of <access control list> | effective enumerate subkeys permissions for | <boolean> | <access control list> | Named
effective execute permission for <string> of <access control list> | effective execute permissions for | <boolean> | <access control list> | Named
effective generic all permission for <string> of <access control list> | effective generic all permissions for | <boolean> | <access control list> | Named
effective generic execute permission for <string> of <access control list> | effective generic execute permissions for | <boolean> | <access control list> | Named
effective generic read permission for <string> of <access control list> | effective generic read permissions for | <boolean> | <access control list> | Named
effective generic write permission for <string> of <access control list> | effective generic write permissions for | <boolean> | <access control list> | Named
effective list permission for <string> of <access control list> | effective list permissions for | <boolean> | <access control list> | Named
effective maximum allowed permission for <string> of <access control list> | effective maximum allowed permissions for | <boolean> | <access control list> | Named
effective policy <security account> of <audit policy subcategory> | effective policies | <audit policy information> | <audit policy subcategory> | Index<security account>
effective query value permission for <string> of <access control list> | effective query value permissions for | <boolean> | <access control list> | Named
effective read attributes permission for <string> of <access control list> | effective read attributes permissions for | <boolean> | <access control list> | Named
effective read control permission for <string> of <access control list> | effective read control permissions for | <boolean> | <access control list> | Named
effective read extended attributes permission for <string> of <access control list> | effective read extended attributes permissions for | <boolean> | <access control list> | Named
effective read permission for <string> of <access control list> | effective read permissions for | <boolean> | <access control list> | Named
effective set value permission for <string> of <access control list> | effective set value permissions for | <boolean> | <access control list> | Named
effective synchronize permission for <string> of <access control list> | effective synchronize permissions for | <boolean> | <access control list> | Named
effective traverse permission for <string> of <access control list> | effective traverse permissions for | <boolean> | <access control list> | Named
effective write attributes permission for <string> of <access control list> | effective write attributes permissions for | <boolean> | <access control list> | Named
effective write dac permission for <string> of <access control list> | effective write dac permissions for | <boolean> | <access control list> | Named
effective write extended attributes permission for <string> of <access control list> | effective write extended attributes permissions for | <boolean> | <access control list> | Named
effective write owner permission for <string> of <access control list> | effective write owner permissions for | <boolean> | <access control list> | Named
effective write permission for <string> of <access control list> | effective write permissions for | <boolean> | <access control list> | Named
element of <integer set> | elements | <integer> | <integer set> | Plain
element of <string set> | elements | <string> | <string set> | Plain
em <string> of <html> | ems | <html> | <html> | Named
em <string> of <string> | ems | <html> | <string> | Named
em of <html> | ems | <html> | <html> | Plain
em of <string> | ems | <html> | <string> | Plain
email address of <license> | email addresses | <string> | <license> | Plain
embedded nt bit <operating system suite mask> | embedded nt bits | <boolean> | <world> | Index<operating system suite mask>Global
embedded restricted bit <operating system suite mask> | embedded restricted bits | <boolean> | <world> | Index<operating system suite mask>Global
enabled of <firewall authorized application> | enableds | <boolean> | <firewall authorized application> | Plain
enabled of <firewall open port> | enableds | <boolean> | <firewall open port> | Plain
enabled of <firewall rule> | enableds | <boolean> | <firewall rule> | Plain
enabled of <firewall service> | enableds | <boolean> | <firewall service> | Plain
enabled of <internet connection firewall> | enableds | <boolean> | <internet connection firewall> | Plain
enabled of <port mapping> | enableds | <boolean> | <port mapping> | Plain
enabled of <setting> | enableds | <boolean> | <setting> | Plain
encrypt report failure message of <client_cryptography> | encrypt report failure messages | <string> | <client_cryptography> | Plain
encrypt report of <client_cryptography> | encrypt reports | <boolean> | <client_cryptography> | Plain
encryption certificate of <license> | encryption certificates | <x509 certificate> | <license> | Plain
end of <substring> | ends | <string position> | <substring> | Plain
end of <time range> | ends | <time> | <time range> | Plain
enterprise bit <operating system suite mask> | enterprise bits | <boolean> | <world> | Index<operating system suite mask>Global
entry of <access control list> | entries | <access control entry> | <access control list> | Plain
enumerate subkeys permission of <access control entry> | enumerate subkeys permissions | <boolean> | <access control entry> | Plain
environment | environments | <environment> | <world> | PlainGlobal
error <string> | errors | <undefined> | <world> | NamedGlobal
error event log event type | error event log event types | <event log event type> | <world> | PlainGlobal
escape of <string> | escapes | <string> | <string> | Plain
evaluation of <license> | evaluations | <boolean> | <license> | Plain
event id of <event log record> | event ids | <integer> | <event log record> | Plain
event log <string> | event logs | <event log> | <world> | NamedGlobal
event log event type <integer> | event log event types | <event log event type> | <world> | NumberedGlobal
event type of <event log record> | event types | <event log event type> | <event log record> | Plain
exceptions allowed of <firewall profile> | exceptions alloweds | <boolean> | <firewall profile> | Plain
excluded interface of <firewall profile> | excluded interfaces | <string> | <firewall profile> | Plain
executable file format of <file> | executable file formats | <string> | <file> | Plain
execute permission of <access control entry> | execute permissions | <boolean> | <access control entry> | Plain
execute permission of <network share> | execute permissions | <boolean> | <network share> | Plain
expand environment string of <string> | expand environment strings | <string> | <string> | Plain
expiration date of <action lock state> | expiration dates | <time> | <action lock state> | Plain
expiration date of <license> | expiration dates | <time> | <license> | Plain
expiration state of <license> | expiration states | <string> | <license> | Plain
extended family of <processor> | extended families | <integer> | <processor> | Plain
extended model of <processor> | extended models | <integer> | <processor> | Plain
external port of <port mapping> | external ports | <integer> | <port mapping> | Plain
extrema of <date> | extremas | <( date, date )> | <date> | Plain
extrema of <day of month> | extremas | <( day of month, day of month )> | <day of month> | Plain
extrema of <day of year> | extremas | <( day of year, day of year )> | <day of year> | Plain
extrema of <floating point> | extremas | <( floating point, floating point )> | <floating point> | Plain
extrema of <hertz> | extremas | <( hertz, hertz )> | <hertz> | Plain
extrema of <integer> | extremas | <( integer, integer )> | <integer> | Plain
extrema of <ipv4 address> | extremas | <( ipv4 address, ipv4 address )> | <ipv4 address> | Plain
extrema of <ipv6 address> | extremas | <( ipv6 address, ipv6 address )> | <ipv6 address> | Plain
extrema of <month and year> | extremas | <( month and year, month and year )> | <month and year> | Plain
extrema of <month> | extremas | <( month, month )> | <month> | Plain
extrema of <number of months> | extremas | <( number of months, number of months )> | <number of months> | Plain
extrema of <site version list> | extremas | <( site version list, site version list )> | <site version list> | Plain
extrema of <time interval> | extremas | <( time interval, time interval )> | <time interval> | Plain
extrema of <time of day> | extremas | <( time of day, time of day )> | <time of day> | Plain
extrema of <time> | extremas | <( time, time )> | <time> | Plain
extrema of <version> | extremas | <( version, version )> | <version> | Plain
extrema of <year> | extremas | <( year, year )> | <year> | Plain
false | falses | <boolean> | <world> | PlainGlobal
family name of <processor> | family names | <string> | <processor> | Plain
family of <network interface> | families | <integer> | <network interface> | Plain
family of <processor> | families | <integer> | <processor> | Plain
feature mask of <processor> | feature masks | <integer> | <processor> | Plain
february | februarys | <month> | <world> | PlainGlobal
february <integer> | februarys | <day of year> | <world> | NumberedGlobal
february <integer> of <integer> | februarys | <date> | <integer> | Numbered
february of <integer> | februarys | <month and year> | <integer> | Plain
file <string> | files | <file> | <world> | NamedGlobal
file <string> of <folder> | files | <file> | <folder> | Named
file extension <string> of <registry> | file extensions | <registry key> | <registry> | Named
file of <folder> | files | <file> | <folder> | Plain
file of <service> | files | <file> | <service> | Plain
file system type of <drive> | file system types | <string> | <drive> | Plain
file type <string> of <registry> | file types | <registry key> | <registry> | Named
file version of <file> | file versions | <version> | <file> | Plain
file_and_print firewall service type | file_and_print firewall service types | <firewall service type> | <world> | PlainGlobal
file_supports_encryption of <drive> | file_supports_encryptions | <boolean> | <drive> | Plain
file_supports_object_ids of <drive> | file_supports_object_idss | <boolean> | <drive> | Plain
file_supports_reparse_points of <drive> | file_supports_reparse_pointss | <boolean> | <drive> | Plain
file_supports_sparse_files of <drive> | file_supports_sparse_filess | <boolean> | <drive> | Plain
file_volume_quotas of <drive> | file_volume_quotass | <boolean> | <drive> | Plain
final part <time interval> of <time range> | final parts | <time range> | <time range> | Index<time interval>
find file <string> of <folder> | find files | <file> | <folder> | Named
finite of <floating point> | finites | <boolean> | <floating point> | Plain
fips mode failure message of <cryptography> | fips mode failure messages | <string> | <cryptography> | Plain
fips mode of <cryptography> | fips modes | <boolean> | <cryptography> | Plain
fips mode of <license> | fips modes | <boolean> | <license> | Plain
firewall | firewalls | <firewall> | <world> | PlainGlobal
firewall action <integer> | firewall actions | <firewall action> | <world> | NumberedGlobal
firewall enabled of <firewall profile> | firewalls enabled | <boolean> | <firewall profile> | Plain
firewall local policy modify state <integer> | firewall local policy modify states | <firewall local policy modify state> | <world> | NumberedGlobal
firewall of <connection> | firewalls | <internet connection firewall> | <connection> | Plain
firewall profile type <integer> | firewall profile types | <firewall profile type> | <world> | NumberedGlobal
firewall scope <integer> | firewall scopes | <firewall scope> | <world> | NumberedGlobal
firewall service type <integer> | firewall service types | <firewall service type> | <world> | NumberedGlobal
first <day of week> of <month and year> | firsts | <date> | <month and year> | Index<day of week>
first <integer> of <string> | firsts | <substring> | <string> | Numbered
first <string> of <string> | firsts | <substring> | <string> | Named
first child of <xml dom node> | first children | <xml dom node> | <xml dom node> | Plain
first friday of <month and year> | first fridays | <date> | <month and year> | Plain
first match <regular expression> of <string> | first matches | <regular expression match> | <string> | Index<regular expression>
first monday of <month and year> | first mondays | <date> | <month and year> | Plain
first raw version block of <file> | first raw version blocks | <file version block> | <file> | Plain
first saturday of <month and year> | first saturdays | <date> | <month and year> | Plain
first start time of <application usage summary> | first start times | <time> | <application usage summary> | Plain
first sunday of <month and year> | first sundays | <date> | <month and year> | Plain
first thursday of <month and year> | first thursdays | <date> | <month and year> | Plain
first tuesday of <month and year> | first tuesdays | <date> | <month and year> | Plain
first wednesday of <month and year> | first wednesdays | <date> | <month and year> | Plain
fixlet of <site> | fixlets | <fixlet> | <site> | Plain
floating point <floating point> | floating points | <floating point> | <world> | Index<floating point>Global
floating point <string> | floating points | <floating point> | <world> | NamedGlobal
folder <string> | folders | <folder> | <world> | NamedGlobal
folder <string> of <drive> | folders | <folder> | <drive> | Named
folder <string> of <folder> | folders | <folder> | <folder> | Named
folder of <folder> | folders | <folder> | <folder> | Plain
following text of <string position> | following texts | <substring> | <string position> | Plain
following text of <substring> | following texts | <substring> | <substring> | Plain
force logoff interval of <security database> | force logoff intervals | <time interval> | <security database> | Plain
free space of <drive> | free spaces | <integer> | <drive> | Plain
friday | fridays | <day of week> | <world> | PlainGlobal
friendly name of <active device> | friendly names | <string> | <active device> | Plain
friendly name of <network adapter> | friendly names | <string> | <network adapter> | Plain
fs_case_is_preserved of <drive> | fs_case_is_preserveds | <boolean> | <drive> | Plain
fs_case_sensitive of <drive> | fs_case_sensitives | <boolean> | <drive> | Plain
fs_file_compression of <drive> | fs_file_compressions | <boolean> | <drive> | Plain
fs_persistent_acls of <drive> | fs_persistent_aclss | <boolean> | <drive> | Plain
fs_unicode_stored_on_disk of <drive> | fs_unicode_stored_on_disks | <boolean> | <drive> | Plain
fs_vol_is_compressed of <drive> | fs_vol_is_compresseds | <boolean> | <drive> | Plain
full name of <local user> | full names | <string> | <local user> | Plain
full wmi <string> | full wmis | <wmi> | <world> | NamedGlobal
gateway address <integer> of <selected server> | gateway addresses | <ipv4 address> | <selected server> | Numbered
gateway address of <selected server> | gateway addresses | <ipv4 address> | <selected server> | Plain
gateway list of <network adapter> | gateway lists | <network address list> | <network adapter> | Plain
gateway of <network adapter> | gateways | <ipv4 address> | <network adapter> | Plain
gather schedule authority of <site> | gather schedule authoritys | <string> | <site> | Plain
gather schedule time interval of <site> | gather schedule time intervals | <time interval> | <site> | Plain
gather url of <license> | gather urls | <string> | <license> | Plain
generic all permission of <access control entry> | generic all permissions | <boolean> | <access control entry> | Plain
generic execute permission of <access control entry> | generic execute permissions | <boolean> | <access control entry> | Plain
generic read permission of <access control entry> | generic read permissions | <boolean> | <access control entry> | Plain
generic write permission of <access control entry> | generic write permissions | <boolean> | <access control entry> | Plain
ghz | ghzs | <hertz> | <world> | PlainGlobal
globally open port of <firewall profile> | globally open ports | <firewall open port> | <firewall profile> | Plain
globally open port of <firewall service> | globally open ports | <firewall open port> | <firewall service> | Plain
gp override firewall local policy modify state | gp override firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
greatest hz | greatest hzs | <hertz> | <world> | PlainGlobal
greatest integer | greatest integers | <integer> | <world> | PlainGlobal
greatest time interval | greatest time intervals | <time interval> | <world> | PlainGlobal
group <integer> of <site> | groups | <site group> | <site> | Numbered
group leader of <action> | group leaders | <boolean> | <action> | Plain
group of <security descriptor> | groups | <security identifier> | <security descriptor> | Plain
grouping of <firewall rule> | groupings | <string> | <firewall rule> | Plain
guest privilege of <local user> | guest privileges | <boolean> | <local user> | Plain
guid of <connection> | guids | <string> | <connection> | Plain
h1 <string> of <html> | h1s | <html> | <html> | Named
h1 <string> of <string> | h1s | <html> | <string> | Named
h1 of <html> | h1s | <html> | <html> | Plain
h1 of <string> | h1s | <html> | <string> | Plain
h2 <string> of <html> | h2s | <html> | <html> | Named
h2 <string> of <string> | h2s | <html> | <string> | Named
h2 of <html> | h2s | <html> | <html> | Plain
h2 of <string> | h2s | <html> | <string> | Plain
h3 <string> of <html> | h3s | <html> | <html> | Named
h3 <string> of <string> | h3s | <html> | <string> | Named
h3 of <html> | h3s | <html> | <html> | Plain
h3 of <string> | h3s | <html> | <string> | Plain
h4 <string> of <html> | h4s | <html> | <html> | Named
h4 <string> of <string> | h4s | <html> | <string> | Named
h4 of <html> | h4s | <html> | <html> | Plain
h4 of <string> | h4s | <html> | <string> | Plain
h5 <string> of <html> | h5s | <html> | <html> | Named
h5 <string> of <string> | h5s | <html> | <string> | Named
h5 of <html> | h5s | <html> | <html> | Plain
h5 of <string> | h5s | <html> | <string> | Plain
h6 <string> of <html> | h6s | <html> | <html> | Named
h6 <string> of <string> | h6s | <html> | <string> | Named
h6 of <html> | h6s | <html> | <html> | Plain
h6 of <string> | h6s | <html> | <string> | Plain
hardware id of <active device> | hardware ids | <string> | <active device> | Plain
has blank sa password of <local mssql database> | has blank sa passwords | <boolean> | <local mssql database> | Plain
head <string> of <html> | heads | <html> | <html> | Named
head <string> of <string> | heads | <html> | <string> | Named
head of <html> | heads | <html> | <html> | Plain
head of <string> | heads | <html> | <string> | Plain
header <string> of <fixlet> | headers | <fixlet_header> | <fixlet> | Named
header of <fixlet> | headers | <fixlet_header> | <fixlet> | Plain
hexadecet <integer> of <ipv6 address> | hexadecets | <integer> | <ipv6 address> | Numbered
hexadecimal integer <string> | hexadecimal integers | <integer> | <world> | NamedGlobal
hexadecimal string <string> | hexadecimal strings | <string> | <world> | NamedGlobal
hidden of <filesystem object> | hiddens | <boolean> | <filesystem object> | Plain
home directory drive of <local user> | home directory drives | <string> | <local user> | Plain
home directory of <local user> | home directories | <string> | <local user> | Plain
home directory required flag of <local user> | home directory required flags | <boolean> | <local user> | Plain
host name of <root server> | host names | <string> | <root server> | Plain
hostname | hostnames | <string> | <world> | PlainGlobal
hour | hours | <time interval> | <world> | PlainGlobal
hour_of_day of <time of day with time zone> | hours_of_day | <integer> | <time of day with time zone> | Plain
hour_of_day of <time of day> | hours_of_day | <integer> | <time of day> | Plain
hr | hrs | <html> | <world> | PlainGlobal
hr <string> | hrs | <html> | <world> | NamedGlobal
html <string> | htmls | <html> | <world> | NamedGlobal
html <string> of <html> | htmls | <html> | <html> | Named
html <string> of <string> | htmls | <html> | <string> | Named
html concatenation <string> of <html> | html concatenations | <html> | <html> | Named
html concatenation of <html> | html concatenations | <html> | <html> | Plain
html of <html> | htmls | <html> | <html> | Plain
html of <string> | htmls | <html> | <string> | Plain
html tag <( string, html )> | html tags | <html> | <world> | Index<( string, html )>Global
html tag <( string, html attribute list, html )> | html tags | <html> | <world> | Index<( string, html attribute list, html )>Global
html tag <( string, html attribute list, string )> | html tags | <html> | <world> | Index<( string, html attribute list, string )>Global
html tag <( string, string )> | html tags | <html> | <world> | Index<( string, string )>Global
html tag <string> of <html> | html tags | <html> | <html> | Named
html tag <string> of <string> | html tags | <html> | <string> | Named
hyperthreading capable | hyperthreading capables | <boolean> | <world> | PlainGlobal
hyperthreading enabled | hyperthreading enableds | <boolean> | <world> | PlainGlobal
hz | hzs | <hertz> | <world> | PlainGlobal
ia64 of <operating system> | ia64s | <boolean> | <operating system> | Plain
icmp settings of <firewall profile> | icmp settingses | <firewall icmp settings> | <firewall profile> | Plain
icmp types_and_codes string of <firewall rule> | icmp types_and_codes strings | <string> | <firewall rule> | Plain
icon index of <file shortcut> | icon indexes | <integer> | <file shortcut> | Plain
icon pathname of <file shortcut> | icon pathnames | <string> | <file shortcut> | Plain
id of <action> | ids | <integer> | <action> | Plain
id of <file version block> | ids | <string> | <file version block> | Plain
id of <fixlet> | ids | <integer> | <fixlet> | Plain
id of <root server> | ids | <integer> | <root server> | Plain
id of <site group> | ids | <integer> | <site group> | Plain
identifier of <metabase value> | identifiers | <metabase identifier> | <metabase value> | Plain
image path of <service> | image paths | <string> | <service> | Plain
inbound blocked firewall local policy modify state | inbound blocked firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
inbound connections allowed of <firewall profile> | inbound connections alloweds | <boolean> | <firewall profile> | Plain
inbound of <firewall rule> | inbounds | <boolean> | <firewall rule> | Plain
index type of <property> | index types | <type> | <property> | Plain
inexact of <floating point> | inexacts | <boolean> | <floating point> | Plain
infinite of <floating point> | infinites | <boolean> | <floating point> | Plain
information event log event type | information event log event types | <event log event type> | <world> | PlainGlobal
inherit attribute of <metabase value> | inherit attributes | <boolean> | <metabase value> | Plain
inheritance of <access control entry> | inheritances | <integer> | <access control entry> | Plain
initial part <time interval> of <time range> | initial parts | <time range> | <time range> | Index<time interval>
ins <string> of <html> | inss | <html> | <html> | Named
ins <string> of <string> | inss | <html> | <string> | Named
ins of <html> | inss | <html> | <html> | Plain
ins of <string> | inss | <html> | <string> | Plain
insert path attribute of <metabase value> | insert path attributes | <boolean> | <metabase value> | Plain
install folder <integer> | install folders | <folder> | <world> | NumberedGlobal
instance name of <local mssql database> | instance names | <string> | <local mssql database> | Plain
integer <integer> | integers | <integer> | <world> | NumberedGlobal
integer <string> | integers | <integer> | <world> | NamedGlobal
integer ceiling of <floating point> | integer ceilings | <integer> | <floating point> | Plain
integer floor of <floating point> | integer floors | <integer> | <floating point> | Plain
integer value <integer> of <wmi select> | integer values | <integer> | <wmi select> | Numbered
integer value of <wmi select> | integer values | <integer> | <wmi select> | Plain
interdomain trust account flag of <local user> | interdomain trust account flags | <boolean> | <local user> | Plain
interface <integer> of <network> | interfaces | <network interface> | <network> | Numbered
interface of <firewall rule> | interfaces | <string> | <firewall rule> | Plain
interface of <network> | interfaces | <network interface> | <network> | Plain
interface types string of <firewall rule> | interface types strings | <string> | <firewall rule> | Plain
internal port of <port mapping> | internal ports | <integer> | <port mapping> | Plain
internet connection firewall of <network adapter> | internet connection firewalls | <internet connection firewall> | <network adapter> | Plain
internet protocol <integer> | internet protocols | <internet protocol> | <world> | NumberedGlobal
intersection of <integer set> | intersections | <integer set> | <integer set> | Plain
intersection of <string set> | intersections | <string set> | <string set> | Plain
invalid before of <x509 certificate> | invalid befores | <time> | <x509 certificate> | Plain
invalid of <floating point> | invalids | <boolean> | <floating point> | Plain
ip address of <selected server> | ip addresses | <ipv4 address> | <selected server> | Plain
ip interface <integer> of <network> | ip interfaces | <network ip interface> | <network> | Numbered
ip interface of <network> | ip interfaces | <network ip interface> | <network> | Plain
ip version <integer> | ip versions | <ip version> | <world> | NumberedGlobal
ip version of <firewall authorized application> | ip versions | <ip version> | <firewall authorized application> | Plain
ip version of <firewall open port> | ip versions | <ip version> | <firewall open port> | Plain
ip version of <firewall service> | ip versions | <ip version> | <firewall service> | Plain
ipv4 | ipv4s | <ip version> | <world> | PlainGlobal
ipv4 address <string> | ipv4 addresses | <ipv4 address> | <world> | NamedGlobal
ipv4 part of <ipv6 address> | ipv4 parts | <ipv4 address> | <ipv6 address> | Plain
ipv6 | ipv6s | <ip version> | <world> | PlainGlobal
ipv6 address <string> | ipv6 addresses | <ipv6 address> | <world> | NamedGlobal
ipv6 address of <network adapter> | ipv6 addresses | <ipv6 address> | <network adapter> | Plain
ipv6 dns server of <network adapter> | ipv6 dns servers | <ipv6 address> | <network adapter> | Plain
italic <string> of <html> | italics | <html> | <html> | Named
italic <string> of <string> | italics | <html> | <string> | Named
italic of <html> | italics | <html> | <html> | Plain
italic of <string> | italics | <html> | <string> | Plain
january | januarys | <month> | <world> | PlainGlobal
january <integer> | januarys | <day of year> | <world> | NumberedGlobal
january <integer> of <integer> | januarys | <date> | <integer> | Numbered
january of <integer> | januarys | <month and year> | <integer> | Plain
july | julys | <month> | <world> | PlainGlobal
july <integer> | julys | <day of year> | <world> | NumberedGlobal
july <integer> of <integer> | julys | <date> | <integer> | Numbered
july of <integer> | julys | <month and year> | <integer> | Plain
june | junes | <month> | <world> | PlainGlobal
june <integer> | junes | <day of year> | <world> | NumberedGlobal
june <integer> of <integer> | junes | <date> | <integer> | Numbered
june of <integer> | junes | <month and year> | <integer> | Plain
kbd <string> of <html> | kbds | <html> | <html> | Named
kbd <string> of <string> | kbds | <html> | <string> | Named
kbd of <html> | kbds | <html> | <html> | Plain
kbd of <string> | kbds | <html> | <string> | Plain
key <string> of <file section> | keys | <string> | <file section> | Named
key <string> of <file> | keys | <string> | <file> | Named
key <string> of <metabase key> | keys | <metabase key> | <metabase key> | Named
key <string> of <metabase> | keys | <metabase key> | <metabase> | Named
key <string> of <registry key> | keys | <registry key> | <registry key> | Named
key <string> of <registry> | keys | <registry key> | <registry> | Named
key of <metabase key> | keys | <metabase key> | <metabase key> | Plain
key of <metabase> | keys | <metabase key> | <metabase> | Plain
key of <registry key> | keys | <registry key> | <registry key> | Plain
khz | khzs | <hertz> | <world> | PlainGlobal
language of <file version block> | languages | <string> | <file version block> | Plain
last <integer> of <string> | lasts | <substring> | <string> | Numbered
last <string> of <string> | lasts | <substring> | <string> | Named
last change time of <action> | last change times | <time> | <action> | Plain
last child of <xml dom node> | last children | <xml dom node> | <xml dom node> | Plain
last gather time of <site> | last gather times | <time> | <site> | Plain
last logoff of <local user> | last logoffs | <time> | <local user> | Plain
last logon of <local user> | last logons | <time> | <local user> | Plain
last start time of <application usage summary> | last start times | <time> | <application usage summary> | Plain
last time seen of <application usage summary> | last times seen | <time> | <application usage summary> | Plain
leap of <year> | leaps | <boolean> | <year> | Plain
lease expires of <network adapter> | leases expire | <time> | <network adapter> | Plain
lease obtained of <network adapter> | leases obtained | <time> | <network adapter> | Plain
least hz | least hzs | <hertz> | <world> | PlainGlobal
least integer | least integers | <integer> | <world> | PlainGlobal
least significant one bit of <bit set> | least significant one bits | <integer> | <bit set> | Plain
least time interval | least time intervals | <time interval> | <world> | PlainGlobal
left operand type of <binary operator> | left operand types | <type> | <binary operator> | Plain
left shift <integer> of <bit set> | left shifts | <bit set> | <bit set> | Numbered
length of <event log record> | lengths | <integer> | <event log record> | Plain
length of <month and year> | lengths | <time interval> | <month and year> | Plain
length of <rope> | lengths | <integer> | <rope> | Plain
length of <string> | lengths | <integer> | <string> | Plain
length of <time range> | lengths | <time interval> | <time range> | Plain
length of <year> | lengths | <time interval> | <year> | Plain
less significance <integer> of <floating point> | less significances | <floating point> | <floating point> | Numbered
li <string> of <html> | lis | <html> | <html> | Named
li <string> of <string> | lis | <html> | <string> | Named
li of <html> | lis | <html> | <html> | Plain
li of <string> | lis | <html> | <string> | Plain
line <integer> of <file> | lines | <file line> | <file> | Numbered
line containing <string> of <file> | lines containing | <file line> | <file> | Named
line number of <file line> | line numbers | <integer> | <file line> | Plain
line of <file> | lines | <file line> | <file> | Plain
line starting with <string> of <file> | lines starting with | <file line> | <file> | Named
link <string> of <html> | links | <html> | <html> | Named
link <string> of <string> | links | <html> | <string> | Named
link of <html> | links | <html> | <html> | Plain
link of <string> | links | <html> | <string> | Plain
link speed of <network adapter> | link speeds | <integer> | <network adapter> | Plain
list permission of <access control entry> | list permissions | <boolean> | <access control entry> | Plain
local addresses string of <firewall rule> | local addresses strings | <string> | <firewall rule> | Plain
local administrator | local administrators | <boolean> | <world> | PlainGlobal
local computer of <active directory server> | local computers | <active directory local computer> | <active directory server> | Plain
local group | local groups | <local group> | <world> | PlainGlobal
local group <string> | local groups | <local group> | <world> | NamedGlobal
local mssql database | local mssql databases | <local mssql database> | <world> | PlainGlobal
local mssql database <string> | local mssql databases | <local mssql database> | <world> | NamedGlobal
local policy modify state of <firewall> | local policy modify states | <firewall local policy modify state> | <firewall> | Plain
local policy of <firewall> | local policies | <firewall policy> | <firewall> | Plain
local ports string of <firewall rule> | local ports strings | <string> | <firewall rule> | Plain
local subnet firewall scope | local subnet firewall scopes | <firewall scope> | <world> | PlainGlobal
local time <string> | local times | <time> | <world> | NamedGlobal
local time zone | local time zones | <time zone> | <world> | PlainGlobal
local user | local users | <local user> | <world> | PlainGlobal
local user <string> | local users | <local user> | <world> | NamedGlobal
location information of <active device> | location informations | <string> | <active device> | Plain
location of <filesystem object> | locations | <string> | <filesystem object> | Plain
lock string of <action lock state> | lock strings | <string> | <action lock state> | Plain
locked of <action lock state> | lockeds | <boolean> | <action lock state> | Plain
locked out flag of <local user> | locked out flags | <boolean> | <local user> | Plain
logged on user | logged on users | <logged on user> | <world> | PlainGlobal
logical processor count | logical processor counts | <integer> | <world> | PlainGlobal
login account of <service> | login accounts | <string> | <service> | Plain
login mode of <local mssql database> | login modes | <integer> | <local mssql database> | Plain
logon count of <local user> | logon counts | <integer> | <local user> | Plain
logon logoff category of <audit policy> | logon logoff categories | <audit policy category> | <audit policy> | Plain
logon script of <local user> | logon scripts | <string> | <local user> | Plain
logon server of <local user> | logon servers | <string> | <local user> | Plain
loopback of <network ip interface> | loopbacks | <boolean> | <network ip interface> | Plain
lower bound of <integer range> | lower bounds | <integer> | <integer range> | Plain
mac address of <network adapter> | mac addresses | <string> | <network adapter> | Plain
main gather service | main gather services | <service> | <world> | PlainGlobal
main processor | main processors | <processor> | <world> | PlainGlobal
major version of <operating system> | major versions | <integer> | <operating system> | Plain
manufacturer of <active device> | manufacturers | <string> | <active device> | Plain
march | marchs | <month> | <world> | PlainGlobal
march <integer> | marchs | <day of year> | <world> | NumberedGlobal
march <integer> of <integer> | marchs | <date> | <integer> | Numbered
march of <integer> | marchs | <month and year> | <integer> | Plain
masthead of <site> | mastheads | <file> | <site> | Plain
match <regular expression> of <string> | matches | <regular expression match> | <string> | Index<regular expression>
maximum allowed permission of <access control entry> | maximum allowed permissions | <boolean> | <access control entry> | Plain
maximum of <date> | maxima | <date> | <date> | Plain
maximum of <day of month> | maxima | <day of month> | <day of month> | Plain
maximum of <day of year> | maxima | <day of year> | <day of year> | Plain
maximum of <floating point> | maxima | <floating point> | <floating point> | Plain
maximum of <hertz> | maxima | <hertz> | <hertz> | Plain
maximum of <integer> | maxima | <integer> | <integer> | Plain
maximum of <ipv4 address> | maxima | <ipv4 address> | <ipv4 address> | Plain
maximum of <ipv6 address> | maxima | <ipv6 address> | <ipv6 address> | Plain
maximum of <month and year> | maxima | <month and year> | <month and year> | Plain
maximum of <month> | maxima | <month> | <month> | Plain
maximum of <number of months> | maxima | <number of months> | <number of months> | Plain
maximum of <site version list> | maxima | <site version list> | <site version list> | Plain
maximum of <time interval> | maxima | <time interval> | <time interval> | Plain
maximum of <time of day> | maxima | <time of day> | <time of day> | Plain
maximum of <time> | maxima | <time> | <time> | Plain
maximum of <version> | maxima | <version> | <version> | Plain
maximum of <year> | maxima | <year> | <year> | Plain
maximum password age of <security database> | maximum password ages | <time interval> | <security database> | Plain
maximum seat count of <license> | maximum seat counts | <integer> | <license> | Plain
maximum storage of <local user> | maximum storages | <integer> | <local user> | Plain
maximum transmission unit of <network adapter> | maximum transmission units | <integer> | <network adapter> | Plain
may | mays | <month> | <world> | PlainGlobal
may <integer> | mays | <day of year> | <world> | NumberedGlobal
may <integer> of <integer> | mays | <date> | <integer> | Numbered
may of <integer> | mays | <month and year> | <integer> | Plain
mean of <floating point> | means | <floating point> | <floating point> | Plain
mean of <integer> | means | <floating point> | <integer> | Plain
media type <integer> | media types | <media type> | <world> | NumberedGlobal
media type bridge | media types bridge | <media type> | <world> | PlainGlobal
media type direct | media types direct | <media type> | <world> | PlainGlobal
media type isdn | media types isdn | <media type> | <world> | PlainGlobal
media type lan | media types lans | <media type> | <world> | PlainGlobal
media type of <connection> | media types | <media type> | <connection> | Plain
media type phone | media types phone | <media type> | <world> | PlainGlobal
media type pppoe | media types pppoe | <media type> | <world> | PlainGlobal
media type shared access host lan | media types shared access host lan | <media type> | <world> | PlainGlobal
media type shared access host ras | media types shared access host ras | <media type> | <world> | PlainGlobal
media type tunnel | media types tunnel | <media type> | <world> | PlainGlobal
member of <local group> | members | <local group member> | <local group> | Plain
member of <site group> | members | <boolean> | <site group> | Plain
meta <string> of <html> | metas | <html> | <html> | Named
meta <string> of <string> | metas | <html> | <string> | Named
meta of <html> | metas | <html> | <html> | Plain
meta of <string> | metas | <html> | <string> | Plain
metabase | metabases | <metabase> | <world> | PlainGlobal
metric <integer> of <operating system> | metrics | <integer> | <operating system> | Numbered
mhz | mhzs | <hertz> | <world> | PlainGlobal
microsecond | microseconds | <time interval> | <world> | PlainGlobal
midnight | midnights | <time of day> | <world> | PlainGlobal
millisecond | milliseconds | <time interval> | <world> | PlainGlobal
minimum of <date> | minima | <date> | <date> | Plain
minimum of <day of month> | minima | <day of month> | <day of month> | Plain
minimum of <day of year> | minima | <day of year> | <day of year> | Plain
minimum of <floating point> | minima | <floating point> | <floating point> | Plain
minimum of <hertz> | minima | <hertz> | <hertz> | Plain
minimum of <integer> | minima | <integer> | <integer> | Plain
minimum of <ipv4 address> | minima | <ipv4 address> | <ipv4 address> | Plain
minimum of <ipv6 address> | minima | <ipv6 address> | <ipv6 address> | Plain
minimum of <month and year> | minima | <month and year> | <month and year> | Plain
minimum of <month> | minima | <month> | <month> | Plain
minimum of <number of months> | minima | <number of months> | <number of months> | Plain
minimum of <site version list> | minima | <site version list> | <site version list> | Plain
minimum of <time interval> | minima | <time interval> | <time interval> | Plain
minimum of <time of day> | minima | <time of day> | <time of day> | Plain
minimum of <time> | minima | <time> | <time> | Plain
minimum of <version> | minima | <version> | <version> | Plain
minimum of <year> | minima | <year> | <year> | Plain
minimum password age of <security database> | minimum password ages | <time interval> | <security database> | Plain
minimum password length of <security database> | minimum password lengths | <integer> | <security database> | Plain
minor version of <operating system> | minor versions | <integer> | <operating system> | Plain
minute | minutes | <time interval> | <world> | PlainGlobal
minute_of_hour of <time of day with time zone> | minutes_of_hour | <integer> | <time of day with time zone> | Plain
minute_of_hour of <time of day> | minutes_of_hour | <integer> | <time of day> | Plain
model of <processor> | models | <integer> | <processor> | Plain
modification time of <filesystem object> | modification times | <time> | <filesystem object> | Plain
module <string> | modules | <module> | <world> | NamedGlobal
monday | mondays | <day of week> | <world> | PlainGlobal
month | months | <number of months> | <world> | PlainGlobal
month <integer> | months | <month> | <world> | NumberedGlobal
month <string> | months | <month> | <world> | NamedGlobal
month of <date> | months | <month> | <date> | Plain
month of <day of year> | months | <month> | <day of year> | Plain
month of <month and year> | months | <month> | <month and year> | Plain
month_and_year of <date> | months_and_years | <month and year> | <date> | Plain
more significance <integer> of <floating point> | more significances | <floating point> | <floating point> | Numbered
most significant one bit of <bit set> | most significant one bits | <integer> | <bit set> | Plain
multicast support of <network ip interface> | multicast supports | <boolean> | <network ip interface> | Plain
multiplicity of <date with multiplicity> | multiplicities | <integer> | <date with multiplicity> | Plain
multiplicity of <day of month with multiplicity> | multiplicities | <integer> | <day of month with multiplicity> | Plain
multiplicity of <day of week with multiplicity> | multiplicities | <integer> | <day of week with multiplicity> | Plain
multiplicity of <day of year with multiplicity> | multiplicities | <integer> | <day of year with multiplicity> | Plain
multiplicity of <floating point with multiplicity> | multiplicities | <integer> | <floating point with multiplicity> | Plain
multiplicity of <hertz with multiplicity> | multiplicities | <integer> | <hertz with multiplicity> | Plain
multiplicity of <integer with multiplicity> | multiplicities | <integer> | <integer with multiplicity> | Plain
multiplicity of <ipv4 address with multiplicity> | multiplicities | <integer> | <ipv4 address with multiplicity> | Plain
multiplicity of <ipv6 address with multiplicity> | multiplicities | <integer> | <ipv6 address with multiplicity> | Plain
multiplicity of <month and year with multiplicity> | multiplicities | <integer> | <month and year with multiplicity> | Plain
multiplicity of <month with multiplicity> | multiplicities | <integer> | <month with multiplicity> | Plain
multiplicity of <number of months with multiplicity> | multiplicities | <integer> | <number of months with multiplicity> | Plain
multiplicity of <site version list with multiplicity> | multiplicities | <integer> | <site version list with multiplicity> | Plain
multiplicity of <string with multiplicity> | multiplicities | <integer> | <string with multiplicity> | Plain
multiplicity of <time interval with multiplicity> | multiplicities | <integer> | <time interval with multiplicity> | Plain
multiplicity of <time of day with multiplicity> | multiplicities | <integer> | <time of day with multiplicity> | Plain
multiplicity of <time of day with time zone with multiplicity> | multiplicities | <integer> | <time of day with time zone with multiplicity> | Plain
multiplicity of <time range with multiplicity> | multiplicities | <integer> | <time range with multiplicity> | Plain
multiplicity of <time with multiplicity> | multiplicities | <integer> | <time with multiplicity> | Plain
multiplicity of <time zone with multiplicity> | multiplicities | <integer> | <time zone with multiplicity> | Plain
multiplicity of <version with multiplicity> | multiplicities | <integer> | <version with multiplicity> | Plain
multiplicity of <year with multiplicity> | multiplicities | <integer> | <year with multiplicity> | Plain
multivalued of <property> | multivalueds | <boolean> | <property> | Plain
name of <application usage summary> | names | <string> | <application usage summary> | Plain
name of <audit policy category> | names | <string> | <audit policy category> | Plain
name of <audit policy subcategory> | names | <string> | <audit policy subcategory> | Plain
name of <binary operator> | names | <string> | <binary operator> | Plain
name of <cast> | names | <string> | <cast> | Plain
name of <connection> | names | <string> | <connection> | Plain
name of <drive> | names | <string> | <drive> | Plain
name of <environment variable> | names | <string> | <environment variable> | Plain
name of <filesystem object> | names | <string> | <filesystem object> | Plain
name of <firewall authorized application> | names | <string> | <firewall authorized application> | Plain
name of <firewall open port> | names | <string> | <firewall open port> | Plain
name of <firewall rule> | names | <string> | <firewall rule> | Plain
name of <firewall service> | names | <string> | <firewall service> | Plain
name of <fixlet_header> | names | <string> | <fixlet_header> | Plain
name of <local group> | names | <string> | <local group> | Plain
name of <local user> | names | <string> | <local user> | Plain
name of <logged on user> | names | <string> | <logged on user> | Plain
name of <metabase key> | names | <string> | <metabase key> | Plain
name of <network adapter> | names | <string> | <network adapter> | Plain
name of <network share> | names | <string> | <network share> | Plain
name of <operating system> | names | <string> | <operating system> | Plain
name of <port mapping> | names | <string> | <port mapping> | Plain
name of <registry key value> | names | <string> | <registry key value> | Plain
name of <registry key> | names | <string> | <registry key> | Plain
name of <selected server> | names | <string> | <selected server> | Plain
name of <setting> | names | <string> | <setting> | Plain
name of <site> | names | <string> | <site> | Plain
name of <type> | names | <string> | <type> | Plain
name of <unary operator> | names | <string> | <unary operator> | Plain
name of <wmi select> | names | <string> | <wmi select> | Plain
nan of <floating point> | nans | <boolean> | <floating point> | Plain
native registry | native registries | <registry> | <world> | PlainGlobal
network | networks | <network> | <world> | PlainGlobal
network share | network shares | <network share> | <world> | PlainGlobal
network share <string> | network shares | <network share> | <world> | NamedGlobal
next line of <file line> | next lines | <file line> | <file line> | Plain
next sibling of <xml dom node> | next siblings | <xml dom node> | <xml dom node> | Plain
no password required flag of <local user> | no password required flags | <boolean> | <local user> | Plain
node name of <xml dom node> | node names | <string> | <xml dom node> | Plain
node type of <xml dom node> | node types | <integer> | <xml dom node> | Plain
node value of <xml dom node> | node values | <string> | <xml dom node> | Plain
none firewall service type | none firewall service types | <firewall service type> | <world> | PlainGlobal
noon | noons | <time of day> | <world> | PlainGlobal
normal account flag of <local user> | normal account flags | <boolean> | <local user> | Plain
normal of <filesystem object> | normals | <boolean> | <filesystem object> | Plain
normal of <floating point> | normals | <boolean> | <floating point> | Plain
notifications disabled of <firewall profile> | notifications disableds | <boolean> | <firewall profile> | Plain
november | novembers | <month> | <world> | PlainGlobal
november <integer> | novembers | <day of year> | <world> | NumberedGlobal
november <integer> of <integer> | novembers | <date> | <integer> | Numbered
november of <integer> | novembers | <month and year> | <integer> | Plain
now | nows | <time> | <world> | PlainGlobal
nt domain controller product type | nt domain controller product types | <operating system product type> | <world> | PlainGlobal
nt server product type | nt server product types | <operating system product type> | <world> | PlainGlobal
nt workstation product type | nt workstation product types | <operating system product type> | <world> | PlainGlobal
numeric type of <drive> | numeric types | <integer> | <drive> | Plain
numeric value of <string> | numeric values | <integer> | <string> | Plain
object access category of <audit policy> | object access categories | <audit policy category> | <audit policy> | Plain
october | octobers | <month> | <world> | PlainGlobal
october <integer> | octobers | <day of year> | <world> | NumberedGlobal
october <integer> of <integer> | octobers | <date> | <integer> | Numbered
october of <integer> | octobers | <month and year> | <integer> | Plain
oem code page | oem code pages | <integer> | <world> | PlainGlobal
offer accepted of <action> | offer accepteds | <boolean> | <action> | Plain
offer of <action> | offers | <boolean> | <action> | Plain
offline of <filesystem object> | offlines | <boolean> | <filesystem object> | Plain
ok firewall local policy modify state | ok firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
ol <string> of <html> | ols | <html> | <html> | Named
ol <string> of <string> | ols | <html> | <string> | Named
ol of <html> | ols | <html> | <html> | Plain
ol of <string> | ols | <html> | <string> | Plain
oldest record number of <event log> | oldest record numbers | <integer> | <event log> | Plain
one bit of <bit set> | one bits | <integer> | <bit set> | Plain
only raw version block of <file> | only raw version blocks | <file version block> | <file> | Plain
only version block of <file> | only version blocks | <file version block> | <file> | Plain
operand type of <cast> | operand types | <type> | <cast> | Plain
operand type of <unary operator> | operand types | <type> | <unary operator> | Plain
operating system | operating systems | <operating system> | <world> | PlainGlobal
operating system product type <integer> | operating system product types | <operating system product type> | <world> | NumberedGlobal
options of <port mapping> | optionss | <integer> | <port mapping> | Plain
ordered list <string> of <html> | ordered lists | <html> | <html> | Named
ordered list <string> of <string> | ordered lists | <html> | <string> | Named
ordered list of <html> | ordered lists | <html> | <html> | Plain
ordered list of <string> | ordered lists | <html> | <string> | Plain
organization of <license> | organizations | <string> | <license> | Plain
origin fixlet id of <action> | origin fixlet ids | <integer> | <action> | Plain
outbound connections allowed of <firewall profile> | outbound connections alloweds | <boolean> | <firewall profile> | Plain
outbound of <firewall rule> | outbounds | <boolean> | <firewall rule> | Plain
overflow of <floating point> | overflows | <boolean> | <floating point> | Plain
owner document of <xml dom node> | owner documents | <xml dom document> | <xml dom node> | Plain
owner of <security descriptor> | owners | <security identifier> | <security descriptor> | Plain
p <string> of <html> | ps | <html> | <html> | Named
p <string> of <string> | ps | <html> | <string> | Named
p of <html> | ps | <html> | <html> | Plain
p of <string> | ps | <html> | <string> | Plain
pad of <version> | pads | <version> | <version> | Plain
parameter <string> | parameters | <string> | <world> | NamedGlobal
parameter <string> of <action> | parameters | <string> | <action> | Named
parent folder of <filesystem object> | parent folders | <folder> | <filesystem object> | Plain
parent node of <xml dom node> | parent nodes | <xml dom node> | <xml dom node> | Plain
parent of <type> | parents | <type> | <type> | Plain
parenthesized part <integer> of <regular expression match> | parenthesized parts | <substring> | <regular expression match> | Numbered
parenthesized part of <regular expression match> | parenthesized parts | <substring> | <regular expression match> | Plain
password age of <local user> | password ages | <time interval> | <local user> | Plain
password change disabled flag of <local user> | password change disabled flags | <boolean> | <local user> | Plain
password expiration disabled flag of <local user> | password expiration disabled flags | <boolean> | <local user> | Plain
password expired of <local user> | passwords expired | <boolean> | <local user> | Plain
password history length of <security database> | password history lengths | <integer> | <security database> | Plain
password of <network share> | passwords | <string> | <network share> | Plain
path of <network share> | paths | <string> | <network share> | Plain
pathname of <file shortcut> | pathnames | <string> | <file shortcut> | Plain
pathname of <filesystem object> | pathnames | <string> | <filesystem object> | Plain
pem encoded certificate of <file> | pem encoded certificates | <x509 certificate> | <file> | Plain
pending login | pending logins | <boolean> | <world> | PlainGlobal
pending login of <action> | pending logins | <boolean> | <action> | Plain
pending of <action> | pendings | <boolean> | <action> | Plain
pending restart | pending restarts | <boolean> | <world> | PlainGlobal
pending restart <string> | pending restarts | <boolean> | <world> | NamedGlobal
pending restart of <action> | pending restarts | <boolean> | <action> | Plain
pending time of <action> | pending times | <time> | <action> | Plain
per user policy <security account> of <audit policy subcategory> | per user policies | <audit policy information> | <audit policy subcategory> | Index<security account>
performance counter frequency of <operating system> | performance counter frequencies | <hertz> | <operating system> | Plain
performance counter of <operating system> | performance counters | <integer> | <operating system> | Plain
permission permission of <network share> | permission permissions | <boolean> | <network share> | Plain
personal bit <operating system suite mask> | personal bits | <boolean> | <world> | Index<operating system suite mask>Global
physical processor count | physical processor counts | <integer> | <world> | PlainGlobal
platform id of <operating system> | platform ids | <integer> | <operating system> | Plain
plural name of <property> | plural names | <string> | <property> | Plain
point to point of <network ip interface> | point to points | <boolean> | <network ip interface> | Plain
policy change category of <audit policy> | policy change categories | <audit policy category> | <audit policy> | Plain
port mapping of <internet connection firewall> | port mappings | <port mapping> | <internet connection firewall> | Plain
port number of <selected server> | port numbers | <integer> | <selected server> | Plain
port of <firewall open port> | ports | <integer> | <firewall open port> | Plain
position <integer> of <string> | positions | <string position> | <string> | Numbered
position of <string> | positions | <string position> | <string> | Plain
pre <string> of <html> | pres | <html> | <html> | Named
pre <string> of <string> | pres | <html> | <string> | Named
pre of <html> | pres | <html> | <html> | Plain
pre of <string> | pres | <html> | <string> | Plain
preceding text of <string position> | preceding texts | <substring> | <string position> | Plain
preceding text of <substring> | preceding texts | <substring> | <substring> | Plain
previous line of <file line> | previous lines | <file line> | <file line> | Plain
previous sibling of <xml dom node> | previous siblings | <xml dom node> | <xml dom node> | Plain
primary group id of <local user> | primary group ids | <integer> | <local user> | Plain
primary language of <language> | primary languages | <primary language> | <language> | Plain
primary wins server of <network adapter> | primary wins servers | <ipv4 address> | <network adapter> | Plain
print operator flag of <local user> | print operator flags | <boolean> | <local user> | Plain
priority of <selected server> | priorities | <integer> | <selected server> | Plain
private firewall profile type | private firewall profile types | <firewall profile type> | <world> | PlainGlobal
private profile of <firewall policy> | private profiles | <firewall profile> | <firewall policy> | Plain
privilege of <security account> | privileges | <string> | <security account> | Plain
privilege use category of <audit policy> | privilege use categories | <audit policy category> | <audit policy> | Plain
problem id of <active device> | problem ids | <integer> | <active device> | Plain
process image file name of <firewall authorized application> | process image file names | <string> | <firewall authorized application> | Plain
processor | processors | <processor> | <world> | PlainGlobal
processor <integer> | processors | <processor> | <world> | NumberedGlobal
product info numeric of <operating system> | product info numerics | <integer> | <operating system> | Plain
product info string of <operating system> | product info strings | <string> | <operating system> | Plain
product of <integer> | products | <integer> | <integer> | Plain
product type of <operating system> | product types | <operating system product type> | <operating system> | Plain
product version of <file> | product versions | <version> | <file> | Plain
profile <firewall profile type> of <firewall rule> | profiles | <boolean> | <firewall rule> | Index<firewall profile type>
profile folder of <local user> | profile folders | <string> | <local user> | Plain
property <string> | properties | <property> | <world> | NamedGlobal
property <string> of <type> | properties | <property> | <type> | Named
property <string> of <wmi object> | properties | <wmi select> | <wmi object> | Named
property of <type> | properties | <property> | <type> | Plain
property of <wmi object> | properties | <wmi select> | <wmi object> | Plain
property returning <type> | properties returning | <property> | <world> | Index<type>Global
property returning <type> of <type> | properties returning | <property> | <type> | Index<type>
protocol of <firewall open port> | protocols | <internet protocol> | <firewall open port> | Plain
protocol of <firewall rule> | protocols | <internet protocol> | <firewall rule> | Plain
protocol of <port mapping> | protocols | <string> | <port mapping> | Plain
public firewall profile type | public firewall profile types | <firewall profile type> | <world> | PlainGlobal
public profile of <firewall policy> | public profiles | <firewall profile> | <firewall policy> | Plain
q <string> of <html> | qs | <html> | <html> | Named
q <string> of <string> | qs | <html> | <string> | Named
q of <html> | qs | <html> | <html> | Plain
q of <string> | qs | <html> | <string> | Plain
query value permission of <access control entry> | query value permissions | <boolean> | <access control entry> | Plain
ram | rams | <ram> | <world> | PlainGlobal
random access memory | random access memories | <ram> | <world> | PlainGlobal
range after <time> of <time range> | ranges after | <time range> | <time range> | Index<time>
range before <time> of <time range> | ranges before | <time range> | <time range> | Index<time>
raw file version of <file> | raw file versions | <version> | <file> | Plain
raw product version of <file> | raw product versions | <version> | <file> | Plain
raw version block <integer> of <file> | raw version blocks | <file version block> | <file> | Numbered
raw version block <string> of <file> | raw version blocks | <file version block> | <file> | Named
raw version block of <file> | raw version blocks | <file version block> | <file> | Plain
raw version of <file> | raw versions | <version> | <file> | Plain
read attributes permission of <access control entry> | read attributes permissions | <boolean> | <access control entry> | Plain
read control permission of <access control entry> | read control permissions | <boolean> | <access control entry> | Plain
read extended attributes permission of <access control entry> | read extended attributes permissions | <boolean> | <access control entry> | Plain
read permission of <access control entry> | read permissions | <boolean> | <access control entry> | Plain
read permission of <network share> | read permissions | <boolean> | <network share> | Plain
readonly of <filesystem object> | readonlys | <boolean> | <filesystem object> | Plain
recent application | recent applications | <application> | <world> | PlainGlobal
recent application <string> | recent applications | <application> | <world> | NamedGlobal
record <integer> of <event log> | records | <event log record> | <event log> | Numbered
record count of <event log> | record counts | <integer> | <event log> | Plain
record number of <event log record> | record numbers | <integer> | <event log record> | Plain
record of <event log> | records | <event log record> | <event log> | Plain
reference attribute of <metabase value> | reference attributes | <boolean> | <metabase value> | Plain
regapp | regapps | <application> | <world> | PlainGlobal
regapp <string> | regapps | <application> | <world> | NamedGlobal
regex <string> | regexes | <regular expression> | <world> | NamedGlobal
registrar number of <license> | registrar numbers | <integer> | <license> | Plain
registry | registries | <registry> | <world> | PlainGlobal
regular expression <string> | regular expressions | <regular expression> | <world> | NamedGlobal
relative significance place <integer> of <floating point> | relative significance places | <floating point> | <floating point> | Numbered
relative significance place of <floating point> | relative significance places | <floating point> | <floating point> | Plain
relay service | relay services | <service> | <world> | PlainGlobal
release of <operating system> | releases | <string> | <operating system> | Plain
relevance of <fixlet> | relevances | <boolean> | <fixlet> | Plain
relevant fixlet of <site> | relevant fixlets | <fixlet> | <site> | Plain
remote addresses of <firewall authorized application> | remote addresseses | <string> | <firewall authorized application> | Plain
remote addresses of <firewall open port> | remote addresseses | <string> | <firewall open port> | Plain
remote addresses of <firewall service> | remote addresseses | <string> | <firewall service> | Plain
remote addresses string of <firewall rule> | remote addresses strings | <string> | <firewall rule> | Plain
remote admin settings of <firewall profile> | remote admin settingses | <firewall remote admin settings> | <firewall profile> | Plain
remote desktop firewall service type | remote desktop firewall service types | <firewall service type> | <world> | PlainGlobal
remote of <logged on user> | remotes | <boolean> | <logged on user> | Plain
remote ports string of <firewall rule> | remote ports strings | <string> | <firewall rule> | Plain
result type of <binary operator> | result types | <type> | <binary operator> | Plain
result type of <property> | result types | <type> | <property> | Plain
result type of <unary operator> | result types | <type> | <unary operator> | Plain
right operand type of <binary operator> | right operand types | <type> | <binary operator> | Plain
right shift <integer> of <bit set> | right shifts | <bit set> | <bit set> | Numbered
root folder of <drive> | root folders | <folder> | <drive> | Plain
root server | root servers | <root server> | <world> | PlainGlobal
rope <string> | ropes | <rope> | <world> | NamedGlobal
rsop computer wmi | rsop computer wmis | <wmi> | <world> | PlainGlobal
rsop user wmi <security identifier> | rsop user wmis | <wmi> | <world> | Index<security identifier>Global
rule group currently enabled <string> of <firewall> | rule group currently enableds | <boolean> | <firewall> | Named
rule group enabled <string> of <firewall profile> | rule group enableds | <boolean> | <firewall profile> | Named
rule of <firewall service restriction> | rules | <firewall rule> | <firewall service restriction> | Plain
rule of <firewall> | rules | <firewall rule> | <firewall> | Plain
running application | running applications | <application> | <world> | PlainGlobal
running application <string> | running applications | <application> | <world> | NamedGlobal
running of <application usage summary> | runnings | <boolean> | <application usage summary> | Plain
running of <local mssql database> | runnings | <boolean> | <local mssql database> | Plain
running service | running services | <service> | <world> | PlainGlobal
running service <string> | running services | <service> | <world> | NamedGlobal
sacl of <security descriptor> | sacls | <system access control list> | <security descriptor> | Plain
samp <string> of <html> | samps | <html> | <html> | Named
samp <string> of <string> | samps | <html> | <string> | Named
samp of <html> | samps | <html> | <html> | Plain
samp of <string> | samps | <html> | <string> | Plain
saturday | saturdays | <day of week> | <world> | PlainGlobal
scope of <firewall authorized application> | scopes | <firewall scope> | <firewall authorized application> | Plain
scope of <firewall open port> | scopes | <firewall scope> | <firewall open port> | Plain
scope of <firewall service> | scopes | <firewall scope> | <firewall service> | Plain
script flag of <local user> | script flags | <boolean> | <local user> | Plain
seat count state of <license> | seat count states | <string> | <license> | Plain
seat of <license> | seats | <integer> | <license> | Plain
second | seconds | <time interval> | <world> | PlainGlobal
second_of_minute of <time of day with time zone> | seconds_of_minute | <integer> | <time of day with time zone> | Plain
second_of_minute of <time of day> | seconds_of_minute | <integer> | <time of day> | Plain
secondary wins server of <network adapter> | secondary wins servers | <ipv4 address> | <network adapter> | Plain
section <string> of <file> | sections | <file section> | <file> | Named
secure attribute of <metabase value> | secure attributes | <boolean> | <metabase value> | Plain
security account <string> | security accounts | <security account> | <world> | NamedGlobal
security database | security databases | <security database> | <world> | PlainGlobal
security descriptor of <file> | security descriptors | <security descriptor> | <file> | Plain
security descriptor of <folder> | security descriptors | <security descriptor> | <folder> | Plain
security descriptor of <network share> | security descriptors | <security descriptor> | <network share> | Plain
security descriptor of <registry key> | security descriptors | <security descriptor> | <registry key> | Plain
security descriptor of <service> | security descriptors | <security descriptor> | <service> | Plain
security event log | security event logs | <event log> | <world> | PlainGlobal
select <string> of <wmi> | selects | <wmi select> | <wmi> | Named
select <string> of <xml dom node> | selects | <xml dom node> | <xml dom node> | Named
select object <string> of <wmi> | select objects | <wmi object> | <wmi> | Named
selected server | selected servers | <selected server> | <world> | PlainGlobal
september | septembers | <month> | <world> | PlainGlobal
september <integer> | septembers | <day of year> | <world> | NumberedGlobal
september <integer> of <integer> | septembers | <date> | <integer> | Numbered
september of <integer> | septembers | <month and year> | <integer> | Plain
server operator flag of <local user> | server operator flags | <boolean> | <local user> | Plain
server trust account flag of <local user> | server trust account flags | <boolean> | <local user> | Plain
service | services | <service> | <world> | PlainGlobal
service <string> | services | <service> | <world> | NamedGlobal
service key value name of <active device> | service key value names | <string> | <active device> | Plain
service name of <firewall rule> | service names | <string> | <firewall rule> | Plain
service name of <service> | service names | <string> | <service> | Plain
service of <firewall profile> | services | <firewall service> | <firewall profile> | Plain
service pack major version of <operating system> | service pack major versions | <integer> | <operating system> | Plain
service pack minor version of <operating system> | service pack minor versions | <integer> | <operating system> | Plain
service restricted <( string, string )> of <firewall service restriction> | service restricteds | <boolean> | <firewall service restriction> | Index<( string, string )>
service restriction of <firewall> | service restrictions | <firewall service restriction> | <firewall> | Plain
service specific exit code of <service> | service specific exit codes | <integer> | <service> | Plain
set of <integer> | sets | <integer set> | <integer> | Plain
set of <string> | sets | <string set> | <string> | Plain
set value permission of <access control entry> | set value permissions | <boolean> | <access control entry> | Plain
setting <string> of <client> | settings | <setting> | <client> | Named
setting <string> of <site> | settings | <setting> | <site> | Named
setting of <client> | settings | <setting> | <client> | Plain
setting of <site> | settings | <setting> | <site> | Plain
sha1 of <file> | sha1s | <string> | <file> | Plain
sha1 of <x509 certificate> | sha1s | <string> | <x509 certificate> | Plain
shortcut of <file> | shortcuts | <file shortcut> | <file> | Plain
sid of <logged on user> | sids | <security identifier> | <logged on user> | Plain
sid of <security account> | sids | <security identifier> | <security account> | Plain
significance place <integer> of <floating point> | significance places | <floating point> | <floating point> | Numbered
significance place of <floating point> | significance places | <floating point> | <floating point> | Plain
significance threshold of <floating point> | significance thresholds | <floating point> | <floating point> | Plain
significant digits <integer> of <hertz> | significant digitss | <hertz> | <hertz> | Numbered
significant digits <integer> of <integer> | significant digitss | <integer> | <integer> | Numbered
single user ts bit <operating system suite mask> | single user ts bits | <boolean> | <world> | Index<operating system suite mask>Global
singular name of <property> | singular names | <string> | <property> | Plain
site | sites | <site> | <world> | PlainGlobal
site <string> | sites | <site> | <world> | NamedGlobal
site number of <license> | site numbers | <integer> | <license> | Plain
site tag of <site> | site tags | <string> | <site> | Plain
site version list <string> | site version lists | <site version list> | <world> | NamedGlobal
site version list of <site> | site version lists | <site version list> | <site> | Plain
size of <file> | sizes | <integer> | <file> | Plain
size of <integer set> | sizes | <integer> | <integer set> | Plain
size of <ram> | sizes | <integer> | <ram> | Plain
size of <registry key value> | sizes | <integer> | <registry key value> | Plain
size of <string set> | sizes | <integer> | <string set> | Plain
size of <type> | sizes | <integer> | <type> | Plain
small <string> of <html> | smalls | <html> | <html> | Named
small <string> of <string> | smalls | <html> | <string> | Named
small business bit <operating system suite mask> | small business bits | <boolean> | <world> | Index<operating system suite mask>Global
small business restricted bit <operating system suite mask> | small business restricted bits | <boolean> | <world> | Index<operating system suite mask>Global
small of <html> | smalls | <html> | <html> | Plain
small of <string> | smalls | <html> | <string> | Plain
source of <event log record> | sources | <string> | <event log record> | Plain
span <string> of <html> | spans | <html> | <html> | Named
span <string> of <string> | spans | <html> | <string> | Named
span of <html> | spans | <html> | <html> | Plain
span of <string> | spans | <html> | <string> | Plain
speed of <processor> | speeds | <hertz> | <processor> | Plain
standard deviation of <floating point> | standard deviations | <floating point> | <floating point> | Plain
standard deviation of <integer> | standard deviations | <floating point> | <integer> | Plain
standard firewall profile type | standard firewall profile types | <firewall profile type> | <world> | PlainGlobal
standard profile of <firewall policy> | standard profiles | <firewall profile> | <firewall policy> | Plain
start date of <license> | start dates | <time> | <license> | Plain
start in pathname of <file shortcut> | start in pathnames | <string> | <file shortcut> | Plain
start of <substring> | starts | <string position> | <substring> | Plain
start of <time range> | starts | <time> | <time range> | Plain
start type of <service> | start types | <string> | <service> | Plain
state of <service> | states | <string> | <service> | Plain
status of <action> | statuss | <string> | <action> | Plain
status of <active device> | statuss | <integer> | <active device> | Plain
status of <connection> | statuses | <connection status> | <connection> | Plain
status of <network adapter> | statuses | <integer> | <network adapter> | Plain
stepping of <processor> | steppings | <integer> | <processor> | Plain
string <string> | strings | <string> | <world> | NamedGlobal
string value <integer> of <wmi select> | string values | <string> | <wmi select> | Numbered
string value of <wmi select> | string values | <string> | <wmi select> | Plain
strong <string> of <html> | strongs | <html> | <html> | Named
strong <string> of <string> | strongs | <html> | <string> | Named
strong of <html> | strongs | <html> | <html> | Plain
strong of <string> | strongs | <html> | <string> | Plain
sub <string> of <html> | subs | <html> | <html> | Named
sub <string> of <string> | subs | <html> | <string> | Named
sub of <html> | subs | <html> | <html> | Plain
sub of <string> | subs | <html> | <string> | Plain
subcategory of <audit policy category> | subcategories | <audit policy subcategory> | <audit policy category> | Plain
subnet address of <network adapter> | subnet addresses | <ipv4 address> | <network adapter> | Plain
subnet address of <network address list> | subnet addresses | <ipv4 address> | <network address list> | Plain
subnet address of <network ip interface> | subnet addresses | <ipv4 address> | <network ip interface> | Plain
subnet mask of <network adapter> | subnet masks | <ipv4 address> | <network adapter> | Plain
subnet mask of <network address list> | subnet masks | <ipv4 address> | <network address list> | Plain
subnet mask of <network ip interface> | subnet masks | <ipv4 address> | <network ip interface> | Plain
subscribe time of <site> | subscribe times | <time> | <site> | Plain
substring <string> of <string> | substrings | <substring> | <string> | Named
substring after <string> of <string> | substrings after | <substring> | <string> | Named
substring before <string> of <string> | substrings before | <substring> | <string> | Named
substring between <string> of <string> | substrings between | <substring> | <string> | Named
substring separated by <string> of <string> | substrings separated by | <substring> | <string> | Named
suite mask of <operating system> | suite masks | <operating system suite mask> | <operating system> | Plain
sum of <integer> | sums | <integer> | <integer> | Plain
sunday | sundays | <day of week> | <world> | PlainGlobal
sup <string> of <html> | sups | <html> | <html> | Named
sup <string> of <string> | sups | <html> | <string> | Named
sup of <html> | sups | <html> | <html> | Plain
sup of <string> | sups | <html> | <string> | Plain
symbol of <binary operator> | symbols | <string> | <binary operator> | Plain
symbol of <unary operator> | symbols | <string> | <unary operator> | Plain
synchronize permission of <access control entry> | synchronize permissions | <boolean> | <access control entry> | Plain
system category of <audit policy> | system categories | <audit policy category> | <audit policy> | Plain
system event log | system event logs | <event log> | <world> | PlainGlobal
system file <string> | system files | <file> | <world> | NamedGlobal
system ini device file | system ini device files | <file> | <world> | PlainGlobal
system ini device file <string> | system ini device files | <file> | <world> | NamedGlobal
system language | system languages | <string> | <world> | PlainGlobal
system locale | system locales | <language> | <world> | PlainGlobal
system of <filesystem object> | systems | <boolean> | <filesystem object> | Plain
system policy of <audit policy subcategory> | system policies | <audit policy information> | <audit policy subcategory> | Plain
system ui language | system ui languages | <language> | <world> | PlainGlobal
system wow64 folder | system wow64 folders | <folder> | <world> | PlainGlobal
system x32 folder | system x32 folders | <folder> | <world> | PlainGlobal
system x64 folder | system x64 folders | <folder> | <world> | PlainGlobal
table <string> of <html> | tables | <html> | <html> | Named
table <string> of <string> | tables | <html> | <string> | Named
table of <html> | tables | <html> | <html> | Plain
table of <string> | tables | <html> | <string> | Plain
target ip address of <port mapping> | target ip addresses | <ipv4 address> | <port mapping> | Plain
target name of <port mapping> | target names | <string> | <port mapping> | Plain
tbody <string> of <html> | tbodys | <html> | <html> | Named
tbody <string> of <string> | tbodys | <html> | <string> | Named
tbody of <html> | tbodys | <html> | <html> | Plain
tbody of <string> | tbodys | <html> | <string> | Plain
tcp | tcps | <internet protocol> | <world> | PlainGlobal
td <string> of <html> | tds | <html> | <html> | Named
td <string> of <string> | tds | <html> | <string> | Named
td of <html> | tds | <html> | <html> | Plain
td of <string> | tds | <html> | <string> | Plain
temporary duplicate account flag of <local user> | temporary duplicate account flags | <boolean> | <local user> | Plain
temporary of <filesystem object> | temporarys | <boolean> | <filesystem object> | Plain
terminal bit <operating system suite mask> | terminal bits | <boolean> | <world> | Index<operating system suite mask>Global
tfoot <string> of <html> | tfoots | <html> | <html> | Named
tfoot <string> of <string> | tfoots | <html> | <string> | Named
tfoot of <html> | tfoots | <html> | <html> | Plain
tfoot of <string> | tfoots | <html> | <string> | Plain
th <string> of <html> | ths | <html> | <html> | Named
th <string> of <string> | ths | <html> | <string> | Named
th of <html> | ths | <html> | <html> | Plain
th of <string> | ths | <html> | <string> | Plain
thead <string> of <html> | theads | <html> | <html> | Named
thead <string> of <string> | theads | <html> | <string> | Named
thead of <html> | theads | <html> | <html> | Plain
thead of <string> | theads | <html> | <string> | Plain
thursday | thursdays | <day of week> | <world> | PlainGlobal
time <string> | times | <time> | <world> | NamedGlobal
time <time zone> of <time> | times | <time of day with time zone> | <time> | Index<time zone>
time generated of <event log record> | times generated | <time> | <event log record> | Plain
time interval <string> | time intervals | <time interval> | <world> | NamedGlobal
time of <time of day with time zone> | times | <time of day> | <time of day with time zone> | Plain
time value <integer> of <wmi select> | time values | <time> | <wmi select> | Numbered
time value of <wmi select> | time values | <time> | <wmi select> | Plain
time written of <event log record> | times written | <time> | <event log record> | Plain
time zone <string> | time zones | <time zone> | <world> | NamedGlobal
time_of_day <string> | times_of_day | <time of day> | <world> | NamedGlobal
title <string> of <html> | titles | <html> | <html> | Named
title <string> of <string> | titles | <html> | <string> | Named
title of <html> | titles | <html> | <html> | Plain
title of <string> | titles | <html> | <string> | Plain
total duration of <application usage summary> | total durations | <time interval> | <application usage summary> | Plain
total processor core count | total processor core counts | <integer> | <world> | PlainGlobal
total run count of <application usage summary> | total run counts | <integer> | <application usage summary> | Plain
total space of <drive> | total spaces | <integer> | <drive> | Plain
tr <string> of <html> | trs | <html> | <html> | Named
tr <string> of <string> | trs | <html> | <string> | Named
tr of <html> | trs | <html> | <html> | Plain
tr of <string> | trs | <html> | <string> | Plain
traverse permission of <access control entry> | traverse permissions | <boolean> | <access control entry> | Plain
true | trues | <boolean> | <world> | PlainGlobal
trustee of <access control entry> | trustees | <security identifier> | <access control entry> | Plain
trustee type of <access control entry> | trustee types | <integer> | <access control entry> | Plain
tt <string> of <html> | tts | <html> | <html> | Named
tt <string> of <string> | tts | <html> | <string> | Named
tt of <html> | tts | <html> | <html> | Plain
tt of <string> | tts | <html> | <string> | Plain
tuesday | tuesdays | <day of week> | <world> | PlainGlobal
two digit hour of <time of day with time zone> | two digit hours | <string> | <time of day with time zone> | Plain
two digit hour of <time of day> | two digit hours | <string> | <time of day> | Plain
two digit minute of <time of day with time zone> | two digit minutes | <string> | <time of day with time zone> | Plain
two digit minute of <time of day> | two digit minutes | <string> | <time of day> | Plain
two digit second of <time of day with time zone> | two digit seconds | <string> | <time of day with time zone> | Plain
two digit second of <time of day> | two digit seconds | <string> | <time of day> | Plain
type of <distinguished name component> | types | <string> | <distinguished name component> | Plain
type of <drive> | types | <string> | <drive> | Plain
type of <firewall profile> | types | <firewall profile type> | <firewall profile> | Plain
type of <firewall service> | types | <firewall service type> | <firewall service> | Plain
type of <metabase value> | types | <metabase type> | <metabase value> | Plain
type of <network adapter> | types | <integer> | <network adapter> | Plain
type of <network share> | types | <integer> | <network share> | Plain
type of <processor> | types | <integer> | <processor> | Plain
type of <registry key value> | types | <registry key value type> | <registry key value> | Plain
type of <site> | types | <string> | <site> | Plain
type of <wmi select> | types | <integer> | <wmi select> | Plain
udp | udps | <internet protocol> | <world> | PlainGlobal
ul <string> of <html> | uls | <html> | <html> | Named
ul <string> of <string> | uls | <html> | <string> | Named
ul of <html> | uls | <html> | <html> | Plain
ul of <string> | uls | <html> | <string> | Plain
unary operator <string> | unary operators | <unary operator> | <world> | NamedGlobal
unary operator returning <type> | unary operators returning | <unary operator> | <world> | Index<type>Global
underflow of <floating point> | underflows | <boolean> | <floating point> | Plain
unicast responses to multicast broadcast disabled of <firewall profile> | unicast responses to multicast broadcast disableds | <boolean> | <firewall profile> | Plain
union of <integer set> | unions | <integer set> | <integer set> | Plain
union of <string set> | unions | <string set> | <string set> | Plain
unique value of <date> | unique values | <date with multiplicity> | <date> | Plain
unique value of <day of month> | unique values | <day of month with multiplicity> | <day of month> | Plain
unique value of <day of week> | unique values | <day of week with multiplicity> | <day of week> | Plain
unique value of <day of year> | unique values | <day of year with multiplicity> | <day of year> | Plain
unique value of <floating point> | unique values | <floating point with multiplicity> | <floating point> | Plain
unique value of <hertz> | unique values | <hertz with multiplicity> | <hertz> | Plain
unique value of <integer> | unique values | <integer with multiplicity> | <integer> | Plain
unique value of <ipv4 address> | unique values | <ipv4 address with multiplicity> | <ipv4 address> | Plain
unique value of <ipv6 address> | unique values | <ipv6 address with multiplicity> | <ipv6 address> | Plain
unique value of <month and year> | unique values | <month and year with multiplicity> | <month and year> | Plain
unique value of <month> | unique values | <month with multiplicity> | <month> | Plain
unique value of <number of months> | unique values | <number of months with multiplicity> | <number of months> | Plain
unique value of <site version list> | unique values | <site version list with multiplicity> | <site version list> | Plain
unique value of <string> | unique values | <string with multiplicity> | <string> | Plain
unique value of <time interval> | unique values | <time interval with multiplicity> | <time interval> | Plain
unique value of <time of day with time zone> | unique values | <time of day with time zone with multiplicity> | <time of day with time zone> | Plain
unique value of <time of day> | unique values | <time of day with multiplicity> | <time of day> | Plain
unique value of <time range> | unique values | <time range with multiplicity> | <time range> | Plain
unique value of <time zone> | unique values | <time zone with multiplicity> | <time zone> | Plain
unique value of <time> | unique values | <time with multiplicity> | <time> | Plain
unique value of <version> | unique values | <version with multiplicity> | <version> | Plain
unique value of <year> | unique values | <year with multiplicity> | <year> | Plain
universal time <string> | universal times | <time> | <world> | NamedGlobal
universal time zone | universal time zones | <time zone> | <world> | PlainGlobal
unordered list <string> of <html> | unordered lists | <html> | <html> | Named
unordered list <string> of <string> | unordered lists | <html> | <string> | Named
unordered list of <html> | unordered lists | <html> | <html> | Plain
unordered list of <string> | unordered lists | <html> | <string> | Plain
upnp firewall service type | upnp firewall service types | <firewall service type> | <world> | PlainGlobal
upper bound of <integer range> | upper bounds | <integer> | <integer range> | Plain
uptime of <operating system> | uptimes | <time interval> | <operating system> | Plain
url of <site> | urls | <string> | <site> | Plain
use count of <network share> | use counts | <integer> | <network share> | Plain
use limit of <network share> | use limits | <integer> | <network share> | Plain
user comment of <local user> | user comments | <string> | <local user> | Plain
user id of <local user> | user ids | <integer> | <local user> | Plain
user language | user languages | <string> | <world> | PlainGlobal
user locale | user locales | <language> | <world> | PlainGlobal
user privilege of <local user> | user privileges | <boolean> | <local user> | Plain
user sid of <event log record> | user sids | <security identifier> | <event log record> | Plain
user type of <metabase value> | user types | <metabase user type> | <metabase value> | Plain
user ui language | user ui languages | <language> | <world> | PlainGlobal
usual name of <property> | usual names | <string> | <property> | Plain
value <string> of <file version block> | values | <string> | <file version block> | Named
value <string> of <registry key> | values | <registry key value> | <registry key> | Named
value of <distinguished name component> | values | <string> | <distinguished name component> | Plain
value of <environment variable> | values | <string> | <environment variable> | Plain
value of <fixlet_header> | values | <string> | <fixlet_header> | Plain
value of <metabase key> | values | <metabase value> | <metabase key> | Plain
value of <registry key> | values | <registry key value> | <registry key> | Plain
value of <setting> | values | <string> | <setting> | Plain
var <string> of <html> | vars | <html> | <html> | Named
var <string> of <string> | vars | <html> | <string> | Named
var of <html> | vars | <html> | <html> | Plain
var of <string> | vars | <html> | <string> | Plain
variable <string> of <environment> | variables | <environment variable> | <environment> | Named
variable of <environment> | variables | <environment variable> | <environment> | Plain
variable of <file> | variables | <string> | <file> | Plain
vendor name of <processor> | vendor names | <string> | <processor> | Plain
version <string> | versions | <version> | <world> | NamedGlobal
version block <integer> of <file> | version blocks | <file version block> | <file> | Numbered
version block <string> of <file> | version blocks | <file version block> | <file> | Named
version block of <file> | version blocks | <file version block> | <file> | Plain
version of <bios> | versions | <string> | <bios> | Plain
version of <current relay> | versions | <version> | <current relay> | Plain
version of <file> | versions | <version> | <file> | Plain
version of <site> | versions | <integer> | <site> | Plain
version string <string> of <module> | version strings | <string> | <module> | Named
volatile attribute of <metabase value> | volatile attributes | <boolean> | <metabase value> | Plain
waiting for download of <action> | waiting for downloads | <boolean> | <action> | Plain
wake on lan subnet cidr string | wake on lan subnet cidr strings | <string> | <world> | PlainGlobal
wakeonlan enabled of <network adapter> | wakeonlan enableds | <boolean> | <network adapter> | Plain
warning event log event type | warning event log event types | <event log event type> | <world> | PlainGlobal
wednesday | wednesdays | <day of week> | <world> | PlainGlobal
week | weeks | <time interval> | <world> | PlainGlobal
weight of <selected server> | weights | <integer> | <selected server> | Plain
win32 exit code of <service> | win32 exit codes | <integer> | <service> | Plain
windows display time <string> | windows display times | <time> | <world> | NamedGlobal
windows file <string> | windows files | <file> | <world> | NamedGlobal
windows folder | windows folders | <folder> | <world> | PlainGlobal
wins enabled of <network adapter> | wins enableds | <boolean> | <network adapter> | Plain
winsock2 supported of <network> | winsock2 supporteds | <boolean> | <network> | Plain
wmi | wmis | <wmi> | <world> | PlainGlobal
wmi <string> | wmis | <wmi> | <world> | NamedGlobal
workstation trust account flag of <local user> | workstation trust account flags | <boolean> | <local user> | Plain
write attributes permission of <access control entry> | write attributes permissions | <boolean> | <access control entry> | Plain
write dac permission of <access control entry> | write dac permissions | <boolean> | <access control entry> | Plain
write extended attributes permission of <access control entry> | write extended attributes permissions | <boolean> | <access control entry> | Plain
write owner permission of <access control entry> | write owner permissions | <boolean> | <access control entry> | Plain
write permission of <access control entry> | write permissions | <boolean> | <access control entry> | Plain
write permission of <network share> | write permissions | <boolean> | <network share> | Plain
x32 application <string> | x32 applications | <application> | <world> | NamedGlobal
x32 file <string> | x32 files | <file> | <world> | NamedGlobal
x32 folder <string> | x32 folders | <folder> | <world> | NamedGlobal
x32 registry | x32 registries | <registry> | <world> | PlainGlobal
x64 application <string> | x64 applications | <application> | <world> | NamedGlobal
x64 file <string> | x64 files | <file> | <world> | NamedGlobal
x64 folder <string> | x64 folders | <folder> | <world> | NamedGlobal
x64 of <operating system> | x64s | <boolean> | <operating system> | Plain
x64 registry | x64 registries | <registry> | <world> | PlainGlobal
xml document of <file> | xml documents | <xml dom document> | <file> | Plain
xml document of <string> | xml documents | <xml dom document> | <string> | Plain
xpath <( string, string )> of <xml dom node> | xpaths | <xml dom node> | <xml dom node> | Index<( string, string )>
xpath <string> of <xml dom node> | xpaths | <xml dom node> | <xml dom node> | Named
year | years | <number of months> | <world> | PlainGlobal
year <integer> | years | <year> | <world> | NumberedGlobal
year <string> | years | <year> | <world> | NamedGlobal
year of <date> | years | <year> | <date> | Plain
year of <month and year> | years | <year> | <month and year> | Plain
zone of <time of day with time zone> | zones | <time zone> | <time of day with time zone> | Plain
zoned time_of_day <string> | zoned times_of_day | <time of day with time zone> | <world> | NamedGlobal


World

All objects created without context are known as 'properties of the world' in the relevance language. Below is a list of these global properties, sorted by key phrase.

Properties

Key Phrase | Form | Return Type | Description
administrator <( bes computer, bes user )> | Index<( bes computer, bes user )>Global | <boolean> | Returns TRUE if the specified user is an administrator of the given computers. Win:7.0
administrator <( bes user, bes computer )> | Index<( bes user, bes computer )>Global | <boolean> | Returns TRUE if the specified user is an administrator of the given computers. Win:7.0
all bes site | PlainGlobal | <bes site> | This iterative Inspector returns a list of all external, master, operator, and custom sites. Win:7.0
all computer count | PlainGlobal | <historical computer count> | Returns a list of all <historical_computer_count> objects. Win:6.0
all fixlet count | PlainGlobal | <historical fixlet count> | Returns a list of all the historical Fixlet counts. • Note: This is a Web Reports-only Inspector. Win:6.0
bes action | PlainGlobal | <bes action> | Returns all actions, except those that are normally hidden in the console, such as subscription actions, management rights actions, etc. Win:6.0
bes action set | PlainGlobal | <bes action set> | Returns the current list of BES Actions in the form of a set, which can be arithmetically manipulated. Win:7.0
bes action status constrained | PlainGlobal | <bes action status> | Returns the BES action status corresponding to constraints. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status download failed | PlainGlobal | <bes action status> | Returns the BES action status corresponding to failed downloads. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status error | PlainGlobal | <bes action status> | Returns the BES action status corresponding to errors. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status evaluating | PlainGlobal | <bes action status> | Returns the BES action status corresponding to evaluation. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status expired | PlainGlobal | <bes action status> | Returns the BES action status corresponding to expiration. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status failed | PlainGlobal | <bes action status> | Returns the BES action status corresponding to failure. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status fixed | PlainGlobal | <bes action status> | Returns the BES action status corresponding to successful fixes. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status invalid signature | PlainGlobal | <bes action status> | Returns the BES action status corresponding to invalid signatures. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status irrelevant | PlainGlobal | <bes action status> | Returns the BES action status corresponding to irrelevance This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status locked | PlainGlobal | <bes action status> | Returns the BES action status corresponding to locking. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status offers disabled | PlainGlobal | <bes action status> | Returns the BES action status corresponding to disabled offers. This result can be cast to a <string> format to give the text as shown in the console. Win:7.0
bes action status pending downloads | PlainGlobal | <bes action status> | Returns the BES action status corresponding to pending downloads. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending login | PlainGlobal | <bes action status> | Returns the BES action status corresponding to pending logins. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending message | PlainGlobal | <bes action status> | Returns the BES action status corresponding to pending messages. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending offer | PlainGlobal | <bes action status> | Returns the BES action status corresponding to pending offers. This result can be cast to a <string> format to give the text as shown in the console. Win:7.0
bes action status pending restart | PlainGlobal | <bes action status> | Returns the BES action status corresponding to pending restarts. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status postponed | PlainGlobal | <bes action status> | Returns the BES action status corresponding to postponements. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status running | PlainGlobal | <bes action status> | Returns the BES action status corresponding to whether or not it is running. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status unreported | PlainGlobal | <bes action status> | Returns a constant representing an action status of 'not reported'. Win:6.0
bes action status user cancelled | PlainGlobal | <bes action status> | Returns the BES action status corresponding to user cancelation. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status waiting | PlainGlobal | <bes action status> | Returns the BES action status corresponding to waiting. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes brand | PlainGlobal | <string> | As of version 7.2, the BES Console can be branded by third parties who wish to use the engine to deliver specific content. This Inspector returns a string that identifies any branding associated with the BES Console. The unbranded Console returns 'bigfix', but other third-party brands may result. Win:7.2
bes computer | PlainGlobal | <bes computer> | Returns a list of all the BES computers visible to the current console user. Win:6.0
bes computer group | PlainGlobal | <bes computer group> | Returns the current list of BES computer groups. Win:7.0
bes computer group set | PlainGlobal | <bes computer group set> | Returns the current list of BES computer groups in the form of a set, which can be arithmetically manipulated. Win:7.0
bes computer set | PlainGlobal | <bes computer set> | Returns the current list of BES computers in the form of a set, which can be arithmetically manipulated. Win:7.0
bes custom site | PlainGlobal | <bes site> | Returns a list of all custom sites. Deprecated as of version 7.0; instead use "all bes sites whose (custom site flag of it)". Win:7.0
bes deployment option | PlainGlobal | <bes deployment option> | Returns the current deployment options as listed in the BES Admin Tool, under the Advanced Options tab. You can add your own name/value pairs to this list. Win:7.0
bes deployment option <string> | NamedGlobal | <bes deployment option> | Returns the value associated with the deployment option named by the <string>. Win:7.0
bes filter | PlainGlobal | <bes filter> | Returns the list of the currently defined BES Filters, collected across all topics, including Baselines, Actions, Fixlets, etc. Win:7.0
bes filter <integer> | NumberedGlobal | <bes filter> | Returns the filter with the specified ID. It is the same as "bes filter whose (id of it is <integer>)". Win:7.0
bes filter set | PlainGlobal | <bes filter set> | Iterates over the BES Filters and converts the list to a set. Win:7.0
bes fixlet | PlainGlobal | <bes fixlet> | Returns a list of all the BES properties. Win:6.0
bes fixlet set | PlainGlobal | <bes fixlet set> | Returns the current list of BES Fixlet messages in the form of a set, which can be arithmetically manipulated. Win:7.0
bes property | PlainGlobal | <bes property> | Returns a list of all the BES custom site objects. Win:6.0
bes property <string> | NamedGlobal | <bes property> | Returns the first property whose name matches the given string. Note that it is not safe to assume that there is only one property with a given name. Win:6.0
bes property set | PlainGlobal | <bes property set> | Returns the current list of BES Properties in the form of a set, which can be arithmetically manipulated. Win:7.0
bes site | PlainGlobal | <bes site> | Returns a list of all the BES sites. Win:6.0
bes unmanagedasset | PlainGlobal | <bes unmanagedasset> | Returns a list of all the Unmanaged Assets currently defined in BES. Win:7.0
bes user | PlainGlobal | <bes user> | Returns a list of all the BES users. Win:6.0
bes user set | PlainGlobal | <bes user set> | Returns the current list of BES Users in the form of a set, which can be arithmetically manipulated. Win:7.0
bes wakeonlan status | PlainGlobal | <bes wakeonlan status> | Returns the current BES WakeOnLan status. Win:7.1
bes wizard | PlainGlobal | <bes wizard> | Returns a list of all the available BES Wizards. • Note: This is a Console-only Inspector. Win:6.0
current analysis | PlainGlobal | <bes fixlet> | When this Inspector is evaluated in the context of an analysis, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
current bes server | PlainGlobal | <bes server> | Returns a <bes server> object corresponding to the BES Server currently connected to the Console or Web Reports applications. The current bes server Inspectors allow dashboards to access files hosted on the current BES Server. Win:7.2
current computer | PlainGlobal | <bes computer> | This Inspector returns the computer that is currently selected by a right-click in the BES Console. This Inspector is designed to assist you in the creation of extended Context menu applications. Win:6.0
current console user | PlainGlobal | <bes user> | Returns a user object for the user currently logged into the BES Console. Win:6.0
current fixlet | PlainGlobal | <bes fixlet> | When this Inspector is evaluated in the context of a Fixlet message, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
current task | PlainGlobal | <bes fixlet> | When this Inspector is evaluated in the context of a Task, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
current unmanagedasset | PlainGlobal | <bes unmanagedasset> | Returns the unmanaged asset that is currently selected in the BES Console from the right-click context menu under the Unmanaged Assets tab. This Inspector is designed to assist you in the creation of extended Context Menu applications. Win:7.0
current wizard | PlainGlobal | <bes wizard> | If this Inspector is being evaluated in the context of a Wizard, then it returns the corresponding <bes wizard> object. Win:6.0
hidden bes action | PlainGlobal | <bes action> | Returns all actions that are normally hidden by the console, such as subscription actions, management rights actions, etc. Win:6.0
hidden bes action set | PlainGlobal | <bes action set> | Retrieves the set (iterated list) of hidden BES Actions. Win:7.0
in console context | PlainGlobal | <boolean> | Returns TRUE if this Inspector is being evaluated in the BES Console environment. Win:6.0
in web reports context | PlainGlobal | <boolean> | Returns TRUE if this Inspector is being evaluated in the Web Reports environment. Win:6.0
relevant <( bes computer, bes fixlet )> | Index<( bes computer, bes fixlet )>Global | <boolean> | Returns TRUE if the given Fixlet message is relevant on the specified computer. Win:6.0
relevant <( bes fixlet, bes computer )> | Index<( bes fixlet, bes computer )>Global | <boolean> | Returns TRUE if the given Fixlet message is relevant on the specified computer. Win:6.0
result <( bes action, bes computer )> | Index<( bes action, bes computer )>Global | <bes action result> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result from <bes action> of <bes computer>. Win:6.0
result <( bes computer, bes action )> | Index<( bes computer, bes action )>Global | <bes action result> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result from <bes action> of <bes computer>. Win:6.0
result <( bes computer, bes fixlet )> | Index<( bes computer, bes fixlet )>Global | <bes fixlet result> | Returns a Fixlet result for the given computer and Fixlet. This command is a variant of other result Inspectors, such as result from <bes fixlet> of <bes computer>. Win:7.0
result <( bes computer, bes property )> | Index<( bes computer, bes property )>Global | <bes property result> | Returns the result of the specified BES property and computer. Win:6.0
result <( bes fixlet, bes computer )> | Index<( bes fixlet, bes computer )>Global | <bes fixlet result> | Returns a Fixlet result for the given computer and Fixlet. This command is a variant of other result Inspectors, such as result from <bes fixlet> of <bes computer>. Win:7.0
result <( bes property, bes computer )> | Index<( bes property, bes computer )>Global | <bes property result> | Returns the result of the specified BES property and computer. Win:6.0
top level bes action | PlainGlobal | <bes action> | Returns all top-level actions. Does not include actions that are normally hidden or sub-actions of a multiple action group. Win:6.0
top level bes action set | PlainGlobal | <bes action set> | Returns all top level actions as a mathematical set. Does not include actions that are normally hidden, and sub-actions of a multiple action group. Win:7.0

Examples

names of bes actions
Returns a list of all the actions.

"The brand is: " & bes brand
Returns a string containing the current third-party branding of the BES Console (or, if none, returns 'bigfix').

names of hidden bes actions
Returns a list of all the hidden actions.

detailed status of result ( (bes action whose (id of it is 1234)) , (bes computer whose (id of it is 1234567)) )
Returns the detailed status of the specified action on the given computer.

detailed status of result ( (bes computer whose (id of it is 1234567)) , (bes action whose (id of it is 1234)) )
Returns the detailed status of the specified action on the given computer.

names of top level bes actions
Returns a list of all the top-level actions.


Casting Operators

The casting operators allow you to convert one type to another. This is a list of the casting operators sorted by key phrase.

Key Phrase | Creates a | From a
<action lock state> as string | <string> | <action lock state>
<binary operator> as string | <string> | <binary operator>
<bios> as string | <string> | <bios>
<bit set> as integer | <integer> | <bit set>
<bit set> as string | <string> | <bit set>
<boolean> as boolean | <boolean> | <boolean>
<boolean> as string | <string> | <boolean>
<cast> as string | <string> | <cast>
<date> as string | <string> | <date>
<day of month> as integer | <integer> | <day of month>
<day of month> as string | <string> | <day of month>
<day of month> as two digits | <string> | <day of month>
<day of week> as string | <string> | <day of week>
<day of week> as three letters | <string> | <day of week>
<day of year> as string | <string> | <day of year>
<discretionary access control list> as string | <string> | <discretionary access control list>
<environment variable> as string | <string> | <environment variable>
<file content> as lowercase | <file content> | <file content>
<file content> as uppercase | <file content> | <file content>
<file> as string | <string> | <file>
<floating point> as floating point | <floating point> | <floating point>
<floating point> as integer | <integer> | <floating point>
<floating point> as scientific notation | <string> | <floating point>
<floating point> as standard notation | <string> | <floating point>
<floating point> as string | <string> | <floating point>
<hertz> as string | <string> | <hertz>
<html> as html | <html> | <html>
<html> as string | <string> | <html>
<integer> as bit set | <bit set> | <integer>
<integer> as bits | <bit set> | <integer>
<integer> as day_of_month | <day of month> | <integer>
<integer> as floating point | <floating point> | <integer>
<integer> as hexadecimal | <string> | <integer>
<integer> as integer | <integer> | <integer>
<integer> as month | <month> | <integer>
<integer> as string | <string> | <integer>
<integer> as year | <year> | <integer>
<ipv4 address> as ipv6 address | <ipv6 address> | <ipv4 address>
<ipv4 address> as string | <string> | <ipv4 address>
<ipv6 address> as compressed string | <string> | <ipv6 address>
<ipv6 address> as compressed string with ipv4 | <string> | <ipv6 address>
<ipv6 address> as string | <string> | <ipv6 address>
<ipv6 address> as string with ipv4 | <string> | <ipv6 address>
<ipv6 address> as string with leading zeros | <string> | <ipv6 address>
<language> as string | <string> | <language>
<local group member> as string | <string> | <local group member>
<metabase identifier> as integer | <integer> | <metabase identifier>
<metabase identifier> as string | <string> | <metabase identifier>
<metabase type> as integer | <integer> | <metabase type>
<metabase type> as string | <string> | <metabase type>
<metabase user type> as integer | <integer> | <metabase user type>
<metabase user type> as string | <string> | <metabase user type>
<metabase value> as integer | <integer> | <metabase value>
<metabase value> as string | <string> | <metabase value>
<month and year> as string | <string> | <month and year>
<month> as integer | <integer> | <month>
<month> as string | <string> | <month>
<month> as three letters | <string> | <month>
<month> as two digits | <string> | <month>
<number of months> as string | <string> | <number of months>
<operating system> as string | <string> | <operating system>
<primary language> as string | <string> | <primary language>
<property> as string | <string> | <property>
<registry key value type> as string | <string> | <registry key value type>
<registry key value> as application | <application> | <registry key value>
<registry key value> as file | <file> | <registry key value>
<registry key value> as folder | <folder> | <registry key value>
<registry key value> as integer | <integer> | <registry key value>
<registry key value> as string | <string> | <registry key value>
<registry key value> as system file | <file> | <registry key value>
<registry key value> as time | <time> | <registry key value>
<rope> as string | <string> | <rope>
<security descriptor> as string | <string> | <security descriptor>
<security identifier> as string | <string> | <security identifier>
<service> as string | <string> | <service>
<setting> as string | <string> | <setting>
<site version list> as string | <string> | <site version list>
<string> as boolean | <boolean> | <string>
<string> as date | <date> | <string>
<string> as day_of_month | <day of month> | <string>
<string> as day_of_week | <day of week> | <string>
<string> as floating point | <floating point> | <string>
<string> as hexadecimal | <string> | <string>
<string> as html | <html> | <string>
<string> as integer | <integer> | <string>
<string> as ipv6 address | <ipv6 address> | <string>
<string> as left trimmed string | <string> | <string>
<string> as local time | <time> | <string>
<string> as local zoned time_of_day | <time of day with time zone> | <string>
<string> as lowercase | <string> | <string>
<string> as month | <month> | <string>
<string> as right trimmed string | <string> | <string>
<string> as site version list | <site version list> | <string>
<string> as string | <string> | <string>
<string> as time | <time> | <string>
<string> as time interval | <time interval> | <string>
<string> as time zone | <time zone> | <string>
<string> as time_of_day | <time of day> | <string>
<string> as trimmed string | <string> | <string>
<string> as universal time | <time> | <string>
<string> as universal zoned time_of_day | <time of day with time zone> | <string>
<string> as uppercase | <string> | <string>
<string> as version | <version> | <string>
<string> as windows display time | <time> | <string>
<string> as year | <year> | <string>
<string> as zoned time_of_day | <time of day with time zone> | <string>
<system access control list> as string | <string> | <system access control list>
<time interval> as string | <string> | <time interval>
<time of day with time zone> as string | <string> | <time of day with time zone>
<time of day> as string | <string> | <time of day>
<time range> as string | <string> | <time range>
<time zone> as string | <string> | <time zone>
<time> as local string | <string> | <time>
<time> as string | <string> | <time>
<time> as universal string | <string> | <time>
<type> as string | <string> | <type>
<unary operator> as string | <string> | <unary operator>
<version> as string | <string> | <version>
<version> as version | <version> | <version>
<wmi object> as string | <string> | <wmi object>
<wmi select> as string | <string> | <wmi select>
<xml dom node> as text | <string> | <xml dom node>
<xml dom node> as xml | <string> | <xml dom node>
<year> as integer | <integer> | <year>
<year> as string | <string> | <year>


BES Action

These Inspectors are used to access information about the actions which have been issued by the BES Operators. You can iterate over the actions to create lists. Each action may have several properties that can be examined.

Creation Methods

Key Phrase | Form | Description
action of <bes action result> | Plain | Returns the action corresponding to the action result. Win:6.0
bes action | PlainGlobal | Returns all actions, except those that are normally hidden in the console, such as subscription actions, management rights actions, etc. Win:6.0
element of <bes action set> | Plain | Returns the unique elements of the specified <bes action set>, removing duplicates and sorting by value. Win:7.0
hidden bes action | PlainGlobal | Returns all actions that are normally hidden by the console, such as subscription actions, management rights actions, etc. Win:6.0
issued action of <bes user> | Plain | Returns all actions, including hidden actions, issued by the specified user. Win:7.0
member action of <bes action> | Plain | Returns the individual member actions for the specified multiple action group parent, <bes action>. Win:7.0
middle action of <bes action> | Plain | For a start action this iterates over the list of <action> objects that make up the group. Win:6.0
parent group of <bes action> | Plain | Returns the parent group action for the specified group action member. Win:7.0
top level bes action | PlainGlobal | Returns all top-level actions. Does not include actions that are normally hidden or sub-actions of a multiple action group. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<bes action> as xml | Cast | <utf8 string> | Converts the specified BES Action to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
action script of <bes action> | Plain | <string> | Returns the script behind the specified action as a string. Win:6.0
action script type of <bes action> | Plain | <string> | Returns the MIME type of the specified action as a string. Win:6.0
applicability relevance of <bes action> | Plain | <string> | Returns the relevance statement as a string. This string is included in the targeting relevance expression but is maintained separately because it comes from the relevance of the original analysis fixlet. Win:6.0
comment of <bes action> | Plain | <bes comment> | Returns the comments assigned to the specified BES Action. Win:7.0
computer group flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a computer group action. Win:6.0
constrain by property name of <bes action> | Plain | <string> | Returns the 'constrain by property name' setting, one of the property constraints of the action. Win:6.0
constrain by property relation of <bes action> | Plain | <string> | Returns the 'constrain by property relation' setting, one of the property constraints of the action. Win:6.0
constrain by property value of <bes action> | Plain | <string> | Returns the 'constrain by property value' setting, one of the property constraints of the action. Win:6.0
custom success relevance of <bes action> | Plain | <string> | Returns the custom relevance expression for this action, if it exists. Win:6.0
database id of <bes action> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES Action resides. Win:6.0
database name of <bes action> | Plain | <string> | In a Web Reports context, this Inspector returns the name (as a string) of the database containing the specified BES Action. Win:6.0
end date of <bes action> | Plain | <date> | Returns the ending <date> for the specified action. Along with the start date, this defines the allowed time range for execution of the action. Win:6.0
end flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is an end action. Win:6.0
end time_of_day of <bes action> | Plain | <time of day> | Returns the ending <time of day> for the specified action. Along with the start time of day, this defines the allowed time range for execution of the action. Win:6.0
expiration time of <bes action> | Plain | <time> | This Inspector was deprecated after version 5.0 and now only returns FALSE. For a workaround, see the 'end date' and 'end time_of_day' properties. Win:6.0
group member flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a group member action. Win:6.0
hidden flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a hiding action. Win:6.0
id of <bes action> | Plain | <integer> | Returns the numeric ID number of the specified BES Action. Win:6.0
issuer of <bes action> | Plain | <bes user> | Returns the BES user object corresponding to the issuer of the specified action. Win:6.0
link <html> of <bes action> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the given action's document (in the BES Console) or description page (in Web Reports). Win:6.0
link <string> of <bes action> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the given action's document (in the BES Console) or description page (in Web Reports). Win:6.0
link href of <bes action> | Plain | <string> | Returns a <string> that can be embedded into an <A> tag that, when clicked, will open the given action's document (in the BES Console) or description page (in Web Reports). Note that link href returns a normal string, not an HTML string. Win:6.0
link of <bes action> | Plain | <html> | Returns an HTML string containing an <A> tag that, when clicked, will open the given action's document (in the BES Console) or description page (in Web Reports). Win:6.0
management rights flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a management rights action. Win:6.0
member action of <bes action> | Plain | <bes action> | Returns the individual member actions for the specified multiple action group parent, <bes action>. Win:7.0
member action set of <bes action> | Plain | <bes action set> | Returns the individual member actions for the specified multiple action group parent, <bes action>. Win:7.0
message action button flag of <bes action> | Plain | <boolean> | Returns the value of the message action button flag, one of the settings that control the pre-action user interface. Win:6.0
message allow cancel flag of <bes action> | Plain | <boolean> | Returns the value of the message allow cancel flag, one of the settings that control the pre-action user interface. Win:6.0
message postpone delay of <bes action> | Plain | <time interval> | Returns the value of the message postpone delay flag, one of the settings that control the pre-action user interface. Win:6.0
message text of <bes action> | Plain | <string> | Returns the value of the message text flag, one of the settings that control the pre-action user interface. Win:6.0
message timeout delay of <bes action> | Plain | <time interval> | Returns the timeout delay assigned to the action message: 'Automatically close message box and run action after…'. The time can vary from 1 minute to 30 days. Win:6.0
message title of <bes action> | Plain | <string> | Returns the value of the message title flag, one of the settings that control the pre-action user interface. Win:6.0
middle action of <bes action> | Plain | <bes action> | For a start action this iterates over the list of <action> objects that make up the group. Win:6.0
multiple flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a multiple action (see single flag of <bes action>). Win:6.0
name of <bes action> | Plain | <string> | Returns the name of the specified BES action. Win:6.0
offer category of <bes action> | Plain | <string> | Returns the user-defined offer category of the specified bes action. Win:7.2
offer description html of <bes action> | Plain | <html> | Returns the offer description of the specified bes action as an html string. This description is what appears to the client when the action executes. Win:7.2
offer flag of <bes action> | Plain | <boolean> | Returns the offer flag of the specified bes action as a boolean TRUE/FALSE. TRUE indicates that the action has an attached offer to present to the client. Win:7.2
operator site flag of <bes action> | Plain | <boolean> | Returns TRUE if the action is propagated from a non-master operator's site. Win:6.0
parameter <string> of <bes action> | Named | <string> | Some Fixlets allow the Console Operator to customize the Action. When they are triggered, the BES Console displays a dialog prompting the user for certain Action parameters. For a given Action, this Inspector returns value of the parameter specified by <string>. Win:7.0
parameter of <bes action> | Plain | <bes action parameter> | Returns the parameter(s) for the specified BES Action. An action parameter has two inspectable properties: a name and a value. Parameters are embedded in Actions to allow the Console user to supply a custom value. Win:7.0
parent group of <bes action> | Plain | <bes action> | Returns the parent group action for the specified group action member. Win:7.0
postaction allow cancel flag of <bes action> | Plain | <boolean> | Returns the value of the allow cancel flag, one of the settings that control the post-action user interface. Win:6.0
postaction force delay of <bes action> | Plain | <time interval> | Returns the value of the force delay flag, one of the settings that control the post-action user interface. Win:6.0
postaction message text of <bes action> | Plain | <string> | Returns the value of the message text flag, one of the settings that control the post-action user interface. Win:6.0
postaction message title of <bes action> | Plain | <string> | Returns the value of the message title flag, one of the settings that control the post-action user interface. Win:6.0
postaction postpone delay of <bes action> | Plain | <time interval> | Returns the value of the postpone delay flag, one of the settings that control the post-action user interface. Win:6.0
reapplication interval of <bes action> | Plain | <time interval> | Returns the time period specified between applications of the given BES Action. Win:7.0
reapplication limit of <bes action> | Plain | <integer> | Returns the maximum number of times the action will be reapplied. If the action is not set to be reapplied, then this will return a "non-existent" error. Win:6.0
reapply flag of <bes action> | Plain | <boolean> | Returns TRUE if the reapply flag was set for the specified BES Action. Win:7.0
reported computer set of <bes action> | Plain | <bes computer set> | Returns a list of all the computers that have reported for the specified BES Action. The list is formatted as a mathematical set. Win:7.0
require user absence of <bes action> | Plain | <boolean> | Returns TRUE if the action requires that the user be absent to execute the specified action. Win:6.0
require user presence of <bes action> | Plain | <boolean> | Returns TRUE if the action requires that the user be present to execute the specified action. Win:6.0
restart flag of <bes action> | Plain | <boolean> | Returns the value of the reset flag, one of the settings that control the post-action user interface. Win:6.0
result from <bes computer> of <bes action> | Index<bes computer> | <bes action result> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result <( bes action, bes computer )>. Win:6.0
result of <bes action> | Plain | <bes action result> | Returns a bes action result object for each computer which has reported on the specified action. Win:6.0
retry delay of <bes action> | Plain | <time interval> | Returns the <time interval> object that represents the amount of time to wait before retrying after a failure. If the action is not set to delay for a time interval before retrying then this will return a "non-existent" error. Win:6.0
retry limit of <bes action> | Plain | <integer> | Returns the maximum number of times the action will be retried after failure. If the action is not set to be retried, then this will return a "non-existent" error. Win:6.0
retry wait for reboot flag of <bes action> | Plain | <boolean> | Returns the waiting period after completion of the specified action before the computer will be restarted (from 15 minutes to 30 days). Win:7.0
running message text of <bes action> | Plain | <string> | Returns the value of the running message text, one of the user interfaces that is displayed while the action is running. Win:6.0
running message title of <bes action> | Plain | <string> | Returns the value of the running message title, one of the user interfaces that is displayed while the action is running. Win:6.0
selected groups string of <bes action> | Plain | <string> | If the specified action is targeted by property, then this returns a string that contains a tree representation of the items that were selected. Win:6.0
set of <bes action> | Plain | <bes action set> | Converts the specified BES Action list to a set that can be arithmetically manipulated. Win:7.0
settings flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a settings action. Win:6.0
show message flag of <bes action> | Plain | <boolean> | Returns the value of the message flag, one of the settings that control the pre-action user interface. Win:6.0
show running message flag of <bes action> | Plain | <boolean> | Returns the value of the running message flag, one of the user interfaces that is displayed while the action is running. Win:6.0
shutdown flag of <bes action> | Plain | <boolean> | Returns the value of the shutdown flag, one of the settings that control the post-action user interface. Win:6.0
single flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a single action (see multiple flag of <bes action>). Win:6.0
source fixlet of <bes action> | Plain | <bes fixlet> | Returns the <bes fixlet> object that was the source of the specified action. Win:6.0
source relevance of <bes action> | Plain | <string> | Returns the original relevance expression for this action. Win:6.0
start date of <bes action> | Plain | <date> | Returns the starting <date> for the specified action. Along with the end date, this defines the allowed time range for execution of the action. Win:6.0
start flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a start action. Win:6.0
start time_of_day of <bes action> | Plain | <time of day> | Returns the starting <time of day> for the specified action. Along with the end time of day, this defines the allowed time range for execution of the action. Win:6.0
state of <bes action> | Plain | <string> | Returns the current state of the specified action as a string. It should be one of the following: • Open • Stopped • Expired. Win:6.0
stopper of <bes action> | Plain | <bes user> | If the specified action has been stopped, this Inspector returns the user who stopped it. Win:7.0
subscription flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is a subscription action. Win:6.0
success on custom relevance of <bes action> | Plain | <boolean> | Returns TRUE if the success of the action is determined by the custom relevance becoming false (no longer relevant). Win:6.0
success on original relevance of <bes action> | Plain | <boolean> | Returns TRUE if the success of the action is determined by the original relevance becoming false (no longer relevant). Win:6.0
success on run to completion of <bes action> | Plain | <boolean> | Returns TRUE if the success of the action is determined by the completion of all lines of the action script. Win:6.0
targeted by id flag of <bes action> | Plain | <boolean> | Returns a boolean TRUE if the specified action is targeted by an ID Flag. Win:6.0
targeted by list flag of <bes action> | Plain | <boolean> | Returns a boolean TRUE if the specified action is targeted by a List Flag. Win:6.0
targeted by property flag of <bes action> | Plain | <boolean> | Returns a boolean TRUE if the specified action is targeted by a Property Flag. Win:6.0
targeted computer of <bes action> | Plain | <bes computer> | If the specified action is targeted by ID, then this Inspector returns an iterated list of the targeted BES computer objects. Win:6.0
targeted computer set of <bes action> | Plain | <bes computer set> | Returns the list (formatted as a set) of targeted computers associated with the specified BES Action. Win:7.0
targeted list of <bes action> | Plain | <string> | If the specified action is targeted by list, then this returns the relevant BES computer names, concatenated into a single string. Win:6.0
targeted name of <bes action> | Plain | <string> | If the specified action is targeted by list, then this returns the relevant BES computer names as an iterated list with one string for each name. Win:6.0
targeting method of <bes action> | Plain | <string> | Returns one of the strings "By Property", "By Computer ID", "By List", or "Untargeted". Win:6.0
targeting relevance of <bes action> | Plain | <string> | Returns the relevance string that is being used to target the action. Win:6.0
temporal distribution of <bes action> | Plain | <time interval> | Returns the <time interval> over which the execution (and file downloads) of this action will be distributed. Win:6.0
time issued of <bes action> | Plain | <time> | Returns the time when the action was issued. Win:6.0
time range end of <bes action> | Plain | <time of day> | Returns the ending <time of day> for the specified action. Along with the starting time of day, this defines the allowed time range for execution of the action. Win:6.0
time range start of <bes action> | Plain | <time of day> | Returns the starting <time of day> for the specified action. Along with the ending time of day, this defines the allowed time range for execution of the action. Win:6.0
time stopped of <bes action> | Plain | <time> | If the specified action has been stopped, this Inspector returns the time it was stopped. Win:7.0
unique value of <bes action> | Plain | <bes action with multiplicity> | Returns the unique values of a given list of <bes action> types, removing duplicates and sorting by value. Win:7.1
untargeted flag of <bes action> | Plain | <boolean> | Returns a boolean TRUE if the specified action is untargeted. Win:6.0
urgent flag of <bes action> | Plain | <boolean> | Returns TRUE if the specified action is marked urgent, which means that it will be executed by the client before all non-urgent actions. Win:6.0

Operators

Key phrase | Return Type | Description
<bes action> = <bes action> | <boolean> | Compares two BES Actions and returns TRUE if they are equal. Win:7.1

Examples

names of hidden bes actions
Returns the list of currently hidden BES Actions.

links (h1 of name of it) of bes actions
Creates clickable links listing all the current BES Actions, displaying the Action names in headline format.

links (name of it & "(" & id of it as string & ")")) of bes actions
Creates clickable links listing all the current BES Actions, formated as name and ID.

(br & html "Click <A href='" & link href of it & html "'>here</A> to open action " & id of it as string) of bes actions
Creates clickable links listing all the current BES Actions, formated with a descriptive prompt and an embedded link, such as:
• Click here to open action 123456.

links of bes actions
Returns a set of <A> tags enclosing all the BES Actions in html format, creating a series of clickable Action links.

detailed status of result from (bes computer whose (id of it is 1234567)) of (bes action whose (id of it is 1234))
Returns the detailed status of the specified action on the given computer.

detailed statuses of results of (bes action whose (id of it is 1234))
Returns a detailed status list containing the results of bes actions with the specified id.

size of (set of bes actions)
Returns the current number of BES Actions.


BES Action Parameter

A Fixlet can incorporate parameters in its associated Action(s). When the Fixlet becomes relevant to the network, the BES Console will prompt the user for the value of the parameter. For example, a Fixlet Action might need to start a Windows service specified by the Console user. When the the Action is taken, the Console would prompt for the name of the service. That value would then be passed down to the BES Client and substituted into the local Action script upon execution.

Creation Methods

Key Phrase | Form | Description
parameter of <bes action> | Plain | Returns the parameter(s) for the specified BES Action. An action parameter has two inspectable properties: a name and a value. Parameters are embedded in Actions to allow the Console user to supply a custom value. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
name of <bes action parameter> | Plain | <string> | Returns the name of the specified Action parameter. Win:7.0
value of <bes action parameter> | Plain | <string> | Returns the value associated with the specified Action parameter. Win:7.0

Examples

names of parameters of bes action whose (name of it contains "Download")
Returns the parameter names of bes actions with "Download" in the name.


BES Action Result

These Inspectors examine the results of BES Actions, which can be used to make reports.

Creation Methods

Key Phrase | Form | Description
action result of <bes computer> | Plain | Returns the results of BES actions that have occurred on the specified computer. Win:6.0
result <( bes action, bes computer )> | Index<( bes action, bes computer )>Global | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result from <bes action> of <bes computer>. Win:6.0
result <( bes computer, bes action )> | Index<( bes computer, bes action )>Global | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result from <bes action> of <bes computer>. Win:6.0
result from <bes action> of <bes computer> | Index<bes action> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result <( bes action, bes computer )>. Win:6.0
result from <bes computer> of <bes action> | Index<bes computer> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result <( bes action, bes computer )>. Win:6.0
result of <bes action> | Plain | Returns a bes action result object for each computer which has reported on the specified action. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
action of <bes action result> | Plain | <bes action> | Returns the action corresponding to the specified action result. Win:6.0
apply count of <bes action result> | Plain | <integer> | Returns the number of times (as an integer) that the specified BES action result has been initiated on the client. Win:6.0
computer of <bes action result> | Plain | <bes computer> | Returns the computer(s) that the specified action result applies to. Win:6.0
detailed status of <bes action result> | Plain | <string> | Returns a string describing the detailed status of the specified action result on this computer. Win:6.0
line number of <bes action result> | Plain | <integer> | Returns the current line number of the action script that is being executed on the client computer. Win:6.0
retry count of <bes action result> | Plain | <integer> | Returns the number of times (as an integer) that the specified BES action result has been retried on the client. Win:6.0
status of <bes action result> | Plain | <bes action status> | Returns the <bes action state> object corresponding to the specified action result on the client computer. Win:6.0

Examples

detailed status of result from (bes computer whose (id of it is 1234567)) of (bes action whose (id of it is 1234))
Returns the detailed status of the specified action on the given computer.

detailed statuses of results of (bes action whose (id of it is 34))
Returns the detailed result status of the specified BES Action.

detailed statuses of results of (bes action whose (id of it is 1234))
Returns a detailed report on the BES Action result for each computer reporting on the specified Action.


BES Action Set

These Inspectors return the iterated list of BES Actions, converted into a set to make it easy to do set arithmetic with the list.

Creation Methods

Key Phrase | Form | Description
action set of <bes filter> | Plain | Returns a filtered set of Actions. Given an Action filter that specifies "Name contains 'Custom Action'", this Inspector returns the set of BES Actions with 'Custom Action' in the name. Win:7.0
bes action set | PlainGlobal | An iteration over the BES Actions represented as a mathematical set. Win:7.0
hidden bes action set | PlainGlobal | Retrieves the set (iterated list) of hidden BES Actions. Win:7.0
intersection of <bes action set> | Plain | Returns the intersection of multiple BES Action sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
issued action set of <bes user> | Plain | Returns all actions, including hidden actions, issued by the specified user. This list is formatted as a mathematical set. Win:7.0
member action set of <bes action> | Plain | Returns the individual member actions for the specified multiple action group parent, <bes action>. Win:7.0
reported action set of <bes computer> | Plain | Returns a list of all the reported Actions for the specified computer. These may be Actions that are running, fixed, failed, etc. The list is formatted as a mathematical set. Win:7.0
set of <bes action> | Plain | Creates a set from an iterated list of BES Actions. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
top level bes action set | PlainGlobal | Returns all top level actions as a mathematical set. Does not include actions that are normally hidden, and sub-actions of a multiple action group. Win:7.0
union of <bes action set> | Plain | Returns the union of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes action set> as xml | Cast | <utf8 string> | Casts a BES Action set as an XML document, for submission to to the ImportXML API in the Console. It can only be used in the Console using the EvaluateRelevance API, not the <?relevance ?> interface. Win:7.0
element of <bes action set> | Plain | <bes action> | Returns the unique elements of the specified <bes action set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes action set> | Plain | <bes action set> | Returns the intersection of multiple BES Action sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes action set> | Plain | <integer> | Returns the number of unique elements in the specified BES Action set. Win:7.0
union of <bes action set> | Plain | <bes action set> | Returns the union of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes action set> {op} <bes action set> | <bes action set> | Where {op} is one of: -, *, +. Win:7.0
<bes action set> = <bes action set> | <boolean> | Returns TRUE if the two bes action sets are equivalent. Win:7.0

Examples

names of elements of (set of bes actions)
Returns a list of names of each of the current BES Actions.

names of elements of bes action set
Returns the names of all the BES Actions.


BES Action Status

These Inspectors return information about the status of BES actions, such as whether it is running, evaluating, expired, etc.

Creation Methods

Key Phrase | Form | Description
bes action status constrained | PlainGlobal | Returns the BES action status corresponding to constraints. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status download failed | PlainGlobal | Returns the BES action status corresponding to failed downloads. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status error | PlainGlobal | Returns the BES action status corresponding to errors. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status evaluating | PlainGlobal | Returns the BES action status corresponding to evaluation. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status expired | PlainGlobal | Returns the BES action status corresponding to expiration. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status failed | PlainGlobal | Returns the BES action status corresponding to failure. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status fixed | PlainGlobal | Returns the BES action status corresponding to successful fixes. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status invalid signature | PlainGlobal | Returns the BES action status corresponding to invalid signatures. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status irrelevant | PlainGlobal | Returns the BES action status corresponding to irrelevance This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status locked | PlainGlobal | Returns the BES action status corresponding to locking. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status offers disabled | PlainGlobal | Returns the BES action status corresponding to disabled offers. This result can be cast to a <string> format to give the text as shown in the console. Win:7.0
bes action status pending downloads | PlainGlobal | Returns the BES action status corresponding to pending downloads. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending login | PlainGlobal | Returns the BES action status corresponding to pending logins. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending message | PlainGlobal | Returns the BES action status corresponding to pending messages. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status pending offer | PlainGlobal | Returns the BES action status corresponding to pending offers. This result can be cast to a <string> format to give the text as shown in the console. Win:7.0
bes action status pending restart | PlainGlobal | Returns the BES action status corresponding to pending restarts. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status postponed | PlainGlobal | Returns the BES action status corresponding to postponements. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status running | PlainGlobal | Returns the BES action status corresponding to whether or not it is running. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status unreported | PlainGlobal | Returns a constant representing an action status of 'not reported'. Win:6.0
bes action status user cancelled | PlainGlobal | Returns the BES action status corresponding to user cancelation. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
bes action status waiting | PlainGlobal | Returns the BES action status corresponding to waiting. This result can be cast to a <string> format to give the text as shown in the console. Win:6.0
status of <bes action result> | Plain | Returns the <bes action state> object corresponding to the specified action result on the client computer. Win:6.0

Note

The status returned from a BES Action can be cast into a string format to give the text shown in the console. This can be compared for equality using the following constants:

bes action status fixed
bes action status running
bes action status evaluating
bes action status failed
bes action status user cancelled
bes action status download failed
bes action status locked
bes action status waiting
bes action status pending downloads
bes action status pending restart
bes action status pending message
bes action status pending login
bes action status constrained
bes action status expired
bes action status postponed
bes action status invalid signature
bes action status error
bes action status not relevant
bes action status not reported

Properties

Key Phrase | Form | Return Type | Description
<bes action status> as string | Cast | <string> | Casts an action status as a string. Win:6.0

Operators

Key phrase | Return Type | Description
<bes action status> = <bes action status> | <boolean> | Compares two action status objects, and returns a boolean TRUE or FALSE. Win:6.0


BES Action with Multiplicity

These Inspectors deal with arrays of bes actions, allowing you to pluck out unique actions and count them. These objects are derived from bes action types.

Creation Methods

Key Phrase | Form | Description
unique value of <bes action> | Plain | Returns the unique values of a given list of <bes action> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes action with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes action> types. Win:7.1


BES Activation

These Inspectors examine the various Analyses that have been activated on the networked BES Clients.

Creation Methods

Key Phrase | Form | Description
activation of <bes fixlet> | Plain | If the specified Fixlet message is from an analysis, this Inspector returns a list of all of its activations. Win:6.0
best activation of <bes fixlet> | Plain | If the specified Fixlet message is from an analysis, then this Inspector returns the activation which is most appropriate for the current console user. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
active flag of <bes activation> | Plain | <boolean> | Returns TRUE if the specified activation is active, FALSE if it has been stopped. Win:6.0
analysis of <bes activation> | Plain | <bes fixlet> | Returns the source analysis fixlet that spawned the specified activation. Win:6.0
creation time of <bes activation> | Plain | <time> | Returns the time when the given BES Analysis activation was created. Win:7.1
database id of <bes activation> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES Activation resides. Win:6.0
id of <bes activation> | Plain | <integer> | Returns the numeric ID of the BES activation object. Win:6.0
issuer of <bes activation> | Plain | <bes user> | Returns the <bes user> object corresponding to the user who issued the specified activation. Win:6.0
modification time of <bes activation> | Plain | <time> | Returns the time when the given BES Analysis activation was last modified. Win:7.1
name of <bes activation> | Plain | <string> | Returns the name of the specified BES activation as a string. Win:6.0


BES Baseline Component

These Inspectors return the individual components of a Baseline, such as Fixlets, Tasks or other Baselines.

Creation Methods

Key Phrase | Form | Description
component of <bes baseline component group> | Plain | Returns a list of the components of the specified BES Baseline component group. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
action of <bes baseline component> | Plain | <bes fixlet action> | Returns the Action corresponding to the specified BES Baseline component. Win:7.0
applicable computer count of <bes baseline component> | Plain | <integer> | Returns the number of computers (regardless of locking) that have reported that the specified BES Baseline component is relevant. Win:7.0
applicable computer set of <bes baseline component> | Plain | <bes computer set> | Returns the set of computers where the given baseline component(s) is applicable, i.e., those computers where the baseline component is relevant. Win:7.0
id of <bes baseline component> | Plain | <integer> | Returns the numeric ID of the specified BES Baseline component. Win:7.0
include in relevance flag of <bes baseline component> | Plain | <boolean> | When you define a Baseline by adding components, the default is to OR the relevance from each baseline component with the overall Baseline relevance. Thus, the multiple Action group will be relevant on machines where any of the components are relevant. If you add a component that is always relevant (such as "true"), you might want to uncheck the "Baseline will be relevant on applicable computers where this component is relevant" checkbox (click the + next to the component name to see it). This Inspector returns TRUE if this box is checked for the specified component. Win:7.0
name of <bes baseline component> | Plain | <string> | Returns the name of the specified BES Baseline component. Win:7.0
relevance of <bes baseline component> | Plain | <string> | Returns the relevance expression used to determine if the specified BES Baseline component is applicable on a client computer. Win:7.0
source fixlet of <bes baseline component> | Plain | <bes fixlet> | Returns the BES Fixlet(s) associated with the specified BES Baseline component. Win:7.0
unknown computer count of <bes baseline component> | Plain | <integer> | Returns the number of unknown computers associated with the specified baseline component. Win:7.0
unknown computer set of <bes baseline component> | Plain | <bes computer set> | Returns the unknown computers associated with the specified baseline component. The list is formatted as a set for mathematical manipulations, included intersections and unions. Win:7.0


BES Baseline Component Group

Baselines provide a method of grouping Actions from multiple Fixlets, Tasks, or other Baselines. Once a Baseline is defined (in the BES Console) the Actions are all grouped for simulataneous application. This technique allows you to form natural groupings of Actions for a single-click deployment.

Creation Methods

Key Phrase | Form | Description
component group of <bes fixlet> | Plain | If the specified Fixlet message is a baseline, then this Inspector iterates over the component groups. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
component of <bes baseline component group> | Plain | <bes baseline component> | Returns a list of the components of the specified BES Baseline component group. Win:7.0
name of <bes baseline component group> | Plain | <string> | Returns the name(s) of the specified BES Baseline component group(s). Win:7.0


BES Client Setting

These Inspectors return the name, value and scope of BES Client settings. These are named variables that are used to report on and control various client behaviors.

Creation Methods

Key Phrase | Form | Description
client setting of <bes computer> | Plain | Returns the client setting(s) for the specified computer. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
name of <bes client setting> | Plain | <string> | Returns the name of the specified BES client setting. Win:7.0
scope of <bes client setting> | Plain | <string> | Depending on the scope of the specified Client setting, returns 'Local' or a site URL. Win:7.0
value of <bes client setting> | Plain | <string> | Returns the value associated with the specified BES Client setting. Win:7.0

Examples

(name of it, scope of it, value of it) of client settings of bes computers
Returns a list containing the name, scope and value for each of the BES Client settings for each of the BES computers.


BES Comment

These Inspectors return the text, timestamp and author of BES Comments.

Creation Methods

Key Phrase | Form | Description
comment of <bes action> | Plain | Returns the comment associated with the specified BES Action. Win:7.0
comment of <bes computer> | Plain | Returns the comments assigned to the specified BES Computer. Win:7.0
comment of <bes fixlet> | Plain | Returns the comments assigned to the specified BES Fixlet message. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
author of <bes comment> | Plain | <bes user> | Returns the author of the specified BES Comment. Win:7.0
deleted flag of <bes comment> | Plain | <boolean> | Returns TRUE if the specified BES Comment has been deleted. Win:7.0
text of <bes comment> | Plain | <string> | Returns the text of the specified BES Comment. Win:7.0
timestamp of <bes comment> | Plain | <time> | Returns the time that the specified BES Comment was posted. Win:7.0

Examples

(name of author of it, text of it) of comments of bes fixlets
Returns a list of all the comments attached to the BES Fixlets, along with the author's name.


BES Computer

These Inspectors return lists of the computers currently visible through the BES Console.

Creation Methods

Key Phrase | Form | Description
administered computer of <bes user> | Plain | Returns the computer(s) currently administered by the specified BES User. Win:7.0
applicable computer of <bes fixlet> | Plain | Returns a list of all of the <bes computer> objects reporting that the specified Fixlet message is relevant. Win:6.0
bes computer | PlainGlobal | Returns a list of all the BES computers visible to the current console user. Win:6.0
computer of <bes action result> | Plain | Returns the computer(s) that the specified action result applies to. Win:6.0
computer of <bes fixlet result> | Plain | Returns the BES computer associated with the specified Fixlet result. Win:6.0
computer of <bes property result> | Plain | Returns the computer corresponding to the specified BES property result. Win:6.0
current computer | PlainGlobal | This Inspector returns the computer that is currently selected by a right-click in the BES Console. This Inspector is designed to assist you in the creation of extended Context menu applications. Win:6.0
element of <bes computer set> | Plain | Returns the unique elements of the specified <bes computer set>, removing duplicates and sorting by value. Win:7.0
member of <bes computer group> | Plain | Returns the set of computers that comprise the specified BES Computer Group. Win:7.0
subscribed computer of <bes site> | Plain | Returns the list of computers that are subscribed to the specified BES site. Win:7.0
targeted computer of <bes action> | Plain | If the specified action is targeted by ID, then this Inspector returns an iterated list of the targeted BES computer objects. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
action result of <bes computer> | Plain | <bes action result> | Returns the results of BES actions that have occurred on the specified computer. Win:6.0
active directory path of <bes computer> | Plain | <distinguished name> | Returns the result of the 'Active Directory Path' property of the specified computer. Win:7.0
administrator <bes user> of <bes computer> | Index<bes user> | <boolean> | Returns TRUE if the specified user is an administrator of the given computers. Win:7.0
administrator of <bes computer> | Plain | <bes user> | Iterates over the users who have administrative rights on this computer. Win:7.0
administrator set of <bes computer> | Plain | <bes user set> | Returns the set of users who have administrative rights on this computer. Win:7.0
client setting of <bes computer> | Plain | <bes client setting> | Returns the client setting(s) for the specified computer. Win:7.0
comment of <bes computer> | Plain | <bes comment> | Returns the comments assigned to the specified BES Computer. Win:7.0
cpu of <bes computer> | Plain | <string> | Returns the result of the 'CPU' Property for the specified computer. Win:7.0
database id of <bes computer> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES computer resides. Win:6.0
database name of <bes computer> | Plain | <string> | In a Web Reports context, this Inspector returns the name (as a string) of the database containing the specified BES computer. Win:6.0
hostname of <bes computer> | Plain | <string> | Returns the result of the 'DNS Name' Property for the specified computer. Win:7.0
id of <bes computer> | Plain | <integer> | Returns the numeric ID unique to the specified BES computer. Win:6.0
ip address of <bes computer> | Plain | <ipv4 address> | Returns the result of the 'IP Address' property of the specified computer. Win:7.0
last report time of <bes computer> | Plain | <time> | Returns the time of the last report submitted by the specified BES computer. Win:6.0
link <html> of <bes computer> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the given computer's document (in the BES Console) or its description page (in Web Reports). Win:6.0
link <string> of <bes computer> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the given computer's document (in the BES Console) or its description page (in Web Reports). Win:6.0
link href of <bes computer> | Plain | <string> | The link href property does not return an <A> tag but rather returns the value of the href attribute of the <A> tag that would be constructed by the other link inspectors. This allows you to create more flexible linking formats. (See link of <bes computer>). Note that link href returns a string, not an HTML string. Win:6.0
link of <bes computer> | Plain | <html> | Returns an HTML string containing an <A> tag that when clicked will open the given computer's document (in the BES Console) or its description page (in Web Reports). Win:6.0
locked flag of <bes computer> | Plain | <boolean> | Returns the result of the 'Locked' property of the specified computer. Win:7.0
name of <bes computer> | Plain | <string> | Returns the value of the specified 'Computer Name' property for the specified BES computer. Win:6.0
operating system of <bes computer> | Plain | <string> | Returns the result of the 'OS' Property for the specified computer. Win:7.0
property result of <bes computer> | Plain | <bes property result> | Returns a list of all of the <bes property result> objects that the specified BES computer has reported. Win:6.0
relay distance of <bes computer> | Plain | <integer> | Returns the result of the 'Distance to BES Relay' property for the specified computer. Win:7.0
relay hostname of <bes computer> | Plain | <string> | Returns the result of the 'Relay Name of Client' property for the specified computer. Win:7.0
relay selection method of <bes computer> | Plain | <string> | Returns the result of the 'BES Relay Selection Method' property for the specified computer. Win:7.0
relay server flag of <bes computer> | Plain | <boolean> | Returns TRUE iff the result of the 'BES Relay Server Installed' property for the specified computer indicates that the BES Relay is installed. Win:7.0
relay server of <bes computer> | Plain | <string> | Returns the result of the 'Relay' property of the specified computer. Win:7.0
relevant <bes fixlet> of <bes computer> | Index<bes fixlet> | <boolean> | Returns TRUE if the given Fixlet message is relevant on the specified computer. Win:6.0
relevant fixlet of <bes computer> | Plain | <bes fixlet> | Returns a list of all the <bes fixlet> objects that the specified computer has reported are relevant. Win:6.0
relevant fixlet set of <bes computer> | Plain | <bes fixlet set> | Returns a list of all the <bes fixlet> objects that the specified computer has reported are relevant. The list is formatted as a mathematical set. Win:7.0
reported action set of <bes computer> | Plain | <bes action set> | Returns a list of all the reported Actions for the specified computer. These may be Actions that are running, fixed, failed, etc. The list is formatted as a mathematical set. Win:7.0
reported property set of <bes computer> | Plain | <bes property set> | Returns a list of all the BES properties that have reported on the specified computer(s). The list is formatted as a mathematical set. Win:7.0
result from <bes action> of <bes computer> | Index<bes action> | <bes action result> | Returns a bes action result object for the given computer and action. This command is a variant of other result Inspectors, such as result <( bes action, bes computer )>. Win:6.0
result from <bes fixlet> of <bes computer> | Index<bes fixlet> | <bes fixlet result> | Returns a Fixlet result for the given computer and Fixlet. Win:7.0
result from <bes property> of <bes computer> | Index<bes property> | <bes property result> | Returns the result of the specified BES property and computer. Win:6.0
root server flag of <bes computer> | Plain | <boolean> | Returns TRUE iff the result of the 'BES Relay Server Installed' property for the specified computer indicates that it's a BES root server. Win:7.0
root server of <bes computer> | Plain | <string> | Returns the result of the 'BES Root Server' property of the specified computer. Win:7.0
set of <bes computer> | Plain | <bes computer set> | Converts the specified BES computer list to a set that can be arithmetically manipulated. Win:7.0
unique value of <bes computer> | Plain | <bes computer with multiplicity> | Returns the unique values of a given list of <bes computer> types, removing duplicates and sorting by value. Win:7.1

Operators

Key phrase | Return Type | Description
<bes computer> = <bes computer> | <boolean> | Compares two BES Computer types and returns TRUE if they are equal. Win:7.1

Examples

names of administered computers of bes user whose (name of it is "Joe")
Returns the list of computers currently administered by the BES User named Joe.

links (h1 of name of it) of bes computers
Returns a list of HTML strings, each with an HTML link named after the BES computer and formatted as a header (h1).

links (name of it & "(" & id of it as string & ")")) of bes computers
Returns an HTML string that will print the name and ID of the computer inside a clickable <A> tag.

(br & html "Click <A href='" & link href of it & html "'>here</A> to open computer " & id of it as string) of bes computers
Returns an html string such as 'Click here to open computer 89201' message that, when clicked, will open the corresponding BES computer document.

detailed status of result from (bes action whose (id of it is 1234)) of (bes computer whose (id of it is 1234567))
Returns the detailed status of the specified action on the given computer.

size of (set of bes computers)
Returns the current number of BES computers.


BES Computer Group

These Inspectors return an iterated list of computer groups, as defined in the BES Console.

Creation Methods

Key Phrase | Form | Description
bes computer group | PlainGlobal | Returns a list of the global computer groups. Win:7.0
element of <bes computer group set> | Plain | Returns the unique elements of the specified <bes computer group set>, removing duplicates and sorting by value. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes computer group> as xml | Cast | <utf8 string> | Converts the specified BES computer group to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
automatic flag of <bes computer group> | Plain | <boolean> | Returns the value of the 'Automatic' flag corresponding to the specified BES Computer Group. Groups can be manual, automatic or ad-hoc. Win:7.0
client evaluated flag of <bes computer group> | Plain | <boolean> | Returns TRUE if the specified BES computer group is determined by client acknowledgement. Win:7.0
database id of <bes computer group> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES computer group resides. Win:7.0
id of <bes computer group> | Plain | <integer> | Returns the numeric ID corresponding to the specified BES Computer Group. Win:7.0
manual flag of <bes computer group> | Plain | <boolean> | Returns the value of the 'Manual' flag corresponding to the specified BES Computer Group. Groups can be manual, automatic or ad-hoc. Win:7.0
member of <bes computer group> | Plain | <bes computer> | Returns the set of computers that comprise the specified BES Computer Group. Win:7.0
member set of <bes computer group> | Plain | <bes computer set> | Returns the computer set that comprise the specified BES Computer Group. Win:7.0
name of <bes computer group> | Plain | <string> | Returns the name corresponding to the specified BES Computer Group. Win:7.0
set of <bes computer group> | Plain | <bes computer group set> | Converts the specified BES computer group list to a set that can be arithmetically manipulated. Win:7.0
site of <bes computer group> | Plain | <bes site> | Returns the site corresponding to the specified BES Computer Group. Win:7.0
unique value of <bes computer group> | Plain | <bes computer group with multiplicity> | Returns the unique values of a given list of <bes computer group> types, removing duplicates and sorting by value. Win:7.1

Operators

Key phrase | Return Type | Description
<bes computer group> = <bes computer group> | <boolean> | Compares two BES Computer Group types and returns TRUE if they are equal. Win:7.1

Examples

names of bes computer groups
Returns a list of the currently defined computer groups, by name.

size of (set of bes computer groups)
Returns the current number of computer groups.


BES Computer Group Set

These Inspectors convert an iterated list of computer groups into a set, which allows you to perform intersections, unions and other mathematical operations on them.

Creation Methods

Key Phrase | Form | Description
bes computer group set | PlainGlobal | An iteration over the BES computer groups, represented as a mathematical set. Win:7.0
intersection of <bes computer group set> | Plain | Returns the intersection of multiple BES computer group sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
set of <bes computer group> | Plain | Creates a set from an iterated list of BES Computer Groups. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
union of <bes computer group set> | Plain | Returns the union of multiple BES computer group sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes computer group set> as xml | Cast | <utf8 string> | Converts the specified set of BES computer groups to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
element of <bes computer group set> | Plain | <bes computer group> | Returns the unique elements of the specified <bes computer group set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes computer group set> | Plain | <bes computer group set> | Returns the intersection of multiple BES computer group sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes computer group set> | Plain | <integer> | Returns the number of unique BES Computer Groups in the specified set. Win:7.0
union of <bes computer group set> | Plain | <bes computer group set> | Returns the union of multiple BES computer group sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes computer group set> {op} <bes computer group set> | <bes computer group set> | Operates on two sets of BES computer groups, where {op} is one of: -, *, +. Minus subtracts the elements of one set from the other, multiply performs an intersection and plus performs a union. Win:7.0
<bes computer group set> = <bes computer group set> | <boolean> | Compares two sets of BES computer groups for equivalence. Win:7.0

Examples

names of elements of intersection of administered computer sets of bes users whose (name of it is "joe" or name of it is "sue")
Returns a list of the names of those computers administered by both Sue and Joe.


BES Computer Group with Multiplicity

These Inspectors deal with arrays of bes computer groups, allowing you to pluck out unique computer groups and count them. These objects are derived from ordinary bes computer groups.

Creation Methods

Key Phrase | Form | Description
unique value of <bes computer group> | Plain | Returns the unique values of a given list of <bes computer group> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes computer group with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes computer group> types. Win:7.1


BES Computer Set

These Inspectors convert an iterated list of computers into a set, which allows you to perform intersections, unions and other mathematical operations on them.

Creation Methods

Key Phrase | Form | Description
administered computer set of <bes user> | Plain | Returns the set of computers that are administerable by the specified BES user. Win:7.0
applicable computer set of <bes baseline component> | Plain | Returns the set of computers where the given baseline component(s) is applicable, i.e., those computers where the baseline component is relevant. Win:7.0
applicable computer set of <bes fixlet> | Plain | Returns the set of computers where the given Fixlet(s) is applicable, i.e., those computers where the Fixlet is relevant. Win:7.0
bes computer set | PlainGlobal | An iteration over the BES computers, represented as a mathematical set. Win:7.0
computer set of <bes filter> | Plain | Returns a filtered set of Computers. Given a Computer filter that specifies "OS contains 'Win'", this Inspector returns the set of Windows Computers. Win:7.0
intersection of <bes computer set> | Plain | Returns the intersection of multiple BES computer sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
member set of <bes computer group> | Plain | Returns the computer set that comprise the specified BES Computer Group. Win:7.0
reported computer set of <bes action> | Plain | Returns a list of all the computers that have reported for the specified BES Action. The list is formatted as a mathematical set. Win:7.0
reported computer set of <bes property> | Plain | Returns a list of all the computers that have reported for the specified BES property. The list is formatted as a mathematical set. Win:7.0
set of <bes computer> | Plain | Creates a set from an iterated list of BES computers. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
subscribed computer set of <bes site> | Plain | Returns the list of computers that are subscribed to the specified BES site. The list is formatted as a mathematical set for easier manipulation. Win:7.0
targeted computer set of <bes action> | Plain | Returns the list (formatted as a set) of targeted computers associated with the specified BES Action. Win:7.0
union of <bes computer set> | Plain | Returns the union of multiple BES computer sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
unknown computer set of <bes baseline component> | Plain | Returns the unknown computers associated with the specified baseline component. The list is formatted as a set for mathematical manipulations, included intersections and unions. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
element of <bes computer set> | Plain | <bes computer> | Returns the unique elements of the specified <bes computer set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes computer set> | Plain | <bes computer set> | Returns the intersection of multiple BES computer sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes computer set> | Plain | <integer> | Returns the number of unique BES Computers in the specified set. Win:7.0
union of <bes computer set> | Plain | <bes computer set> | Returns the union of multiple BES computer sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes computer set> {op} <bes computer set> | <bes computer set> | Where {op} is one of: -, *, +. Win:7.0
<bes computer set> = <bes computer set> | <boolean> | Compares two sets of BES computers for equivalence. Win:7.0

Examples

size of union of applicable computer sets of bes fixlets whose ((source severity of it is "Critical") and (current date - source release date of it > 7 * day)) as floating point / size of bes computer set as floating point
Computes the ratio of computers which have at least one relevant critical fixlet released more than 1 week ago.


BES Computer with Multiplicity

These Inspectors deal with arrays of bes computers, allowing you to pluck out unique computers and count them. These objects are derived from ordinary bes computers.

Creation Methods

Key Phrase | Form | Description
unique value of <bes computer> | Plain | Returns the unique values of a given list of <bes computer> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes computer with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes computer> types. Win:7.1


BES Deployment Option

These options allow you to customize the behavior of your BES deployment. They are set by the system administrator in the BES Admin Tool, under the Advanced Options tab.

Creation Methods

Key Phrase | Form | Description
bes deployment option | PlainGlobal | Returns the current deployment options as listed in the BES Admin Tool, under the Advanced Options tab. You can add your own name/value pairs to this list. Win:7.0
bes deployment option <string> | NamedGlobal | Returns the value associated with the deployment option named by the <string>. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
database id of <bes deployment option> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES deployment option resides. Win:7.0
database name of <bes deployment option> | Plain | <string> | In the Web Reports environment, this Inspector returns the name of the database containing the specified BES deployment option. Win:7.0
name of <bes deployment option> | Plain | <string> | Returns the name of the specified BES deployment option. Win:7.0
value of <bes deployment option> | Plain | <string> | Returns the <string> value reported by this computer for the specified BES deployment option(s). Win:7.0

Examples

(name of it, value of it) of bes deployment options
Returns a list of the names and values of the current BES deployment options.


BES Filter

These Inspectors return the filters, which represent the criteria used by the Find command (Ctrl-F in the BES Console). The filters are specific to computers, computer groups, Actions, Analyses, Baselines, Unmanaged Assets, Users, Tasks or Fixlets, and are appropriately flagged.

Creation Methods

Key Phrase | Form | Description
bes filter | PlainGlobal | Returns the list of the global BES Filters, as created by the Find command (ctrl-F). Win:7.0
bes filter <integer> | NumberedGlobal | Returns the filter with the specified ID. It is the same as "bes filter whose (id of it is <integer>)". Win:7.0
element of <bes filter set> | Plain | Returns the unique elements of the specified <bes filter set>, removing duplicates and sorting by value. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
action flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Actions. Win:7.0
action set of <bes filter> | Plain | <bes action set> | Returns a filtered set of Actions. Given an Action filter that specifies "Name contains 'Custom Action'", this Inspector returns the set of BES Actions with 'Custom Action' in the name. Win:7.0
analysis flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Analyses. Win:7.0
analysis set of <bes filter> | Plain | <bes fixlet set> | Returns a filtered set of Analyses. Given an Analysis filter that specifies "Visibility equals Visible", this Inspector returns just the set of BES Analyses that are visible. Win:7.0
baseline flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Baselines. Win:7.0
baseline set of <bes filter> | Plain | <bes fixlet set> | Returns a filtered set of Baselines. Given a Baseline filter that specifies "Visibility equals Visible", this Inspector returns just the set of BES Baselines that are visible. Win:7.0
computer flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding computers. Win:7.0
computer group set of <bes filter> | Plain | <bes fixlet set> | Returns a filtered set of computer groups. Given a computer group filter that specifies "Name contains 'test'", this Inspector returns the set of computer groups that have 'test' in their name. Win:7.0
computer set of <bes filter> | Plain | <bes computer set> | Returns a filtered set of Computers. Given a Computer filter that specifies "OS contains 'Win'", this Inspector returns the set of Windows Computers. Win:7.0
fixlet flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Computers. Win:7.0
fixlet set of <bes filter> | Plain | <bes fixlet set> | Returns a filtered set of Fixlets. Given a Fixlet filter that specifies "Visibility equals Globally Hidden", this Inspector returns just the set of BES Fixlets that are globally hidden. Win:7.0
group flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding computer groups. Win:7.0
id of <bes filter> | Plain | <integer> | Returns the numeric ID unique to the specified BES filter. Win:7.0
join by intersection flag of <bes filter> | Plain | <boolean> | Returns TRUE if the various find properties are intersected (included with ALL properties) in the specified filter. Win:7.0
name of <bes filter> | Plain | <string> | Returns the name of the specified BES filter. Win:7.0
private flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES filter is marked as private. Win:7.0
set of <bes filter> | Plain | <bes filter set> | Converts the specified BES Filter list to a set that can be arithmetically manipulated. Win:7.0
task flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Tasks. Win:7.0
task set of <bes filter> | Plain | <bes fixlet set> | Returns a filtered set of Tasks. Given a Task filter that specifies "Visibility equals Locally Hidden", this Inspector returns just the set of BES Tasks that are locally hidden. Win:7.0
unique value of <bes filter> | Plain | <bes filter with multiplicity> | Returns the unique values of a given list of <bes filter> types, removing duplicates and sorting by value. Win:7.1
unmanagedasset flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Unmanaged Assets. Win:7.0
user flag of <bes filter> | Plain | <boolean> | Returns TRUE if the specified BES Filter was designed for finding Users. Win:7.0
user set of <bes filter> | Plain | <bes user set> | Returns a filtered set of Console Operators. Given a Console Operator filter that specifies "Name contains Joe", this Inspector returns just the set of Console Operators named Joe. Win:7.0

Operators

Key phrase | Return Type | Description
<bes filter set> contains <bes filter> | <boolean> | Returns TRUE if the specified filter set contains the given filter. Win:7.0
<bes filter> = <bes filter> | <boolean> | Compares two BES Filter types and returns TRUE if they are equal. Win:7.1

Examples

names of bes filters
Returns a list of the currently defined BES Filters used in the Find (ctrl-F) commands.

name of bes filter 2
Returns the name of the second BES Filter (a saved Find command).

size of (action set of bes filters)
Returns the number of BES Filters that were designed for finding Actions.

size of (set of bes filters)
Returns the current number of defined and saved BES find filters.


BES Filter Set

These Inspectors return the iterated list of BES Filters, converted into a set to make it easy to do set arithmetic with the list.

Creation Methods

Key Phrase | Form | Description
bes filter set | PlainGlobal | An iteration over the BES filters, represented as a mathematical set. Win:7.0
intersection of <bes filter set> | Plain | Returns the intersection of multiple BES filter sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
set of <bes filter> | Plain | Creates a set from an iterated list of BES filters. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
union of <bes filter set> | Plain | Returns the union of multiple BES filter sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
element of <bes filter set> | Plain | <bes filter> | Returns the unique elements of the specified <bes filter set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes filter set> | Plain | <bes filter set> | Returns the intersection of multiple BES filter sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes filter set> | Plain | <integer> | Returns the number of unique BES Filters in the specified set. Win:7.0
union of <bes filter set> | Plain | <bes filter set> | Returns the union of multiple BES filter sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes filter set> {op} <bes filter set> | <bes filter set> | Operates on two sets of BES filters, where {op} is one of: -, *, +. Minus subtracts the elements of one set from the other, multiply performs an intersection and plus performs a union. Win:7.0
<bes filter set> = <bes filter set> | <boolean> | Compares two sets of BES filters for equivalence. Win:7.0
<bes filter set> contains <bes filter set> | <boolean> | Returns TRUE if the first filter set contains the second. Win:7.0
<bes filter set> contains <bes filter> | <boolean> | Returns TRUE if the specified filter set contains the given filter. Win:7.0


BES Filter with Multiplicity

These Inspectors deal with arrays of bes filters, allowing you to pluck out unique filters and count them. These objects are derived from ordinary bes filters.

Creation Methods

Key Phrase | Form | Description
unique value of <bes filter> | Plain | Returns the unique values of a given list of <bes filter> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes filter with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes filter> types. Win:7.1


BES Fixlet

These Inspectors allow you to iterate over the BES Fixlet messages to create lists of various Fixlet properties such as name, ID, site, etc.

Creation Methods

Key Phrase | Form | Description
analysis of <bes activation> | Plain | Returns the source analysis fixlet that spawned the specified activation. Win:6.0
bes fixlet | PlainGlobal | Returns a list of all the BES custom site objects. Win:6.0
current analysis | PlainGlobal | When this Inspector is evaluated in the context of an analysis, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
current fixlet | PlainGlobal | When this Inspector is evaluated in the context of a Fixlet message, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
current task | PlainGlobal | When this Inspector is evaluated in the context of a Task, it returns the associated Fixlet object. • Note: This is a Console-only Inspector. Win:6.0
element of <bes fixlet set> | Plain | Returns the unique elements of the specified <bes fixlet set>, removing duplicates and sorting by value. Win:7.0
fixlet <integer> of <bes site> | Numbered | Returns the Fixlet with the specified ID from the given BES site. Win:6.0
fixlet of <bes fixlet result> | Plain | Returns the Fixlet message associated with the specified Fixlet result. Win:6.0
fixlet of <bes site> | Plain | Returns a list all of the Fixlet objects in the given BES site. Win:6.0
relevant fixlet of <bes computer> | Plain | Returns a list of all the <bes fixlet> objects that the specified computer has reported are relevant. Win:6.0
source analysis of <bes property> | Plain | Returns the <bes fixlet> object corresponding to the analysis that defines the specified property. Win:6.0
source fixlet of <bes action> | Plain | Returns the <bes fixlet> object that was the source of the specified action. Win:6.0
source fixlet of <bes baseline component> | Plain | Returns the BES Fixlet(s) associated with the specified BES Baseline component. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes fixlet> as xml | Cast | <utf8 string> | Converts the specified BES Fixlet to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
action <integer> of <bes fixlet> | Numbered | <bes fixlet action> | Returns an object representing the nth action for the specified Fixlet message. Win:6.0
action <string> of <bes fixlet> | Named | <bes fixlet action> | Returns an object representing the named action for the specified Fixlet message. Win:6.0
action of <bes fixlet> | Plain | <bes fixlet action> | Returns a list of all the Fixlet actions associated with the specified Fixlet message. Win:6.0
activation of <bes fixlet> | Plain | <bes activation> | If the specified Fixlet message is from an analysis, this Inspector returns a list of all of its activations. Win:6.0
analysis flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message originates from an Analysis. Win:6.0
applicable computer count of <bes fixlet> | Plain | <integer> | Returns the number of computers (regardless of locking) that have reported that the specified Fixlet message is relevant. Win:6.0
applicable computer of <bes fixlet> | Plain | <bes computer> | Returns a list of all of the <bes computer> objects reporting that the specified Fixlet message is relevant. Win:6.0
applicable computer set of <bes fixlet> | Plain | <bes computer set> | Returns the set of computers where the given Fixlet(s) is applicable, i.e., those computers where the Fixlet is relevant. Win:7.0
baseline flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message originates from a Baseline. Win:6.0
best activation of <bes fixlet> | Plain | <bes activation> | If the specified Fixlet message is from an analysis, then this Inspector returns the activation which is most appropriate for the current console user. Win:6.0
body of <bes fixlet> | Plain | <html> | Returns an HTML string containing the body of the Fixlet message. Win:6.0
category of <bes fixlet> | Plain | <string> | Returns the category of the given Fixlet message as a string value, such as "Security Hotfix", "Service Pack", "Upgrade", etc. Win:6.0
charset of <bes fixlet> | Plain | <string> | Returns the character set to be used when displaying the body or text of the specified Fixlet message. Win:6.0
comment of <bes fixlet> | Plain | <bes comment> | Returns the comments assigned to the specified BES Fixlet message. Win:7.0
component group of <bes fixlet> | Plain | <bes baseline component group> | If the specified Fixlet message is a baseline, then this Inspector iterates over the component groups. Win:7.0
components xml of <bes fixlet> | Plain | <string> | If the specified Fixlet message is a baseline, then this Inspector returned the XML representation of the baseline components. • Use component groups of <bes fixlet> instead. Win:6.0
creation time of <bes fixlet> | Plain | <time> | Returns the time when the specified fixlet was created. This Inspector is only valid for custom fixlets. Win:7.1
custom flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message is custom. Win:6.0
custom site flag of <bes fixlet> | Plain | <boolean> | Returns true if and only if the specified Fixlet message resides in a custom site. Win:6.0
custom site of <bes fixlet> | Plain | <bes site> | If the specified Fixlet message resides in a custom site, this Inspector returns the corresponding site object. Win:7.0
cve id list of <bes fixlet> | Plain | <string> | Returns a string containing the list of CVE (Common Vulnerabilities and Exposures) ID numbers associated with the specified Fixlet message. Win:6.0
default action of <bes fixlet> | Plain | <bes fixlet action> | Returns an object representing the default action for the specified Fixlet message. Win:6.0
digest file name of <bes fixlet> | Plain | <string> | Returns the file name of the .fxf file that contains this Fixlet message, or the empty string if the Fixlet message does not come from a digest file (i.e., it is a custom Fixlet). Win:6.0
download size of <bes fixlet> | Plain | <integer> | Returns the size of the download associated with this Fixlet message, in bytes. Win:6.0
fixlet flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message originates from an ordinary Fixlet site. Win:6.0
globally visible flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified Fixlet message is globally visible. Win:6.0
group flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message originates from a Group. Win:6.0
id of <bes fixlet> | Plain | <integer> | Returns the numeric ID unique to the specified Fixlet message. Win:6.0
issuer of <bes fixlet> | Plain | <bes user> | Returns the <bes user> object corresponding to the author of the specified fixlet. Win:6.0
link <html> of <bes fixlet> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the specified Fixlet document (in the BES Console) or its description page (in Web Reports). Win:6.0
link <string> of <bes fixlet> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the specified Fixlet document (in the BES Console) or its description page (in Web Reports). Win:6.0
link href of <bes fixlet> | Plain | <string> | The link href property does not return an <A> tag but rather returns the value of the href attribute of the <A> tag that would be constructed by the other link inspectors. This allows you to create more flexible linking formats. (See link of <bes fixlet>). Note that link href returns a normal string, not an HTML string. Win:6.0
link of <bes fixlet> | Plain | <html> | Returns an HTML string containing an <A> tag that when clicked will open the specified Fixlet document (in the BES Console) or its description page (in Web Reports). Win:6.0
locally visible flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified Fixlet message is locally visible. • Note: This is a Console-only Inspector. Win:6.0
master site flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified Fixlet message is from the Master site. Win:6.0
message of <bes fixlet> | Plain | <html> | Returns an HTML string containing the text of the Fixlet message. Win:6.0
mime field <string> of <bes fixlet> | Named | <string> | External fixlet authors can add custom fields to their Fixlets. This Inspector returns the mime field labeled by <string> from the specified Fixlet. Win:7.0
name of <bes fixlet> | Plain | <string> | Returns the name of the specified BES Fixlet. Win:6.0
open action count of <bes fixlet> | Plain | <integer> | Returns the number of open actions whose source is the specified Fixlet message. Win:6.0
operator site flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if and only if the specified Fixlet message resides in a non-master operator site. Win:6.0
property <integer> of <bes fixlet> | Numbered | <bes property> | If the specified Fixlet is from an analysis, this Inspector returns the property with the ID given by <integer>. Win:6.0
property of <bes fixlet> | Plain | <bes property> | If the specified Fixlet is from an analysis, this Inspector returns a list of all of the <bes property> objects associated with it. Win:6.0
relevance of <bes fixlet> | Plain | <string> | Returns the relevance expression used to determine if the specified Fixlet message is applicable on a client computer. Win:6.0
relevant <bes computer> of <bes fixlet> | Index<bes computer> | <boolean> | Returns TRUE if the given Fixlet message is relevant on the specified computer. Win:6.0
result from <bes computer> of <bes fixlet> | Index<bes computer> | <bes fixlet result> | Returns a Fixlet result for the given computer and Fixlet. Win:7.0
result of <bes fixlet> | Plain | <bes fixlet result> | Returns a list of all <bes fixlet result> objects for all computers that have reported on the specified Fixlet message. Win:6.0
sans id list of <bes fixlet> | Plain | <string> | Returns a string containing the list of SANS (SysAdmin, Audit, Network, Security) ID numbers associated with the specified Fixlet message. Win:6.0
set of <bes fixlet> | Plain | <bes fixlet set> | Converts the specified BES Fixlet list to a set that can be arithmetically manipulated. Win:7.0
site of <bes fixlet> | Plain | <bes site> | Returns the <bes site> object which contains the specified fixlet. Win:6.0
source id of <bes fixlet> | Plain | <string> | Returns the source ID of the given Fixlet message as a string value. Win:6.0
source of <bes fixlet> | Plain | <string> | Returns the source of the given Fixlet message as a string value. Win:6.0
source release date of <bes fixlet> | Plain | <date> | Returns the <date> object that represents the source release date of the specified Fixlet message. Win:6.0
source severity of <bes fixlet> | Plain | <string> | Returns the source severity of the given Fixlet message as a string value. Win:6.0
task flag of <bes fixlet> | Plain | <boolean> | Returns TRUE if the specified BES Fixlet message originates from a Task. Win:6.0
type of <bes fixlet> | Plain | <string> | Returns the type of the specified Fixlet message, which can have values such as "Fixlet", "Task", "Analysis", "ComputerGroup" or "Baseline". Win:6.0
unique value of <bes fixlet> | Plain | <bes fixlet with multiplicity> | Returns the unique values of a given list of <bes fixlet> types, removing duplicates and sorting by value. Win:7.1
unlocked computer count of <bes fixlet> | Plain | <integer> | Returns the number of computers that are not locked and that have reported that the specified Fixlet message is relevant. • Note: This is a Console-only Inspector. Win:6.0
wizard data of <bes fixlet> | Plain | <html> | If the specified Fixlet message was created with a Wizard then this Inspector returns the HTML string representing the DataStore element of that Wizard. • Note: This is a Console-only Inspector. Win:6.0
wizard link of <bes fixlet> | Plain | <string> | If the specified Fixlet message was created with a Wizard then this Inspector returns the HTML string representing the link of that Wizard. • Note: This is a Console-only Inspector. Win:6.0
wizard name of <bes fixlet> | Plain | <string> | If the specified Fixlet message was created with a Wizard then this Inspector returns the HTML string representing the name of that Wizard. • Note: This is a Console-only Inspector. Win:6.0

Operators

Key phrase | Return Type | Description
<bes fixlet> = <bes fixlet> | <boolean> | Compares two BES Fixlet types and returns TRUE if they are equal. Win:7.1

Examples

links (h1 of name of it) of bes fixlets
Returns a list of HTML strings, each with an HTML link named after the Fixlet message and formatted as a header (h1).

links (name of it & "(" & id of it as string & ")")) of bes fixlets
Returns an HTML string that will print the name and ID of the Fixlet message inside a clickable <A> tag.

(br & html "Click <A href='" & link href of it & html "'>here</A> to open fixlet " & id of it as string) of bes fixlets
Returns an html string such as 'Click here to open fixlet 12345' message that, when clicked, will open the corresponding BES Fixlet document.

links of bes fixlets
Returns a list of all the BES Fixlets formated as links in an HTML string.

links (name of it & "(" & id of it as string & ")")) of bes actions
Returns a list of clickable links displaying the name and ID of each Action.

links (h1 of name of it) of bes actions
Returns a list of clickable links displaying the name each Action as a header.

(id of it, mime fields "x-fixlet-sans" of it) of bes fixlets
Returns a list of the Fixlet IDs and the values of the mime SANS fields (if they exist) of each.

size of (set of bes fixlets)
Returns the current number of BES Fixlet messages.

names of bes fixlets whose (source severity of it is "Critical")
Returns a list of the names of the critical Fixlets. Note that the quoted severity (in this case "Critical") is case-sensitive.


BES Fixlet Action

These Inspectors let you examine BES Actions that are attached to Fixlet messages.

Creation Methods

Key Phrase | Form | Description
action <integer> of <bes fixlet> | Numbered | Returns an object representing the nth action for the specified Fixlet message. Win:6.0
action <string> of <bes fixlet> | Named | Returns an object representing the named action for the specified Fixlet message. Win:6.0
action of <bes baseline component> | Plain | Returns the action(s) associated with the specified baseline component. Win:7.0
action of <bes fixlet> | Plain | Returns a list of all the Fixlet actions associated with the specified Fixlet message. Win:6.0
default action of <bes fixlet> | Plain | Returns an object representing the default action for the specified Fixlet message. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
content id of <bes fixlet action> | Plain | <string> | Returns the content ID field for the specified Fixlet action. Win:6.0
script of <bes fixlet action> | Plain | <string> | Returns the script for the specified Fixlet action. Win:6.0
script type of <bes fixlet action> | Plain | <string> | Returns the MIME type of the specified Fixlet action. Win:6.0


BES Fixlet Result

These Inspectors allow you to inspect the results of BES Fixlet messages, including relevance and affected computers.

Creation Methods

Key Phrase | Form | Description
result <( bes computer, bes fixlet )> | Index<( bes computer, bes fixlet )>Global | Returns a Fixlet result for the given computer and Fixlet. This command is a variant of other result Inspectors, such as result from <bes fixlet> of <bes computer>. Win:7.0
result <( bes fixlet, bes computer )> | Index<( bes fixlet, bes computer )>Global | Returns a Fixlet result for the given computer and Fixlet. This command is a variant of other result Inspectors, such as result from <bes fixlet> of <bes computer>. Win:7.0
result from <bes computer> of <bes fixlet> | Index<bes computer> | Returns a Fixlet result for the given computer and Fixlet. Win:7.0
result from <bes fixlet> of <bes computer> | Index<bes fixlet> | Returns a Fixlet result for the given computer and Fixlet. Win:7.0
result of <bes fixlet> | Plain | Returns a list of all <bes fixlet result> objects for all computers that have reported on the specified Fixlet message. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
computer of <bes fixlet result> | Plain | <bes computer> | Returns the BES computer associated with the specified Fixlet result. Win:6.0
first became relevant of <bes fixlet result> | Plain | <time> | Returns the time when the Fixlet result first became relevant. • Note: This is a Web Reports-only Inspector. Win:6.0
fixlet of <bes fixlet result> | Plain | <bes fixlet> | Returns the Fixlet message associated with the specified Fixlet result. Win:6.0
last became nonrelevant of <bes fixlet result> | Plain | <time> | Returns the time when the Fixlet result last became non-relevant. This may be tied to the successful completion of the Fixlet message. • Note: This is a Web Reports-only Inspector. Win:6.0
last became relevant of <bes fixlet result> | Plain | <time> | Returns the time when the Fixlet result last became relevant. • Note: This is a Web Reports-only Inspector. Win:6.0
relevant flag of <bes fixlet result> | Plain | <boolean> | Returns TRUE if the computer reports that the given Fixlet result is relevant, and FALSE otherwise. Win:6.0


BES Fixlet Set

These Inspectors iterate over the current set of BES Fixlets and package them as a mathematical set, suitable for further set manipulation.

Creation Methods

Key Phrase | Form | Description
analysis set of <bes filter> | Plain | Returns a filtered set of Analyses. Given an Analysis filter that specifies "Visibility equals Visible", this Inspector returns just the set of BES Analyses that are visible. Win:7.0
baseline set of <bes filter> | Plain | Returns a filtered set of Baselines. Given a Baseline filter that specifies "Visibility equals Visible", this Inspector returns just the set of BES Baselines that are visible. Win:7.0
bes fixlet set | PlainGlobal | An iteration over the BES Fixlets, represented as a mathematical set. Win:7.0
computer group set of <bes filter> | Plain | Returns a filtered set of computer groups. Given a computer group filter that specifies "Name contains 'test'", this Inspector returns the set of computer groups that have 'test' in their name. Win:7.0
fixlet set of <bes filter> | Plain | Returns a filtered set of Fixlets. Given a Fixlet filter that specifies "Visibility equals Globally Hidden", this Inspector returns just the set of BES Fixlets that are globally hidden. Win:7.0
fixlet set of <bes site> | Plain | Returns the set of Fixlets that are associated with the specified BES Site. Win:7.0
intersection of <bes fixlet set> | Plain | Returns the intersection of multiple BES Fixlet sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
relevant fixlet set of <bes computer> | Plain | Returns a list of all the <bes fixlet> objects that the specified computer has reported are relevant. The list is formatted as a mathematical set. Win:7.0
set of <bes fixlet> | Plain | Creates a set from an iterated list of BES Fixlets. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
task set of <bes filter> | Plain | Returns a filtered set of Tasks. Given a Task filter that specifies "Visibility equals Locally Hidden", this Inspector returns just the set of BES Tasks that are locally hidden. Win:7.0
union of <bes fixlet set> | Plain | Returns the union of multiple BES Fixlet sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes fixlet set> as xml | Cast | <utf8 string> | Converts the specified set of BES Fixlets to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
element of <bes fixlet set> | Plain | <bes fixlet> | Returns the unique elements of the specified <bes fixlet set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes fixlet set> | Plain | <bes fixlet set> | Returns the intersection of multiple BES Fixlet sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes fixlet set> | Plain | <integer> | Returns the number of unique BES Fixlets in the specified set. Win:7.0
union of <bes fixlet set> | Plain | <bes fixlet set> | Returns the union of multiple BES Fixlet sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes fixlet set> {op} <bes fixlet set> | <bes fixlet set> | Operates on two sets of BES Fixlets, where {op} is one of: -, *, +. Minus subtracts the elements of one set from the other, multiply performs an intersection and plus performs a union. Win:7.0
<bes fixlet set> = <bes fixlet set> | <boolean> | Compares two sets of BES Fixlets for equivalence. Win:7.0


BES Fixlet with Multiplicity

These Inspectors deal with arrays of bes fixlets, allowing you to pluck out unique fixlets and count them. These objects are derived from ordinary bes fixlets.

Creation Methods

Key Phrase | Form | Description
unique value of <bes fixlet> | Plain | Returns the unique values of a given list of <bes fixlet> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes fixlet with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes fixlet> types. Win:7.1


BES Property

These Inspectors return information about the properties of BES Client computers. Properties -- along with their names, IDs and definitions -- can be iterated to produce property lists of all your networked BES computers.

Creation Methods

Key Phrase | Form | Description
bes property | PlainGlobal | Returns a list of all the BES custom site objects. Win:6.0
bes property <string> | NamedGlobal | Returns the first property whose name matches the given string. Note that it is not safe to assume that there is only one property with a given name. Win:6.0
element of <bes property set> | Plain | Returns the unique elements of the specified <bes property set>, removing duplicates and sorting by value. Win:7.0
property <integer> of <bes fixlet> | Numbered | If the specified Fixlet is from an analysis, this Inspector returns the property with the ID given by <integer>. Win:6.0
property of <bes fixlet> | Plain | If the specified Fixlet is from an analysis, this Inspector returns a list of all of the <bes property> objects associated with it. Win:6.0
property of <bes property result> | Plain | Returns the property corresponding to the specified BES property result. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<bes property> as xml | Cast | <utf8 string> | Converts the specified BES Property to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
analysis flag of <bes property> | Plain | <boolean> | Returns TRUE if the specified BES property is an analysis property. Win:6.0
category of <bes property> | Plain | <string> | Returns the optional category created for the specified BES property. Win:7.0
custom flag of <bes property> | Plain | <boolean> | Returns TRUE if the specified BES property is custom. Win:6.0
database id of <bes property> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database containing the specified BES property. Win:6.0
default flag of <bes property> | Plain | <boolean> | Returns TRUE if the specified BES property is the default. Win:6.0
definition of <bes property> | Plain | <string> | Returns the relevance expression which defines the specified property. Win:6.0
evaluation period of <bes property> | Plain | <time interval> | Returns the <time interval> that controls how frequently clients will submit reports for the specified property. Win:6.0
id of <bes property> | Plain | <( integer, integer, integer )> | Returns a 3-tuple of integers composed of the site ID, analysis ID and property ID. The first integer identifies the site hosting the Analysis. For custom properties not contained in an analysis (those created using the Manage Properties dialog), it is the ID of the Action site. The second integer indentifies the Analysis containing the property. For custom properties, this is 0. The third integer identifies the property itself. This is the same as the source ID if the property is defined in an Analysis. If it is not defined in an Analysis then this is the unique object ID for the property. Win:7.0
keep statistics flag of <bes property> | Plain | <boolean> | Returns TRUE if statistics are being kept for the specified BES property. Win:7.0
name of <bes property> | Plain | <string> | Returns the name of the specified BES property. This name is not guaranteed to be unique. Win:6.0
reported computer set of <bes property> | Plain | <bes computer set> | Returns a list of all the computers that have reported for the specified BES property. The list is formatted as a mathematical set. Win:7.0
reserved flag of <bes property> | Plain | <boolean> | Returns TRUE if the specified BES property is reserved. Win:6.0
result from <bes computer> of <bes property> | Index<bes computer> | <bes property result> | Returns the result of the specified BES property and computer. Win:6.0
result of <bes property> | Plain | <bes property result> | Returns a list of the BES property results for every computer reporting a result for the specified property. Win:6.0
set of <bes property> | Plain | <bes property set> | Converts the specified BES Property list to a set that can be arithmetically manipulated. Win:7.0
simple name of <bes property> | Plain | <string> | Returns the non-category portion of the property name. Win:7.0
source analysis of <bes property> | Plain | <bes fixlet> | Returns the <bes fixlet> object corresponding to the analysis that defines the specified property. Win:6.0
source evaluation period of <bes property> | Plain | <time interval> | Returns the period of the property as specified by the analysis that defines it. This period is not necessarily the same as the period of the property. Win:6.0
source id of <bes property> | Plain | <integer> | Returns the ID of the property as specified by the analysis that defines it. This is not the same as the unique property ID. Win:6.0
source name of <bes property> | Plain | <string> | Returns the name of the property as specified by the analysis that defines it. This name is not necessarily the same as the name of the property. Win:6.0
statistic range of <bes property> | Plain | <statistic range> | Returns the range of statistical bins associated with the given property. The property must be marked for statistical aggregation. If not, or if no clients have reported results, it throws NoSuchObject. Win:6.0
unique value of <bes property> | Plain | <bes property with multiplicity> | Returns the unique values of a given list of <bes property> types, removing duplicates and sorting by value. Win:7.1

Operators

Key phrase | Return Type | Description
<bes property> = <bes property> | <boolean> | Compares two BES Property types and returns TRUE if they are equal. Win:7.1

Examples

size of (set of bes properties)
Returns the current number of BES properties.


BES Property Result

These Inspectors return the results derived from the given properties of the specified BES Client computers.

Creation Methods

Key Phrase | Form | Description
property result of <bes computer> | Plain | Returns a list of all of the <bes property result> objects that the specified BES computer has reported. Win:6.0
result <( bes computer, bes property )> | Index<( bes computer, bes property )>Global | Returns the result of the specified BES property and computer. Win:6.0
result <( bes property, bes computer )> | Index<( bes property, bes computer )>Global | Returns the result of the specified BES property and computer. Win:6.0
result from <bes computer> of <bes property> | Index<bes computer> | Returns the result of the specified BES property and computer. Win:6.0
result from <bes property> of <bes computer> | Index<bes property> | Returns the result of the specified BES property and computer. Win:6.0
result of <bes property> | Plain | Returns a list of the BES property results for every computer reporting a result for the specified property. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
computer of <bes property result> | Plain | <bes computer> | Returns the computer corresponding to the specified BES property result. Win:6.0
error flag of <bes property result> | Plain | <boolean> | Returns TRUE if the specified BES property result is an error. Win:6.0
error message of <bes property result> | Plain | <string> | If the specified BES property result is an error, this Inspector returns the error message. Win:6.0
plural flag of <bes property result> | Plain | <boolean> | Returns TRUE if the specified BES property result is a multiple result. Win:6.0
property of <bes property result> | Plain | <bes property> | Returns the property corresponding to the specified BES property result. Win:6.0
value count of <bes property result> | Plain | <integer> | Returns the number of values reported by this computer for the specified property result. Win:6.0
value of <bes property result> | Plain | <string> | Returns a list of the <string> values reported by this computer for the specified property result. Win:6.0


BES Property Set

These Inspectors iterate over the current set of BES properties and package them as a mathematical set, suitable for further set manipulation.

Creation Methods

Key Phrase | Form | Description
bes property set | PlainGlobal | An iteration over the BES Properties, represented as a mathematical set. Win:7.0
intersection of <bes property set> | Plain | Returns the intersection of multiple BES property sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
reported property set of <bes computer> | Plain | Returns a list of all the BES properties that have reported on the specified computer(s). The list is formatted as a mathematical set. Win:7.0
set of <bes property> | Plain | Creates a set from an iterated list of BES Properties. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
union of <bes property set> | Plain | Returns the union of multiple BES property sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<bes property set> as xml | Cast | <utf8 string> | Converts the specified set of BES Properties to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
element of <bes property set> | Plain | <bes property> | Returns the unique elements of the specified <bes property set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes property set> | Plain | <bes property set> | Returns the intersection of multiple BES property sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes property set> | Plain | <integer> | Returns the number of unique BES Properties in the specified set. Win:7.0
union of <bes property set> | Plain | <bes property set> | Returns the union of multiple BES property sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes property set> {op} <bes property set> | <bes property set> | Operates on two sets of BES properties, where {op} is one of: -, *, +. Minus subtracts the elements of one set from the other, multiply performs an intersection and plus performs a union. Win:7.0
<bes property set> = <bes property set> | <boolean> | Compares two sets of BES properties for equivalence. Win:7.0


BES Property with Multiplicity

These Inspectors deal with arrays of bes properties, allowing you to pluck out unique properties and count them. These objects are derived from ordinary bes properties.

Creation Methods

Key Phrase | Form | Description
unique value of <bes property> | Plain | Returns the unique values of a given list of <bes property> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes property with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes property> types. Win:7.1


BES Server

These Inspectors return information about the BES Server, allowing Dashboards and Web Reports to access files and other information from the BES database.

Creation Methods

Key Phrase | Form | Description
current bes server | PlainGlobal | Returns a <bes server> object corresponding to the BES Server currently connected to the Console or Web Reports applications. The current bes server Inspectors allow dashboards to access files hosted on the current BES Server. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
database id of <bes server> | Plain | <integer> | Returns the integer database ID corresponding to the specified BES Server. Win:7.2
database name of <bes server> | Plain | <string> | Returns the database name (as a <string>) corresponding to the specified BES Server. Win:7.2
url of <bes server> | Plain | <string> | Returns the URL of the specified BES Server, providing access to any files hosted on that server. Win:7.2


BES Site

The site Inspectors return the names and IDs of the specified site objects. As of BES 7.0, the <bes custom site> type has been merged with bes site, which now represents all supported types, including external sites, master action sites, operator sites, and custom sites. All properties of bes custom site are now accessible via <bes site>. As a compatibility measure, bes sites still returns only external and master action sites.

Creation Methods

Key Phrase | Form | Description
all bes site | PlainGlobal | This iterative Inspector returns a list of all external, master, operator, and custom sites. Win:7.0
bes custom site | PlainGlobal | Returns a list of all custom sites. Deprecated as of version 7.0; instead use "all bes sites whose (custom site flag of it)". Win:7.0
bes site | PlainGlobal | Returns a list of all the BES sites. Win:6.0
custom site of <bes fixlet> | Plain | If the specified Fixlet message resides in a custom site, this Inspector returns the corresponding site object. Win:7.0
site of <bes computer group> | Plain | Returns the site corresponding to the specified BES Computer Group. Win:7.0
site of <bes fixlet> | Plain | Returns the <bes site> object which contains the specified fixlet. Win:6.0
site of <bes wizard> | Plain | Returns the site corresponding to the specified BES Wizard. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
creation date of <bes site> | Plain | <time> | Depending on the type of the BES site, this inspector returns the creation date: • External and Master sites: Does not exist (added in version 7.0). • Operator sites: The <moment> when the operator was created (added in version 7.0). • Custom sites: The <moment> when the site was created. Win:7.0
creator of <bes site> | Plain | <bes user> | Returns the <bes user> who created the specified custom site. Does not exist for External, Master or Operator sites. Win:7.0
custom site flag of <bes site> | Plain | <boolean> | Returns TRUE if and only if the specified site is a custom site. Win:7.0
description of <bes site> | Plain | <string> | For a custom site, this is the description of the site that was specified by the creator. For External, Master or Operator sites, the description does not exist. Win:7.0
display name of <bes site> | Plain | <string> | Beginning with version 7.1, a custom site can specify a display name that's different from the site name in the masthead. This inspector returns the display name; for the masthead name, use name of <bes site>. Win:7.1
explicit owner of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted ownership of the specified site. Notice that the creator of this site is not included in the owner list. • Note: This is a Console-only Inspector. Win:7.1
explicit owner set of <bes site> | Plain | <bes user set> | Returns the set of BES users who are owners (an iterated list) of the specified BES site. Win:7.1
explicit reader of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted reading privileges on the specified site. Notice that the creator, owners (unless explicitly added) and writers of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.1
explicit reader set of <bes site> | Plain | <bes user set> | Returns the set of BES users who have read rights (the iterated list) on the specified BES custom site. Win:7.1
explicit writer of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted writing privileges on the specified site. Notice that the creator and owners (unless explicitly added) of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.1
explicit writer set of <bes site> | Plain | <bes user set> | Returns the set of BES users who have write permissions (as an iterated list) on the specified BES site. Win:7.1
external site flag of <bes site> | Plain | <boolean> | Returns TRUE if and only if the specified site is an external site. Win:7.0
fixlet <integer> of <bes site> | Numbered | <bes fixlet> | Returns the Fixlet with the specified ID from the given BES site. Win:6.0
fixlet of <bes site> | Plain | <bes fixlet> | Returns a list all of the Fixlet objects in the given BES site. Win:6.0
fixlet set of <bes site> | Plain | <bes fixlet set> | Returns the set of Fixlets that are associated with the specified BES Site. Win:7.0
globally readable flag of <bes site> | Plain | <boolean> | The value of the globally readable flag depends on the type of site: • External sites: True if and only if the site has been marked as readable by all users. • Master sites: True. • Operator sites: False. • Custom sites: True if and only if the site has been marked as readable by all users. Win:7.0
id of <bes site> | Plain | <integer> | Returns the numeric ID unique to the specified BES site. Win:6.0
master site flag of <bes site> | Plain | <boolean> | Returns TRUE if and only if the specified site is a master site. Win:7.0
name of <bes site> | Plain | <string> | Returns the name of the specified BES site (undecorated). Win:6.0
operator site flag of <bes site> | Plain | <boolean> | Returns TRUE if and only if the specified site is an operator site. Win:7.0
owner flag <bes user> of <bes site> | Index<bes user> | <boolean> | This Inspector is deprecated as of Version 7.0. Instead use "exists owner of <bes site> whose (it = <bes user>)". Win:7.0
owner of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted ownership of the specified site. Notice that the creator of this site is not included in the owner list. • Note: This is a Console-only Inspector. Win:7.0
owner set of <bes site> | Plain | <bes user set> | Returns the set of BES users who are owners (an iterated list) of the specified BES site. Win:7.0
reader of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted reading privileges on the specified site. Notice that the creator, owners (unless explicitly added) and writers of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.0
reader set of <bes site> | Plain | <bes user set> | Returns the set of BES users who have read rights (the iterated list) on the specified BES custom site. Win:7.0
subscribed computer of <bes site> | Plain | <bes computer> | Returns the list of computers that are subscribed to the specified BES site. Win:7.0
subscribed computer set of <bes site> | Plain | <bes computer set> | Returns the list of computers that are subscribed to the specified BES site. The list is formatted as a mathematical set for easier manipulation. Win:7.0
writer of <bes site> | Plain | <bes user> | Returns a list of BES users that have been granted writing privileges on the specified site. Notice that the creator and owners (unless explicitly added) of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.0
writer set of <bes site> | Plain | <bes user set> | Returns the set of BES users who have write permissions (as an iterated list) on the specified BES site. Win:7.0

Examples

display name of bes site whose (name of it = "Enterprise Security")
Returns "Patches for Windows.".


BES Unmanagedasset

These Inspectors provide access to externally sourced data, such as that derived from Nmap scans on client computers. The results, such as OS, Device Type, Network Card Vendor, and Open Ports, are uploaded to the BES Server for storage and analysis. These Inspectors provide a way to monitor and report on mobile or hand-held devices that are not traditional BES Clients, but instead use "microAgents" to report their status. For more information on currently supported devices, consult the BigFix support pages.

Creation Methods

Key Phrase | Form | Description
asset of <bes unmanagedasset field> | Plain | Returns an asset (containing a name / value pair) from the specified BES unmanaged asset field. Win:7.0
bes unmanagedasset | PlainGlobal | Returns a list of all the Unmanaged Assets currently defined in BES. Win:7.0
current unmanagedasset | PlainGlobal | Returns the unmanaged asset that is currently selected in the BES Console from the right-click context menu under the Unmanaged Assets tab. This Inspector is designed to assist you in the creation of extended Context Menu applications. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
client installed flag of <bes unmanagedasset> | Plain | <boolean> | Returns TRUE if the specified unmanaged asset is running the BES Client. Win:7.0
field of <bes unmanagedasset> | Plain | <bes unmanagedasset field> | Returns a list of the fields from the specified BES Unmanaged Asset. Win:7.0
id of <bes unmanagedasset> | Plain | <integer> | Returns the unique numeric ID of the given unmanaged asset. Win:7.0
link <html> of <bes unmanagedasset> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the specified unmanaged asset (in the BES Console) or its description page (in Web Reports). Win:7.0
link <string> of <bes unmanagedasset> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the specified unmanaged asset (in the BES Console) or its description page (in Web Reports). Win:7.0
link href of <bes unmanagedasset> | Plain | <string> | The link href property does not return an <A> tag but rather returns the value of the href attribute of the <A> tag that would be constructed by the other link inspectors. This allows you to create more flexible linking formats. (See link of <bes unmanaged asset>). Note that link href returns a normal string, not an HTML string. Win:7.0
link of <bes unmanagedasset> | Plain | <html> | Returns an HTML string containing an <A> tag that when clicked will open the specified BES unmanaged asset document (in the BES Console) or its description page (in Web Reports). Win:7.0
source of <bes unmanagedasset> | Plain | <string> | Returns the source of the specified Unmanaged Asset as a string value. Win:7.0

Examples

(values of fields whose (name of it is "Hostname")) of bes unmanagedassets whose (not client installed flag of it)
Returns the hostnames of all devices that are running windows but are not running the BES Client.

(name of it & " - " & value of it) of fields of bes unmanagedasset whose (id of it is 55)
Outputs a list of name/value pairs for each field in the specified BES Unmanaged Asset, for instance:
• IP Address - 10.10.42.1
• Hostname - Donald.


BES Unmanagedasset Field

These Inspectors provide authors with access to the individual fields of various unmanaged assets. Each field consists of a name / value pair, analogous to BES properties. There are three types of fields:
• IdentifyingField: Each asset must have one IdentifyingField, such as a MAC Address, which is used to identify and correlate different reports from the same asset.
• FilterableField: These are displayed in the Console in both the Unmanaged Asset list and the unmanaged asset document, allowing sorting and filtering.
• NonFilterable: These are only displayed in the Unmanaged Assets document, and typically return a large amount of data, such as a list of vulnerabilities.

Creation Methods

Key Phrase | Form | Description
field of <bes unmanagedasset> | Plain | Returns a list of the fields from the specified BES Unmanaged Asset. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
asset of <bes unmanagedasset field> | Plain | <bes unmanagedasset> | Returns an asset (containing a name / value pair) from the specified BES unmanaged asset field. Win:7.0
editable flag of <bes unmanagedasset field> | Plain | <boolean> | Returns TRUE if the specified BES Unmanaged Asset is editable. Win:7.0
filterable flag of <bes unmanagedasset field> | Plain | <boolean> | Returns TRUE if the specified asset field is filterable. Fields that are filterable will show up in the Unmanaged Assets list, allowing you to sort and filter them. Win:7.0
name of <bes unmanagedasset field> | Plain | <string> | Returns the name of the specified BES unmanaged asset field. Win:7.0
value of <bes unmanagedasset field> | Plain | <string> | Returns the value (as a <string>) of the specified BES Unmanaged Asset field. Win:7.0

Examples

(name of it & " - " & value of it) of fields of bes unmanagedasset whose (id of it is 55)
Outputs a list of name/value pairs for each field in the specified BES Unmanaged Asset, for instance:
• IP Address - 10.10.42.1
• Hostname - Donald.


BES User

These Inspectors let you keep track of the users authorized to use the BES Console. You can iterate over the users, producing lists containing information such as the name and authorization level.

Creation Methods

Key Phrase | Form | Description
administrator of <bes computer> | Plain | Iterates over the users who have administrative rights on this computer. Win:7.0
author of <bes comment> | Plain | Returns the author of the specified BES Comment. Win:7.0
bes user | PlainGlobal | Returns a list of all the BES users. Win:6.0
creator of <bes site> | Plain | Returns the <bes user> who created the specified custom site. Does not exist for External, Master or Operator sites. Win:7.0
current console user | PlainGlobal | Returns a user object for the user currently logged into the BES Console. Win:6.0
element of <bes user set> | Plain | Returns the unique elements of the specified <bes user set>, removing duplicates and sorting by value. Win:7.0
explicit owner of <bes site> | Plain | Returns a list of BES users that have been granted ownership of the specified site. Notice that the creator of this site is not included in the owner list. • Note: This is a Console-only Inspector. Win:7.1
explicit reader of <bes site> | Plain | Returns a list of BES users that have been granted reading privileges on the specified site. Notice that the creator, owners (unless explicitly added) and writers of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.1
explicit writer of <bes site> | Plain | Returns a list of BES users that have been granted writing privileges on the specified site. Notice that the creator and owners (unless explicitly added) of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.1
issuer of <bes action> | Plain | Returns the BES user object corresponding to the issuer of the specified action. Win:6.0
issuer of <bes activation> | Plain | Returns the <bes user> object corresponding to the user who issued the specified activation. Win:6.0
issuer of <bes fixlet> | Plain | Returns the <bes user> object corresponding to the author of the specified fixlet. Win:6.0
owner of <bes site> | Plain | Returns a list of BES users that have been granted ownership of the specified site. Notice that the creator of this site is not included in the owner list. • Note: This is a Console-only Inspector. Win:7.0
reader of <bes site> | Plain | Returns a list of BES users that have been granted reading privileges on the specified site. Notice that the creator, owners (unless explicitly added) and writers of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.0
stopper of <bes action> | Plain | If the specified action has been stopped, this Inspector returns the user who stopped it. Win:7.0
writer of <bes site> | Plain | Returns a list of BES users that have been granted writing privileges on the specified site. Notice that the creator and owners (unless explicitly added) of this site are not included in this reader list. • Note: This is a Console-only Inspector. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
administered computer of <bes user> | Plain | <bes computer> | Iterates and returns a list of the computers that are administered by the specified BES user. Win:7.0
administered computer set of <bes user> | Plain | <bes computer set> | Returns the set of computers that are administerable by the specified BES user. Win:7.0
administrator <bes computer> of <bes user> | Index<bes computer> | <boolean> | Returns TRUE if the specified user is an administrator of the given computers. Win:7.0
creation time of <bes user> | Plain | <time> | Returns the time when the specified user was created. Win:6.0
custom content flag of <bes user> | Plain | <boolean> | Returns TRUE if the user has been granted the privilege to author custom content/actions. Win:6.0
issued action of <bes user> | Plain | <bes action> | Returns all actions, including hidden actions, issued by the specified user. Win:7.0
issued action set of <bes user> | Plain | <bes action set> | Returns all actions, including hidden actions, issued by the specified user. This list is formatted as a mathematical set. Win:7.0
last login time of <bes user> | Plain | <time> | Returns the time of the specified user's most recent database login. Win:6.0
link <html> of <bes user> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the specified user document (in the BES Console) or its description page (in Web Reports). Win:6.0
link <string> of <bes user> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the given user document (in the BES Console) or description page (in Web Reports). Win:6.0
link href of <bes user> | Plain | <string> | The link href property does not return an <A> tag but rather returns the value of the href attribute of the <A> tag that would be constructed by the other link inspectors. This allows you to create more flexible linking formats. (See link of <bes user>). Note that link href returns a normal string, not an HTML string. Win:6.0
link of <bes user> | Plain | <html> | Returns an HTML string containing an <A> tag that when clicked will open the specified user document (in the BES Console) or its description page (in Web Reports). Win:6.0
master flag of <bes user> | Plain | <boolean> | Returns TRUE if the user is a master administrator. Win:6.0
name of <bes user> | Plain | <string> | Returns the name of the specified BES user (database login name). Win:6.0
set of <bes user> | Plain | <bes user set> | Converts the specified BES User list to a set that can be arithmetically manipulated. Win:7.0
unique value of <bes user> | Plain | <bes user with multiplicity> | Returns the unique values of a given list of <bes user> types, removing duplicates and sorting by value. Win:7.1
unmanagedasset privilege scanpoint flag of <bes user> | Plain | <boolean> | When you create or edit a user, you specify whether they can see all unmanaged assets, none, or only those that were scanned by a computer which the user manages. This Inspector returns TRUE if the "scanpoint only" option is set for the specified user. Win:7.0
unmanagedasset privilege showall flag of <bes user> | Plain | <boolean> | When you create or edit a user, you specify whether they can see all unmanaged assets, none, or only those that were scanned by a computer which the user manages. This Inspector returns TRUE if all assets are visible for the specified user. Win:7.0
unmanagedasset privilege shownone flag of <bes user> | Plain | <boolean> | When you create or edit a user, you specify whether they can see all unmanaged assets, none, or only those that were scanned by a computer which the user manages. This Inspector returns TRUE if no assets are visible the specified user. Win:7.0

Operators

Key phrase | Return Type | Description
<bes user> = <bes user> | <boolean> | Compares two BES Users. Win:7.0

Examples

(name of item 0 of it, size of item 1 of it) of (it, sets of items 1 of (it, bes fixlets) whose (issuer of item 1 of it = item 0 of it)) of bes users
Returns a list of the names of the current BES Users and the number of Fixlets each one has issued.

links (h1 of name of it) of bes users
Returns a list of HTML strings, each with an HTML link named after the user and formatted as a header (h1).

links (name of it & "(" & master flag of it as string & ")")) of bes users
Returns an HTML string that will print the name and master status of the user inside a clickable <A> tag.

(br & html "Click <A href='" & link href of it & html "'>here</A> to open user " & name of it as string) of bes users
Returns an html string such as 'Click here to open user John' message that, when clicked, will open the corresponding BES user document.

links of bes users
Returns a list of all the BES users formated as links in an HTML string.

size of (set of bes users)
Returns the current number of BES users.


BES User Set

These Inspectors iterate over the current set of BES users and package them as a mathematical set, suitable for further set manipulation.

Creation Methods

Key Phrase | Form | Description
administrator set of <bes computer> | Plain | Returns the set of users who have administrative rights on this computer. Win:7.0
bes user set | PlainGlobal | An iteration over the BES Users, represented as a mathematical set. Win:7.0
explicit owner set of <bes site> | Plain | Returns the set of BES users who are owners (an iterated list) of the specified BES site. Win:7.1
explicit reader set of <bes site> | Plain | Returns the set of BES users who have read rights (the iterated list) on the specified BES custom site. Win:7.1
explicit writer set of <bes site> | Plain | Returns the set of BES users who have write permissions (as an iterated list) on the specified BES site. Win:7.1
intersection of <bes user set> | Plain | Returns the intersection of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
owner set of <bes site> | Plain | Returns the set of BES users who are owners (an iterated list) of the specified BES site. Win:7.0
reader set of <bes site> | Plain | Returns the set of BES users who have read rights (the iterated list) on the specified BES custom site. Win:7.0
set of <bes user> | Plain | Creates a set from an iterated list of BES Users. This can be subjected to arithmetic set operations such as union and intersection. Win:7.0
union of <bes user set> | Plain | Returns the union of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
user set of <bes filter> | Plain | Returns a filtered set of Console Operators. Given a Console Operator filter that specifies "Name contains Joe", this Inspector returns just the set of Console Operators named Joe. Win:7.0
writer set of <bes site> | Plain | Returns the set of BES users who have write permissions (as an iterated list) on the specified BES site. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
element of <bes user set> | Plain | <bes user> | Returns the unique elements of the specified <bes user set>, removing duplicates and sorting by value. Win:7.0
intersection of <bes user set> | Plain | <bes user set> | Returns the intersection of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0
size of <bes user set> | Plain | <integer> | Returns the number of unique BES Users in the specified set. Win:7.0
union of <bes user set> | Plain | <bes user set> | Returns the union of multiple BES User sets. The arguments to this Inspector are typically plural values or iterations, but you can also compose such a set by separating singlet values with semicolons. Win:7.0

Operators

Key phrase | Return Type | Description
<bes user set> {op} <bes user set> | <bes user set> | Operates on two sets of BES Users, where {op} is one of: -, *, +. Minus subtracts the elements of one set from the other, multiply performs an intersection and plus performs a union. Win:7.0
<bes user set> = <bes user set> | <boolean> | Compares two sets of BES Users for equivalence. Win:7.0


BES User with Multiplicity

These Inspectors deal with arrays of bes users, allowing you to pluck out unique users and count them. These objects are derived from ordinary bes users.

Creation Methods

Key Phrase | Form | Description
unique value of <bes user> | Plain | Returns the unique values of a given list of <bes user> types, removing duplicates and sorting by value. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <bes user with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <bes user> types. Win:7.1


BES Wakeonlan Status

These Windows Inspectors return the status of the BES WakeOnLan feature.

Creation Methods

Key Phrase | Form | Description
bes wakeonlan status | PlainGlobal | Returns the current BES WakeOnLan status. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
database id of <bes wakeonlan status> | Plain | <integer> | Returns the integer ID corresponding to the Database with WoL. Win:7.1
database name of <bes wakeonlan status> | Plain | <string> | Returns the name(s) corresponding to the Database with WoL. Win:7.1
enabled of <bes wakeonlan status> | Plain | <boolean> | Returns TRUE if the BES WakeOnLan status is currently enabled. Win:7.1

Examples

(database id of it, enabled of it) of bes wakeonlan statuses
Returns a list of database IDs and the WoL status for each, such as:
• 1, True
• 2, False.


BES Wizard

These are Console-only Inspectors that return a list of the available BES Wizards.

Creation Methods

Key Phrase | Form | Description
bes wizard | PlainGlobal | Returns a list of all the available BES Wizards. • Note: This is a Console-only Inspector. Win:6.0
current wizard | PlainGlobal | If this Inspector is being evaluated in the context of a Wizard, then it returns the corresponding <bes wizard> object. Win:6.0
wizard of <bes wizard variable> | Plain | Returns the <bes wizard> object to which the specified variable belongs. You can use "dashboard id of wizard of <bes wizard variable>" to get the correct dashboard id to use with the Store/DeleteVariable script functions (private variables are CONSOLE only). Win:7.0

Properties

Key Phrase | Form | Return Type | Description
charset of <bes wizard> | Plain | <string> | Returns the charset that should be used when displaying the specified Wizard. Win:6.0
dashboard id of <bes wizard> | Plain | <string> | Returns an ID that can be used by Dashboards/Wizards to unambiguously identify stored variables. Win:7.0
database id of <bes wizard> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database in which this BES Wizard resides. Win:6.0
database name of <bes wizard> | Plain | <string> | Returns the name (as a string) of the database containing the specified BES Wizard. Win:6.0
default page name of <bes wizard> | Plain | <string> | Returns the name of the first page to display when launching the specified Wizard. Win:6.0
dialog flag of <bes wizard> | Plain | <boolean> | Returns TRUE if the specified Wizard launches in a dialog box. Win:6.0
document flag of <bes wizard> | Plain | <boolean> | Returns TRUE if the specified Wizard launches in an MDI document window. Win:6.0
link <html> of <bes wizard> | Index<html> | <html> | Returns an HTML string containing an <A> tag including the supplied HTML description that, when clicked, will open the specified Wizard. • Note: This is a Console-only Inspector. Win:6.0
link <string> of <bes wizard> | Named | <html> | Returns an HTML string containing an <A> tag including the supplied descriptive string that, when clicked, will open the specified Wizard. • Note: This is a Console-only Inspector. Win:6.0
link href of <bes wizard> | Plain | <string> | The link href property does not return an <A> tag but rather returns the value of the href attribute of the <A> tag that would be constructed by the other link inspectors. This allows you to create more flexible linking formats. (See link of <bes wizard>). Notice that link href returns a normal string, not an HTML string. • Note: This is a Console-only Inspector. Win:6.0
link of <bes wizard> | Plain | <html> | Returns an HTML string containing an <A> tag that when clicked will open the specified Wizard. • Note: This is a Console-only Inspector. Win:6.0
menu path of <bes wizard> | Plain | <string> | Returns the path of the menu containing the menu item that launches the specified Wizard. Win:6.0
name of <bes wizard> | Plain | <string> | Returns the name of the specified BES Wizard. • Note: This is a Console-only Inspector. Win:6.0
navbar name of <bes wizard> | Plain | <string> | Returns the name of the specified BES Wizard as listed in the Navigation Bar. Win:6.0
pre60 flag of <bes wizard> | Plain | <boolean> | Returns TRUE if this wizard is an "old" (prior to version 6.0) style of Wizard. Win:6.0
private variable <string> of <bes wizard> | Named | <string> | Returns a string containing the value of the named private variable for the given BES Wizard. Win:7.0
private variable of <bes wizard> | Plain | <bes wizard variable> | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each private variable. Private variables are Console-only. Win:7.0
requires authoring flag of <bes wizard> | Plain | <boolean> | Returns TRUE if access to the specified Wizard requires that the user have the 'Authoring' bit set in their credentials. Win:6.0
shared variable <string> of <bes wizard> | Named | <string> | Returns a string containing the value of the named public or shared variable for the given BES Wizard. Win:7.0
shared variable of <bes wizard> | Plain | <bes wizard variable> | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each shared variable. Win:7.0
site of <bes wizard> | Plain | <bes site> | Returns the site hosting the specified BES Wizard. Win:7.0
url of <bes wizard> | Plain | <string> | Returns the URL of the specified Wizard. For ordinary Wizards, this is of the form "siteid:<id>,<filename>", but for Wizards that were added using the "Debug->Load Wizard..." dialog this is of the form "file:///<fullpath>". Win:6.0
variable of <bes wizard> | Plain | <bes wizard variable> | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each variable. Win:7.0

Examples

links (h1 of name of it) of bes wizards
Returns a list of HTML strings, each with an HTML link named for the Wizard and formatted as a header (h1).

links (name of it & "(" & dialog flag of it as string & ")")) of bes wizards
Returns an HTML string that will print the name and dialog flag of the Wizard inside a clickable <A> tag.

(br & html "Click <A href='" & link href of it & html "'>here</A> to open wizard " & name of it as string) of bes wizards
Returns an html string such as 'Click here to open wizard Windows Registry Wizard' that, when clicked, will open the corresponding Wizard.


BES Wizard Variable

These are Console-only Inspectors that return a list of the available BES Wizard variables.

Creation Methods

Key Phrase | Form | Description
private variable of <bes wizard> | Plain | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each private variable. Private variables are Console-only. Win:7.0
shared variable of <bes wizard> | Plain | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each shared variable. Win:7.0
variable of <bes wizard> | Plain | Iterates over all the variables for a Wizard, returning a <bes wizard variable> type for each variable. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
name of <bes wizard variable> | Plain | <string> | Returns the name of the specified Wizard variable. Win:7.0
private flag of <bes wizard variable> | Plain | <boolean> | Returns the private flag of the given <bes wizard variable> (private vars are CONSOLE only). Win:7.0
value of <bes wizard variable> | Plain | <string> | Returns the value of the given BES Wizard variable. Win:7.0
wizard of <bes wizard variable> | Plain | <bes wizard> | Returns the <bes wizard> object to which the specified variable belongs. You can use "dashboard id of wizard of <bes wizard variable>" to get the correct dashboard id to use with the Store/DeleteVariable script functions (private variables are CONSOLE only). Win:7.0


Exponential Projection

These Inspectors return statistical correlation information about the logarithms of the aggregated properties.

Creation Methods

Key Phrase | Form | Description
exponential fit of <statistical bin> | Plain | Calculates a least-squares fit on the sum of the logarithms of the absolute values of the values. This provides a way to extrapolate an exponential change of values. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
correlation coefficient of <exponential projection> | Plain | <floating point> | Returns a floating-point number between -1 and 1, representing how well an exponential projection fits the data. Win:6.0, Mac:7.1
extrapolation <time> of <exponential projection> | Index<time> | <floating point> | Returns the projected value at the specified time, assuming an exponential projection. Win:6.0, Mac:7.1
rate <time interval> of <exponential projection> | Index<time interval> | <floating point> | Returns the slope of the exponential projection over the specified time interval. Win:6.0, Mac:7.1


Fixlet Count Pair

These Inspectors return information about the Fixlet count pair objects for each severity level.

Creation Methods

Key Phrase | Form | Description
count map of <historical fixlet count> | Plain | Returns all of the <fixlet count pair> objects (one for each severity level) that were saved with the specified historical Fixlet count. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
count of <fixlet count pair> | Plain | <integer> | Returns the Fixlet count for each severity level of the Fixlet count pairs. Win:6.0
source severity of <fixlet count pair> | Plain | <string> | Returns the severity level corresponding to the given Fixlet count pair. Win:6.0


Historical Computer Count

These Inspectors provide information about historical computer count objects.

Creation Methods

Key Phrase | Form | Description
all computer count | PlainGlobal | Returns a list of all <historical_computer_count> objects. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
count of <historical computer count> | Plain | <integer> | Returns the count when the specified historical computer count was last archived. Win:6.0
database id of <historical computer count> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database containing the specified historical computer count. Win:6.0
time of <historical computer count> | Plain | <time> | Returns the time when the specified count was archived. Win:6.0


Historical Fixlet Count

These provide historical information about the number of Fixlets at different severity levels.

Creation Methods

Key Phrase | Form | Description
all fixlet count | PlainGlobal | Returns a list of all the historical Fixlet counts. • Note: This is a Web Reports-only Inspector. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
count map of <historical fixlet count> | Plain | <fixlet count pair> | Returns all of the <fixlet count pair> objects (one for each severity level) that were saved with the specified historical Fixlet count. Win:6.0
database id of <historical fixlet count> | Plain | <integer> | In the Web Reports environment, this Inspector returns the numeric ID of the database containing the specified historical Fixlet count. Win:6.0
time of <historical fixlet count> | Plain | <time> | Returns the time when the specified historical Fixlet count was calculated. Win:6.0


Linear Projection

These Inspectors return statistical correlation information about the linearity of specific aggregated properties.

Creation Methods

Key Phrase | Form | Description
linear fit of <statistical bin> | Plain | This Inspector calculates a least-squares fit on the sum of the values to project how that sum might change with time. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
correlation coefficient of <linear projection> | Plain | <floating point> | Returns a floating-point number between -1 and 1, representing how well a linear projection fits the data. Win:6.0, Mac:7.1
extrapolation <time> of <linear projection> | Index<time> | <floating point> | Returns the projected value at the specified time, assuming a linear projection. Win:6.0, Mac:7.1
rate of <linear projection> | Plain | <rate> | Returns the slope of the linear projection. Multiply this by a time interval to compute the projected growth over that period. Win:6.0, Mac:7.1


Rate

Rates are floating point numbers divided by time intervals. These Inspectors let you examine and convert rate objects.

Creation Methods

Key Phrase | Form | Description
maximum of <rate> | Plain | Returns the maximum value from a list of <rate> types. Win:7.1, Mac:7.1
mean sample rate of <statistical bin> | Plain | For instantaneous data, BES keeps sample-rate statistics to provide a gauge of how well-reported the data is. The sample interval is the time between consecutive samples on a single computer; the sample rate is the reciprocal of that time interval. Win:6.0
minimum of <rate> | Plain | Returns the minimum value from a list of <rate> types. Win:7.1, Mac:7.1
rate of <linear projection> | Plain | Returns the slope of the linear projection. Multiply this by a time interval to compute the projected growth over that period. Win:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<rate> as string | Cast | <string> | Casts a rate as a string. Win:6.0, Mac:7.1
extrema of <rate> | Plain | <( rate, rate )> | Returns the minimum and maximum extreme values of the given list of <rate> types. Win:7.1, Mac:7.1
maximum of <rate> | Plain | <rate> | Returns the maximum value from a list of <rate> types. Win:7.1, Mac:7.1
minimum of <rate> | Plain | <rate> | Returns the minimum value from a list of <rate> types. Win:7.1, Mac:7.1
unique value of <rate> | Plain | <rate with multiplicity> | Returns the unique values of a given list of <rate> types, removing duplicates and sorting by value. Win:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
- <rate> | <rate> | Returns the negative of the given rate. Win:6.0, Mac:7.1
<rate> * <time interval> | <floating point> | Multiplies a <rate> by a <time interval>, producing a floating point number. Win:6.0, Mac:7.1
<rate> {cmp} <rate> | <boolean> | Compare two rates, returning a boolean TRUE or FALSE, where {cmp} is one of: <, <=, =. Win:6.0
<rate> {op} <rate> | <rate> | Operate on two rates, returning a new rate, where {op} is one of: -, +. Win:6.0
<time interval> * <rate> | <floating point> | Multiplies a <time interval> by a <rate>, producing a floating point number. Win:6.0, Mac:7.1


Rate with Multiplicity

These Inspectors deal with rate arrays, allowing you to pluck out unique rate values and count them. These objects are derived from ordinary rate types.

Creation Methods

Key Phrase | Form | Description
unique value of <rate> | Plain | Returns the unique values of a given list of <rate> types, removing duplicates and sorting by value. Win:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <rate with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <rate> types. Win:7.1, Mac:7.1


Statistic Range

Statistical ranges are time intervals used to examine particular statistical bins.

Creation Methods

Key Phrase | Form | Description
range <time range> of <statistic range> | Index<time range> | For the duration of the specified time range, (time0 to time1), this Inspector returns a sub-range of bins beginning with earliest bin containing time0 and going up to (but not including) the bin containing time1. If either of these bins does not exist, it throws NoSuchObject. Win:6.0
statistic range of <bes property> | Plain | Returns the range of statistical bins associated with the given property. The property must be marked for statistical aggregation. If not, or if no clients have reported results, it throws NoSuchObject. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
bin at <time> of <statistic range> | Index<time> | <statistical bin> | Returns the bin in the specified statistical range which brackets the given time. If no such bin exists, it throws NoSuchObject. Win:6.0
bin of <statistic range> | Plain | <statistical bin> | Returns a list of the individual bins in the specified range. Primarily useful after downsampling (see total <time interval> of <statistic range>). Win:6.0
end of <statistic range> | Plain | <time> | Returns the ending time of the statistical range. Win:6.0
range <time range> of <statistic range> | Index<time range> | <statistic range> | For the duration of the specified time range, (time0 to time1), this Inspector returns a sub-range of bins beginning with earliest bin containing time0 and going up to (but not including) the bin containing time1. If either of these bins does not exist, it throws NoSuchObject. Win:6.0
start of <statistic range> | Plain | <time> | Returns the starting time of the statistical range. Win:6.0
total <time interval> of <statistic range> | Index<time interval> | <statistical bin> | This Inspector can be used to downsample or consolidate bins. It statistically totals over the given range, producing a new series of bins broken down by the (larger) specified time interval. The resulting range will start and end on a multiple of the interval. For example, if you ask for day bins, the results will start and end at midnight. If the specified time interval is not a multiple of the length of the starting bin of the range, this Inspector throws NoSuchObject. For example, you cannot get 6 hour totals of a range which starts with day bins. Win:6.0
total of <statistic range> | Plain | <statistical bin> | Totals the bins over the specified range, producing a single summary bin. This allows you to reduce the data by constraining the range. Win:6.0

Examples

mean of total of range ((now - day) & now) of statistics of property 1 of current analysis
Returns the mean (average) value across all reported values in the last day. Note that this might fail if there have been no reports in the last day.


Statistical Bin

Statistical bins contain property information summed over all computers in a given time period.

Creation Methods

Key Phrase | Form | Description
bin at <time> of <statistic range> | Index<time> | Returns the bin in the specified statistical range which brackets the given time. If no such bin exists, it throws NoSuchObject. Win:6.0
bin of <statistic range> | Plain | Returns a list of the individual bins in the specified range. Primarily useful after downsampling (see total <time interval> of <statistic range>). Win:6.0
total <time interval> of <statistic range> | Index<time interval> | This Inspector can be used to downsample or consolidate bins. It statistically totals over the given range, producing a new series of bins broken down by the (larger) specified time interval. The resulting range will start and end on a multiple of the interval. For example, if you ask for day bins, the results will start and end at midnight. If the specified time interval is not a multiple of the length of the starting bin of the range, this Inspector throws NoSuchObject. For example, you cannot get 6 hour totals of a range which starts with day bins. Win:6.0
total of <statistic range> | Plain | Totals the bins over the specified range, producing a single summary bin. This allows you to reduce the data by constraining the range. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
end of <statistical bin> | Plain | <time> | Returns the ending time of the specified statistical bin. Win:6.0
exponential fit of <statistical bin> | Plain | <exponential projection> | Calculates a least-squares fit on the sum of the logarithms of the absolute values of the values. This provides a way to extrapolate an exponential change of values. Win:6.0
failure rate of <statistical bin> | Plain | <floating point> | The integral over time of the number of failing computers divided by the integral over time of the number of reporting computers. Win:6.0
geometric mean of <statistical bin> | Plain | <floating point> | Returns the geometric mean of the specified statistical bin. Win:6.0
javascript array <string> of <statistical bin> | Named | <html> | Produces a section of JavaScript which initializes the named array of objects, one for each input bin. Each object in the array has JavaScript properties which match the above bin data properties. For each inspector property, the equivalent JavaScript property is named by CamelCasing the name of the inspector property. Win:6.0
kurtosis of <statistical bin> | Plain | <floating point> | Returns the kurtosis (a measure of the "narrowness" of the distribution) of the specified statistical bin. Win:6.0
length of <statistical bin> | Plain | <time interval> | Returns a time interval corresponding to the length (or period) of the specified bin. Win:6.0
linear fit of <statistical bin> | Plain | <linear projection> | Calculates a least-squares fit on the values, providing a tool for extrapolating a linear change of values. Win:6.0
logarithm kurtosis of <statistical bin> | Plain | <floating point> | The kurtosis of the logarithms of the absolute values of the nonzero reported values. Win:6.0
logarithm skewness of <statistical bin> | Plain | <floating point> | The skewness of the logarithms of the absolute values of the nonzero reported values. Win:6.0
logarithm standard deviation of <statistical bin> | Plain | <floating point> | The standard deviation of the logarithms of the absolute values of the nonzero reported values. Win:6.0
logarithm variance of <statistical bin> | Plain | <floating point> | The variance of the logarithms of the absolute values of the nonzero reported values. Win:6.0
maximum single computer total of <statistical bin> | Plain | <floating point> | Returns a floating point number representing the largest computer total in the specified bin. Win:6.0
maximum value of <statistical bin> | Plain | <floating point> | The maximum single value reported by any computer over the duration of the bin. Win:6.0
mean computer count of <statistical bin> | Plain | <floating point> | This is the integral over time of the number of computers reporting this property divided by the duration of the bin. It might be fractional if computers started or stopped reporting this property during the interval of the bin. Win:6.0
mean failing computer count of <statistical bin> | Plain | <floating point> | Returns the mean count of the computers where the inspection has failed. Win:6.0
mean logarithm of <statistical bin> | Plain | <floating point> | The integral over time of the sum of the logarithms of the absolute values of all nonzero reported values, divided by the integral over time of the number of nonzero reported values. Win:6.0
mean nonzero value count of <statistical bin> | Plain | <floating point> | Provides a measure of nonzero values, which is useful in interpreting the logarithmic results, which ignore zero values. The logarithmic results generally aren't interesting for any property that can be zero, so this Inspector can be used to validate property statistics. Win:6.0
mean of <statistical bin> | Plain | <floating point> | The integral over time of the sum of all reported values, divided by the integral over time of the number of reported values. The variance, standard deviation, skewness, and kurtosis inspectors have this same domain. In particular, computers that fail and computers that report no values don't affect these statistics. Win:6.0
mean sample interval of <statistical bin> | Plain | <time interval> | The sample interval is the time between consecutive samples on a single computer. The mean sample interval is the integral over time of the sum over computers of the sample interval divided by the integral over time of the number of reporting computers. This is the inverse of the mean sample rate. Win:6.0
mean sample rate of <statistical bin> | Plain | <rate> | This is the inverse of the mean sample interval. Win:6.0
mean successful computer count of <statistical bin> | Plain | <floating point> | Returns the mean count of the computers where the inspection has succeeded. Win:6.0
mean total of <statistical bin> | Plain | <floating point> | The integral over time of the sum of all values reported divided by the integral over time of the number of computers reporting this property (successfully or failing). Win:6.0
mean value count of <statistical bin> | Plain | <floating point> | This is the integral over time of the number of values reported divided by the integral over time of the number of computers reporting. That is, this is a mean over both time and computers. Win:6.0
mean zero value count of <statistical bin> | Plain | <floating point> | Provides a measure of zero values, which is useful in interpreting the logarithmic results, which ignore zero values. The logarithmic results generally aren't interesting for any property that can be zero, so this Inspector can be used to test for that issue. Win:6.0
minimum single computer total of <statistical bin> | Plain | <floating point> | The minimum over time and computers of the total of simultaneous values. (Thus, for a singular property, the same as "minimum value."). Win:6.0
minimum value of <statistical bin> | Plain | <floating point> | The minimum single value reported by any computer over the duration of the bin. Win:6.0
skewness of <statistical bin> | Plain | <floating point> | Returns a floating point number representing the skewness (a measure the assymetry of the data) over the specified bin. Win:6.0
standard deviation of <statistical bin> | Plain | <floating point> | Returns a floating point number representing the standard deviation of the data over the specified bin. Win:6.0
start of <statistical bin> | Plain | <time> | Returns the starting time of the statistical bin. Win:6.0
success rate of <statistical bin> | Plain | <floating point> | The integral over time of the number of successful computers divided by the integral over time of the number of reporting computers. Win:6.0
total lower bound of <statistical bin> | Plain | <floating point> | Returns the lower bound of a group of statistical bins. Win:6.0
total upper bound of <statistical bin> | Plain | <floating point> | Returns the upper bound of a group of statistical bins. Win:6.0
variance of <statistical bin> | Plain | <floating point> | Returns the variance of the specified statistical bin. Win:6.0

Examples

javascript array "statistics" of totals (6*hour) of statistics of property 1 of current analysis
Produces a JavaScript variable named "statistics" which holds an array of objects representing the statistical data for 6-hour periods across the entire range of data for the specified property. Make sure to restrict the range to a known size, so that the resulting array is not too big. For this example, the range must be 5-minute or hour bins, since day bins cannot be downsampled to 6-hour periods.


Utf8 String

UTF-8 (8-bit Unicode Transformation Format) is a variable-length character encoding format. It can represent all the characters in the Unicode standard, but it remains backward-compatible with ASCII. These Inspectors are specifically designed for the EvaluateRelevance API as used by BES Wizards.

Creation Methods

Key Phrase | Form | Description
<bes action set> as xml | Cast | Casts a BES Action set as an XML document, for submission to to the ImportXML API in the Console. It can only be used in the Console using the EvaluateRelevance API, not the <?relevance ?> interface. Win:7.0
<bes action> as xml | Cast | Converts the specified BES Action to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes computer group set> as xml | Cast | Converts the specified set of BES computer groups to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes computer group> as xml | Cast | Converts the specified BES computer group to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes fixlet set> as xml | Cast | Converts the specified set of BES Fixlets to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes fixlet> as xml | Cast | Converts the specified BES Fixlet to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes property set> as xml | Cast | Converts the specified set of BES Properties to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0
<bes property> as xml | Cast | Converts the specified BES Property to XML format, for submission to the EvaluateRelevance API used by the BES Console and Web Reports. Win:7.0