Intro

Intro to BigFix Inspectors and Actions

This online guide to the BigFix® Inspectors and Actions contains a list of all the BigFix 7.2 Core Inspectors as well as the Client Inspectors for Windows, Mac, Linux, AIX, HPUX and Solaris. It also describes all of the currently available BigFix Actions. Using this guide, you can write your own Relevance Expressions and use them to target actions to exactly those computers that need them. Both the BES Console and the BigFix Development Environment allow you to write Fixlet® messages, including Actions, and post them to Fixlet Sites. For more information on how these programs support the Relevance language, see the BigFix Console Operator’s Guide.

BigFix Action Shell Commands

After a Fixlet message locates a potential problem on a computer, it may offer to fix the problem with an Action Shell Command. This allows the user or administrator to quickly cure the problem across the entire network, often with a single mouse-click. This help file describes all the BigFix Action Shell Commands, with examples of each. At the bottom of each topic is a version number, such as BES 5.1 and above. This represents the first version that is compatible with the given topic. Some actions are marked "Windows Only," and will fail on Unix or Mac systems.

Many Action Shell Commands allow or require parameters. Those parameters can either be hard-coded (static) values or expressions that are evaluated by the BigFix relevance language. These substitution variables endow actions with great power and flexibility. Except where noted, all commands may perform substitution on their arguments before processing them.

Audience

This guide is for IT managers and other people who want to write Fixlet messages and Actions. This content will be deployed and monitored by the BigFix Enterprise Suite (BES) to keep a network of computers up to date and running smoothly without interruption. You can author Fixlets to automate the dozens of repetitive network-wide operations that are specific to your company. To get the most out of this manual, it helps to have some experience with the Windows Registry and the BigFix Relevance Language.


Key phrases

This is a list of the key phrases relevant to this document, sorted alphabetically.

Key Phrase | Plural | Creates a | From a | Form
abbr <string> of <html> | abbrs | <html> | <html> | Named
abbr <string> of <string> | abbrs | <html> | <string> | Named
abbr of <html> | abbrs | <html> | <html> | Plain
abbr of <string> | abbrs | <html> | <string> | Plain
absolute value of <hertz> | absolute values | <hertz> | <hertz> | Plain
absolute value of <integer> | absolute values | <integer> | <integer> | Plain
absolute value of <time interval> | absolute values | <time interval> | <time interval> | Plain
access mode of <access control entry> | access modes | <integer> | <access control entry> | Plain
accessed time of <filesystem object> | accessed times | <time> | <filesystem object> | Plain
accessed time of <symlink> | accessed times | <time> | <symlink> | Plain
account disabled flag of <local user> | account disabled flags | <boolean> | <local user> | Plain
account expiration of <local user> | account expirations | <time> | <local user> | Plain
account lockout duration of <security database> | account lockout durations | <time interval> | <security database> | Plain
account lockout observation window of <security database> | account lockout observation windows | <time interval> | <security database> | Plain
account lockout threshold of <security database> | account lockout thresholds | <integer> | <security database> | Plain
account logon category of <audit policy> | account logon categories | <audit policy category> | <audit policy> | Plain
account management category of <audit policy> | account management categories | <audit policy category> | <audit policy> | Plain
account name of <security identifier> | account names | <string> | <security identifier> | Plain
accounts operator flag of <local user> | accounts operator flags | <boolean> | <local user> | Plain
acronym <string> of <html> | acronyms | <html> | <html> | Named
acronym <string> of <string> | acronyms | <html> | <string> | Named
acronym of <html> | acronyms | <html> | <html> | Plain
acronym of <string> | acronyms | <html> | <string> | Plain
action | actions | <action> | <world> | PlainGlobal
action <integer> | actions | <action> | <world> | NumberedGlobal
action lock state | action lock states | <action lock state> | <world> | PlainGlobal
action of <firewall rule> | actions | <firewall action> | <firewall rule> | Plain
active action | active actions | <action> | <world> | PlainGlobal
active device | active devices | <active device> | <world> | PlainGlobal
active device file | active device files | <file> | <world> | PlainGlobal
active device file <string> | active device files | <file> | <world> | NamedGlobal
active of <action> | actives | <boolean> | <action> | Plain
active of <logged on user> | actives | <boolean> | <logged on user> | Plain
active start time of <action> | active start times | <time> | <action> | Plain
adapter <integer> of <network> | adapters | <network adapter> | <network> | Numbered
adapter <string> of <network> | adapters | <network adapter> | <network> | Named
adapter of <network> | adapters | <network adapter> | <network> | Plain
address <string> of <html> | addresss | <html> | <html> | Named
address <string> of <string> | addresss | <html> | <string> | Named
address list of <network adapter> | address lists | <network address list> | <network adapter> | Plain
address of <html> | addresss | <html> | <html> | Plain
address of <network adapter> | addresses | <ipv4 address> | <network adapter> | Plain
address of <network address list> | addresses | <ipv4 address> | <network address list> | Plain
address of <network ip interface> | addresses | <ipv4 address> | <network ip interface> | Plain
address of <string> | addresss | <html> | <string> | Plain
admin privilege of <local user> | admin privileges | <boolean> | <local user> | Plain
administrative rights of <client> | administrative rightss | <setting> | <client> | Plain
administrator <string> of <client> | administrators | <setting> | <client> | Named
administrator of <client> | administrators | <setting> | <client> | Plain
alias of <file> | aliases | <boolean> | <file> | Plain
alias of <network ip interface> | aliases | <boolean> | <network ip interface> | Plain
all firewall scope | all firewall scopes | <firewall scope> | <world> | PlainGlobal
allocation block count of <volume> | allocation block counts | <integer> | <volume> | Plain
allow firewall action | allow firewall actions | <firewall action> | <world> | PlainGlobal
allow inbound echo request of <firewall icmp settings> | allow inbound echo requests | <boolean> | <firewall icmp settings> | Plain
allow inbound mask request of <firewall icmp settings> | allow inbound mask requests | <boolean> | <firewall icmp settings> | Plain
allow inbound router request of <firewall icmp settings> | allow inbound router requests | <boolean> | <firewall icmp settings> | Plain
allow inbound timestamp request of <firewall icmp settings> | allow inbound timestamp requests | <boolean> | <firewall icmp settings> | Plain
allow outbound destination unreachable of <firewall icmp settings> | allow outbound destination unreachables | <boolean> | <firewall icmp settings> | Plain
allow outbound packet too big of <firewall icmp settings> | allow outbound packet too bigs | <boolean> | <firewall icmp settings> | Plain
allow outbound parameter problem of <firewall icmp settings> | allow outbound parameter problems | <boolean> | <firewall icmp settings> | Plain
allow outbound source quench of <firewall icmp settings> | allow outbound source quenches | <boolean> | <firewall icmp settings> | Plain
allow outbound time exceeded of <firewall icmp settings> | allow outbound time exceededs | <boolean> | <firewall icmp settings> | Plain
allow redirect of <firewall icmp settings> | allow redirects | <boolean> | <firewall icmp settings> | Plain
allowed workstations string of <local user> | allowed workstations strings | <string> | <local user> | Plain
ancestor of <filesystem object> | ancestors | <folder> | <filesystem object> | Plain
ancestor of <symlink> | ancestors | <folder> | <symlink> | Plain
anchor <string> of <html> | anchors | <html> | <html> | Named
anchor <string> of <string> | anchors | <html> | <string> | Named
anchor of <html> | anchors | <html> | <html> | Plain
anchor of <string> | anchors | <html> | <string> | Plain
ansi code page | ansi code pages | <integer> | <world> | PlainGlobal
any ip version | any ip versions | <ip version> | <world> | PlainGlobal
apparent registration server time | apparent registration server times | <time> | <world> | PlainGlobal
append permission of <access control entry> | append permissions | <boolean> | <access control entry> | Plain
apple extras folder of <domain> | apple extras folders | <folder> | <domain> | Plain
apple menu items folder of <domain> | apple menu items folders | <folder> | <domain> | Plain
application | applications | <filesystem object> | <world> | PlainGlobal
application <string> | applications | <application> | <world> | NamedGlobal
application <string> | applications | <filesystem object> | <world> | NamedGlobal
application <string> of <folder> | applications | <application> | <folder> | Named
application <string> of <registry key> | applications | <application> | <registry key> | Named
application <string> of <registry> | applications | <application> | <registry> | Named
application event log | application event logs | <event log> | <world> | PlainGlobal
application folder <string> of <registry key> | application folders | <folder> | <registry key> | Named
application folder <string> of <registry> | application folders | <folder> | <registry> | Named
application folder of <registry key> | application folders | <folder> | <registry key> | Plain
application name of <firewall rule> | application names | <string> | <firewall rule> | Plain
application of <folder> | applications | <filesystem object> | <folder> | Plain
application of <registry key> | applications | <application> | <registry key> | Plain
application of <registry> | applications | <application> | <registry> | Plain
application parameter string of <local user> | application parameter strings | <string> | <local user> | Plain
application support folder of <domain> | application support folders | <folder> | <domain> | Plain
application usage summary | application usage summaries | <application usage summary> | <world> | PlainGlobal
application usage summary <string> | application usage summaries | <application usage summary> | <world> | NamedGlobal
applications folder of <domain> | applications folders | <folder> | <domain> | Plain
april | aprils | <month> | <world> | PlainGlobal
april <integer> | aprils | <day of year> | <world> | NumberedGlobal
april <integer> of <integer> | aprils | <date> | <integer> | Numbered
april of <integer> | aprils | <month and year> | <integer> | Plain
arch of <pkginfo> | archs | <string> | <pkginfo> | Plain
architecture of <operating system> | architectures | <string> | <operating system> | Plain
architecture of <package> | architectures | <string> | <package> | Plain
archive of <filesystem object> | archives | <boolean> | <filesystem object> | Plain
argument string of <file shortcut> | argument strings | <string> | <file shortcut> | Plain
array <integer> of <array> | arrays | <array> | <array> | Numbered
array <string> of <dictionary> | arrays | <array> | <dictionary> | Named
array <string> of <preference> | arrays | <array> | <preference> | Named
array of <osxvalue> | arrays | <array> | <osxvalue> | Plain
assistants folder of <domain> | assistants folders | <folder> | <domain> | Plain
attribute <integer> of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Numbered
attribute <string> of <user> | attributes | <user attribute> | <user> | Named
attribute <string> of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Named
attribute of <user> | attributes | <user attribute> | <user> | Plain
attribute of <xml dom node> | attributes | <xml dom node> | <xml dom node> | Plain
attribute permission of <network share> | attribute permissions | <boolean> | <network share> | Plain
audio folder of <domain> | audio folders | <folder> | <domain> | Plain
audio plane of <registryroot> | audio planes | <registrynode> | <registryroot> | Plain
audit failure event log event type | audit failure event log event types | <event log event type> | <world> | PlainGlobal
audit failure of <audit policy information> | audit failures | <boolean> | <audit policy information> | Plain
audit level of <local mssql database> | audit levels | <integer> | <local mssql database> | Plain
audit policy | audit policies | <audit policy> | <world> | PlainGlobal
audit success event log event type | audit success event log event types | <event log event type> | <world> | PlainGlobal
audit success of <audit policy information> | audit successes | <boolean> | <audit policy information> | Plain
august | augusts | <month> | <world> | PlainGlobal
august <integer> | augusts | <day of year> | <world> | NumberedGlobal
august <integer> of <integer> | augusts | <date> | <integer> | Numbered
august of <integer> | augusts | <month and year> | <integer> | Plain
authorized application of <firewall profile> | authorized applications | <firewall authorized application> | <firewall profile> | Plain
available amount of <ram> | available amounts | <integer> | <ram> | Plain
b <string> of <html> | bs | <html> | <html> | Named
b <string> of <string> | bs | <html> | <string> | Named
b of <html> | bs | <html> | <html> | Plain
b of <string> | bs | <html> | <string> | Plain
backoffice bit <operating system suite mask> | backoffice bits | <boolean> | <world> | Index<operating system suite mask>Global
backup time of <filesystem object> | backup times | <time> | <filesystem object> | Plain
bad password count of <local user> | bad password counts | <integer> | <local user> | Plain
base <string> of <html> | bases | <html> | <html> | Named
base <string> of <string> | bases | <html> | <string> | Named
base of <html> | bases | <html> | <html> | Plain
base of <patch> | bases | <string> | <patch> | Plain
base of <string> | bases | <html> | <string> | Plain
bes license | bes licenses | <license> | <world> | PlainGlobal
big <string> of <html> | bigs | <html> | <html> | Named
big <string> of <string> | bigs | <html> | <string> | Named
big of <html> | bigs | <html> | <html> | Plain
big of <string> | bigs | <html> | <string> | Plain
binary operator <string> | binary operators | <binary operator> | <world> | NamedGlobal
binary operator returning <type> | binary operators returning | <binary operator> | <world> | Index<type>Global
bit <integer> | bits | <bit set> | <world> | NumberedGlobal
bit <integer> of <bit set> | bits | <boolean> | <bit set> | Numbered
bit <integer> of <integer> | bits | <boolean> | <integer> | Numbered
bit set <string> | bit sets | <bit set> | <world> | NamedGlobal
blade bit <operating system suite mask> | blade bits | <boolean> | <world> | Index<operating system suite mask>Global
block firewall action | block firewall actions | <firewall action> | <world> | PlainGlobal
blockquote <string> of <html> | blockquotes | <html> | <html> | Named
blockquote <string> of <string> | blockquotes | <html> | <string> | Named
blockquote of <html> | blockquotes | <html> | <html> | Plain
blockquote of <string> | blockquotes | <html> | <string> | Plain
body <string> of <html> | bodys | <html> | <html> | Named
body <string> of <string> | bodys | <html> | <string> | Named
body of <html> | bodys | <html> | <html> | Plain
body of <string> | bodys | <html> | <string> | Plain
bogomips of <processor> | bogomipses | <integer> | <processor> | Plain
boolean <integer> of <array> | booleans | <boolean> | <array> | Numbered
boolean <string> | booleans | <boolean> | <world> | NamedGlobal
boolean <string> of <dictionary> | booleans | <boolean> | <dictionary> | Named
boolean <string> of <preference> | booleans | <boolean> | <preference> | Named
boolean of <osxvalue> | booleans | <boolean> | <osxvalue> | Plain
boolean value <integer> of <wmi select> | boolean values | <boolean> | <wmi select> | Numbered
boolean value of <wmi select> | boolean values | <boolean> | <wmi select> | Plain
boot time of <operating system> | boot times | <time> | <operating system> | Plain
br | brs | <html> | <world> | PlainGlobal
br <string> | brs | <html> | <world> | NamedGlobal
brand id of <processor> | brand ids | <integer> | <processor> | Plain
brand string of <processor> | brand strings | <string> | <processor> | Plain
broadcast address of <network adapter> | broadcast addresses | <ipv4 address> | <network adapter> | Plain
broadcast address of <network ip interface> | broadcast addresses | <ipv4 address> | <network ip interface> | Plain
broadcast support of <network adapter> | broadcast supports | <boolean> | <network adapter> | Plain
broadcast support of <network ip interface> | broadcast supports | <boolean> | <network ip interface> | Plain
buffered amount of <ram> | buffered amounts | <integer> | <ram> | Plain
bug revision of <version> | bug revisions | <integer> | <version> | Plain
build number high of <operating system> | build number highs | <integer> | <operating system> | Plain
build number low of <operating system> | build number lows | <integer> | <operating system> | Plain
build number of <operating system> | build numbers | <integer> | <operating system> | Plain
build number of <operating system> | build numbers | <string> | <operating system> | Plain
build of <operating system> | builds | <string> | <operating system> | Plain
build revision of <version> | build revisions | <integer> | <version> | Plain
built in of <firewall open port> | built ins | <boolean> | <firewall open port> | Plain
bundle <string> | bundles | <bundle> | <world> | NamedGlobal
bundle <string> of <software_depot> | bundles | <bundle> | <software_depot> | Named
bundle of <folder> | bundles | <bundle> | <folder> | Plain
bundle of <product> | bundles | <bundle> | <product> | Plain
bundle of <software_depot> | bundles | <bundle> | <software_depot> | Plain
bundle version of <bundle> | bundle versions | <version> | <bundle> | Plain
bundle version of <filesystem object> | bundle versions | <version> | <filesystem object> | Plain
bundle version of <folder> | bundle versions | <version> | <folder> | Plain
byte <integer> of <file> | bytes | <integer> | <file> | Numbered
cache folder of <domain> | cache folders | <folder> | <domain> | Plain
cached amount of <ram> | cached amounts | <integer> | <ram> | Plain
can interact with desktop of <service> | can interact with desktops | <boolean> | <service> | Plain
capability <string> | capabilities | <capability> | <world> | NamedGlobal
capability <string> of <rpmdatabase> | capabilities | <capability> | <rpmdatabase> | Named
caption <string> of <html> | captions | <html> | <html> | Named
caption <string> of <string> | captions | <html> | <string> | Named
caption of <html> | captions | <html> | <html> | Plain
caption of <string> | captions | <html> | <string> | Plain
carbon folder of <domain> | carbon folders | <folder> | <domain> | Plain
case insensitive regex <string> | case insensitive regexes | <regular expression> | <world> | NamedGlobal
case insensitive regular expression <string> | case insensitive regular expressions | <regular expression> | <world> | NamedGlobal
cast <string> | casts | <cast> | <world> | NamedGlobal
cast from of <type> | casts from | <cast> | <type> | Plain
cast returning <type> | casts returning | <cast> | <world> | Index<type>Global
category of <audit policy> | categories | <audit policy category> | <audit policy> | Plain
category of <event log record> | categories | <integer> | <event log record> | Plain
category of <pkginfo> | categories | <string> | <pkginfo> | Plain
change notification permission of <access control entry> | change notification permissions | <boolean> | <access control entry> | Plain
change time of <symlink> | change times | <time> | <symlink> | Plain
character <integer> | characters | <string> | <world> | NumberedGlobal
character <integer> of <string> | characters | <substring> | <string> | Numbered
character of <string> | characters | <substring> | <string> | Plain
checkpoint of <service> | checkpoints | <integer> | <service> | Plain
chewable items folder of <domain> | chewable items folders | <folder> | <domain> | Plain
child node <integer> of <xml dom node> | child nodes | <xml dom node> | <xml dom node> | Numbered
child node of <xml dom node> | child nodes | <xml dom node> | <xml dom node> | Plain
cidr string of <network adapter> | cidr strings | <string> | <network adapter> | Plain
cidr string of <network address list> | cidr strings | <string> | <network address list> | Plain
cidr string of <network ip interface> | cidr strings | <string> | <network ip interface> | Plain
cite <string> of <html> | cites | <html> | <html> | Named
cite <string> of <string> | cites | <html> | <string> | Named
cite of <html> | cites | <html> | <html> | Plain
cite of <string> | cites | <html> | <string> | Plain
class of <active device> | classes | <string> | <active device> | Plain
classic domain | classic domains | <domain> | <world> | PlainGlobal
classic folder of <domain> | classic folders | <folder> | <domain> | Plain
classname of <registrynode> | classnames | <string> | <registrynode> | Plain
client | clients | <client> | <world> | PlainGlobal
client cryptography | client cryptographies | <client_cryptography> | <world> | PlainGlobal
client folder of <site> | client folders | <folder> | <site> | Plain
client license | client licenses | <license> | <world> | PlainGlobal
code <string> of <html> | codes | <html> | <html> | Named
code <string> of <string> | codes | <html> | <string> | Named
code of <html> | codes | <html> | <html> | Plain
code of <string> | codes | <html> | <string> | Plain
code page of <local user> | code pages | <integer> | <local user> | Plain
codepage of <file version block> | codepages | <string> | <file version block> | Plain
col <string> of <html> | cols | <html> | <html> | Named
col <string> of <string> | cols | <html> | <string> | Named
col of <html> | cols | <html> | <html> | Plain
col of <string> | cols | <html> | <string> | Plain
colgroup <string> of <html> | colgroups | <html> | <html> | Named
colgroup <string> of <string> | colgroups | <html> | <string> | Named
colgroup of <html> | colgroups | <html> | <html> | Plain
colgroup of <string> | colgroups | <html> | <string> | Plain
color sync folder of <domain> | color sync folders | <folder> | <domain> | Plain
colorsync profiles folder of <domain> | colorsync profiles folders | <folder> | <domain> | Plain
coma bug of <processor> | coma bugs | <boolean> | <processor> | Plain
comment of <local group> | comments | <string> | <local group> | Plain
comment of <local user> | comments | <string> | <local user> | Plain
comment of <network share> | comments | <string> | <network share> | Plain
common name of <license> | common names | <string> | <license> | Plain
communications bit <operating system suite mask> | communications bits | <boolean> | <world> | Index<operating system suite mask>Global
communications operator flag of <local user> | communications operator flags | <boolean> | <local user> | Plain
competition size of <selected server> | competition sizes | <integer> | <selected server> | Plain
competition weight of <selected server> | competition weights | <integer> | <selected server> | Plain
complete time of <action> | complete times | <time> | <action> | Plain
component | components | <component> | <world> | PlainGlobal
component <integer> of <distinguished name> | components | <distinguished name component> | <distinguished name> | Numbered
component <integer> of <site version list> | components | <integer> | <site version list> | Numbered
component folder of <domain> | component folders | <folder> | <domain> | Plain
component of <distinguished name> | components | <distinguished name component> | <distinguished name> | Plain
component string of <security identifier> | component strings | <string> | <security identifier> | Plain
compressed of <filesystem object> | compresseds | <boolean> | <filesystem object> | Plain
computer | computers | <computer> | <world> | PlainGlobal
computer id | computer ids | <integer> | <world> | PlainGlobal
computer name | computer names | <string> | <world> | PlainGlobal
computer of <event log record> | computers | <string> | <event log record> | Plain
concatenation <html> of <html> | concatenations | <html> | <html> | Index<html>
concatenation <html> of <string> | concatenations | <html> | <string> | Index<html>
concatenation <string> of <html> | concatenations | <html> | <html> | Named
concatenation <string> of <string> | concatenations | <string> | <string> | Named
concatenation of <html> | concatenations | <html> | <html> | Plain
concatenation of <string> | concatenations | <string> | <string> | Plain
conflict of <package> | conflicts | <capability> | <package> | Plain
conjunction of <boolean> | conjunctions | <boolean> | <boolean> | Plain
connection of <network> | connections | <connection> | <network> | Plain
connection status <integer> | connection statuses | <connection status> | <world> | NumberedGlobal
connection status authenticating | connection statuses authenticating | <connection status> | <world> | PlainGlobal
connection status authentication failed | connection statuses authentication failed | <connection status> | <world> | PlainGlobal
connection status authentication succeeded | connection statuses authentication succeeded | <connection status> | <world> | PlainGlobal
connection status connected | connection statuses connected | <connection status> | <world> | PlainGlobal
connection status connecting | connection statuses connecting | <connection status> | <world> | PlainGlobal
connection status disconnected | connection statuses disconnected | <connection status> | <world> | PlainGlobal
connection status disconnecting | connection statuses disconnecting | <connection status> | <world> | PlainGlobal
connection status hardware disabled | connection statuses hardware disabled | <connection status> | <world> | PlainGlobal
connection status hardware malfunction | connection statuses hardware malfunction | <connection status> | <world> | PlainGlobal
connection status media disconnected | connection statuses media disconnected | <connection status> | <world> | PlainGlobal
connection status no hardware present | connection statuses no hardware present | <connection status> | <world> | PlainGlobal
constrained of <action> | constraineds | <boolean> | <action> | Plain
content of <file> | contents | <file content> | <file> | Plain
contextual menu items folder of <domain> | contextual menu items folders | <folder> | <domain> | Plain
control of <security descriptor> | controls | <integer> | <security descriptor> | Plain
control panels folder of <domain> | control panels folders | <folder> | <domain> | Plain
control strip modules folder of <domain> | control strip modules folders | <folder> | <domain> | Plain
controller of <action lock state> | controllers | <string> | <action lock state> | Plain
core services folder of <domain> | core services folders | <folder> | <domain> | Plain
country <string> | countries | <country> | <world> | NamedGlobal
country code of <local user> | country codes | <integer> | <local user> | Plain
cpu speed | cpu speeds | <integer> | <world> | PlainGlobal
cpuid level of <processor> | cpuid levels | <integer> | <processor> | Plain
create file permission of <access control entry> | create file permissions | <boolean> | <access control entry> | Plain
create folder permission of <access control entry> | create folder permissions | <boolean> | <access control entry> | Plain
create link permission of <access control entry> | create link permissions | <boolean> | <access control entry> | Plain
create permission of <network share> | create permissions | <boolean> | <network share> | Plain
create subkey permission of <access control entry> | create subkey permissions | <boolean> | <access control entry> | Plain
creation time of <filesystem object> | creation times | <time> | <filesystem object> | Plain
creator of <bundle> | creators | <file signature> | <bundle> | Plain
cryptography | cryptographies | <cryptography> | <world> | PlainGlobal
csd version of <operating system> | csd versions | <string> | <operating system> | Plain
csidl folder <integer> | csidl folders | <folder> | <world> | NumberedGlobal
cstring <string> of <dictionary> | cstrings | <string> | <dictionary> | Named
cstring of <osxvalue> | cstrings | <string> | <osxvalue> | Plain
current date | current dates | <date> | <world> | PlainGlobal
current day_of_month | current days_of_month | <day of month> | <world> | PlainGlobal
current day_of_week | current days_of_week | <day of week> | <world> | PlainGlobal
current day_of_year | current days_of_year | <day of year> | <world> | PlainGlobal
current firewall profile type | current firewall profile types | <firewall profile type> | <world> | PlainGlobal
current month | current months | <month> | <world> | PlainGlobal
current month_and_year | current months_and_years | <month and year> | <world> | PlainGlobal
current profile of <firewall policy> | current profiles | <firewall profile> | <firewall policy> | Plain
current profile type of <firewall> | current profile types | <firewall profile type> | <firewall> | Plain
current relay | current relays | <current relay> | <world> | PlainGlobal
current site | current sites | <site> | <world> | PlainGlobal
current time_of_day | current times_of_day | <time of day with time zone> | <world> | PlainGlobal
current time_of_day <time zone> | current times_of_day | <time of day with time zone> | <world> | Index<time zone>Global
current user | current users | <logged on user> | <world> | PlainGlobal
current user | current users | <user> | <world> | PlainGlobal
current user folder of <domain> | current user folders | <folder> | <domain> | Plain
current user key <logged on user> of <registry> | current user keys | <registry key> | <registry> | Index<logged on user>
current year | current years | <year> | <world> | PlainGlobal
currently active of <firewall rule> | currently actives | <boolean> | <firewall rule> | Plain
custom firewall scope | custom firewall scopes | <firewall scope> | <world> | PlainGlobal
custom site subscription effective date <string> | custom site subscription effective dates | <time> | <world> | NamedGlobal
customized of <firewall service> | customizeds | <boolean> | <firewall service> | Plain
dacl of <security descriptor> | dacls | <discretionary access control list> | <security descriptor> | Plain
data <string> of <dictionary> | datas | <string> | <dictionary> | Named
data fork of <file> | data forks | <datafork> | <file> | Plain
data of <osxvalue> | datas | <string> | <osxvalue> | Plain
datacenter bit <operating system suite mask> | datacenter bits | <boolean> | <world> | Index<operating system suite mask>Global
date <integer> of <array> | dates | <time> | <array> | Numbered
date <string> | dates | <date> | <world> | NamedGlobal
date <string> of <dictionary> | dates | <time> | <dictionary> | Named
date <string> of <preference> | dates | <time> | <preference> | Named
date <time zone> of <time> | dates | <date> | <time> | Index<time zone>
date of <bios> | dates | <string> | <bios> | Plain
date of <osxvalue> | dates | <time> | <osxvalue> | Plain
day | days | <time interval> | <world> | PlainGlobal
day of <day of year> | days | <day of month> | <day of year> | Plain
day_of_month <integer> | days_of_month | <day of month> | <world> | NumberedGlobal
day_of_month <string> | days_of_month | <day of month> | <world> | NamedGlobal
day_of_month of <date> | days_of_month | <day of month> | <date> | Plain
day_of_week <string> | days_of_week | <day of week> | <world> | NamedGlobal
day_of_week of <date> | days_of_week | <day of week> | <date> | Plain
day_of_year of <date> | days_of_year | <day of year> | <date> | Plain
dd <string> of <html> | dds | <html> | <html> | Named
dd <string> of <string> | dds | <html> | <string> | Named
dd of <html> | dds | <html> | <html> | Plain
dd of <string> | dds | <html> | <string> | Plain
december | decembers | <month> | <world> | PlainGlobal
december <integer> | decembers | <day of year> | <world> | NumberedGlobal
december <integer> of <integer> | decembers | <date> | <integer> | Numbered
december of <integer> | decembers | <month and year> | <integer> | Plain
default value of <registry key> | default values | <registry key value> | <registry key> | Plain
default web browser | default web browsers | <application> | <world> | PlainGlobal
default web browser | default web browsers | <file> | <world> | PlainGlobal
definition list <string> of <html> | definition lists | <html> | <html> | Named
definition list <string> of <string> | definition lists | <html> | <string> | Named
definition list of <html> | definition lists | <html> | <html> | Plain
definition list of <string> | definition lists | <html> | <string> | Plain
del <string> of <html> | dels | <html> | <html> | Named
del <string> of <string> | dels | <html> | <string> | Named
del of <html> | dels | <html> | <html> | Plain
del of <string> | dels | <html> | <string> | Plain
delete child permission of <access control entry> | delete child permissions | <boolean> | <access control entry> | Plain
delete permission of <access control entry> | delete permissions | <boolean> | <access control entry> | Plain
delete permission of <network share> | delete permissions | <boolean> | <network share> | Plain
descendant folder of <folder> | descendant folders | <folder> | <folder> | Plain
descendant of <folder> | descendants | <file> | <folder> | Plain
description of <active device> | descriptions | <string> | <active device> | Plain
description of <event log record> | descriptions | <string> | <event log record> | Plain
description of <fileset> | descriptions | <string> | <fileset> | Plain
description of <firewall rule> | descriptions | <string> | <firewall rule> | Plain
description of <network adapter> | descriptions | <string> | <network adapter> | Plain
desired encrypt report of <client_cryptography> | desired encrypt reports | <boolean> | <client_cryptography> | Plain
desired fips mode of <cryptography> | desired fips modes | <boolean> | <cryptography> | Plain
desktop folder of <domain> | desktop folders | <folder> | <domain> | Plain
detailed tracking category of <audit policy> | detailed tracking categories | <audit policy category> | <audit policy> | Plain
developer docs folder of <domain> | developer docs folders | <folder> | <domain> | Plain
developer folder of <domain> | developer folders | <folder> | <domain> | Plain
developer help folder of <domain> | developer help folders | <folder> | <domain> | Plain
device key <string> of <registry> | device keys | <registry key> | <registry> | Named
device key of <registry> | device keys | <registry key> | <registry> | Plain
device name of <connection> | device names | <string> | <connection> | Plain
devicetree plane of <registryroot> | devicetree planes | <registrynode> | <registryroot> | Plain
dfn <string> of <html> | dfns | <html> | <html> | Named
dfn <string> of <string> | dfns | <html> | <string> | Named
dfn of <html> | dfns | <html> | <html> | Plain
dfn of <string> | dfns | <html> | <string> | Plain
dhcp enabled of <network adapter> | dhcp enableds | <boolean> | <network adapter> | Plain
dhcp server of <network adapter> | dhcp servers | <ipv4 address> | <network adapter> | Plain
dictionary <integer> of <array> | dictionaries | <dictionary> | <array> | Numbered
dictionary <string> of <dictionary> | dictionaries | <dictionary> | <dictionary> | Named
dictionary <string> of <preference> | dictionaries | <dictionary> | <preference> | Named
dictionary of <file> | dictionaries | <dictionary> | <file> | Plain
dictionary of <osxvalue> | dictionaries | <dictionary> | <osxvalue> | Plain
dictionary of <registrynode> | dictionaries | <dictionary> | <registrynode> | Plain
dictionary of <registryroot> | dictionaries | <dictionary> | <registryroot> | Plain
direct object type of <property> | direct object types | <type> | <property> | Plain
directory count of <volume> | directory counts | <integer> | <volume> | Plain
disabled control panels folder of <domain> | disabled control panels folders | <folder> | <domain> | Plain
disabled extensions folder of <domain> | disabled extensions folders | <folder> | <domain> | Plain
disabled shutdown items folder of <domain> | disabled shutdown items folders | <folder> | <domain> | Plain
disabled startup items folder of <domain> | disabled startup items folders | <folder> | <domain> | Plain
disabled system extensions folder of <domain> | disabled system extensions folders | <folder> | <domain> | Plain
disjunction of <boolean> | disjunctions | <boolean> | <boolean> | Plain
display name of <service> | display names | <string> | <service> | Plain
distance of <selected server> | distances | <integer range> | <selected server> | Plain
distinguished name error message of <active directory local computer> | distinguished name error messages | <string> | <active directory local computer> | Plain
distinguished name of <active directory local computer> | distinguished names | <string> | <active directory local computer> | Plain
div <string> of <html> | divs | <html> | <html> | Named
div <string> of <string> | divs | <html> | <string> | Named
div of <html> | divs | <html> | <html> | Plain
div of <string> | divs | <html> | <string> | Plain
divided by zero of <floating point> | divided by zeroes | <boolean> | <floating point> | Plain
dmi | dmis | <dmi> | <world> | PlainGlobal
dns name | dns names | <string> | <world> | PlainGlobal
dns server of <network adapter> | dns servers | <network address list> | <network adapter> | Plain
dns server of <network> | dns servers | <network address list> | <network> | Plain
dns suffix of <network adapter> | dns suffixes | <string> | <network adapter> | Plain
documentation folder of <domain> | documentation folders | <folder> | <domain> | Plain
documents folder of <domain> | documents folders | <folder> | <domain> | Plain
domain firewall profile type | domain firewall profile types | <firewall profile type> | <world> | PlainGlobal
domain library folder of <domain> | domain library folders | <folder> | <domain> | Plain
domain name | domain names | <string> | <world> | PlainGlobal
domain name of <security identifier> | domain names | <string> | <security identifier> | Plain
domain profile of <firewall policy> | domain profiles | <firewall profile> | <firewall policy> | Plain
domain top folder of <domain> | domain top folders | <folder> | <domain> | Plain
domain user | domain users | <local user> | <world> | PlainGlobal
domain user <string> | domain users | <local user> | <world> | NamedGlobal
domainname | domainnames | <string> | <world> | PlainGlobal
download file <string> | download files | <file> | <world> | NamedGlobal
download folder | download folders | <folder> | <world> | PlainGlobal
download path <string> | download paths | <string> | <world> | NamedGlobal
drive | drives | <filesystem> | <world> | PlainGlobal
drive | drives | <volume> | <world> | PlainGlobal
drive <integer> | drives | <volume> | <world> | NumberedGlobal
drive <string> | drives | <drive> | <world> | NamedGlobal
drive <string> | drives | <filesystem> | <world> | NamedGlobal
drive <string> | drives | <volume> | <world> | NamedGlobal
drive of <file> | drives | <filesystem> | <file> | Plain
drive of <file> | drives | <volume> | <file> | Plain
drive of <filesystem object> | drives | <drive> | <filesystem object> | Plain
drive of <folder> | drives | <filesystem> | <folder> | Plain
drive of <folder> | drives | <volume> | <folder> | Plain
drive of <symlink> | drives | <filesystem> | <symlink> | Plain
driver key of <active device> | driver keys | <registry key> | <active device> | Plain
driver key of <registry key> | driver keys | <registry key> | <registry key> | Plain
driver key value name of <active device> | driver key value names | <string> | <active device> | Plain
ds access category of <audit policy> | ds access categories | <audit policy category> | <audit policy> | Plain
dt <string> of <html> | dts | <html> | <html> | Named
dt <string> of <string> | dts | <html> | <string> | Named
dt of <html> | dts | <html> | <html> | Plain
dt of <string> | dts | <html> | <string> | Plain
edge traversal allowed of <firewall rule> | edge traversal alloweds | <boolean> | <firewall rule> | Plain
effective access mode for <string> of <access control list> | effective access modes for | <integer> | <access control list> | Named
effective access system security permission for <string> of <access control list> | effective access system security permissions for | <boolean> | <access control list> | Named
effective append permission for <string> of <access control list> | effective append permissions for | <boolean> | <access control list> | Named
effective change notification permission for <string> of <access control list> | effective change notification permissions for | <boolean> | <access control list> | Named
effective create file permission for <string> of <access control list> | effective create file permissions for | <boolean> | <access control list> | Named
effective create folder permission for <string> of <access control list> | effective create folder permissions for | <boolean> | <access control list> | Named
effective create link permission for <string> of <access control list> | effective create link permissions for | <boolean> | <access control list> | Named
effective create subkey permission for <string> of <access control list> | effective create subkey permissions for | <boolean> | <access control list> | Named
effective date of <action lock state> | effective dates | <time> | <action lock state> | Plain
effective date of <setting> | effective dates | <time> | <setting> | Plain
effective delete child permission for <string> of <access control list> | effective delete child permissions for | <boolean> | <access control list> | Named
effective delete permission for <string> of <access control list> | effective delete permissions for | <boolean> | <access control list> | Named
effective enumerate subkeys permission for <string> of <access control list> | effective enumerate subkeys permissions for | <boolean> | <access control list> | Named
effective execute permission for <string> of <access control list> | effective execute permissions for | <boolean> | <access control list> | Named
effective generic all permission for <string> of <access control list> | effective generic all permissions for | <boolean> | <access control list> | Named
effective generic execute permission for <string> of <access control list> | effective generic execute permissions for | <boolean> | <access control list> | Named
effective generic read permission for <string> of <access control list> | effective generic read permissions for | <boolean> | <access control list> | Named
effective generic write permission for <string> of <access control list> | effective generic write permissions for | <boolean> | <access control list> | Named
effective list permission for <string> of <access control list> | effective list permissions for | <boolean> | <access control list> | Named
effective maximum allowed permission for <string> of <access control list> | effective maximum allowed permissions for | <boolean> | <access control list> | Named
effective policy <security account> of <audit policy subcategory> | effective policies | <audit policy information> | <audit policy subcategory> | Index<security account>
effective query value permission for <string> of <access control list> | effective query value permissions for | <boolean> | <access control list> | Named
effective read attributes permission for <string> of <access control list> | effective read attributes permissions for | <boolean> | <access control list> | Named
effective read control permission for <string> of <access control list> | effective read control permissions for | <boolean> | <access control list> | Named
effective read extended attributes permission for <string> of <access control list> | effective read extended attributes permissions for | <boolean> | <access control list> | Named
effective read permission for <string> of <access control list> | effective read permissions for | <boolean> | <access control list> | Named
effective set value permission for <string> of <access control list> | effective set value permissions for | <boolean> | <access control list> | Named
effective synchronize permission for <string> of <access control list> | effective synchronize permissions for | <boolean> | <access control list> | Named
effective time of <runlevel> | effective times | <time> | <runlevel> | Plain
effective traverse permission for <string> of <access control list> | effective traverse permissions for | <boolean> | <access control list> | Named
effective write attributes permission for <string> of <access control list> | effective write attributes permissions for | <boolean> | <access control list> | Named
effective write dac permission for <string> of <access control list> | effective write dac permissions for | <boolean> | <access control list> | Named
effective write extended attributes permission for <string> of <access control list> | effective write extended attributes permissions for | <boolean> | <access control list> | Named
effective write owner permission for <string> of <access control list> | effective write owner permissions for | <boolean> | <access control list> | Named
effective write permission for <string> of <access control list> | effective write permissions for | <boolean> | <access control list> | Named
element of <integer set> | elements | <integer> | <integer set> | Plain
element of <string set> | elements | <string> | <string set> | Plain
em <string> of <html> | ems | <html> | <html> | Named
em <string> of <string> | ems | <html> | <string> | Named
em of <html> | ems | <html> | <html> | Plain
em of <string> | ems | <html> | <string> | Plain
email address of <license> | email addresses | <string> | <license> | Plain
embedded nt bit <operating system suite mask> | embedded nt bits | <boolean> | <world> | Index<operating system suite mask>Global
embedded restricted bit <operating system suite mask> | embedded restricted bits | <boolean> | <world> | Index<operating system suite mask>Global
enabled of <firewall authorized application> | enableds | <boolean> | <firewall authorized application> | Plain
enabled of <firewall open port> | enableds | <boolean> | <firewall open port> | Plain
enabled of <firewall rule> | enableds | <boolean> | <firewall rule> | Plain
enabled of <firewall service> | enableds | <boolean> | <firewall service> | Plain
enabled of <internet connection firewall> | enableds | <boolean> | <internet connection firewall> | Plain
enabled of <port mapping> | enableds | <boolean> | <port mapping> | Plain
enabled of <setting> | enableds | <boolean> | <setting> | Plain
encrypt report failure message of <client_cryptography> | encrypt report failure messages | <string> | <client_cryptography> | Plain
encrypt report of <client_cryptography> | encrypt reports | <boolean> | <client_cryptography> | Plain
encryption certificate of <license> | encryption certificates | <x509 certificate> | <license> | Plain
end of <substring> | ends | <string position> | <substring> | Plain
end of <time range> | ends | <time> | <time range> | Plain
enterprise bit <operating system suite mask> | enterprise bits | <boolean> | <world> | Index<operating system suite mask>Global
entry of <access control list> | entries | <access control entry> | <access control list> | Plain
entry of <dictionary> | entries | <dictionaryentry> | <dictionary> | Plain
enumerate subkeys permission of <access control entry> | enumerate subkeys permissions | <boolean> | <access control entry> | Plain
environment | environments | <environment> | <world> | PlainGlobal
error <string> | errors | <undefined> | <world> | NamedGlobal
error event log event type | error event log event types | <event log event type> | <world> | PlainGlobal
escape of <string> | escapes | <string> | <string> | Plain
evaluation of <license> | evaluations | <boolean> | <license> | Plain
event id of <event log record> | event ids | <integer> | <event log record> | Plain
event log <string> | event logs | <event log> | <world> | NamedGlobal
event log event type <integer> | event log event types | <event log event type> | <world> | NumberedGlobal
event type of <event log record> | event types | <event log event type> | <event log record> | Plain
exceptions allowed of <firewall profile> | exceptions alloweds | <boolean> | <firewall profile> | Plain
excluded interface of <firewall profile> | excluded interfaces | <string> | <firewall profile> | Plain
executable file format of <file> | executable file formats | <string> | <file> | Plain
execute of <mode_mask> | executes | <boolean> | <mode_mask> | Plain
execute permission of <access control entry> | execute permissions | <boolean> | <access control entry> | Plain
execute permission of <network share> | execute permissions | <boolean> | <network share> | Plain
expand environment string of <string> | expand environment strings | <string> | <string> | Plain
expiration date of <action lock state> | expiration dates | <time> | <action lock state> | Plain
expiration date of <license> | expiration dates | <time> | <license> | Plain
expiration state of <license> | expiration states | <string> | <license> | Plain
extended family of <processor> | extended families | <integer> | <processor> | Plain
extended model of <processor> | extended models | <integer> | <processor> | Plain
extensions folder of <domain> | extensions folders | <folder> | <domain> | Plain
external port of <port mapping> | external ports | <integer> | <port mapping> | Plain
extrema of <date> | extremas | <( date, date )> | <date> | Plain
extrema of <day of month> | extremas | <( day of month, day of month )> | <day of month> | Plain
extrema of <day of year> | extremas | <( day of year, day of year )> | <day of year> | Plain
extrema of <floating point> | extremas | <( floating point, floating point )> | <floating point> | Plain
extrema of <hertz> | extremas | <( hertz, hertz )> | <hertz> | Plain
extrema of <integer> | extremas | <( integer, integer )> | <integer> | Plain
extrema of <ipv4 address> | extremas | <( ipv4 address, ipv4 address )> | <ipv4 address> | Plain
extrema of <ipv6 address> | extremas | <( ipv6 address, ipv6 address )> | <ipv6 address> | Plain
extrema of <month and year> | extremas | <( month and year, month and year )> | <month and year> | Plain
extrema of <month> | extremas | <( month, month )> | <month> | Plain
extrema of <number of months> | extremas | <( number of months, number of months )> | <number of months> | Plain
extrema of <site version list> | extremas | <( site version list, site version list )> | <site version list> | Plain
extrema of <time interval> | extremas | <( time interval, time interval )> | <time interval> | Plain
extrema of <time of day> | extremas | <( time of day, time of day )> | <time of day> | Plain
extrema of <time> | extremas | <( time, time )> | <time> | Plain
extrema of <version> | extremas | <( version, version )> | <version> | Plain
extrema of <year> | extremas | <( year, year )> | <year> | Plain
f00f bug of <processor> | f00f bugs | <boolean> | <processor> | Plain
false | falses | <boolean> | <world> | PlainGlobal
family name of <network interface> | family names | <string> | <network interface> | Plain
family name of <processor> | family names | <string> | <processor> | Plain
family of <network interface> | families | <integer> | <network interface> | Plain
family of <processor> | families | <integer> | <processor> | Plain
family of <processor> | families | <string> | <processor> | Plain
favorites folder of <domain> | favorites folders | <folder> | <domain> | Plain
fdiv bug of <processor> | fdiv bugs | <boolean> | <processor> | Plain
feature mask of <processor> | feature masks | <integer> | <processor> | Plain
february | februarys | <month> | <world> | PlainGlobal
february <integer> | februarys | <day of year> | <world> | NumberedGlobal
february <integer> of <integer> | februarys | <date> | <integer> | Numbered
february of <integer> | februarys | <month and year> | <integer> | Plain
file <string> | files | <file> | <world> | NamedGlobal
file <string> of <folder> | files | <file> | <folder> | Named
file <symlink> | files | <file> | <world> | Index<symlink>Global
file count of <filesystem> | file counts | <integer> | <filesystem> | Plain
file count of <volume> | file counts | <integer> | <volume> | Plain
file ending in <string> of <folder> | files ending in | <file> | <folder> | Named
file extension <string> of <registry> | file extensions | <registry key> | <registry> | Named
file of <folder> | files | <file> | <folder> | Plain
file of <service> | files | <file> | <service> | Plain
file signature <string> | file signatures | <file signature> | <world> | NamedGlobal
file system type of <drive> | file system types | <string> | <drive> | Plain
file type <string> | file types | <file type> | <world> | NamedGlobal
file type <string> of <registry> | file types | <registry key> | <registry> | Named
file version of <file> | file versions | <version> | <file> | Plain
file_and_print firewall service type | file_and_print firewall service types | <firewall service type> | <world> | PlainGlobal
file_supports_encryption of <drive> | file_supports_encryptions | <boolean> | <drive> | Plain
file_supports_object_ids of <drive> | file_supports_object_idss | <boolean> | <drive> | Plain
file_supports_reparse_points of <drive> | file_supports_reparse_pointss | <boolean> | <drive> | Plain
file_supports_sparse_files of <drive> | file_supports_sparse_filess | <boolean> | <drive> | Plain
file_volume_quotas of <drive> | file_volume_quotass | <boolean> | <drive> | Plain
fileset matching <string> of <object_repository> | filesets matching | <fileset> | <object_repository> | Named
fileset of <product> | filesets | <fileset> | <product> | Plain
filesystem | filesystems | <filesystem> | <world> | PlainGlobal
filesystem | filesystems | <volume> | <world> | PlainGlobal
filesystem <integer> | filesystems | <volume> | <world> | NumberedGlobal
filesystem <string> | filesystems | <filesystem> | <world> | NamedGlobal
filesystem <string> | filesystems | <volume> | <world> | NamedGlobal
filesystem of <file> | filesystems | <filesystem> | <file> | Plain
filesystem of <file> | filesystems | <volume> | <file> | Plain
filesystem of <folder> | filesystems | <filesystem> | <folder> | Plain
filesystem of <folder> | filesystems | <volume> | <folder> | Plain
filesystem of <symlink> | filesystems | <filesystem> | <symlink> | Plain
final part <time interval> of <time range> | final parts | <time range> | <time range> | Index<time interval>
find file <string> of <folder> | find files | <file> | <folder> | Named
finite of <floating point> | finites | <boolean> | <floating point> | Plain
fips mode failure message of <cryptography> | fips mode failure messages | <string> | <cryptography> | Plain
fips mode of <cryptography> | fips modes | <boolean> | <cryptography> | Plain
fips mode of <license> | fips modes | <boolean> | <license> | Plain
firewall | firewalls | <firewall> | <world> | PlainGlobal
firewall action <integer> | firewall actions | <firewall action> | <world> | NumberedGlobal
firewall enabled of <firewall profile> | firewalls enabled | <boolean> | <firewall profile> | Plain
firewall local policy modify state <integer> | firewall local policy modify states | <firewall local policy modify state> | <world> | NumberedGlobal
firewall of <connection> | firewalls | <internet connection firewall> | <connection> | Plain
firewall profile type <integer> | firewall profile types | <firewall profile type> | <world> | NumberedGlobal
firewall scope <integer> | firewall scopes | <firewall scope> | <world> | NumberedGlobal
firewall service type <integer> | firewall service types | <firewall service type> | <world> | NumberedGlobal
firewire plane of <registryroot> | firewire planes | <registrynode> | <registryroot> | Plain
first <day of week> of <month and year> | firsts | <date> | <month and year> | Index<day of week>
first <integer> of <string> | firsts | <substring> | <string> | Numbered
first <string> of <string> | firsts | <substring> | <string> | Named
first child of <xml dom node> | first children | <xml dom node> | <xml dom node> | Plain
first friday of <month and year> | first fridays | <date> | <month and year> | Plain
first match <regular expression> of <string> | first matches | <regular expression match> | <string> | Index<regular expression>
first monday of <month and year> | first mondays | <date> | <month and year> | Plain
first raw version block of <file> | first raw version blocks | <file version block> | <file> | Plain
first saturday of <month and year> | first saturdays | <date> | <month and year> | Plain
first start time of <application usage summary> | first start times | <time> | <application usage summary> | Plain
first sunday of <month and year> | first sundays | <date> | <month and year> | Plain
first thursday of <month and year> | first thursdays | <date> | <month and year> | Plain
first tuesday of <month and year> | first tuesdays | <date> | <month and year> | Plain
first wednesday of <month and year> | first wednesdays | <date> | <month and year> | Plain
fixlet of <site> | fixlets | <fixlet> | <site> | Plain
flag list of <processor> | flag lists | <string> | <processor> | Plain
flag of <volume> | flags | <integer> | <volume> | Plain
floating point <floating point> | floating points | <floating point> | <world> | Index<floating point>Global
floating point <string> | floating points | <floating point> | <world> | NamedGlobal
folder <string> | folders | <folder> | <world> | NamedGlobal
folder <string> of <drive> | folders | <folder> | <drive> | Named
folder <string> of <folder> | folders | <folder> | <folder> | Named
folder <symlink> | folders | <folder> | <world> | Index<symlink>Global
folder ending in <string> of <folder> | folders ending in | <folder> | <folder> | Named
folder of <folder> | folders | <folder> | <folder> | Plain
following text of <string position> | following texts | <substring> | <string position> | Plain
following text of <substring> | following texts | <substring> | <substring> | Plain
fonts folder of <domain> | fonts folders | <folder> | <domain> | Plain
force logoff interval of <security database> | force logoff intervals | <time interval> | <security database> | Plain
fpu exception of <processor> | fpu exceptions | <boolean> | <processor> | Plain
fpu of <processor> | fpus | <boolean> | <processor> | Plain
fputype of <processor> | fputypes | <string> | <processor> | Plain
framework <string> of <domain> | frameworks | <folder> | <domain> | Named
framework folder of <domain> | framework folders | <folder> | <domain> | Plain
free amount of <ram> | free amounts | <integer> | <ram> | Plain
free amount of <swap> | free amounts | <integer> | <swap> | Plain
free file count of <filesystem> | free file counts | <integer> | <filesystem> | Plain
free partition count of <volume group> | free partition counts | <integer> | <volume group> | Plain
free percent of <filesystem> | free percents | <integer> | <filesystem> | Plain
free percent of <volume> | free percents | <integer> | <volume> | Plain
free space of <drive> | free spaces | <integer> | <drive> | Plain
free space of <filesystem> | free spaces | <integer> | <filesystem> | Plain
free space of <volume> | free spaces | <integer> | <volume> | Plain
friday | fridays | <day of week> | <world> | PlainGlobal
friendly name of <active device> | friendly names | <string> | <active device> | Plain
friendly name of <network adapter> | friendly names | <string> | <network adapter> | Plain
fs_case_is_preserved of <drive> | fs_case_is_preserveds | <boolean> | <drive> | Plain
fs_case_sensitive of <drive> | fs_case_sensitives | <boolean> | <drive> | Plain
fs_file_compression of <drive> | fs_file_compressions | <boolean> | <drive> | Plain
fs_persistent_acls of <drive> | fs_persistent_aclss | <boolean> | <drive> | Plain
fs_unicode_stored_on_disk of <drive> | fs_unicode_stored_on_disks | <boolean> | <drive> | Plain
fs_vol_is_compressed of <drive> | fs_vol_is_compresseds | <boolean> | <drive> | Plain
full name of <local user> | full names | <string> | <local user> | Plain
full wmi <string> | full wmis | <wmi> | <world> | NamedGlobal
gateway address <integer> of <selected server> | gateway addresses | <ipv4 address> | <selected server> | Numbered
gateway address of <selected server> | gateway addresses | <ipv4 address> | <selected server> | Plain
gateway list of <network adapter> | gateway lists | <network address list> | <network adapter> | Plain
gateway of <network adapter> | gateways | <ipv4 address> | <network adapter> | Plain
gather schedule authority of <site> | gather schedule authoritys | <string> | <site> | Plain
gather schedule time interval of <site> | gather schedule time intervals | <time interval> | <site> | Plain
gather url of <license> | gather urls | <string> | <license> | Plain
generic all permission of <access control entry> | generic all permissions | <boolean> | <access control entry> | Plain
generic execute permission of <access control entry> | generic execute permissions | <boolean> | <access control entry> | Plain
generic read permission of <access control entry> | generic read permissions | <boolean> | <access control entry> | Plain
generic write permission of <access control entry> | generic write permissions | <boolean> | <access control entry> | Plain
gestalt <string> | gestalts | <integer> | <world> | NamedGlobal
ghz | ghzs | <hertz> | <world> | PlainGlobal
gid of <filesystem object> | gids | <integer> | <filesystem object> | Plain
gid of <symlink> | gids | <integer> | <symlink> | Plain
global dictionary of <bundle> | global dictionaries | <dictionary> | <bundle> | Plain
globally open port of <firewall profile> | globally open ports | <firewall open port> | <firewall profile> | Plain
globally open port of <firewall service> | globally open ports | <firewall open port> | <firewall service> | Plain
gp override firewall local policy modify state | gp override firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
greatest hz | greatest hzs | <hertz> | <world> | PlainGlobal
greatest integer | greatest integers | <integer> | <world> | PlainGlobal
greatest revision of <patch> | greatest revisions | <string> | <patch> | Plain
greatest time interval | greatest time intervals | <time interval> | <world> | PlainGlobal
group <integer> of <site> | groups | <site group> | <site> | Numbered
group execute of <filesystem object> | group executes | <boolean> | <filesystem object> | Plain
group leader of <action> | group leaders | <boolean> | <action> | Plain
group mask of <filesystem object> | group masks | <integer> | <filesystem object> | Plain
group mask of <mode> | group masks | <mode_mask> | <mode> | Plain
group name of <filesystem object> | group names | <string> | <filesystem object> | Plain
group name of <symlink> | group names | <string> | <symlink> | Plain
group of <security descriptor> | groups | <security identifier> | <security descriptor> | Plain
group read of <filesystem object> | group reads | <boolean> | <filesystem object> | Plain
group write of <filesystem object> | group writes | <boolean> | <filesystem object> | Plain
grouping of <firewall rule> | groupings | <string> | <firewall rule> | Plain
guest privilege of <local user> | guest privileges | <boolean> | <local user> | Plain
guid of <connection> | guids | <string> | <connection> | Plain
h1 <string> of <html> | h1s | <html> | <html> | Named
h1 <string> of <string> | h1s | <html> | <string> | Named
h1 of <html> | h1s | <html> | <html> | Plain
h1 of <string> | h1s | <html> | <string> | Plain
h2 <string> of <html> | h2s | <html> | <html> | Named
h2 <string> of <string> | h2s | <html> | <string> | Named
h2 of <html> | h2s | <html> | <html> | Plain
h2 of <string> | h2s | <html> | <string> | Plain
h3 <string> of <html> | h3s | <html> | <html> | Named
h3 <string> of <string> | h3s | <html> | <string> | Named
h3 of <html> | h3s | <html> | <html> | Plain
h3 of <string> | h3s | <html> | <string> | Plain
h4 <string> of <html> | h4s | <html> | <html> | Named
h4 <string> of <string> | h4s | <html> | <string> | Named
h4 of <html> | h4s | <html> | <html> | Plain
h4 of <string> | h4s | <html> | <string> | Plain
h5 <string> of <html> | h5s | <html> | <html> | Named
h5 <string> of <string> | h5s | <html> | <string> | Named
h5 of <html> | h5s | <html> | <html> | Plain
h5 of <string> | h5s | <html> | <string> | Plain
h6 <string> of <html> | h6s | <html> | <html> | Named
h6 <string> of <string> | h6s | <html> | <string> | Named
h6 of <html> | h6s | <html> | <html> | Plain
h6 of <string> | h6s | <html> | <string> | Plain
hardware id of <active device> | hardware ids | <string> | <active device> | Plain
has blank sa password of <local mssql database> | has blank sa passwords | <boolean> | <local mssql database> | Plain
head <string> of <html> | heads | <html> | <html> | Named
head <string> of <string> | heads | <html> | <string> | Named
head of <html> | heads | <html> | <html> | Plain
head of <string> | heads | <html> | <string> | Plain
header <string> of <fixlet> | headers | <fixlet_header> | <fixlet> | Named
header of <fixlet> | headers | <fixlet_header> | <fixlet> | Plain
help folder of <domain> | help folders | <folder> | <domain> | Plain
hexadecet <integer> of <ipv6 address> | hexadecets | <integer> | <ipv6 address> | Numbered
hexadecimal integer <string> | hexadecimal integers | <integer> | <world> | NamedGlobal
hexadecimal string <string> | hexadecimal strings | <string> | <world> | NamedGlobal
hfs file <string> | hfs files | <file> | <world> | NamedGlobal
hfs folder <string> | hfs folders | <folder> | <world> | NamedGlobal
hfs path of <filesystem object> | hfs paths | <string> | <filesystem object> | Plain
hidden of <filesystem object> | hiddens | <boolean> | <filesystem object> | Plain
hlt bug of <processor> | hlt bugs | <boolean> | <processor> | Plain
home directory drive of <local user> | home directory drives | <string> | <local user> | Plain
home directory of <local user> | home directories | <string> | <local user> | Plain
home directory of <user> | home directories | <folder> | <user> | Plain
home directory required flag of <local user> | home directory required flags | <boolean> | <local user> | Plain
host name | host names | <string> | <world> | PlainGlobal
host name of <root server> | host names | <string> | <root server> | Plain
hostname | hostnames | <string> | <world> | PlainGlobal
hour | hours | <time interval> | <world> | PlainGlobal
hour_of_day of <time of day with time zone> | hours_of_day | <integer> | <time of day with time zone> | Plain
hour_of_day of <time of day> | hours_of_day | <integer> | <time of day> | Plain
hr | hrs | <html> | <world> | PlainGlobal
hr <string> | hrs | <html> | <world> | NamedGlobal
html <string> | htmls | <html> | <world> | NamedGlobal
html <string> of <html> | htmls | <html> | <html> | Named
html <string> of <string> | htmls | <html> | <string> | Named
html concatenation <string> of <html> | html concatenations | <html> | <html> | Named
html concatenation of <html> | html concatenations | <html> | <html> | Plain
html of <html> | htmls | <html> | <html> | Plain
html of <string> | htmls | <html> | <string> | Plain
html tag <( string, html )> | html tags | <html> | <world> | Index<( string, html )>Global
html tag <( string, html attribute list, html )> | html tags | <html> | <world> | Index<( string, html attribute list, html )>Global
html tag <( string, html attribute list, string )> | html tags | <html> | <world> | Index<( string, html attribute list, string )>Global
html tag <( string, string )> | html tags | <html> | <world> | Index<( string, string )>Global
html tag <string> of <html> | html tags | <html> | <html> | Named
html tag <string> of <string> | html tags | <html> | <string> | Named
hyperthreading capable | hyperthreading capables | <boolean> | <world> | PlainGlobal
hyperthreading enabled | hyperthreading enableds | <boolean> | <world> | PlainGlobal
hz | hzs | <hertz> | <world> | PlainGlobal
ia64 of <operating system> | ia64s | <boolean> | <operating system> | Plain
icmp settings of <firewall profile> | icmp settingses | <firewall icmp settings> | <firewall profile> | Plain
icmp types_and_codes string of <firewall rule> | icmp types_and_codes strings | <string> | <firewall rule> | Plain
icon index of <file shortcut> | icon indexes | <integer> | <file shortcut> | Plain
icon pathname of <file shortcut> | icon pathnames | <string> | <file shortcut> | Plain
id of <action> | ids | <integer> | <action> | Plain
id of <file version block> | ids | <string> | <file version block> | Plain
id of <fixlet> | ids | <integer> | <fixlet> | Plain
id of <process> | ids | <integer> | <process> | Plain
id of <processor> | ids | <integer> | <processor> | Plain
id of <root server> | ids | <integer> | <root server> | Plain
id of <site group> | ids | <integer> | <site group> | Plain
id of <user> | ids | <string> | <user> | Plain
identifier of <metabase value> | identifiers | <metabase identifier> | <metabase value> | Plain
image path of <service> | image paths | <string> | <service> | Plain
inbound blocked firewall local policy modify state | inbound blocked firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
inbound connections allowed of <firewall profile> | inbound connections alloweds | <boolean> | <firewall profile> | Plain
inbound of <firewall rule> | inbounds | <boolean> | <firewall rule> | Plain
index of <processor> | indexes | <integer> | <processor> | Plain
index type of <property> | index types | <type> | <property> | Plain
inexact of <floating point> | inexacts | <boolean> | <floating point> | Plain
infinite of <floating point> | infinites | <boolean> | <floating point> | Plain
info of <component> | infos | <string> | <component> | Plain
information event log event type | information event log event types | <event log event type> | <world> | PlainGlobal
inherit attribute of <metabase value> | inherit attributes | <boolean> | <metabase value> | Plain
inheritance of <access control entry> | inheritances | <integer> | <access control entry> | Plain
init date of <volume> | init dates | <time> | <volume> | Plain
initial part <time interval> of <time range> | initial parts | <time range> | <time range> | Index<time interval>
ins <string> of <html> | inss | <html> | <html> | Named
ins <string> of <string> | inss | <html> | <string> | Named
ins of <html> | inss | <html> | <html> | Plain
ins of <string> | inss | <html> | <string> | Plain
insert path attribute of <metabase value> | insert path attributes | <boolean> | <metabase value> | Plain
install folder <integer> | install folders | <folder> | <world> | NumberedGlobal
installed <string> of <rpmdatabase> | installeds | <boolean> | <rpmdatabase> | Named
installed file of <package> | installed files | <capability> | <package> | Plain
instance name of <local mssql database> | instance names | <string> | <local mssql database> | Plain
integer <integer> | integers | <integer> | <world> | NumberedGlobal
integer <integer> of <array> | integers | <integer> | <array> | Numbered
integer <string> | integers | <integer> | <world> | NamedGlobal
integer <string> of <dictionary> | integers | <integer> | <dictionary> | Named
integer <string> of <preference> | integers | <integer> | <preference> | Named
integer ceiling of <floating point> | integer ceilings | <integer> | <floating point> | Plain
integer floor of <floating point> | integer floors | <integer> | <floating point> | Plain
integer of <osxvalue> | integers | <integer> | <osxvalue> | Plain
integer value <integer> of <wmi select> | integer values | <integer> | <wmi select> | Numbered
integer value of <wmi select> | integer values | <integer> | <wmi select> | Plain
interdomain trust account flag of <local user> | interdomain trust account flags | <boolean> | <local user> | Plain
interface <integer> of <network> | interfaces | <network interface> | <network> | Numbered
interface of <firewall rule> | interfaces | <string> | <firewall rule> | Plain
interface of <network adapter> | interfaces | <network interface> | <network adapter> | Plain
interface of <network> | interfaces | <network interface> | <network> | Plain
interface types string of <firewall rule> | interface types strings | <string> | <firewall rule> | Plain
internal port of <port mapping> | internal ports | <integer> | <port mapping> | Plain
internet connection firewall of <network adapter> | internet connection firewalls | <internet connection firewall> | <network adapter> | Plain
internet plugins folder | internet plugins folders | <folder> | <world> | PlainGlobal
internet plugins folder of <domain> | internet plugins folders | <folder> | <domain> | Plain
internet protocol <integer> | internet protocols | <internet protocol> | <world> | NumberedGlobal
intersection of <integer set> | intersections | <integer set> | <integer set> | Plain
intersection of <string set> | intersections | <string set> | <string set> | Plain
invalid before of <x509 certificate> | invalid befores | <time> | <x509 certificate> | Plain
invalid of <floating point> | invalids | <boolean> | <floating point> | Plain
iokit registry | iokit registries | <registryroot> | <world> | PlainGlobal
ip address of <selected server> | ip addresses | <ipv4 address> | <selected server> | Plain
ip interface <integer> of <network> | ip interfaces | <network ip interface> | <network> | Numbered
ip interface of <network adapter> | ip interfaces | <network ip interface> | <network adapter> | Plain
ip interface of <network> | ip interfaces | <network ip interface> | <network> | Plain
ip version <integer> | ip versions | <ip version> | <world> | NumberedGlobal
ip version of <firewall authorized application> | ip versions | <ip version> | <firewall authorized application> | Plain
ip version of <firewall open port> | ip versions | <ip version> | <firewall open port> | Plain
ip version of <firewall service> | ip versions | <ip version> | <firewall service> | Plain
ipv4 | ipv4s | <ip version> | <world> | PlainGlobal
ipv4 address <string> | ipv4 addresses | <ipv4 address> | <world> | NamedGlobal
ipv4 part of <ipv6 address> | ipv4 parts | <ipv4 address> | <ipv6 address> | Plain
ipv6 | ipv6s | <ip version> | <world> | PlainGlobal
ipv6 address <string> | ipv6 addresses | <ipv6 address> | <world> | NamedGlobal
ipv6 address of <network adapter> | ipv6 addresses | <ipv6 address> | <network adapter> | Plain
ipv6 dns server of <network adapter> | ipv6 dns servers | <ipv6 address> | <network adapter> | Plain
isochronous of <usb> | isochronouses | <boolean> | <usb> | Plain
iss download folder | download folders | <folder> | <world> | PlainGlobal
iss download folder of <domain> | iss download folders | <folder> | <domain> | Plain
italic <string> of <html> | italics | <html> | <html> | Named
italic <string> of <string> | italics | <html> | <string> | Named
italic of <html> | italics | <html> | <html> | Plain
italic of <string> | italics | <html> | <string> | Plain
item <string> of <folder> | items | <filesystem object> | <folder> | Named
item ending in <string> of <folder> | items ending in | <filesystem object> | <folder> | Named
item of <folder> | items | <filesystem object> | <folder> | Plain
january | januarys | <month> | <world> | PlainGlobal
january <integer> | januarys | <day of year> | <world> | NumberedGlobal
january <integer> of <integer> | januarys | <date> | <integer> | Numbered
january of <integer> | januarys | <month and year> | <integer> | Plain
july | julys | <month> | <world> | PlainGlobal
july <integer> | julys | <day of year> | <world> | NumberedGlobal
july <integer> of <integer> | julys | <date> | <integer> | Numbered
july of <integer> | julys | <month and year> | <integer> | Plain
june | junes | <month> | <world> | PlainGlobal
june <integer> | junes | <day of year> | <world> | NumberedGlobal
june <integer> of <integer> | junes | <date> | <integer> | Numbered
june of <integer> | junes | <month and year> | <integer> | Plain
kbd <string> of <html> | kbds | <html> | <html> | Named
kbd <string> of <string> | kbds | <html> | <string> | Named
kbd of <html> | kbds | <html> | <html> | Plain
kbd of <string> | kbds | <html> | <string> | Plain
kernel extensions folder of <domain> | kernel extensions folders | <folder> | <domain> | Plain
key <string> of <file section> | keys | <string> | <file section> | Named
key <string> of <file> | keys | <string> | <file> | Named
key <string> of <metabase key> | keys | <metabase key> | <metabase key> | Named
key <string> of <metabase> | keys | <metabase key> | <metabase> | Named
key <string> of <registry key> | keys | <registry key> | <registry key> | Named
key <string> of <registry> | keys | <registry key> | <registry> | Named
key of <dictionary> | keys | <string> | <dictionary> | Plain
key of <dictionaryentry> | keys | <string> | <dictionaryentry> | Plain
key of <metabase key> | keys | <metabase key> | <metabase key> | Plain
key of <metabase> | keys | <metabase key> | <metabase> | Plain
key of <registry key> | keys | <registry key> | <registry key> | Plain
key of <user attribute> | keys | <string> | <user attribute> | Plain
khz | khzs | <hertz> | <world> | PlainGlobal
label of <logical volume> | labels | <string> | <logical volume> | Plain
language of <file version block> | languages | <string> | <file version block> | Plain
last <integer> of <string> | lasts | <substring> | <string> | Numbered
last <string> of <string> | lasts | <substring> | <string> | Named
last change time of <action> | last change times | <time> | <action> | Plain
last child of <xml dom node> | last children | <xml dom node> | <xml dom node> | Plain
last gather time of <site> | last gather times | <time> | <site> | Plain
last logoff of <local user> | last logoffs | <time> | <local user> | Plain
last logon of <local user> | last logons | <time> | <local user> | Plain
last start time of <application usage summary> | last start times | <time> | <application usage summary> | Plain
last time seen of <application usage summary> | last times seen | <time> | <application usage summary> | Plain
leap of <year> | leaps | <boolean> | <year> | Plain
lease expires of <network adapter> | leases expire | <time> | <network adapter> | Plain
lease obtained of <network adapter> | leases obtained | <time> | <network adapter> | Plain
least hz | least hzs | <hertz> | <world> | PlainGlobal
least integer | least integers | <integer> | <world> | PlainGlobal
least revision of <patch> | least revisions | <string> | <patch> | Plain
least significant one bit of <bit set> | least significant one bits | <integer> | <bit set> | Plain
least time interval | least time intervals | <time interval> | <world> | PlainGlobal
left operand type of <binary operator> | left operand types | <type> | <binary operator> | Plain
left shift <integer> of <bit set> | left shifts | <bit set> | <bit set> | Numbered
length of <datafork> | lengths | <integer> | <datafork> | Plain
length of <event log record> | lengths | <integer> | <event log record> | Plain
length of <file> | lengths | <integer> | <file> | Plain
length of <month and year> | lengths | <time interval> | <month and year> | Plain
length of <resfork> | lengths | <integer> | <resfork> | Plain
length of <rope> | lengths | <integer> | <rope> | Plain
length of <string> | lengths | <integer> | <string> | Plain
length of <time range> | lengths | <time interval> | <time range> | Plain
length of <year> | lengths | <time interval> | <year> | Plain
less significance <integer> of <floating point> | less significances | <floating point> | <floating point> | Numbered
li <string> of <html> | lis | <html> | <html> | Named
li <string> of <string> | lis | <html> | <string> | Named
li of <html> | lis | <html> | <html> | Plain
li of <string> | lis | <html> | <string> | Plain
line <integer> of <file> | lines | <file line> | <file> | Numbered
line containing <string> of <file> | lines containing | <file line> | <file> | Named
line number of <file line> | line numbers | <integer> | <file line> | Plain
line of <file> | lines | <file line> | <file> | Plain
line starting with <string> of <file> | lines starting with | <file line> | <file> | Named
link <string> of <html> | links | <html> | <html> | Named
link <string> of <string> | links | <html> | <string> | Named
link count of <filesystem object> | link counts | <integer> | <filesystem object> | Plain
link count of <symlink> | link counts | <integer> | <symlink> | Plain
link interface <integer> of <network> | link interfaces | <network link interface> | <network> | Numbered
link interface of <network adapter> | link interfaces | <network link interface> | <network adapter> | Plain
link interface of <network> | link interfaces | <network link interface> | <network> | Plain
link of <html> | links | <html> | <html> | Plain
link of <string> | links | <html> | <string> | Plain
link speed of <network adapter> | link speeds | <integer> | <network adapter> | Plain
list permission of <access control entry> | list permissions | <boolean> | <access control entry> | Plain
local addresses string of <firewall rule> | local addresses strings | <string> | <firewall rule> | Plain
local administrator | local administrators | <boolean> | <world> | PlainGlobal
local computer of <active directory server> | local computers | <active directory local computer> | <active directory server> | Plain
local dictionary of <bundle> | local dictionaries | <dictionary> | <bundle> | Plain
local domain | local domains | <domain> | <world> | PlainGlobal
local group | local groups | <local group> | <world> | PlainGlobal
local group <string> | local groups | <local group> | <world> | NamedGlobal
local mssql database | local mssql databases | <local mssql database> | <world> | PlainGlobal
local mssql database <string> | local mssql databases | <local mssql database> | <world> | NamedGlobal
local policy modify state of <firewall> | local policy modify states | <firewall local policy modify state> | <firewall> | Plain
local policy of <firewall> | local policies | <firewall policy> | <firewall> | Plain
local ports string of <firewall rule> | local ports strings | <string> | <firewall rule> | Plain
local subnet firewall scope | local subnet firewall scopes | <firewall scope> | <world> | PlainGlobal
local time <string> | local times | <time> | <world> | NamedGlobal
local time zone | local time zones | <time zone> | <world> | PlainGlobal
local user | local users | <local user> | <world> | PlainGlobal
local user <string> | local users | <local user> | <world> | NamedGlobal
locales folder of <domain> | locales folders | <folder> | <domain> | Plain
location information of <active device> | location informations | <string> | <active device> | Plain
location manager modules folder of <domain> | location manager modules folders | <folder> | <domain> | Plain
location manager preferences folder of <domain> | location manager preferences folders | <folder> | <domain> | Plain
location of <filesystem object> | locations | <string> | <filesystem object> | Plain
location of <symlink> | locations | <string> | <symlink> | Plain
locations folder of <domain> | locations folders | <folder> | <domain> | Plain
lock string of <action lock state> | lock strings | <string> | <action lock state> | Plain
locked of <action lock state> | lockeds | <boolean> | <action lock state> | Plain
locked of <file> | lockeds | <boolean> | <file> | Plain
locked out flag of <local user> | locked out flags | <boolean> | <local user> | Plain
logged on user | logged on users | <logged on user> | <world> | PlainGlobal
logical processor count | logical processor counts | <integer> | <world> | PlainGlobal
logical ram | logical rams | <integer> | <world> | PlainGlobal
logical volume <string> of <volume group> | logical volumes | <logical volume> | <volume group> | Named
logical volume manager | logical volume managers | <logical volume manager> | <world> | PlainGlobal
logical volume of <filesystem> | logical volumes | <logical volume> | <filesystem> | Plain
logical volume of <volume group> | logical volumes | <logical volume> | <volume group> | Plain
login account of <service> | login accounts | <string> | <service> | Plain
login mode of <local mssql database> | login modes | <integer> | <local mssql database> | Plain
logon count of <local user> | logon counts | <integer> | <local user> | Plain
logon logoff category of <audit policy> | logon logoff categories | <audit policy category> | <audit policy> | Plain
logon script of <local user> | logon scripts | <string> | <local user> | Plain
logon server of <local user> | logon servers | <string> | <local user> | Plain
long name of <client process owner> | long names | <string> | <client process owner> | Plain
loopback of <network adapter> | loopbacks | <boolean> | <network adapter> | Plain
loopback of <network ip interface> | loopbacks | <boolean> | <network ip interface> | Plain
lower bound of <integer range> | lower bounds | <integer> | <integer range> | Plain
lpp_name of <fileset> | lpp_names | <string> | <fileset> | Plain
mac address of <network adapter> | mac addresses | <string> | <network adapter> | Plain
mac address of <network ip interface> | mac addresses | <string> | <network ip interface> | Plain
mac address of <network link interface> | mac addresses | <string> | <network link interface> | Plain
machine name | machine names | <string> | <world> | PlainGlobal
macos read me folder of <domain> | macos read me folders | <folder> | <domain> | Plain
main gather service | main gather services | <nothing> | <world> | PlainGlobal
main gather service | main gather services | <service> | <world> | PlainGlobal
main processor | main processors | <processor> | <world> | PlainGlobal
major number of <volume group> | major numbers | <integer> | <volume group> | Plain
major revision of <version> | major revisions | <integer> | <version> | Plain
major version of <operating system> | major versions | <integer> | <operating system> | Plain
maker of <component> | makers | <string> | <component> | Plain
manufacturer of <active device> | manufacturers | <string> | <active device> | Plain
march | marchs | <month> | <world> | PlainGlobal
march <integer> | marchs | <day of year> | <world> | NumberedGlobal
march <integer> of <integer> | marchs | <date> | <integer> | Numbered
march of <integer> | marchs | <month and year> | <integer> | Plain
masthead of <site> | mastheads | <file> | <site> | Plain
match <regular expression> of <string> | matches | <regular expression match> | <string> | Index<regular expression>
maximum allowed permission of <access control entry> | maximum allowed permissions | <boolean> | <access control entry> | Plain
maximum of <date> | maxima | <date> | <date> | Plain
maximum of <day of month> | maxima | <day of month> | <day of month> | Plain
maximum of <day of year> | maxima | <day of year> | <day of year> | Plain
maximum of <floating point> | maxima | <floating point> | <floating point> | Plain
maximum of <hertz> | maxima | <hertz> | <hertz> | Plain
maximum of <integer> | maxima | <integer> | <integer> | Plain
maximum of <ipv4 address> | maxima | <ipv4 address> | <ipv4 address> | Plain
maximum of <ipv6 address> | maxima | <ipv6 address> | <ipv6 address> | Plain
maximum of <month and year> | maxima | <month and year> | <month and year> | Plain
maximum of <month> | maxima | <month> | <month> | Plain
maximum of <number of months> | maxima | <number of months> | <number of months> | Plain
maximum of <site version list> | maxima | <site version list> | <site version list> | Plain
maximum of <time interval> | maxima | <time interval> | <time interval> | Plain
maximum of <time of day> | maxima | <time of day> | <time of day> | Plain
maximum of <time> | maxima | <time> | <time> | Plain
maximum of <version> | maxima | <version> | <version> | Plain
maximum of <year> | maxima | <year> | <year> | Plain
maximum partition count of <logical volume> | maximum partition counts | <integer> | <logical volume> | Plain
maximum password age of <security database> | maximum password ages | <time interval> | <security database> | Plain
maximum seat count of <license> | maximum seat counts | <integer> | <license> | Plain
maximum storage of <local user> | maximum storages | <integer> | <local user> | Plain
maximum transmission unit of <network adapter> | maximum transmission units | <integer> | <network adapter> | Plain
may | mays | <month> | <world> | PlainGlobal
may <integer> | mays | <day of year> | <world> | NumberedGlobal
may <integer> of <integer> | mays | <date> | <integer> | Numbered
may of <integer> | mays | <month and year> | <integer> | Plain
mean of <floating point> | means | <floating point> | <floating point> | Plain
mean of <integer> | means | <floating point> | <integer> | Plain
media type <integer> | media types | <media type> | <world> | NumberedGlobal
media type bridge | media types bridge | <media type> | <world> | PlainGlobal
media type direct | media types direct | <media type> | <world> | PlainGlobal
media type isdn | media types isdn | <media type> | <world> | PlainGlobal
media type lan | media types lans | <media type> | <world> | PlainGlobal
media type of <connection> | media types | <media type> | <connection> | Plain
media type phone | media types phone | <media type> | <world> | PlainGlobal
media type pppoe | media types pppoe | <media type> | <world> | PlainGlobal
media type shared access host lan | media types shared access host lan | <media type> | <world> | PlainGlobal
media type shared access host ras | media types shared access host ras | <media type> | <world> | PlainGlobal
media type tunnel | media types tunnel | <media type> | <world> | PlainGlobal
member of <local group> | members | <local group member> | <local group> | Plain
member of <site group> | members | <boolean> | <site group> | Plain
meta <string> of <html> | metas | <html> | <html> | Named
meta <string> of <string> | metas | <html> | <string> | Named
meta of <html> | metas | <html> | <html> | Plain
meta of <string> | metas | <html> | <string> | Plain
metabase | metabases | <metabase> | <world> | PlainGlobal
metric <integer> of <operating system> | metrics | <integer> | <operating system> | Numbered
mhz | mhzs | <hertz> | <world> | PlainGlobal
microsecond | microseconds | <time interval> | <world> | PlainGlobal
midnight | midnights | <time of day> | <world> | PlainGlobal
millisecond | milliseconds | <time interval> | <world> | PlainGlobal
minimum of <date> | minima | <date> | <date> | Plain
minimum of <day of month> | minima | <day of month> | <day of month> | Plain
minimum of <day of year> | minima | <day of year> | <day of year> | Plain
minimum of <floating point> | minima | <floating point> | <floating point> | Plain
minimum of <hertz> | minima | <hertz> | <hertz> | Plain
minimum of <integer> | minima | <integer> | <integer> | Plain
minimum of <ipv4 address> | minima | <ipv4 address> | <ipv4 address> | Plain
minimum of <ipv6 address> | minima | <ipv6 address> | <ipv6 address> | Plain
minimum of <month and year> | minima | <month and year> | <month and year> | Plain
minimum of <month> | minima | <month> | <month> | Plain
minimum of <number of months> | minima | <number of months> | <number of months> | Plain
minimum of <site version list> | minima | <site version list> | <site version list> | Plain
minimum of <time interval> | minima | <time interval> | <time interval> | Plain
minimum of <time of day> | minima | <time of day> | <time of day> | Plain
minimum of <time> | minima | <time> | <time> | Plain
minimum of <version> | minima | <version> | <version> | Plain
minimum of <year> | minima | <year> | <year> | Plain
minimum password age of <security database> | minimum password ages | <time interval> | <security database> | Plain
minimum password length of <security database> | minimum password lengths | <integer> | <security database> | Plain
minor number of <logical volume> | minor numbers | <integer> | <logical volume> | Plain
minor revision of <version> | minor revisions | <integer> | <version> | Plain
minor version of <operating system> | minor versions | <integer> | <operating system> | Plain
minute | minutes | <time interval> | <world> | PlainGlobal
minute_of_hour of <time of day with time zone> | minutes_of_hour | <integer> | <time of day with time zone> | Plain
minute_of_hour of <time of day> | minutes_of_hour | <integer> | <time of day> | Plain
mirror count of <logical volume> | mirror counts | <integer> | <logical volume> | Plain
mode of <filesystem object> | modes | <mode> | <filesystem object> | Plain
model | models | <string> | <world> | PlainGlobal
model name of <processor> | model names | <string> | <processor> | Plain
model of <processor> | models | <integer> | <processor> | Plain
model of <processor> | models | <string> | <processor> | Plain
modem scripts folder of <domain> | modem scripts folders | <folder> | <domain> | Plain
modification time of <filesystem object> | modification times | <time> | <filesystem object> | Plain
modification time of <symlink> | modification times | <time> | <symlink> | Plain
modification time of <volume> | modification times | <time> | <volume> | Plain
module <string> | modules | <module> | <world> | NamedGlobal
monday | mondays | <day of week> | <world> | PlainGlobal
month | months | <number of months> | <world> | PlainGlobal
month <integer> | months | <month> | <world> | NumberedGlobal
month <string> | months | <month> | <world> | NamedGlobal
month of <date> | months | <month> | <date> | Plain
month of <day of year> | months | <month> | <day of year> | Plain
month of <month and year> | months | <month> | <month and year> | Plain
month_and_year of <date> | months_and_years | <month and year> | <date> | Plain
more significance <integer> of <floating point> | more significances | <floating point> | <floating point> | Numbered
most significant one bit of <bit set> | most significant one bits | <integer> | <bit set> | Plain
multicast support of <network adapter> | multicast supports | <boolean> | <network adapter> | Plain
multicast support of <network ip interface> | multicast supports | <boolean> | <network ip interface> | Plain
multiplicity of <date with multiplicity> | multiplicities | <integer> | <date with multiplicity> | Plain
multiplicity of <day of month with multiplicity> | multiplicities | <integer> | <day of month with multiplicity> | Plain
multiplicity of <day of week with multiplicity> | multiplicities | <integer> | <day of week with multiplicity> | Plain
multiplicity of <day of year with multiplicity> | multiplicities | <integer> | <day of year with multiplicity> | Plain
multiplicity of <floating point with multiplicity> | multiplicities | <integer> | <floating point with multiplicity> | Plain
multiplicity of <hertz with multiplicity> | multiplicities | <integer> | <hertz with multiplicity> | Plain
multiplicity of <integer with multiplicity> | multiplicities | <integer> | <integer with multiplicity> | Plain
multiplicity of <ipv4 address with multiplicity> | multiplicities | <integer> | <ipv4 address with multiplicity> | Plain
multiplicity of <ipv6 address with multiplicity> | multiplicities | <integer> | <ipv6 address with multiplicity> | Plain
multiplicity of <month and year with multiplicity> | multiplicities | <integer> | <month and year with multiplicity> | Plain
multiplicity of <month with multiplicity> | multiplicities | <integer> | <month with multiplicity> | Plain
multiplicity of <number of months with multiplicity> | multiplicities | <integer> | <number of months with multiplicity> | Plain
multiplicity of <site version list with multiplicity> | multiplicities | <integer> | <site version list with multiplicity> | Plain
multiplicity of <string with multiplicity> | multiplicities | <integer> | <string with multiplicity> | Plain
multiplicity of <time interval with multiplicity> | multiplicities | <integer> | <time interval with multiplicity> | Plain
multiplicity of <time of day with multiplicity> | multiplicities | <integer> | <time of day with multiplicity> | Plain
multiplicity of <time of day with time zone with multiplicity> | multiplicities | <integer> | <time of day with time zone with multiplicity> | Plain
multiplicity of <time range with multiplicity> | multiplicities | <integer> | <time range with multiplicity> | Plain
multiplicity of <time with multiplicity> | multiplicities | <integer> | <time with multiplicity> | Plain
multiplicity of <time zone with multiplicity> | multiplicities | <integer> | <time zone with multiplicity> | Plain
multiplicity of <version with multiplicity> | multiplicities | <integer> | <version with multiplicity> | Plain
multiplicity of <year with multiplicity> | multiplicities | <integer> | <year with multiplicity> | Plain
multivalued of <property> | multivalueds | <boolean> | <property> | Plain
name of <application usage summary> | names | <string> | <application usage summary> | Plain
name of <audit policy category> | names | <string> | <audit policy category> | Plain
name of <audit policy subcategory> | names | <string> | <audit policy subcategory> | Plain
name of <binary operator> | names | <string> | <binary operator> | Plain
name of <capability> | names | <string> | <capability> | Plain
name of <cast> | names | <string> | <cast> | Plain
name of <client process owner> | names | <string> | <client process owner> | Plain
name of <component> | names | <string> | <component> | Plain
name of <computer> | names | <string> | <computer> | Plain
name of <connection> | names | <string> | <connection> | Plain
name of <drive> | names | <string> | <drive> | Plain
name of <environment variable> | names | <string> | <environment variable> | Plain
name of <filesystem object> | names | <string> | <filesystem object> | Plain
name of <filesystem> | names | <string> | <filesystem> | Plain
name of <firewall authorized application> | names | <string> | <firewall authorized application> | Plain
name of <firewall open port> | names | <string> | <firewall open port> | Plain
name of <firewall rule> | names | <string> | <firewall rule> | Plain
name of <firewall service> | names | <string> | <firewall service> | Plain
name of <fixlet_header> | names | <string> | <fixlet_header> | Plain
name of <local group> | names | <string> | <local group> | Plain
name of <local user> | names | <string> | <local user> | Plain
name of <logged on user> | names | <string> | <logged on user> | Plain
name of <logical volume> | names | <string> | <logical volume> | Plain
name of <metabase key> | names | <string> | <metabase key> | Plain
name of <network adapter> | names | <string> | <network adapter> | Plain
name of <network interface> | names | <string> | <network interface> | Plain
name of <network ip interface> | names | <string> | <network ip interface> | Plain
name of <network share> | names | <string> | <network share> | Plain
name of <operating system> | names | <string> | <operating system> | Plain
name of <package> | names | <string> | <package> | Plain
name of <pkginfo> | names | <string> | <pkginfo> | Plain
name of <port mapping> | names | <string> | <port mapping> | Plain
name of <process> | names | <string> | <process> | Plain
name of <product> | names | <string> | <product> | Plain
name of <registry key value> | names | <string> | <registry key value> | Plain
name of <registry key> | names | <string> | <registry key> | Plain
name of <registrynode> | names | <string> | <registrynode> | Plain
name of <selected server> | names | <string> | <selected server> | Plain
name of <setting> | names | <string> | <setting> | Plain
name of <site> | names | <string> | <site> | Plain
name of <symlink> | names | <string> | <symlink> | Plain
name of <type> | names | <string> | <type> | Plain
name of <unary operator> | names | <string> | <unary operator> | Plain
name of <user> | names | <string> | <user> | Plain
name of <volume group> | names | <string> | <volume group> | Plain
name of <volume> | names | <string> | <volume> | Plain
name of <wmi select> | names | <string> | <wmi select> | Plain
nan of <floating point> | nans | <boolean> | <floating point> | Plain
native registry | native registries | <registry> | <world> | PlainGlobal
network | networks | <network> | <world> | PlainGlobal
network domain | network domains | <domain> | <world> | PlainGlobal
network share | network shares | <network share> | <world> | PlainGlobal
network share <string> | network shares | <network share> | <world> | NamedGlobal
next line of <file line> | next lines | <file line> | <file line> | Plain
next sibling of <xml dom node> | next siblings | <xml dom node> | <xml dom node> | Plain
no password required flag of <local user> | no password required flags | <boolean> | <local user> | Plain
node <string> of <registrynode> | nodes | <registrynode> | <registrynode> | Named
node <string> of <registryroot> | nodes | <registrynode> | <registryroot> | Named
node name of <xml dom node> | node names | <string> | <xml dom node> | Plain
node of <registrynode> | nodes | <registrynode> | <registrynode> | Plain
node type of <xml dom node> | node types | <integer> | <xml dom node> | Plain
node value of <xml dom node> | node values | <string> | <xml dom node> | Plain
none firewall service type | none firewall service types | <firewall service type> | <world> | PlainGlobal
noon | noons | <time of day> | <world> | PlainGlobal
normal account flag of <local user> | normal account flags | <boolean> | <local user> | Plain
normal of <filesystem object> | normals | <boolean> | <filesystem object> | Plain
normal of <floating point> | normals | <boolean> | <floating point> | Plain
notifications disabled of <firewall profile> | notifications disableds | <boolean> | <firewall profile> | Plain
november | novembers | <month> | <world> | PlainGlobal
november <integer> | novembers | <day of year> | <world> | NumberedGlobal
november <integer> of <integer> | novembers | <date> | <integer> | Numbered
november of <integer> | novembers | <month and year> | <integer> | Plain
now | nows | <time> | <world> | PlainGlobal
nt domain controller product type | nt domain controller product types | <operating system product type> | <world> | PlainGlobal
nt server product type | nt server product types | <operating system product type> | <world> | PlainGlobal
nt workstation product type | nt workstation product types | <operating system product type> | <world> | PlainGlobal
nubus map | nubus maps | <integer> | <world> | PlainGlobal
numeric type of <drive> | numeric types | <integer> | <drive> | Plain
numeric value of <string> | numeric values | <integer> | <string> | Plain
object access category of <audit policy> | object access categories | <audit policy category> | <audit policy> | Plain
object repository | object repositories | <object_repository> | <world> | PlainGlobal
obsolete of <package> | obsoletes | <capability> | <package> | Plain
october | octobers | <month> | <world> | PlainGlobal
october <integer> | octobers | <day of year> | <world> | NumberedGlobal
october <integer> of <integer> | octobers | <date> | <integer> | Numbered
october of <integer> | octobers | <month and year> | <integer> | Plain
oem code page | oem code pages | <integer> | <world> | PlainGlobal
offer accepted of <action> | offer accepteds | <boolean> | <action> | Plain
offer of <action> | offers | <boolean> | <action> | Plain
offline of <filesystem object> | offlines | <boolean> | <filesystem object> | Plain
ok firewall local policy modify state | ok firewall local policy modify states | <firewall local policy modify state> | <world> | PlainGlobal
ol <string> of <html> | ols | <html> | <html> | Named
ol <string> of <string> | ols | <html> | <string> | Named
ol of <html> | ols | <html> | <html> | Plain
ol of <string> | ols | <html> | <string> | Plain
oldest record number of <event log> | oldest record numbers | <integer> | <event log> | Plain
on appropriate disk domain | on appropriate disk domains | <domain> | <world> | PlainGlobal
on system disk domain | on system disk domains | <domain> | <world> | PlainGlobal
one bit of <bit set> | one bits | <integer> | <bit set> | Plain
only raw version block of <file> | only raw version blocks | <file version block> | <file> | Plain
only version block of <file> | only version blocks | <file version block> | <file> | Plain
operand type of <cast> | operand types | <type> | <cast> | Plain
operand type of <unary operator> | operand types | <type> | <unary operator> | Plain
operating system | operating systems | <operating system> | <world> | PlainGlobal
operating system product type <integer> | operating system product types | <operating system product type> | <world> | NumberedGlobal
options of <port mapping> | optionss | <integer> | <port mapping> | Plain
ordered list <string> of <html> | ordered lists | <html> | <html> | Named
ordered list <string> of <string> | ordered lists | <html> | <string> | Named
ordered list of <html> | ordered lists | <html> | <html> | Plain
ordered list of <string> | ordered lists | <html> | <string> | Plain
organization of <license> | organizations | <string> | <license> | Plain
origin fixlet id of <action> | origin fixlet ids | <integer> | <action> | Plain
other execute of <filesystem object> | other executes | <boolean> | <filesystem object> | Plain
other mask of <filesystem object> | other masks | <integer> | <filesystem object> | Plain
other mask of <mode> | other masks | <mode_mask> | <mode> | Plain
other read of <filesystem object> | other reads | <boolean> | <filesystem object> | Plain
other write of <filesystem object> | other writes | <boolean> | <filesystem object> | Plain
outbound connections allowed of <firewall profile> | outbound connections alloweds | <boolean> | <firewall profile> | Plain
outbound of <firewall rule> | outbounds | <boolean> | <firewall rule> | Plain
overflow of <floating point> | overflows | <boolean> | <floating point> | Plain
owner document of <xml dom node> | owner documents | <xml dom document> | <xml dom node> | Plain
owner of <security descriptor> | owners | <security identifier> | <security descriptor> | Plain
p <string> of <html> | ps | <html> | <html> | Named
p <string> of <string> | ps | <html> | <string> | Named
p of <html> | ps | <html> | <html> | Plain
p of <string> | ps | <html> | <string> | Plain
package <string> of <rpmdatabase> | packages | <package> | <rpmdatabase> | Named
package conflicting with <capability> of <rpmdatabase> | packages conflicting with | <package> | <rpmdatabase> | Index<capability>
package installing <capability> of <rpmdatabase> | packages installing | <package> | <rpmdatabase> | Index<capability>
package of <rpmdatabase> | packages | <package> | <rpmdatabase> | Plain
package providing <capability> of <rpmdatabase> | packages providing | <package> | <rpmdatabase> | Index<capability>
package requiring <capability> of <rpmdatabase> | packages requiring | <package> | <rpmdatabase> | Index<capability>
pad of <version> | pads | <version> | <version> | Plain
param <string> of <pkginfo> | params | <string> | <pkginfo> | Named
parameter <string> | parameters | <string> | <world> | NamedGlobal
parameter <string> of <action> | parameters | <string> | <action> | Named
parent folder of <filesystem object> | parent folders | <folder> | <filesystem object> | Plain
parent folder of <symlink> | parent folders | <folder> | <symlink> | Plain
parent node of <xml dom node> | parent nodes | <xml dom node> | <xml dom node> | Plain
parent of <type> | parents | <type> | <type> | Plain
parenthesized part <integer> of <regular expression match> | parenthesized parts | <substring> | <regular expression match> | Numbered
parenthesized part of <regular expression match> | parenthesized parts | <substring> | <regular expression match> | Plain
partition count of <logical volume> | partition counts | <integer> | <logical volume> | Plain
partition size of <volume group> | partition sizes | <integer> | <volume group> | Plain
password age of <local user> | password ages | <time interval> | <local user> | Plain
password change disabled flag of <local user> | password change disabled flags | <boolean> | <local user> | Plain
password expiration disabled flag of <local user> | password expiration disabled flags | <boolean> | <local user> | Plain
password expired of <local user> | passwords expired | <boolean> | <local user> | Plain
password history length of <security database> | password history lengths | <integer> | <security database> | Plain
password of <network share> | passwords | <string> | <network share> | Plain
patch <string> of <pkgdb> | patches | <patch> | <pkgdb> | Named
patch <string> of <pkginfo> | patches | <patch> | <pkginfo> | Named
patch id <string> of <pkgdb> | patch ids | <string> | <pkgdb> | Named
patch id <string> of <pkginfo> | patch ids | <string> | <pkginfo> | Named
patch id of <pkgdb> | patch ids | <string> | <pkgdb> | Plain
patch id of <pkginfo> | patch ids | <string> | <pkginfo> | Plain
patch of <pkgdb> | patches | <patch> | <pkgdb> | Plain
patch of <pkginfo> | patches | <patch> | <pkginfo> | Plain
path of <network share> | paths | <string> | <network share> | Plain
path of <registrynode> | paths | <string> | <registrynode> | Plain
pathname of <file shortcut> | pathnames | <string> | <file shortcut> | Plain
pathname of <filesystem object> | pathnames | <string> | <filesystem object> | Plain
pathname of <symlink> | pathnames | <string> | <symlink> | Plain
pem encoded certificate of <file> | pem encoded certificates | <x509 certificate> | <file> | Plain
pending login | pending logins | <boolean> | <world> | PlainGlobal
pending login of <action> | pending logins | <boolean> | <action> | Plain
pending of <action> | pendings | <boolean> | <action> | Plain
pending restart | pending restarts | <boolean> | <world> | PlainGlobal
pending restart <string> | pending restarts | <boolean> | <world> | NamedGlobal
pending restart of <action> | pending restarts | <boolean> | <action> | Plain
pending time of <action> | pending times | <time> | <action> | Plain
per user policy <security account> of <audit policy subcategory> | per user policies | <audit policy information> | <audit policy subcategory> | Index<security account>
performance counter frequency of <operating system> | performance counter frequencies | <hertz> | <operating system> | Plain
performance counter of <operating system> | performance counters | <integer> | <operating system> | Plain
permission permission of <network share> | permission permissions | <boolean> | <network share> | Plain
personal bit <operating system suite mask> | personal bits | <boolean> | <world> | Index<operating system suite mask>Global
physical processor count | physical processor counts | <integer> | <world> | PlainGlobal
physical ram | physical rams | <integer> | <world> | PlainGlobal
pid of <process> | pids | <integer> | <process> | Plain
pkgdb | pkgdbs | <pkgdb> | <world> | PlainGlobal
pkginfo <string> of <pkgdb> | pkginfos | <pkginfo> | <pkgdb> | Named
pkginfo of <pkgdb> | pkginfos | <pkginfo> | <pkgdb> | Plain
pkginst of <pkginfo> | pkginsts | <string> | <pkginfo> | Plain
platform id of <language> | platform ids | <string> | <language> | Plain
platform id of <operating system> | platform ids | <integer> | <operating system> | Plain
plural name of <property> | plural names | <string> | <property> | Plain
point to point of <network adapter> | point to points | <boolean> | <network adapter> | Plain
point to point of <network ip interface> | point to points | <boolean> | <network ip interface> | Plain
policy change category of <audit policy> | policy change categories | <audit policy category> | <audit policy> | Plain
port mapping of <internet connection firewall> | port mappings | <port mapping> | <internet connection firewall> | Plain
port number of <selected server> | port numbers | <integer> | <selected server> | Plain
port of <firewall open port> | ports | <integer> | <firewall open port> | Plain
position <integer> of <string> | positions | <string position> | <string> | Numbered
position of <string> | positions | <string position> | <string> | Plain
posix file <string> | posix files | <file> | <world> | NamedGlobal
posix folder <string> | posix folders | <folder> | <world> | NamedGlobal
posix path of <filesystem object> | posix paths | <string> | <filesystem object> | Plain
power plane of <registryroot> | power planes | <registrynode> | <registryroot> | Plain
powerpc | powerpcs | <boolean> | <world> | PlainGlobal
pre <string> of <html> | pres | <html> | <html> | Named
pre <string> of <string> | pres | <html> | <string> | Named
pre of <html> | pres | <html> | <html> | Plain
pre of <string> | pres | <html> | <string> | Plain
preceding text of <string position> | preceding texts | <substring> | <string position> | Plain
preceding text of <substring> | preceding texts | <substring> | <substring> | Plain
preference <string> | preferences | <preference> | <world> | NamedGlobal
preferences folder of <domain> | preferences folders | <folder> | <domain> | Plain
previous line of <file line> | previous lines | <file line> | <file line> | Plain
previous sibling of <xml dom node> | previous siblings | <xml dom node> | <xml dom node> | Plain
previous value of <runlevel> | previous values | <string> | <runlevel> | Plain
primary group id of <local user> | primary group ids | <integer> | <local user> | Plain
primary group id of <user> | primary group ids | <string> | <user> | Plain
primary internet connection | primary internet connections | <network ip interface> | <world> | PlainGlobal
primary language of <language> | primary languages | <primary language> | <language> | Plain
primary wins server of <network adapter> | primary wins servers | <ipv4 address> | <network adapter> | Plain
print operator flag of <local user> | print operator flags | <boolean> | <local user> | Plain
printer descriptions folder of <domain> | printer descriptions folders | <folder> | <domain> | Plain
printer drivers folder of <domain> | printer drivers folders | <folder> | <domain> | Plain
printers folder of <domain> | printers folders | <folder> | <domain> | Plain
printmonitor documents folder of <domain> | printmonitor documents folders | <folder> | <domain> | Plain
priority of <selected server> | priorities | <integer> | <selected server> | Plain
private firewall profile type | private firewall profile types | <firewall profile type> | <world> | PlainGlobal
private framework folder of <domain> | private framework folders | <folder> | <domain> | Plain
private profile of <firewall policy> | private profiles | <firewall profile> | <firewall policy> | Plain
privilege of <security account> | privileges | <string> | <security account> | Plain
privilege use category of <audit policy> | privilege use categories | <audit policy category> | <audit policy> | Plain
problem id of <active device> | problem ids | <integer> | <active device> | Plain
process | processes | <process> | <world> | PlainGlobal
process <integer> | processes | <process> | <world> | NumberedGlobal
process <string> | processes | <process> | <world> | NamedGlobal
process id of <process> | process ids | <integer> | <process> | Plain
process image file name of <firewall authorized application> | process image file names | <string> | <firewall authorized application> | Plain
process owner of <client> | process owners | <client process owner> | <client> | Plain
processor | processors | <processor> | <world> | PlainGlobal
processor <integer> | processors | <processor> | <world> | NumberedGlobal
product <string> of <object_repository> | products | <product> | <object_repository> | Named
product <string> of <software_depot> | products | <product> | <software_depot> | Named
product info numeric of <operating system> | product info numerics | <integer> | <operating system> | Plain
product info string of <operating system> | product info strings | <string> | <operating system> | Plain
product of <bundle> | products | <product> | <bundle> | Plain
product of <fileset> | products | <product> | <fileset> | Plain
product of <integer> | products | <integer> | <integer> | Plain
product of <object_repository> | products | <product> | <object_repository> | Plain
product of <scsidevice> | products | <string> | <scsidevice> | Plain
product of <software_depot> | products | <product> | <software_depot> | Plain
product type of <operating system> | product types | <operating system product type> | <operating system> | Plain
product version of <file> | product versions | <version> | <file> | Plain
profile <firewall profile type> of <firewall rule> | profiles | <boolean> | <firewall rule> | Index<firewall profile type>
profile folder of <local user> | profile folders | <string> | <local user> | Plain
property <string> | properties | <property> | <world> | NamedGlobal
property <string> of <type> | properties | <property> | <type> | Named
property <string> of <wmi object> | properties | <wmi select> | <wmi object> | Named
property of <type> | properties | <property> | <type> | Plain
property of <wmi object> | properties | <wmi select> | <wmi object> | Plain
property returning <type> | properties returning | <property> | <world> | Index<type>Global
property returning <type> of <type> | properties returning | <property> | <type> | Index<type>
protocol of <firewall open port> | protocols | <internet protocol> | <firewall open port> | Plain
protocol of <firewall rule> | protocols | <internet protocol> | <firewall rule> | Plain
protocol of <port mapping> | protocols | <string> | <port mapping> | Plain
provide of <package> | provides | <capability> | <package> | Plain
public firewall profile type | public firewall profile types | <firewall profile type> | <world> | PlainGlobal
public profile of <firewall policy> | public profiles | <firewall profile> | <firewall policy> | Plain
q <string> of <html> | qs | <html> | <html> | Named
q <string> of <string> | qs | <html> | <string> | Named
q of <html> | qs | <html> | <html> | Plain
q of <string> | qs | <html> | <string> | Plain
query value permission of <access control entry> | query value permissions | <boolean> | <access control entry> | Plain
quickdraw version | quickdraw versions | <version> | <world> | PlainGlobal
quicktime folder of <domain> | quicktime folders | <folder> | <domain> | Plain
ram | rams | <ram> | <world> | PlainGlobal
random access memory | random access memories | <ram> | <world> | PlainGlobal
range after <time> of <time range> | ranges after | <time range> | <time range> | Index<time>
range before <time> of <time range> | ranges before | <time range> | <time range> | Index<time>
raw file version of <file> | raw file versions | <version> | <file> | Plain
raw product version of <file> | raw product versions | <version> | <file> | Plain
raw version block <integer> of <file> | raw version blocks | <file version block> | <file> | Numbered
raw version block <string> of <file> | raw version blocks | <file version block> | <file> | Named
raw version block of <file> | raw version blocks | <file version block> | <file> | Plain
raw version of <file> | raw versions | <version> | <file> | Plain
read attributes permission of <access control entry> | read attributes permissions | <boolean> | <access control entry> | Plain
read control permission of <access control entry> | read control permissions | <boolean> | <access control entry> | Plain
read extended attributes permission of <access control entry> | read extended attributes permissions | <boolean> | <access control entry> | Plain
read of <mode_mask> | reads | <boolean> | <mode_mask> | Plain
read permission of <access control entry> | read permissions | <boolean> | <access control entry> | Plain
read permission of <network share> | read permissions | <boolean> | <network share> | Plain
readonly of <filesystem object> | readonlys | <boolean> | <filesystem object> | Plain
receipts folder of <domain> | receipts folders | <folder> | <domain> | Plain
recent application | recent applications | <application> | <world> | PlainGlobal
recent application <string> | recent applications | <application> | <world> | NamedGlobal
record <integer> of <event log> | records | <event log record> | <event log> | Numbered
record count of <event log> | record counts | <integer> | <event log> | Plain
record number of <event log record> | record numbers | <integer> | <event log record> | Plain
record of <event log> | records | <event log record> | <event log> | Plain
reference attribute of <metabase value> | reference attributes | <boolean> | <metabase value> | Plain
regapp | regapps | <application> | <world> | PlainGlobal
regapp | regapps | <filesystem object> | <world> | PlainGlobal
regapp <string> | regapps | <application> | <world> | NamedGlobal
regex <string> | regexes | <regular expression> | <world> | NamedGlobal
registrar number of <license> | registrar numbers | <integer> | <license> | Plain
registry | registries | <dummy type> | <world> | PlainGlobal
registry | registries | <registry> | <world> | PlainGlobal
regular expression <string> | regular expressions | <regular expression> | <world> | NamedGlobal
relation of <capability> | relations | <string> | <capability> | Plain
relative file <string> of <folder> | relative files | <file> | <folder> | Named
relative folder <string> of <folder> | relative folders | <folder> | <folder> | Named
relative hfs file <string> of <folder> | relative hfs files | <file> | <folder> | Named
relative hfs folder <string> of <folder> | relative hfs folders | <folder> | <folder> | Named
relative posix file <string> of <folder> | relative posix files | <file> | <folder> | Named
relative posix folder <string> of <folder> | relative posix folders | <folder> | <folder> | Named
relative significance place <integer> of <floating point> | relative significance places | <floating point> | <floating point> | Numbered
relative significance place of <floating point> | relative significance places | <floating point> | <floating point> | Plain
relay service | relay services | <nothing> | <world> | PlainGlobal
relay service | relay services | <service> | <world> | PlainGlobal
release of <operating system> | releases | <string> | <operating system> | Plain
release of <operating system> | releases | <version> | <operating system> | Plain
relevance of <fixlet> | relevances | <boolean> | <fixlet> | Plain
relevant fixlet of <site> | relevant fixlets | <fixlet> | <site> | Plain
remote addresses of <firewall authorized application> | remote addresseses | <string> | <firewall authorized application> | Plain
remote addresses of <firewall open port> | remote addresseses | <string> | <firewall open port> | Plain
remote addresses of <firewall service> | remote addresseses | <string> | <firewall service> | Plain
remote addresses string of <firewall rule> | remote addresses strings | <string> | <firewall rule> | Plain
remote admin settings of <firewall profile> | remote admin settingses | <firewall remote admin settings> | <firewall profile> | Plain
remote desktop firewall service type | remote desktop firewall service types | <firewall service type> | <world> | PlainGlobal
remote of <logged on user> | remotes | <boolean> | <logged on user> | Plain
remote ports string of <firewall rule> | remote ports strings | <string> | <firewall rule> | Plain
require of <package> | requires | <capability> | <package> | Plain
resource fork of <file> | resource forks | <resfork> | <file> | Plain
result type of <binary operator> | result types | <type> | <binary operator> | Plain
result type of <property> | result types | <type> | <property> | Plain
result type of <unary operator> | result types | <type> | <unary operator> | Plain
revision <string> of <patch> | revisions | <string> | <patch> | Named
revision of <patch> | revisions | <string> | <patch> | Plain
revision of <product> | revisions | <string> | <product> | Plain
revision of <scsidevice> | revisions | <string> | <scsidevice> | Plain
right operand type of <binary operator> | right operand types | <type> | <binary operator> | Plain
right shift <integer> of <bit set> | right shifts | <bit set> | <bit set> | Numbered
rom version | rom versions | <version> | <world> | PlainGlobal
root folder | root folders | <folder> | <world> | PlainGlobal
root folder of <drive> | root folders | <folder> | <drive> | Plain
root server | root servers | <root server> | <world> | PlainGlobal
rope <string> | ropes | <rope> | <world> | NamedGlobal
rpm | rpms | <rpmdatabase> | <world> | PlainGlobal
rpm <string> | rpms | <rpmdatabase> | <world> | NamedGlobal
rsop computer wmi | rsop computer wmis | <wmi> | <world> | PlainGlobal
rsop user wmi <security identifier> | rsop user wmis | <wmi> | <world> | Index<security identifier>Global
rule group currently enabled <string> of <firewall> | rule group currently enableds | <boolean> | <firewall> | Named
rule group enabled <string> of <firewall profile> | rule group enableds | <boolean> | <firewall profile> | Named
rule of <firewall service restriction> | rules | <firewall rule> | <firewall service restriction> | Plain
rule of <firewall> | rules | <firewall rule> | <firewall> | Plain
runlevel | runlevels | <runlevel> | <world> | PlainGlobal
running application | running applications | <application> | <world> | PlainGlobal
running application <string> | running applications | <application> | <world> | NamedGlobal
running of <application usage summary> | runnings | <boolean> | <application usage summary> | Plain
running of <local mssql database> | runnings | <boolean> | <local mssql database> | Plain
running service | running services | <service> | <world> | PlainGlobal
running service <string> | running services | <service> | <world> | NamedGlobal
sacl of <security descriptor> | sacls | <system access control list> | <security descriptor> | Plain
samp <string> of <html> | samps | <html> | <html> | Named
samp <string> of <string> | samps | <html> | <string> | Named
samp of <html> | samps | <html> | <html> | Plain
samp of <string> | samps | <html> | <string> | Plain
saturday | saturdays | <day of week> | <world> | PlainGlobal
scope of <firewall authorized application> | scopes | <firewall scope> | <firewall authorized application> | Plain
scope of <firewall open port> | scopes | <firewall scope> | <firewall open port> | Plain
scope of <firewall service> | scopes | <firewall scope> | <firewall service> | Plain
script flag of <local user> | script flags | <boolean> | <local user> | Plain
scripting additions folder of <domain> | scripting additions folders | <folder> | <domain> | Plain
scsibus | scsibuses | <scsibus> | <world> | PlainGlobal
scsibus <integer> | scsibuses | <scsibus> | <world> | NumberedGlobal
scsidevice | scsidevices | <scsidevice> | <world> | PlainGlobal
scsidevice <integer> | scsidevices | <scsidevice> | <world> | NumberedGlobal
scsidevice <integer> of <scsibus> | scsidevices | <scsidevice> | <scsibus> | Numbered
scsidevice of <scsibus> | scsidevices | <scsidevice> | <scsibus> | Plain
seat count state of <license> | seat count states | <string> | <license> | Plain
seat of <license> | seats | <integer> | <license> | Plain
second | seconds | <time interval> | <world> | PlainGlobal
second_of_minute of <time of day with time zone> | seconds_of_minute | <integer> | <time of day with time zone> | Plain
second_of_minute of <time of day> | seconds_of_minute | <integer> | <time of day> | Plain
secondary wins server of <network adapter> | secondary wins servers | <ipv4 address> | <network adapter> | Plain
section <string> of <file> | sections | <file section> | <file> | Named
secure attribute of <metabase value> | secure attributes | <boolean> | <metabase value> | Plain
security account <string> | security accounts | <security account> | <world> | NamedGlobal
security database | security databases | <security database> | <world> | PlainGlobal
security descriptor of <file> | security descriptors | <security descriptor> | <file> | Plain
security descriptor of <folder> | security descriptors | <security descriptor> | <folder> | Plain
security descriptor of <network share> | security descriptors | <security descriptor> | <network share> | Plain
security descriptor of <registry key> | security descriptors | <security descriptor> | <registry key> | Plain
security descriptor of <service> | security descriptors | <security descriptor> | <service> | Plain
security event log | security event logs | <event log> | <world> | PlainGlobal
select <string> of <wmi> | selects | <wmi select> | <wmi> | Named
select <string> of <xml dom node> | selects | <xml dom node> | <xml dom node> | Named
select object <string> of <wmi> | select objects | <wmi object> | <wmi> | Named
selected server | selected servers | <selected server> | <world> | PlainGlobal
sep bug of <processor> | sep bugs | <boolean> | <processor> | Plain
september | septembers | <month> | <world> | PlainGlobal
september <integer> | septembers | <day of year> | <world> | NumberedGlobal
september <integer> of <integer> | septembers | <date> | <integer> | Numbered
september of <integer> | septembers | <month and year> | <integer> | Plain
server operator flag of <local user> | server operator flags | <boolean> | <local user> | Plain
server trust account flag of <local user> | server trust account flags | <boolean> | <local user> | Plain
service | services | <service> | <world> | PlainGlobal
service <string> | services | <dummy> | <world> | NamedGlobal
service <string> | services | <service> | <world> | NamedGlobal
service key value name of <active device> | service key value names | <string> | <active device> | Plain
service name of <firewall rule> | service names | <string> | <firewall rule> | Plain
service name of <service> | service names | <string> | <service> | Plain
service of <firewall profile> | services | <firewall service> | <firewall profile> | Plain
service pack major version of <operating system> | service pack major versions | <integer> | <operating system> | Plain
service pack minor version of <operating system> | service pack minor versions | <integer> | <operating system> | Plain
service plane of <registryroot> | service planes | <registrynode> | <registryroot> | Plain
service restricted <( string, string )> of <firewall service restriction> | service restricteds | <boolean> | <firewall service restriction> | Index<( string, string )>
service restriction of <firewall> | service restrictions | <firewall service restriction> | <firewall> | Plain
service specific exit code of <service> | service specific exit codes | <integer> | <service> | Plain
session id of <logged on user> | session ids | <string> | <logged on user> | Plain
set of <integer> | sets | <integer set> | <integer> | Plain
set of <string> | sets | <string set> | <string> | Plain
set value permission of <access control entry> | set value permissions | <boolean> | <access control entry> | Plain
setgid of <filesystem object> | setgids | <boolean> | <filesystem object> | Plain
setgid of <mode> | setgids | <boolean> | <mode> | Plain
setting <string> of <client> | settings | <setting> | <client> | Named
setting <string> of <site> | settings | <setting> | <site> | Named
setting of <client> | settings | <setting> | <client> | Plain
setting of <site> | settings | <setting> | <site> | Plain
setuid of <filesystem object> | setuids | <boolean> | <filesystem object> | Plain
setuid of <mode> | setuids | <boolean> | <mode> | Plain
sha1 of <file> | sha1s | <string> | <file> | Plain
sha1 of <x509 certificate> | sha1s | <string> | <x509 certificate> | Plain
shared amount of <ram> | shared amounts | <integer> | <ram> | Plain
shared folder of <domain> | shared folders | <folder> | <domain> | Plain
shared libraries folder of <domain> | shared libraries folders | <folder> | <domain> | Plain
short name of <client process owner> | short names | <string> | <client process owner> | Plain
shortcut of <file> | shortcuts | <file shortcut> | <file> | Plain
shutdown items folder of <domain> | shutdown items folders | <folder> | <domain> | Plain
sibling file <string> of <filesystem object> | sibling files | <file> | <filesystem object> | Named
sibling folder <string> of <filesystem object> | sibling folders | <folder> | <filesystem object> | Named
sibling item <string> of <filesystem object> | sibling items | <filesystem object> | <filesystem object> | Named
sid of <logged on user> | sids | <security identifier> | <logged on user> | Plain
sid of <security account> | sids | <security identifier> | <security account> | Plain
significance place <integer> of <floating point> | significance places | <floating point> | <floating point> | Numbered
significance place of <floating point> | significance places | <floating point> | <floating point> | Plain
significance threshold of <floating point> | significance thresholds | <floating point> | <floating point> | Plain
significant digits <integer> of <hertz> | significant digitss | <hertz> | <hertz> | Numbered
significant digits <integer> of <integer> | significant digitss | <integer> | <integer> | Numbered
single user ts bit <operating system suite mask> | single user ts bits | <boolean> | <world> | Index<operating system suite mask>Global
singular name of <property> | singular names | <string> | <property> | Plain
site | sites | <site> | <world> | PlainGlobal
site <string> | sites | <site> | <world> | NamedGlobal
site number of <license> | site numbers | <integer> | <license> | Plain
site tag of <site> | site tags | <string> | <site> | Plain
site version list <string> | site version lists | <site version list> | <world> | NamedGlobal
site version list of <site> | site version lists | <site version list> | <site> | Plain
size of <array> | sizes | <integer> | <array> | Plain
size of <datafork> | sizes | <integer> | <datafork> | Plain
size of <dictionary> | sizes | <integer> | <dictionary> | Plain
size of <file> | sizes | <integer> | <file> | Plain
size of <filesystem> | sizes | <integer> | <filesystem> | Plain
size of <integer set> | sizes | <integer> | <integer set> | Plain
size of <ram> | sizes | <integer> | <ram> | Plain
size of <registry key value> | sizes | <integer> | <registry key value> | Plain
size of <resfork> | sizes | <integer> | <resfork> | Plain
size of <string set> | sizes | <integer> | <string set> | Plain
size of <swap> | sizes | <integer> | <swap> | Plain
size of <type> | sizes | <integer> | <type> | Plain
size of <volume> | sizes | <integer> | <volume> | Plain
small <string> of <html> | smalls | <html> | <html> | Named
small <string> of <string> | smalls | <html> | <string> | Named
small business bit <operating system suite mask> | small business bits | <boolean> | <world> | Index<operating system suite mask>Global
small business restricted bit <operating system suite mask> | small business restricted bits | <boolean> | <world> | Index<operating system suite mask>Global
small of <html> | smalls | <html> | <html> | Plain
small of <string> | smalls | <html> | <string> | Plain
software depot | software depots | <software_depot> | <world> | PlainGlobal
sound folder of <domain> | sound folders | <folder> | <domain> | Plain
source of <event log record> | sources | <string> | <event log record> | Plain
span <string> of <html> | spans | <html> | <html> | Named
span <string> of <string> | spans | <html> | <string> | Named
span of <html> | spans | <html> | <html> | Plain
span of <string> | spans | <html> | <string> | Plain
speech folder of <domain> | speech folders | <folder> | <domain> | Plain
speed of <processor> | speeds | <hertz> | <processor> | Plain
standard deviation of <floating point> | standard deviations | <floating point> | <floating point> | Plain
standard deviation of <integer> | standard deviations | <floating point> | <integer> | Plain
standard firewall profile type | standard firewall profile types | <firewall profile type> | <world> | PlainGlobal
standard profile of <firewall policy> | standard profiles | <firewall profile> | <firewall policy> | Plain
start date of <license> | start dates | <time> | <license> | Plain
start in pathname of <file shortcut> | start in pathnames | <string> | <file shortcut> | Plain
start of <substring> | starts | <string position> | <substring> | Plain
start of <time range> | starts | <time> | <time range> | Plain
start type of <service> | start types | <string> | <service> | Plain
startup items folder of <domain> | startup items folders | <folder> | <domain> | Plain
state of <dummy> | states | <string> | <dummy> | Plain
state of <processor> | states | <string> | <processor> | Plain
state of <service> | states | <string> | <service> | Plain
status of <action> | statuss | <string> | <action> | Plain
status of <active device> | statuss | <integer> | <active device> | Plain
status of <connection> | statuses | <connection status> | <connection> | Plain
status of <network adapter> | statuses | <integer> | <network adapter> | Plain
stepping of <processor> | steppings | <integer> | <processor> | Plain
sticky of <mode> | stickies | <boolean> | <mode> | Plain
string <integer> of <array> | strings | <string> | <array> | Numbered
string <string> | strings | <string> | <world> | NamedGlobal
string <string> of <dictionary> | strings | <string> | <dictionary> | Named
string <string> of <preference> | strings | <string> | <preference> | Named
string of <osxvalue> | strings | <string> | <osxvalue> | Plain
string value <integer> of <wmi select> | string values | <string> | <wmi select> | Numbered
string value of <wmi select> | string values | <string> | <wmi select> | Plain
strong <string> of <html> | strongs | <html> | <html> | Named
strong <string> of <string> | strongs | <html> | <string> | Named
strong of <html> | strongs | <html> | <html> | Plain
strong of <string> | strongs | <html> | <string> | Plain
strverscmp version <string> | strverscmp versions | <strverscmp version> | <world> | NamedGlobal
sub <string> of <html> | subs | <html> | <html> | Named
sub <string> of <string> | subs | <html> | <string> | Named
sub of <html> | subs | <html> | <html> | Plain
sub of <string> | subs | <html> | <string> | Plain
subcategory of <audit policy category> | subcategories | <audit policy subcategory> | <audit policy category> | Plain
subnet address of <network adapter> | subnet addresses | <ipv4 address> | <network adapter> | Plain
subnet address of <network address list> | subnet addresses | <ipv4 address> | <network address list> | Plain
subnet address of <network ip interface> | subnet addresses | <ipv4 address> | <network ip interface> | Plain
subnet mask of <network adapter> | subnet masks | <ipv4 address> | <network adapter> | Plain
subnet mask of <network address list> | subnet masks | <ipv4 address> | <network address list> | Plain
subnet mask of <network ip interface> | subnet masks | <ipv4 address> | <network ip interface> | Plain
subscribe time of <site> | subscribe times | <time> | <site> | Plain
substring <string> of <string> | substrings | <substring> | <string> | Named
substring after <string> of <string> | substrings after | <substring> | <string> | Named
substring before <string> of <string> | substrings before | <substring> | <string> | Named
substring between <string> of <string> | substrings between | <substring> | <string> | Named
substring separated by <string> of <string> | substrings separated by | <substring> | <string> | Named
subtype of <component> | subtypes | <string> | <component> | Plain
suite mask of <operating system> | suite masks | <operating system suite mask> | <operating system> | Plain
sum of <integer> | sums | <integer> | <integer> | Plain
sunday | sundays | <day of week> | <world> | PlainGlobal
sup <string> of <html> | sups | <html> | <html> | Named
sup <string> of <string> | sups | <html> | <string> | Named
sup of <html> | sups | <html> | <html> | Plain
sup of <string> | sups | <html> | <string> | Plain
swap | swaps | <swap> | <world> | PlainGlobal
symbol of <binary operator> | symbols | <string> | <binary operator> | Plain
symbol of <unary operator> | symbols | <string> | <unary operator> | Plain
symlink <filesystem object> | symlinks | <symlink> | <world> | Index<filesystem object>Global
symlink <string> | symlinks | <symlink> | <world> | NamedGlobal
symlink <string> of <folder> | symlinks | <symlink> | <folder> | Named
symlink <symlink> | symlinks | <symlink> | <world> | Index<symlink>Global
symlink of <folder> | symlinks | <symlink> | <folder> | Plain
synchronize permission of <access control entry> | synchronize permissions | <boolean> | <access control entry> | Plain
system category of <audit policy> | system categories | <audit policy category> | <audit policy> | Plain
system domain | system domains | <domain> | <world> | PlainGlobal
system event log | system event logs | <event log> | <world> | PlainGlobal
system file <string> | system files | <file> | <world> | NamedGlobal
system folder of <domain> | system folders | <folder> | <domain> | Plain
system ini device file | system ini device files | <file> | <world> | PlainGlobal
system ini device file <string> | system ini device files | <file> | <world> | NamedGlobal
system language | system languages | <string> | <world> | PlainGlobal
system locale | system locales | <language> | <world> | PlainGlobal
system of <filesystem object> | systems | <boolean> | <filesystem object> | Plain
system policy of <audit policy subcategory> | system policies | <audit policy information> | <audit policy subcategory> | Plain
system ui language | system ui languages | <language> | <world> | PlainGlobal
system version | system versions | <version> | <world> | PlainGlobal
system wow64 folder | system wow64 folders | <folder> | <world> | PlainGlobal
system x32 folder | system x32 folders | <folder> | <world> | PlainGlobal
system x64 folder | system x64 folders | <folder> | <world> | PlainGlobal
table <string> of <html> | tables | <html> | <html> | Named
table <string> of <string> | tables | <html> | <string> | Named
table of <html> | tables | <html> | <html> | Plain
table of <string> | tables | <html> | <string> | Plain
tag of <product> | tags | <string> | <product> | Plain
target ip address of <port mapping> | target ip addresses | <ipv4 address> | <port mapping> | Plain
target name of <port mapping> | target names | <string> | <port mapping> | Plain
tbody <string> of <html> | tbodys | <html> | <html> | Named
tbody <string> of <string> | tbodys | <html> | <string> | Named
tbody of <html> | tbodys | <html> | <html> | Plain
tbody of <string> | tbodys | <html> | <string> | Plain
tcp | tcps | <internet protocol> | <world> | PlainGlobal
td <string> of <html> | tds | <html> | <html> | Named
td <string> of <string> | tds | <html> | <string> | Named
td of <html> | tds | <html> | <html> | Plain
td of <string> | tds | <html> | <string> | Plain
temporary duplicate account flag of <local user> | temporary duplicate account flags | <boolean> | <local user> | Plain
temporary items folder of <domain> | temporary items folders | <folder> | <domain> | Plain
temporary of <filesystem object> | temporarys | <boolean> | <filesystem object> | Plain
terminal bit <operating system suite mask> | terminal bits | <boolean> | <world> | Index<operating system suite mask>Global
text encodings folder of <domain> | text encodings folders | <folder> | <domain> | Plain
tfoot <string> of <html> | tfoots | <html> | <html> | Named
tfoot <string> of <string> | tfoots | <html> | <string> | Named
tfoot of <html> | tfoots | <html> | <html> | Plain
tfoot of <string> | tfoots | <html> | <string> | Plain
th <string> of <html> | ths | <html> | <html> | Named
th <string> of <string> | ths | <html> | <string> | Named
th of <html> | ths | <html> | <html> | Plain
th of <string> | ths | <html> | <string> | Plain
thead <string> of <html> | theads | <html> | <html> | Named
thead <string> of <string> | theads | <html> | <string> | Named
thead of <html> | theads | <html> | <html> | Plain
thead of <string> | theads | <html> | <string> | Plain
themes folder of <domain> | themes folders | <folder> | <domain> | Plain
thursday | thursdays | <day of week> | <world> | PlainGlobal
time <string> | times | <time> | <world> | NamedGlobal
time <time zone> of <time> | times | <time of day with time zone> | <time> | Index<time zone>
time generated of <event log record> | times generated | <time> | <event log record> | Plain
time interval <string> | time intervals | <time interval> | <world> | NamedGlobal
time of <time of day with time zone> | times | <time of day> | <time of day with time zone> | Plain
time value <integer> of <wmi select> | time values | <time> | <wmi select> | Numbered
time value of <wmi select> | time values | <time> | <wmi select> | Plain
time written of <event log record> | times written | <time> | <event log record> | Plain
time zone <string> | time zones | <time zone> | <world> | NamedGlobal
time_of_day <string> | times_of_day | <time of day> | <world> | NamedGlobal
title <string> of <html> | titles | <html> | <html> | Named
title <string> of <string> | titles | <html> | <string> | Named
title of <html> | titles | <html> | <html> | Plain
title of <product> | titles | <string> | <product> | Plain
title of <string> | titles | <html> | <string> | Plain
total amount of <ram> | total amounts | <integer> | <ram> | Plain
total amount of <swap> | total amounts | <integer> | <swap> | Plain
total duration of <application usage summary> | total durations | <time interval> | <application usage summary> | Plain
total processor core count | total processor core counts | <integer> | <world> | PlainGlobal
total run count of <application usage summary> | total run counts | <integer> | <application usage summary> | Plain
total space of <drive> | total spaces | <integer> | <drive> | Plain
total space of <filesystem> | total spaces | <integer> | <filesystem> | Plain
total space of <volume> | total spaces | <integer> | <volume> | Plain
tr <string> of <html> | trs | <html> | <html> | Named
tr <string> of <string> | trs | <html> | <string> | Named
tr of <html> | trs | <html> | <html> | Plain
tr of <string> | trs | <html> | <string> | Plain
traverse permission of <access control entry> | traverse permissions | <boolean> | <access control entry> | Plain
true | trues | <boolean> | <world> | PlainGlobal
trustee of <access control entry> | trustees | <security identifier> | <access control entry> | Plain
trustee type of <access control entry> | trustee types | <integer> | <access control entry> | Plain
tt <string> of <html> | tts | <html> | <html> | Named
tt <string> of <string> | tts | <html> | <string> | Named
tt of <html> | tts | <html> | <html> | Plain
tt of <string> | tts | <html> | <string> | Plain
tty of <user> | ttys | <string> | <user> | Plain
tuesday | tuesdays | <day of week> | <world> | PlainGlobal
two digit hour of <time of day with time zone> | two digit hours | <string> | <time of day with time zone> | Plain
two digit hour of <time of day> | two digit hours | <string> | <time of day> | Plain
two digit minute of <time of day with time zone> | two digit minutes | <string> | <time of day with time zone> | Plain
two digit minute of <time of day> | two digit minutes | <string> | <time of day> | Plain
two digit second of <time of day with time zone> | two digit seconds | <string> | <time of day with time zone> | Plain
two digit second of <time of day> | two digit seconds | <string> | <time of day> | Plain
type of <bundle> | types | <file type> | <bundle> | Plain
type of <component> | types | <string> | <component> | Plain
type of <distinguished name component> | types | <string> | <distinguished name component> | Plain
type of <drive> | types | <string> | <drive> | Plain
type of <filesystem> | types | <string> | <filesystem> | Plain
type of <firewall profile> | types | <firewall profile type> | <firewall profile> | Plain
type of <firewall service> | types | <firewall service type> | <firewall service> | Plain
type of <metabase value> | types | <metabase type> | <metabase value> | Plain
type of <network adapter> | types | <integer> | <network adapter> | Plain
type of <network share> | types | <integer> | <network share> | Plain
type of <osxvalue> | types | <string> | <osxvalue> | Plain
type of <processor> | types | <integer> | <processor> | Plain
type of <processor> | types | <string> | <processor> | Plain
type of <registry key value> | types | <registry key value type> | <registry key value> | Plain
type of <scsidevice> | types | <string> | <scsidevice> | Plain
type of <site> | types | <string> | <site> | Plain
type of <wmi select> | types | <integer> | <wmi select> | Plain
udp | udps | <internet protocol> | <world> | PlainGlobal
uid of <filesystem object> | uids | <integer> | <filesystem object> | Plain
uid of <symlink> | uids | <integer> | <symlink> | Plain
ul <string> of <html> | uls | <html> | <html> | Named
ul <string> of <string> | uls | <html> | <string> | Named
ul of <html> | uls | <html> | <html> | Plain
ul of <string> | uls | <html> | <string> | Plain
unary operator <string> | unary operators | <unary operator> | <world> | NamedGlobal
unary operator returning <type> | unary operators returning | <unary operator> | <world> | Index<type>Global
unavailable amount of <ram> | unavailable amounts | <integer> | <ram> | Plain
underflow of <floating point> | underflows | <boolean> | <floating point> | Plain
unicast responses to multicast broadcast disabled of <firewall profile> | unicast responses to multicast broadcast disableds | <boolean> | <firewall profile> | Plain
union of <integer set> | unions | <integer set> | <integer set> | Plain
union of <string set> | unions | <string set> | <string set> | Plain
unique value of <date> | unique values | <date with multiplicity> | <date> | Plain
unique value of <day of month> | unique values | <day of month with multiplicity> | <day of month> | Plain
unique value of <day of week> | unique values | <day of week with multiplicity> | <day of week> | Plain
unique value of <day of year> | unique values | <day of year with multiplicity> | <day of year> | Plain
unique value of <floating point> | unique values | <floating point with multiplicity> | <floating point> | Plain
unique value of <hertz> | unique values | <hertz with multiplicity> | <hertz> | Plain
unique value of <integer> | unique values | <integer with multiplicity> | <integer> | Plain
unique value of <ipv4 address> | unique values | <ipv4 address with multiplicity> | <ipv4 address> | Plain
unique value of <ipv6 address> | unique values | <ipv6 address with multiplicity> | <ipv6 address> | Plain
unique value of <month and year> | unique values | <month and year with multiplicity> | <month and year> | Plain
unique value of <month> | unique values | <month with multiplicity> | <month> | Plain
unique value of <number of months> | unique values | <number of months with multiplicity> | <number of months> | Plain
unique value of <site version list> | unique values | <site version list with multiplicity> | <site version list> | Plain
unique value of <string> | unique values | <string with multiplicity> | <string> | Plain
unique value of <time interval> | unique values | <time interval with multiplicity> | <time interval> | Plain
unique value of <time of day with time zone> | unique values | <time of day with time zone with multiplicity> | <time of day with time zone> | Plain
unique value of <time of day> | unique values | <time of day with multiplicity> | <time of day> | Plain
unique value of <time range> | unique values | <time range with multiplicity> | <time range> | Plain
unique value of <time zone> | unique values | <time zone with multiplicity> | <time zone> | Plain
unique value of <time> | unique values | <time with multiplicity> | <time> | Plain
unique value of <version> | unique values | <version with multiplicity> | <version> | Plain
unique value of <year> | unique values | <year with multiplicity> | <year> | Plain
universal time <string> | universal times | <time> | <world> | NamedGlobal
universal time zone | universal time zones | <time zone> | <world> | PlainGlobal
unordered list <string> of <html> | unordered lists | <html> | <html> | Named
unordered list <string> of <string> | unordered lists | <html> | <string> | Named
unordered list of <html> | unordered lists | <html> | <html> | Plain
unordered list of <string> | unordered lists | <html> | <string> | Plain
up of <network adapter> | ups | <boolean> | <network adapter> | Plain
up of <network interface> | ups | <boolean> | <network interface> | Plain
update of <fileset> | updates | <integer> | <fileset> | Plain
upnp firewall service type | upnp firewall service types | <firewall service type> | <world> | PlainGlobal
upper bound of <integer range> | upper bounds | <integer> | <integer range> | Plain
uptime of <operating system> | uptimes | <time interval> | <operating system> | Plain
url of <site> | urls | <string> | <site> | Plain
usb | usbs | <usb> | <world> | PlainGlobal
usb plane of <registryroot> | usb planes | <registrynode> | <registryroot> | Plain
use count of <network share> | use counts | <integer> | <network share> | Plain
use limit of <network share> | use limits | <integer> | <network share> | Plain
used amount of <ram> | used amounts | <integer> | <ram> | Plain
used amount of <swap> | used amounts | <integer> | <swap> | Plain
used file count of <filesystem> | used file counts | <integer> | <filesystem> | Plain
used percent of <filesystem> | used percents | <integer> | <filesystem> | Plain
used percent of <volume> | used percents | <integer> | <volume> | Plain
used space of <filesystem> | used spaces | <integer> | <filesystem> | Plain
used space of <volume> | used spaces | <integer> | <volume> | Plain
user | users | <user> | <world> | PlainGlobal
user <string> | users | <user> | <world> | NamedGlobal
user comment of <local user> | user comments | <string> | <local user> | Plain
user domain | user domains | <domain> | <world> | PlainGlobal
user execute of <filesystem object> | user executes | <boolean> | <filesystem object> | Plain
user id of <local user> | user ids | <integer> | <local user> | Plain
user language | user languages | <string> | <world> | PlainGlobal
user locale | user locales | <language> | <world> | PlainGlobal
user mask of <filesystem object> | user masks | <integer> | <filesystem object> | Plain
user mask of <mode> | user masks | <mode_mask> | <mode> | Plain
user name of <filesystem object> | user names | <string> | <filesystem object> | Plain
user name of <symlink> | user names | <string> | <symlink> | Plain
user privilege of <local user> | user privileges | <boolean> | <local user> | Plain
user read of <filesystem object> | user reads | <boolean> | <filesystem object> | Plain
user sid of <event log record> | user sids | <security identifier> | <event log record> | Plain
user temp folder of <domain> | user temp folders | <folder> | <domain> | Plain
user type of <metabase value> | user types | <metabase user type> | <metabase value> | Plain
user ui language | user ui languages | <language> | <world> | PlainGlobal
user write of <filesystem object> | user writes | <boolean> | <filesystem object> | Plain
users folder of <domain> | users folders | <folder> | <domain> | Plain
usual name of <property> | usual names | <string> | <property> | Plain
utilities folder of <domain> | utilities folders | <folder> | <domain> | Plain
value <string> of <file version block> | values | <string> | <file version block> | Named
value <string> of <registry key> | values | <registry key value> | <registry key> | Named
value accessible of <symlink> | values accessible | <boolean> | <symlink> | Plain
value of <array> | values | <osxvalue> | <array> | Plain
value of <dictionaryentry> | values | <osxvalue> | <dictionaryentry> | Plain
value of <distinguished name component> | values | <string> | <distinguished name component> | Plain
value of <environment variable> | values | <string> | <environment variable> | Plain
value of <fixlet_header> | values | <string> | <fixlet_header> | Plain
value of <metabase key> | values | <metabase value> | <metabase key> | Plain
value of <registry key> | values | <registry key value> | <registry key> | Plain
value of <runlevel> | values | <string> | <runlevel> | Plain
value of <setting> | values | <string> | <setting> | Plain
value of <symlink> | values | <string> | <symlink> | Plain
value of <user attribute> | values | <string> | <user attribute> | Plain
var <string> of <html> | vars | <html> | <html> | Named
var <string> of <string> | vars | <html> | <string> | Named
var of <html> | vars | <html> | <html> | Plain
var of <string> | vars | <html> | <string> | Plain
variable <string> of <environment> | variables | <environment variable> | <environment> | Named
variable of <environment> | variables | <environment variable> | <environment> | Plain
variable of <file> | variables | <string> | <file> | Plain
vendor name of <processor> | vendor names | <string> | <processor> | Plain
vendor of <pkginfo> | vendors | <string> | <pkginfo> | Plain
vendor of <product> | vendors | <string> | <product> | Plain
vendor of <scsidevice> | vendors | <string> | <scsidevice> | Plain
version <integer> of <file> | versions | <version> | <file> | Numbered
version <string> | versions | <version> | <world> | NamedGlobal
version block <integer> of <file> | version blocks | <file version block> | <file> | Numbered
version block <string> of <file> | version blocks | <file version block> | <file> | Named
version block of <file> | version blocks | <file version block> | <file> | Plain
version of <bios> | versions | <string> | <bios> | Plain
version of <bundle> | versions | <version> | <bundle> | Plain
version of <capability> | versions | <string> | <capability> | Plain
version of <client> | versions | <version> | <client> | Plain
version of <component> | versions | <version> | <component> | Plain
version of <current relay> | versions | <version> | <current relay> | Plain
version of <file> | versions | <version> | <file> | Plain
version of <fileset> | versions | <version> | <fileset> | Plain
version of <filesystem object> | versions | <version> | <filesystem object> | Plain
version of <folder> | versions | <version> | <folder> | Plain
version of <package> | versions | <version> | <package> | Plain
version of <pkginfo> | versions | <string> | <pkginfo> | Plain
version of <processor> | versions | <string> | <processor> | Plain
version of <scsibus> | versions | <version> | <scsibus> | Plain
version of <site> | versions | <integer> | <site> | Plain
version of <usb> | versions | <version> | <usb> | Plain
version string <string> of <module> | version strings | <string> | <module> | Named
virtual memory | virtual memories | <boolean> | <world> | PlainGlobal
visible of <file> | visibles | <boolean> | <file> | Plain
voices folder of <domain> | voices folders | <folder> | <domain> | Plain
volatile attribute of <metabase value> | volatile attributes | <boolean> | <metabase value> | Plain
volume | volumes | <volume> | <world> | PlainGlobal
volume <integer> | volumes | <volume> | <world> | NumberedGlobal
volume <string> | volumes | <volume> | <world> | NamedGlobal
volume group <string> of <logical volume manager> | volume groups | <volume group> | <logical volume manager> | Named
volume group of <logical volume manager> | volume groups | <volume group> | <logical volume manager> | Plain
volume group of <logical volume> | volume groups | <volume group> | <logical volume> | Plain
volume of <file> | volumes | <volume> | <file> | Plain
volume of <folder> | volumes | <volume> | <folder> | Plain
volume settings folder of <domain> | volume settings folders | <folder> | <domain> | Plain
waiting for download of <action> | waiting for downloads | <boolean> | <action> | Plain
wake on lan subnet cidr string | wake on lan subnet cidr strings | <string> | <world> | PlainGlobal
wakeonlan enabled of <network adapter> | wakeonlan enableds | <boolean> | <network adapter> | Plain
warning event log event type | warning event log event types | <event log event type> | <world> | PlainGlobal
wednesday | wednesdays | <day of week> | <world> | PlainGlobal
week | weeks | <time interval> | <world> | PlainGlobal
weight of <selected server> | weights | <integer> | <selected server> | Plain
wide16 scsi of <scsibus> | wide16 scsis | <boolean> | <scsibus> | Plain
wide32 scsi of <scsibus> | wide32 scsis | <boolean> | <scsibus> | Plain
win32 exit code of <service> | win32 exit codes | <integer> | <service> | Plain
windows display time <string> | windows display times | <time> | <world> | NamedGlobal
windows file <string> | windows files | <file> | <world> | NamedGlobal
windows folder | windows folders | <folder> | <world> | PlainGlobal
wins enabled of <network adapter> | wins enableds | <boolean> | <network adapter> | Plain
winsock2 supported of <network> | winsock2 supporteds | <boolean> | <network> | Plain
wmi | wmis | <wmi> | <world> | PlainGlobal
wmi <string> | wmis | <wmi> | <world> | NamedGlobal
workstation trust account flag of <local user> | workstation trust account flags | <boolean> | <local user> | Plain
wp of <processor> | wps | <boolean> | <processor> | Plain
write attributes permission of <access control entry> | write attributes permissions | <boolean> | <access control entry> | Plain
write dac permission of <access control entry> | write dac permissions | <boolean> | <access control entry> | Plain
write extended attributes permission of <access control entry> | write extended attributes permissions | <boolean> | <access control entry> | Plain
write of <mode_mask> | writes | <boolean> | <mode_mask> | Plain
write owner permission of <access control entry> | write owner permissions | <boolean> | <access control entry> | Plain
write permission of <access control entry> | write permissions | <boolean> | <access control entry> | Plain
write permission of <network share> | write permissions | <boolean> | <network share> | Plain
x32 application <string> | x32 applications | <application> | <world> | NamedGlobal
x32 file <string> | x32 files | <file> | <world> | NamedGlobal
x32 folder <string> | x32 folders | <folder> | <world> | NamedGlobal
x32 registry | x32 registries | <registry> | <world> | PlainGlobal
x64 application <string> | x64 applications | <application> | <world> | NamedGlobal
x64 file <string> | x64 files | <file> | <world> | NamedGlobal
x64 folder <string> | x64 folders | <folder> | <world> | NamedGlobal
x64 of <operating system> | x64s | <boolean> | <operating system> | Plain
x64 registry | x64 registries | <registry> | <world> | PlainGlobal
xml document of <file> | xml documents | <xml dom document> | <file> | Plain
xml document of <string> | xml documents | <xml dom document> | <string> | Plain
xpath <( string, string )> of <xml dom node> | xpaths | <xml dom node> | <xml dom node> | Index<( string, string )>
xpath <string> of <xml dom node> | xpaths | <xml dom node> | <xml dom node> | Named
year | years | <number of months> | <world> | PlainGlobal
year <integer> | years | <year> | <world> | NumberedGlobal
year <string> | years | <year> | <world> | NamedGlobal
year of <date> | years | <year> | <date> | Plain
year of <month and year> | years | <year> | <month and year> | Plain
zone of <time of day with time zone> | zones | <time zone> | <time of day with time zone> | Plain
zoned time_of_day <string> | zoned times_of_day | <time of day with time zone> | <world> | NamedGlobal


World

All objects created without context are known as 'properties of the world' in the relevance language. Below is a list of these global properties, sorted by key phrase.

Properties

Key Phrase | Form | Return Type | Description
action | PlainGlobal | <action> | Returns the action currently being parsed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
action <integer> | NumberedGlobal | <action> | Returns the action matching the <integer> id. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
action lock state | PlainGlobal | <action lock state> | Returns the client action lock state. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
active action | PlainGlobal | <action> | Returns the action currently executing. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
active device | PlainGlobal | <active device> | Returns a list of all active devices found using the Configuration Manager SetupDiGetClassDevs NT API. Win:1.2
active device file | PlainGlobal | <file> | Under Windows NT, returns a list of file objects corresponding the list returned from the Windows NT EnumDeviceDrivers() function. Win:1.2
active device file <string> | NamedGlobal | <file> | Under Windows NT, returns a file object corresponding to the name provided. See file. Win:1.2
all firewall scope | PlainGlobal | <firewall scope> | Returns the scope of computers that allow ALL traffic through the firewall, corresponding to the Microsoft enumerated type NET_FW_SCOPE_ALL. Win:5.1
allow firewall action | PlainGlobal | <firewall action> | Returns a value corresponding to the NET_FW_ACTION enumerated type, which specifies the action for a rule or default setting. This is a Vista Inspector. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0
ansi code page | PlainGlobal | <integer> | Returns an integer value of the Windows API GetACP. Win:4.1
any ip version | PlainGlobal | <ip version> | Returns a type corresponding to the Microsoft enumerated value NET_FW_IP_VERSION_ANY. Win:5.1
apparent registration server time | PlainGlobal | <time> | Shorthand for 'now of registration server'. When the client registers with the server, the server passes its current time back to the client. The client starts a stop watch at that time. The apparent registration server time is the time the server passed back to the client, plus the elapsed time on the stop watch. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
application | PlainGlobal | <filesystem object> | This Mac Inspector recursively finds all applications (bundles) and executables under the /Applications directory, as well as all of those under the Applications directories of all local users of the machine. Mac:5.1
application <string> | NamedGlobal | <application> | Returns an application for the name provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
application <string> | NamedGlobal | <filesystem object> | Returns the named applications (bundles) and executables as filesystem objects. Mac:5.1
application event log | PlainGlobal | <event log> | Returns the object corresponding to the application event log, which records certain application events, such as the failure of MS SQL to access a database. Win:6.0
application usage summary | PlainGlobal | <application usage summary> | Returns an application usage summary containing information including the start time, duration and other statistics on client applications. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
application usage summary <string> | NamedGlobal | <application usage summary> | Returns the usage summary for the application specified in <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
april | PlainGlobal | <month> | Returns april as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
april <integer> | NumberedGlobal | <day of year> | Returns the nth day of april as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
audit failure event log event type | PlainGlobal | <event log event type> | Returns an object corresponding to an audit failure -- an event related to the failed execution of an action. Win:6.0
audit policy | PlainGlobal | <audit policy> | Windows Vista (and later versions of Windows) allows a finer granularity with audit policies by using subcategories. Setting audit policy at the category level overrides the new subcategory feature. A new registry key introduced in Vista is used to manage subcategories without requiring a change to Group Policy. This registry can be set to prevent the application of category-level audit policy from both Group Policy and the Local Security Policy admin tool. Win:7.2
audit success event log event type | PlainGlobal | <event log event type> | Returns an object corresponding to an audit success in an event log. Win:6.0
august | PlainGlobal | <month> | Returns August as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
august <integer> | NumberedGlobal | <day of year> | Returns the nth day of August as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
backoffice bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the backoffice bit of the Windows operating system suite mask is set. Win:6.0
bes license | PlainGlobal | <license> | Synonym for 'client license'. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
binary operator <string> | NamedGlobal | <binary operator> | Typically used in the plural, returns the various possible binary inspectors that use the specified operators. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
binary operator returning <type> | Index<type>Global | <binary operator> | Returns a list of binary operators that return the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
bit <integer> | NumberedGlobal | <bit set> | Returns TRUE or FALSE, corresponding to value of the bit specified by <integer>. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
bit set <string> | NamedGlobal | <bit set> | Returns the bits of the binary number given by the string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
blade bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the blade bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
block firewall action | PlainGlobal | <firewall action> | Returns a value corresponding to the NET_FW_ACTION enumerated type, which specifies the action for a rule or default setting. This is a Vista Inspector. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0
boolean <string> | NamedGlobal | <boolean> | Returns a boolean. For example, boolean "TRUE". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
br | PlainGlobal | <html> | Creates an HTML <br/> tag to output a line break. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
br <string> | NamedGlobal | <html> | Creates an HTML <br/> tag with an included modifier, such as class. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
bundle <string> | NamedGlobal | <bundle> | Returns a bundle (CFBundle) by name. Mac:4.1
capability <string> | NamedGlobal | <capability> | Converts a string to a capability object for rpm dependency version comparisons. Strings with version information take the form capability relation version, where relation is one of {<,>,>=,<=,=}. If a relation and version are not specified, then comparisons will assume a capability at any version number. Lin:4.1
case insensitive regex <string> | NamedGlobal | <regular expression> | Returns a case-insensitive regular expression from the supplied string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
case insensitive regular expression <string> | NamedGlobal | <regular expression> | Same as case insensitive regex <string>. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
cast <string> | NamedGlobal | <cast> | Returns a list of the objects that can be cast into the type specified by <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
cast returning <type> | Index<type>Global | <cast> | Returns a list of the objects that can be cast into the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
character <integer> | NumberedGlobal | <string> | Returns a string containing a single ASCII character. For example, character 90 = "Z". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
classic domain | PlainGlobal | <domain> | Returns a classic domain object. Mac:5.1
client | PlainGlobal | <client> | Returns the client object corresponding to the BigFix application evaluating the current relevance expression. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
client cryptography | PlainGlobal | <client_cryptography> | This Inspector is similar to the global cryptography object except that it returns properties exclusive to the client (whereas <cryptography> is also available in the Console/Web Reports contexts). Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
client license | PlainGlobal | <license> | Global object containing client licensing information. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
communications bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the communications bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
component | PlainGlobal | <component> | Is an iterated property. The MacOS supports software "components", for example QuickTime codecs. This iterator can examine the components that are available. Mac:4.1
computer | PlainGlobal | <computer> | Refers to the computer itself. Mac:4.1
computer id | PlainGlobal | <integer> | This is a unique integer assigned to the computer by the BES system. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
computer name | PlainGlobal | <string> | Returns a string corresponding to the name of the computer as it appears on the network. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
connection status <integer> | NumberedGlobal | <connection status> | Returns the connection status based on its integer value. This Inspector is included to take advantage of new (or undocumented) additions to the status values. Win:5.0
connection status authenticating | PlainGlobal | <connection status> | Returns the value NCS_AUTHENTICATING: The connection is waiting for authentication to occur. Win:5.0
connection status authentication failed | PlainGlobal | <connection status> | Returns the value NCS_AUTHENTICATION_FAILED: Authentication has failed on this connection. Win:5.0
connection status authentication succeeded | PlainGlobal | <connection status> | Returns the value NCS_AUTHENTICATION_SUCCEEDED: Authentication has succeeded on this connection. Win:5.0
connection status connected | PlainGlobal | <connection status> | Returns the value NCS_CONNECTED: The connection is in a connected state. Win:5.0
connection status connecting | PlainGlobal | <connection status> | Returns the value NCS_CONNECTING: The connection is in the process of connecting. Win:5.0
connection status disconnected | PlainGlobal | <connection status> | Returns the value NCS_DISCONNECTED: The connection is disconnected. Win:5.0
connection status disconnecting | PlainGlobal | <connection status> | Returns the value NCS_DISCONNECTING: The connection is in the process of disconnecting. Win:5.0
connection status hardware disabled | PlainGlobal | <connection status> | Returns the value NCS_HARDWARE_DISABLED: The hardware for the connection is present, but is not enabled. Win:5.0
connection status hardware malfunction | PlainGlobal | <connection status> | Returns the value NCS_HARDWARE_MALFUNCTION: A malfunction has occurred in the hardware for the connection. Win:5.0
connection status media disconnected | PlainGlobal | <connection status> | Returns the value NCS_MEDIA_DISCONNECTED: The media, for example the network cable, is disconnected. Win:5.0
connection status no hardware present | PlainGlobal | <connection status> | Returns the value NCS_NO_HARDWARE_PRESENT: The hardware for the connection, for example network interface card (NIC), is not present. Win:6.0
country <string> | NamedGlobal | <country> | Maps a country script string (e.g. verAfrikaans) to its region code. Mac:4.1
cpu speed | PlainGlobal | <integer> | Returns the clock speed of the cpu in Hz. Mac:4.1
cryptography | PlainGlobal | <cryptography> | A global object that implements the FIPS 140-2 standard for secure signing and authentication throughout the BigFix application. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
csidl folder <integer> | NumberedGlobal | <folder> | Returns the csidl folder corresponding to the specified integer. The windows SHGetSpecialFolderLocation API is used to look up paths to special folders, which are identified by passing the specified integer as the second argument of the API call. These values and their meaning are described in the windows ShlObj.h include file found in the development sdk. • Note that some of these folders do not exist in the Local System context. Win:7.0
current date | PlainGlobal | <date> | Returns the current date in the format: • Day of week, Day Month Year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_month | PlainGlobal | <day of month> | Returns the current day of the month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_week | PlainGlobal | <day of week> | Retruns the current day of the week, eg. Monday, Tuesday, etc. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_year | PlainGlobal | <day of year> | Retruns the current day of the year, in a Month Day format. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current firewall profile type | PlainGlobal | <firewall profile type> | Retrieves the type of firewall profile that is currently in effect. Win:5.1
current month | PlainGlobal | <month> | Returns the current month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current month_and_year | PlainGlobal | <month and year> | Returns the current date in month year format, eg. January 2012. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current relay | PlainGlobal | <current relay> | Returns an object corresponding to the server or relay that the client last registered with. This may be a BES Relay or the BES root server. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
current site | PlainGlobal | <site> | Returns the current site object. See site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
current time_of_day | PlainGlobal | <time of day with time zone> | Returns the current time of day in the local time zone. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
current time_of_day <time zone> | Index<time zone>Global | <time of day with time zone> | Returns the current time of day in the specified time zone. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
current user | PlainGlobal | <logged on user> | Returns the active, console (local) user, if logged on. Otherwise does not exist. Win:7.0, Mac:7.1
current user | PlainGlobal | <user> | Returns the current <user> if one is logged in to the desktop. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
current year | PlainGlobal | <year> | Returns the current year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
custom firewall scope | PlainGlobal | <firewall scope> | Returns the custom firewall scope, corresponding to the Microsoft enumerated type: NET_FW_SCOPE_CUSTOM. Win:5.1
custom site subscription effective date <string> | NamedGlobal | <time> | Returns the date the custom site (specified by <string>) was last subscribed or unsubscribed. It is used internally by BES to manage custom site subscriptions. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
datacenter bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the datacenter bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
date <string> | NamedGlobal | <date> | Converts the given string into a date. The string should be of the form 'Day Month Year' and the returned date will be of the form 'Day of week, Day Month Year'. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day | PlainGlobal | <time interval> | Returns a time interval corresponding to 1 day. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
day_of_month <integer> | NumberedGlobal | <day of month> | Converts the given integer to a day of month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_month <string> | NamedGlobal | <day of month> | Converts the given string value (must be an integer from 1-31) to a day of month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_week <string> | NamedGlobal | <day of week> | Converts the given string value to a day of week type, eg. Monday, Tuesday, etc. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december | PlainGlobal | <month> | Returns December as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december <integer> | NumberedGlobal | <day of year> | Returns the nth day of December as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
default web browser | PlainGlobal | <application> | Returns an application object corresponding to the computer's default web browser. This is the application associated with the .html file extension of the user context the inspector is run. When the agent is a service under windows, it runs in the LocalSystem context. This may have no meaning on some computers. Win:7.2
default web browser | PlainGlobal | <file> | Creates an object corresponding to the default web browser. This is a Windows and Macintosh inspector; it will fail gracefully on other operating systems instead of generating an error. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
dmi | PlainGlobal | <dmi> | Creates the global dmi object. If no dmi information is available, creation of the object will fail. Win:1.2, Lin:4.1
dns name | PlainGlobal | <string> | Returns the DNS name of the computer. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
domain firewall profile type | PlainGlobal | <firewall profile type> | Creates a domain firewall profile type for comparison. Win:5.1
domain name | PlainGlobal | <string> | Returns the fully qualified domain name of the machine. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
domain user | PlainGlobal | <local user> | Returns all of the users that are members of the domain for which the machine is a user. Win:4.1
domain user <string> | NamedGlobal | <local user> | Returns the local user object corresponding to the specified name. Win:4.1
domainname | PlainGlobal | <string> | Same as domain name. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
download file <string> | NamedGlobal | <file> | This inspector is available in relevance subsitution action processing. It returns a file object with the given name from the named folder or the download folder. This is equivalent to 'file "name" of download folder'. The file should exist or the result will not exist. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
download folder | PlainGlobal | <folder> | This inspector is available in relevance subsitution action processing. When the action is active, this inspector returns a folder object of __Download\, otherwise it returns a folder object of __Global\sitename\actionid\named. This inspector is designed for the prefetch process of action execution. • Macintosh Note: Prior to version 7.2, this Inspector referred to the system download folder on the Macintosh. That Inspector is referred to as ISS Download as of version 7.2. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
download path <string> | NamedGlobal | <string> | This inspector is available in relevance subsitution action processing. It returns a string corresponding to the download path of the specified file. This Inspector (along with download folder and download file) is designed to be used during the prefetch process of action execution. This is equivalent to '(pathname of download folder) & pathseparator & "myfile"'. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
drive | PlainGlobal | <filesystem> | Iterates through all valid drives on the system. Included for compatibility with Windows machines, this Inspector is the same as filesystem. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
drive | PlainGlobal | <volume> | Returns the volume corresponding to the drive. Typically used to return a list of the drives (volumes, filesystems) on the client computer. Drives, volumes and filesystems are treated the same on the Macintosh and return a <volume> type. Mac:6.0
drive <integer> | NumberedGlobal | <volume> | Returns the volume corresponding to the numbered drive. Mac:6.0
drive <string> | NamedGlobal | <drive> | Returns a drive object for the name provided. • Note: For Unix, this Inspector returns a <filesystem> object as of version 6.0 of BES. Win:1.2, , , ,
drive <string> | NamedGlobal | <filesystem> | Returns the drive associated with the pathname specified by <string>. Included for compatibility with Windows machines, this Inspector is the same as filesystem <string>. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
drive <string> | NamedGlobal | <volume> | Returns the volume corresponding to the named drive. Mac:6.0
embedded nt bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the embedded nt bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
embedded restricted bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the embedded restricted bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
enterprise bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the enterprise bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
environment | PlainGlobal | <environment> | Returns an object corresponding to the currently defined set of environment variables. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
error <string> | NamedGlobal | <undefined> | Always fails; if an error message is generated, it is based on the given string. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
error event log event type | PlainGlobal | <event log event type> | Returns an object corresponding to an error in the event log, such as the failure of a service to start. Win:6.0
event log <string> | NamedGlobal | <event log> | Returns the named event log, which contains historical information that help to track down system and security problems. There are several distinct logs that you can specify, including: • Application log: records application events • Security log: recirds global or local policy audit events • System log: records OS events. Win:6.0
event log event type <integer> | NumberedGlobal | <event log event type> | Returns an event type object corresponding to the specified number. The enumerated types include: • 1: error event • 2: warning event • 4: information event • 8: audit success event • 16: audit failure event. Win:6.0
false | PlainGlobal | <boolean> | Returns the boolean FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
february | PlainGlobal | <month> | Returns February as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
february <integer> | NumberedGlobal | <day of year> | Returns the nth day of February as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
file <string> | NamedGlobal | <file> | Returns a filesystem object corresponding to the full pathname provided in <string>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
file <symlink> | Index<symlink>Global | <file> | Returns the file pointed to by the specified symlink. If the file doesn't exist, this Inspector will throw a 'non-existent object' error. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
file signature <string> | NamedGlobal | <file signature> | Turn a string into a file signature (four letters, e.g. FNDR). Mac:4.1
file type <string> | NamedGlobal | <file type> | The phrase 'file type' can be used to create a file type object from a string. Mac:4.1
file_and_print firewall service type | PlainGlobal | <firewall service type> | Returns the global service type for file and print sharing, corresponding to the Microsoft enumerated type: NET_FW_SERVICE_FILE_AND_PRINT. Win:6.0
filesystem | PlainGlobal | <filesystem> | Returns <filesystem> objects for all currently mounted file systems. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
filesystem | PlainGlobal | <volume> | Returns the volume corresponding to the filesystem. Typically used to return a list of the filesystems (drives, volumes) on the client computer. Drives, volumes and filesystems are treated the same on the Macintosh and return a <volume> type. Mac:6.0
filesystem <integer> | NumberedGlobal | <volume> | Returns the volume corresponding to the numbered filesystem. Mac:6.0
filesystem <string> | NamedGlobal | <filesystem> | Returns the filesystem corresponding to the specified name. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem <string> | NamedGlobal | <volume> | Returns the volume corresponding to the named filesystem. Mac:6.0
firewall | PlainGlobal | <firewall> | Returns the global firewall object for this computer. Win:5.1
firewall action <integer> | NumberedGlobal | <firewall action> | Returns the Nth enumerated type from the Firewall Action interface. This provides an alternative way to access the firewall action variables and requires Vista. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0
firewall local policy modify state <integer> | NumberedGlobal | <firewall local policy modify state> | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. The <integer> specifies the zero-based enumeration, and provides an alternative access method. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
firewall profile type <integer> | NumberedGlobal | <firewall profile type> | Returns the firewall profile type corresponding to the given integer: • 0: Domain • 1: Standard • 2: Current. Win:5.1
firewall scope <integer> | NumberedGlobal | <firewall scope> | Returns the scope of addresses from which a port can listen. Win:5.1
firewall service type <integer> | NumberedGlobal | <firewall service type> | Returns the firewall service type specified by <integer>. Win:5.1
floating point <floating point> | Index<floating point>Global | <floating point> | Creates a floating point type object from the specified floating point number. Win:7.2, Mac:7.2
floating point <string> | NamedGlobal | <floating point> | Creates a floating point number from the provided string. Win:4.1, Mac:4.1
folder <string> | NamedGlobal | <folder> | Returns a folder object for the name provided. See drive. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
folder <symlink> | Index<symlink>Global | <folder> | Returns the folder pointed to by the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
friday | PlainGlobal | <day of week> | Returns Friday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
full wmi <string> | NamedGlobal | <wmi> | Returns a wmi object which can retrieve all values, including system values. Win:3.0
gestalt <string> | NamedGlobal | <integer> | This reads a 32 bit integer from the MacOS. The selector name is the four character OSType that chooses which item is being inspected. The interpretation of the result depends on the selector. It might represent an integer or a version, for instance. Mac:4.1
ghz | PlainGlobal | <hertz> | Returns a Hertz object corresponding to 1 giga-hertz. See hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
gp override firewall local policy modify state | PlainGlobal | <firewall local policy modify state> | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
greatest hz | PlainGlobal | <hertz> | Returns the largest hertz object that can be represented on this machine. See hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
greatest integer | PlainGlobal | <integer> | Returns the largest integer that can be represented on this machine. See integer. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
greatest time interval | PlainGlobal | <time interval> | Returns the greatest time interval representable. The value corresponds to 106751991 days, 04:00:54.775807. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hexadecimal integer <string> | NamedGlobal | <integer> | Creates an integer from the provided hexadecimal value. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
hexadecimal string <string> | NamedGlobal | <string> | Creates a string from the given hexadecimal value. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
hfs file <string> | NamedGlobal | <file> | Returns the hierachical file system (HFS) file specified by <string>. Mac:5.1
hfs folder <string> | NamedGlobal | <folder> | Returns the hierachical file system (HFS) folder specified by <string>. Mac:5.1
host name | PlainGlobal | <string> | Returns the machine name (the same as the computer name or hostname on Unix machines). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
hostname | PlainGlobal | <string> | Returns the standard host name, usually for the computer’s network. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hour | PlainGlobal | <time interval> | Returns a time interval corresponding to 1 hour. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hr | PlainGlobal | <html> | Creates a horizontal line tag <hr/>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
hr <string> | NamedGlobal | <html> | Creates a horizontal line tag with an option specfied by the string <hr string/>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html <string> | NamedGlobal | <html> | Embeds the specified string between <html></html> tags. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html tag <( string, html )> | Index<( string, html )>Global | <html> | Returns an HTML snippet containing the specified html enclosed in an html tag specified by string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html tag <( string, html attribute list, html )> | Index<( string, html attribute list, html )>Global | <html> | Returns an HTML snippet enclosed in a tag specified by the string, modified by the html attribute list and bracketing the html argument. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html tag <( string, html attribute list, string )> | Index<( string, html attribute list, string )>Global | <html> | Returns an HTML snippet enclosed in a tag specified by the first string, modified by the html attribute list and bracketing the second string argument. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html tag <( string, string )> | Index<( string, string )>Global | <html> | Returns an HTML snippet containing the second string enclosed in an html tag specified by the first string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
hyperthreading capable | PlainGlobal | <boolean> | Returns a boolean TRUE if the agent is able to detect that the processor is capable of running with hyperthreading enabled. Win:6.0
hyperthreading enabled | PlainGlobal | <boolean> | Returns TRUE if the machine is running with hyperthreading enabled, a method in which each physical processor on the machine presents itself as multiple logical processors to the operating system. Win:5.0
hz | PlainGlobal | <hertz> | Returns a hertz object corresponding to 1 hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
inbound blocked firewall local policy modify state | PlainGlobal | <firewall local policy modify state> | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
information event log event type | PlainGlobal | <event log event type> | Returns an object corresponding to an information event -- An informational event which is generally related to a successful action. Win:6.0
install folder <integer> | NumberedGlobal | <folder> | Returns a folder object corresponding to the number provided. The placement of some system folders can be found using numbers that have been associated with those folders. See folder. Win:1.2
integer <integer> | NumberedGlobal | <integer> | Returns an integer. The keyword is optional. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
integer <string> | NamedGlobal | <integer> | Returns integer for name provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
internet plugins folder | PlainGlobal | <folder> | Returns the folder object corresponding to the internet plugins. Mac:5.1
internet protocol <integer> | NumberedGlobal | <internet protocol> | Returns the firewall internet protocol specified by the given integer. These correspond to the Microsoft enumerated types: • NET_FW_IP_PROTOCOL_TCP • NET_FW_IP_PROTOCOL_UDP. Win:5.1
iokit registry | PlainGlobal | <registryroot> | Returns the root of the registry; the place to start with the registry. Mac:4.1
ip version <integer> | NumberedGlobal | <ip version> | Returns the the IP version for the specified integer. Win:5.1
ipv4 | PlainGlobal | <ip version> | Provides a comparison value for a firewall ip version inspector. Win:5.1
ipv4 address <string> | NamedGlobal | <ipv4 address> | Returns an ip address for the string provided. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ipv6 | PlainGlobal | <ip version> | Provides a comparison value for a firewall ip version inspector. Win:5.1
ipv6 address <string> | NamedGlobal | <ipv6 address> | Converts a string representations of an IPv6 address (with colons and/or dots) as an IPv6 address type. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
iss download folder | PlainGlobal | <folder> | The Macintosh download folder. This Inspector was previously labeled "download," which now refers to a world object that performs dynamic downloading. Mac:7.2
january | PlainGlobal | <month> | Returns January as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
january <integer> | NumberedGlobal | <day of year> | Returns the nth day of January as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july | PlainGlobal | <month> | Returns July as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july <integer> | NumberedGlobal | <day of year> | Returns the nth day of July as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june | PlainGlobal | <month> | Returns June as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june <integer> | NumberedGlobal | <day of year> | Returns the nth day of June as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
khz | PlainGlobal | <hertz> | Returns a hertz object corresponding to 1 kilohertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
least hz | PlainGlobal | <hertz> | Returns the least hertz value that can be represented on this machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
least integer | PlainGlobal | <integer> | Returns the least integer value that can be represented on this machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
least time interval | PlainGlobal | <time interval> | Returns the least time interval that can be represented on this machine. The value corresponds to -106751991 days, 04:00:54.775808. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
local administrator | PlainGlobal | <boolean> | Returns the boolean TRUE if the user belongs to the local administrator group. Also returns TRUE for Win9x and WinME. Win:1.2
local domain | PlainGlobal | <domain> | Returns a local domain object. Mac:5.1
local group | PlainGlobal | <local group> | Returns local groups defined on the local computer using the windows NetLocalGroupEnum API. Several local groups are defined simply by a default operating system install, and have names such as Administrators, Backup Operators, Guests, Network Configuration Operators, Power users, Users, etc. Some software applications also define local groups in order to help manage protections. Win:6.0
local group <string> | NamedGlobal | <local group> | Returns a local group corresponding to the given name, such as Adminstrator, Guests, etc. Win:6.0
local mssql database | PlainGlobal | <local mssql database> | Returns local MSSQL database objects. Win:1.2
local mssql database <string> | NamedGlobal | <local mssql database> | Returns the local Microsoft SQL (MSSQL) database object identified by the name provided. Win:1.2
local subnet firewall scope | PlainGlobal | <firewall scope> | Returns the local subnet firewall scope, corresponding to the Microsoft enumerated type: NET_FW_SCOPE_LOCAL_SUBNET. Win:5.1
local time <string> | NamedGlobal | <time> | Returns a time object for the name provided. See time. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
local time zone | PlainGlobal | <time zone> | Returns a time zone object corresponding to the local time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
local user | PlainGlobal | <local user> | Returns all local users of the machine. Win:1.2
local user <string> | NamedGlobal | <local user> | Returns the named local user. Win:1.2
logged on user | PlainGlobal | <logged on user> | Returns the user logged on to this BES Client. This Inspector iterates through all logged-on users, using Terminal Services, ACLs, and on Win 9x, the registry. Win:7.0, Mac:7.1
logical processor count | PlainGlobal | <integer> | Returns the number of logical processors available per physical processor. This can be interpreted as the number of hyperthreads that could be enabled on the machine. On a machine with 2 physical processors, each with 2 possible hyperthreads per processor, the ‘physical processor count’ and the ‘logical processor count’ would both return 2, while the ‘number of processors’ would return 4, since there are a total of 4 logical processors available for work. With hyperthreading turned off, the ‘number of processors’, ‘logical processor count’ and ‘physical processor count’ would all be 2. Disabling one of those processors will then give ‘number of processors’=1, ‘logical processor count’=2, and ‘physical processor count’=1. If the number of processors / physical processor count != logical processor count, you can turn on hyperthreading. Win:6.0
logical ram | PlainGlobal | <integer> | Returns the amount of logical ram in the computer, physical plus virtual. Mac:4.1
logical volume manager | PlainGlobal | <logical volume manager> | Returns the global logical volume manager on AIX systems. AIX:7.0
machine name | PlainGlobal | <string> | Returns the machine name. The value is from a long enumeration of all Mac platforms. See the header file Gestalt.h or Apple's Website. Mac:4.1
main gather service | PlainGlobal | <nothing> | Returns "no such object" -- included for compatibility with other operating systems. Mac:7.2
main gather service | PlainGlobal | <service> | Returns a service object for the main gathering service, typically located on the main server. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
main processor | PlainGlobal | <processor> | Returns the processor object corresponding to the main processor. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
march | PlainGlobal | <month> | Returns March as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
march <integer> | NumberedGlobal | <day of year> | Returns the nth day of March as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
may | PlainGlobal | <month> | Returns May as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
may <integer> | NumberedGlobal | <day of year> | Returns the nth day of May as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
media type <integer> | NumberedGlobal | <media type> | Returns the media type based on its integer value. This Inspector is included to take advantage of new (or undocumented) additions to the media types. Win:5.0
media type bridge | PlainGlobal | <media type> | Returns the value NCM_BRIDGE: Bridged connection. Win:5.0
media type direct | PlainGlobal | <media type> | Returns the value NCM_DIRECT: Direct serial connection through a serial port. Win:5.0
media type isdn | PlainGlobal | <media type> | Returns the value NCM_ISDN: Connection is through an integrated services digital network (ISDN) line. Win:5.0
media type lan | PlainGlobal | <media type> | Returns the value NCM_LAN: Connection is to a local area network (LAN). Win:5.0
media type phone | PlainGlobal | <media type> | Returns the value NCM_PHONE: Dial-up connection over a conventional phone line. Win:5.0
media type pppoe | PlainGlobal | <media type> | Returns the value NCM_PPPOE: Point-to-Point protocol (PPP) over Ethernet. Win:5.0
media type shared access host lan | PlainGlobal | <media type> | Returns the value NCM_SHAREDACCESSHOST_LAN: Shared connection to a LAN. Win:5.0
media type shared access host ras | PlainGlobal | <media type> | Returns the value NCM_SHAREDACCESSHOST_RAS: Shared connection to a remote or wide area network (WAN). Win:5.0
media type tunnel | PlainGlobal | <media type> | Returns the value NCM_TUNNEL: Virtual private network (VPN) connection. Win:5.0
metabase | PlainGlobal | <metabase> | Returns the IIS metabase object. Win:4.1
mhz | PlainGlobal | <hertz> | Returns a hertz object corresponding to 1 megahertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
microsecond | PlainGlobal | <time interval> | Returns a time interval corresponding to .000001 seconds. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
midnight | PlainGlobal | <time of day> | Returns 00:00:00 as a time of day object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
millisecond | PlainGlobal | <time interval> | Returns a time interval corresponding to .001 seconds. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
minute | PlainGlobal | <time interval> | Returns a time interval corresponding to 1 minute. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
model | PlainGlobal | <string> | Returns the model of the computer. HPUX:4.0
module <string> | NamedGlobal | <module> | For BigFix internal use only. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
monday | PlainGlobal | <day of week> | Returns the day of week object for Monday. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month | PlainGlobal | <number of months> | Returns the specified number of months. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month <integer> | NumberedGlobal | <month> | Returns the month type corresponding to the given <integer>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month <string> | NamedGlobal | <month> | Returns a month type corresponding to the given <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
native registry | PlainGlobal | <registry> | On 32 bit versions of windows, this returns the same as registry32 and registry. On 64 bit versions of windows, this returns the same as registry64. Win:6.0
network | PlainGlobal | <network> | Returns an object containing properties of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
network domain | PlainGlobal | <domain> | Returns a network domain object. Mac:5.1
network share | PlainGlobal | <network share> | Creates a network shared object. Win:4.1
network share <string> | NamedGlobal | <network share> | Creates a named network shared object. Win:4.1
none firewall service type | PlainGlobal | <firewall service type> | Returns the no firewall service type, corresponding to the Microsoft enumerated type: NET_FW_SERVICE_NONE. Win:6.0
noon | PlainGlobal | <time of day> | Returns 12:00:00 as a time of day object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
november | PlainGlobal | <month> | Returns November as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
november <integer> | NumberedGlobal | <day of year> | Returns the nth day of November as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
now | PlainGlobal | <time> | Returns the current time as a time object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
nt domain controller product type | PlainGlobal | <operating system product type> | Returns an object corresponding to OS product type of nt domain controller. Win:6.0
nt server product type | PlainGlobal | <operating system product type> | Returns an object corresponding to OS product type of nt server. Win:6.0
nt workstation product type | PlainGlobal | <operating system product type> | Returns an object corresponding to OS product type of nt workstation. Win:6.0
nubus map | PlainGlobal | <integer> | Returns the nubus map. Mac:4.1
object repository | PlainGlobal | <object_repository> | This is the global inspector object; all installed software inspectors are properties of this. AIX:4.1
october | PlainGlobal | <month> | Returns October as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
october <integer> | NumberedGlobal | <day of year> | Returns the nth day of October as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
oem code page | PlainGlobal | <integer> | Returns an integer value of the Windows API GetOEMCP. Win:4.1
ok firewall local policy modify state | PlainGlobal | <firewall local policy modify state> | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
on appropriate disk domain | PlainGlobal | <domain> | Returns one of the Macintosh domains. In most cases, this is the equivalent of kOnAppropriateDisk. On Mac OS X, this constant is used instead of the constant kOnSytemDisk to indicate any disk. For more information, see the Apple documentation on Carbon domain constants. Mac:5.1
on system disk domain | PlainGlobal | <domain> | Returns the OnSystemDisk domain. Mac:5.1
operating system | PlainGlobal | <operating system> | Returns the operating system object. See operating system. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
operating system product type <integer> | NumberedGlobal | <operating system product type> | Returns an object corresponding to the numbered OS product type. Win:6.0
parameter <string> | NamedGlobal | <string> | This Inspector is a synonym for the parameter <string> of <action>. It looks up the value of the action parameter specified by <string>. This is used in conjunction with the parameter set command. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
pending login | PlainGlobal | <boolean> | Installers may leave values in the registry that the operating system will execute when the next user logs in. Pending login can detect these registry entries. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
pending restart | PlainGlobal | <boolean> | Returns TRUE if the operating system indicates that a restart needs to occur. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
pending restart <string> | NamedGlobal | <boolean> | Immediately after issuing a command like 'Action requires restart "PatchGroupX”', the expression 'Pending restart "PatchGroupX”' will be true until the next restart. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
personal bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the personal bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
physical processor count | PlainGlobal | <integer> | Returns the number of physical processors on the machine. Note that 'number of processors' returns the number of logical processors. To determine the number of logical processors per physical processor, use 'number of processors / physical processor count'. Win:5.0
physical ram | PlainGlobal | <integer> | Returns the amount of physical ram in the computer. Mac:4.1
pkgdb | PlainGlobal | <pkgdb> | A top-level object containing a list of all the installed packages, in the form of pkginfos. Sol:3.1
posix file <string> | NamedGlobal | <file> | Returns the POSIX file specified by <string>. Mac:5.1
posix folder <string> | NamedGlobal | <folder> | Returns the POSIX folder specified by <string>. Mac:5.1
powerpc | PlainGlobal | <boolean> | Returns TRUE if the cpu is a PowerPC, FALSE if it is a 68000 chip. Mac:4.1
preference <string> | NamedGlobal | <preference> | The named set of preferences. Mac:4.1
primary internet connection | PlainGlobal | <network ip interface> | This contains information about the current internet connection. Mac:5.1
private firewall profile type | PlainGlobal | <firewall profile type> | Retrieves the enumerated variable corresponding to private profile type. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
process | PlainGlobal | <process> | Returns all process objects currently running. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
process <integer> | NumberedGlobal | <process> | Returns the process object corresponding to the given integer pid. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
process <string> | NamedGlobal | <process> | Returns the process object corresponding to the name specified by <string>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
processor | PlainGlobal | <processor> | Returns all the processor objects defined on the machine. See processor. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
processor <integer> | NumberedGlobal | <processor> | Returns a processor object for the numbered processor. Processors are numbered from 1. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
property <string> | NamedGlobal | <property> | Typically used in the plural, returns the "line" Inspector properties. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property returning <type> | Index<type>Global | <property> | Produces a list of the Inspector properties that return the specified <type>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
public firewall profile type | PlainGlobal | <firewall profile type> | Retrieves the enumerated variable corresponding to public profile type. This profile type is used for public internet access points. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
quickdraw version | PlainGlobal | <version> | Returns the version of QuickDraw installed. Mac:4.1
ram | PlainGlobal | <ram> | Returns a ram object for inspecting the properties of Random Access Memory installed on the machine. See ram. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
random access memory | PlainGlobal | <ram> | Same as above. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
recent application | PlainGlobal | <application> | Returns all the application objects that have recently been executing on the machine. See application. Win:1.2, Lin:6.0
recent application <string> | NamedGlobal | <application> | Returns an application for the name provided it has recently executed. The name is assumed to be the last part of an executable file name. Win:1.2, Lin:6.0
regapp | PlainGlobal | <application> | Returns all the application objects defined under the 'App Paths' key of the registry. • Note: This Inspector returns a <filesystem> object on the Macintosh. Win:1.2
regapp | PlainGlobal | <filesystem object> | This Mac Inspector recursively finds all applications (bundles) and executables under the /Applications directory, as well as all of those under the Applications directories of all local users of the machine. This Inspector is the same as application, and is included for compatibility with Windows. Mac:5.1
regapp <string> | NamedGlobal | <application> | Returns an application object for the name provided. See application and regapp. Win:1.2
regex <string> | NamedGlobal | <regular expression> | Creates a regex object from the given string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
registry | PlainGlobal | <dummy type> | Windows only, but included for compatibility with other operating systems. Mac:5.1
registry | PlainGlobal | <registry> | Returns a registry object. Win:1.2
regular expression <string> | NamedGlobal | <regular expression> | Same as regex <string>. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
relay service | PlainGlobal | <nothing> | Returns FALSE. Included for compatibility with Windows Inspectors. Mac:5.1
relay service | PlainGlobal | <service> | Returns a service object for the relay component of BES. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
remote desktop firewall service type | PlainGlobal | <firewall service type> | Returns the remote desktop firewall service type, corresponding to the Microsoft enumerated type: NET_FW_SERVICE_REMOTE_DESKTOP. Win:5.1
rom version | PlainGlobal | <version> | Returns the version of the system ROM. Mac:4.1
root folder | PlainGlobal | <folder> | Returns the folder corresponding to ‘/’. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
root server | PlainGlobal | <root server> | Returns an object representing the root BES Server to which the client last registered. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
rope <string> | NamedGlobal | <rope> | Creates a rope object from the given string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
rpm | PlainGlobal | <rpmdatabase> | Returns an object representing the rpm database of the machine. Lin:3.1
rpm <string> | NamedGlobal | <rpmdatabase> | Returns an object corresponding to the database named by <string>. Lin:3.1
rsop computer wmi | PlainGlobal | <wmi> | Provides access to the Resultant Set of Policy (RSoP) WMI classes via the RsopLoggingModeProvider. This is used to examine the state of the GPO (Group Policy object) security policies. Win:7.0
rsop user wmi <security identifier> | Index<security identifier>Global | <wmi> | Each user has its own RSoP (Resultant Set of Policy) namespace based on the user’s Security Identifier (SID). This Inspector returns the namespace specified by the <security identifier>. Win:7.0
runlevel | PlainGlobal | <runlevel> | Returns the current runlevel of the local machine. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
running application | PlainGlobal | <application> | Returns all the application objects that are currently executing on the machine. See application. Win:1.2, Lin:6.0
running application <string> | NamedGlobal | <application> | Returns an application for the name provided it is currently executing. The name is assumed to be the last part of an executable file name. Win:1.2, Lin:6.0
running service | PlainGlobal | <service> | Returns all the running service objects. Win:1.2
running service <string> | NamedGlobal | <service> | Returns the running service object matching the name provided. Win:1.2
saturday | PlainGlobal | <day of week> | Returns Saturday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
scsibus | PlainGlobal | <scsibus> | An iterated property. When used without a number and not iterated it means SCSI bus 0. Mac:4.1
scsibus <integer> | NumberedGlobal | <scsibus> | Returns a SCSI bus with the given number. Mac:4.1
scsidevice | PlainGlobal | <scsidevice> | An iterated property. It is derived from calls to the MacOS. Mac:4.1
scsidevice <integer> | NumberedGlobal | <scsidevice> | Returns a SCSI device with the given number. Mac:4.1
second | PlainGlobal | <time interval> | Returns a time interval corresponding to 1 second. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
security account <string> | NamedGlobal | <security account> | This is a named Inspector that uses the LookupAccountName API function to return an object representing a user or group. Win:7.2
security database | PlainGlobal | <security database> | Returns the security accounts manager (SAM) database or, in the case of domain controllers, the Active Directory. Win:7.1
security event log | PlainGlobal | <event log> | Returns a security event log, which records global or local group policy events. Win:6.0
selected server | PlainGlobal | <selected server> | The BES Server or BES Relay to which the agent reports. Returned as the "selected server" type. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
september | PlainGlobal | <month> | Returns September as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
september <integer> | NumberedGlobal | <day of year> | Returns the nth day of September as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
service | PlainGlobal | <service> | Returns all the service objects. Win:1.2
service <string> | NamedGlobal | <dummy> | A dummy inspector to provide compatibility with Windows and Unix. Mac:5.1
service <string> | NamedGlobal | <service> | Returns the service object matching the name provided regardless of its running state. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
single user ts bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the single user ts bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
site | PlainGlobal | <site> | Returns all the site objects that are currently loaded into memory. See site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site <string> | NamedGlobal | <site> | Returns a site object for the name provided. The name is the URL of the site location. See site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site version list <string> | NamedGlobal | <site version list> | Returns a textual representation of a site version list ("manyversion"). Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
small business bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the small business bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
small business restricted bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the small business restricted bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
software depot | PlainGlobal | <software_depot> | Accesses the set of installed software and products. HPUX:4.0
standard firewall profile type | PlainGlobal | <firewall profile type> | Returns the Standard firewall profile type. This is a global property. Win:5.1
string <string> | NamedGlobal | <string> | Returns a string for the name provided. The keyword string is optional. For example, string "hi" = "hi". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
strverscmp version <string> | NamedGlobal | <strverscmp version> | Creates a strverscmp version, which is compared to other versions using the OS supplied strverscmp function. Lin:4.1
sunday | PlainGlobal | <day of week> | Returns Sunday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
swap | PlainGlobal | <swap> | Returns an object containing information about the swap partition. Lin:3.1, HPUX:4.0, AIX:4.1
symlink <filesystem object> | Index<filesystem object>Global | <symlink> | Returns a symlink from the specified filesystem object. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <string> | NamedGlobal | <symlink> | Returns a symlink from the specified string. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <symlink> | Index<symlink>Global | <symlink> | Returns a symlink from the specified symlink path, even if the symlink is broken. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
system domain | PlainGlobal | <domain> | Returns a system domain object. Mac:5.1
system event log | PlainGlobal | <event log> | Returns a system event log, which records OS or component events, such as the failure of a bootup service. Win:6.0
system file <string> | NamedGlobal | <file> | Returns a file object corresponding to the relative pathname provided. Win:1.2
system ini device file | PlainGlobal | <file> | Returns a list of file objects corresponding to all the device files loaded as a result of a device= lines of the system.ini file. See file. Win:1.2
system ini device file <string> | NamedGlobal | <file> | Returns a file object corresponding to a device file loaded as a result of a device= line of the system.ini file. Win:1.2
system language | PlainGlobal | <string> | Returns the language of the system as a string. It is identified using the GetSystemDefaultLangID() system call. See the language keyword of the application object for a list of possible language value. Win:1.2, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
system locale | PlainGlobal | <language> | Determines which bitmap fonts, and OEM, ANSI, and MAC code pages are defaults for the system. This only affects applications that are not fully Unicode. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
system ui language | PlainGlobal | <language> | Determines the default language of menus and dialogs, messages and help files. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
system version | PlainGlobal | <version> | Returns the version of MacOS. Mac:4.1
system wow64 folder | PlainGlobal | <folder> | Returns a filesystem object corresponding to a "Windows On Windows 64" system folder, which does not exist on 32-bit Windows. You can find out more about the WOW64 system folder at the Microsoft site: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/sysinfo/base/getsystemwow64directory.asp. Win:6.0
system x32 folder | PlainGlobal | <folder> | Returns a filesystem object corresponding to a 32-bit system folder. On a 32-bit machine, this is equivalent to the normal system folder. Win:6.0
system x64 folder | PlainGlobal | <folder> | Returns a filesystem object corresponding to a 64-bit system folder. This is the same as the system folder, but with file system redirection disabled. For more information about file redirection, see the Microsoft site http://msdn.microsoft.com/library/default.asp?url=/library/en-us/win64/win64/file_system_redirector.asp. Win:6.0
tcp | PlainGlobal | <internet protocol> | Returns an internet protocol corresponding to the Microsoft enumerated type: NET_FW_IP_PROTOCOL_TCP. Win:5.1
terminal bit <operating system suite mask> | Index<operating system suite mask>Global | <boolean> | Returns TRUE if the terminal bit of the Suite Mask (a part of the Windows OS version) is set. Win:6.0
thursday | PlainGlobal | <day of week> | Returns Thursday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
time <string> | NamedGlobal | <time> | Returns a time object for the name provided. See time. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time interval <string> | NamedGlobal | <time interval> | Creates a time interval from the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time zone <string> | NamedGlobal | <time zone> | Returns a time zone object for the name provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time_of_day <string> | NamedGlobal | <time of day> | Creates a time of day object out of the given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
total processor core count | PlainGlobal | <integer> | Returns an integer corresponding to the total number of processor cores. Win:6.0
true | PlainGlobal | <boolean> | Returns the boolean TRUE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
tuesday | PlainGlobal | <day of week> | Returns Tuesday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
udp | PlainGlobal | <internet protocol> | Returns an internet protocol corresponding to the Microsoft enumerated type: NET_FW_IP_PROTOCOL_UDP. Win:5.1
unary operator <string> | NamedGlobal | <unary operator> | Typically used in the plural, this inspector returns a list of objects that use the specified operator. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
unary operator returning <type> | Index<type>Global | <unary operator> | Returns a list of the unary operator inspectors (such as negative) that return the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
universal time <string> | NamedGlobal | <time> | Returns a time object for the name provided. See time. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
universal time zone | PlainGlobal | <time zone> | Returns a time zone object corresponding to the universal time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
upnp firewall service type | PlainGlobal | <firewall service type> | Returns the UPnP (Universal Plug and Play) firewall service type, corresponding to the Microsoft enumerated type: NET_FW_SERVICE_UPNP. • Note: UPnP is not the same as PnP. UPnP is used for network connectivity via TCP/IP to various devices (scanners, printers, etc.). Win:5.1
usb | PlainGlobal | <usb> | The Universal Serial Bus. Mac:4.1
user | PlainGlobal | <user> | Returns objects for all users of the computer, logged in or not. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
user <string> | NamedGlobal | <user> | Returns the user specified by <string>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
user domain | PlainGlobal | <domain> | Returns a user domain object. • NOTE: The "user domain" refers to the root user, not the currently logged in user. Mac:5.1
user language | PlainGlobal | <string> | Returns the language of the system as a string. It is identified by using the GetUserDefaultLangId() system call. See the language keyword of the application object for a list of possible language value. Win:1.2
user locale | PlainGlobal | <language> | Determines which settings are used for formatting dates, times, currency, and numbers as a default for each user. Also determines the sort order for sorting text. Win:4.1
user ui language | PlainGlobal | <language> | Non-MUI: Same as system UI Language. • MUI: Determines the language of menus and dialogs, messages, and help files. Win:4.1
version <string> | NamedGlobal | <version> | Short hand for 'file version'. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
virtual memory | PlainGlobal | <boolean> | Returns TRUE if virtual memory is turned on. Mac:4.1
volume | PlainGlobal | <volume> | An iterated property. Examines all currently mounted volumes which will include the startup volume, CD-ROM, disk images and other removable media and file sharing volumes. Mac:4.1
volume <integer> | NumberedGlobal | <volume> | A numbered property returning the specified volume. Mac:4.1
volume <string> | NamedGlobal | <volume> | A numbered property returning the specified volume. Mac:4.1
wake on lan subnet cidr string | PlainGlobal | <string> | Returns the subnet the client is in for Wake on Lan (WoL) purposes. The client sends information to the relay during registration that is used to decide which subnet the client is in. The relay returns the subnet to the client, which is the value this Inspector exposes. This value is used to send WoL commands to forwarders. To wake a machine by computer ID, the server looks up the mac address and subnet of that machine. It then tries to identify clients that have been configured as WoL forwarders within the same subnet and routes WoL commands to those forwarders, sending them the mac address of the machine that needs to be awoken. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
warning event log event type | PlainGlobal | <event log event type> | Returns an object corresponding to a warning in the event log. Warnings can be used to prevent future system problems. Win:6.0
wednesday | PlainGlobal | <day of week> | Returns Wednesday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
week | PlainGlobal | <time interval> | Returns a time interval corresponding to 1 week. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
windows display time <string> | NamedGlobal | <time> | Returns a string that may match the time shown in the Windows file system. Win:1.2
windows file <string> | NamedGlobal | <file> | Returns a file object corresponding to the relative pathname (within the Windows folder) provided. See file. Win:1.2
windows folder | PlainGlobal | <folder> | Returns a folder object of the Windows folder This is operating system dependent. Under Win98 this is usually c:\Windows. Win:1.2
wmi | PlainGlobal | <wmi> | Returns the wmi object corresponding to the "root\cimv2" namespace. Win:3.0
wmi <string> | NamedGlobal | <wmi> | Returns the wmi object corresponding to the namespace string provided. Win:3.0
x32 application <string> | NamedGlobal | <application> | Returns an object corresponding to the 32-bit application specified by <string>. Win:6.0
x32 file <string> | NamedGlobal | <file> | Returns an object corresponding to a 32 bit file with name specified by <string>. Win:6.0
x32 folder <string> | NamedGlobal | <folder> | Returns a filesystem object corresponding to a 32-bit folder. Win:6.0
x32 registry | PlainGlobal | <registry> | Returns a 32-bit registry object. This Inspector is equivalent to the ordinary registry Inspector. Win:6.0
x64 application <string> | NamedGlobal | <application> | Returns an object corresponding to the 64-bit application specified by <string>. On a 32-bit computer, this is equivalent to a normal application Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. Win:6.0
x64 file <string> | NamedGlobal | <file> | Returns an object corresponding to a 64 bit file with pathname specified by <string>. On a 32-bit computer, this is equivalent to a normal file Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. Win:6.0
x64 folder <string> | NamedGlobal | <folder> | Returns a filesystem object corresponding to a 64-bit folder with the given pathname. On a 32-bit computer, this is equivalent to a normal folder Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. This action is transitive: any resulting filesystem objects will also have redirection disabled. For example, "pathnames of files of x64 folder <path>" will disable redirection when locating the folder, iterating over the files in the folder and calculating pathnames. Win:6.0
x64 registry | PlainGlobal | <registry> | Returns a 64-bit registry object. This Inspector is for 64-bit computers only; there is no 64-bit registry on a 32-bit computer. • Note that "x64 registry" and "native registry" on 64-bit machines do NOT provide the same view as the 64-bit version of regedit (the "physical" view). If you try to access the physical location of the 32-bit view keys using a 64-bit view, it will be mapped back to the equivalent location in the 64-bit view. Win:6.0
year | PlainGlobal | <number of months> | Returns the specified number of years as a <number of months> type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year <integer> | NumberedGlobal | <year> | Creates a year object from the specified integer. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year <string> | NamedGlobal | <year> | Creates a year object from the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
zoned time_of_day <string> | NamedGlobal | <time of day with time zone> | Returns a 'time of day with time zone' object from the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Examples

bit 0 of 5
Returns TRUE.

bit set "101" as integer
Returns 5.

bundle "com.apple.BigFixEnterprise"
Returns a bundle to hand to something that needs one. It doesn't print out, per se.

capability "libxml2 >= 2.4.7"
Returns a capability named "libxml2 >= 2.4.7".

name of computer
Returns the name of the computer, e.g. "MacBES".

exists (country "verChina")
Returns TRUE if there exists a Chinese script string.

cpu speed > 2000000000
Returns TRUE if the CPU speed is greater than two gigahertz.

name of default web browser as lowercase = "iexplorer.exe"
Returns TRUE if Internet Explorer is the default browser on the client machine.

wait "{pathname of download file "update.exe"}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

wait "{pathname of file "update.exe" of download folder}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

wait "{download path"update.exe"}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

names of drives
Returns a list of drives, eg., C:, D:, etc.

drives
Returns a list of drives, eg., /, /Users/MyUserName, etc.

if FALSE then 1 else error "my error message"
Returns the string: User-defined error: my error message.

names of filesystems
Returns the names of the mounted file systems.

filesystems
Returns a list of filesystems, eg., /, /Users/MyUserName, etc.

floating point (floating point "5.2")
Returns a floating point object of 5.3.

gestalt "ram" > 33554432
Returns TRUE if the installed RAM is greater than the amount specified.

hexadecimal integer "A0"
Returns 160.

host name
Returns a string like "localhost.localdomain" or "user.bigcorp".

html tag ("i", "italic text")
Returns <i>italic text</i>.

html tag ( "p", attr list of ( ( "class", "myclass"); ( "align", "left" ) ), html "html <i>snippet</i>" )
Returns <p class="myclass" align="left">html <i>snippet</i></p>.

html tag ( "p", attr list of ( ( "class", "myclass"); ( "align", "left" ) ), "formatted text" )
Returns <p class="myclass" align="left">formatted text</p>.

html tag ( "b", "bold text" )
Returns <b>bold text</b>.

model
Returns a string such as "9000/785/c3000".

physical ram > 33554432
Returns TRUE if there is more than the specified amount of RAM.

names of packages of rpm
Returns a list of all the software packages in the RPM database on this computer.

exists scsidevices whose (vendor of it is "Apple") of scsibuses
Returns TRUE if an Apple SCSI device exists on the SCSI bus.

exists scsidevice whose (vendor of it is "Apple") of scsibus 1
Here the scsibus is specified and the scsidevice is iterated over vendors.

exists software depot
Returns TRUE if the software depot exists on this computer.


Casting Operators

The casting operators allow you to convert one type to another. This is a list of the casting operators sorted by key phrase.

Key Phrase | Creates a | From a
<action lock state> as string | <string> | <action lock state>
<binary operator> as string | <string> | <binary operator>
<bios> as string | <string> | <bios>
<bit set> as integer | <integer> | <bit set>
<bit set> as string | <string> | <bit set>
<boolean> as boolean | <boolean> | <boolean>
<boolean> as string | <string> | <boolean>
<capability> as string | <string> | <capability>
<cast> as string | <string> | <cast>
<client process owner> as string | <string> | <client process owner>
<date> as string | <string> | <date>
<day of month> as integer | <integer> | <day of month>
<day of month> as string | <string> | <day of month>
<day of month> as two digits | <string> | <day of month>
<day of week> as string | <string> | <day of week>
<day of week> as three letters | <string> | <day of week>
<day of year> as string | <string> | <day of year>
<discretionary access control list> as string | <string> | <discretionary access control list>
<environment variable> as string | <string> | <environment variable>
<file content> as lowercase | <file content> | <file content>
<file content> as uppercase | <file content> | <file content>
<file> as string | <string> | <file>
<fileset> as string | <string> | <fileset>
<filesystem object> as file | <file> | <filesystem object>
<filesystem object> as folder | <folder> | <filesystem object>
<filesystem object> as string | <string> | <filesystem object>
<filesystem object> as symlink | <symlink> | <filesystem object>
<floating point> as floating point | <floating point> | <floating point>
<floating point> as integer | <integer> | <floating point>
<floating point> as scientific notation | <string> | <floating point>
<floating point> as standard notation | <string> | <floating point>
<floating point> as string | <string> | <floating point>
<folder> as string | <string> | <folder>
<hertz> as string | <string> | <hertz>
<html> as html | <html> | <html>
<html> as string | <string> | <html>
<integer> as bit set | <bit set> | <integer>
<integer> as bits | <bit set> | <integer>
<integer> as day_of_month | <day of month> | <integer>
<integer> as floating point | <floating point> | <integer>
<integer> as hexadecimal | <string> | <integer>
<integer> as integer | <integer> | <integer>
<integer> as month | <month> | <integer>
<integer> as string | <string> | <integer>
<integer> as year | <year> | <integer>
<ip address> as string | <string> | <ip address>
<ipv4 address> as ipv6 address | <ipv6 address> | <ipv4 address>
<ipv4 address> as string | <string> | <ipv4 address>
<ipv6 address> as compressed string | <string> | <ipv6 address>
<ipv6 address> as compressed string with ipv4 | <string> | <ipv6 address>
<ipv6 address> as string | <string> | <ipv6 address>
<ipv6 address> as string with ipv4 | <string> | <ipv6 address>
<ipv6 address> as string with leading zeros | <string> | <ipv6 address>
<language> as string | <string> | <language>
<local group member> as string | <string> | <local group member>
<logical volume> as string | <string> | <logical volume>
<metabase identifier> as integer | <integer> | <metabase identifier>
<metabase identifier> as string | <string> | <metabase identifier>
<metabase type> as integer | <integer> | <metabase type>
<metabase type> as string | <string> | <metabase type>
<metabase user type> as integer | <integer> | <metabase user type>
<metabase user type> as string | <string> | <metabase user type>
<metabase value> as integer | <integer> | <metabase value>
<metabase value> as string | <string> | <metabase value>
<mode_mask> as integer | <integer> | <mode_mask>
<mode_mask> as string | <string> | <mode_mask>
<mode> as octal string | <string> | <mode>
<mode> as string | <string> | <mode>
<month and year> as string | <string> | <month and year>
<month> as integer | <integer> | <month>
<month> as string | <string> | <month>
<month> as three letters | <string> | <month>
<month> as two digits | <string> | <month>
<number of months> as string | <string> | <number of months>
<operating system> as string | <string> | <operating system>
<package> as string | <string> | <package>
<pkginfo> as string | <string> | <pkginfo>
<primary language> as string | <string> | <primary language>
<product> as string | <string> | <product>
<property> as string | <string> | <property>
<registry key value type> as string | <string> | <registry key value type>
<registry key value> as application | <application> | <registry key value>
<registry key value> as file | <file> | <registry key value>
<registry key value> as folder | <folder> | <registry key value>
<registry key value> as integer | <integer> | <registry key value>
<registry key value> as string | <string> | <registry key value>
<registry key value> as system file | <file> | <registry key value>
<registry key value> as time | <time> | <registry key value>
<rope> as string | <string> | <rope>
<runlevel> as string | <string> | <runlevel>
<security descriptor> as string | <string> | <security descriptor>
<security identifier> as string | <string> | <security identifier>
<service> as string | <string> | <service>
<setting> as string | <string> | <setting>
<site version list> as string | <string> | <site version list>
<stage> as string | <string> | <stage>
<string> as boolean | <boolean> | <string>
<string> as date | <date> | <string>
<string> as day_of_month | <day of month> | <string>
<string> as day_of_week | <day of week> | <string>
<string> as floating point | <floating point> | <string>
<string> as hexadecimal | <string> | <string>
<string> as html | <html> | <string>
<string> as integer | <integer> | <string>
<string> as ipv6 address | <ipv6 address> | <string>
<string> as left trimmed string | <string> | <string>
<string> as local time | <time> | <string>
<string> as local zoned time_of_day | <time of day with time zone> | <string>
<string> as lowercase | <string> | <string>
<string> as month | <month> | <string>
<string> as right trimmed string | <string> | <string>
<string> as site version list | <site version list> | <string>
<string> as string | <string> | <string>
<string> as strverscmp version | <strverscmp version> | <string>
<string> as time | <time> | <string>
<string> as time interval | <time interval> | <string>
<string> as time zone | <time zone> | <string>
<string> as time_of_day | <time of day> | <string>
<string> as trimmed string | <string> | <string>
<string> as universal time | <time> | <string>
<string> as universal zoned time_of_day | <time of day with time zone> | <string>
<string> as uppercase | <string> | <string>
<string> as version | <version> | <string>
<string> as windows display time | <time> | <string>
<string> as year | <year> | <string>
<string> as zoned time_of_day | <time of day with time zone> | <string>
<symlink> as file | <file> | <symlink>
<symlink> as folder | <folder> | <symlink>
<symlink> as string | <string> | <symlink>
<symlink> as symlink | <symlink> | <symlink>
<system access control list> as string | <string> | <system access control list>
<time interval> as string | <string> | <time interval>
<time of day with time zone> as string | <string> | <time of day with time zone>
<time of day> as string | <string> | <time of day>
<time range> as string | <string> | <time range>
<time zone> as string | <string> | <time zone>
<time> as local string | <string> | <time>
<time> as string | <string> | <time>
<time> as universal string | <string> | <time>
<type> as string | <string> | <type>
<unary operator> as string | <string> | <unary operator>
<user attribute> as string | <string> | <user attribute>
<version> as string | <string> | <version>
<version> as version | <version> | <version>
<volume group> as string | <string> | <volume group>
<wmi object> as string | <string> | <wmi object>
<wmi select> as string | <string> | <wmi select>
<xml dom node> as text | <string> | <xml dom node>
<xml dom node> as xml | <string> | <xml dom node>
<year> as integer | <integer> | <year>
<year> as string | <string> | <year>


Access Control Entry

An Access Control Entity, or ACE, is an entry in an access control list (ACL). An ACE contains a set of access rights and a security identifier (SID) that identifies a trustee for whom the rights are allowed, denied, or audited.

Creation Methods

Key Phrase | Form | Description
entry of <access control list> | Plain | Iterates the ACEs of an ACL. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
access mode of <access control entry> | Plain | <integer> | For a discretionary ACL (DACL), this flag indicates whether the ACL allows (1) or denies (3) the specified access rights. Win:4.1
append permission of <access control entry> | Plain | <boolean> | For a file ACE, returns TRUE if the ACE grants or denies append permissions. Win:4.1
change notification permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or denies change notification permissions. Win:4.1
create file permission of <access control entry> | Plain | <boolean> | For a folder ACE, returns TRUE if the ACE grants or denies create file permissions. Win:4.1
create folder permission of <access control entry> | Plain | <boolean> | For a folder ACE, returns TRUE if the ACE grants or denies create folder permissions. Win:4.1
create link permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or denies create key link permissions. Win:4.1
create subkey permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or denies creation of subkey permissions. Win:4.1
delete child permission of <access control entry> | Plain | <boolean> | For a folder ACE, returns TRUE if the ACE grants or denies child deletion permissions. Win:4.1
delete permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or generic delete permissions. Win:4.1
enumerate subkeys permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or enumerate subkey permissions. Win:4.1
execute permission of <access control entry> | Plain | <boolean> | For a file ACE, returns TRUE if the ACE grants or denies execute permissions. Win:4.1
generic all permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies all generic permissions. Win:4.1
generic execute permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies generic execute permissions. Win:4.1
generic read permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies generic read permissions. Win:4.1
generic write permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies generic write permissions. Win:4.1
inheritance of <access control entry> | Plain | <integer> | A set of bit flags that determines whether other containers or objects can inherit the ACE from the primary object to which the ACL is attached. The actual values of the constants are: • NO_INHERITANCE = 0 • SUB_OBJECTS_ONLY_INHERIT = 1 • SUB_CONTAINERS_ONLY_INHERIT = 2 • SUB_CONTAINERS_AND_OBJECTS_INHERIT = 3 • OJECT_INHERIT_ACE = 1 • CONTAINER_INHERIT_ACE = 2 • NO_PROPAGATE_INHERIT_ACE = 4 • INHERIT_ONLY_ACE = 8. Win:4.1
list permission of <access control entry> | Plain | <boolean> | For a folder ACE, returns TRUE if the ACE grants or denies list permissions. Win:4.1
maximum allowed permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies maximum allowed permissions. Win:4.1
query value permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or denies query value permissions. Win:4.1
read attributes permission of <access control entry> | Plain | <boolean> | For a file or folder ACE, returns TRUE if the ACE grants or denies read attributes permissions. Win:4.1
read control permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies reading access control permissions. Win:4.1
read extended attributes permission of <access control entry> | Plain | <boolean> | For a file or folder ACE, returns TRUE if the ACE grants or denies read extended attributes permissions. Win:4.1
read permission of <access control entry> | Plain | <boolean> | For a file ACE, returns TRUE if the ACE grants or denies read permissions. Win:4.1
set value permission of <access control entry> | Plain | <boolean> | For a registry key ACE, returns TRUE if the ACE grants or denies set value permissions. Win:4.1
synchronize permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies synchronize permissions. Win:4.1
traverse permission of <access control entry> | Plain | <boolean> | For the specified folder ACE, returns TRUE if it grants or denies traverse • folder permission. Win:4.1
trustee of <access control entry> | Plain | <security identifier> | Returns the trustee to whom the specified ACE applies. Win:4.1
trustee type of <access control entry> | Plain | <integer> | Returns the type of trustee to whom the specified ACE applies. Win:4.1
write attributes permission of <access control entry> | Plain | <boolean> | For a file or folder ACE, returns TRUE if the ACE grants or denies write attribute permissions. Win:4.1
write dac permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies write DAC permissions. Win:4.1
write extended attributes permission of <access control entry> | Plain | <boolean> | For a file or folder ACE, returns TRUE if the ACE grants or denies write extended attribute permissions. Win:4.1
write owner permission of <access control entry> | Plain | <boolean> | For any ACE, returns TRUE if the ACE grants or denies write owner permissions. Win:4.1
write permission of <access control entry> | Plain | <boolean> | For a file ACE, returns TRUE if the ACE grants or denies write permissions. Win:4.1


Access Control List

An Access Control List, or ACL, is a list of security protections that applies to an object. An object can be a file, process, event, or anything else having a security descriptor. An entry in an access control list (ACL) is an access control entry (ACE). Access rights run up through the object hierarchy, so rights granted at a low level can be vetoed by rights higher up. Some of the following Inspectors determine the effective permissions for a given trustee by traversing the hierarchy. They work by exposing the GetEffectiveRightsFromAcl method, as explained here: http://tinyurl.com/dtmje.

Creation Methods

Key Phrase | Form | Description
dacl of <security descriptor> | Plain | Returns the discretionary access control list associated with the given security descriptor. Win:4.1

Note

Requires Windows XP, Windows 2000 Professional, or Windows NT Workstation 3.1 and later.

Properties

Key Phrase | Form | Return Type | Description
effective access mode for <string> of <access control list> | Named | <integer> | Returns an integer corresponding to the access mode for the trustee specified by <string> of the given access control list. Win:6.0
effective access system security permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has access system security permissions on the given access control list. Win:6.0
effective append permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has append permissions on the given access control list. Win:6.0
effective change notification permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has change notification permissions on the given access control list. Win:6.0
effective create file permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has file creation permissions on the given access control list. Win:6.0
effective create folder permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has folder creation permissions on the given access control list. Win:6.0
effective create link permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has link creation permissions on the given access control list. Win:6.0
effective create subkey permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has subkey creation permissions on the given access control list. Win:6.0
effective delete child permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has child deletion permissions on the given access control list. Win:6.0
effective delete permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has delete permissions on the given access control list. Win:6.0
effective enumerate subkeys permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has subkey enumeration permissions on the given access control list. Win:6.0
effective execute permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has execution permissions on the given access control list. Win:6.0
effective generic all permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has all generic permissions on the given access control list. Win:6.0
effective generic execute permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has generic execution permissions on the given access control list. Win:6.0
effective generic read permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has generic read permissions on the given access control list. Win:6.0
effective generic write permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has generic write permissions on the given access control list. Win:6.0
effective list permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has list permissions on the given access control list. Win:6.0
effective maximum allowed permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has maximum allowed permissions on the given access control list. Win:6.0
effective query value permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has query value permissions on the given access control list. Win:6.0
effective read attributes permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has read attribute permissions on the given access control list. Win:6.0
effective read control permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has read control permissions on the given access control list. Win:6.0
effective read extended attributes permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has extended read attribute permissions on the given access control list. Win:6.0
effective read permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has read permissions on the given access control list. Win:6.0
effective set value permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has value setting permissions on the given access control list. Win:6.0
effective synchronize permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has synchronization permissions on the given access control list. Win:6.0
effective traverse permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has traverse permissions on the given access control list. Win:6.0
effective write attributes permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has attribute writing permissions on the given access control list. Win:6.0
effective write dac permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has dac writing permissions on the given access control list. Win:6.0
effective write extended attributes permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has extended attribute writing permissions on the given access control list. Win:6.0
effective write owner permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has write owner permissions on the given access control list. Win:6.0
effective write permission for <string> of <access control list> | Named | <boolean> | Returns TRUE if the trustee specified by <string> has write permissions on the given access control list. Win:6.0
entry of <access control list> | Plain | <access control entry> | Iterates the ACEs of a ACL. Win:4.1

Note

The ACCESS_MASK is returned from the effective access mode as a double word defining standard, specific, and generic rights. These rights are used in access control entries (ACEs) and are the primary means of determining access to an object.

Bits | Meaning
0 through 15 | Specific rights. Contains the access mask specific to the object type associated with the mask.
16 through 23 | Contains the object's standard access rights.
24 | The Access system security bit is used to indicate access to a system access control list (SACL). If this flag is set in the access mask of an audit access ACE (successful or unsuccessful access), the SACL access will be audited.
25 | Maximum allowed.
26 through 27 | Reserved.
28 | Generic all.
29 | Generic execute.
30 | Generic write.
31 | Generic read.

The standard rights bits from 16 to 23 contain the object's standard access rights and can be a combination of the following predefined flags:
Bit | Flag | Meaning
16 | DELETE | Delete access.
17 | READ_CONTROL | Read access to the owner, group, and discretionary access control list (DACL) of the security descriptor.
18 | WRITE_DAC | Write access to the DACL.
19 | WRITE_OWNER | Write access to owner.
20 | SYNCHRONIZE | Synchronize access.


Action

These are the keywords associated with properties available for inspection during the execution of BigFix Actions.

Creation Methods

Key Phrase | Form | Description
action | PlainGlobal | Creates an action object corresponding to the BigFix Action currently being parsed. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
action <integer> | NumberedGlobal | Creates an action object matching the <integer> id. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
active action | PlainGlobal | Creates an action object corresponding to the currently executing action. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
active of <action> | Plain | <boolean> | Returns TRUE if the action is currently running (active). Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
active start time of <action> | Plain | <time> | Returns the time the action started. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
complete time of <action> | Plain | <time> | Returns the time the action completed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
constrained of <action> | Plain | <boolean> | Returns TRUE if action is unable to run yet. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
group leader of <action> | Plain | <boolean> | Returns TRUE if the action is a group action and the action component is the group leader. When you deploy a mult-action from the BES Console, it constructs a group action with a group leader to control the overall behavior of the action. This inspector is used internally to manage the progress of the group action. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
id of <action> | Plain | <integer> | Returns the numeric ID associated with the specified Action. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
last change time of <action> | Plain | <time> | Returns the time when the action state last changed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
offer accepted of <action> | Plain | <boolean> | Returns TRUE when users indicated they want to run the action by accepting the offer presented by the BES Client UI. When an offer has been accepted, the Client evaluates its constraints and runs as soon as conditions allow. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
offer of <action> | Plain | <boolean> | Returns TRUE when the Action is presented as an offer (as indicated by the header "x-offer: 1"). Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
origin fixlet id of <action> | Plain | <integer> | Returns the Fixlet id that contained the action. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
parameter <string> of <action> | Named | <string> | Returns the value of parameter <string> for the active action. Parameters only live as long as the action is active. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
pending login of <action> | Plain | <boolean> | Returns TRUE if the specified action included an 'action requires login' command, and a login has not yet occurred since the action has run. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
pending of <action> | Plain | <boolean> | Returns TRUE if action is available to run. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
pending restart of <action> | Plain | <boolean> | Returns TRUE if the specified action included an 'action requires restart' command and a restart has not occurred since the action has run. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
pending time of <action> | Plain | <time> | Returns the time the action became pending. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
status of <action> | Plain | <string> | Returns one of the following strings: • Running = when the action is currently active. • Executed = no longer relevant and action has completed. • Not Relevant = action was not relevant. • Waiting = action is relevant, but waiting to run. • Not Executed = action is relevant, unconstrained, but has not yet started. • Failed = action is relevant, unconstrained, has completed, but is still relevant. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
waiting for download of <action> | Plain | <boolean> | Returns TRUE if client is waiting for mirroring server to have downloads required by the action. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1


Active Device

On Windows NT systems (including XP and 2K), these Inspectors returns a set of objects corresponding to the active devices on the machine, e.g., modems, graphics cards, printers, etc.

Creation Methods

Key Phrase | Form | Description
active device | PlainGlobal | Creates a list of all active devices found using the Configuration Manager SetupDiGetClassDevs NT API. The locations of active devices are relative to the Windows Directory. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
class of <active device> | Plain | <string> | Returns the name of the class of the active device provided. Win:1.2
description of <active device> | Plain | <string> | Returns the description of the active device provided. Win:1.2
driver key of <active device> | Plain | <registry key> | The key identified by adding the value of 'driver key value name of active device' to HKLM\System\CurrentControlSet\Control\Class\. Win:1.2
driver key value name of <active device> | Plain | <string> | Returns the driver key value name of the active device provided. Win:1.2
friendly name of <active device> | Plain | <string> | Returns the friendly name of the active device. Win:1.2
hardware id of <active device> | Plain | <string> | Returns the hardware id of the active device provided. Win:1.2
location information of <active device> | Plain | <string> | Returns a string containing information about the bus location of the device. Win:1.2
manufacturer of <active device> | Plain | <string> | Returns the manufactures string of the active device. Win:1.2
problem id of <active device> | Plain | <integer> | Configuration manager defined number describing device installation or use problems. Returned by call to CM_Get_DevInst_Status. Win:1.2
service key value name of <active device> | Plain | <string> | Returns the service key value name. Win:1.2
status of <active device> | Plain | <integer> | Configuration manager defined status bits conveying device driver status. Win:1.2

Examples

number of active devices
Returns the number of active devices as determined by the Configuration Manager.

exists active device file "system32\ntoskrnl.exe"
Returns TRUE if ntoskrnl.exe exists in the System32 folder of the Windows folder.

exists active device file "C:\WINNT\System32\ntoskrnl.exe"
Returns FALSE because this Inspector path is relative to the Windows directory.

exists active device whose (class of it = "Display")
Returns TRUE if there is an active device named "Display".

(description of it) of active devices whose ( class of it ="Display")
Provides a list of the descriptions of the active display devices.

exists service key value name whose (it = "PGPdisk" ) of active devices
Returns TRUE if the designated service key value name exists on this system.


Active Directory Local Computer

These are the Active Directory Inspectors for the local computer.

Creation Methods

Key Phrase | Form | Description
local computer of <active directory server> | Plain | Represents your computer within the Active Directory. Win:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
distinguished name error message of <active directory local computer> | Plain | <string> | Active Directory error if unable to get the distinguished name (this is for debugging purposes). Win:4.1, Mac:5.1
distinguished name of <active directory local computer> | Plain | <string> | Returns the computer's fully qualified active directory name in the distinguished name format, for instance, 'CN=ALBATROSS, CN=Computers, DC=bigfix, DC=com'. Win:4.1, Mac:5.1

Examples

distinguished name of local computer of active directory
Returns CN=mymachinename,CN=Computers,DC=bigfix,DC=com.


Active Directory Server

These are the Active Directory Server Inspectors.

Creation Methods

Key Phrase | Form | Description
active directory | PlainGlobal | Returns an object containing the properties of the Active Directory to which your machine is attached. Win:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
local computer of <active directory server> | Plain | <active directory local computer> | Represents your computer within the Active Directory. Win:4.1, Mac:5.1


Administrator

These inspect the BES administrators authorized to adminster the client.

Creation Methods

Properties

Key Phrase | Form | Return Type | Description
name of <administrator> | Plain | <string> | The administrator(s) authorized to send actions to the agent. Mac:4.1


Application

Application objects derive from file objects. Therefore, application objects inherit all of the properties of the file object. This means that you can inspect properties such as 'modification time' or 'Product Version' of an application just as you would a file. See the properties of a file object for a complete list of these. The real power and primary purpose of the application object is their creation. The creation methods are optimized in anticipation of the importance of this object.

Creation Methods

Key Phrase | Form | Description
<registry key value> as application | Cast | If the value is of type string, and the string is a full pathname to an executable that exists on disk, an application object is created. Win:1.2
application <string> | NamedGlobal | Creates an application object for the name provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
application <string> of <folder> | Named | As with the file object, you can create an application object by naming it relative to its parent folder. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
application <string> of <registry key> | Named | Creates the application object associated with the named command. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file type. Win:1.2
application <string> of <registry> | Named | Creates the application object associated with the name provided. The name provided must be the name of a sub-key of the 'App Paths' registry key. See notes. Win:1.2
application of <registry key> | Plain | Creates the application object associated with the "open" command. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file extension. Win:1.2
application of <registry> | Plain | Iterates through the 'App Paths' registry key creating objects for the applications that exist. See notes. Win:1.2
default web browser | PlainGlobal | Returns the application object (typically the web browser) associated with HTML documents. Win:3.0
recent application | PlainGlobal | Iterates through the list of recently executed applications, creating application objects. This includes the list of all currently running applications. Win:1.2, Lin:6.0
recent application <string> | NamedGlobal | If named application has been executed recently, this inspector creates an application object. Only specify the last component of the filename. Win:1.2, Lin:6.0
regapp | PlainGlobal | Iterates through the applications of the registry. The applications will be those associated with the sub-keys of the 'App Paths' registry key. See notes. Win:1.2
regapp <string> | NamedGlobal | Returns an application object for the name provided. See application and regapp. Win:1.2
running application | PlainGlobal | Iterates through the list of running applications. Win:1.2, Lin:6.0
running application <string> | NamedGlobal | If the named application is currently executing then this inspector creates an application object. Only specify the last component of the file name. Win:1.2, Lin:6.0
x32 application <string> | NamedGlobal | Returns an object corresponding to the 32-bit application specified by <string>. Win:6.0
x64 application <string> | NamedGlobal | Returns an object corresponding to the 64-bit application specified by <string>. On a 32-bit computer, this is equivalent to a normal application Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. Win:6.0

Note

See ‘File’ for a list of the Application properties. Folder and file names may be case sensitive. Use “as uppercase” or “as lowercase” if you don’t know the actual case when making comparisons. For Windows versions of these Inspectors, a properly installed application will register itself with the operating system. It does this by creating a registry sub-key usually named after the executable. The regapp Inspector uses the default value of this sub-key as a string that is the full pathname of the executable.

Examples

exists application "notepad.exe" of the windows folder
Using the application of folder creation method, this example locates the notepad application provided it exists in the Windows folder.

name of application "print" of key "HKEY_CLASSES_ROOT\.gif" of registry
Returns the name of the application currently responsible for printing gif files.

name of application "print" of key "HKEY_CLASSES_ROOT\giffile" of the registry
The same as above when the default value of the key HKEY_CLASSES_ROOT\.gif contains giffile. These two examples demonstrate the method used by Windows to maintain file associations in the registry.

application of key "HKEY_CLASSES_ROOT\mailto" of the registry
This example returns the application responsible for handling mailto requests in your web browser.

names of regapps
Primarily used in QnA to obtain lists of applications installed under the "app path" key of the registry.

byte 0 of regapp "bigfix.exe" = 77
TRUE if the first byte in the specified file is ASCII 77.

regapp "IEXPLORE.EXE"
Returns the application object associated with the named registry key. Checks to see if the executable exists and if so, returns the application object. Case is ignored.

exists running application whose (name of it as lowercase is "winword.exe")
Returns TRUE if Microsoft Word is currently executing.


Application Usage Summary

To enable these Inspectors, you first need to create the client setting _BESClient_UsageManager_EnableAppUsageSummary and initialize it to 1. You can also limit the summary to a subset of applications by creating _BESClient_UsageManager_EnableAppUsageSummaryApps and initializing it to a list of apps to include (or exclude). The value of this setting should look like +:app1:app2:app3: to add apps to the scope, and -:app1:app2: to exclude apps. The case is ignored. For instance, to enable summaries on the Word application, use the value +:winword.exe:.

Creation Methods

Key Phrase | Form | Description
application usage summary | PlainGlobal | Returns an application usage summary containing information including the start time, duration and other statistics on client applications. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
application usage summary <string> | NamedGlobal | Returns the usage summary for the application specified in <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
first start time of <application usage summary> | Plain | <time> | Returns the start time of the specified application since the computer was configured to track it, regardless of reboots. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
last start time of <application usage summary> | Plain | <time> | Returns the last time this specified application was started. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
last time seen of <application usage summary> | Plain | <time> | Returns the last time this specified application was seen running. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
name of <application usage summary> | Plain | <string> | Returns the names of the applications that are currently enabled for usage summaries. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
running of <application usage summary> | Plain | <boolean> | Returns TRUE if the specified application is currently running. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
total duration of <application usage summary> | Plain | <time interval> | Returns the total elapsed time that the specified application has been running. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
total run count of <application usage summary> | Plain | <integer> | Returns the number of times that the specified application has been run since the client was configured to track it. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Array

These Inspectors return a list of values in a dictionary array.

Creation Methods

Key Phrase | Form | Description
array <integer> of <array> | Numbered | An array from an array by index. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
array <integer> of <array> | Numbered | <array> | An array from an array by index. Mac:4.1
boolean <integer> of <array> | Numbered | <boolean> | Get, from an array, a boolean keyed by the specified integer. Mac:4.1
date <integer> of <array> | Numbered | <time> | Get, from an array, a date keyed by the specified integer. Mac:4.1
dictionary <integer> of <array> | Numbered | <dictionary> | Get, from an array, a dictionary keyed by the specified integer. Mac:4.1
integer <integer> of <array> | Numbered | <integer> | Get, from an array, an integer keyed by the specified integer. Mac:4.1
size of <array> | Plain | <integer> | Returns the number of unique elements in the given array. Mac:4.1
string <integer> of <array> | Numbered | <string> | Get, from an array, a string keyed by the specified integer. Mac:4.1
value of <array> | Plain | <osxvalue> | Values of the array. Mac:4.1

Examples

strings of values of array 0 of array "com.apple.iTunes" of dictionary of file "com.apple.help.plist" of preferences folder
Returns any values of type string from the array, e.g. iTunes Help or file://localhost/Applications/iTunes.app/Contents/Resources/English.lproj/iTunes.Help/.

boolean 1 of array "NSTableView Sort Ordering NSNavOutlineColumnSettings.v1" of preference "com.apple.Console"
Returns the first boolean value in the array.

size of array "persistent-apps" of preference "com.apple.dock"
Returns the number of unique elements in the specified array.

string 0 of array "RecentSearchStrings" of preference "com.apple.safari"
Returns the most recent search string.


Audit Policy

The audit policy inspectors return the policies put in place for recording information about security-related operations on the client computer. For example, you can set a policy to monitor the modification of files. This will trigger an audit entry showing whenever a file is modified, the associated user account, and the date and time of the action. You can audit both successful and failed attempts at actions. Often, the failed attempts are more interesting, as they may indicate attempts to unsuccessfully subvert a policy. For instance, a successful login is not as interesting as a repeated failure might be.

Creation Methods

Key Phrase | Form | Description
audit policy | PlainGlobal | Windows Vista (and later versions of Windows) allows a finer granularity with audit policies by using subcategories. Setting audit policy at the category level overrides the new subcategory feature. A new registry key introduced in Vista is used to manage subcategories without requiring a change to Group Policy. This registry can be set to prevent the application of category-level audit policy from both Group Policy and the Local Security Policy admin tool. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
account logon category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Account Logon category of the audit policy. Win:7.2
account management category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Account Management category of the audit policy. Win:7.2
category of <audit policy> | Plain | <audit policy category> | Returns the categories of the specified audit policy. Win:7.2
detailed tracking category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Detailed Tracking category of the specified audit policy. Win:7.2
ds access category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the DS Access category of the audit policy. Win:7.2
logon logoff category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Logon/Logoff category of the audit policy. Win:7.2
object access category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Object Access category of the audit policy. Win:7.2
policy change category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Policy Change category of the audit policy. Win:7.2
privilege use category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the Privilege Use category of the audit policy. Win:7.2
system category of <audit policy> | Plain | <audit policy category> | Returns an object corresponding to the System category of the audit policy. Win:7.2


Audit Policy Category

Windows audit policies, as of Vista and later, are divided into categories. Currently there are 9 categories, including System, Logon/Logoff, Object Access, Privilege Use, Detailed Tracking, Policy Change, Account Management, DS Access and Account Logon.

Creation Methods

Key Phrase | Form | Description
account logon category of <audit policy> | Plain | Returns an object corresponding to the Account Logon category of the audit policy. Win:7.2
account management category of <audit policy> | Plain | Returns an object corresponding to the Account Management category of the audit policy. Win:7.2
category of <audit policy> | Plain | Returns the categories of the specified audit policy. Win:7.2
detailed tracking category of <audit policy> | Plain | Returns an object corresponding to the Detailed Tracking category of the specified audit policy. Win:7.2
ds access category of <audit policy> | Plain | Returns an object corresponding to the DS Access category of the audit policy. Win:7.2
logon logoff category of <audit policy> | Plain | Returns an object corresponding to the Logon/Logoff category of the audit policy. Win:7.2
object access category of <audit policy> | Plain | Returns an object corresponding to the Object Access category of the audit policy. Win:7.2
policy change category of <audit policy> | Plain | Returns an object corresponding to the Policy Change category of the audit policy. Win:7.2
privilege use category of <audit policy> | Plain | Returns an object corresponding to the Privilege Use category of the audit policy. Win:7.2
system category of <audit policy> | Plain | Returns an object corresponding to the System category of the audit policy. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
name of <audit policy category> | Plain | <string> | Returns the name of the specified audit policy category. Win:7.2
subcategory of <audit policy category> | Plain | <audit policy subcategory> | Returns the subcategory for the specified audit policy category. Win:7.2


Audit Policy Information

These Inspectors return the two attributes of the audit policy for a given subcategory: whether or not succesful operations will be audited ("audit success"), and whether or not unsuccessful operations will be audited ("audit failure").

Creation Methods

Key Phrase | Form | Description
effective policy <security account> of <audit policy subcategory> | Index<security account> | Returns the effective audit policy for the specified subcategory for the given security account. The effective audit policy is determined by combining the system audit policy with per-user policy. Win:7.2
per user policy <security account> of <audit policy subcategory> | Index<security account> | Returns the per-user audit policy information for the given audit-policy subcategory and the specified security account. Win:7.2
system policy of <audit policy subcategory> | Plain | Returns the audit policy information (audit success or audit failure) corresponding to the specified audit policy subcategory. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
audit failure of <audit policy information> | Plain | <boolean> | Returns the boolean audit failure status of the specified audit policy information. Win:7.2
audit success of <audit policy information> | Plain | <boolean> | Returns the boolean audit success status of the specified audit policy information. Win:7.2


Audit Policy Subcategory

Windows audit policy categories, as of Vista and later, are divided into about 50 subcategories. This level of granularity is designed to narrow in on specific security-related operations on the client computer, helping to filter out the normal noise of an active environment.

Creation Methods

Key Phrase | Form | Description
subcategory of <audit policy category> | Plain | Returns a list of the subcategories for the specified audit policy category. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
effective policy <security account> of <audit policy subcategory> | Index<security account> | <audit policy information> | Returns the effective audit policy information for the specified subcategory for the given security account. The effective audit policy is determined by combining the system audit policy with per-user policy. Win:7.2
name of <audit policy subcategory> | Plain | <string> | Returns the name of the specified audit policy subcategory. Win:7.2
per user policy <security account> of <audit policy subcategory> | Index<security account> | <audit policy information> | Returns the per-user audit policy information for the given audit-policy subcategory and the specified security account. Win:7.2
system policy of <audit policy subcategory> | Plain | <audit policy information> | Returns the audit policy information (audit success or audit failure) corresponding to the specified audit policy subcategory. Win:7.2


Binary Operator

Some Inspectors look at the Relevance language itself, inspecting the Inspectors, so to speak. There are several aspects to view, including the types, properties, casts and operators. This group of Inspectors looks at the various binary operators available from the Relevance language.

Creation Methods

Key Phrase | Form | Description
binary operator | PlainGlobal | The inspectors that have two parameters, and are invoked with punctuation marks or reserved phrases. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
binary operator <string> | NamedGlobal | Typically used in the plural, returns the various possible binary inspectors that use the specified operators. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
binary operator returning <type> | Index<type>Global | Returns a list of binary operators that return the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<binary operator> as string | Cast | <string> | A short description of the use of the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
left operand type of <binary operator> | Plain | <type> | The type required before the operator in an expression. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
name of <binary operator> | Plain | <string> | A phrase naming the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <binary operator> | Plain | <type> | The type that the operator produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
right operand type of <binary operator> | Plain | <type> | The type required after the operator in an expression. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
symbol of <binary operator> | Plain | <string> | A phrase or punctuation mark used to invoke the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Bios

On Windows computers, this object returns strings that identify the version of the BIOS. On other computers, all bios expressions will fail gracefully, rather than generating an error.

Creation Methods

Key Phrase | Form | Description
bios | PlainGlobal | Returns the date of the bios if it exists, or <unknown> if it does not exist. This is a Windows-only command. On a non-Windows system, bios returns False. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
<bios> as string | Cast | <string> | This Windows-only Inspector returns a string that is the concatenation of the BIOS name and date. On a non-Windows operating system, it returns FALSE. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
date of <bios> | Plain | <string> | This Windows-only Inspector returns the date string stored in the bios. This string is formatted as MM/DD/YY. On a non-Windows operating system, it returns FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
version of <bios> | Plain | <string> | This Windows-only Inspector returns the first string of the multi-string version stored in the bios. This string may not exist. The format depends upon your BIOS manufacturer. On a non-Windows operating system, it returns FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1


Bit Set

A small, numbered collection of bits that can be examined and manipulated.

Creation Methods

Key Phrase | Form | Description
<integer> as bit set | Cast | Returns the bits of the binary representation of the integer; bit zero is the least-significant bit. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<integer> as bits | Cast | Returns the bits of the binary representation of the integer; bit zero is the least-significant bit. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
bit <integer> | NumberedGlobal | Creates a <bit set> object representing the nth bit position as specified by the integer. The integer value must be between 0 and 63 corresponding to the bit position of interest. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
bit set <string> | NamedGlobal | Returns the bits of the binary number given by the string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
left shift <integer> of <bit set> | Numbered | A bit set which, at each position n >= delta, holds bit n-delta of the original bit set, where delta is the given integer. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
right shift <integer> of <bit set> | Numbered | A bit set which, at each position n, holds bit n+delta of the original bit set, where delta is the given shift integer. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
<bit set> as integer | Cast | <integer> | Returns the integer whose binary representation matches the bit set. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<bit set> as string | Cast | <string> | Returns the bits (0s and 1s) in a string format. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
bit <integer> of <bit set> | Numbered | <boolean> | Returns the value of the bit at the given <integer> position in the set. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
least significant one bit of <bit set> | Plain | <integer> | Returns the least n such that bit n of the set is true. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
left shift <integer> of <bit set> | Numbered | <bit set> | A bit set which, at each position n >= delta, holds bit n-delta of the original bit set, where delta is the given integer. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
most significant one bit of <bit set> | Plain | <integer> | Returns the greatest n such that bit n of the set is true. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
one bit of <bit set> | Plain | <integer> | Returns the numbers n for which bit n of the set is true. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
right shift <integer> of <bit set> | Numbered | <bit set> | A bit set which, at each position n, holds bit n+delta of the original bit set, where delta is the given shift integer. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1

Operators

Key phrase | Return Type | Description
<bit set> - <bit set> | <bit set> | Returns the bits that are true in the left bit set and false in the right bit set. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<bit set> * <bit set> | <bit set> | Returns the intersection of the two bit sets. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<bit set> + <bit set> | <bit set> | Returns the union of the two sets. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<bit set> = <bit set> | <boolean> | Returns true if the corresponding bits of the two sets are equal. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<bit set> contains <bit set> | <boolean> | Returns false if -- for any n -- bit n of the left set is false, but bit n of the right set is true. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1

Examples

bit 0 of 5
Returns TRUE.

bit 3 of bit 3
Returns TRUE.


Boolean

Creation Methods

These boolean creation methods are in addition to the other properties that return the boolean type.

Key Phrase | Form | Description
<string> as boolean | Cast | Returns a boolean TRUE or FALSE from a string. The string must contain values of "TRUE" or "FALSE". Case is ignored. For example, "FalSe" as boolean = FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
bit <integer> of <integer> | Numbered | Return TRUE if the bit referenced by the integer is on. Bits are numbered starting with zero being the least significant. For example, bit 0 of 5 and bit 2 of 5 and not bit 1 of 5 = TRUE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
boolean <integer> of <array> | Numbered | Get, from an array, a boolean keyed by the specified integer. Mac:4.1
boolean <string> | NamedGlobal | Creates the boolean value of the <string>, e.g., • boolean "False" = FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
conjunction of <boolean> | Plain | This inspector performs a serial AND on all its boolean arguments: • conjunction of (true; true; true) -> TRUE • conjunction of (true; true; false) -> FALSE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
disjunction of <boolean> | Plain | This inspector performs a serial OR on all its boolean arguments: • disjunction of (false; false; false) -> FALSE • disjunction of (false; false; true) -> TRUE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
enabled of <administrative rights> | Plain | Creates a setting object corresponding to an administrator for the given <client> computer. Win:4.1, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
false | PlainGlobal | Creates a boolean with value FALSE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
inexact of <floating point> | Plain | Returns TRUE if the calculation raised the inexact exception; that is, if some intermediate result could not be represented exactly. Win:4.1,
infinite of <floating point> | Plain | Returns TRUE if the floating point number is infinite. Win:4.1, Mac:4.1
invalid of <floating point> | Plain | Returns TRUE if the calculation raised the invalid exception; that is, if some part of the calculation a function was applied to a value outside its domain. Win:4.1,
nan of <floating point> | Plain | Returns TRUE if the value is not a number. Win:4.1, Mac:4.1
normal of <floating point> | Plain | Returns TRUE if the value is a valid floating point number. Win:4.1, Mac:4.1
overflow of <floating point> | Plain | Returns TRUE if the calculation raised the overflow exception; that is, if some intermediate result was too large to be represented, but not an exact infinity. Win:4.1,
powerpc | PlainGlobal | Returns TRUE if the cpu is a PowerPC, FALSE if it is a 68000 chip. Mac:4.1
true | PlainGlobal | Creates a boolean with value TRUE. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
underflow of <floating point> | Plain | Returns TRUE if the calculation raised the underflow exception; that is, if some intermediate result was a nonzero value too small to be represented. Win:4.1,

Properties

Key Phrase | Form | Return Type | Description
<boolean> as string | Cast | <string> | Converts the boolean value to a string. The possible values returned are "True" and "False" with this exact case, e.g., • TRUE as string = "True". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
conjunction of <boolean> | Plain | <boolean> | This inspector performs a serial AND on all its boolean arguments: • conjunction of (true; true; true) -> TRUE • conjunction of (true; true; false) -> FALSE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
disjunction of <boolean> | Plain | <boolean> | This inspector performs a serial OR on all its boolean arguments: • disjunction of (false; false; false) -> FALSE • disjunction of (false; false; true) -> TRUE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<boolean> * <time range> | <timed( time range, boolean )> | Returns a time interval labeled with a boolean TRUE or FALSE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<boolean> {cmp} <boolean> | <boolean> | Compare two boolean expressions. Returns another boolean, depending on the evaluation of the comparison: • {cmp} is one of: =, != . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<boolean> {op} <boolean> | <boolean> | Operates on two boolean expressions. Returns another boolean, depending on the evaluation of the operation, e.g., (True And True) = True. • {op} is one of: And, Or . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<floating point> {cmp} <floating point> | <boolean> | Compares two floating point numbers, where: • {cmp} is one of: =, <, <=. Win:4.1, Mac:4.1
<floating point> {cmp} <integer> | <boolean> | Compares a floating point number and an integer, where: • {cmp} is one of: =, <=, <. Win:4.1, Mac:4.1
<integer> {cmp} <floating point> | <boolean> | Compares an integer to a floating point number, where: • {cmp} is one of: =, <=, <. Win:4.1, Mac:4.1
<time interval> {cmp} <time interval> | <boolean> | Compare two time intervals, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time range> * <boolean> | <timed( time range, boolean )> | Returns a time interval labeled with the specified boolean, in the form of: • (<date> to <date>), <boolean>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Examples

bit 0 of (least integer + 1)
Returns the least significant bit of the smallest possible integer, plus one.

infinite of (floating point "1"/ 0)
Returns TRUE.

nan of (floating point "1.e-99999" * floating point "1.e999999")
Returns TRUE.

overflow of (floating point "1.0e50000")
Returns TRUE, since the number is too big to represent in floating point.


Bundle

A bundle object is used to inspect software installations as managed by the "software depot."

Creation Methods

Key Phrase | Form | Description
bundle <string> | NamedGlobal | Returns a bundle (CFBundle) by name. Mac:4.1
bundle <string> of <software_depot> | Named | Returns the bundle object corresponding to the name provided. Useful for seeing if a bundle is installed. HPUX:4.1
bundle of <folder> | Plain | Returns a bundle from a folder (if it has one like application folders do). Mac:4.1
bundle of <product> | Plain | Returns the bundle to which the product belongs. HPUX:4.1
bundle of <software_depot> | Plain | Returns a bundle object. Use the plural expression 'bundles of software depot' to return all of the bundles installed. HPUX:4.1

Properties

Key Phrase | Form | Return Type | Description
bundle version of <bundle> | Plain | <version> | Returns the version of the bundle corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
creator of <bundle> | Plain | <file signature> | The creator 4-letter code of the bundle (e.g., FNDR for Finder). Mac:4.1
global dictionary of <bundle> | Plain | <dictionary> | The bundle's information dictionary. Mac:4.1
local dictionary of <bundle> | Plain | <dictionary> | The bundle’s localized information dictionary. Mac:4.1
product of <bundle> | Plain | <product> | Returns the product and/or products contained in the bundle. HPUX:4.1
type of <bundle> | Plain | <file type> | Returns the file type of the bundle. Can be used only to compare equality between file types. Mac:4.1
version of <bundle> | Plain | <version> | Version of the given bundle. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
bundle version of <bundle> | Plain | <version> | Returns the version of the bundle corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
creator of <bundle> | Plain | <file signature> | The creator 4-letter code of the bundle (e.g., FNDR for Finder). Mac:4.1
global dictionary of <bundle> | Plain | <dictionary> | The bundle's information dictionary. Mac:4.1
local dictionary of <bundle> | Plain | <dictionary> | The bundle’s localized information dictionary. Mac:4.1
product of <bundle> | Plain | <product> | Returns the product and/or products contained in the bundle. HPUX:4.1
type of <bundle> | Plain | <file type> | Returns the file type of the bundle. Can be used only to compare equality between file types. Mac:4.1
version of <bundle> | Plain | <version> | Version of the given bundle. Mac:4.1

Examples

exists bundle of folder "iTunes.app" of applications folder
A bundle is a directory in the file system that groups related resources together in one place. Applications, frameworks, and plug-ins are all examples of bundles. Programs can also use document bundles instead of flat files to save complex content. For more info, see the Apple Developer documentation.

string "CFBundleVersion" of global dictionary of bundle of folder "iTunes.app" of applications folder
Returns the bundle version of the specified folder.

type of bundle of applications folder = type of bundle of domain library folder
Returns TRUE if the specified types are the same.


Capability

A package can have capabilities that it requires, provides, obsoletes, or conflicts with. For instance, apache may require sh, and provide httpd. If you want to install apache, you will need to have sh in the RPM database. If you want to install a package that uses httpd, you will need to install apache.

Creation Methods

Key Phrase | Form | Description
capability <string> | NamedGlobal | Converts a string to a capability object for rpm dependency version comparisons. Strings with version information take the form capability relation version, where relation is one of {<,>,>=,<=,=}. If a relation and version are not specified, then comparisons will assume a capability at any version number. Lin:4.1
capability <string> of <rpmdatabase> | Named | Returns a capability object matching this string if some package in the RPM database provides that capability. <string> refers to built-in properties of the installed rpm version itself, not normal package capabilities. Lin:4.1
conflict of <package> | Plain | Returns capability objects that conflict with this package in the RPM database. Lin:4.1
installed file of <package> | Plain | The list of actual files that the package leaves installed. Lin:4.1
obsolete of <package> | Plain | Returns a capability object that this package obsoletes. Lin:4.1
provide of <package> | Plain | Returns capability objects for each capability that this package provides. Lin:4.1
require of <package> | Plain | Returns capability objects for each capability that this package requires. Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
<capability> as string | Cast | <string> | Creates a string containing the capability's name, relation and version. Lin:4.1
name of <capability> | Plain | <string> | Returns the name of this capability object. Lin:4.1
relation of <capability> | Plain | <string> | If this capability object has version information, the relation is returned. Lin:4.1
version of <capability> | Plain | <string> | If this capability object has version information, the version is returned. Lin:4.1

Operators

Key phrase | Return Type | Description
<capability> contains <capability> | <boolean> | Returns a boolean TRUE if the first capability satisfies the dependency specified by the second capability. A capability without version information is interpreted as a capability over all versions. If a package requires a capability not contained in the RPM database, then the rpm command will not allow that package to be installed. Lin:4.1

Examples

capability "anything"
Returns "anything". You can create any capability of a world object.

capability "apache" of rpm
If installed, returns "apache". You can only create capability of rpm objects if the capability is actually in the RPM database.

conflict of package "apache" of rpm
Returns a string, such as "apache2". The apache package specifies that it conflicts with apache2, so rpm should not install apache if apache2 is on the system.

installed files of package "BESAgent" of rpm
Returns a list of the installed files.

obsolete of package "openssh" of rpm
Returns a string such as "ssh", which is a capability that is obsoleted by the current package.

provide of package "apache" of rpm
Returns a string such as "httpd", which indicates a functional capability of the apache software.

require of package "libxslt" of rpm
Returns a capability, such as "libxml2 >= 2.4.7" or else, it returns no such object.

capability "libxml2 >= 2.4.7"
Casts the capability as a string, returning "libxml2 >= 2.4.7".

relation of capability "sh <= 4.1"
Returns "<=", the "less than or equal" relation.

version of capability "sh <= 4.1"
Returns "4.1", the version of the specified capability.

capability "x" contains capability "x = 1.0"
Returns TRUE. Having "x" at any version satisfies a requirement to have "x" at version 1.0.

capability "x = 1.0" contains capability "x"
Returns TRUE. Having "x" at version 1.0 satisfies a requirement to have "x" at any version.

capability "x = 1.0" contains capability "x > 1.0"
Returns FALSE. Having x = version 1.0 will not satisfy a requirement to have x > version 1.0.

capability "x = 1.0" contains capability "x < 2.0"
Returns TRUE. Having x = version 1.0 will satisfy a requirement to have x < version 2.0.

capability "x" contains capability "y"
Returns FALSE. A capability can only be contained/satisfied by a capability with the same name.


Carbon Proc

The Carbon Process Manager is a Macintosh API for that allows both forward and backward compatibility between code written for Mac OS 9 and Mac OS X. These Inspectors access the Carbon Process functionality. The Carbon proc Inspector allows you to access all processes that register with the Carbon Process Manager. This is different from the set of BSD Unix processes in that not all BSD processes use Carbon, e.g., daemon processes are not shown. Apps that run in Classic mode only run in the Classic process and so do not show up individually as in the Unix process list. However, they do show up in the Carbon version as they register with the Carbon Process Manager as individual entries. The Carbon processes also allow you to get information such as the file path.

Creation Methods

Key Phrase | Form | Description
carbon process | PlainGlobal | Returns a list of the processes currently running. Mac:5.1
carbon process <integer> | NumberedGlobal | Returns the process object corresponding to the given integer process ID (pid). Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
file of <carbon proc> | Plain | <filesystem object> | Returns a filesystem object corresponding to the given process. Mac:5.1
id of <carbon proc> | Plain | <integer> | Returns the integer ID of the specified carbon process. Mac:5.1
name of <carbon proc> | Plain | <string> | Returns the name of the specified carbon process. Mac:5.1
pid of <carbon proc> | Plain | <integer> | Returns the process ID of the specified carbon process. Mac:5.1
process id of <carbon proc> | Plain | <integer> | Returns the integer ID of the specified carbon process. Mac:5.1

Examples

names of carbon processes
Returns a list of processes, such as loginwindow, Dock, SystemUIServer, Finder, iTunesHelper, System Events, Terminal, DashboardClient, etc.

files of carbon processes
Returns a list of file pathnames, such as /System/Library/CoreServcies/loginwindow.app/Contents/MacOS/loginwindow, /System/Library/CoreServcies/Dock.app/Contents/MacOS/Dock, /System/Library/CoreServcies/SystemUIServer.app/Contents/MacOS/SystemUIServer, /System/Library/CoreServcies/Finder.app/Contents/MacOS/Finder, etc.


Cast

Some Inspectors look at the Relevance language itself, inspecting the Inspectors, so to speak. There are several aspects to view, including the types, properties, casts and operators. This group of Inspectors looks at the various casting operations available from the Relevance language.

Creation Methods

Key Phrase | Form | Description
cast | PlainGlobal | The inspectors invoked using the keyword "as.". Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
cast <string> | NamedGlobal | Returns a list of the objects that can be cast into the type specified by <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
cast from of <type> | Plain | Returns the casts that can be created from the specified <type>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
cast returning <type> | Index<type>Global | Returns a list of the objects that can be cast into the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<cast> as string | Cast | <string> | A short description of the use of the cast. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
name of <cast> | Plain | <string> | The phrase used after the keyword "as" in an expression using the cast. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
operand type of <cast> | Plain | <type> | The type required before the keyword "as" in an expression using the cast. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Client

The client object allows access to properties of the client application hosting the relevance evaluation, typically a BigFix program. In addition, the client maintains a collection of settings with both name and value properties that are inspectable using the client object. Client objects are derived from file objects, so they share all the file properties.

Creation Methods

Key Phrase | Form | Description
client | PlainGlobal | Returns the client object corresponding to the BigFix application evaluating the current relevance expression. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
administrative rights of <client> | Plain | <setting> | A setting that determines if administrative rights are enabled for this computer. Mac:7.1
administrator <string> of <client> | Named | <setting> | If the administrator named in the <string> is enabled on the given <client> computer, this property returns a setting with the given name and the value 'allow.' For instance, if the name of the administrator is joe_admin, then the client would return a setting object with the name 'joe_admin' and a value of 'allow'. Casting this as a string would return 'joe_admin=allow'. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
administrator of <client> | Plain | <setting> | Creates a setting object corresponding to the administrators of the given <client>. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
process owner of <client> | Plain | <client process owner> | The name of the owner of the BigFix client. Mac:4.1
setting <string> of <client> | Named | <setting> | Returns a client setting whose name matches the string provided from the client settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
setting of <client> | Plain | <setting> | Returns one or more settings from the client settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
version of <client> | Plain | <version> | The product version of the BES application (BESClient or QnA). • Note: On the Macintosh only, this Inspector returns a <string>. Lin:4.1, Sol:4.1, HPUX:4.0, AIX:4.1, Mac:7.1

Examples

version of client as string
Returns a string like "4.0.3.7".


Client_cryptography

These Inspectors expose cryptographic properties exclusive to the client.

Creation Methods

Key Phrase | Form | Description
client cryptography | PlainGlobal | This Inspector is similar to the global cryptography object except that it returns properties exclusive to the client (whereas <cryptography> is also available in the Console/Web Reports contexts). Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
desired encrypt report of <client_cryptography> | Plain | <boolean> | Returns TRUE if the client is configured to attempt to encrypt reports. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
encrypt report failure message of <client_cryptography> | Plain | <string> | If the client is not successfully encrypting reports, this Inspector returns the failure message. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
encrypt report of <client_cryptography> | Plain | <boolean> | Returns TRUE if the client is successfully encrypting reports. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Client Process Owner

These Inspectors tell what user context the client is running in.

Creation Methods

Key Phrase | Form | Description
process owner of <client> | Plain | Owner of the agent process. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<client process owner> as string | Cast | <string> | Owner of the agent process. Mac:4.1
long name of <client process owner> | Plain | <string> | The long name of the client process owner. Mac:4.1
name of <client process owner> | Plain | <string> | Owner of the agent process. Mac:4.1
short name of <client process owner> | Plain | <string> | The short name of the client process owner. Mac:4.1

Examples

process owner of client as string
Typically returns "root".

long name of process owner of client
OS X usernames typically have a long and a short form. For a properly installed Agent, long name of process owner of client should return the same as short name, namely 'root'.

name of process owner of client
Should usually be root.

short name of process owner of client
OS X usernames typically have a long and a short form. For a properly installed Agent, short name of process owner of client should return the same as long name, namely 'root'.


Component

Components are handled by the MacOS Component Manager. These Inspectors provide access to the various software components available through the Component Manager. The information derived from a component is placed there by its maker. What it means is determined by the maker.

Creation Methods

Key Phrase | Form | Description
component | PlainGlobal | Is an iterated property. The MacOS supports software "components", for example QuickTime codecs. This iterator can examine the components that are available. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
info of <component> | Plain | <string> | Returns information about the component, as determined by the creator of the component. Mac:4.1
maker of <component> | Plain | <string> | Returns the name of the maker of the specified component. Mac:4.1
name of <component> | Plain | <string> | The name of the component, as determined by its maker. Mac:4.1
subtype of <component> | Plain | <string> | The subtype of the component, as determined by the component maker. Mac:4.1
type of <component> | Plain | <string> | The type of the component, as determined by the component maker. Mac:4.1
version of <component> | Plain | <version> | The version of the component, as determined by the component maker. Mac:4.1


Computer

These Inspectors provide access to the name of the computer.

Creation Methods

Key Phrase | Form | Description
computer | PlainGlobal | Refers to the computer itself. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
name of <computer> | Plain | <string> | The name of the computer. Mac:4.1

Examples

name of computer
Returns the name of the computer.


Connection

This object is used to query your connections. These are all properties of the Internet Connection Firewall, as returned in the NETCON_PROPERTIES structure.

Creation Methods

Key Phrase | Form | Description
connection of <network> | Plain | Returns a connection to the specified network. This Inspector requires Windows XP or better. Win:5.0

Properties

Key Phrase | Form | Return Type | Description
device name of <connection> | Plain | <string> | Returns the name of the device associated with the specified connection. Win:5.0
firewall of <connection> | Plain | <internet connection firewall> | Returns the internet connection firewall object corresponding to the specified connection. Win:5.0
guid of <connection> | Plain | <string> | Returns the globally-unique identifier (GUID) for the specified connection. Win:5.0
media type of <connection> | Plain | <media type> | Returns the media type of for the specified connection. Win:5.0
name of <connection> | Plain | <string> | Returns the name of the specified connection. Win:5.0
status of <connection> | Plain | <connection status> | Returns the status of the specified connection. Win:5.0


Connection Status

This object returns information about the status of your connections.

Creation Methods

Key Phrase Form Description
connection status <integer> NumberedGlobal

Returns the connection status based on its integer value. This Inspector is included to take advantage of new (or undocumented) additions to the status values.

Win:5.0

connection status authenticating PlainGlobal

Returns the value NCS_AUTHENTICATING: The connection is waiting for authentication to occur.

Win:5.0

connection status authentication failed PlainGlobal

Returns the value NCS_AUTHENTICATION_FAILED: Authentication has failed on this connection.

Win:5.0

connection status authentication succeeded PlainGlobal

Returns the value NCS_AUTHENTICATION_SUCCEEDED: Authentication has succeeded on this connection.

Win:5.0

connection status connected PlainGlobal

Returns the value NCS_CONNECTED: The connection is in a connected state.

Win:5.0

connection status connecting PlainGlobal

Returns the value NCS_CONNECTING: The connection is in the process of connecting.

Win:5.0

connection status disconnected PlainGlobal

Returns the value NCS_DISCONNECTED: The connection is disconnected.

Win:5.0

connection status disconnecting PlainGlobal

Returns the value NCS_DISCONNECTING: The connection is in the process of disconnecting.

Win:5.0

connection status hardware disabled PlainGlobal

Returns the value NCS_HARDWARE_DISABLED: The hardware for the connection is present, but is not enabled.

Win:5.0

connection status hardware malfunction PlainGlobal

Returns the value NCS_HARDWARE_MALFUNCTION: A malfunction has occurred in the hardware for the connection.

Win:5.0

connection status media disconnected PlainGlobal

Returns the value NCS_MEDIA_DISCONNECTED: The media, for example the network cable, is disconnected.

Win:5.0

connection status no hardware present PlainGlobal

Returns the value NCS_NO_HARDWARE_PRESENT: The hardware for the connection, for example network interface card (NIC), is not present.

Win:6.0

status of <connection> Plain

Returns the current status of the connection. You can compare this status to the 'connection status' global objects, which act as constants. Some of the possible values include:
• NCS_DISCONNECTED: The connection is disconnected.
• NCS_CONNECTING: The connection is in the process of connecting.
• NCS_CONNECTED: The connection is in a connected state.
• NCS_DISCONNECTING: The connection is in the process of disconnecting.
• NCS_HARDWARE_NOT_PRESENT: The hardware for the connection, for example network interface card (NIC), is not present.
• NCS_HARDWARE_DISABLED: The hardware for the connection is present, but is not enabled.
• NCS_HARDWARE_MALFUNCTION: A malfunction has occurred in the hardware for the connection.
• NCS_MEDIA_DISCONNECTED: The media, for example the network cable, is disconnected.
• NCS_AUTHENTICATING: The connection is waiting for authentication to occur.
• NCS_AUTHENTICATION_SUCCEEDED: Authentication has succeeded on this connection.
• NCS_AUTHENTICATION_FAILED: Authentication has failed on this connection.
• NCS_INVALID_ADDRESS: The address is invalid.
• NCS_CREDENTIALS_REQUIRED: Security credentials are required.

Win:5.0

Operators

Key phrase | Return Type | Description
<connection status> = <connection status> | <boolean> | Compare the statuses of two connections. Win:5.0


Country

These Inspectors allow comparing countries (as seen in version numbers).

Creation Methods

Key Phrase | Form | Description
country <string> | NamedGlobal | Maps a country script string (e.g. verAfrikaans) to its region code. Mac:4.1

Operators

Key phrase | Return Type | Description
<country> = <country> | <boolean> | Compares two countries, as found in a Macintosh version. Mac:4.1

Examples

exists (country "verChina")
See the Apple developer documentation for more information.


Cryptography

This is a global object that has several properties that expose the state of the cryptography controls. BigFix uses cryptographic functions throughout the BigFix Platform. Every time an operator logs in to BigFix, creates a new user, starts an action or subscribes to new content, authentication and signature routines are executed using cryptographic libraries based on the FIPS 140-2 standard.

Creation Methods

Key Phrase | Form | Description
cryptography | PlainGlobal | A global object that implements the FIPS 140-2 standard for secure signing and authentication throughout the BigFix application. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
desired fips mode of <cryptography> | Plain | <boolean> | Returns TRUE if the application (the client, console, or web reports, depending on the context) tried to enter FIPS 140-2 compliant mode. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
fips mode failure message of <cryptography> | Plain | <string> | Returns the error message returned by the cryptographic library if the application (the client, console, or web reports, depending on the context) tried to enter FIPS 140-2 compliant mode and failed. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
fips mode of <cryptography> | Plain | <boolean> | Returns TRUE if the application (the client, console, or web reports, depending on the context) is operating in FIPS 140-2 mode (the mode provided by openssl). FIPS mode limits the set of ciphers and SSL protocols that can be used in the cryptographic library. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Current Relay

These Inspectors refer to the BES Server or Relay that the client last registered with.

Creation Methods

Key Phrase | Form | Description
current relay | PlainGlobal | Returns an object corresponding to the server or relay that the client last registered with. This may be a BES Relay or the BES root server. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
version of <current relay> | Plain | <version> | Returns a version object that is the version of the server that the client last registered with. This may be a BES Relay or the BES root server. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1


Current User

This object exists if the user is logged in to the current machine.

Creation Methods

Key Phrase | Form | Description
current user | PlainGlobal | Creates the current user object if one is logged in to the desktop. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
name of <current user> | Plain | <string> | Returns the name of the current user. Mac:4.1


Datafork

These Inspectors refer to the data fork of a filesystem object.

Creation Methods

Key Phrase | Form | Description
data fork of <file> | Plain | Returns information about the data fork of the specified file. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <datafork> | Plain | <integer> | The logical length of the data fork of the file. Mac:4.1
size of <datafork> | Plain | <integer> | Returns the size of the specified datafork. Mac:5.1


Date

These are the various Inspectors that access the date types.

Creation Methods

Key Phrase | Form | Description
<string> as date | Cast | Casts a string as a date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
april <integer> of <integer> | Numbered | Returns the nth day of april and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
august <integer> of <integer> | Numbered | Returns the nth day of August and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current date | PlainGlobal | Returns the current date in the format: • Day of week, Day Month Year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
date <string> | NamedGlobal | Converts the given string into a date. The string should be of the form 'Day Month Year' and the returned date will be of the form 'Day of week, Day Month Year'. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
date <time zone> of <time> | Index<time zone> | Returns the date adjusted for the specified time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december <integer> of <integer> | Numbered | Returns the nth day of December and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
february <integer> of <integer> | Numbered | Returns the nth day of February and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
january <integer> of <integer> | Numbered | Returns the nth day of January and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july <integer> of <integer> | Numbered | Returns the nth day of July and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june <integer> of <integer> | Numbered | Returns the nth day of June and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
march <integer> of <integer> | Numbered | Returns the nth day of March and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <date> | Plain | Returns the maximum value from a list of <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
may <integer> of <integer> | Numbered | Returns the nth day of May and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minimum of <date> | Plain | Returns the minimum value from a list of <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
november <integer> of <integer> | Numbered | Returns the nth day of November and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
october <integer> of <integer> | Numbered | Returns the nth day of October and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
september <integer> of <integer> | Numbered | Returns the nth day of September and the specified year as a date (day of week, month day year). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<date> as string | Cast | <string> | Cast a date type as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_month of <date> | Plain | <day of month> | Extracts the day of the month from the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_week of <date> | Plain | <day of week> | Extracts the day of the week (Monday, Tuesday, etc.) from the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_year of <date> | Plain | <day of year> | Extracts the day of year from the specified date, in the 'Month Day' format. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <date> | Plain | <( date, date )> | Returns the minimum and maximum extreme values of the given list of <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <date> | Plain | <date> | Returns the maximum value from a list of <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <date> | Plain | <date> | Returns the minimum value from a list of <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month of <date> | Plain | <month> | Returns the month derived from the given date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month_and_year of <date> | Plain | <month and year> | Formats the specified date in month year format, eg. March 2012. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <date> | Plain | <date with multiplicity> | Returns the unique values of a given list of <date> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
year of <date> | Plain | <year> | Returns the year, extracted from the given date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<date> - <date> | <time interval> | Subtracts two dates to produce a time interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<date> & <time of day with time zone> | <time> | Concatenates a date with a time and a time zone for a complete time stamp. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<date> {cmp} <date> | <boolean> | Compares two dates, where: • {cmp} is one of: =, <, <=. Mac:4.1
<date> {op} <number of months> | <date> | Adds or subtracts a specified number of months to a given date, where {op} is one of: -, +. Win:6.0
<date> {op} <time interval> | <date> | Add or subtract a time interval to a date, producing a new date, where {op} is one of: -, +. Win:6.0
<number of months> + <date> | <date> | Adds a number of months to a date, returning a new date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time interval> + <date> | <date> | Adds a time interval (days, hours, minutes, seconds) to a date to create a new date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day with time zone> & <date> | <time> | Concatenates a 'time of day with time zone' object with a date object to produce a time object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Date with Multiplicity

These Inspectors deal with arrays of dates, allowing you to pluck out unique dates and count them. These objects are derived from ordinary dates.

Creation Methods

Key Phrase | Form | Description
unique value of <date> | Plain | Returns the unique values of a given list of <date> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <date with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <date> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Day of Month

These Inspectors provide tools for dealing and calculating with day-of-month types, which are numbers from 1-31.

Creation Methods

Key Phrase | Form | Description
<integer> as day_of_month | Cast | Cast an integer as a day of the month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as day_of_month | Cast | Casts a string as a day of month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_month | PlainGlobal | Returns the current day of the month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day of <day of year> | Plain | Returns the day of the month of the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_month <integer> | NumberedGlobal | Converts the given integer to a day of month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_month <string> | NamedGlobal | Converts the given string value (must be an integer from 1-31) to a day of month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_month of <date> | Plain | Extracts the day of the month from the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <day of month> | Plain | Returns the maximum value from a list of <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <day of month> | Plain | Returns the minimum value from a list of <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<day of month> as integer | Cast | <integer> | Cast a day of month type as an integer. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of month> as string | Cast | <string> | Cast a day of month type as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of month> as two digits | Cast | <string> | Cast a day of month type as a two-digit number. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <day of month> | Plain | <( day of month, day of month )> | Returns the minimum and maximum extreme values of the given list of <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <day of month> | Plain | <day of month> | Returns the maximum value from a list of <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <day of month> | Plain | <day of month> | Returns the minimum value from a list of <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <day of month> | Plain | <day of month with multiplicity> | Returns the unique values of a given list of <day of month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of month> - <day of month> | <time interval> | Subtract two day of month types, producing a time interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of month> & <month and year> | <date> | Concatenate a day of month with a month and year type to produce a complete date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of month> & <month> | <day of year> | Concatenate a day of month with a month type to produce a day of year (eg. April 20). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of month> {cmp} <day of month> | <boolean> | Compare two day of month types, where {cmp} is one of: <, <=, =. Win:6.0
<day of month> {op} <time interval> | <day of month> | Add or subtract a time interval from a day of month to produce a new day of month. Here {op} is one of: -, +. Win:6.0
<month and year> & <day of month> | <date> | Concatenates a month and year with a day of month to produce a complete date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> & <day of month> | <day of year> | Concatenates a month and a day of the month to produce a day of year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time interval> + <day of month> | <day of month> | Adds a time interval (days, hours, minutes, seconds) to a day of the month to create a new day of the month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Day of Month with Multiplicity

These Inspectors deal with day-of-month arrays, allowing you to pluck out unique day-of-month values and count them. These objects are derived from ordinary day-of-month types.

Creation Methods

Key Phrase | Form | Description
unique value of <day of month> | Plain | Returns the unique values of a given list of <day of month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <day of month with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <day of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Day of Week

These Inspectors provide tools for dealing and calculating with day-of-week types, which include Monday, Tuesday, etc. This set of Inspectors includes each day as a self-named object.

Creation Methods

Key Phrase | Form | Description
<string> as day_of_week | Cast | Casts a string as a day of the week. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_week | PlainGlobal | Retruns the current day of the week, eg. Monday, Tuesday, etc. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_week <string> | NamedGlobal | Converts the given string value to a day of week type, eg. Monday, Tuesday, etc. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_week of <date> | Plain | Extracts the day of the week from the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
friday | PlainGlobal | Returns Friday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
monday | PlainGlobal | Returns the day of week object for Monday. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
saturday | PlainGlobal | Returns Saturday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
sunday | PlainGlobal | Returns Sunday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
thursday | PlainGlobal | Returns Thursday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tuesday | PlainGlobal | Returns Tuesday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
wednesday | PlainGlobal | Returns Wednesday as a day of week object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<day of week> as string | Cast | <string> | Casts the day of week as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of week> as three letters | Cast | <string> | Casts the day of week as a three-letter abbreviation (Mon, Tue, etc.). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <day of week> | Plain | <day of week with multiplicity> | Returns the unique values of a given list of <day of week> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of week> - <day of week> | <time interval> | Subtract two day of week types (Monday, Tuesday, etc.) to produce a time interval. The answer cannot exceed 6 days. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of week> {op} <time interval> | <day of week> | Add or subtract a time interval from a day of the week to produce a new day of week. Here {op} is one of: -, +. Win:6.0
<day of week> = <day of week> | <boolean> | Compares two days of the week and returns a boolean TRUE or FALSE. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time interval> + <day of week> | <day of week> | Adds a time interval (days, hours, minutes, seconds) to a day of the week to create a new day of the week. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Day of Week with Multiplicity

These Inspectors deal with day-of-week arrays, allowing you to pluck out unique day-of-week values and count them. These objects are derived from ordinary day-of-week types.

Creation Methods

Key Phrase | Form | Description
unique value of <day of week> | Plain | Returns the unique values of a given list of <day of week> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <day of week with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <day of week> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Day of Year

These Inspectors provide tools for dealing and calculating with day-of-month types, which are of the form Sun, 01 Apr 2007.

Creation Methods

Key Phrase | Form | Description
april <integer> | NumberedGlobal | Returns the nth day of april as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
august <integer> | NumberedGlobal | Returns the nth day of August as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current day_of_year | PlainGlobal | Retruns the current day of the year, in a Month Day format. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day_of_year of <date> | Plain | Extracts the day of year from the specified date, in the 'Month Day' format. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december <integer> | NumberedGlobal | Returns the nth day of December as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
february <integer> | NumberedGlobal | Returns the nth day of February as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
january <integer> | NumberedGlobal | Returns the nth day of January as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july <integer> | NumberedGlobal | Returns the nth day of July as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june <integer> | NumberedGlobal | Returns the nth day of June as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
march <integer> | NumberedGlobal | Returns the nth day of March as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <day of year> | Plain | Returns the maximum value from a list of <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
may <integer> | NumberedGlobal | Returns the nth day of May as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minimum of <day of year> | Plain | Returns the minimum value from a list of <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
november <integer> | NumberedGlobal | Returns the nth day of November as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
october <integer> | NumberedGlobal | Returns the nth day of October as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
september <integer> | NumberedGlobal | Returns the nth day of September as a 'day of year' type (month day). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<day of year> as string | Cast | <string> | Casts a day of the year as a string type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
day of <day of year> | Plain | <day of month> | Returns the day of the month of the specified date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <day of year> | Plain | <( day of year, day of year )> | Returns the minimum and maximum extreme values of the given list of <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <day of year> | Plain | <day of year> | Returns the maximum value from a list of <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <day of year> | Plain | <day of year> | Returns the minimum value from a list of <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month of <day of year> | Plain | <month> | Returns the month portion of the given date (in month day format). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <day of year> | Plain | <day of year with multiplicity> | Returns the unique values of a given list of <day of year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of year> - <day of year> | <time interval> | Subtracts two days of the year to produce a time interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of year> & <month and year> | <date> | Concatenates a day of the year with a month and year to create a complete date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of year> & <year> | <date> | Concatenates a day of the year with a year to create a complete date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of year> {cmp} <day of year> | <boolean> | Compares two days of the year, producing a boolean TRUE or FALSE, where {cmp} is one of: <, <=, =. Win:6.0
<day of year> {op} <number of months> | <day of year> | Add or subtract a number of months to a day of the year to produce a new day of the year. Here {op} is one of: -, +. Win:6.0
<day of year> {op} <time interval> | <day of year> | Add or subtract a time interval to a day of the year to produce a new day of the year. Here {op} is one of: -, +. Win:6.0
<month and year> & <day of year> | <date> | Concatenates a month and year with a day of year to produce a complete date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<number of months> + <day of year> | <day of year> | Adds a number of months to a day of the year (July 4, say) to produce another day of the year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time interval> + <day of year> | <day of year> | Adds a time interval (days, hours, minutes, seconds) to a day of the year to create a new day of the year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> & <day of year> | <date> | Concatenates a year with the day of the year, returning a full date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Day of Year with Multiplicity

These Inspectors deal with day-of-year arrays, allowing you to pluck out unique day-of-year values and count them. These objects are derived from ordinary day-of-year types.

Creation Methods

Key Phrase | Form | Description
unique value of <day of year> | Plain | Returns the unique values of a given list of <day of year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <day of year with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <day of year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Dictionary

These Inspectors provide access to an XML dictionary as used in .plist (property list) files.

Creation Methods

Key Phrase | Form | Description
dictionary <integer> of <array> | Numbered | Get, from an array, a dictionary keyed by the specified integer. Mac:4.1
dictionary <string> of <dictionary> | Named | Get, from a dictionary, a dictionary keyed by the specified string. Mac:4.1
dictionary <string> of <preference> | Named | Get, from a preference, a dictionary keyed by the specified string. Mac:4.1
dictionary of <file> | Plain | Returns the dictionary object for the specified file, if it exists. Mac:4.1
dictionary of <osxvalue> | Plain | Cast the osxvalue (essentially untyped) to a dictionary. Mac:4.1
dictionary of <registrynode> | Plain | Returns a dictionary from a node in the IORegistry. Mac:4.1
dictionary of <registryroot> | Plain | Returns a dictionary from the root of the registry. Mac:4.1
global dictionary of <bundle> | Plain | The bundle's information dictionary. Mac:4.1
local dictionary of <bundle> | Plain | The bundle’s localized information dictionary. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
array <string> of <dictionary> | Named | <array> | Get, from a dictionary, an array keyed by the specified string. Mac:4.1
boolean <string> of <dictionary> | Named | <boolean> | Get, from a dictionary, a boolean keyed by the string. Mac:4.1
cstring <string> of <dictionary> | Named | <string> | Get, from a dictionary, the string keyed by the specified string. Works for objects in a dictionary of type String or Data. If the type is Data, any null terminator will be stripped. Mac:6.0
data <string> of <dictionary> | Named | <string> | Returns the specified dictionary data as a string. Mac:6.0
date <string> of <dictionary> | Named | <time> | Get, from a dictionary, a date keyed by the specified string. Mac:4.1
dictionary <string> of <dictionary> | Named | <dictionary> | Get, from a dictionary, a dictionary keyed by the specified string. Mac:4.1
entry of <dictionary> | Plain | <dictionaryentry> | A key-value pair of a dictionary. Mac:4.1
integer <string> of <dictionary> | Named | <integer> | Get, from a dictionary, an integer keyed by the specified string. Mac:4.1
key of <dictionary> | Plain | <string> | The keys of a dictionary. Mac:4.1
size of <dictionary> | Plain | <integer> | The size of the given dictionary. Mac:4.1
string <string> of <dictionary> | Named | <string> | Get, from a dictionary, the string keyed by the specified string. Works for objects in a dictionary of type String or Data. If the type is Data, any null terminator will be returned as part of the string. Use cstring if you expect a Data object containing a null terminated string. Mac:4.1

Examples

exists dictionary 0 of array "LogFileDicts" of preference "com.apple.Console"
Returns TRUE if the specified dictionary exists.

exists dictionary "Timer" of dictionary "SUCheckSchedulerTag" of dictionary "com.apple.SoftwareUpdate" of dictionary "AbsoluteSchedule" of dictionary of file "com.apple.scheduler.plist" of preferences folder
Returns TRUE if the specified dictionary exists.

exists dictionary "Timer" of dictionary "SUCheckSchedulerTag" of dictionary "com.apple.SoftwareUpdate" of dictionary "AbsoluteSchedule" of preference "com.apple.scheduler"
Returns TRUE if the specified dictionary exists.

exists dictionary of file "com.apple.scheduler.plist" of preferences folder
Returns TRUE if the specified dictionary exists.

keys of entries of dictionary of usb plane of iokit registry
Returns the specified keys, e.g.: Device Speed, iSerialNumber, bNumConfigurations, IOUserClientClass, AAPL, current-available, bDeviceClass, USB Product Name, IOCFPlugInTypes.

keys of entries of dictionary of iokit registry
Returns the specified keys, e.g.: IOKitBuildVersion, IONDRVFrameBufferGeneration, IOConsoleUsers, IOKitDiagnostics, IORegistryPlanes, IOMaximumMappedIOByteCount, IOCatalogue.

string "CFBundleVersion" of global dictionary of bundle of folder "iTunes.app" of applications folder
Returns the specified bundle version.

keys of entries of local dictionary of bundle of folder "iTunes.app" of applications folder
Returns information in the default system langauge for bundles that include localized resources, such as Movie File, iTunes Remote Library URL, MP2 Audio File, WAVE Audio File, MP3 Audio File, CFBundleHelpBookName, Equalizer Settings, Tunes Database File, etc...

boolean "trash-full" of dictionary of file "com.apple.dock.plist" of preferences folder
Returns TRUE if the given flag is set.

date "date" of dictionary "Timer" of dictionary "SUCheckSchedulerTag" of dictionary "com.apple.SoftwareUpdate" of dictionary "AbsoluteSchedule" of dictionary of file "com.apple.scheduler.plist" of preferences folder
Returns the date of the specified dictionary.

integer "mod-count" of dictionary of file "com.apple.dock.plist" of preferences folder
Returns the mod-count of the specified dictionary as an integer.

keys of global dictionary of bundle of folder "iTunes.app" of applications folder
Returns a list of the specified keys, e.g.: CFBundlePackageType, CFBundleVersion, CFBundleHelpBookName, CFBundleName, CSResourcesFileMapped, LSMulitpleInstancesProhibted, CFBundleDocumentTypes, etc….

sizes of dictionaries of file "com.apple.help.plist" of preferences folder
Returns a list of the number of elements in the specified dictionary.

string "FXSearchFieldTarget" of dictionary of file "com.apple.finder.plist" of preferences folder
Returns a string, such as Spcf.


Dictionaryentry

These Inspectors provide access to the entries of a dictionary.

Creation Methods

Key Phrase | Form | Description
entry of <dictionary> | Plain | A key-value pair of a dictionary. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
key of <dictionaryentry> | Plain | <string> | The key of the given dictionary entry. Mac:4.1
value of <dictionaryentry> | Plain | <osxvalue> | Values of the dictionary entry. Mac:4.1

Examples

keys of entries of dictionary of iokit registry
Returns the specified keys, e.g.: IOKitBuildVersion, IONDRVFrameBufferGeneration, IOConsoleUsers, IOKitDiagnostics, IORegistryPlanes, IOMaximumMappedIOByteCount, IOCatalogue.

keys of entries of global dictionary of bundle of folder "iTunes.app" of applications folder
Returns a list of the specified keys.


Discretionary Access Control List

These Inspectors retrieve information from the access control list that is monitored by the owner of the object and specifies what kinds of access particular users or groups can have to the specified object.

Creation Methods

Key Phrase | Form | Description
dacl of <security descriptor> | Plain | Returns the discretionary access control list (DACL) that identifies the users and groups who are allowed or denied access to the specified security descriptor. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
<discretionary access control list> as string | Cast | <string> | Converts the discretionary system access control list (DACL) into a string value in the Microsoft Security Descriptor String Format. Win:7.1


Distinguished Name

These Inspectors refer to the distinguished name (DN) as defined by the Microsoft Active Directory service.

Creation Methods

Key Phrase | Form | Description
distinguished name <string> | NamedGlobal | Interprets a distingushed name in the textual format described by RFC 2253 and used by the LDAP/Active Directory. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
component <integer> of <distinguished name> | Numbered | <distinguished name component> | Returns the component (as specified by <integer>) of the distinguished name. Win:7.0
component of <distinguished name> | Plain | <distinguished name component> | Used as a plural, returns a list of the components of the given distinguished name. Win:7.0


Distinguished Name Component

These Inspectors refer to the various components of the distinguished name (DN) as defined by the Microsoft Active Directory API. A DN is a sequence of relative distinguished names (RDN) connected by commas. An RDN is an attribute with an associated value in the form attribute=value; normally expressed in a UTF-8 string format. For more information, see the MSDN article on Distinguished Names.

Creation Methods

Key Phrase | Form | Description
component <integer> of <distinguished name> | Numbered | Returns the component (as specified by <integer>) of the distinguished name. Win:7.0
component of <distinguished name> | Plain | Used as a plural, returns a list of the components of the given distinguished name. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
type of <distinguished name component> | Plain | <string> | Returns the type of the specified component of the distinguished name. Win:7.0
value of <distinguished name component> | Plain | <string> | Returns the value of the specified component of the distinguished name. Win:7.0

Examples

component 0 of distinguished name "CN=BIGFOOT,CN=Computers,DC=devlan,DC=bigfix,DC=com"
Returns "CN=BIGFOOT".

(type of it, value of it) of components of distinguished name "CN=BIGFOOT,CN=Computers,DC=devlan,DC=bigfix,DC=com"
Returns the list:
• CN, BIGFOOT
• CN, Computers
• DC, devlan
• DC, bigfix
• DC, com.

value of component 0 of distinguished name "CN=BIGFOOT,CN=Computers,DC=devlan,DC=bigfix,DC=com"
Returns "BIGFOOT".


Dmi

The desktop management task force (DMTF) has defined a set of standards and API's for accessing asset data from the BIOS of the PC. A BIOS that supports these interfaces is said to be DMI or SYMBIOS compliant. The amount of information obtainable from the BIOS is highly dependent upon its implementation. "Manageable" PC's often provide some DMI information. Rather than rephrase the entire specification of DMI data structures, we include here only the keywords used to access the data. See the SYMBIOS 2.0 documentation for more details at: http://www.dmtf.org/.
• NOTE: to make the plural of a dmi Inspector, simply add 's'.

Creation Methods

Key Phrase | Form | Description
dmi | PlainGlobal | Creates the global dmi object. If no dmi information is available from the BIOS, creation of the object will fail. Win:1.2, Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
b32_bit_memory_error_information <integer> of <dmi> | Numbered | <dmi b32_bit_memory_error_information> | Lin:4.1
b32_bit_memory_error_information of <dmi> | Plain | <dmi b32_bit_memory_error_information> | Lin:4.1
b64_bit_memory_error_information <integer> of <dmi> | Numbered | <dmi b64_bit_memory_error_information> | Lin:4.1
b64_bit_memory_error_information of <dmi> | Plain | <dmi b64_bit_memory_error_information> | Lin:4.1
base_board_information <integer> of <dmi> | Numbered | <dmi base_board_information> | Lin:4.1
base_board_information of <dmi> | Plain | <dmi base_board_information> | Lin:4.1
bios_information <integer> of <dmi> | Numbered | <dmi bios_information> | Lin:4.1
bios_information of <dmi> | Plain | <dmi bios_information> | Lin:4.1
bios_language_information <integer> of <dmi> | Numbered | <dmi bios_language_information> | Lin:4.1
bios_language_information of <dmi> | Plain | <dmi bios_language_information> | Lin:4.1
built_in_pointing_device <integer> of <dmi> | Numbered | <dmi built_in_pointing_device> | Lin:4.1
built_in_pointing_device of <dmi> | Plain | <dmi built_in_pointing_device> | Lin:4.1
cache_information <integer> of <dmi> | Numbered | <dmi cache_information> | Lin:4.1
cache_information of <dmi> | Plain | <dmi cache_information> | Lin:4.1
cooling_device <integer> of <dmi> | Numbered | <dmi cooling_device> | Lin:4.1
cooling_device of <dmi> | Plain | <dmi cooling_device> | Lin:4.1
electrical_current_probe <integer> of <dmi> | Numbered | <dmi electrical_current_probe> | Lin:4.1
electrical_current_probe of <dmi> | Plain | <dmi electrical_current_probe> | Lin:4.1
end_of_table <integer> of <dmi> | Numbered | <dmi end_of_table> | Lin:4.1
end_of_table of <dmi> | Plain | <dmi end_of_table> | Lin:4.1
group_associations <integer> of <dmi> | Numbered | <dmi group_associations> | Lin:4.1
group_associations of <dmi> | Plain | <dmi group_associations> | Lin:4.1
hardware_security <integer> of <dmi> | Numbered | <dmi hardware_security> | Lin:4.1
hardware_security of <dmi> | Plain | <dmi hardware_security> | Lin:4.1
inactive <integer> of <dmi> | Numbered | <dmi inactive> | Lin:4.1
inactive of <dmi> | Plain | <dmi inactive> | Lin:4.1
management_device <integer> of <dmi> | Numbered | <dmi management_device> | Lin:4.1
management_device of <dmi> | Plain | <dmi management_device> | Lin:4.1
management_device_component <integer> of <dmi> | Numbered | <dmi management_device_component> | Lin:4.1
management_device_component of <dmi> | Plain | <dmi management_device_component> | Lin:4.1
management_device_threshold_data <integer> of <dmi> | Numbered | <dmi management_device_threshold_data> | Lin:4.1
management_device_threshold_data of <dmi> | Plain | <dmi management_device_threshold_data> | Lin:4.1
memory_array_mapped_address <integer> of <dmi> | Numbered | <dmi memory_array_mapped_address> | Lin:4.1
memory_array_mapped_address of <dmi> | Plain | <dmi memory_array_mapped_address> | Lin:4.1
memory_controller_information <integer> of <dmi> | Numbered | <dmi memory_controller_information> | Lin:4.1
memory_controller_information of <dmi> | Plain | <dmi memory_controller_information> | Lin:4.1
memory_device <integer> of <dmi> | Numbered | <dmi memory_device> | Lin:4.1
memory_device of <dmi> | Plain | <dmi memory_device> | Lin:4.1
memory_device_mapped_address <integer> of <dmi> | Numbered | <dmi memory_device_mapped_address> | Lin:4.1
memory_device_mapped_address of <dmi> | Plain | <dmi memory_device_mapped_address> | Lin:4.1
memory_module_information <integer> of <dmi> | Numbered | <dmi memory_module_information> | Lin:4.1
memory_module_information of <dmi> | Plain | <dmi memory_module_information> | Lin:4.1
oem_string <integer> of <dmi> | Numbered | <string> | Returns the OEM string corresponding to the given integer of the DMI object. Win:1.2, Lin:4.1
oem_string of <dmi> | Plain | <string> | Returns the OEM string corresponding to the specified DMI object. Win:1.2, Lin:4.1
on_board_devices_information <integer> of <dmi> | Numbered | <dmi on_board_devices_information> | Lin:4.1
on_board_devices_information of <dmi> | Plain | <dmi on_board_devices_information> | Lin:4.1
out_of_band_remote_access <integer> of <dmi> | Numbered | <dmi out_of_band_remote_access> | Lin:4.1
out_of_band_remote_access of <dmi> | Plain | <dmi out_of_band_remote_access> | Lin:4.1
physical_memory_array <integer> of <dmi> | Numbered | <dmi physical_memory_array> | Lin:4.1
physical_memory_array of <dmi> | Plain | <dmi physical_memory_array> | Lin:4.1
port_connector_information <integer> of <dmi> | Numbered | <dmi port_connector_information> | Lin:4.1
port_connector_information of <dmi> | Plain | <dmi port_connector_information> | Lin:4.1
portable_battery <integer> of <dmi> | Numbered | <dmi portable_battery> | Lin:4.1
portable_battery of <dmi> | Plain | <dmi portable_battery> | Lin:4.1
processor_information <integer> of <dmi> | Numbered | <dmi processor_information> | Lin:4.1
processor_information of <dmi> | Plain | <dmi processor_information> | Lin:4.1
system_boot_information <integer> of <dmi> | Numbered | <dmi system_boot_information> | Lin:4.1
system_boot_information of <dmi> | Plain | <dmi system_boot_information> | Lin:4.1
system_configuration_option <integer> of <dmi> | Numbered | <string> | Lin:4.1
system_configuration_option of <dmi> | Plain | <string> | Lin:4.1
system_enclosure_or_chassis <integer> of <dmi> | Numbered | <dmi system_enclosure_or_chassis> | Lin:4.1
system_enclosure_or_chassis of <dmi> | Plain | <dmi system_enclosure_or_chassis> | Lin:4.1
system_information <integer> of <dmi> | Numbered | <dmi system_information> | Lin:4.1
system_information of <dmi> | Plain | <dmi system_information> | Lin:4.1
system_power_controls <integer> of <dmi> | Numbered | <dmi system_power_controls> | Lin:4.1
system_power_controls of <dmi> | Plain | <dmi system_power_controls> | Lin:4.1
system_reset <integer> of <dmi> | Numbered | <dmi system_reset> | Lin:4.1
system_reset of <dmi> | Plain | <dmi system_reset> | Lin:4.1
system_slots <integer> of <dmi> | Numbered | <dmi system_slots> | Lin:4.1
system_slots of <dmi> | Plain | <dmi system_slots> | Lin:4.1
temperature_probe <integer> of <dmi> | Numbered | <dmi temperature_probe> | Lin:4.1
temperature_probe of <dmi> | Plain | <dmi temperature_probe> | Lin:4.1
voltage_probe <integer> of <dmi> | Numbered | <dmi voltage_probe> | Lin:4.1
voltage_probe of <dmi> | Plain | <dmi voltage_probe> | Lin:4.1


Dmi B32_bit_memory_error_information

Creation Methods

Key Phrase | Form | Description
b32_bit_memory_error_information <integer> of <dmi> | Numbered | Lin:4.1
b32_bit_memory_error_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
device_error_address of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_granularity of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_operation of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_resolution of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_type of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
length of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
memory_array_error_address of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1
vendor_syndrome of <dmi b32_bit_memory_error_information> | Plain | <integer> | Lin:4.1


Dmi B64_bit_memory_error_information

Creation Methods

Key Phrase | Form | Description
b64_bit_memory_error_information <integer> of <dmi> | Numbered | Lin:4.1
b64_bit_memory_error_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
device_error_address of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_granularity of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_operation of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_resolution of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
error_type of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
length of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
memory_array_error_address of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1
vendor_syndrome of <dmi b64_bit_memory_error_information> | Plain | <integer> | Lin:4.1


Dmi Base_board_information

Creation Methods

Key Phrase | Form | Description
base_board_information <integer> of <dmi> | Numbered | Lin:4.1
base_board_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi base_board_information> | Plain | <integer> | Lin:4.1
manufacturer of <dmi base_board_information> | Plain | <string> | Lin:4.1
product of <dmi base_board_information> | Plain | <string> | Lin:4.1
serial_number of <dmi base_board_information> | Plain | <string> | Lin:4.1
version of <dmi base_board_information> | Plain | <string> | Lin:4.1


Dmi Bios_information

Creation Methods

Key Phrase | Form | Description
bios_information <integer> of <dmi> | Numbered | Lin:4.1
bios_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
bios_characteristics of <dmi bios_information> | Plain | <integer> | Lin:4.1
bios_release_date of <dmi bios_information> | Plain | <string> | Lin:4.1
bios_rom_size of <dmi bios_information> | Plain | <integer> | Lin:4.1
bios_starting_address_segment of <dmi bios_information> | Plain | <integer> | Lin:4.1
bios_version of <dmi bios_information> | Plain | <string> | Lin:4.1
length of <dmi bios_information> | Plain | <integer> | Lin:4.1
vendor of <dmi bios_information> | Plain | <string> | Lin:4.1


Dmi Bios_language_information

Creation Methods

Key Phrase | Form | Description
bios_language_information <integer> of <dmi> | Numbered | Lin:4.1
bios_language_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
current_language of <dmi bios_language_information> | Plain | <string> | Lin:4.1
flags of <dmi bios_language_information> | Plain | <integer> | Lin:4.1
installable_languages of <dmi bios_language_information> | Plain | <integer> | Lin:4.1
length of <dmi bios_language_information> | Plain | <integer> | Lin:4.1


Dmi Built_in_pointing_device

Creation Methods

Key Phrase | Form | Description
built_in_pointing_device <integer> of <dmi> | Numbered | Lin:4.1
built_in_pointing_device of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
interface of <dmi built_in_pointing_device> | Plain | <integer> | Lin:4.1
length of <dmi built_in_pointing_device> | Plain | <integer> | Lin:4.1
number_of_buttons of <dmi built_in_pointing_device> | Plain | <integer> | Lin:4.1
type of <dmi built_in_pointing_device> | Plain | <integer> | Lin:4.1


Dmi Cache_information

Creation Methods

Key Phrase | Form | Description
cache_information <integer> of <dmi> | Numbered | Lin:4.1
cache_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
associativity of <dmi cache_information> | Plain | <integer> | Lin:4.1
cache_configuration of <dmi cache_information> | Plain | <integer> | Lin:4.1
cache_speed of <dmi cache_information> | Plain | <integer> | Lin:4.1
current_sram_type of <dmi cache_information> | Plain | <integer> | Lin:4.1
error_correction_type of <dmi cache_information> | Plain | <integer> | Lin:4.1
installed_size of <dmi cache_information> | Plain | <integer> | Lin:4.1
length of <dmi cache_information> | Plain | <integer> | Lin:4.1
maximum_cache_size of <dmi cache_information> | Plain | <integer> | Lin:4.1
socket_designation of <dmi cache_information> | Plain | <string> | Lin:4.1
supported_sram_type of <dmi cache_information> | Plain | <integer> | Lin:4.1
system_cache_type of <dmi cache_information> | Plain | <integer> | Lin:4.1


Dmi Cooling_device

Creation Methods

Key Phrase | Form | Description
cooling_device <integer> of <dmi> | Numbered | Lin:4.1
cooling_device of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
cooling_unit_group of <dmi cooling_device> | Plain | <integer> | Lin:4.1
device_type_and_status of <dmi cooling_device> | Plain | <integer> | Lin:4.1
length of <dmi cooling_device> | Plain | <integer> | Lin:4.1
nominal_speed of <dmi cooling_device> | Plain | <integer> | Lin:4.1
oem_defined of <dmi cooling_device> | Plain | <integer> | Lin:4.1
temperature_probe_handle of <dmi cooling_device> | Plain | <integer> | Lin:4.1


Dmi Electrical_current_probe

Creation Methods

Key Phrase | Form | Description
electrical_current_probe <integer> of <dmi> | Numbered | Lin:4.1
electrical_current_probe of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
accuracy of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
description of <dmi electrical_current_probe> | Plain | <string> | Lin:4.1
length of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
location_and_status of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
maximum_value of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
minimum_value of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
nominal_value of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
oem_defined of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
resolution of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1
tolerance of <dmi electrical_current_probe> | Plain | <integer> | Lin:4.1


Dmi End_of_table

Creation Methods

Key Phrase | Form | Description
end_of_table <integer> of <dmi> | Numbered | Lin:4.1
end_of_table of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi end_of_table> | Plain | <integer> | Lin:4.1


Dmi Group_associations

Creation Methods

Key Phrase | Form | Description
group_associations <integer> of <dmi> | Numbered | Lin:4.1
group_associations of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
group_name of <dmi group_associations> | Plain | <string> | Lin:4.1
item_handle of <dmi group_associations> | Plain | <integer> | Lin:4.1
item_type of <dmi group_associations> | Plain | <integer> | Lin:4.1
length of <dmi group_associations> | Plain | <integer> | Lin:4.1


Dmi Hardware_security

Creation Methods

Key Phrase | Form | Description
hardware_security <integer> of <dmi> | Numbered | Lin:4.1
hardware_security of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
hardware_security_settings of <dmi hardware_security> | Plain | <integer> | Lin:4.1
length of <dmi hardware_security> | Plain | <integer> | Lin:4.1


Dmi Inactive

Creation Methods

Key Phrase | Form | Description
inactive <integer> of <dmi> | Numbered | Lin:4.1
inactive of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi inactive> | Plain | <integer> | Lin:4.1


Dmi Management_device

Creation Methods

Key Phrase | Form | Description
management_device <integer> of <dmi> | Numbered | Lin:4.1
management_device of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
address of <dmi management_device> | Plain | <integer> | Lin:4.1
address_type of <dmi management_device> | Plain | <integer> | Lin:4.1
description of <dmi management_device> | Plain | <string> | Lin:4.1
length of <dmi management_device> | Plain | <integer> | Lin:4.1
type of <dmi management_device> | Plain | <integer> | Lin:4.1


Dmi Management_device_component

Creation Methods

Key Phrase | Form | Description
management_device_component <integer> of <dmi> | Numbered | Lin:4.1
management_device_component of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
component_handle of <dmi management_device_component> | Plain | <integer> | Lin:4.1
description of <dmi management_device_component> | Plain | <string> | Lin:4.1
length of <dmi management_device_component> | Plain | <integer> | Lin:4.1
management_device_handle of <dmi management_device_component> | Plain | <integer> | Lin:4.1
threshold_handle of <dmi management_device_component> | Plain | <integer> | Lin:4.1


Dmi Management_device_threshold_data

Creation Methods

Key Phrase | Form | Description
management_device_threshold_data <integer> of <dmi> | Numbered | Lin:4.1
management_device_threshold_data of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
lower_threshold_critical of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
lower_threshold_non_critical of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
lower_threshold_non_recoverable of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
upper_threshold_critical of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
upper_threshold_non_critical of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1
upper_threshold_non_recoverable of <dmi management_device_threshold_data> | Plain | <integer> | Lin:4.1


Dmi Memory_array_mapped_address

Creation Methods

Key Phrase | Form | Description
memory_array_mapped_address <integer> of <dmi> | Numbered | Lin:4.1
memory_array_mapped_address of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
ending_address of <dmi memory_array_mapped_address> | Plain | <integer> | Lin:4.1
length of <dmi memory_array_mapped_address> | Plain | <integer> | Lin:4.1
memory_array_handle of <dmi memory_array_mapped_address> | Plain | <integer> | Lin:4.1
partition_width of <dmi memory_array_mapped_address> | Plain | <integer> | Lin:4.1
starting_address of <dmi memory_array_mapped_address> | Plain | <integer> | Lin:4.1


Dmi Memory_controller_information

Creation Methods

Key Phrase | Form | Description
memory_controller_information <integer> of <dmi> | Numbered | Lin:4.1
memory_controller_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
current_interleave of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
error_correcting_capability of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
error_detecting_method of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
length of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
maximum_memory_module_size of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
memory_module_voltage of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
number_of_associated_memory_slots of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
supported_interleave of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
supported_memory_types of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1
supported_speeds of <dmi memory_controller_information> | Plain | <integer> | Lin:4.1


Dmi Memory_device

Creation Methods

Key Phrase | Form | Description
memory_device <integer> of <dmi> | Numbered | Lin:4.1
memory_device of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
bank_locator of <dmi memory_device> | Plain | <string> | Lin:4.1
data_width of <dmi memory_device> | Plain | <integer> | Lin:4.1
device_locator of <dmi memory_device> | Plain | <string> | Lin:4.1
device_set of <dmi memory_device> | Plain | <integer> | Lin:4.1
form_factor of <dmi memory_device> | Plain | <integer> | Lin:4.1
length of <dmi memory_device> | Plain | <integer> | Lin:4.1
memory_array_handle of <dmi memory_device> | Plain | <integer> | Lin:4.1
memory_error_information_handle of <dmi memory_device> | Plain | <integer> | Lin:4.1
memory_type of <dmi memory_device> | Plain | <integer> | Lin:4.1
size of <dmi memory_device> | Plain | <integer> | Lin:4.1
speed of <dmi memory_device> | Plain | <integer> | Lin:4.1
total_width of <dmi memory_device> | Plain | <integer> | Lin:4.1
type_detail of <dmi memory_device> | Plain | <integer> | Lin:4.1


Dmi Memory_device_mapped_address

Creation Methods

Key Phrase | Form | Description
memory_device_mapped_address <integer> of <dmi> | Numbered | Lin:4.1
memory_device_mapped_address of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
ending_address of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
interleave_position of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
interleaved_data_depth of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
length of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
memory_array_mapped_address_handle of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
memory_device_handle of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
partition_row_position of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1
starting_address of <dmi memory_device_mapped_address> | Plain | <integer> | Lin:4.1


Dmi Memory_module_information

Creation Methods

Key Phrase | Form | Description
memory_module_information <integer> of <dmi> | Numbered | Lin:4.1
memory_module_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
bank_connections of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
current_memory_type of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
current_speed of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
enabled_size of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
error_status of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
installed_size of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
length of <dmi memory_module_information> | Plain | <integer> | Lin:4.1
socket_designation of <dmi memory_module_information> | Plain | <string> | Lin:4.1


Dmi On_board_devices_information

Creation Methods

Key Phrase | Form | Description
on_board_devices_information <integer> of <dmi> | Numbered | Lin:4.1
on_board_devices_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
device_description <integer> of <dmi on_board_devices_information> | Numbered | <string> | Lin:4.1
device_description of <dmi on_board_devices_information> | Plain | <string> | Lin:4.1
device_type <integer> of <dmi on_board_devices_information> | Numbered | <integer> | Lin:4.1
device_type of <dmi on_board_devices_information> | Plain | <integer> | Lin:4.1
length of <dmi on_board_devices_information> | Plain | <integer> | Lin:4.1


Dmi Out_of_band_remote_access

Creation Methods

Key Phrase | Form | Description
out_of_band_remote_access <integer> of <dmi> | Numbered | Lin:4.1
out_of_band_remote_access of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
connections of <dmi out_of_band_remote_access> | Plain | <integer> | Lin:4.1
length of <dmi out_of_band_remote_access> | Plain | <integer> | Lin:4.1
manufacturer_name of <dmi out_of_band_remote_access> | Plain | <string> | Lin:4.1


Dmi Physical_memory_array

Creation Methods

Key Phrase | Form | Description
physical_memory_array <integer> of <dmi> | Numbered | Lin:4.1
physical_memory_array of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
location of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
maximum_capacity of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
memory_error_correction of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
memory_error_information_handle of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
number_of_memory_devices of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1
use of <dmi physical_memory_array> | Plain | <integer> | Lin:4.1


Dmi Port_connector_information

Creation Methods

Key Phrase | Form | Description
port_connector_information <integer> of <dmi> | Numbered | Lin:4.1
port_connector_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
external_connector_type of <dmi port_connector_information> | Plain | <integer> | Lin:4.1
external_reference_designator of <dmi port_connector_information> | Plain | <string> | Lin:4.1
internal_connector_type of <dmi port_connector_information> | Plain | <integer> | Lin:4.1
internal_reference_designator of <dmi port_connector_information> | Plain | <string> | Lin:4.1
length of <dmi port_connector_information> | Plain | <integer> | Lin:4.1
port_type of <dmi port_connector_information> | Plain | <integer> | Lin:4.1


Dmi Portable_battery

Creation Methods

Key Phrase | Form | Description
portable_battery <integer> of <dmi> | Numbered | Lin:4.1
portable_battery of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
design_capacity of <dmi portable_battery> | Plain | <integer> | Lin:4.1
design_capacity_multiplier of <dmi portable_battery> | Plain | <integer> | Lin:4.1
design_voltage of <dmi portable_battery> | Plain | <integer> | Lin:4.1
device_chemistry of <dmi portable_battery> | Plain | <integer> | Lin:4.1
device_name of <dmi portable_battery> | Plain | <string> | Lin:4.1
length of <dmi portable_battery> | Plain | <integer> | Lin:4.1
location of <dmi portable_battery> | Plain | <string> | Lin:4.1
manufacture_date of <dmi portable_battery> | Plain | <string> | Lin:4.1
manufacturer of <dmi portable_battery> | Plain | <string> | Lin:4.1
maximum_error_in_battery_data of <dmi portable_battery> | Plain | <integer> | Lin:4.1
oem_specific of <dmi portable_battery> | Plain | <integer> | Lin:4.1
sbds_device_chemistry of <dmi portable_battery> | Plain | <string> | Lin:4.1
sbds_manufacture_date of <dmi portable_battery> | Plain | <integer> | Lin:4.1
sbds_serial_number of <dmi portable_battery> | Plain | <integer> | Lin:4.1
sbds_version_number of <dmi portable_battery> | Plain | <string> | Lin:4.1
serial_number of <dmi portable_battery> | Plain | <string> | Lin:4.1


Dmi Processor_information

Creation Methods

Key Phrase | Form | Description
processor_information <integer> of <dmi> | Numbered | Lin:4.1
processor_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
current_speed of <dmi processor_information> | Plain | <integer> | Lin:4.1
external_clock of <dmi processor_information> | Plain | <integer> | Lin:4.1
l1_cache_handle of <dmi processor_information> | Plain | <integer> | Lin:4.1
l2_cache_handle of <dmi processor_information> | Plain | <integer> | Lin:4.1
l3_cache_handle of <dmi processor_information> | Plain | <integer> | Lin:4.1
length of <dmi processor_information> | Plain | <integer> | Lin:4.1
max_speed of <dmi processor_information> | Plain | <integer> | Lin:4.1
processor_family of <dmi processor_information> | Plain | <integer> | Lin:4.1
processor_id of <dmi processor_information> | Plain | <integer> | Lin:4.1
processor_manufacturer of <dmi processor_information> | Plain | <string> | Lin:4.1
processor_type of <dmi processor_information> | Plain | <integer> | Lin:4.1
processor_upgrade of <dmi processor_information> | Plain | <integer> | Lin:4.1
processor_version of <dmi processor_information> | Plain | <string> | Lin:4.1
socket_designation of <dmi processor_information> | Plain | <string> | Lin:4.1
status of <dmi processor_information> | Plain | <integer> | Lin:4.1
voltage of <dmi processor_information> | Plain | <integer> | Lin:4.1


Dmi System_boot_information

Creation Methods

Key Phrase | Form | Description
system_boot_information <integer> of <dmi> | Numbered | Lin:4.1
system_boot_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi system_boot_information> | Plain | <integer> | Lin:4.1


Dmi System_enclosure_or_chassis

Creation Methods

Key Phrase | Form | Description
system_enclosure_or_chassis <integer> of <dmi> | Numbered | Lin:4.1
system_enclosure_or_chassis of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
asset_tag_number of <dmi system_enclosure_or_chassis> | Plain | <string> | Lin:4.1
bootup_state of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
length of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
manufacturer of <dmi system_enclosure_or_chassis> | Plain | <string> | Lin:4.1
oem_defined of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
power_supply_state of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
security_status of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
serial_number of <dmi system_enclosure_or_chassis> | Plain | <string> | Lin:4.1
thermal_state of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
type of <dmi system_enclosure_or_chassis> | Plain | <integer> | Lin:4.1
version of <dmi system_enclosure_or_chassis> | Plain | <string> | Lin:4.1


Dmi System_information

Creation Methods

Key Phrase | Form | Description
system_information <integer> of <dmi> | Numbered | Lin:4.1
system_information of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi system_information> | Plain | <integer> | Lin:4.1
manufacturer of <dmi system_information> | Plain | <string> | Lin:4.1
product_name of <dmi system_information> | Plain | <string> | Lin:4.1
serial_number of <dmi system_information> | Plain | <string> | Lin:4.1
version of <dmi system_information> | Plain | <string> | Lin:4.1
wake_up_type of <dmi system_information> | Plain | <integer> | Lin:4.1


Dmi System_power_controls

Creation Methods

Key Phrase | Form | Description
system_power_controls <integer> of <dmi> | Numbered | Lin:4.1
system_power_controls of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <dmi system_power_controls> | Plain | <integer> | Lin:4.1
next_scheduled_power_on_day_of_month of <dmi system_power_controls> | Plain | <integer> | Lin:4.1
next_scheduled_power_on_hour of <dmi system_power_controls> | Plain | <integer> | Lin:4.1
next_scheduled_power_on_minute of <dmi system_power_controls> | Plain | <integer> | Lin:4.1
next_scheduled_power_on_month of <dmi system_power_controls> | Plain | <integer> | Lin:4.1
next_scheduled_power_on_second of <dmi system_power_controls> | Plain | <integer> | Lin:4.1


Dmi System_reset

Creation Methods

Key Phrase | Form | Description
system_reset <integer> of <dmi> | Numbered | Lin:4.1
system_reset of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
capabilities of <dmi system_reset> | Plain | <integer> | Lin:4.1
length of <dmi system_reset> | Plain | <integer> | Lin:4.1
reset_count of <dmi system_reset> | Plain | <integer> | Lin:4.1
reset_limit of <dmi system_reset> | Plain | <integer> | Lin:4.1
timeout of <dmi system_reset> | Plain | <integer> | Lin:4.1
timer_interval of <dmi system_reset> | Plain | <integer> | Lin:4.1


Dmi System_slots

Creation Methods

Key Phrase | Form | Description
system_slots <integer> of <dmi> | Numbered | Lin:4.1
system_slots of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
current_usage of <dmi system_slots> | Plain | <integer> | Lin:4.1
length of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_characteristics_1 of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_characteristics_2 of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_data_bus_width of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_designation of <dmi system_slots> | Plain | <string> | Lin:4.1
slot_id of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_length of <dmi system_slots> | Plain | <integer> | Lin:4.1
slot_type of <dmi system_slots> | Plain | <integer> | Lin:4.1


Dmi Temperature_probe

Creation Methods

Key Phrase | Form | Description
temperature_probe <integer> of <dmi> | Numbered | Lin:4.1
temperature_probe of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
accuracy of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
description of <dmi temperature_probe> | Plain | <string> | Lin:4.1
length of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
location_and_status of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
maximum_value of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
minimum_value of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
nominal_value of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
oem_defined of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
resolution of <dmi temperature_probe> | Plain | <integer> | Lin:4.1
tolerance of <dmi temperature_probe> | Plain | <integer> | Lin:4.1


Dmi Voltage_probe

Creation Methods

Key Phrase | Form | Description
voltage_probe <integer> of <dmi> | Numbered | Lin:4.1
voltage_probe of <dmi> | Plain | Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
accuracy of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
description of <dmi voltage_probe> | Plain | <string> | Lin:4.1
length of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
location_and_status of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
maximum_value of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
minimum_value of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
nominal_value of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
oem_defined of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
resolution of <dmi voltage_probe> | Plain | <integer> | Lin:4.1
tolerance of <dmi voltage_probe> | Plain | <integer> | Lin:4.1


Domain

Mac OS X defines several file system domains to control access to system resources on multi-user systems. These include the User, Local, Network, Classic and System domains. The domain for a given resource or folder determines its accessibility to the user. For example, while a user-installed font is only available to that user, an administrator-installed font is available to all network users. The following Inspectors allow folder access to be parceled out according to domain.
• NOTE: The "user domain" refers to the root user, not the currently logged in user.

Creation Methods

Key Phrase | Form | Description
classic domain | PlainGlobal | Returns a classic domain object. Mac:5.1
local domain | PlainGlobal | Returns a local domain object. Mac:5.1
network domain | PlainGlobal | Returns a network domain object. Mac:5.1
on appropriate disk domain | PlainGlobal | Returns one of the Macintosh domains. In most cases, this is the equivalent of kOnAppropriateDisk. On Mac OS X, this constant is used instead of the constant kOnSytemDisk to indicate any disk. For more information, see the Apple documentation on Carbon domain constants. Mac:5.1
on system disk domain | PlainGlobal | Returns the OnSystemDisk domain. Mac:5.1
system domain | PlainGlobal | Returns a system domain object. Mac:5.1
user domain | PlainGlobal | Returns a user domain object. • NOTE: The "user domain" refers to the root user, not the currently logged in user. Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
apple extras folder of <domain> | Plain | <folder> | Returns the apple extras folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
apple menu items folder of <domain> | Plain | <folder> | Returns the apple menu items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
application support folder of <domain> | Plain | <folder> | Returns the application support folder of the specified OS X domain, typically /Library/Application Support. If the domain is not specified, it defaults to the system domain. Mac:5.1
applications folder of <domain> | Plain | <folder> | Returns the applications folder of the specified OS X domain, typically /Applications. If the domain is not specified, it defaults to the system domain. Mac:5.1
assistants folder of <domain> | Plain | <folder> | Returns the assistants folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
audio folder of <domain> | Plain | <folder> | Returns the audio folder of the specified OS X domain, typically /Library/Audio. If the domain is not specified, it defaults to the system domain. Mac:5.1
cache folder of <domain> | Plain | <folder> | Returns the cache folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
carbon folder of <domain> | Plain | <folder> | Returns the carbon folder of the specified OS X domain, typically /Library/Carbon. If the domain is not specified, it defaults to the system domain. Mac:5.1
chewable items folder of <domain> | Plain | <folder> | Returns the chewable items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
classic folder of <domain> | Plain | <folder> | Returns the classic folder of the specified OS X domain, typically the /System Folder. If the domain is not specified, it defaults to the system domain. Mac:5.1
color sync folder of <domain> | Plain | <folder> | Returns the color sync folder of the specified OS X domain, typically /System/Library/ColorSync. If the domain is not specified, it defaults to the system domain. Mac:5.1
colorsync profiles folder of <domain> | Plain | <folder> | Returns the colorsync profiles folder of the specified OS X domain, typically /System/Library/ColorSync/Profiles. If the domain is not specified, it defaults to the system domain. Mac:5.1
component folder of <domain> | Plain | <folder> | Returns the component folder of the specified OS X domain, typically /System/Library/Components. If the domain is not specified, it defaults to the system domain. Mac:5.1
contextual menu items folder of <domain> | Plain | <folder> | Returns the contextual menu items folder of the specified OS X domain, typically /Library/Contextual Menu Items. If the domain is not specified, it defaults to the system domain. Mac:5.1
control panels folder of <domain> | Plain | <folder> | Returns the control panels folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
control strip modules folder of <domain> | Plain | <folder> | Returns the control strip modules folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
core services folder of <domain> | Plain | <folder> | Returns the core services folder of the specified OS X domain, typically /System/Library/CoreServices. If the domain is not specified, it defaults to the system domain. Mac:5.1
current user folder of <domain> | Plain | <folder> | Returns the current user folder of the specified OS X domain, typically found at /Users/username. If the domain is not specified, it defaults to the system domain. Mac:5.1
desktop folder of <domain> | Plain | <folder> | Returns the desktop folder of the specified OS X domain, typically /Users/Username/Desktop. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer docs folder of <domain> | Plain | <folder> | Returns the developer docs folder of the specified OS X domain, typically found at /Developer/Documentation. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer folder of <domain> | Plain | <folder> | Returns the developer folder of the specified OS X domain, typically found at /Developer. If the domain is not specified, it defaults to the system domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer help folder of <domain> | Plain | <folder> | Returns the help folder of the specified OS X domain, typically /Developer/Documentation/Help. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled control panels folder of <domain> | Plain | <folder> | Returns the control panels folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled extensions folder of <domain> | Plain | <folder> | Returns the extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled shutdown items folder of <domain> | Plain | <folder> | Returns the shutdown folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled startup items folder of <domain> | Plain | <folder> | Returns the startup items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled system extensions folder of <domain> | Plain | <folder> | Returns the systems extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
documentation folder of <domain> | Plain | <folder> | Returns the documentation folder for the given OS X domain, typically found at /Library/Documentation. If the domain is not specified, it defaults to the system domain. Mac:5.1
documents folder of <domain> | Plain | <folder> | Returns the documents folder for the specified OS X domain, typically found at /User/Username/Documents. If the domain is not specified, it defaults to the system domain. Mac:5.1
domain library folder of <domain> | Plain | <folder> | Returns the domain library folder of the specified OS X domain, typically found at /Library. If the domain is not specified, it defaults to the system domain. Mac:5.1
domain top folder of <domain> | Plain | <folder> | Returns the top folder of the specified OS X domain, typically found at /System. If the domain is not specified, it defaults to the system domain. Mac:5.1
extensions folder of <domain> | Plain | <folder> | Returns the extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
favorites folder of <domain> | Plain | <folder> | Returns the favorites folder of the specified OS X domain, typically /Users/username/Library/Favorites. If the domain is not specified, it defaults to the system domain. Mac:5.1
fonts folder of <domain> | Plain | <folder> | Returns the font folder of the specified OS X domain, typically /System/Library/Fonts. If the domain is not specified, it defaults to the system domain. Mac:5.1
framework <string> of <domain> | Named | <folder> | Returns a folder of the form "/System/Library/Frameworks/<string>.framework”. • Note: This Inspector appends .framework for you, so don't provide it. The framework inspector needs a domain, and without it defaults to the system domain. Mac:5.1
framework folder of <domain> | Plain | <folder> | Returns the framework folder of the specified OS X domain, typically /System/Library/Frameworks. If the domain is not specified, it defaults to the system domain. Mac:5.1
help folder of <domain> | Plain | <folder> | Returns the help folder of the specified OS X domain, typically /Library/Documentation/Help. If the domain is not specified, it defaults to the system domain. Mac:5.1
internet plugins folder of <domain> | Plain | <folder> | Returns the internet plugins folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
iss download folder of <domain> | Plain | <folder> | Returns the Macintosh download folder for the specified domain. Mac:7.2
kernel extensions folder of <domain> | Plain | <folder> | Returns the kernel extensions folder of the specified OS X domain, typically /System/Library/Extensions. If the domain is not specified, it defaults to the system domain. Mac:5.1
locales folder of <domain> | Plain | <folder> | Returns the locales folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
location manager modules folder of <domain> | Plain | <folder> | Returns the location manager modules folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
location manager preferences folder of <domain> | Plain | <folder> | Returns the location manager preferences folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
locations folder of <domain> | Plain | <folder> | Returns the locations folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
macos read me folder of <domain> | Plain | <folder> | Returns the Mac OS read me folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
modem scripts folder of <domain> | Plain | <folder> | Returns the modem scripts folder of the specified OS X domain, typically /System/Library/Modem Scripts. If the domain is not specified, it defaults to the system domain. Mac:5.1
preferences folder of <domain> | Plain | <folder> | Returns the preferences folder of the specified OS X domain, typically /Users/username/Library/Preferences. If the domain is not specified, it defaults to the system domain. Mac:5.1
printer descriptions folder of <domain> | Plain | <folder> | Returns the printer descriptions folder of the specified OS X domain, typically /System/Library/Printers/PPDs. If the domain is not specified, it defaults to the system domain. Mac:5.1
printer drivers folder of <domain> | Plain | <folder> | Returns the printer drivers folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
printers folder of <domain> | Plain | <folder> | Returns the printers folder of the specified OS X domain, typically /System/Library/Printers. If the domain is not specified, it defaults to the system domain. Mac:5.1
printmonitor documents folder of <domain> | Plain | <folder> | Returns the printmonitor documents folder of the specified OS X domain, typically /Library/Printers/PrintMonitor Documents. If the domain is not specified, it defaults to the system domain. Mac:5.1
private framework folder of <domain> | Plain | <folder> | Returns the private framework folder of the specified OS X domain, typically /System/Library/PrivateFrameworks. If the domain is not specified, it defaults to the system domain. Mac:5.1
quicktime folder of <domain> | Plain | <folder> | Returns the quicktime folder of the specified OS X domain, typically /System/Library/QuickTime. If the domain is not specified, it defaults to the system domain. Mac:5.1
receipts folder of <domain> | Plain | <folder> | Returns the receipts folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
scripting additions folder of <domain> | Plain | <folder> | Returns the scripting additions folder of the specified OS X domain, typically /System/Library/Scripting Additions. If the domain is not specified, it defaults to the system domain. Mac:5.1
shared folder of <domain> | Plain | <folder> | Returns the shared folder of the specified OS X domain, typically /Users/Shared. If the domain is not specified, it defaults to the system domain. Mac:5.1
shared libraries folder of <domain> | Plain | <folder> | Returns the shared libraries folder of the specified OS X domain, typically /System/Library/CFMSupport. If the domain is not specified, it defaults to the system domain. Mac:5.1
shutdown items folder of <domain> | Plain | <folder> | Returns the shutdown items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
sound folder of <domain> | Plain | <folder> | Returns the sound folder of the specified OS X domain, typically /System/Library/Sound. If the domain is not specified, it defaults to the system domain. Mac:5.1
speech folder of <domain> | Plain | <folder> | Returns the speech folder of the specified OS X domain, typically /System/Library/Speech. If the domain is not specified, it defaults to the system domain. Mac:5.1
startup items folder of <domain> | Plain | <folder> | Returns the startup items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
system folder of <domain> | Plain | <folder> | Returns the system folder of the specified OS X domain, typically /System. If the domain is not specified, it defaults to the system domain. Mac:5.1
temporary items folder of <domain> | Plain | <folder> | Returns the temporary items folder of the specified OS X domain, typically /private/tmp/. If the domain is not specified, it defaults to the system domain. Mac:5.1
text encodings folder of <domain> | Plain | <folder> | Returns the text encodings folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
themes folder of <domain> | Plain | <folder> | Returns the themes folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
user temp folder of <domain> | Plain | <folder> | Returns the user temp folder of the specified OS X domain, typically /private/tmp/uid where uid is the user ID number. If the domain is not specified, it defaults to the system domain. Mac:5.1
users folder of <domain> | Plain | <folder> | Returns the users folder of the specified OS X domain, typically /Users. If the domain is not specified, it defaults to the system domain. Mac:5.1
utilities folder of <domain> | Plain | <folder> | Returns the utilities folder of the specified OS X domain, typically /Applications/Utilities. If the domain is not specified, it defaults to the system domain. Mac:5.1
voices folder of <domain> | Plain | <folder> | Returns the voices folder of the specified OS X domain, typically /System/Library/Speech/Voices. If the domain is not specified, it defaults to the system domain. Mac:5.1
volume settings folder of <domain> | Plain | <folder> | Returns the volume settings folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1


Drive

The drive object is available to inspect these aspects of the file system.

Creation Methods

Key Phrase | Form | Description
drive | PlainGlobal | Iterates through all valid drives on the system. Win:1.2
drive <string> | NamedGlobal | Creates the drive object for the name specified. Win:1.2
drive of <filesystem object> | Plain | Returns the drive associated with the specified file or folder (filesystem object). Win:6.0

Properties

Key Phrase | Form | Return Type | Description
file system type of <drive> | Plain | <string> | Value as reported by GetVolumeInformation. Win:1.2
file_supports_encryption of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
file_supports_object_ids of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
file_supports_reparse_points of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
file_supports_sparse_files of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
file_volume_quotas of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
folder <string> of <drive> | Named | <folder> | Returns a folder object corresponding to the name given provided that folder exists on the drive. Win:1.2
free space of <drive> | Plain | <integer> | Returns the number of unused bytes of storage for the drive. (Only available for fixed disks). Win:1.2
fs_case_is_preserved of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
fs_case_sensitive of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
fs_file_compression of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
fs_persistent_acls of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
fs_unicode_stored_on_disk of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
fs_vol_is_compressed of <drive> | Plain | <boolean> | TRUE if bit is returned by GetVolumeInformation. Win:1.2
name of <drive> | Plain | <string> | Returns the name of the drive. Names look like 'c:' and 'D:'. Win:1.2
numeric type of <drive> | Plain | <integer> | Returns the type of drive as an integer. Win:1.2
root folder of <drive> | Plain | <folder> | Returns the folder corresponding to the root of the drive. Win:1.2
total space of <drive> | Plain | <integer> | Returns the size in bytes of the drive. (Only available for fixed disks). Win:1.2
type of <drive> | Plain | <string> | Returns the type of drive as a string. Win:1.2

Note

The drive object does not exist if the file is located on a file server. The expression
drive of file "command.com" of folder "\\oak\c\windows"
will fail even though the file exists. Drive objects do not exist for shared files and shared folders unless they have been mapped as a drive letter. The name of drives may be upper or lower case. The type of drive can be inspected. The values as string and integer are:

Type of drive | Numeric type
DRIVE_UNKNOWN | 0
DRIVE_NO_ROOT_DIR | 1
DRIVE_REMOVABLE | 2
DRIVE_FIXED | 3
DRIVE_REMOTE | 4
DRIVE_CDROM | 5
DRIVE_RAMDISK | 6

Examples

free space of drive "c:" < 1000000
Returns TRUE if there is less than one million bytes of space left on drive C.

name of drive of regapp "vshield.exe" as lowercase = "e:"
Returns TRUE if the application exists on drive E.

numeric type of drive "e:" = 5
Returns TRUE if drive E is a CD-ROM. (See notes).

total space of drive "c:" > 2000000000
Returns TRUE when the drive is capable of holding more than 2 billion bytes.

type of drive of the system folder = "DRIVE_FIXED"
Returns TRUE if the system folder is on a fixed disk drive.


Dummy

These Inspectors are place holders for compatability with Windows clients

Creation Methods

Key Phrase | Form | Description
service <string> | NamedGlobal | A dummy inspector to provide compatibility with Windows. Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
state of <dummy> | Plain | <string> | A dummy inspector to provide compatibility with other operating systems. Mac:5.1


Dummy Type

These Inspectors are place holders for compatability with Windows clients

Creation Methods

Key Phrase | Form | Description
registry | PlainGlobal | No meaning on the Macintosh. Included for compatability with other Agents. Mac:4.1

Properties


Environment

Environment variables define a particular set of paths and variables for a computer or an application. These Inspectors let you examine this set.

Creation Methods

Key Phrase | Form | Description
environment | PlainGlobal | Creates the one and only environment object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
variable <string> of <environment> | Named | <environment variable> | Returns an environment variable that matches the given name. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
variable of <environment> | Plain | <environment variable> | Iterates through all the environment variables defined. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Examples

exists environment
TRUE if the computer has an environment object.


Environment Variable

Every variable defined by the environment has both a name and a value. Both names and values are treated as strings.

Creation Methods

Key Phrase | Form | Description
variable <string> of <environment> | Named | Creates the variable of the environment matching the name provided. The capitalization of the name is ignored. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
variable of <environment> | Plain | Iterates through all the environment variables defined. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
<environment variable> as string | Cast | <string> | Casting the variable as a string yields a string containing the variable name and the value of the variable separated by ' = '. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
name of <environment variable> | Plain | <string> | Returns the name of the variable. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
value of <environment variable> | Plain | <string> | Returns the value of the variable. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Examples

exists variable "PATH" of environment
TRUE if a path variable has been defined in this environment.

number of variables of environment
Returns the total number of variables in this environment.


Event Log

These Inspectors return information about the specified Windows Event logs, including the System, Security and the Application log.

Creation Methods

Key Phrase | Form | Description
application event log | PlainGlobal | Returns an object corresponding to an application event log, one of the event logs created by most Windows systems. Win:6.0
event log <string> | NamedGlobal | Returns the event log object with the specified name. Win:6.0
security event log | PlainGlobal | Returns an event log object for the security event log. Win:6.0
system event log | PlainGlobal | Returns a system event log, which records OS or component events, such as the failure of a bootup service. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
oldest record number of <event log> | Plain | <integer> | Returns an integer corresponding to the oldest record number on the Client computer's event log. Win:6.0
record <integer> of <event log> | Numbered | <event log record> | Returns the nth record corresponding to the specified event log. Win:6.0
record count of <event log> | Plain | <integer> | Returns the record count for the specified event log. Win:6.0
record of <event log> | Plain | <event log record> | Returns the record corresponding to the specified event log, for instance the application or system event log. Win:6.0


Event Log Event Type

These Inspectors return information about the types of Windows Event log entries, which record various operating system events including errors, warnings and general information.

Creation Methods

Key Phrase | Form | Description
audit failure event log event type | PlainGlobal | Returns an object corresponding to an audit failure -- an event related to the failed execution of an action. Win:6.0
audit success event log event type | PlainGlobal | Returns an object corresponding to an audit success in an event log. Win:6.0
error event log event type | PlainGlobal | Returns an object corresponding to an error event in the log, such as the failure of a service to start. Win:6.0
event log event type <integer> | NumberedGlobal | Returns an event type object corresponding to the specified number. The enumerated types include: • 1: error event • 2: warning event • 4: information event • 8: audit success event • 16: audit failure event. Win:6.0
event type of <event log record> | Plain | Returns the event type of the specified record from the event log. Win:6.0
information event log event type | PlainGlobal | Returns an object corresponding to an information event, which is generally related to a successful action. Win:6.0
warning event log event type | PlainGlobal | Returns an object corresponding to a warning in the event log. Warnings can be used to prevent future system problems. Win:6.0

Operators

Key phrase | Return Type | Description
<event log event type> = <event log event type> | <boolean> | Compare two event log event types for equality. Win:6.0


Event Log Record

These Inspectors return individual records from the Windows Event logs, which record information about operating system events.

Creation Methods

Key Phrase | Form | Description
record <integer> of <event log> | Numbered | Returns the nth record corresponding to the specified event log. Win:6.0
record of <event log> | Plain | Retrieves the record from the event log. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
category of <event log record> | Plain | <integer> | Returns the category of the specified event log, which is sometimes used to further describe the related action. Win:6.0
computer of <event log record> | Plain | <string> | Returns the name of the computer that has entered a record in the specified log. Win:6.0
description of <event log record> | Plain | <string> | Returns a human-readable description of the specified event log record. Win:6.0
event id of <event log record> | Plain | <integer> | Returns an integer corresponding to the ID of the specified record in the Client computer's event log. Win:6.0
event type of <event log record> | Plain | <event log event type> | Returns the type of the specified event log record, such as error, warning, information, etc. Win:6.0
length of <event log record> | Plain | <integer> | Returns the length of the specified record. This is not the same as the length of the description. Win:6.0
record number of <event log record> | Plain | <integer> | Returns the integer value of the record number corresponding to the specified event log record. Win:6.0
source of <event log record> | Plain | <string> | Returns the source name (from the application, service, or component that logged the event) of the specified event log record. Win:6.0
time generated of <event log record> | Plain | <time> | Returns the time that the specified event log record was generated. Win:6.0
time written of <event log record> | Plain | <time> | Returns the time that the specified event record was written to the log. Win:6.0
user sid of <event log record> | Plain | <security identifier> | Returns the user security ID for the specified record in the event log. Win:6.0


File

For each file in the file system, you can create a corresponding file object and inspect its properties. Inspectors are also provided to look at version data of executable files. File objects are derived from filesystem objects.

Creation Methods

See application objects for additional creation methods

Key Phrase | Form | Description
<filesystem object> as file | Cast | Returns a file or nothing (if, for example, the filesystem object was a folder). Mac:4.1
<registry key value> as file | Cast | If the value contains a string and the string points to an existing file, a file object is returned. Win:1.2
<registry key value> as system file | Cast | If the value contains a string and the string points to an file, a file object is returned. Relative paths are interpreted relative to the system folder. Win:1.2
<symlink> as file | Cast | Converts a symlink object into the file it points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
active device file | PlainGlobal | Under Windows NT, returns a list of file objects corresponding the list returned from the Windows NT EnumDeviceDrivers() function. Win:1.2
active device file <string> | NamedGlobal | Under Windows NT, returns a file object corresponding to the name provided. Names provided need only match the last component of the file. This inspector uses the Windows NT EnumDeviceDrivers() function. Win:1.2
default web browser | PlainGlobal | Creates an object corresponding to the default web browser. This is a Windows and Macintosh inspector; it will fail gracefully on other operating systems instead of generating an error. • Note: This Inspector returns a <file> object on Unix, an <application> on Windows and a <filesystem object> on the Mac. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
descendant of <folder> | Plain | Returns a list of all the descendant files of the specified folder. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:6.0
download file <string> | NamedGlobal | This inspector is available in relevance subsitution action processing. It returns a file object with the given name from the named folder or the download folder. This is equivalent to 'file "name" of download folder'. The file should exist or the result will not exist. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
file <string> | NamedGlobal | Returns a filesystem object corresponding to the full pathname provided in <string>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
file <string> of <folder> | Named | Creates the file objects corresponding to the named file within the folder. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
file <symlink> | Index<symlink>Global | Returns the file pointed to by the specified symlink. If the file doesn't exist, this Inspector will throw a 'non-existent object' error. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
file ending in <string> of <folder> | Named | Returns a list of files ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
file of <folder> | Plain | Iterates through the files of a folder. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
file of <service> | Plain | This returns the executable file associated with the given <service> under Windows 2000 operating systems. Win:3.0
find file <string> of <folder> | Named | Creates an object corresponding to the files of the folder that that match the wildcard <string> provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
hfs file <string> | NamedGlobal | Returns the hierachical file system (HFS) file specified by <string>. Mac:5.1
masthead of <site> | Plain | A copy of the masthead is maintained with the site data. This inspector returns a file object for the copy. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
posix file <string> | NamedGlobal | Returns the POSIX file specified by <string>. Mac:5.1
relative file <string> of <folder> | Named | Returns the file with the path specified by <string> relative to the given <folder>. Mac:5.1
relative hfs file <string> of <folder> | Named | Returns the HFS file with the path specified by <string> relative to the given <folder>. Mac:5.1
relative posix file <string> of <folder> | Named | Returns the POSIX file with the path specified by <string> relative to the given <folder>. Mac:5.1
sibling file <string> of <filesystem object> | Named | A named property. A file in the same folder as the specified file object. Mac:4.1
system file <string> | NamedGlobal | Creates the file objects corresponding to the named file within the system folder. Win:1.2
system ini device file | PlainGlobal | Creates a list of file objects corresponding to all the device= lines of the system.ini file. Note that items whose pathnames start with '*' are not placed into this list. Win:1.2
system ini device file <string> | NamedGlobal | Creates a file object corresponding to a device file loaded as a result of a device= line of the system.ini file. The name provided should match the last component of the full path. Win:1.2
windows file <string> | NamedGlobal | Returns a file object corresponding to the relative pathname (within the Windows folder) provided. See file. Win:1.2
x32 file <string> | NamedGlobal | Returns an object corresponding to a 32 bit file with name specified by <string>. Win:6.0
x64 file <string> | NamedGlobal | Returns an object corresponding to a 64 bit file with pathname specified by <string>. On a 32-bit computer, this is equivalent to a normal file Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. Win:6.0

Note

File systems that do not maintain the creation or last accessed times will often return the last modification time when queried for the creation or last accessed times or files. Modification times are preserved when files are copied. Thus, it is not uncommon to see a file that appears to have been modified before it was created.

Properties

Key Phrase | Form | Return Type | Description
<file> as string | Cast | <string> | Creates a string containing the full pathname of the specified file. See <file>. Win:1.2, , , ,
alias of <file> | Plain | <boolean> | Returns TRUE if the file is an alias for another file. Mac:4.1
byte <integer> of <file> | Numbered | <integer> | Returns the numeric value of the byte located at the offset specified by number within the file. Byte 0 of the file is the first byte. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
content of <file> | Plain | <file content> | Returns an object that can be used to search for a string in the file. See content. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
data fork of <file> | Plain | <datafork> | Returns information about the data fork of the specified file. Mac:4.1
dictionary of <file> | Plain | <dictionary> | Returns the dictionary object for the specified file. Mac:4.1
drive of <file> | Plain | <filesystem> | Returns the drive associated with the specified file as a <filesystem> object. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
drive of <file> | Plain | <volume> | Returns the drive (as a <volume>) associated with the specified file. This is a Macintosh-only Inspector. Mac:5.1
executable file format of <file> | Plain | <string> | Returns a four-byte string containing the format specifier for the specified file. Win:4.1
file version of <file> | Plain | <version> | Returns the file version extracted from the file's resource block. See version. Win:1.2
filesystem of <file> | Plain | <filesystem> | Returns the Unix filesystem flag for the given file. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem of <file> | Plain | <volume> | Returns the volume corresponding to the filesystem of the specified file. Mac:6.0
first raw version block of <file> | Plain | <file version block> | Returns the first version block directly from a PE file. If the first block is sufficient for your purposes, use this version inspector for best speed. Win:4.1
key <string> of <file> | Named | <string> | Returns a key and its value from the given structured text file. It iterates over lines that start with the key name (as specified by <string>) followed by an = or : character. When searching, white space is ignored. Win:4.1, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
length of <file> | Plain | <integer> | The total length of the data and resource forks. Mac:4.1
line <integer> of <file> | Numbered | <file line> | Returns the nth line (specified by <integer>) from the given file. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
line containing <string> of <file> | Named | <file line> | Returns all lines from the given file that contain the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
line of <file> | Plain | <file line> | Iterates over all the lines of the specified file. NOTE: lines are truncated to 1023 characters. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
line starting with <string> of <file> | Named | <file line> | Same as line <string> of <file>, returns the lines of the given file that start with the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
locked of <file> | Plain | <boolean> | Returns TRUE if the file is locked. Mac:4.1
only raw version block of <file> | Plain | <file version block> | Returns the only version block directly from a PE file. Win:4.1
only version block of <file> | Plain | <file version block> | Most files only have 1 version block. This property allows language independent access when there is only one version block present. The result is the same as 'version block 1'. Win:1.2
pem encoded certificate of <file> | Plain | <x509 certificate> | Reads and returns the certificate from a file in the PEM format. This can be used to analyze encryption credentials on decrypting relays or root servers. Win:7.1
product version of <file> | Plain | <version> | Returns the product version extracted from the file's resource block. See version. Win:1.2
raw file version of <file> | Plain | <version> | Returns the file version directly from a PE file. Win:4.1
raw product version of <file> | Plain | <version> | Returns the product version directly from a PE file. Win:4.1
raw version block <integer> of <file> | Numbered | <file version block> | Returns the numbered version block directly from a PE file. Win:4.1
raw version block <string> of <file> | Named | <file version block> | Returns the named version block directly from a PE file. Win:4.1
raw version block of <file> | Plain | <file version block> | Returns the version block directly from a PE file. Win:4.1
raw version of <file> | Plain | <version> | Returns the version directly from a PE file. Win:4.1
resource fork of <file> | Plain | <resfork> | Returns information about the resource fork of the file. Mac:4.1
section <string> of <file> | Named | <file section> | Returns a named section of a file. Useful for locating sections of 'ini' files. Section names are delimited by square bracket characters '[section name]'. See examples below. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
security descriptor of <file> | Plain | <security descriptor> | Specifies the security descriptor associated with the specified file. Win:4.1
sha1 of <file> | Plain | <string> | Returns the sha1 checksum of the file hex encoded as a 40 character long string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
shortcut of <file> | Plain | <file shortcut> | Returns the properties and locates the target of a file shortcut: • pathname (string) • start in pathname (string) • argument string (string) • icon pathname (string) • icon index (integer). Win:1.2
size of <file> | Plain | <integer> | Returns the size in bytes of a file. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
variable of <file> | Plain | <string> | Returns the names of variables contained in an INF style file, in the format [section].name=value. Win:4.1, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
version <integer> of <file> | Numbered | <version> | Returns the nth version information from the "vers" resource of the given file. Typically n=1, but other information may be stored in "vers" resources greater than 1. Mac:4.1
version block <integer> of <file> | Numbered | <file version block> | You can identify the particular version block you want to access by ordinal number. Win:1.2
version block <string> of <file> | Named | <file version block> | You can identify the particular version block you are looking up by name. The name you provide should match the id string of the version block. Win:1.2
version block of <file> | Plain | <file version block> | Iterates through the version blocks of a file. Win:1.2
version of <file> | Plain | <version> | Synonym for file version of <file>. Win:1.2, Mac:4.1
visible of <file> | Plain | <boolean> | Returns TRUE if the file is visible. Mac:4.1
volume of <file> | Plain | <volume> | The volume containing the file. Mac:4.1
xml document of <file> | Plain | <xml dom document> | Returns an XML Document Object Model (DOM) for the specified file. Win:5.1

Note

Folder and file names may be case sensitive. Use “as uppercase” or “as lowercase” if you don’t know the actual case when making comparisons. Iterating through folders with many files can be time consuming.

Note

The format of the string returned when casting a file using 'as string' is:
"<fileName>" "<version>" "<fileDesc>" "<fileVersion>" "<companyName>"
Where:

<fileName> | The name of the file
<version> | The 'Product Version' of the file.
<fileDesc> | The value 'FileDescription' of version block 1 of the file.
<fileVersion> | The value 'FileVersion' of version block 1 of the file.
<companyName> | The value 'CompanyName' of version block 1 of the file.

Examples

wait "{pathname of download file "update.exe"}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

files ending in ".a" of folder "/usr/lib"
Returns a list of files with the specified ending, such as: /usr/lib/libcpp_kext.a, /usr/lib/libfl.a, /usr/lib/libioabc.a, etc.

Number of find files "siteico*.bmp" of client folder of current site = 3
Returns TRUE if there are 3 files matching the wildcard pattern siteico*.bmp.

modification time of masthead of current site < time "4 Aug 1997 01:00 pdt"
TRUE if the masthead is older than the specified date.

relative file "Safari.app/Contents/MacOS/Safari” of applications folder
Returns the concatenation of the specified folder and the given path, /Applications/Safari.app/Contents/MacOS/Safari.

exists windows file "command.com"
Verifies the existence of the named file in the Windows folder.

file version of application "iexplore.exe" of the registry < "4"
Test for older version of IE -- returns TRUE is version is less than 4.

filesystem of folder "/Users/MyUserName/Library"
Returns /Users/MyUserName.

Length of data fork of file "Microsoft Word" of folder "Microsoft Office X" of Applications folder is greater than 100000
Returns TRUE if the data fork of the system file is greater than the specified amount.

locked of file "this file" of folder "this folder"
Returns TRUE if the specified file is locked.

product version of file "qna.exe" of parent folder of regapp "bigfix.exe" = product version of regapp "bigfix.exe"
Verifies the existence a co-executable located in the same folder with the proper version.

product version of regapp "bigfix.exe" > version "1.0.21"
Returns TRUE if the application has a version of 1.0.22 or higher, and FALSE if the application has a version of 1.0.21 or less.

pathname of shortcut of file "BigFix.lnk" of (value "Common Desktop" of key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders" of registry as folder)
Returns the pathname associated with the shortcut.

version 0 of file "fname" = "1.0"
Checks for the zero version, if one exists.

volume of (application "iTunes.app" as folder) is volume of system folder
Returns TRUE if iTunes is installed on the same volume as the system folder.


File Content

Content objects can be constructed from file objects to inspect their contents.

Creation Methods

Key Phrase | Form | Description
<file content> as lowercase | Cast | Returns the contents of the file as lower case characters. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<file content> as uppercase | Cast | Returns the contents of the file as upper case characters. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
content of <file> | Plain | Creates a content object for a file. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<file content> as lowercase | Cast | <file content> | Returns a lowercase version of the content provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<file content> as uppercase | Cast | <file content> | Returns an uppercase version of the content provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Operators

Key phrase | Return Type | Description
<file content> contains <string> | <boolean> | Returns TRUE if the string is located in the content provided. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Note

See "file section" for a more detailed inspection of .ini files.

Examples

content of file "oeminfo.ini" of system folder as lowercase contains "emachines"
Returns TRUE if either of the strings "emachines" or "eMachines" is found in the file.


File Line

A file line is a string from a text file.

Creation Methods

Key Phrase | Form | Description
line <integer> of <file> | Numbered | Returns the nth line in a file. A file line is just a string, except that you can use the additional properties "next line" and "previous line". Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
line containing <string> of <file> | Named | Returns the line with the specified search string in the given file. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
line of <file> | Plain | Returns the lines of a specified file. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
line starting with <string> of <file> | Named | Returns a line from the given file beginning with the specified phrase. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
next line of <file line> | Plain | Returns the line after the specified line in a file (provided that it is not the last line). This Inspector can be chained indefinitely, eg., next line of next line of …. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
previous line of <file line> | Plain | Returns the line before the nth line in a file, provided n>1. You may repeat this command up to three times. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
line number of <file line> | Plain | <integer> | Returns the line number of a given line. Can be used to locate specific lines in a file. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
next line of <file line> | Plain | <file line> | Returns the line after the specified line in a file (provided that it is not the last line). This Inspector can be chained indefinitely, eg., next line of next line of …. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
previous line of <file line> | Plain | <file line> | Returns the line before the nth line in a file, provided n>1. You may repeat this command up to three times. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1


File Section

Many programs and utilities store their settings in 'ini' files. This object is designed to access these settings. An 'ini' file is composed of zero or more named sections, each with zero or more keys. Each key is identified by name and has a string value.

Creation Methods

Key Phrase | Form | Description
section <string> of <file> | Named | Creates a file section for the name given. A case-insensitive search is performed to locate the named section in the file. Searching through files for configuration data can be a slow process. Particularly for large ini files. In this case you may want to find another method that requires less computation. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
key <string> of <file section> | Named | <string> | Returns a string containing the value for the name provided. A case-insensitive search is performed through the section of the file. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0

Note

Files with an extension of .ini are common in Windows systems, but rare in unix systems. However they are a handy cross-platform way of maintaining a collection of named variables.


File Shortcut

Shortcuts to files can be constructed in the file system. The shortcut contains some additional properties that can be inspected.

Creation Methods

Key Phrase | Form | Description
shortcut of <file> | Plain | Creates a shortcut object for the file. If the file is not a shortcut, this property does not exist. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
argument string of <file shortcut> | Plain | <string> | Returns the arguments that are passed to the application to which the shortcut points when the user attempts to open the shortcut. Win:1.2
icon index of <file shortcut> | Plain | <integer> | The index number of the icon in the file containing the icon associated with the shortcut. Win:1.2
icon pathname of <file shortcut> | Plain | <string> | The full path name of the file containing the icon associated with the shortcut. Win:1.2
pathname of <file shortcut> | Plain | <string> | Returns the full path name of the object to which the shortcut points. Win:1.2
start in pathname of <file shortcut> | Plain | <string> | Returns the full path name the system sets the current directory when the user launches the shortcut. Win:1.2

Examples

pathname of shortcut of file "BigFix.lnk" of (value "Common Desktop" of key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders" of registry as folder)
Returns the pathname associated with shortcut.

pathname of parent folder of system folder = pathname of windows folder
Checks that the system folder is located inside the Windows folder.


File Signature

These Inspectors provide access to each of the four character file signatures associated with some types of files.

Creation Methods

Key Phrase | Form | Description
creator of <bundle> | Plain | The creator 4-letter code of the bundle (e.g., FNDR for Finder). Mac:4.1
creator of <file> | Plain | This refers to the four-character identifier used in all MacOS files. The creator tells what application should open the specified file. Mac:4.1

Operators

Key phrase | Return Type | Description
<file signature> = <file signature> | <boolean> | Compares two Macintosh file signatures. Mac:4.1

Examples

creator of bundle of applications folder = creator of bundle of preferences folder
Returns TRUE if the creator of the application and preference folders are the same.


File Type

These Inspectors provide access to the four character file type associated with some types of files.

Creation Methods

Key Phrase | Form | Description
file type <string> | NamedGlobal | The phrase 'file type' can be used to create a file type object from a string. Mac:4.1
type of <bundle> | Plain | Returns the file type of the bundle. Can be used only to compare equality between file types. Mac:4.1
type of <file> | Plain | Refers to the file type of the specified file. Mac:4.1

Operators

Key phrase | Return Type | Description
<file type> = <file type> | <boolean> | Compare two file types. Mac:4.1

Examples

creator of "that file" of "that folder" is file type "ttxt"
Returns TRUE if "that file" is a TeachText file.

type of "that file" is type of "this file"
Compares the types of two files.


File Version Block

You can inspect the version blocks of a file. There may be several language-specific version blocks. Version blocks contain version and name information in a human readable form for the specified language. This is the information that Windows displays in the file properties dialog. This technique uses string values and has a limited array of comparators. For better speed, utility and compactness see the version object.

Creation Methods

Key Phrase | Form | Description
first raw version block of <file> | Plain | Returns the first version block directly from a PE file. If the first block is sufficient for your purposes, use this version inspector for best speed. Win:4.1
only raw version block of <file> | Plain | Returns the only version block directly from a PE file. Win:4.1
only version block of <file> | Plain | Most applications only have 1 version block. This inspector allows language independent access when there is only one version block present. Win:1.2
raw version block <integer> of <file> | Numbered | Returns the numbered version block directly from a PE file. Win:4.1
raw version block <string> of <file> | Named | Returns the named version block directly from a PE file. Win:4.1
raw version block of <file> | Plain | Returns the version block directly from a PE file. Win:4.1
version block <integer> of <file> | Numbered | You can identify the particular version block you are looking up by ordinal number. 'Version block 1' is equivalent to 'Only Version block'. Win:1.2
version block <string> of <file> | Named | You can identify the particular version block you are looking up by name. The name you provide should match the id string of the version block. Win:1.2
version block of <file> | Plain | Iterates through the version blocks of a file. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
codepage of <file version block> | Plain | <string> | A string representation of the codepage portion of the id of this version block. See notes for known codepage strings. For example, 'Unicode'. Win:1.2
id of <file version block> | Plain | <string> | A string representation containing both the language and codepage of this version block. The format is 8 hex digits, 4 of the codepage concatenated with 4 of the language. For example, '040904b0'. See notes for known values. Win:1.2
language of <file version block> | Plain | <string> | A string representation of the language portion of the id of this version block. For example, 'English (United States)'. See notes for known values. Win:1.2
value <string> of <file version block> | Named | <string> | Returns a string corresponding to the name provided. Values have names such as 'CompanyName', 'FileDescription', 'FileVersion'. Win:1.2

Note

The value, ID, language and codepage properties of the file version block have the following typical values:
value:
Each application can define its own set of values. Standard values include:
CompanyName
FileDescription *
FileVersion *
InternalName
LegalCopyright *
OriginalFilename
ProductName
ProductVersion
Comments
LegalTrademarks
PrivateBuild
SpecialBuild
* As displayed on the version property sheet of the properties of a file.

id:
The version block id is an eight character string. The left 4 characters of the string identify the language while the right 4 characters of the string identify the codepage of a version block. When looking up a version block by its name, you specify the id as a string. The id's of version blocks are case insensitive.

language:
The language inspector returns the full language name. Language names are found using the left 4 hex characters of the id. Thus if the id of the version block is '040904b0', then the language returned would be 'English (United States)'.
Here are some sample language identifiers (left 4 hex chars):

0000 | Language Neutral | 0800 | Language Neutral | 1801 | Arabic (Morocco)
0400 | Process Default Language | 0801 | Arabic (Iraq) | 1809 | English (Ireland)
0401 | Arabic (Saudi Arabia) | 0804 | Chinese (PRC) | 180A | Spanish (Panama)
0402 | Bulgarian | 0807 | German (Swiss) | 1C01 | Arabic (Tunisia)
0403 | Catalan | 0809 | English (British) | 1C09 | English (South Africa)
0404 | Chinese (Taiwan) | 080A | Spanish (Mexican) | 1C0A | Spanish (Dominican Republic)
0405 | Czech | 080C | French (Belgian) | 2001 | Arabic (Oman)
0406 | Danish | 0810 | Italian (Swiss) | 2009 | English (Jamaica)
0407 | German (Standard) | 0812 | Korean (Johab) | 200A | Spanish (Venezuela)
0408 | Greek | 0813 | Dutch (Belgian) | 2401 | Arabic (Yemen)
0409 | English (United States) | 0814 | Norwegian (Nynorsk) | 2409 | English (Caribbean)
040A | Spanish (traditional Sort) | 0816 | Portuguese (Standard) | 240A | Spanish (Colombia)
040B | Finnish | 081A | Serbian (Latin) | 2801 | Arabic (Syria)
040C | French (Standard) | 081D | Swedish (Finland) | 2809 | English (Belize)
040E | Hungarian | 0C01 | Arabic (Egypt) | 280A | Spanish (Peru)
040F | Icelandic | 0C04 | Chinese (Hong Kong) | 2C01 | Arabic (Jordan)
0410 | Italian (Standard) | 0C07 | German (Austrian) | 2C09 | English (Trinidad)
0411 | Japanese | 0C09 | English (Australian) | 2C0A | Spanish (Argentina)
0412 | Korean | 0C0A | Spanish (Modern Sort) | 3001 | Arabic (Lebanon)
0413 | Dutch (Standard) | 0C0C | French (Canadian) | 300A | Spanish (Ecuador)
0414 | Norwegian (Bokmal) | 0C1A | Serbian (Cyrillic) | 3401 | Arabic (Kuwait)
0415 | Polish | 1001 | Arabic (Lybia) | 340A | Spanish (Chile)
0416 | Portuguese (Brazilian) | 1004 | Chinese (Singapore) | 3801 | Arabic (U.A.E)
0418 | Romanian | 1007 | German (Luxembourg) | 380A | Spanish (Uruguay)
0419 | Russian | 1009 | English (Canadian) | 3C01 | Arabic (Bahrain)
041A | Croation | 100A | Spanish (Guatemala) | 3C0A | Spanish (Paraguay)
041B | Slovak | 100C | French (Swiss) | 4001 | Arabic (Qatar)
041D | Swedish | 1401 | Arabic (Algeria) | 400A | Spanish (Bolivia)
041F | Turkish | 1407 | German (Liechtenstein) | 440A | Spanish (El Salvador)
0423 | Belarusian | 1409 | English (New Zealand) | 480A | Spanish (Honduras)
0424 | Slovene | 140A | Spanish (Costa Rica) | 4C0A | Spanish (Nicaragua)
042D | Basque | 140C | French (Luxembourg) | 500A | Spanish (Puerto Rico)

codepage:
The right 4 characters of the id correspond to the codepage as in these examples:

0000 | 7-bit ASCII | 04B0 | Unicode | 04E5 | Windows, Greek
03A4 | Windows, Japan | 0400 | Windows, Latin-2 | 04E7 | Windows, Hebrew
03B5 | Windows, Korean | 04E3 | Windows, Cyrillic | 2710 | Macintosh, Roman
03B6 | Windows, Taiwan | 04E4 | Windows, Multilingual | 2711 | Macintosh, Japanese

The string 'Unknown' is returned for an unidentified language or codepage.

Examples

id of only version block of regapp "bigfix.exe" is "040904b0"
Returns TRUE if the given file's version block id is the specified string.

language of version block 1 of regapp "bigfix.exe" = "English (United States)"
Returns TRUE if the given file's version block language is as specified.

value "FileVersion" of version block 1 of regapp "bigfix.exe" as version
When casting a string value to a version, the parser skips through the string until it identifies something that can be interpreted as a version. This is convenient for extracting version numbers from strings containing added text.


Fileset

A set of files required for installing a software package.

Creation Methods

Key Phrase | Form | Description
fileset matching <string> of <object_repository> | Named | Returns the fileset(s) matching the specified string from within the object repository. AIX:4.1
fileset of <product> | Plain | An iterated property of product, which in turn is a property of the object repository. AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
<fileset> as string | Cast | <string> | Casts a fileset as a string type. AIX:4.1
description of <fileset> | Plain | <string> | Returns a description of a set of installation files. AIX:7.0
lpp_name of <fileset> | Plain | <string> | Licensed Program Product(s) of the fileset. AIX:4.1
product of <fileset> | Plain | <product> | Returns the product corresponding to the specified fileset. AIX:4.1
update of <fileset> | Plain | <integer> | Returns the update number for the specified fileset. AIX:4.1
version of <fileset> | Plain | <version> | Returns the version of the specified fileset. AIX:4.1

Examples

filesets matching "description = 'Inventory Scout Runtime'" of object repository
Returns the filesets matching the given string, in this case the description.

(lpp_name of it & " ver = " & version of it as string) of filesets matching "lpp_name = 'bos.terminfo.rte'" of object repository
Returns a formatted list of filesets with the specified Licensed Program Product name.

updates of filesets matching "lpp_name = 'bos.terminfo.rte'" of object repository
Returns the update numbers of the specified filesets.


Filesystem

The filesystem object can be used to inspect various aspects of the directory structure and file types. Here are some of the possible types:
• affs
• ext, ext2, ext2_old
• hpfs
• iso
• minix, minix_30, minix2, minix2_30
• msdos
• ncp
• nfs
• proc
• smb
• xenix
• sysv4, sysv2
• coh
• ufs
• xia

Creation Methods

Key Phrase | Form | Description
drive | PlainGlobal | For relevance language compatibility with Windows, you can iterate the mounted file systems using this inspector. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
drive <string> | NamedGlobal | Returns the drive associated with the pathname specified by <string>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
drive of <symlink> | Plain | Returns the drive associated with the specified symlink as a <filesystem> object. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
filesystem | PlainGlobal | Returns <filesystem> objects for all currently mounted file systems. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
filesystem <string> | NamedGlobal | Returns the filesystem object for the name provided. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem of <file> | Plain | Returns the filesystem on which the file resides. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem of <folder> | Plain | Returns the filesystem on which the folder resides. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem of <symlink> | Plain | Returns the filesystem on which the symlink resides. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
file count of <filesystem> | Plain | <integer> | Returns the total number of files that may be saved on this filesystem. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
free file count of <filesystem> | Plain | <integer> | Returns the number of files available on this filesystem. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
free percent of <filesystem> | Plain | <integer> | Returns the percentage of the file system currently available. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
free space of <filesystem> | Plain | <integer> | Returns the number of bytes on this filesystem. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
logical volume of <filesystem> | Plain | <logical volume> | On an AIX system, returns the logical volume corresponding to the given filesystem. AIX:7.0
name of <filesystem> | Plain | <string> | Returns the mount point of the filesystem object. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
size of <filesystem> | Plain | <integer> | Returns the total number of bytes on this file system (same as total space). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
total space of <filesystem> | Plain | <integer> | Returns the total number of bytes on this file system (same as size). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
type of <filesystem> | Plain | <string> | Returns the filesystem type. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
used file count of <filesystem> | Plain | <integer> | The number of files in use on this filesystem. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
used percent of <filesystem> | Plain | <integer> | Returns the percentage of the file system currently in use. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
used space of <filesystem> | Plain | <integer> | Returns the number of bytes on this filesystem currently in use. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Examples

names of drives
Returns the names of the mounted drives.

file count of drive "/etc/passwd"
Returns the total number of files on the drive containing the specified file.

names of filesystems
Returns the mount points of the file systems.


Filesystem Object

These Inspectors provide handles for the various objects available in the file system.

Creation Methods

Key Phrase | Form | Description
application | PlainGlobal | This Mac Inspector recursively finds all applications (bundles) and executables under the /Applications directory, as well as all of those under the Applications directories of all local users of the machine. Mac:5.1
application <string> | NamedGlobal | Returns the named applications (bundles) and executables as filesystem objects. Mac:4.1
application of <folder> | Plain | Recursively finds executables in the supplied folder, returning a list of "application" objects, which are basically filesystem_objects. Mac:7.1
item <string> of <folder> | Named | Returns the named item (file or folder) from the specified folder. Mac:5.1
item ending in <string> of <folder> | Named | Returns a list of items (files/folders) ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
item of <folder> | Plain | Returns a list of the items (file or folder) in the specified folder. Mac:4.1
regapp | PlainGlobal | This Mac Inspector recursively finds all applications (bundles) and executables under the /Applications directory, as well as all of those under the Applications directories of all local users of the machine. This Inspector is the same as application, and is included for compatibility with Windows. Mac:5.1
sibling item <string> of <filesystem object> | Named | The named sibling of a filesystem object (file, folder). Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
<filesystem object> as file | Cast | <file> | Returns a file or nothing (if, for example, the filesystem object was a folder). Mac:4.1
<filesystem object> as folder | Cast | <folder> | Returns a folder or nothing. Mac:4.1
<filesystem object> as string | Cast | <string> | Casts a filesystem object as a string. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
<filesystem object> as symlink | Cast | <symlink> | Casts a link in the form of a file into a symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
accessed time of <filesystem object> | Plain | <time> | When the filesystem object (file or folder) was last accessed. Some file systems maintain this property. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
ancestor of <filesystem object> | Plain | <folder> | Returns all ancestor folders (recursive parent folders) of the given filesystem object (file or folder). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
archive of <filesystem object> | Plain | <boolean> | Returns TRUE if the Archive bit is turned on for the specified file or folder (filesystem object). This bit is often used by backup software. Win:6.0
backup time of <filesystem object> | Plain | <time> | The date of the last backup of the specified filesystem object (such as a file or folder). This corresponds to what is shown in the "Get Info" box for this object. Mac:4.1
bundle version of <filesystem object> | Plain | <version> | Returns the version of the filesystem object corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
compressed of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (filesystem object) has been compressed. Win:6.0
creation time of <filesystem object> | Plain | <time> | The date and time of creation of the specified file or folder. This corresponds to what is shown in the "Get Info" box. Win:6.0, Mac:4.1
drive of <filesystem object> | Plain | <drive> | Returns the drive associated with the specified file or folder (filesystem object). Win:6.0
gid of <filesystem object> | Plain | <integer> | Returns the group ID of the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
group execute of <filesystem object> | Plain | <boolean> | Returns TRUE if the group execute flag is set for the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
group mask of <filesystem object> | Plain | <integer> | Returns the group permission mask of the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
group name of <filesystem object> | Plain | <string> | Returns the group name of the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
group read of <filesystem object> | Plain | <boolean> | Returns TRUE if the group read flag is set for the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
group write of <filesystem object> | Plain | <boolean> | Returns TRUE if the group write flag is set for the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
hfs path of <filesystem object> | Plain | <string> | Returns the path to a filesystem object in HFS terms (colons as delimiters). Mac:4.1
hidden of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (filesystem object) is marked as hidden. Win:6.0
link count of <filesystem object> | Plain | <integer> | Returns an integer corresponding to the number of hard links attached to the specified filesystem object. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
location of <filesystem object> | Plain | <string> | Returns the name of the directory in which the file or folder (filesystem object) is located. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
mode of <filesystem object> | Plain | <mode> | Returns the permissions mode for the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
modification time of <filesystem object> | Plain | <time> | The date and time of latest modification of the file. This corresponds to what is shown in the "Get Info" box. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:4.1
name of <filesystem object> | Plain | <string> | This returns the name of the file or folder. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:4.1
normal of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (filesystem object) is 'normal'. Win:6.0
offline of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (the filesystem object) is marked as 'offline'. Win:6.0
other execute of <filesystem object> | Plain | <boolean> | Returns TRUE if others (not in the group) have execute permissions on the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
other mask of <filesystem object> | Plain | <integer> | Returns the other (not in the group) mask as a 3-bit integer corresponding to rwx permissions for the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
other read of <filesystem object> | Plain | <boolean> | Returns TRUE if others (not in the group) have read permissions on the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
other write of <filesystem object> | Plain | <boolean> | Returns TRUE if others (not in the group) have write permissions on the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
parent folder of <filesystem object> | Plain | <folder> | The folder containing the specified file or folder. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:4.1
pathname of <filesystem object> | Plain | <string> | Returns the full pathname of the specified file or folder (filesystem object) as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
posix path of <filesystem object> | Plain | <string> | The POSIX file path for the file or folder. Mac:4.1
readonly of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (the filesystem object) is marked as read-only. Win:6.0
setgid of <filesystem object> | Plain | <boolean> | Returns TRUE if the setgid (group ID) bit is set for the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
setuid of <filesystem object> | Plain | <boolean> | Returns TRUE if the setuid (user ID) bit is set for the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
sibling file <string> of <filesystem object> | Named | <file> | A named property. A file in the same folder as the specified file object. Mac:4.1
sibling folder <string> of <filesystem object> | Named | <folder> | A named property. A folder in the same folder as the specified file object. Mac:4.1
sibling item <string> of <filesystem object> | Named | <filesystem object> | The named sibling of a filesystem object (file, folder). Mac:5.1
system of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (the filesystem object) is marked as a system folder. Win:6.0
temporary of <filesystem object> | Plain | <boolean> | Returns TRUE if the file or folder (the filesystem object) is marked as a temporary folder. Win:6.0
uid of <filesystem object> | Plain | <integer> | The user ID of the user who owns this filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
user execute of <filesystem object> | Plain | <boolean> | Returns TRUE if the owner (user) has execute permissions on the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
user mask of <filesystem object> | Plain | <integer> | Integer representing user permissions (3 bit mask, RWX) on the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
user name of <filesystem object> | Plain | <string> | Returns the owner (user) name of the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
user read of <filesystem object> | Plain | <boolean> | Returns the owner (user) read permissions for the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
user write of <filesystem object> | Plain | <boolean> | Returns the owner (user) write permissions for the specified filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
version of <filesystem object> | Plain | <version> | This returns the version information from "vers" resource 1 of the file. It is usually present in applications, and may exist in data files as well. It corresponds to what appears in the "Get Info" box for the specified filesystem object. Mac:4.1

Operators

Key phrase | Return Type | Description
<filesystem object> = <filesystem object> | <boolean> | Compares two Macintosh file system objects. Mac:4.1

Examples

applications of folder "/Users/fizzle/bin"
Returns a list of applications in the specified directory, such as /Users/fizzle/bin/p4, /Users/fizzle/bin/mylocaltool.

names of items of applications folder
Returns a list of applications, such as DS_Store, .localized, AddressBook.app, AppleScript, Calculator.app, Chess.app, DVD Player.app, etc….

application "iTunes.app" as file
Fails because that is in fact a folder.

file "/example/link" as symlink
Returns the link (in file format) as a symlink object ("/example/link").

creation time of file "System" of System Folder > time "3 jan 1998 00:00+0000"
Returns TRUE if the creation time of the system file is newer than the specified date.

name of object "iChat.app" of applications folder
Returns iChat.app.

exists sibling file "iTunes.app" of application "iChat.app"
Returns TRUE if both applications are in the same folder.

version of primary application "ttxt" is greater than "1.3"
Returns TRUE if the default application for "ttxt" is more recent than version 1.3.


Firewall

The Firewall Inspectors allow you to view the settings of the Windows Firewall on Windows Clients. By inspecting the firewall properties, you can determine which applications have access to unsolicited traffic and how the firewall is configured for various subsets of your network. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the MSDN site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
firewall | PlainGlobal | Returns the global firewall object for this computer. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
current profile type of <firewall> | Plain | <firewall profile type> | Returns the current profile type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_PROFILE_TYPE. Win:5.1
local policy modify state of <firewall> | Plain | <firewall local policy modify state> | Determines if adding or setting a rule or group of rules will take effect in the specified firewall profile. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
local policy of <firewall> | Plain | <firewall policy> | Returns the local policy of the specified firewall. Win:5.1
rule group currently enabled <string> of <firewall> | Named | <boolean> | Determines whether a specified group of firewall rules is enabled or disabled for the current profile, considering the firewall's state, BlockAllInboundTraffic state and group policy overrides state. The string is used to group rules together. It can be the group name or an indirect string to the group name in the form of "@yourresourcedll.dll,-23255." Rules belonging to this group will be queried. Win:7.0
rule of <firewall> | Plain | <firewall rule> | Retrieves the collection of rules for the specified firewall. For more information, see the MSDN Library article on INetFwPolicy2. Win:7.0
service restriction of <firewall> | Plain | <firewall service restriction> | Retrieves the access interface to manipulate the Windows Service Hardening store. On Windows operating systems earlier than Vista, this Inspector always returns no-such-object. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0


Firewall Action

The firewall action Inspectors provide wrappers around the Windows Vista Firewall API. These are Vista-only Inspectors.

Creation Methods

Key Phrase | Form | Description
action of <firewall rule> | Plain | Retrieves the Action property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
allow firewall action | PlainGlobal | Returns a value corresponding to the NET_FW_ACTION enumerated type, which specifies the action for a rule or default setting. This is a Vista Inspector. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0
block firewall action | PlainGlobal | Returns a value corresponding to the NET_FW_ACTION enumerated type, which specifies the action for a rule or default setting. This is a Vista Inspector. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0
firewall action <integer> | NumberedGlobal | Returns the Nth enumerated type from the Firewall Action interface. This provides an alternative way to access the firewall action variables and requires Vista. For more information, see the MSDN Library entry for NET_FW_ACTION. Win:7.0

Operators

Key phrase | Return Type | Description
<firewall action> = <firewall action> | <boolean> | Compares two enumerated types corresponding to the firewall action. This is a Vista Inspector. For more information see the MSDN Library reference to NET_FW_ACTION. Win:7.0


Firewall Authorized Application

These Inspectors apply to applications that are authorized to exchange traffic through the Windows Firewall. These properties correspond to the INetFwAuthorizedApplication interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
authorized application of <firewall profile> | Plain | Provides access to the properties of any application that has been authorized to have firewall openings. There are several methods attached to this Inspector, including: • Name • ProcessImageFileName • IpVersion • Scope • RemoteAddress • Enabled. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
enabled of <firewall authorized application> | Plain | <boolean> | Returns the contents of the Enabled property for the specified application. Returns TRUE if the settings for this application are currently enabled. Win:5.1
ip version of <firewall authorized application> | Plain | <ip version> | Returns the contents of the IpVersion property for the specified application. Win:5.1
name of <firewall authorized application> | Plain | <string> | Returns the contents of the Friendly Name property for the specified application. Win:5.1
process image file name of <firewall authorized application> | Plain | <string> | Returns the contents of the ProcessImageFileName property for the specified application. Win:5.1
remote addresses of <firewall authorized application> | Plain | <string> | Returns the contents of the RemoteAddresses property for the specified application. This property accesses a set of remote addresses that an application can use to listen for traffic. Win:5.1
scope of <firewall authorized application> | Plain | <firewall scope> | Returns the contents of the Scope property for the specified application. This property controls the network scope that a port can listen to. Win:5.1


Firewall Icmp Settings

These Inspectors provide access to the settings controlling Internet Control Message Protocol (ICMP) packets. These properties correspond to the INetFwIcmpSettings interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
icmp settings of <firewall profile> | Plain | The Microsoft Windows Firewall INetFwIcmpSettings interface provides access to the settings controlling Internet Control Message Protocol (ICMP) packets. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
allow inbound echo request of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowInboundEchoRequest property. Type common to IPv4 and IPv6. Win:5.1
allow inbound mask request of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowInboundMaskRequest property. Type common to IPv4 only. Win:5.1
allow inbound router request of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowInboundRouterRequest property. Type common to IPv4 only. Win:5.1
allow inbound timestamp request of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowInboundTimestampRequest property. Type common to IPv4 only. Win:5.1
allow outbound destination unreachable of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowOutboundDestinationUnreachable property. Type common to IPv4 and IPv6. Win:5.1
allow outbound packet too big of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowOutboundPacketTooBig property. Type common to IPv6 only. Win:5.1
allow outbound parameter problem of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowOutboundParameterProblem property. Type common to IPv4 and IPv6. Win:5.1
allow outbound source quench of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowOutboundSourceQuench property. Type common to IPv4 only. Win:5.1
allow outbound time exceeded of <firewall icmp settings> | Plain | <boolean> | Returns the value of the AllowOutboundTimeExceeded property. Type common to IPv4 and IPv6. Win:5.1
allow redirect of <firewall icmp settings> | Plain | <boolean> | Accesses the AllowRedirect property. Type common to IPv4 and IPv6. Win:5.1


Firewall Local Policy Modify State

These Inspectors provide a wrapper for the Windows Firewall Policy Modification State. They are Vista-only. On a non-Vista machine, they return no results. For more information see the MSDN Library reference to NET_FW_MODIFY_STATE at http://msdn.microsoft.com/library/.

Creation Methods

Key Phrase | Form | Description
firewall local policy modify state <integer> | NumberedGlobal | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. The <integer> specifies the zero-based enumeration, and provides an alternative access method. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
gp override firewall local policy modify state | PlainGlobal | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
inbound blocked firewall local policy modify state | PlainGlobal | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0
local policy modify state of <firewall> | Plain | Determines if adding or setting a rule or group of rules will take effect in the specified firewall profile. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
ok firewall local policy modify state | PlainGlobal | Returns a value corresponding to the NET_FW_MODIFY_STATE enumerated type, which specifies the effect of modifications to the current policy. For more information, see the MSDN Library entry for NET_FW_MODIFY_STATE. Win:7.0

Operators

Key phrase | Return Type | Description
<firewall local policy modify state> = <firewall local policy modify state> | <boolean> | Compares two enumerated types corresponding to the firewall policy modification state. This is a Vista Inspector. For more information see the MSDN Library reference to NET_FW_MODIFY_STATE. Win:7.0


Firewall Open Port

These Inspectors provide access to the properties of a port that has been opened in the Windows Firewall. These properties correspond to the INetFwOpenPort interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
globally open port of <firewall profile> | Plain | Provides access to the GloballyOpenPorts collection for this profile. Win:5.1
globally open port of <firewall service> | Plain | Returns the collection of globally open ports associated with the firewall service. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
built in of <firewall open port> | Plain | <boolean> | Returns the contents of the BuiltIn property of the firewall open port. Win:5.1
enabled of <firewall open port> | Plain | <boolean> | Returns the contents of the Enabled property of the firewall open port. Win:5.1
ip version of <firewall open port> | Plain | <ip version> | Returns the IpVersion property of the firewall open port. Win:5.1
name of <firewall open port> | Plain | <string> | Returns the Name property of the firewall open port. Win:5.1
port of <firewall open port> | Plain | <integer> | Returns the Port property of the firewall open port. Win:5.1
protocol of <firewall open port> | Plain | <internet protocol> | Returns the Protocol property of the firewall open port. Win:5.1
remote addresses of <firewall open port> | Plain | <string> | Returns the RemoteAddresses property of the firewall open port. Win:5.1
scope of <firewall open port> | Plain | <firewall scope> | Returns the Scope property of the firewall open port. Win:5.1


Firewall Policy

These Inspectors provide access to the local, current, domain and standard firewall policies. These properties correspond to the INetFwPolicy interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
local policy of <firewall> | Plain | Returns the local policy of the specified firewall. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
current profile of <firewall policy> | Plain | <firewall profile> | Returns the profile currently in effect for the specified firewall policy. Win:5.1
domain profile of <firewall policy> | Plain | <firewall profile> | Returns the domain profile of the specified firewall policy. The domain profile settings are used when a computer is connected to a network that contains the organization's domain controllers. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:5.1
private profile of <firewall policy> | Plain | <firewall profile> | Retrieves the private profile type from the specified firewall policy. This profile type is used for home and other private network types. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
public profile of <firewall policy> | Plain | <firewall profile> | Retrieves the public profile type from the specified firewall policy. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
standard profile of <firewall policy> | Plain | <firewall profile> | Returns the standard profile of the specified firewall policy. The standard profile settings are used when a computer is connected to a network that does not contain the organization's domain controllers. This Inspector corresponds to the Microsoft Windows Firewall enumerated type NET_FW_PROFILE_STANDARD. Win:5.1


Firewall Profile

These Inspectors provide access to the firewall profile. These properties correspond to the INetFwProfile interface in the Windows Firewall API. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
current profile of <firewall policy> | Plain | Returns the profile currently in effect for the specified firewall policy. Win:5.1
domain profile of <firewall policy> | Plain | Returns the domain profile of the specified firewall policy. The domain profile settings are used when a computer is connected to a network that contains the organization's domain controllers. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:5.1
private profile of <firewall policy> | Plain | Retrieves the private profile type from the specified firewall policy. This profile type is used for home and other private network types. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
public profile of <firewall policy> | Plain | Retrieves the public profile type from the specified firewall policy. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
standard profile of <firewall policy> | Plain | Returns the standard profile of the specified firewall policy. The standard profile settings are used when a computer is connected to a network that does not contain the organization's domain controllers. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
authorized application of <firewall profile> | Plain | <firewall authorized application> | Access to the AuthorizedApplications collection for this profile. This Inspector can be iterated through all the authorized applications in each firewall profile. Win:5.1
exceptions allowed of <firewall profile> | Plain | <boolean> | Returns the property that indicates whether exceptions should be allowed by the firewall. Win:6.0
excluded interface of <firewall profile> | Plain | <string> | Gets the value of the ExcludedInterfaces property from the specified firewall profile. This property contains the list of interfaces excluded from a the profile's firewall rules. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
firewall enabled of <firewall profile> | Plain | <boolean> | Gets the value of the FirewallEnabled setting. Win:5.1
globally open port of <firewall profile> | Plain | <firewall open port> | Provides access to the GloballyOpenPorts collection for this profile. This property can be iterated. Win:5.1
icmp settings of <firewall profile> | Plain | <firewall icmp settings> | Gets the object governing settings for ICMP packets. Win:5.1
inbound connections allowed of <firewall profile> | Plain | <boolean> | Determines whether the default action for inbound traffic for the specified firewall profile is NET_FW_ACTION_ALLOW. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
notifications disabled of <firewall profile> | Plain | <boolean> | Gets the value of the NotificationsDisabled setting, TRUE or FALSE. Win:5.1
outbound connections allowed of <firewall profile> | Plain | <boolean> | Determines whether the default action for outbound traffic for the specified firewall profile is NET_FW_ACTION_ALLOW. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
remote admin settings of <firewall profile> | Plain | <firewall remote admin settings> | Gets the object containing the remote administration settings. Win:5.1
rule group enabled <string> of <firewall profile> | Named | <boolean> | Determines whether a specified group of firewall rules are enabled or disabled. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0
service of <firewall profile> | Plain | <firewall service> | Gets the collection containing the services for this profile. This Inspector can be iterated over all services. Win:5.1
type of <firewall profile> | Plain | <firewall profile type> | Returns the type of the specified firewall profile: domain, standard or current. Win:5.1
unicast responses to multicast broadcast disabled of <firewall profile> | Plain | <boolean> | Gets the value of the UnicastResponsesToMulticastBroadcastDisabled setting. Win:5.1


Firewall Profile Type

These Inspectors provide access to the firewall profile type. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
current firewall profile type | PlainGlobal | Retrieves the type of firewall profile that is currently in effect. Win:5.1
current profile type of <firewall> | Plain | Returns the current profile type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_PROFILE_TYPE. Win:5.1
domain firewall profile type | PlainGlobal | Returns the current profile type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_PROFILE_DOMAIN. Win:5.1
firewall profile type <integer> | NumberedGlobal | Returns the firewall profile type corresponding to the given integer: • 0: Domain • 1: Standard • 2: Current. Win:5.1
private firewall profile type | PlainGlobal | Retrieves the enumerated variable corresponding to private profile type. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
public firewall profile type | PlainGlobal | Retrieves the enumerated variable corresponding to public profile type. This profile type is used for public internet access points. For more information, see the MSDN Library entry for NET_FW_PROFILE_TYPE2. Win:7.0
standard firewall profile type | PlainGlobal | Returns the Standard firewall profile type. Win:5.1
type of <firewall profile> | Plain | Returns the type of the specified firewall profile, corresponding to the Microsoft Windows Firewall enumerated types: • NET_FW_PROFILE_DOMAIN • NET_FW_PROFILE_STANDARD • NET_FW_PROFILE_CURRENT. Win:5.1

Operators

Key phrase | Return Type | Description
<firewall profile type> = <firewall profile type> | <boolean> | Compares two firewall policies for equality only. Win:5.1

Examples

current profile type of firewall = standard firewall profile type
Returns TRUE if the current profile type is standard.


Firewall Remote Admin Settings

These Inspectors provide access to the settings that control remote administration. These properties correspond to the INetFwRemoteAdminSettings interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
remote admin settings of <firewall profile> | Plain | Gets the object containing the remote administration settings. These settings include the following properties: • Enabled • IpVersion • RemoteAddresses • Scope. Win:5.1


Firewall Rule

These Inspectors provide a wrapper for the Windows Firewall Rule. They are Vista-only. On a non-Vista machine, they return no results. For more information, see the MSDN library for INetFwRule at http://msdn.microsoft.com/library/.

Creation Methods

Key Phrase | Form | Description
rule of <firewall service restriction> | Plain | Retrieves the collection of Windows Service Hardening network rules for the specified firewall service restriction. For more information, see the MSDN Library section on INetFwServiceRestriction. Win:7.0
rule of <firewall> | Plain | Retrieves the collection of rules for the specified firewall. For more information, see the MSDN Library article on INetFwPolicy2. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
action of <firewall rule> | Plain | <firewall action> | Retrieves the Action property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
application name of <firewall rule> | Plain | <string> | Retrieves the application name property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
currently active of <firewall rule> | Plain | <boolean> | Currently active is true if and only if the specified firewall rule is enabled (the Enabled property is true) AND the currently active profile type (as defined by the CurrentProfileTypes property of INetFwPolicy2) is one of the profiles for which the rule applies (as defined by the Profiles property). For more information see the MSDN Library articles for INetFwRule, including the CurrentProfileTypes and Profiles properties. Win:7.0
description of <firewall rule> | Plain | <string> | Retrieves the Description property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
edge traversal allowed of <firewall rule> | Plain | <boolean> | Retrieves the EdgeTraversal property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
enabled of <firewall rule> | Plain | <boolean> | Retrieves the Enabled property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
grouping of <firewall rule> | Plain | <string> | Retrieves the Grouping property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
icmp types_and_codes string of <firewall rule> | Plain | <string> | Retrieves the IcmpTypesAndCodes property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
inbound of <firewall rule> | Plain | <boolean> | Retrieves the inbound direction property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule and IDispatch. Win:7.0
interface of <firewall rule> | Plain | <string> | Retrieves the Interfaces property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
interface types string of <firewall rule> | Plain | <string> | Retrieves the Interface types property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
local addresses string of <firewall rule> | Plain | <string> | Retrieves the Interfaces property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
local ports string of <firewall rule> | Plain | <string> | Retrieves the LocalPorts property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
name of <firewall rule> | Plain | <string> | Retrieves the Name property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
outbound of <firewall rule> | Plain | <boolean> | Retrieves the outbound direction property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule and IDispatch. Win:7.0
profile <firewall profile type> of <firewall rule> | Index<firewall profile type> | <boolean> | Retrieves the given profile property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
protocol of <firewall rule> | Plain | <internet protocol> | Retrieves the Protocol property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
remote addresses string of <firewall rule> | Plain | <string> | Retrieves the RemoteAddresses property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
remote ports string of <firewall rule> | Plain | <string> | Retrieves the RemotePorts property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
service name of <firewall rule> | Plain | <string> | Retrieves the ServiceName property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0


Firewall Scope

These Inspectors provide access to the firewall scope. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
all firewall scope | PlainGlobal | Returns the scope of computers that allow ALL traffic through the firewall, corresponding to the Microsoft enumerated type NET_FW_SCOPE_ALL. Win:5.1
custom firewall scope | PlainGlobal | Returns the custom firewall scope, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_SCOPE_CUSTOM. Win:5.1
firewall scope <integer> | NumberedGlobal | Returns the scope of addresses from which a port can listen, corresponding to the Microsoft enumerated types: • NET_FW_SCOPE_ALL • NET_FW_SCOPE_LOCAL_SUBNET • NET_FW_SCOPE_CUSTOM. Win:5.1
local subnet firewall scope | PlainGlobal | Returns the local subnet firewall scope, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_SCOPE_LOCAL_SUBNET. Win:5.1
scope of <firewall authorized application> | Plain | Retrieves the contents of the Scope property of the authorized application. Win:5.1
scope of <firewall open port> | Plain | Retrieves the contents of the Scope property of the open port. Win:5.1
scope of <firewall service> | Plain | Retrieves the contents of the Scope property of the firewall service. Win:5.1

Operators

Key phrase | Return Type | Description
<firewall scope> = <firewall scope> | <boolean> | Compares two firewall scopes for equality only. Win:5.1


Firewall Service

These Inspectors provide access to the properties of a service that may be authorized to listen through the firewall. These properties correspond to the INetFwService interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
service of <firewall profile> | Plain | Gets the collection containing the services for this profile. Win:5.1

Properties

Key Phrase | Form | Return Type | Description
customized of <firewall service> | Plain | <boolean> | Returns a flag that indicates whether at least one of the ports associated with the service has been customized. Either TRUE or FALSE. Win:5.1
enabled of <firewall service> | Plain | <boolean> | Returns the enabled flag for the specified firewall service. Win:5.1
globally open port of <firewall service> | Plain | <firewall open port> | Returns the collection of globally open ports associated with the firewall service. Win:5.1
ip version of <firewall service> | Plain | <ip version> | Returns the the IP version for the specified firewall service. Win:5.1
name of <firewall service> | Plain | <string> | Returns the friendly name of the firewall service. Win:5.1
remote addresses of <firewall service> | Plain | <string> | Returns the contents of the RemoteAddresses property for the specified firewall service. Win:5.1
scope of <firewall service> | Plain | <firewall scope> | Retrieves the contents of the Scope property of the firewall service. Win:5.1
type of <firewall service> | Plain | <firewall service type> | Returns the type of the specified firewall service (file and print, upnp, remote desktop or none). Win:5.1


Firewall Service Restriction

These Inspectors provide a wrapper for the Windows Firewall Service Restriction. They are Vista-only. On a non-Vista machine, they return no results. For more information see the MSDN Library reference to INetFwServiceRestriction at http://msdn.microsoft.com/library/.

Creation Methods

Key Phrase | Form | Description
service restriction of <firewall> | Plain | Retrieves the access interface to manipulate the Windows Service Hardening store. On Windows operating systems earlier than Vista, this Inspector always returns no-such-object. For more information, see the MSDN Library entry for INetFwPolicy2. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
rule of <firewall service restriction> | Plain | <firewall rule> | Retrieves the collection of Windows Service Hardening network rules for the specified firewall service restriction. For more information, see the MSDN Library section on INetFwServiceRestriction. Win:7.0
service restricted <( string, string )> of <firewall service restriction> | Index<( string, string )> | <boolean> | Returns the service restriction state of a given service. There are two strings passed to define the restriction: the service name and the application name. For more information, see the MSDN Library section on INetFwServiceRestriction. Win:7.0


Firewall Service Type

These Inspectors provide access to the firewall service type. These properties correspond to the INetFwService.Type interface in the Windows Firewall API. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
file_and_print firewall service type | PlainGlobal | Returns the global service type for file and print sharing, corresponding to the Microsoft enumerated type: NET_FW_SERVICE_FILE_AND_PRINT. Win:6.0
firewall service type <integer> | NumberedGlobal | Returns the firewall service type specified by <integer>, corresponding to the Microsoft Windows Firewall enumerated types: • NET_FW_SERVICE_FILE_AND_PRINT • NET_FW_SERVICE_UPNP • NET_FW_SERVICE_REMOTE_DESKTOP • NET_FW_SERVICE_NONE. Win:5.1
none firewall service type | PlainGlobal | Returns the no firewall service type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_SERVICE_NONE. Win:6.0
remote desktop firewall service type | PlainGlobal | Returns the remote desktop firewall service type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_SERVICE_REMOTE_DESKTOP. Win:5.1
type of <firewall service> | Plain | Returns the type of the specified firewall service, corresponding to the Microsoft Windows Firewall enumerated types: • NET_FW_SERVICE_FILE_AND_PRINT • NET_FW_SERVICE_UPNP • NET_FW_SERVICE_REMOTE_DESKTOP • NET_FW_SERVICE_NONE. Win:5.1
upnp firewall service type | PlainGlobal | Returns the UPnP (Universal Plug and Play) firewall service type, corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_SERVICE_UPNP. • Note: UPnP is not the same as PnP. UPnP is used for network connectivity via TCP/IP to various devices (scanners, printers, etc.). Win:5.1

Operators

Key phrase | Return Type | Description
<firewall service type> = <firewall service type> | <boolean> | Compares two firewall service types for equality only. Win:5.1


Fixlet

These Inspectors can provide important information about the Fixlet messages at any site. These Inspectors only work in the context of property evaluation, not Fixlet evaluation.

Creation Methods

Key Phrase | Form | Description
fixlet of <site> | Plain | This Inspector iterates over all the Fixlet messages in the given site. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
relevant fixlet of <site> | Plain | Iterates over all the relevant Fixlet messages in the specified site. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
header <string> of <fixlet> | Named | <fixlet_header> | Returns the named header (case insensitive) of the specified Fixlet message. Fixlet headers are name:value pairs. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
header of <fixlet> | Plain | <fixlet_header> | Iterates over all the headers of the Fixlet message. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
id of <fixlet> | Plain | <integer> | Returns the numeric ID number of the specified Fixlet message. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
relevance of <fixlet> | Plain | <boolean> | Returns a boolean TRUE or False, depending on the Relevance of the specified Fixlet message. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0


Fixlet_header

Fixlet headers are name:value pairs that can provide important information about the Fixlet messages at any site. These Inspectors only work in the context of property evaluation, not Fixlet evaluation.

Creation Methods

Key Phrase | Form | Description
header <string> of <fixlet> | Named | Returns the named header (case insensitive) of the specified Fixlet message. Fixlet headers are name:value pairs. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
header of <fixlet> | Plain | Iterates over all the headers of the Fixlet message. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
name of <fixlet_header> | Plain | <string> | Headers are name:value pairs, separated by a colon. This Inspector returns the name on the left hand side of the pair. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
value of <fixlet_header> | Plain | <string> | Headers are name:value pairs, separated by a colon. This Inspector returns the value on the right hand side of the pair. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0

Examples

number of relevant fixlets whose (value of header "x-fixlet-source-severity" of it as lowercase = "critical") of site "enterprise security".
Returns the number of critical fixlets in the Enterprise Security site.


Floating Point

The point type holds a floating-point number, with precision dependent on the computer. It also keeps track of the IEEE floating-point exceptions raised in a calculation and an estimate of the significance with which the number should be expressed when it is converted to a string. All arithmetic operations are carried out to the full precision of the computer; only conversions to string are affected by the estimated significance.

Creation Methods

Key Phrase | Form | Description
<integer> as floating point | Cast | Converts an integer into a floating point number. Win:4.1, Mac:4.1
<string> as floating point | Cast | Converts the contents of a string into a floating point number. Win:4.1, Mac:4.1
floating point <floating point> | Index<floating point>Global | Creates a floating point type object from the specified floating point number. Win:7.2, Mac:7.2
floating point <string> | NamedGlobal | Creates a floating point number from the provided string. Win:4.1, Mac:4.1
less significance <integer> of <floating point> | Numbered | Removes <integer> number of digits of significance from the floating point value. Win:4.1, Mac:4.1
maximum of <floating point> | Plain | Returns the maximum value from a list of <floating point> types. Win:7.1, Mac:7.1
mean of <floating point> | Plain | The mean of the floating point number(s). Win:5.1, Mac:4.1
mean of <integer> | Plain | The mean of the integer(s). Win:5.1, Mac:4.1
minimum of <floating point> | Plain | Returns the minimum value from a list of <floating point> types. Win:7.1, Mac:7.1
more significance <integer> of <floating point> | Numbered | Adds <integer> number of digits of significance to the floating point value. Win:4.1, Mac:4.1
relative significance place <integer> of <floating point> | Numbered | The same floating point value, to be expressed to the given number of significant digits. Win:4.1, Mac:4.1
relative significance place of <floating point> | Plain | The base 10 logarithm of the quotient of the value and its significance place; approximately the number of significant digits to which the number should be expressed. Win:4.1, Mac:4.1
significance place <integer> of <floating point> | Numbered | The same floating point value, to be expressed to the given decimal place. Win:4.1, Mac:4.1
significance place of <floating point> | Plain | The base 10 logarithm of the significance threshold; approximately the number of digits to the left (positive) or right (negative) of the ones place to which the number should be expressed. Win:4.1, Mac:4.1
significance threshold of <floating point> | Plain | The difference between the given value and the next number expressed to the same significance level. For example, the significance threshold of 3 is 1, the significance threshold of 3.0 is 0.1, and the significance threshold of 3000 is 1000. Win:4.1, Mac:4.1
standard deviation of <floating point> | Plain | The standard deviation of the floating point number(s). Win:5.1, Mac:4.1
standard deviation of <integer> | Plain | The standard deviation of the integer(s). Win:5.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<floating point> as floating point | Cast | <floating point> | This casting operator is added for completeness. It takes a floating point number and casts it as a floating point number. It facilitates automatic relevance generation where the software is not aware of the input types. Win:7.2, Mac:7.2
<floating point> as integer | Cast | <integer> | Rounds off and casts a floating point number as an integer. Win:6.0, Mac:6.0
<floating point> as scientific notation | Cast | <string> | Converts a floating point number into a string with scientific notation. Win:4.1, Mac:4.1
<floating point> as standard notation | Cast | <string> | Converts a floating point number into a string with standard notation. Win:4.1, Mac:4.1
<floating point> as string | Cast | <string> | Converts a floating point number into a string with standard notation. Win:4.1, Mac:4.1
divided by zero of <floating point> | Plain | <boolean> | Returns TRUE if the calculation raised the divide-by-zero exception; that is, if some part of the calculation produced an exact infinity. Win:4.1,
extrema of <floating point> | Plain | <( floating point, floating point )> | Returns the minimum and maximum extreme values of the given list of <floating point> types. Win:7.1, Mac:7.1
finite of <floating point> | Plain | <boolean> | Returns TRUE if the floating point number is finite. Win:4.1, Mac:4.1
inexact of <floating point> | Plain | <boolean> | Returns TRUE if the calculation raised the inexact exception; that is, if some intermediate result could not be represented exactly. Win:4.1,
infinite of <floating point> | Plain | <boolean> | Returns TRUE if the floating point number is infinite. Win:4.1, Mac:4.1
integer ceiling of <floating point> | Plain | <integer> | Returns the smallest integer not less than the floating point number. For example, ceiling of 2.1 = 3, ceiling of 2 = 2 and ceiling of -2.3 = -2. Win:6.0, Mac:6.0
integer floor of <floating point> | Plain | <integer> | Returns the largest integer less than or equal to the floating point number. For example, floor of 2.8 = 2, floor of -2 = -2 and floor of -2.1 = -3. For nonnegative x, this is the same as the integer part of x. Win:6.0, Mac:6.0
invalid of <floating point> | Plain | <boolean> | Returns TRUE if the calculation raised the invalid exception; that is, if some part of the calculation a function was applied to a value outside its domain. Win:4.1,
less significance <integer> of <floating point> | Numbered | <floating point> | Removes <integer> number of digits of significance from the floating point value. Win:4.1, Mac:4.1
maximum of <floating point> | Plain | <floating point> | Returns the maximum value from a list of <floating point> types. Win:7.1, Mac:7.1
mean of <floating point> | Plain | <floating point> | The mean of the floating point number(s). Win:5.1, Mac:4.1
minimum of <floating point> | Plain | <floating point> | Returns the minimum value from a list of <floating point> types. Win:7.1, Mac:7.1
more significance <integer> of <floating point> | Numbered | <floating point> | Adds <integer> number of digits of significance to the floating point value. Win:4.1, Mac:4.1
nan of <floating point> | Plain | <boolean> | Returns TRUE if the value is not a number. Win:4.1, Mac:4.1
normal of <floating point> | Plain | <boolean> | Returns TRUE if the value is a valid floating point number. Win:4.1, Mac:4.1
overflow of <floating point> | Plain | <boolean> | Returns TRUE if the calculation raised the overflow exception; that is, if some intermediate result was too large to be represented, but not an exact infinity. Win:4.1,
relative significance place <integer> of <floating point> | Numbered | <floating point> | The same floating point value, to be expressed to the given number of significant digits. Win:4.1, Mac:4.1
relative significance place of <floating point> | Plain | <floating point> | The base 10 logarithm of the quotient of the value and its significance place; approximately the number of significant digits to which the number should be expressed. Win:4.1, Mac:4.1
significance place <integer> of <floating point> | Numbered | <floating point> | The same floating point value, to be expressed to the given decimal place. Win:4.1, Mac:4.1
significance place of <floating point> | Plain | <floating point> | The base 10 logarithm of the significance threshold; approximately the number of digits to the left (positive) or right (negative) of the ones place to which the number should be expressed. Win:4.1, Mac:4.1
significance threshold of <floating point> | Plain | <floating point> | The difference between the given value and the next number expressed to the same significance level. For example, the significance threshold of 3 is 1, the significance threshold of 3.0 is 0.1, and the significance threshold of 3000 is 1000. Win:4.1, Mac:4.1
standard deviation of <floating point> | Plain | <floating point> | The standard deviation of the floating point number(s). Win:5.1, Mac:4.1
underflow of <floating point> | Plain | <boolean> | Returns TRUE if the calculation raised the underflow exception; that is, if some intermediate result was a nonzero value too small to be represented. Win:4.1,
unique value of <floating point> | Plain | <floating point with multiplicity> | Returns the unique values of a given list of <floating point> types, removing duplicates and sorting by value. Win:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<floating point> {op} <floating point> | <floating point> | Operates on two floating point numbers, returning another floating point number, where: • {op} is one of: +, -, *, /. Win:4.1, Mac:4.1
<floating point> {op} <integer> | <floating point> | Operates on a floating point number and an integer, returning a floating point number, where: • {op} is one of: +, -, *, / . Win:4.1, Mac:4.1
<integer> {cmp} <floating point> | <boolean> | Compares an integer to a floating point number, where: • {cmp} is one of: =, <=, <, >, >=, !=. Win:4.1, Mac:4.1
<integer> {op} <floating point> | <floating point> | Operates on an integer and a floating point number, returning a floating point number, where: • {op} is one of: -, +, *, /. Win:4.1, Mac:4.1

Examples

4.5 as floating point
Returns 4.5.

floating point (floating point "5.2")
Returns a floating point object of 5.2.

less significance 2 of floating point "5.115"
Returns 5.1.

mean of integers(1;2;3;4;5)
Returns 3.0.

more significance 2 of floating point "5.2"
Returns 5.200.

significance place 2 of floating point "9123"
Returns 9100.

significance place of floating point "9000"
Returns 3.00.

standard deviation of integers(1;2;3;4;5)
Returns 1.4.

floating point "600987.9" as scientific notation
Returns 6.009879e+5.

floating point "6.009e8" as standard notation
Returns 600900000.

finite of (floating point "1"/ 0)
Returns FALSE.

infinite of (floating point "1"/ 0)
Returns TRUE.

integer floor of ("-2.1" as floating point)
Returns -3.

less significance 2 of floating point "5.115"
Returns 5.1.

mean of floating points( "1.3";"2.5")
Returns 1.90.

more significance 2 of floating point "5.2"
Returns 5.200.

nan of (floating point "1.e-99999" * floating point "1.e999999")
Returns TRUE.

overflow of (floating point "1.0e50000")
Returns TRUE, since the number is too big to represent in floating point.

significance place 2 of floating point "9123"
Returns 9100.

significance place of floating point "9000"
Returns 3.00.


Floating Point with Multiplicity

These Inspectors deal with floating point arrays, allowing you to pluck out unique floating point numbers and count them. These objects are derived from ordinary floating point types.

Creation Methods

Key Phrase | Form | Description
unique value of <floating point> | Plain | Returns the unique values of a given list of <floating point> types, removing duplicates and sorting by value. Win:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <floating point with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <floating point> types. Win:7.1, Mac:7.1


Folder

For every folder that exists in the file system, you can create a folder object. The properties of this object allow you to examine many aspects of the system. Folder objects are derived from filesystem objects. On the Macintosh, there are dozens of specialized folders; access to them depends on the domain. If the domain is not specified, it defaults to the system domain.

Creation Methods

Key Phrase | Form | Description
<filesystem object> as folder | Cast | Returns a folder or nothing. Mac:4.1
<registry key value> as folder | Cast | If the value in the registry is a string, and the string points to an existing folder, a folder object is returned. Win:1.2
<symlink> as folder | Cast | Converts a symlink object into the folder it points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
ancestor of <filesystem object> | Plain | Returns all ancestor folders (recursive parent folders) of the given filesystem object (file or folder). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
ancestor of <symlink> | Plain | Returns all ancestor folders (recursive parent folders) of the given symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
apple extras folder of <domain> | Plain | Returns the apple extras folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
apple menu items folder of <domain> | Plain | Returns the apple menu items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
application folder <string> of <registry key> | Named | Synonym for pathname of parent folder of regapp <string>. Win:1.2
application folder <string> of <registry> | Named | Creates a folder object for the name given. Name is used to search through AppPaths of the registry. Application doesn't have to exist. Folder must exist. Win:1.2
application folder of <registry key> | Plain | Creates a folder object for the name given. If the registry key has a "shell\open\command\" subkey and the unnamed value points to an executable, this will return the parent folder of the executable if the application and folder exist. Win:1.2
application support folder of <domain> | Plain | Returns the application support folder of the specified OS X domain, typically /Library/Application Support. If the domain is not specified, it defaults to the system domain. Mac:5.1
applications folder of <domain> | Plain | Returns the applications folder of the specified OS X domain, typically /Applications. If the domain is not specified, it defaults to the system domain. Mac:5.1
assistants folder of <domain> | Plain | Returns the assistants folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
audio folder of <domain> | Plain | Returns the audio folder of the specified OS X domain, typically /Library/Audio. If the domain is not specified, it defaults to the system domain. Mac:5.1
cache folder of <domain> | Plain | Returns the cache folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
carbon folder of <domain> | Plain | Returns the carbon folder of the specified OS X domain, typically /Library/Carbon. If the domain is not specified, it defaults to the system domain. Mac:5.1
chewable items folder of <domain> | Plain | Returns the chewable items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
classic folder of <domain> | Plain | Returns the classic folder of the specified OS X domain, typically the /System Folder. If the domain is not specified, it defaults to the system domain. Mac:5.1
client folder of <site> | Plain | Creates an object corresponding to the folder on the client where site data is gathered. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
color sync folder of <domain> | Plain | Returns the color sync folder of the specified OS X domain, typically /System/Library/ColorSync. If the domain is not specified, it defaults to the system domain. Mac:5.1
colorsync profiles folder of <domain> | Plain | Returns the colorsync profiles folder of the specified OS X domain, typically /System/Library/ColorSync/Profiles. If the domain is not specified, it defaults to the system domain. Mac:5.1
component folder of <domain> | Plain | Returns the component folder of the specified OS X domain, typically /System/Library/Components. If the domain is not specified, it defaults to the system domain. Mac:5.1
contextual menu items folder of <domain> | Plain | Returns the contextual menu items folder of the specified OS X domain, typically /Library/Contextual Menu Items. If the domain is not specified, it defaults to the system domain. Mac:5.1
control panels folder of <domain> | Plain | Returns the control panels folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
control strip modules folder of <domain> | Plain | Returns the control strip modules folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
core services folder of <domain> | Plain | Returns the core services folder of the specified OS X domain, typically /System/Library/CoreServices. If the domain is not specified, it defaults to the system domain. Mac:5.1
csidl folder <integer> | NumberedGlobal | Returns the csidl folder corresponding to the specified integer. The windows SHGetSpecialFolderLocation API is used to look up paths to special folders, which are identified by passing the specified integer as the second argument of the API call. These values and their meaning are described in the windows ShlObj.h include file found in the development sdk. • Note that some of these folders do not exist in the Local System context. Win:7.0
current user folder of <domain> | Plain | Returns the current user folder of the specified OS X domain, typically found at /Users/username. If the domain is not specified, it defaults to the system domain. Mac:5.1
descendant folder of <folder> | Plain | Returns the descendant folders, recursively, of the given folder. The folder equivalent of "descendants of <folder>". Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
desktop folder of <domain> | Plain | Returns the desktop folder of the specified OS X domain, typically /Users/Username/Desktop. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer docs folder of <domain> | Plain | Returns the developer docs folder of the specified OS X domain, typically found at /Developer/Documentation. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer folder of <domain> | Plain | Returns the developer folder of the specified OS X domain, typically found at /Developer. If the domain is not specified, it defaults to the system domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
developer help folder of <domain> | Plain | Returns the help folder of the specified OS X domain, typically /Developer/Documentation/Help. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled control panels folder of <domain> | Plain | Returns the control panels folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled extensions folder of <domain> | Plain | Returns the extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled shutdown items folder of <domain> | Plain | Returns the shutdown folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled startup items folder of <domain> | Plain | Returns the startup items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
disabled system extensions folder of <domain> | Plain | Returns the systems extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
documentation folder of <domain> | Plain | Returns the documentation folder for the given OS X domain, typically found at /Library/Documentation. If the domain is not specified, it defaults to the system domain. Mac:5.1
documents folder of <domain> | Plain | Returns the documents folder for the specified OS X domain, typically found at /User/Username/Documents. If the domain is not specified, it defaults to the system domain. Mac:5.1
domain library folder of <domain> | Plain | Returns the domain library folder of the specified OS X domain, typically found at /Library. If the domain is not specified, it defaults to the system domain. Mac:5.1
domain top folder of <domain> | Plain | Returns the top folder of the specified OS X domain, typically found at /System. If the domain is not specified, it defaults to the system domain. Mac:5.1
download folder | PlainGlobal | This inspector is available in relevance subsitution action processing. When the action is active, this inspector returns a folder object of __Download\, otherwise it returns a folder object of __Global\sitename\actionid\named. This inspector is designed for the prefetch process of action execution. • Macintosh Note: Prior to version 7.2, this Inspector referred to the system download folder on the Macintosh. That Inspector is referred to as ISS Download as of version 7.2. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
extensions folder of <domain> | Plain | Returns the extensions folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
favorites folder of <domain> | Plain | Returns the favorites folder of the specified OS X domain, typically /Users/username/Library/Favorites. If the domain is not specified, it defaults to the system domain. Mac:5.1
folder <string> | NamedGlobal | Creates a folder object for the named folder. This is a global property. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
folder <string> of <drive> | Named | Creates a folder object for the name provided if it exists on the drive provided. Win:1.2
folder <string> of <folder> | Named | Creates a folder object for the named sub-folder. Trailing slashes should be omitted from the name. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
folder <symlink> | Index<symlink>Global | Returns the folder pointed to by the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
folder ending in <string> of <folder> | Named | Returns a list of folders ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
folder of <folder> | Plain | Iterates through the sub-folders of the folder object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
fonts folder of <domain> | Plain | Returns the font folder of the specified OS X domain, typically /System/Library/Fonts. If the domain is not specified, it defaults to the system domain. Mac:5.1
framework <string> of <domain> | Named | Returns a folder of the form "/<domain>/Library/Frameworks/<string>.framework”. • Note: This Inspector appends .framework for you, so don't provide it. The framework inspector needs a domain, and without it defaults to the system domain. Mac:5.1
framework folder of <domain> | Plain | Returns the framework folder of the specified OS X domain, typically /System/Library/Frameworks. If the domain is not specified, it defaults to the system domain. Mac:5.1
help folder of <domain> | Plain | Returns the help folder of the specified OS X domain, typically /Library/Documentation/Help. If the domain is not specified, it defaults to the system domain. Mac:5.1
hfs folder <string> | NamedGlobal | Returns the hierachical file system (HFS) folder specified by <string>. Mac:5.1
home directory of <user> | Plain | Returns the dsAttrTypeStandard:NFSHomeDirectory attribute of the specified user. Mac:7.1
install folder <integer> | NumberedGlobal | Creates a folder object corresponding to the number provided. The placement of some system folders can be found using numbers that have been associated with those folders. See notes. Win:1.2
internet plugins folder | PlainGlobal | Returns the folder object corresponding to the internet plugins. Mac:5.1
internet plugins folder of <domain> | Plain | Returns the internet plugins folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
iss download folder | PlainGlobal | The Macintosh download folder. This Inspector was previously labeled "download," which now refers to a world object that performs dynamic downloading. Mac:7.2
iss download folder of <domain> | Plain | Returns the Macintosh download folder for the specified domain. Mac:7.2
kernel extensions folder of <domain> | Plain | Returns the kernel extensions folder of the specified OS X domain, typically /System/Library/Extensions. If the domain is not specified, it defaults to the system domain. Mac:5.1
locales folder of <domain> | Plain | Returns the locales folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
location manager modules folder of <domain> | Plain | Returns the location manager modules folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
location manager preferences folder of <domain> | Plain | Returns the location manager preferences folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
locations folder of <domain> | Plain | Returns the locations folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
macos read me folder of <domain> | Plain | Returns the Mac OS read me folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
modem scripts folder of <domain> | Plain | Returns the modem scripts folder of the specified OS X domain, typically /System/Library/Modem Scripts. If the domain is not specified, it defaults to the system domain. Mac:5.1
parent folder of <filesystem object> | Plain | The folder containing the specified file or folder. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:4.1
parent folder of <symlink> | Plain | Creates a folder object corresponding to the parent folder of the given symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
posix folder <string> | NamedGlobal | Returns the POSIX folder specified by <string>. Mac:5.1
preferences folder of <domain> | Plain | Returns the preferences folder of the specified OS X domain, typically /Users/username/Library/Preferences. If the domain is not specified, it defaults to the system domain. Mac:5.1
printer descriptions folder of <domain> | Plain | Returns the printer descriptions folder of the specified OS X domain, typically /System/Library/Printers/PPDs. If the domain is not specified, it defaults to the system domain. Mac:5.1
printer drivers folder of <domain> | Plain | Returns the printer drivers folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
printers folder of <domain> | Plain | Returns the printers folder of the specified OS X domain, typically /System/Library/Printers. If the domain is not specified, it defaults to the system domain. Mac:5.1
printmonitor documents folder of <domain> | Plain | Returns the printmonitor documents folder of the specified OS X domain, typically /Library/Printers/PrintMonitor Documents. If the domain is not specified, it defaults to the system domain. Mac:5.1
private framework folder of <domain> | Plain | Returns the private framework folder of the specified OS X domain, typically /System/Library/PrivateFrameworks. If the domain is not specified, it defaults to the system domain. Mac:5.1
quicktime folder of <domain> | Plain | Returns the quicktime folder of the specified OS X domain, typically /System/Library/QuickTime. If the domain is not specified, it defaults to the system domain. Mac:5.1
receipts folder of <domain> | Plain | Returns the receipts folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
relative folder <string> of <folder> | Named | Returns the folder with the path specified by <string> relative to the given <folder>. Mac:5.1
relative hfs folder <string> of <folder> | Named | Returns the HFS folder with the path specified by <string> relative to the given <folder>. Mac:5.1
relative posix folder <string> of <folder> | Named | Returns the POSIX folder with the path specified by <string> relative to the given <folder>. Mac:5.1
root folder | PlainGlobal | Returns the folder corresponding to ‘/’. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
root folder of <drive> | Plain | Creates a folder object for the root of the given drive. Win:1.2
scripting additions folder of <domain> | Plain | Returns the scripting additions folder of the specified OS X domain, typically /System/Library/Scripting Additions. If the domain is not specified, it defaults to the system domain. Mac:5.1
shared folder of <domain> | Plain | Returns the shared folder of the specified OS X domain, typically /Users/Shared. If the domain is not specified, it defaults to the system domain. Mac:5.1
shared libraries folder of <domain> | Plain | Returns the shared libraries folder of the specified OS X domain, typically /System/Library/CFMSupport. If the domain is not specified, it defaults to the system domain. Mac:5.1
shutdown items folder of <domain> | Plain | Returns the shutdown items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
sibling folder <string> of <filesystem object> | Named | A named property. A folder in the same folder as the specified file object. Mac:4.1
sound folder of <domain> | Plain | Returns the sound folder of the specified OS X domain, typically /System/Library/Sound. If the domain is not specified, it defaults to the system domain. Mac:5.1
speech folder of <domain> | Plain | Returns the speech folder of the specified OS X domain, typically /System/Library/Speech. If the domain is not specified, it defaults to the system domain. Mac:5.1
startup items folder of <domain> | Plain | Returns the startup items folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
system folder of <domain> | Plain | Returns the system folder of the specified OS X domain, typically /System. If the domain is not specified, it defaults to the system domain. Mac:5.1
system wow64 folder | PlainGlobal | Returns a filesystem object corresponding to a "Windows On Windows 64" system folder, which does not exist on 32-bit Windows. You can find out more about the WOW64 system folder at the Microsoft site: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/sysinfo/base/getsystemwow64directory.asp. Win:6.0
system x32 folder | PlainGlobal | Returns a filesystem object corresponding to a 32-bit system folder. On a 32-bit machine, this is equivalent to the normal system folder. Win:6.0
system x64 folder | PlainGlobal | Returns a filesystem object corresponding to a 64-bit system folder. This is the same as the system folder, but with file system redirection disabled. For more information about file redirection, see the Microsoft site http://msdn.microsoft.com/library/default.asp?url=/library/en-us/win64/win64/file_system_redirector.asp. Win:6.0
temporary items folder of <domain> | Plain | Returns the temporary items folder of the specified OS X domain, typically /private/tmp/. If the domain is not specified, it defaults to the system domain. Mac:5.1
text encodings folder of <domain> | Plain | Returns the text encodings folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
themes folder of <domain> | Plain | Returns the themes folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
user temp folder of <domain> | Plain | Returns the user temp folder of the specified OS X domain, typically /private/tmp/uid where uid is the user ID number. If the domain is not specified, it defaults to the system domain. Mac:5.1
users folder of <domain> | Plain | Returns the users folder of the specified OS X domain, typically /Users. If the domain is not specified, it defaults to the system domain. Mac:5.1
utilities folder of <domain> | Plain | Returns the utilities folder of the specified OS X domain, typically /Applications/Utilities. If the domain is not specified, it defaults to the system domain. Mac:5.1
voices folder of <domain> | Plain | Returns the voices folder of the specified OS X domain, typically /System/Library/Speech/Voices. If the domain is not specified, it defaults to the system domain. Mac:5.1
volume settings folder of <domain> | Plain | Returns the volume settings folder of the specified OS X domain. If the domain is not specified, it defaults to the system domain. Mac:5.1
windows folder | PlainGlobal | Creates a folder object of the Windows folder. This is operating system dependent. Under Win98 this is usually c:\Windows. Win:1.2
x32 folder <string> | NamedGlobal | Returns a filesystem object corresponding to a 32-bit folder with the specified pathname. Win:6.0
x64 folder <string> | NamedGlobal | Returns a filesystem object corresponding to a 64-bit folder with the given pathname. On a 32-bit computer, this is equivalent to a normal folder Inspector, but on a 64-bit machine, this Inspector returns an object that has filesystem redirection disabled. This action is transitive: any resulting filesystem objects will also have redirection disabled. For example, "pathnames of files of x64 folder <path>" will disable redirection when locating the folder, iterating over the files in the folder and calculating pathnames. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
application <string> of <folder> | Named | <application> | Returns an application object for the named file located in the folder. See application. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
application of <folder> | Plain | <filesystem object> | Recursively finds executables in the supplied folder, returning a list of "application" objects, which are basically filesystem_objects. Mac:7.1
bundle of <folder> | Plain | <bundle> | Returns a bundle from a folder (if it has one like application folders do). Mac:4.1
bundle version of <folder> | Plain | <version> | Returns the version of the folder corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
descendant folder of <folder> | Plain | <folder> | Returns the descendant folders, recursively, of the given folder. The folder equivalent of "descendants of <folder>". Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
descendant of <folder> | Plain | <file> | Returns a list of all the descendant files of the specified folder. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:6.0
drive of <folder> | Plain | <filesystem> | Creates the drive object corresponding to the folder location. Included for compatibility with Windows machines, this Inspector is the same as filesystem of <folder>. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
drive of <folder> | Plain | <volume> | Returns the drive associated with the specified folder. Mac:5.1
file <string> of <folder> | Named | <file> | Returns a file object for the named file located in the folder. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
file ending in <string> of <folder> | Named | <file> | Returns a list of files ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
file of <folder> | Plain | <file> | Iterates through the files of a folder returning file objects. When combined with a whose clause you can select files with specific properties. See file. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
filesystem of <folder> | Plain | <filesystem> | Returns the filesystem on which the folder resides. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
filesystem of <folder> | Plain | <volume> | Returns the volume corresponding to the filesystem of the specified folder. Mac:6.0
find file <string> of <folder> | Named | <file> | Iterates through the files of a folder returning file objects whose name matches the search string provided in the name parameter. See example below. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
folder <string> of <folder> | Named | <folder> | Returns a folder object for the named sub-folder. Trailing slashes should be omitted from the name. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
folder ending in <string> of <folder> | Named | <folder> | Returns a list of folders ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
folder of <folder> | Plain | <folder> | Iterates through the folders of a folder returning folder objects. When combined with a whose clause, you can select folders with specific properties. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
item <string> of <folder> | Named | <filesystem object> | Returns the named item (file or folder) from the specified folder. Mac:5.1
item ending in <string> of <folder> | Named | <filesystem object> | Returns a list of items (files/folders) ending in "xxxx". Typically used to identify a dotted extension. Equivalent to a wildcard search for “*xxxx”. Mac:6.0
item of <folder> | Plain | <filesystem object> | Returns a list of the items (file or folder) in the specified folder. Mac:4.1
relative file <string> of <folder> | Named | <file> | Returns the file with the path specified by <string> relative to the given <folder>. Mac:5.1
relative folder <string> of <folder> | Named | <folder> | Returns the folder with the path specified by <string> relative to the given <folder>. Mac:5.1
relative hfs file <string> of <folder> | Named | <file> | Returns the HFS file with the path specified by <string> relative to the given <folder>. Mac:5.1
relative hfs folder <string> of <folder> | Named | <folder> | Returns the HFS folder with the path specified by <string> relative to the given <folder>. Mac:5.1
relative posix file <string> of <folder> | Named | <file> | Returns the POSIX file with the path specified by <string> relative to the given <folder>. Mac:5.1
relative posix folder <string> of <folder> | Named | <folder> | Returns the POSIX folder with the path specified by <string> relative to the given <folder>. Mac:5.1
security descriptor of <folder> | Plain | <security descriptor> | Specifies the security descriptor associated with the specified folder. Win:4.1
symlink <string> of <folder> | Named | <symlink> | Returns the named symlink from the specified folder. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink of <folder> | Plain | <symlink> | Returns the symlink(s) in the specified folder, whether or not they are broken. • NOTE: This behavior differs from looking for files in a folder. Although that returns links along with the files, it doesn't return broken links. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
version of <folder> | Plain | <version> | Returns a version for a folder representing an application. Mac:4.1
volume of <folder> | Plain | <volume> | The volume containing the specified folder. Mac:4.1

Note

Folder and file names may be case sensitive. Use “as uppercase” or “as lowercase” if you don’t know the actual case when making comparisons. Be careful not to iterate through folders that contain a large number of files. Counting files in such a folder can be slow. Always try to use the most efficient techniques to minimize the client overhead. Consider using the “find file” Inspector which allows you to filter sets of files by using the wildcard.

Examples

color sync folder of system domain
Returns /System/Library/ColorSync.

color sync folder of local domain
Returns /Library/ColorSync.

application support folder of user domain
Returns /var/root/Library/Application Support.

wait "{pathname of file "update.exe" of download folder}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

framework "MyPrivate" of local domain
Returns /Library/Frameworks/MyPrivate.framework.

install folder 11
Returns a folder object for system folder identified with this number.

applications of folder "/Users/fizzle/bin"
Returns a list of applications in the specified directory, such as /Users/fizzle/bin/p4, /Users/fizzle/bin/mylocaltool.

exists (bundle of applications folder)
Typically returns TRUE.

files ending in ".a" of folder "/usr/lib"
Returns a list of files with the specified ending, such as: /usr/lib/libcpp_kext.a, /usr/lib/libfl.a, /usr/lib/libioabc.a, etc.


Hertz

The hertz object is useful to measure clock cycles. It is used primarily to measure clock frequency by the speed of the processor Inspector. Hertz objects have a resolution of 1 hertz and are stored internally as a 64 bit signed integer.

Creation Methods

Key Phrase | Form | Description
absolute value of <hertz> | Plain | Creates a hertz object with a positive value. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
ghz | PlainGlobal | Creates a hertz object corresponding to 1 giga-hertz. For example, ghz = 1000*mhz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
greatest hz | PlainGlobal | Creates the largest hertz object that can be represented on the current machine. It returns the value 9,223,372,036,854,775,807 hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hz | PlainGlobal | Creates a hertz object corresponding to 1 hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
khz | PlainGlobal | Creates a hertz object corresponding to 1 kilohertz. For example, khz = 1000*hz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
least hz | PlainGlobal | Creates the largest negative hertz object that can be represented on the current machine. It returns the value -9,223,372,036,854,775,808 hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
maximum of <hertz> | Plain | Returns the maximum value from a list of <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
mhz | PlainGlobal | Creates a hertz object corresponding to 1 megahertz. For example, mhz = 1000*khz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
minimum of <hertz> | Plain | Returns the minimum value from a list of <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
significant digits <integer> of <hertz> | Numbered | Rounds up the value of a hertz object with <integer> significant digits. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<hertz> as string | Cast | <string> | Returns a string formatted "##### hertz". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
absolute value of <hertz> | Plain | <hertz> | Returns the positive value of the hertz object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
extrema of <hertz> | Plain | <( hertz, hertz )> | Returns the minimum and maximum extreme values of the given list of <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <hertz> | Plain | <hertz> | Returns the maximum value from a list of <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <hertz> | Plain | <hertz> | Returns the minimum value from a list of <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
significant digits <integer> of <hertz> | Numbered | <hertz> | Returns the value of a hertz object with <integer> significant digits (e.g.. significant digits 3 of 1235569 = 1240000). Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
unique value of <hertz> | Plain | <hertz with multiplicity> | Returns the unique values of a given list of <hertz> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
- <hertz> | <hertz> | Returns the negative of the <hertz> value. Win:2.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
<hertz> {cmp} <hertz> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<hertz> {op} <hertz> | <hertz> | Returns a hertz object equal to the result of the operation, where: • {op} is one of: +, -, mod . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<hertz> {op} <integer> | <hertz> | Returns a hertz object equal to the result of the operation, where: • {op} is one of: *, / . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Examples

speed of processor > 3*ghz
Returns TRUE on machines faster than 3Ghz.

greatest hz
Returns a large positive value, such as 9223372036854775807 hertz.

least hz
Returns a large negative value, such as -9223372036854775808 hertz.

significant digits 3 of 1235569
Returns 1240000.

speed of processor
Returns the speed of the processor in hz, such as 3394000000 hertz for a 3.4 GHz computer.


Hertz with Multiplicity

These Inspectors deal with hertz arrays, allowing you to pluck out unique hertz values and count them. These objects are derived from ordinary hertz types.

Creation Methods

Key Phrase | Form | Description
unique value of <hertz> | Plain | Returns the unique values of a given list of <hertz> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <hertz with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <hertz> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Hours

These Inspectors examine parts of a time field.

Creation Methods

Key Phrase | Form | Description
time of <time> | Plain | The hour, minute and second derived from the given time. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
hour of <hours> | Plain | <integer> | The hour portion of a time. Mac:4.1
minute of <hours> | Plain | <integer> | The minute portion of a time. Mac:4.1
second of <hours> | Plain | <integer> | The second portion of a time. Mac:4.1

Operators

Key phrase | Return Type | Description
<hours> {cmp} <hours> | <boolean> | Compares two hours, where: • {cmp} is one of: =, <, <=. Mac:4.1

Examples

hour of now
Returns the hour of the current time.

minute of now
Returns the minute of the current time.

second of now
Returns the second of the current time.


Integer

Integers are represented internally as 64-bit signed values.

Creation Methods

These integer creation methods are in addition to the other properties that return the integer type.

Key Phrase | Form | Description
<floating point> as integer | Cast | Rounds off and casts a floating point number as an integer. Win:6.0, Mac:6.0
<integer> as integer | Cast | Integer casting for completeness. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as integer | Cast | Converts from a string to an integer. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
absolute value of <integer> | Plain | Creates the positive value of the <integer> object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
cpu speed | PlainGlobal | Returns the clock speed of the cpu in Hz. Mac:4.1
gestalt <string> | NamedGlobal | This reads a 32 bit integer from the MacOS. The selector name is the four character OSType that chooses which item is being inspected. The interpretation of the result depends on the selector. It might represent an integer or a version, for instance. Mac:4.1
greatest integer | PlainGlobal | Creates the value 9,223,372,036,854,775,807. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hexadecimal integer <string> | NamedGlobal | Creates an integer from the provided hexadecimal value. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
integer <integer> | NumberedGlobal | Creates a global object with the given integer value, e.g., Integer 123. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
integer <string> | NamedGlobal | Creates a global object with the integer value given by a string, e.g., Integer "123" creates the value 123. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
integer ceiling of <floating point> | Plain | Returns the smallest integer not less than the floating point number. For example, ceiling of 2.1 = 3, ceiling of 2 = 2 and ceiling of -2.3 = -2. Win:6.0, Mac:6.0
integer floor of <floating point> | Plain | Returns the largest integer less than or equal to the floating point number. For example, floor of 2.8 = 2, floor of -2 = -2 and floor of -2.1 = -3. For nonnegative x, this is the same as the integer part of x. Win:6.0, Mac:6.0
keyboard type | PlainGlobal | Returns the keyboard type. Mac:4.1
least integer | PlainGlobal | Creates the value -9,223,372,036,854,775,808. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
length of <rope> | Plain | Creates an integer object corresponding to the number of bytes in the rope. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
length of <string> | Plain | Creates an integer object corresponding to the number of bytes in the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
lower bound of <integer range> | Plain | The low end of the integer range. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
machine type | PlainGlobal | Returns the machine type. The value is from a long enumeration of all Mac platforms. See the header file Gestalt.h. Mac:4.1
maximum of <integer> | Plain | Returns the maximum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
minimum of <integer> | Plain | Returns the minimum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
nubus map | PlainGlobal | Returns the nubus map. Mac:4.1
numeric value of <string> | Plain | Creates an integer object containing the value of the first number contained in a string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
physical ram | PlainGlobal | Returns the amount of physical ram in the computer. Mac:4.1
product of <integer> | Plain | Multiplies a list of integers, returning the product. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
significant digits <integer> of <integer> | Numbered | Creates a number with <integer> significant digits (e.g.. significant digits 3 of 1235569 = 1240000). Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
sum of <integer> | Plain | Returns the sum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
upper bound of <integer range> | Plain | The high end of the integer range. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Properties

Integers are represented internally as 64-bit signed values.

Key Phrase | Form | Return Type | Description
<integer> as bit set | Cast | <bit set> | Returns the bits of the binary representation of the integer; bit zero is the least-significant bit. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<integer> as bits | Cast | <bit set> | Returns the bits of the binary representation of the integer; bit zero is the least-significant bit. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
<integer> as day_of_month | Cast | <day of month> | Cast an integer as a day of the month type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<integer> as floating point | Cast | <floating point> | Converts an integer into a floating point number. Win:4.1, Mac:4.1
<integer> as hexadecimal | Cast | <string> | Converts an integer into a hexadecimal string. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
<integer> as integer | Cast | <integer> | Reflective cast for completeness. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<integer> as month | Cast | <month> | Returns the name of the nth month of the year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<integer> as string | Cast | <string> | Converts an integer to a string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<integer> as year | Cast | <year> | Casts an integer as a year type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
absolute value of <integer> | Plain | <integer> | Returns the positive value of the integer. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
bit <integer> of <integer> | Numbered | <boolean> | Returns TRUE if the numbered bit is on. Bits are numbered starting at zero. Bit 0 is the least significant bit. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
extrema of <integer> | Plain | <( integer, integer )> | Returns the minimum and maximum extreme values of the given list of <integer> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <integer> | Plain | <integer> | Returns the maximum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
mean of <integer> | Plain | <floating point> | The mean of the integer(s). Win:5.1, Mac:4.1
minimum of <integer> | Plain | <integer> | Returns the minimum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
product of <integer> | Plain | <integer> | Multiplies a list of integers, returning the product. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
set of <integer> | Plain | <integer set> | Creates a set from the given list of semicolon-separated integers. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
significant digits <integer> of <integer> | Numbered | <integer> | Returns a number with <integer> significant digits (e.g., significant digits 3 of 1235569 = 1240000). Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
standard deviation of <integer> | Plain | <floating point> | The standard deviation of the integer(s). Win:5.1, Mac:4.1
sum of <integer> | Plain | <integer> | Returns the sum of a list of integers. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
unique value of <integer> | Plain | <integer with multiplicity> | Returns the unique values of a given list of <integer> types, removing duplicates and sorting by value. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Operators

Key phrase | Return Type | Description
<floating point> {cmp} <integer> | <boolean> | Compares a floating point number and an integer, where: • {cmp} is one of: =, <=, <. Win:4.1, Mac:4.1
<floating point> {op} <integer> | <floating point> | Operates on a floating point number and an integer, returning a floating point number, where: • {op} is one of: +, -, *, /, And . Win:4.1, Mac:4.1
<hertz> {op} <integer> | <hertz> | Returns a hertz object operated on by the given integer, where: • {op} is one of: *, / . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<integer set> contains <integer> | <boolean> | Returns TRUE if the specified set contains the given integer. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer> * <number of months> | <number of months> | Multiply a number of months by an integer, producing a new number of months. This is a typical technique to create a value of this type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<integer> * <time range> | <timed( time range, integer )> | Returns a tuple of a time interval and an integer. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<integer> {cmp} <floating point> | <boolean> | Compares an integer to a floating point number, where: • {cmp} is one of: =, <=, <. Win:4.1, Mac:4.1
<integer> {cmp} <integer> | <boolean> | Returns boolean TRUE or FALSE, depending on the comparison operator, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<integer> {cmp} <registry key value type> | <boolean> | Returns boolean TRUE or FALSE, depending on the comparison operator, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<integer> {cmp} <registry key value> | <boolean> | Returns boolean TRUE or FALSE, depending on the comparison operator, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<integer> {op} <floating point> | <floating point> | Operates on an integer and a floating point number, returning a floating point number, where: • {op} is one of: -, +, *, /. Win:4.1, Mac:4.1
<integer> {op} <integer> | <integer> | Returns the integer solution to the equation, depending on the operator, where: • {op} is one of: +, -, *, /, mod . Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<number of months> {op} <integer> | <number of months> | Where {op} is one of: *, /. Win:6.0
<time range> * <integer> | <timed( time range, integer )> | Returns a time interval labeled with the specified integer, in the form of: • (<date> to <date>), <integer>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Examples

hexadecimal integer "A0"
Returns 160.

numeric value of "string 123 xyz 45" = 123
Returns TRUE.

255 as hexadecimal
Returns the string "ff".

maximum of (7;2;4;5)
Returns 7.

set of (3; 2; 2; 1; -1) contains 4
Returns TRUE.

set of (3; 2; 2; 1; -1) contains set of (2; -1)
Returns TRUE.

set of (3; 2; 2; 1; -1) = set of (2; -1)
Returns FALSE.

significant digits 3 of 1235569
Returns 1240000.

set of (1;2;3) contains 3
Returns TRUE.

21 mod 5
Returns 1.


Integer Range

These Inspectors specify a range between two 64-bit signed integers.

Creation Methods

Key Phrase | Form | Description
distance of <selected server> | Plain | The distance, in IP gateway hops, to the server. Among servers with the same priority, closer servers are preferred. Returns an integer range, since the exact distance may not be known. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
lower bound of <integer range> | Plain | <integer> | The low end of the integer range. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
upper bound of <integer range> | Plain | <integer> | The high end of the integer range. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Integer Set

These Inspectors deal with sets of integers, which are essentially lists or arrays with integer elements. Think of them as mathematical sets: you can compare them, subtract them from other sets and form the union and intersection of multiple sets.
• Note: These Inspectors are not available on SUSE Linux systems.

Creation Methods

Key Phrase | Form | Description
set of <integer> | Plain | Creates a set from the given integers (usually plural). Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
union of <integer set> | Plain | Returns a set of integers equal to the union of the specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
element of <integer set> | Plain | <integer> | Returns the unique elements of the specified <integer set>, removing duplicates and sorting by value. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
intersection of <integer set> | Plain | <integer set> | Returns a set of integers equal to the intersection of the specified sets, in numeric order and with redundant elements stripped out. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
size of <integer set> | Plain | <integer> | Returns the number of unique elements in the specified set. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
union of <integer set> | Plain | <integer set> | Returns a set of integers equal to the union of the specified sets, in numeric order and with redundant elements stripped out. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<integer set> - <integer set> | <integer set> | Subtracts the elements in the second set from the elements in the first. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer set> * <integer set> | <integer set> | Returns the intersection of the two specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer set> + <integer set> | <integer set> | Returns the union of the specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer set> = <integer set> | <boolean> | Returns TRUE if the specified sets have identical contents. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer set> contains <integer set> | <boolean> | Returns TRUE if the first set contains all the elements of the second set. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<integer set> contains <integer> | <boolean> | Returns TRUE if the specified set contains the given integer. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Examples

set of (3; 2; 2; 1; -1) contains 3
Returns TRUE.

set of (3; 2; 2; 1; -1) contains set of (2; -1)
Returns TRUE.

set of (3; 2; 2; 1; -1) = set of (2; -1)
Returns FALSE.

elements of union of (set of (1;2;3); set of (2;3;4); set of (5;6))
Returns the list: 1,2,3,4,5,6.

elements of set of (5;7;2;3;3;3)
Returns the integers 2,3,5,7.

elements of intersection of (set of (3;2;1); set of (2;3;4))
Returns the list: 2,3.

intersection of (set of (-1; 2); set of (2; 1; 3); set of (2; 5))
Returns 2.

size of set of (3; 2; 2; 1; -1)
Returns 4, the number of unique elements in the defined set.

elements of union of (set of (1;2;3); set of (2;3;4))
Returns the list: 1,2,3,4.

elements of (set of (1;2;3) - set of (2;3;4))
Returns 1.

elements of (set of (1;2;3) * set of (2;3;4))
Returns the list: 2,3.

elements of (set of (1;2;3) * set of (2;3;4) * set of (3;4;5))
Returns 3.

elements of (set of (1;2;3) + set of (2;3;4))
Returns the list: 1,2,3,4.

set of (3; 2; 2; 1; -1) = set of (2; -1)
Returns FALSE.

set of (1;2;3) contains set of (2;3)
Returns TRUE.

set of (1;2;3) contains 2
Returns TRUE.


Integer with Multiplicity

These Inspectors deal with arrays of integers, allowing you to pluck out unique numbers and count them. These objects are derived from integer types.

Creation Methods

Key Phrase | Form | Description
unique value of <integer> | Plain | Returns the unique values of a given list of integers, removing duplicates and sorting by value. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <integer with multiplicity> | Plain | <integer> | Returns the multiplicity (quantity) of each element in a multiple integer list. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Internet Connection Firewall

These Inspectors provide access to the settings of the Internet Connection Firewall introduced in Windows XP. The Internet Connection Firewall helps to protect a computer that is directly connected to the Internet, or a home network, from network attacks.

Creation Methods

Key Phrase | Form | Description
firewall of <connection> | Plain | Returns the internet connection firewall object corresponding to the specified connection. Win:5.0
internet connection firewall of <network adapter> | Plain | Creates a Windows XP firewall object. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
enabled of <internet connection firewall> | Plain | <boolean> | Returns TRUE if the local computer has the Windows XP built-in firewall enabled. Win:4.1
port mapping of <internet connection firewall> | Plain | <port mapping> | Creates a port mapping object for the built-in firewall. Win:4.1


Internet Protocol

Returns the firewall internet protocol corresponding to the Microsoft enumerated types, either tcp or udp. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
internet protocol <integer> | NumberedGlobal | Returns the firewall internet protocol specified, either tcp or udp. These correspond to the Microsoft Windows Firewall enumerated types: • NET_FW_IP_PROTOCOL_TCP • NET_FW_IP_PROTOCOL_UDP. Win:5.1
protocol of <firewall open port> | Plain | Returns the Protocol property of the firewall open port. Win:5.1
protocol of <firewall rule> | Plain | Retrieves the Protocol property for the specified firewall rule. The firewall rule Inspectors are wrappers around the Windows Vista Firewall API. For more information, see the MSDN library for INetFwRule. Win:7.0
tcp | PlainGlobal | Returns an internet protocol corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_IP_PROTOCOL_TCP. Win:5.1
udp | PlainGlobal | Returns an internet protocol corresponding to the Microsoft Windows Firewall enumerated type: NET_FW_IP_PROTOCOL_UDP. Win:5.1

Operators

Key phrase | Return Type | Description
<internet protocol> = <internet protocol> | <boolean> | Compares two firewall internet protocols for equality only. Win:5.1


Ip Address

These are the Internet Protocol address Inspectors. IP addresses are composed of four single-byte integers separated by periods, like "192.5.0.7".

Creation Methods

Key Phrase | Form | Description
ip address <string> | NamedGlobal | Returns the internal form of an ip address from the given string. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<ip address> as string | Cast | <string> | Cast an IP address as a string. Mac:4.1

Operators

Key phrase | Return Type | Description
<ip address> = <ip address> | <boolean> | Compare two IP addresses. Mac:4.1


Ip Version

Returns the firewall ip version information corresponding to the Microsoft enumerated types, either ipv4 or ipv6. The Windows Firewall is supported on Windows XP SP2. For more information, search for 'Windows Firewall API' at the msdn site (http://msdn.microsoft.com/library/).

Creation Methods

Key Phrase | Form | Description
any ip version | PlainGlobal | Returns a type corresponding to the Microsoft enumerated value NET_FW_IP_VERSION_ANY. Win:5.1
ip version <integer> | NumberedGlobal | Returns the the IP version for the <integer> port corresponding to the Microsoft enumerated types: • NET_FW_IP_VERSION_V4 • NET_FW_IP_VERSION_V6 • NET_FW_IP_VERSION_ANY • NET_FW_IP_VERSION_MAX. Win:5.1
ip version of <firewall authorized application> | Plain | Returns the the IP version for the specified firewall authorized application. Win:5.1
ip version of <firewall open port> | Plain | Returns the the IP version for the specified firewall open port. Win:5.1
ip version of <firewall service> | Plain | Returns the the IP version for the specified firewall service. Win:5.1
ipv4 | PlainGlobal | Provides a comparison value for a firewall ip version inspector. Win:5.1
ipv6 | PlainGlobal | Provides a comparison value for a firewall ip version inspector. Win:5.1

Operators

Key phrase | Return Type | Description
<ip version> = <ip version> | <boolean> | Compares two firewall ip versions for equality only. Win:5.1


Ipv4 Address

This is an Internet Protocol address, version 4. IP addresses are composed of four single-byte integers separated by periods, like "192.5.0.7".

Creation Methods

Key Phrase | Form | Description
address of <network adapter> | Plain | Returns the ip address of the network adapter. Win:2.0, Mac:7.1
address of <network address list> | Plain | Returns the ip address of the network adapter list. Win:2.0
address of <network ip interface> | Plain | Creates an object with the ip address of the interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
broadcast address of <network adapter> | Plain | Creates an object with the ipv4 broadcast address of the specified network adapter. Mac:7.1
broadcast address of <network ip interface> | Plain | Creates an object with the broadcast address of the interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
dhcp server of <network adapter> | Plain | Returns the ip address of the dhcp server of the network adapter. Win:2.0
gateway address <integer> of <selected server> | Numbered | The ip address of a gateway between the agent and the selected server at the given distance from the agent, if known. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
gateway address of <selected server> | Plain | All known ip addresses of gateways between the agent and the selected server. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
gateway of <network adapter> | Plain | Returns the ip address of the gateway of the network adapter. Win:2.0
ip address of <selected server> | Plain | The ip address to which reports are sent. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ipv4 address <string> | NamedGlobal | Creates an object with an ip address for the string provided. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ipv4 part of <ipv6 address> | Plain | Returns the lowest 32-bits of the IPv6 address as an IPv4 address. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <ipv4 address> | Plain | Returns the maximum value from a list of <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <ipv4 address> | Plain | Returns the minimum value from a list of <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
primary wins server of <network adapter> | Plain | Returns the ip address of the primary wins server of the network adapter. Win:2.0
secondary wins server of <network adapter> | Plain | Returns the ip address of the secondary wins server of the network adapter. Win:2.0
subnet address of <network adapter> | Plain | Returns the subnet address of the network adapter. Win:2.0, Mac:7.1
subnet address of <network address list> | Plain | Returns the subnet address of the network address list. Win:2.0
subnet address of <network ip interface> | Plain | Creates an object with the subnet address of the network interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
subnet mask of <network adapter> | Plain | Returns the subnet mask of the network adapter. Win:2.0, Mac:7.1
subnet mask of <network address list> | Plain | Returns the subnet mask of the network adapter list. Win:2.0
subnet mask of <network ip interface> | Plain | Creates an object with the address bitwise ANDed with the subnet mask. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
target ip address of <port mapping> | Plain | Returns the target IP address of the specified port mapping. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<ipv4 address> as ipv6 address | Cast | <ipv6 address> | Returns the specified IPv4 address embedded in a IPv6 address space as defined by RFC 4291 section 2.5.5.2: IPv4-Mapped IPv6 Address. In this scheme the lowest 32 bits of the IPv6 address contain the IPv4 address, the next higher 16 bits are all 1 (ffff) and the remaining bits are all 0. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<ipv4 address> as string | Cast | <string> | Converts the ipv4 address to a string. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
extrema of <ipv4 address> | Plain | <( ipv4 address, ipv4 address )> | Returns the minimum and maximum extreme values of the given list of <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <ipv4 address> | Plain | <ipv4 address> | Returns the maximum value from a list of <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <ipv4 address> | Plain | <ipv4 address> | Returns the minimum value from a list of <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <ipv4 address> | Plain | <ipv4 address with multiplicity> | Returns the unique values of a given list of <ipv4 address> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<ipv4 address> {cmp} <ipv4 address> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
<ipv4 address> {cmp} <string> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1

Examples

exists ip interface whose (address of it = "127.0.0.1" and loopback of it) of network
Returns TRUE if the specified ip interface (with loopback) exists on this computer.

addresses of ip interfaces of network
Returns a list of IP addresses configured on the machine.

ipv4 address "192.168.100.1"
Returns the four-byte ip address 192.168.100.1.


Ipv4 Address with Multiplicity

These Inspectors deal with ipv4 address arrays, allowing you to pluck out unique ipv4 addresses and count them. These objects are derived from ordinary ipv4 address types.

Creation Methods

Key Phrase | Form | Description
unique value of <ipv4 address> | Plain | Returns the unique values of a given list of <ipv4 address> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <ipv4 address with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <ipv4 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Ipv6 Address

These Inspectors deal with the Internet Protocol addressing scheme, version 6.

Creation Methods

Key Phrase | Form | Description
<ipv4 address> as ipv6 address | Cast | Returns the specified IPv4 address embedded in a IPv6 address space as defined by RFC 4291 section 2.5.5.2: IPv4-Mapped IPv6 Address. In this scheme the lowest 32 bits of the IPv6 address contain the IPv4 address, the next higher 16 bits are all 1 (ffff) and the remaining bits are all 0. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<string> as ipv6 address | Cast | Converts a string representations of an IPv6 address (with colons and/or dots) as an IPv6 address type. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
ipv6 address <string> | NamedGlobal | Converts a string representations of an IPv6 address (with colons and/or dots) as an IPv6 address type. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
ipv6 address of <network adapter> | Plain | Returns the local IPv6 address of the adapter. Only for XP/Server 2003 and later. Win:7.0
ipv6 dns server of <network adapter> | Plain | Returns the DNS server IPv6 address of the adapter. Only for XP/Server 2003 and later. Win:7.0
maximum of <ipv6 address> | Plain | Returns the maximum value from a list of <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <ipv6 address> | Plain | Returns the minimum value from a list of <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<ipv6 address> as compressed string | Cast | <string> | Similar to casting as a string, but with double colons used to represent multiple zero 16-bit parts (RFC 4291 section 2.2, item 2). Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<ipv6 address> as compressed string with ipv4 | Cast | <string> | Similar to casting as a string, but with both colon-compression and standard IPv4 representation for the low 32-bits. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<ipv6 address> as string | Cast | <string> | Returns a string representation of the IPv6 address in the form x:x:x:x:x:x:x:x, where each x represents one to four hexadecimal digits of the eight 16-bit address fields. Leading zeros in an individual field are omitted. See RFC 4291 section 2.2, item 1. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<ipv6 address> as string with ipv4 | Cast | <string> | Similar to casting as a string, but with the lowest 32 bits of the address in the standard IPv4 representation (RFC 4291 section 2.2, item 3). Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<ipv6 address> as string with leading zeros | Cast | <string> | Similar to casting as a string, but leading zeros in individual fields are preserved. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
extrema of <ipv6 address> | Plain | <( ipv6 address, ipv6 address )> | Returns the minimum and maximum extreme values of the given list of <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
hexadecet <integer> of <ipv6 address> | Numbered | <integer> | Returns one of the eight 16-bit parts (hexadecets) of an IPv6 address specified by <integer>. Here zero refers to the highest hexadecet (network or big-endian order). Thus hexadecet 0 refers to the most-significant 16-bits of the 128 bit IPv6 address. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
ipv4 part of <ipv6 address> | Plain | <ipv4 address> | Returns the lowest 32-bits of the IPv6 address as an IPv4 address. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <ipv6 address> | Plain | <ipv6 address> | Returns the maximum value from a list of <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <ipv6 address> | Plain | <ipv6 address> | Returns the minimum value from a list of <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <ipv6 address> | Plain | <ipv6 address with multiplicity> | Returns the unique values of a given list of <ipv6 address> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<ipv6 address> {cmp} <ipv6 address> | <boolean> | Where {cmp} is one of: <, <=, =. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Ipv6 Address with Multiplicity

These Inspectors deal with ipv6 address arrays, allowing you to pluck out unique ipv6 addresses and count them. These objects are derived from ordinary ipv6 address types.

Creation Methods

Key Phrase | Form | Description
unique value of <ipv6 address> | Plain | Returns the unique values of a given list of <ipv6 address> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <ipv6 address with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <ipv6 address> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Language

A language is composed of a primary language (for example, Swiss) and a sub-language (for example, Swiss German).

Creation Methods

Key Phrase | Form | Description
system locale | PlainGlobal | Determines which bitmap fonts, and OEM, ANSI, and MAC code pages are defaults for the system. This only affects applications that are not fully Unicode. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
system ui language | PlainGlobal | Determines the default language of menus and dialogs, messages, INF files, and help files. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
user locale | PlainGlobal | Determines which settings are used for formatting dates, times, currency, and numbers as a default for each user. Also determines the sort order for sorting text. Win:4.1
user ui language | PlainGlobal | Non-MUI: Same as system UI Language. • MUI: Determines the language of menus and dialogs, messages, and help files. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<language> as string | Cast | <string> | Returns the language of the system locale. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
platform id of <language> | Plain | <string> | Returns the string resulting from a call to setlocale(LC_TYPE, ""). This call examines the system environment and returns a string representing the language and character set for any text-related system function. The string is of the form "en_US.UTF-8". Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1
primary language of <language> | Plain | <primary language> | Extracts the primary language identifier from a language. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1

Examples

system locale as string
Returns English (United States) if the system locale is US English.


License

These Inspectors are available only through the BigFix Enterprise System. They inspect the properties of the client's BigFix license.

Creation Methods

Key Phrase | Form | Description
bes license | PlainGlobal | Synonym for 'client license'. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
client license | PlainGlobal | Creates the global object containing client licensing information. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
common name of <license> | Plain | <string> | Returns the name of the person (such as John Smith) who requested the action site license. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1
email address of <license> | Plain | <string> | Returns the email address of the person (such as John_Smith@bigcorp.com) who requested the action site license. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1
encryption certificate of <license> | Plain | <x509 certificate> | Provides the encryption certificate that is currently active and which will be used by clients to encrypt reports. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
evaluation of <license> | Plain | <boolean> | Returns TRUE if client is running an evaluation license. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
expiration date of <license> | Plain | <time> | Returns date when license will expire. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
expiration state of <license> | Plain | <string> | Returns a string, one of "Unrestricted", "Grace" or "Restricted". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
fips mode of <license> | Plain | <boolean> | Returns TRUE if the BES action masthead specifies that applications (the client, console, or web reports, depending on the context) in the deployment should operate in FIPS 140-2 compliant mode. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
gather url of <license> | Plain | <string> | Returns the gather URL for the deployment's main Action site as specified in the deployment masthead. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
maximum seat count of <license> | Plain | <integer> | Returns maximum seat count allowed by the license. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
organization of <license> | Plain | <string> | Returns the organization of the person (such as Bigcorp, Inc.) who requested the action site license. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1
registrar number of <license> | Plain | <integer> | A unique number assigned to the issuer of the Action Site certificate. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1
seat count state of <license> | Plain | <string> | Returns one of "Unrestricted", "Grace" or "Restricted". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
seat of <license> | Plain | <integer> | The license number assigned to the client. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site number of <license> | Plain | <integer> | A unique number assigned to the Action Site certificate. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1
start date of <license> | Plain | <time> | The starting date specified for the BigFix license. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:7.1


Local Group

These Inspectors return information on local groups as defined on the local BES Client computer using the windows NetLocalGroupEnum API, one of Windows Network Management Functions. Local groups have names, comments, members and security IDs.

Creation Methods

Key Phrase | Form | Description
local group | PlainGlobal | Returns local groups defined on the local computer using the windows NetLocalGroupEnum API. Several local groups are defined simply by a default operating system install, and have names such as Administrators, Backup Operators, Guests, Network Configuration Operators, Power users, Users, etc. Some software applications also define local groups in order to help manage protections. Win:6.0
local group <string> | NamedGlobal | Returns a local group corresponding to the given name, such as Adminstrator, Guests, etc. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
comment of <local group> | Plain | <string> | Returns a string containing a comment associated with the specfied local group (Administrator, Guest, Users). Win:6.0
member of <local group> | Plain | <local group member> | Returns a list of the members of the specified local group. Win:6.0
name of <local group> | Plain | <string> | Returns the name of the local group. Win:6.0


Local Group Member

These Inspectors return information (such as security IDs) on members of local groups as defined on the local BES Client computer using the windows NetLocalGroupEnum API, one of Windows Network Management Functions.

Creation Methods

Key Phrase | Form | Description
member of <local group> | Plain | Returns an object corresponding to a member of the specified local group. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<local group member> as string | Cast | <string> | Casts a local group member as a string. Win:6.0


Local Mssql Database

These Inspectors retrieve the properties of the MS SQL databases on the local machine.

Creation Methods

Key Phrase | Form | Description
local mssql database | PlainGlobal | Creates the local MSSQL database objects. Win:1.2
local mssql database <string> | NamedGlobal | Creates the local Microsoft SQL (MSSQL) database object identified by the name provided. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
audit level of <local mssql database> | Plain | <integer> | Returns the integer audit level of the MSSQL database. Win:1.2
has blank sa password of <local mssql database> | Plain | <boolean> | Returns TRUE if the MSSQL database sa account has a blank password. Win:1.2
instance name of <local mssql database> | Plain | <string> | Returns the name of the MSSQL database. Win:1.2
login mode of <local mssql database> | Plain | <integer> | Returns the login mode of the MSSQL database. Win:1.2
running of <local mssql database> | Plain | <boolean> | Returns a boolean indicating if the MSSQL database is running. Win:1.2


Local User

A Local User object is provided to access the user data of the local machine. Note that domain users are not available through this Inspector.

Creation Methods

Key Phrase | Form | Description
domain user | PlainGlobal | Returns all of the users that are members of the domain for which the machine is a user. Win:4.1
domain user <string> | NamedGlobal | Returns the local user object corresponding to the specified name. Win:4.1
local user | PlainGlobal | Creates an object with all the local user accounts. Win:1.2
local user <string> | NamedGlobal | Creates an object with a named user account. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
account disabled flag of <local user> | Plain | <boolean> | Indicates that this account is disabled. Win:1.2
account expiration of <local user> | Plain | <time> | Returns the time when this account is set to expire. Win:1.2
accounts operator flag of <local user> | Plain | <boolean> | This user has the accounts operator privilege. Win:1.2
admin privilege of <local user> | Plain | <boolean> | Indicates that the user has a privilege level of 'admin'. Win:1.2
allowed workstations string of <local user> | Plain | <string> | Returns a list of workstations this user is allowed to login to. If this string is empty, no restrictions apply. Win:1.2
application parameter string of <local user> | Plain | <string> | Returns a string used by Microsoft products to store user configuration information. Win:1.2
bad password count of <local user> | Plain | <integer> | Returns the number of attempts to logon to this account with a bad password. Win:1.2
code page of <local user> | Plain | <integer> | Returns the code page for the user's preferred language. Win:1.2
comment of <local user> | Plain | <string> | Returns the comment associated with this user's account. Win:1.2
communications operator flag of <local user> | Plain | <boolean> | This user has the communications operator privilege. Win:1.2
country code of <local user> | Plain | <integer> | Returns the country code of the user's preferred language. Win:1.2
full name of <local user> | Plain | <string> | Returns the full name of the user. Win:1.2
guest privilege of <local user> | Plain | <boolean> | Indicates that the user has a privilege level of 'guest'. Win:1.2
home directory drive of <local user> | Plain | <string> | Returns the name of the drive assigned to the user's home directory. Win:1.2
home directory of <local user> | Plain | <string> | Returns the directory where the user files are stored for the particular user. Win:1.2
home directory required flag of <local user> | Plain | <boolean> | Indicates that a home directory is required for the user. Win:1.2
interdomain trust account flag of <local user> | Plain | <boolean> | This is an account which specifies that a domain should trust other domains. Win:1.2
last logoff of <local user> | Plain | <time> | Returns the time when the user last logged off. Win:1.2
last logon of <local user> | Plain | <time> | Returns the time when the user last logged on. Win:1.2
locked out flag of <local user> | Plain | <boolean> | Indicates that this user is currently locked out. Win:1.2
logon count of <local user> | Plain | <integer> | Returns the number of times which this account has successfully logged on to the local machine. Win:1.2
logon script of <local user> | Plain | <string> | Returns the pathname of this user's logon script. Win:1.2
logon server of <local user> | Plain | <string> | Returns the name of the server to which logon requests are sent for this account. Win:1.2
maximum storage of <local user> | Plain | <integer> | Returns the user's disk quota. Will return FALSE if the user has no disk quota. Win:1.2
name of <local user> | Plain | <string> | Returns the name of the user. Win:1.2
no password required flag of <local user> | Plain | <boolean> | Indicates that no password is required for this user. Win:1.2
normal account flag of <local user> | Plain | <boolean> | Indicates that this account has a default account type that represents a typical user. Win:1.2
password age of <local user> | Plain | <time interval> | Gives the time since the user's password was last changes. Win:1.2
password change disabled flag of <local user> | Plain | <boolean> | Indicates that this user is not allowed to change his password. Win:1.2
password expiration disabled flag of <local user> | Plain | <boolean> | Indicates that the password on this account will never expire. Win:1.2
password expired of <local user> | Plain | <boolean> | Indicates that the user's password has expired. Win:1.2
primary group id of <local user> | Plain | <integer> | Returns the RID of the user's primary group. Win:1.2
print operator flag of <local user> | Plain | <boolean> | This user has the print operator privilege. Win:1.2
profile folder of <local user> | Plain | <string> | Returns the pathname of the folder which contains the user's profile. Win:1.2
script flag of <local user> | Plain | <boolean> | Indicates that the logon script executed. Win:1.2
server operator flag of <local user> | Plain | <boolean> | This user has the server operator privilege. Win:1.2
server trust account flag of <local user> | Plain | <boolean> | This is an account for a backup domain controller. Win:1.2
temporary duplicate account flag of <local user> | Plain | <boolean> | Indicates that this is a temporary duplicate account. Win:1.2
user comment of <local user> | Plain | <string> | Returns the user comment of this user. Win:1.2
user id of <local user> | Plain | <integer> | Returns the user's RID number. Win:1.2
user privilege of <local user> | Plain | <boolean> | Indicates that the user has a privilege level of 'user'. Win:1.2
workstation trust account flag of <local user> | Plain | <boolean> | This account is for a workstation or server. Win:1.2

Examples

exists local user "Administrator"
TRUE if there exists a local user named Administrator.

exists local user whose (bad password count of it > 5)
TRUE if there have been more than 5 bad password attempts on this account.

password age of local user "Administrator" > 30 * day
TRUE if the Administrator's password is older than 30 days.


Logged On User

These Windows and Macintosh Inspectors return information about the currently logged-on user. With the advent of Terminal Services and Fast User Switching, these Inspectors are designed to iterate over all logged on users.
• Windows Note: If Terminal Services are available (NT/2000/2003/XP/Vista) and enabled, these Inspectors iterate over the active and disconnected sessions as returned by WTSEnumerateSessions. Disconnected sessions are those where a user logs on, but is currently inactive. On Vista, the non-interactive session 0 (used for services isolation) is not included. If Terminal Services aren't available, the ACLs on the security descriptor of the "winsta0" window station are examined for user logons. On Windows 9x systems, these Inspectors return the user session associated with the registry value "Current User" of "SYSTEM\CurrentControlSet\Control" if it exists. Otherwise, if a shell process process such as Explorer.exe is running, they return a single session associated with an unnamed user (which occurs when the user cancels the 9x login dialog).

Creation Methods

Key Phrase | Form | Description
current user | PlainGlobal | Returns the active, console (local) user, if logged on. Otherwise does not exist. Win:7.0, Mac:7.1
logged on user | PlainGlobal | Returns the user logged on to this BES Client. This Inspector iterates through all logged-on users, using Fast User Switching, Terminal Services, ACLs, and on Win 9x, the registry. Win:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
active of <logged on user> | Plain | <boolean> | Returns TRUE if the specified user session is active (either as a current Fast User or an active terminal services connection). Win:7.0, Mac:7.1
name of <logged on user> | Plain | <string> | If Terminal Services is available and enabled under NT4/2000/2003/XP/Vista, this Inspector returns the result of WTSQuerySessionInformation with WTSUserName. With Terminal Services disabled, it examines the ACLs on the security descriptor of the "winsta0" window station. Under Windows 9x, returns the "Current User" of "SYSTEM\CurrentControlSet\Control" if it exists. Otherwise returns No Such Object. Win:7.0
remote of <logged on user> | Plain | <boolean> | Returns TRUE if the user session is a remote terminal services connection. Win:7.0, Mac:7.1
session id of <logged on user> | Plain | <string> | Returns the session id, which uniquely identifies a logged on user session. A logged-on user is a subclass of a user, and adding the session id uniquely identifies the session. Mac:7.1
sid of <logged on user> | Plain | <security identifier> | Returns the Security ID (SID) of the user associated with the session's primary access token. With Windows 2003/XP/Vista, this is determined by WTSQueryUserToken. With NT4/2000 it is determined by the apparent shell process running in the given session. This Inspector may fail if run in a non-privileged context. The SID does not exist under Windows 9x. Win:7.0


Logical Volume

A logical volume consists of an array of identically sized logical partitions. The partition size of a logical volume is determined by the volume group that contains it, and is the same as the volume group's physical partition size. Contiguous logical partitions within a logical volume may map to discontiguous physical partitions, possibly distributed across multiple physical volumes. A logical volume may be configured so that its logical partitions are mirrored to protect data from hardware failures. Mirroring may be configured so that each logical partition maps to either 2 or 3 physical partition mirrors.

Creation Methods

Key Phrase | Form | Description
logical volume <string> of <volume group> | Named | Returns a logical volume within the specified volume group whose "name" property matches the given string. AIX:7.0
logical volume of <filesystem> | Plain | On an AIX system, returns the logical volume corresponding to the given filesystem. AIX:7.0
logical volume of <volume group> | Plain | On an AIX system, returns the logical volume corresponding to the specified volume group. AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
<logical volume> as string | Cast | <string> | Casts an AIX logical volume as a string type. AIX:7.0
label of <logical volume> | Plain | <string> | Returns the label of the specified logical volume. If the logical volume contains a filesystem, then then this will be the full pathname of the mount point of the file system, eg. "/home". AIX:7.0
maximum partition count of <logical volume> | Plain | <integer> | Returns the maximum number of logical partitions that the specified logical volume contains. A system administrator may set this value to prevent a logical volume from growing beyond a given size. AIX:7.0
minor number of <logical volume> | Plain | <integer> | Returns the minor number of the specified volume group. Each logical volume is represented by a device special file (located in directory /etc). The major number of the device special file is associated with the volume group containing the logical volume, and the minor number of the device special file is associated with the logical volume. AIX:7.0
mirror count of <logical volume> | Plain | <integer> | Returns the number of mirrors that the logical volume has (a value between 1 and 3). AIX:7.0
name of <logical volume> | Plain | <string> | On an AIX system, returns the name of the logical volume, eg. "hd1". AIX:7.0
partition count of <logical volume> | Plain | <integer> | Returns the number of partitions in the specified logical volume. If mirroring is not enabled for the logical volume, then each logical partition maps to a physical partition within the logical volume's volume group. If the logical volume is mirrored, then each logical partition maps to multiple physical partitions within the logical volume group. In this case, the total number of physical partitions occupied by the logical volume will be the product of the partition count and the mirror count. AIX:7.0
volume group of <logical volume> | Plain | <volume group> | Returns the volume group that contains the given logical volume. AIX:7.0

Examples

logical volumes of volume group "joe" of logical volume manager
Returns a list of the logical volumes in the specified volume group.

number of logical volumes of volume group "dave" of logical volume manager
Returns the number of logical volumes in the specified volume group.

logical volumes of volume groups of logical volume manager
Returns the list of all the logical volumes in the logical volume manager.

label of logical volume "splat" of volume group "dave" of logical volume manager
Returns the label associated with the specified logical volume, such as "/splat_mount_point".

maximum partition count of logical volume "splat" of volume group "dave" of logical volume manager
Returns the maximum partition count that has been set for the specified volume.

mirror count of logical volume "splat" of volume group "dave" of logical volume manager
Returns the number of mirrors set up for the specified volume.

partition count of logical volume "splat" of volume group "dave" of logical volume manager
Returns the number of partitions existing on the specified logical volume.


Logical Volume Manager

On AIX, the logical volume manager provides a flexible means of allocating disk space using volume groups, logical volumes, and physical volumes. A volume group is a collection of one or more physical volumes and a logical volume is an abstraction representing a pool of disk space. The disk space assigned to a logical volume appears contiguous to the user, but it may actually be distributed across one or more physical volumes within a single volume group.

Creation Methods

Key Phrase | Form | Description
logical volume manager | PlainGlobal | Returns the global logical volume manager on AIX systems. AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
volume group <string> of <logical volume manager> | Named | <volume group> | On an AIX system, returns a volume group from the logical group whose name property matches the given string. AIX:7.0
volume group of <logical volume manager> | Plain | <volume group> | Returns the volume group corresponding to the given logical volume manager. AIX:7.0

Examples

number of volume groups of logical volume manager
Returns the number of volume groups in the global logical volume manager.


Media Type

This object allows you to inspect the media type of your Internet Connection Firewall type connection, as returned in the NETCON_PROPERTIES structure.

Creation Methods

Key Phrase | Form | Description
media type <integer> | NumberedGlobal | Returns the media type based on its integer value. This Inspector is included to take advantage of new (or undocumented) additions to the media types. Win:5.0
media type bridge | PlainGlobal | Returns the value NCM_BRIDGE: Bridged connection. Win:5.0
media type direct | PlainGlobal | Returns the value NCM_DIRECT: Direct serial connection through a serial port. Win:5.0
media type isdn | PlainGlobal | Returns the value NCM_ISDN: Connection is through an integrated services digital network (ISDN) line. Win:5.0
media type lan | PlainGlobal | Returns the value NCM_LAN: Connection is to a local area network (LAN). Win:5.0
media type of <connection> | Plain | Returns the media type of the specified connection: • NCM_NONE: No media is present. • NCM_DIRECT: Direct serial connection through a serial port. • NCM_ISDN: Connection is through an integrated services digital network (ISDN) line. • NCM_LAN: Connection is to a local area network (LAN). • NCM_PHONE: Dial-up connection over a conventional phone line. • NCM_TUNNEL: Virtual private network (VPN) connection. • NCM_PPPOE: Point-to-Point protocol (PPP) over Ethernet. • NCM_BRIDGE: Bridged connection. • NCM_SHAREDACCESSHOST_LAN: Shared connection to a LAN. • NCM_SHAREDACCESSHOST_RAS: Shared connection to a remote or wide area network (WAN). Win:5.0
media type phone | PlainGlobal | Returns the value NCM_PHONE: Dial-up connection over a conventional phone line. Win:5.0
media type pppoe | PlainGlobal | Returns the value NCM_PPPOE: Point-to-Point protocol (PPP) over Ethernet. Win:5.0
media type shared access host lan | PlainGlobal | Returns the value NCM_SHAREDACCESSHOST_LAN: Shared connection to a LAN. Win:5.0
media type shared access host ras | PlainGlobal | Returns the value NCM_SHAREDACCESSHOST_RAS: Shared connection to a remote or wide area network (WAN). Win:5.0
media type tunnel | PlainGlobal | Returns the value NCM_TUNNEL: Virtual private network (VPN) connection. Win:5.0

Operators

Key phrase | Return Type | Description
<media type> = <media type> | <boolean> | Compares two media types. Win:5.0


Metabase

The IIS metabase is similar in structure to the Windows Registry, providing hierarchal storage of IIS configuration properties for Web sites, virtual directories, FTP, etc.

Creation Methods

Key Phrase | Form | Description
metabase | PlainGlobal | Returns the IIS metabase object. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
key <string> of <metabase> | Named | <metabase key> | Returns the named key of the metabase. Win:4.1
key of <metabase> | Plain | <metabase key> | Returns the root key of the IIS metabase. Win:4.1


Metabase Identifier

A metabase identifier is a unique numerical identifier which IIS recognizes internally.

Creation Methods

Key Phrase | Form | Description
identifier of <metabase value> | Plain | Returns the metabase identifier of the specified value. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<metabase identifier> as integer | Cast | <integer> | The integer value of the specified identifier. Use the Microsoft MetaEdit utility to find the integer value of an identifier. Win:4.1

Operators

Key phrase | Return Type | Description
<metabase identifier> = <metabase identifier> | <boolean> | Compares two metabase identifiers for equality. Win:4.1


Metabase Key

Like a registry key, a metabase key contains named properties about the IIS metabase.

Creation Methods

Key Phrase | Form | Description
key <string> of <metabase key> | Named | Returns the named subkey of the specified metabase key. Win:4.1
key <string> of <metabase> | Named | Returns the named key of the metabase. Win:4.1
key of <metabase key> | Plain | Iterates the subkeys of the specified metabase key. Win:4.1
key of <metabase> | Plain | Returns the root key of the IIS metabase. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
key <string> of <metabase key> | Named | <metabase key> | Returns the named subkey of the specified metabase key. Win:4.1
key of <metabase key> | Plain | <metabase key> | Iterates the subkeys of the specified metabase key. Win:4.1
name of <metabase key> | Plain | <string> | Returns the name of the specified metabase key. Win:4.1
value of <metabase key> | Plain | <metabase value> | Returns the value of the specified metabase key. Win:4.1


Metabase Type

The type identifier of the data associated with a metabase key value.

Creation Methods

Key Phrase | Form | Description
type of <metabase value> | Plain | Returns the type of the specified metabase value. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<metabase type> as integer | Cast | <integer> | Meanings same as registry types: • 1 = DWORD • 2 = STRING • 3 = BINARY • 4 = EXPANDSZ • 5 = MULTISZ. Win:4.1
<metabase type> as string | Cast | <string> | Returns metabase types as strings: • "DWord" • "String" • "Binary" • "ExpandSz" • "MultiSz". Win:4.1

Operators

Key phrase | Return Type | Description
<metabase type> = <metabase type> | <boolean> | Compares two metabase types for equality. Win:4.1


Metabase User Type

The user type is a DWORD that specifies how the property value is used. User types enable IIS to classify properties by application.

Creation Methods

Key Phrase | Form | Description
user type of <metabase value> | Plain | Returns the user type of the specified metabase value. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<metabase user type> as integer | Cast | <integer> | Returns the metabase user type as an integer: • 2 = Server • 2 = File • 100 = WAM • 200 = ASP App. Win:4.1
<metabase user type> as string | Cast | <string> | Returns the metabase user type as a string: • "Server" • "File" • "WAM" • "ASP App" • "(Other)". Win:4.1

Operators

Key phrase | Return Type | Description
<metabase user type> = <metabase user type> | <boolean> | Compares two metabase user types for equality. Win:4.1


Metabase Value

This Inspector is used to access values stored in an IIS metabase key. The type of the data stored in the value determines what casting operations are allowed. There are several casting Inspectors that you can use to extract values from the registry.

Creation Methods

Key Phrase | Form | Description
value of <metabase key> | Plain | Returns the value of the specified metabase key. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
<metabase value> as integer | Cast | <integer> | Returns the integer value of the metabase value. Win:4.1
<metabase value> as string | Cast | <string> | Returns the string value of the metabase value. Win:4.1
identifier of <metabase value> | Plain | <metabase identifier> | Returns the metabase identifier of the specified value. Win:4.1
inherit attribute of <metabase value> | Plain | <boolean> | Returns TRUE if the specified metabase value has the inherit attribute set. Win:4.1
insert path attribute of <metabase value> | Plain | <boolean> | Returns TRUE if the specified metabase value has the insert path attribute set. Win:4.1
reference attribute of <metabase value> | Plain | <boolean> | Returns TRUE if the specified metabase value has the reference attribute set. Win:4.1
secure attribute of <metabase value> | Plain | <boolean> | Returns TRUE if the specified metabase value has the secure attribute set. Win:4.1
type of <metabase value> | Plain | <metabase type> | Returns the type of the specified metabase value. Win:4.1
user type of <metabase value> | Plain | <metabase user type> | Returns the user type of the specified metabase value. Win:4.1
volatile attribute of <metabase value> | Plain | <boolean> | Returns TRUE if the specified metabase value has the volatile attribute set. Win:4.1


Mode

The mode inpector returns file type information and permissions. These are the possible values of mode:
• S_IFMT 170000 bitmask for the file type bitfields
• S_IFSOCK 140000 socket
• S_IFLNK 120000 symbolic link
• S_IFREG 100000 regular file
• S_IFBLK 060000 block device
• S_IFDIR 040000 directory
• S_IFCHR 020000 character device
• S_IFIFO 010000 fifo
• S_ISUID 004000 set UID bit
• S_ISGID 002000 set GID bit
• S_ISVTX 001000 sticky bit
• S_IRWXU 000700 mask for file owner permissions
• S_IRUSR 000400 owner has read permission
• S_IWUSR 000200 owner has write permission
• S_IXUSR 000100 owner has execute permission
• S_IRWXG 000070 mask for group permissions
• S_IRGRP 000040 group has read permission
• S_IWGRP 000020 group has write permission
• S_IXGRP 000010 group has execute permission
• S_IRWXO 000007 mask for permissions for others (not in group)
• S_IROTH 000004 others have read permission
• S_IWOTH 000002 others have write permission
• S_IXOTH 000001 others have execute permission

Creation Methods

Key Phrase | Form | Description
mode of <filesystem object> | Plain | Returns the permissions mode for the given filesystem object. Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0

Properties

Key Phrase | Form | Return Type | Description
<mode> as octal string | Cast | <string> | Converts the mode to a string of octal numbers. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
<mode> as string | Cast | <string> | Converts the mode to a string. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
group mask of <mode> | Plain | <mode_mask> | Returns the mask for group permissions for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
other mask of <mode> | Plain | <mode_mask> | Returns the mask for permissions for others (those not in the group) for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
setgid of <mode> | Plain | <boolean> | Returns TRUE if setgid (the group ID flag) is set. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
setuid of <mode> | Plain | <boolean> | Returns TRUE if setuid (the user ID flag) is set. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
sticky of <mode> | Plain | <boolean> | The `sticky' bit (S_ISVTX) on a directory means that a file in that directory can be renamed or deleted only by the owner of the file, by the owner of the directory, and by root. This inspector returns TRUE if the sticky bit of the given mode is on. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
user mask of <mode> | Plain | <mode_mask> | Returns the mask for the user (file owner) permissions for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1


Mode_mask

The mode_mask Inspector is a differently formatted version of the mode, created by shifting the key information down to the low three bits.

Creation Methods

Key Phrase | Form | Description
group mask of <mode> | Plain | The rwx mask (shifted to the lower 3 bits) for group permissions for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
other mask of <mode> | Plain | The rwx mask (shifted to the lower 3 bits) for permissions for others (those not in the group) for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
user mask of <mode> | Plain | The rwx mask (shifted to the lower 3 bits) for permissions for the user (the file owner) for the given mode. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
<mode_mask> as integer | Cast | <integer> | Converts the mode mask to an integer, 1-4. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
<mode_mask> as string | Cast | <string> | Converts the mode mask to a string, e.g. "rwx". Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
execute of <mode_mask> | Plain | <boolean> | Returns TRUE if the execute flag (x) of the rwx mode mask is on. (binary 001 = 1). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
read of <mode_mask> | Plain | <boolean> | Returns TRUE if the read flag of the rwx mode mask is on. (binary 100 = 4). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
write of <mode_mask> | Plain | <boolean> | Returns TRUE if the write flag (w) of the rwx mode mask is on. (binary 010 = 2). Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1


Module

Properties

Key Phrase | Form | Return Type | Description
version string <string> of <module> | Named | <string> | For BigFix internal use only. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1


Month

These Inspectors provide tools for dealing and calculating with month types, which are of the form January, February, etc. This set of Inspectors includes each month as a self-named object.

Creation Methods

Key Phrase | Form | Description
<integer> as month | Cast | Returns the name of the nth month of the year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as month | Cast | Converts a string into a month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
april | PlainGlobal | Returns april as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
august | PlainGlobal | Returns August as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current month | PlainGlobal | Returns the current month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december | PlainGlobal | Returns December as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
february | PlainGlobal | Returns February as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
january | PlainGlobal | Returns January as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july | PlainGlobal | Returns July as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june | PlainGlobal | Returns June as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
march | PlainGlobal | Returns March as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <month> | Plain | Returns the maximum value from a list of <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
may | PlainGlobal | Returns May as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minimum of <month> | Plain | Returns the minimum value from a list of <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month <integer> | NumberedGlobal | Returns the month type corresponding to the given <integer>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month <string> | NamedGlobal | Returns a month type corresponding to the given <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month of <date> | Plain | Returns the month of the given date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month of <day of year> | Plain | Returns the month portion of the given date (in month day format). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
month of <month and year> | Plain | Returns the month portion of the given date (in month year format). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
november | PlainGlobal | Returns November as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
october | PlainGlobal | Returns October as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
september | PlainGlobal | Returns September as an object of type month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<month> as integer | Cast | <integer> | Converts the given month into an integer (1-12). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> as string | Cast | <string> | Converts the given month into a string value. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> as three letters | Cast | <string> | Converts the given month into a 3-letter string (Jan, Feb, etc.). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> as two digits | Cast | <string> | Converts the month into a two digit number (01 - 12). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <month> | Plain | <( month, month )> | Returns the minimum and maximum extreme values of the given list of <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <month> | Plain | <month> | Returns the maximum value from a list of <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <month> | Plain | <month> | Returns the minimum value from a list of <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <month> | Plain | <month with multiplicity> | Returns the unique values of a given list of <month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of month> & <month> | <day of year> | Concatenate a day of month with a month type to produce a day of year (eg. April 20). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> - <month> | <number of months> | Subtracts two months, returning a positive number of months. If the first month is earlier than the second, it assumes the year has rolled over. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> & <day of month> | <day of year> | Concatenates a month and a day of the month to produce a day of year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> & <year> | <month and year> | Returns a date (in month year format) from the concatenation of a month and a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> {cmp} <month> | <boolean> | Compares the values of two months, where {cmp} is one of: <, <=, =. Win:6.0
<month> {op} <number of months> | <month> | Adds or subtracts a number of months from the given month. Here {op} is one of: -, +. Win:6.0
<number of months> + <month> | <month> | Adds a number of months to the given month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> & <month> | <month and year> | Returns a date (in month year format) from the concatenation of a month and a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Month and Year

These Inspectors provide tools for dealing and calculating with month-and-year types, which are of the form month of year, eg., January of 2007.

Creation Methods

Key Phrase | Form | Description
april of <integer> | Plain | Creates a date (in month year format) corresponding to april of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
august of <integer> | Plain | Creates a date (in month year format) corresponding to August of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current month_and_year | PlainGlobal | Returns the current date in month year format, eg. January 2012. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
december of <integer> | Plain | Creates a date (in month year format) corresponding to December of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
february of <integer> | Plain | Creates a date (in month year format) corresponding to February of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
january of <integer> | Plain | Creates a date (in month year format) corresponding to January of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
july of <integer> | Plain | Creates a date (in month year format) corresponding to July of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
june of <integer> | Plain | Creates a date (in month year format) corresponding to June of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
march of <integer> | Plain | Creates a date (in month year format) corresponding to March of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <month and year> | Plain | Returns the maximum value from a list of <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
may of <integer> | Plain | Creates a date (in month year format) corresponding to May of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minimum of <month and year> | Plain | Returns the minimum value from a list of <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month_and_year of <date> | Plain | Formats the specified date in month year format, eg. March 2012. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
november of <integer> | Plain | Creates a date (in month year format) corresponding to November of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
october of <integer> | Plain | Creates a date (in month year format) corresponding to October of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
september of <integer> | Plain | Creates a date (in month year format) corresponding to September of the specified year (as an <integer>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<month and year> as string | Cast | <string> | Casts a date (in month year format) as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <month and year> | Plain | <( month and year, month and year )> | Returns the minimum and maximum extreme values of the given list of <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
first <day of week> of <month and year> | Index<day of week> | <date> | Finds the specific date corresponding to the first day of the week (eg. Friday) for a given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first friday of <month and year> | Plain | <date> | Finds the date corresponding to the first Friday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first monday of <month and year> | Plain | <date> | Finds the date corresponding to the first Monday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first saturday of <month and year> | Plain | <date> | Finds the date corresponding to the first Saturday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first sunday of <month and year> | Plain | <date> | Finds the date corresponding to the first Sunday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first thursday of <month and year> | Plain | <date> | Finds the date corresponding to the first Thursday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first tuesday of <month and year> | Plain | <date> | Finds the date corresponding to the first Tuesday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
first wednesday of <month and year> | Plain | <date> | Finds the date corresponding to the first Wednesday of any given month and year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
length of <month and year> | Plain | <time interval> | Returns the number of days in the specified month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <month and year> | Plain | <month and year> | Returns the maximum value from a list of <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <month and year> | Plain | <month and year> | Returns the minimum value from a list of <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month of <month and year> | Plain | <month> | Returns the name of the month corresponding to the given date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <month and year> | Plain | <month and year with multiplicity> | Returns the unique values of a given list of <month and year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
year of <month and year> | Plain | <year> | Returns the year portion of the specified date (in month year format). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of month> & <month and year> | <date> | Concatenate a day of month with a month and year type to produce a complete date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<day of year> & <month and year> | <date> | Concatenates a day of the year with a month and year to create a complete date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month and year> - <month and year> | <number of months> | Subtracts two dates (in month year format), returning a number of months. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month and year> {cmp} <month and year> | <boolean> | Compares two dates (in month year format), where {cmp} is one of: <, <=, =. Win:6.0
<month and year> {op} <number of months> | <month and year> | Adds or subtracts a number of months from a given date (in month year format), where {op} is one of: -, +. Win:6.0
<number of months> + <month and year> | <month and year> | Adds a number of months to a given date (in month year format) producing a new date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Month and Year with Multiplicity

These Inspectors deal with month-and-year arrays, allowing you to pluck out unique month-and-year values and count them. These objects are derived from ordinary month-and-year types.

Creation Methods

Key Phrase | Form | Description
unique value of <month and year> | Plain | Returns the unique values of a given list of <month and year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <month and year with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <month and year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Month with Multiplicity

These Inspectors deal with month arrays, allowing you to pluck out unique month values and count them. These objects are derived from ordinary month types.

Creation Methods

Key Phrase | Form | Description
unique value of <month> | Plain | Returns the unique values of a given list of <month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <month with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Network

These are the keywords used to query the local network configuration.

Creation Methods

Key Phrase | Form | Description
network | PlainGlobal | Creates an object containing properties of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
adapter <integer> of <network> | Numbered | <network adapter> | Returns the nth adapter of the specified network. Mac:7.1
adapter <string> of <network> | Named | <network adapter> | Returns the named adapter of the specified network. Mac:7.1
adapter of <network> | Plain | <network adapter> | Returns the one or more network adapter objects of the network. Win:2.0, Mac:7.1
connection of <network> | Plain | <connection> | Returns a connection to the specified network. This Inspector requires Windows XP or better. Win:5.0
dns server of <network> | Plain | <network address list> | Returns a list of DNS servers used by the local computer. Win:4.1
interface <integer> of <network> | Numbered | <network interface> | Returns the particular interface of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
interface of <network> | Plain | <network interface> | Returns all the interfaces of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ip interface <integer> of <network> | Numbered | <network ip interface> | Returns the particular ip interface of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ip interface of <network> | Plain | <network ip interface> | Returns all the ip interfaces of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
link interface <integer> of <network> | Numbered | <network link interface> | Returns the specified network link interface of the given network. Mac:5.1
link interface of <network> | Plain | <network link interface> | Returns the network link interface of the specified network. Mac:5.1
winsock2 supported of <network> | Plain | <boolean> | Indicates that winsock2 is supported by the network. If this returns FALSE, many of the other properties of the interface are not available for inspection. Win:1.2


Network Adapter

One or more network adapters may be inspected using this property of the network object. Each network adapter has a number of interesting properties such as the MAC address.

Creation Methods

Key Phrase | Form | Description
adapter <integer> of <network> | Numbered | Returns the nth adapter of the specified network. Mac:7.1
adapter <string> of <network> | Named | Returns the named adapter of the specified network. Mac:7.1
adapter of <network> | Plain | Returns one or more adapters of the network. Win:2.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
address list of <network adapter> | Plain | <network address list> | Returns the address list of the network adapter. Win:2.0
address of <network adapter> | Plain | <ipv4 address> | Returns the ip address of the network adapter (returns the first address if it is a list). Win:2.0, Mac:7.1
broadcast address of <network adapter> | Plain | <ipv4 address> | Returns the broadcast address of the specified network adapter as an <ipv4 address>. Mac:7.1
broadcast support of <network adapter> | Plain | <boolean> | Returns TRUE if the specified network adapter supports broadcast. Mac:7.1
cidr string of <network adapter> | Plain | <string> | Returns the Classless Inter-Domain Routing value for the specified network adapter as a string value. Win:7.1, Mac:7.1
description of <network adapter> | Plain | <string> | Returns the description of the network adapter. Win:2.0
dhcp enabled of <network adapter> | Plain | <boolean> | Returns TRUE if dhcp is enabled on the network adapter. Win:2.0
dhcp server of <network adapter> | Plain | <ipv4 address> | Returns the ip address of the dhcp server of the network adapter. Win:2.0
dns server of <network adapter> | Plain | <network address list> | Returns a list of DNS servers used by the specified adapter. Win:4.1
dns suffix of <network adapter> | Plain | <string> | Returns the Domain Name System (DNS) suffix associated with the specified adapter. Win:7.0
friendly name of <network adapter> | Plain | <string> | Returns a user-friendly name for the adapter, for example "Local Area Connection 1". Win:7.0
gateway list of <network adapter> | Plain | <network address list> | Returns the gateway network address list of the network adapter. Win:2.0
gateway of <network adapter> | Plain | <ipv4 address> | Returns the ip address of the gateway of the network adapter. Win:2.0
interface of <network adapter> | Plain | <network interface> | Returns a network interface object from the specified network adapter. Mac:7.1
internet connection firewall of <network adapter> | Plain | <internet connection firewall> | Creates a Windows XP firewall object. Win:4.1
ip interface of <network adapter> | Plain | <network ip interface> | Returns an object or an object list (using the plural keyword) with all the ip interfaces of the specified network adapter. Mac:7.1
ipv6 address of <network adapter> | Plain | <ipv6 address> | Returns the local IPv6 address of the adapter. Only for XP/Server 2003 and later. Win:7.0
ipv6 dns server of <network adapter> | Plain | <ipv6 address> | Returns the DNS server IPv6 address of the adapter. Only for XP/Server 2003 and later. Win:7.0
lease expires of <network adapter> | Plain | <time> | Returns the time that the dhcp lease will expire of the network adapter. Win:2.0
lease obtained of <network adapter> | Plain | <time> | Returns the time that the dhcp lease was obtained of the network adapter. Win:2.0
link interface of <network adapter> | Plain | <network link interface> | Returns the network link interface(s) of the specified network adapter. Mac:7.1
link speed of <network adapter> | Plain | <integer> | This is a property of a network adapter. It returns the maximum speed of the NIC card in bits per second. Win:6.0
loopback of <network adapter> | Plain | <boolean> | Returns TRUE if the specified network adapter is a loopback interface. Mac:7.1
mac address of <network adapter> | Plain | <string> | Returns the mac address of the network adapter. Win:2.0, Mac:7.1
maximum transmission unit of <network adapter> | Plain | <integer> | The maximum transmission unit (MTU) size, in bytes, of the specified adapter. Win:7.0
multicast support of <network adapter> | Plain | <boolean> | Returns TRUE if multicast messages are supported by the specified network adapter. Mac:7.1
name of <network adapter> | Plain | <string> | Returns the name of the network adapter. Win:2.0, Mac:7.1
point to point of <network adapter> | Plain | <boolean> | Returns TRUE if the specified network adapter is a point-to-point interface. Usually TRUE for dialup connections. Mac:7.1
primary wins server of <network adapter> | Plain | <ipv4 address> | Returns the ip address of the primary wins server of the network adapter. Win:2.0
secondary wins server of <network adapter> | Plain | <ipv4 address> | Returns the ip address of the secondary wins server of the network adapter. Win:2.0
status of <network adapter> | Plain | <integer> | The operational status for the interface as defined in RFC 2863. It can be one of the values from the IF_OPER_STATUS enumeration type defined in the Iftypes.h header file. On Windows Vista and later, the header files were reorganized and this enumeration is defined in the Ifdef.h header file. Win:7.0
subnet address of <network adapter> | Plain | <ipv4 address> | Returns the subnet address of the network adapter. Win:2.0, Mac:7.1
subnet mask of <network adapter> | Plain | <ipv4 address> | Returns the subnet mask of the network adapter. Win:2.0, Mac:7.1
type of <network adapter> | Plain | <integer> | Returns the interface type of the specified adapter as defined by the Internet Assigned Names Authority (IANA). Possible values for the interface type are listed in the Ipifcons.h header file. Win:7.0
up of <network adapter> | Plain | <boolean> | Returns TRUE if the specified network adaoter is currently working. Interfaces like wifi may be turned it off to save power, but this Inspector will still tell you if it is active. Mac:7.1
wakeonlan enabled of <network adapter> | Plain | <boolean> | Returns TRUE if the specified network adapter is configured to react to Wake-On-Lan requests. Wake-On-Lan is a mechanism used to trigger a boot of a machine in standby mode by sending a special packet. • Note: Wake-On-Lan is only supported for Windows 2000 and XP machines. Win:5.1
wins enabled of <network adapter> | Plain | <boolean> | Returns TRUE if WINS is enabled on the network adapter. Win:2.0


Network Address List

A network adapter may be configured to respond to a list of network addresses. This object type provides access to such a list.

Creation Methods

Key Phrase | Form | Description
address list of <network adapter> | Plain | Returns the address list of the network adapter. Win:2.0
dns server of <network adapter> | Plain | Returns a list of DNS servers used by the specified adapter. Win:4.1
dns server of <network> | Plain | Returns a list of DNS servers used by the local computer. Win:4.1
gateway list of <network adapter> | Plain | Returns the gateway network address list of the network adapter. Win:2.0

Properties

Key Phrase | Form | Return Type | Description
address of <network address list> | Plain | <ipv4 address> | Returns the address of the address list. Win:2.0
cidr string of <network address list> | Plain | <string> | Returns the Classless Inter-Domain Routing value for the specified network address list as a string value. Win:7.1
subnet address of <network address list> | Plain | <ipv4 address> | Returns the subnet address of the network address list. Win:2.0
subnet mask of <network address list> | Plain | <ipv4 address> | Returns the subnet mask of the network address list. Win:2.0


Network Interface

The network interface object describes a generic network interface, and has information about the name and family of that interface. On the Mac these are commonly of type AF_INET, AF_LINK and AF_INET6.

Creation Methods

Key Phrase | Form | Description
interface <integer> of <network> | Numbered | Creates an object with the specified network interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
interface of <network adapter> | Plain | Creates a network interface object from the specified network adapter. Mac:7.1
interface of <network> | Plain | Creates an object with all the interfaces of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
family name of <network interface> | Plain | <string> | Returns the name of the interface family. There are about 35 of these, but the most common is AF_INET, or normal IP interface. AF_LINK is used for wifi devices and AF_INET6 is for IP v6 addresses. There are specific inspectors for AF_INET (ip interface) and AF_LINK (link interface). The family name of inspector returns this type as a string corresponding to the #define value in the header file. Mac:5.1
family of <network interface> | Plain | <integer> | Returns an family designator of the address family (i.e., 2=AFI_NET). Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
name of <network interface> | Plain | <string> | Returns the name of the network interface object. Mac:5.1
up of <network interface> | Plain | <boolean> | Returns TRUE if the specified network interface is currently working. Interfaces like wifi may be turned it off to save power, but this Inspector will still tell you if it is active. Mac:5.1

Examples

names of interfaces of network
Returns a list of the network interface names, e.g., lo0, gif0, stf0, en0.


Network Ip Interface

In general, the network ip interface object holds locally determined properties of logical network devices configured on the computer. On the Mac, these correspond to interfaces of type AF_INET. The properties that are available depend on the socket support installed on the computer. For Windows computers with winsock 2 support installed, for instance, the information is obtained by an ioctl call and includes Interface address, Interface broadcast address, Interface network mask, Broadcast support flag, Multicast support flag, Loopback interface flag and Point to point interface flag.

Creation Methods

Key Phrase | Form | Description
ip interface <integer> of <network> | Numbered | Creates an object with the specified ip interface of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
ip interface of <network adapter> | Plain | Creates an object or an object list (using the plural keyword) with all the ip interfaces of the specified network adapter. Mac:7.1
ip interface of <network> | Plain | Creates an object or an object list (using the plural keyword) with all the ip interfaces of the network. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
primary internet connection | PlainGlobal | This contains information about the current internet connection. Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
address of <network ip interface> | Plain | <ipv4 address> | Returns the ip address of the ip interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
alias of <network ip interface> | Plain | <boolean> | Returns TRUE if the network ip interface has an alias defined for it (a virtual device, rather than a physical device). Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
broadcast address of <network ip interface> | Plain | <ipv4 address> | Returns the broadcast address of the interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
broadcast support of <network ip interface> | Plain | <boolean> | Indicates that broadcast messages are supported by the ip interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
cidr string of <network ip interface> | Plain | <string> | Returns the Classless Inter-Domain Routing value for the specified network ip interface as a string value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
loopback of <network ip interface> | Plain | <boolean> | Indicates that the particular network ip interface is a loopback interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
mac address of <network ip interface> | Plain | <string> | Returns the mac address (AKA hardware address) of the network ip interface object. The mac address is formatted as a string of lower case hex digits separated by '-'. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
multicast support of <network ip interface> | Plain | <boolean> | Indicates that multicast messages are supported by the ip interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
name of <network ip interface> | Plain | <string> | Returns the name of the network ip interface object. Typical names are lan0, lo0. Virtual interfaces are usually of the form lan0:2. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1
point to point of <network ip interface> | Plain | <boolean> | Indicates that the interface is a point-to-point interface. Usually TRUE for dialup connections. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
subnet address of <network ip interface> | Plain | <ipv4 address> | The subnet to which the interface belongs. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
subnet mask of <network ip interface> | Plain | <ipv4 address> | The subnet mask of the interface. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1

Examples

names of ip interfaces of network
Returns a list of the names of the network IP interfaces, e.g., lo0, en0.

addresses of ip interfaces of network
Returns a list of the IP addresses of the network IP interfaces, e.g., 127.0.0.1, 192.168.1.100, etc.

address of ip interface whose (loopback of it = false) of network = "192.168.127.127"
Returns TRUE if the given IP address doesn’t have loopback.

mac address whose (it = "00-61-b1-d1-7d-29") of ip interfaces of network
Returns the mac address of the specified network ip interface object.


Network Link Interface

The network link interface objects correspond to interfaces of type AF_LINK.

Creation Methods

Key Phrase | Form | Description
link interface <integer> of <network> | Numbered | Returns the specified network link interface of the given network. Mac:5.1
link interface of <network adapter> | Plain | Returns the network link interface(s) of the specified network adapter. Mac:7.1
link interface of <network> | Plain | Returns the network link interface(s) of the specified network. Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
mac address of <network link interface> | Plain | <string> | Returns the MAC address of the specified network link interface. Mac:5.1

Examples

names of link interfaces of network
Returns a list of the names of the network link interfaces, e.g., lo0, gif0, stf0, en0, en1, fw0, etc.

mac addresses of link interfaces of network
Returns a list of the MAC addresses of the network link interfaces, e.g., 00-14-c8-3a-82-11, 00-16-bc-72-2c-57, 00-14-e4-26-fe-4c-14-37, etc.

mac address of link interface (whose name of it is "fw0”) of network
Returns the MAC address of the specified network link interface.


Network Share

The network share Inspector does not work on Windows 95/98/Me. The password and permission properties are relevant only for shares using share-level security. User-level security is given by the security descriptor. The use limit property will throw NoSuchObject if use is unlimited.

Creation Methods

Key Phrase | Form | Description
network share | PlainGlobal | Creates a network shared object. Win:4.1
network share <string> | NamedGlobal | Creates a named network shared object. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
attribute permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to modify the attributes of the shared resource (such as the date and time when a file was last modified). Win:4.1
comment of <network share> | Plain | <string> | Returns a string specifying an optional comment about the shared resource. Win:4.1
create permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to create an instance of a shared resource (such as a file). Win:4.1
delete permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to delete the resource. Win:4.1
execute permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to execute the resource. Win:4.1
name of <network share> | Plain | <string> | Returns a string specifying the name of the specified shared resource. Win:4.1
password of <network share> | Plain | <string> | A string that specifies the share's password (when the server is running with share-level security). Note that the Windows Server 2003 family, Windows XP, Windows 2000, and Windows NT do not support share-level security. Win:4.1
path of <network share> | Plain | <string> | A string containing the local path for the shared resource. Win:4.1
permission permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to modify the permissions (read, write, create, execute, and delete) for the specified network share. Win:4.1
read permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to read data from a resource and, by default, to execute the specified network share. Win:4.1
security descriptor of <network share> | Plain | <security descriptor> | Specifies the security descriptor associated with the specified network share. Win:4.1
type of <network share> | Plain | <integer> | Specifies an integer value that indicates the type of share. (See the Microsoft document on SHARE_INFO_502). Win:4.1
use count of <network share> | Plain | <integer> | Specifies an integer value that indicates the number of current connections to the specified network share. Win:4.1
use limit of <network share> | Plain | <integer> | Specifies an integer value indicating the maximum number of concurrent connections that the shared resource can accommodate. Win:4.1
write permission of <network share> | Plain | <boolean> | Returns TRUE if permission is granted to write data to the specified network share. Win:4.1


Nothing

These Inspectors are place holders for compatability with Windows clients

Creation Methods

Key Phrase | Form | Description
main gather service | PlainGlobal | Returns FALSE. Included for compatability with Windows clients. Mac:4.1
relay service | PlainGlobal | Returns FALSE. Included for compatability with Windows clients. Mac:4.1


Number of Months

These Inspectors provide tools for dealing and calculating with number-of-month types, which are similar to integers, but wih yearly roll-over.

Creation Methods

Key Phrase | Form | Description
maximum of <number of months> | Plain | Returns the maximum value from a list of <number of months> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <number of months> | Plain | Returns the minimum value from a list of <number of months> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
month | PlainGlobal | Returns the specified number of months. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year | PlainGlobal | Returns the specified number of years as a <number of months> type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<number of months> as string | Cast | <string> | Converts a number of months type into a string type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <number of months> | Plain | <( number of months, number of months )> | Returns the minimum and maximum extreme values of the given list of <number of months> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <number of months> | Plain | <number of months> | Returns the maximum value from a list of <number of months> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <number of months> | Plain | <number of months> | Returns the minimum value from a list of <number of months> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <number of months> | Plain | <number of months with multiplicity> | Returns the unique values of a given list of <number of month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
- <number of months> | <number of months> | Creates the negative of the specified number of months. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<number of months> {cmp} <number of months> | <boolean> | Compare two numbers of months, where {cmp} is one of: <, <=, =. Win:6.0
<number of months> {op} <number of months> | <number of months> | Multiplies or divides a number of months by an integer. Here {op} is one of: *, /. Win:6.0
<number of months> + <year> | <year> | Returns the year after adding the specified number of months. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> {op} <number of months> | <year> | Adds or subtracts the specified number of months to derive a new year. Here {op} is one of: -, +. Win:6.0


Number of Months with Multiplicity

These Inspectors deal with number-of-month arrays, allowing you to pluck out unique number-of-month values and count them. These objects are derived from ordinary number-of-month types.

Creation Methods

Key Phrase | Form | Description
unique value of <number of months> | Plain | Returns the unique values of a given list of <number of month> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <number of months with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <number of month> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Object_repository

A database corresponding to installable software products.

Creation Methods

Key Phrase | Form | Description
object repository | PlainGlobal | This is the global inspector object; all installed software inspectors are properties of this. AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
fileset matching <string> of <object_repository> | Named | <fileset> | Returns the fileset(s) matching the specified string from within the object repository. AIX:4.1
product <string> of <object_repository> | Named | <product> | Returns the named product from the object repository. AIX:4.1
product of <object_repository> | Plain | <product> | Returns a list of the products in the object repository. AIX:4.1

Examples

exists object repository
Returns TRUE if the object repository exists.

products whose (name of it contains "bos") of object repository
Returns a list of the software products that have "bos" in their name.


Operating System

The operating system object provides access to several important properties of the system.

Creation Methods

Key Phrase | Form | Description
operating system | PlainGlobal | Creates the global operating system object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<operating system> as string | Cast | <string> | Returns a string containing the name of the operating system concatenated with the release. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
architecture of <operating system> | Plain | <string> | Returns the architecture of the operating system. This is the value of the 'machine' element of the utsname structure obtained by calling uname. Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:6.0
boot time of <operating system> | Plain | <time> | Returns the time of the last restart. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
build number high of <operating system> | Plain | <integer> | Numeric representation of the most significant 16 bits of the build number. Win:1.2
build number low of <operating system> | Plain | <integer> | Numeric representation of the least significant 16 bits of the build number. Win:1.2
build number of <operating system> | Plain | <integer> | This Windows-only inspector returns the build number of the specified OS as an integer. This is the value of the dwBuildNumber member of the OSVERSIONINFO structure returned by the GetVersionEx Windows API. Win:7.2
build number of <operating system> | Plain | <string> | Returns the integer build number (as a string) of the operating system. Mac:5.1
build of <operating system> | Plain | <string> | Returns a string corresponding to the build number of the OS. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
csd version of <operating system> | Plain | <string> | Returns the Corrective Service Disk version of the operating system. The szCSDVersion as returned by the GetVersionEx system call. The format varies depending on the installed service packs. For WinNT it contains a string such as "Service Pack 3", for Win95 it can contain a string such as "B". Win:1.2
ia64 of <operating system> | Plain | <boolean> | Returns TRUE iff the BES Client is running on Itanium. Win:7.0
major version of <operating system> | Plain | <integer> | Returns integer which is the dwMajorVersion returned by the GetVersionEx system call. Note that while the WinNT major version tracks the release (3 for 3.51, 4 for 4.0, and 5.0 for Windows 2000, 5.1 for Windows XP), the major version for Win95 and Win98 is always 4. Win:1.2
metric <integer> of <operating system> | Numbered | <integer> | This inspector uses the windows GetSystemMetrics API. The integer constants and their meaning are defined by Microsoft. For example, the integer 87 indicates that the operating system is a media center edition. The integer constants are defined in WinUser.h. Win:6.0
minor version of <operating system> | Plain | <integer> | Numeric representation of the minor version of the operating system. Win:1.2
name of <operating system> | Plain | <string> | Returns the name of the operating system as a string. Names might include Win98, WinNT, etc. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
performance counter frequency of <operating system> | Plain | <hertz> | The rate at which the performance counter is being incremented (per second). Win:1.2
performance counter of <operating system> | Plain | <integer> | Retrieves a 64-bit performance counter value. Win:1.2
platform id of <operating system> | Plain | <integer> | Returns the dwPlatformId as returned by the GetVersionEx system call. Possible values are 1 (Win95/95) and 2 (WinNT). Win:1.2
product info numeric of <operating system> | Plain | <integer> | This Windows-specific inspector returns the integer from the Windows GetProductInfo API. The inspector only provides meaningful results for Windows Vista and newer versions of the OS. The major/minor version of the OS must be 6.0 or greater for the result to be meaningful. For more information, refer to the Microsoft article at http://msdn2.microsoft.com/en-us/library/ms724358(VS.85).aspx. Win:7.0
product info string of <operating system> | Plain | <string> | On Windows versions 6.0 and newer (Vista minimum), this inspector returns a string derived from the GetProductInfo API. It will be one of the following values: • Unlicensed • Business • Cluster Server • Server Datacenter • Server Datacenter Core • Enterprise • Server Enterprise • Server Enterprise Core • Server Enterprise Itanium • Home Basic • Home Server • Server for Small Business • Small Business Server • Small Business Server Premium • Server Standard • Server Standard Core • Starter • Storage Server Enterprise • Storage Server Standard • Storage Server Workgroup • Ultimate • Web Server • Unknown. Win:7.0
product type of <operating system> | Plain | <operating system product type> | Returns the product type of the operating system, which includes Workstations, Domain Controllers and Servers. Win:6.0
release of <operating system> | Plain | <string> | Information about the release of the operating system, formatted as a <version> on the Macintosh, but a <string> on Unix and Windows. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
release of <operating system> | Plain | <version> | Information about the release of the operating system, formatted as a <version> on the Macintosh, but a <string> on Unix and Windows. Mac:5.1
service pack major version of <operating system> | Plain | <integer> | Returns the major version number of the current service pack of the specified OS. Win:6.0
service pack minor version of <operating system> | Plain | <integer> | Returns the minor version number of the current service pack of the specified OS. Win:6.0
suite mask of <operating system> | Plain | <operating system suite mask> | Returns the bit-mapped suite mask for the operating system, which contains further fine-grain information about the version. Win:6.0
uptime of <operating system> | Plain | <time interval> | Returns a time interval that represents the elapsed time since the operating system was last booted. • Note: Depending on the Laptop, this interval may not include time spent in hibernation. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:6.0
x64 of <operating system> | Plain | <boolean> | Returns TRUE if the current operating system is 64-bits. Win:6.0

Examples

now - boot time of operating system > week
Returns TRUE if the computer hasn't been rebooted for over a week.

build number high of operating system = 1027
Returns TRUE if the high word of the build number = 0403 hex.

build number low of operating system = 1212
Returns TRUE if the low word of the build number = 04BC hex.

csd version of the operating system = "B"
Returns TRUE on a Win95 System with Corrective Service Disk version = "B".

major version of operating system = 4
Returns TRUE if the major version (before the dot) is 4, such as 4.1, 4.2, etc.

minor version of operating system = 0
Returns TRUE if the minor part of a version number (after the dot) is 0, such as 4.0, 5.0, etc.

platform id of operating system = 1
Returns TRUE on a Win95 System.


Operating System Product Type

These Inspectors return the product type of the operating system, which includes Workstations, Domain Controllers and Servers.

Creation Methods

Key Phrase | Form | Description
nt domain controller product type | PlainGlobal | Returns an object corresponding to OS product type of nt domain controller. Win:6.0
nt server product type | PlainGlobal | Returns an object corresponding to OS product type of nt server. Win:6.0
nt workstation product type | PlainGlobal | Returns an object corresponding to OS product type of nt workstation. Win:6.0
operating system product type <integer> | NumberedGlobal | Returns an object corresponding to the numbered OS product type. Win:6.0
product type of <operating system> | Plain | Returns the product type of the operating system, which includes Workstations, Domain Controllers and Servers. Win:6.0

Operators

Key phrase | Return Type | Description
<operating system product type> = <operating system product type> | <boolean> | Compare two operating system product types for equality. Win:6.0


Operating System Suite Mask

These Inspectors provide detailed information about the operating system version.

Creation Methods

Key Phrase | Form | Description
suite mask of <operating system> | Plain | Returns the bit-mapped suite mask for the operating system, which contains further fine-grain information about the version. Win:6.0


Osxvalue

These Inspectors provide access to the elements of a dictionary.

Creation Methods

Key Phrase | Form | Description
value of <array> | Plain | Values of the array. Mac:4.1
value of <dictionaryentry> | Plain | Values of the dictionary entry. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
array of <osxvalue> | Plain | <array> | Casts the osxvalue (which is essentially untyped) to an array. Mac:4.1
boolean of <osxvalue> | Plain | <boolean> | Casts the osxvalue (which is essentially untyped) to a boolean. Mac:4.1
cstring of <osxvalue> | Plain | <string> | Strips off any trailing null from an osxvalue, returning a proper string from the dictionary. • NOTE: In Version 6.0.9.54, the plural inspector is misspelled as csrings. Mac:6.0
data of <osxvalue> | Plain | <string> | Casts the specified osxvalue to a string. Mac:6.0
date of <osxvalue> | Plain | <time> | Casts the osxvalue (essentially untyped) to a date. Mac:4.1
dictionary of <osxvalue> | Plain | <dictionary> | Casts the osxvalue (essentially untyped) to a dictionary. Mac:4.1
integer of <osxvalue> | Plain | <integer> | Casts the osxvalue (essentially untyped) to an integer. Mac:4.1
string of <osxvalue> | Plain | <string> | The string of the osxvalue, cast to a string if necessary. Mac:4.1
type of <osxvalue> | Plain | <string> | The type of the osxvalue (e.g. boolean, string, integer, data, date, array, dictionary, or unknown type). Mac:4.1

Examples

strings of values of array "RecentSearchStrings" of preference "com.apple.safari"
Returns a list of the most recent search strings, in temporal order.

strings of values of entries of dictionary of file "com.apple.safari" of preferences folder
Returns a list of strings corresponding to the dictionary values of the specified file, e.g.: 12/19/2002, /Users/bigfix/Library/Safari/Icons, 125.12, }%00%00%00, 2004-02-20 19:36:50 -0800, 262 485 424 261 0 0 1024 746, etc….


Package

This filesystem object can inspect the propeties of an RPM (RPM Package Manager) package. Each package contains information about the program, including name and version.

Creation Methods

Key Phrase | Form | Description
package <string> of <rpmdatabase> | Named | Creates a named package from the RPM database. Lin:3.1
package conflicting with <capability> of <rpmdatabase> | Index<capability> | Returns a package in the RPM database that conflicts with this capability. If any packages are returned, then the rpm command will not allow any package providing this capability to be installed. Lin:4.1
package installing <capability> of <rpmdatabase> | Index<capability> | Finds the package that installed the specified capability. Lin:4.1
package of <rpmdatabase> | Plain | Returns all the packages in the RPM database. Lin:3.1
package providing <capability> of <rpmdatabase> | Index<capability> | Returns a package in the RPM database that provides this capability. If no packages are returned, then the rpm command will not allow any packages requiring this capability to be installed. Lin:4.1
package requiring <capability> of <rpmdatabase> | Index<capability> | Returns a package in the RPM database that requires this capability. If any packages are returned, then the rpm command will not allow any installed package that provides this capability to be uninstalled. Lin:4.1

Properties

Key Phrase | Form | Return Type | Description
<package> as string | Cast | <string> | Creates a string containing the package's name, version and release. Lin:4.1
architecture of <package> | Plain | <string> | The architecture represents the CPU type that the RPM Package was designed to be used on. Typical values are i386, i686, or x86_64, but packages can be created with archtectures like 'noarch' or have no architecture specified at all. Lin:7.0
conflict of <package> | Plain | <capability> | Returns capability objects that conflict with this package in the RPM database. Lin:4.1
installed file of <package> | Plain | <capability> | The list of actual files that the package leaves installed. Lin:4.1
name of <package> | Plain | <string> | Returns the name of the given RPM package. Lin:3.1
obsolete of <package> | Plain | <capability> | Returns a capability object that this package obsoletes. Lin:4.1
provide of <package> | Plain | <capability> | Returns capability objects for each capability that this package provides. Lin:4.1
require of <package> | Plain | <capability> | Returns capability objects for each capability that this package requires. Lin:4.1
version of <package> | Plain | <version> | Returns the version of the given RPM package. Lin:3.1

Examples

version of package "glibc" of rpm
Returns the version of the glibc package of the rpm database.

package conflicting with (capability "nonfreessh") of rpm
Returns a string like "openssh-3.0.2p1-162", indicating which package(s) conflict with the specified capability.

package installing (capability "/opt/BESClient/BESLib/libEngine.so") of rpm
Returns BESAgent-4.1.4.2-1, the package that installed the specified capability.

package providing (capability "sh") of rpm
Returns a string like "bash-2.05-321", indicating which package(s) provide the specified capability.

package requiring (capability "iptables") of rpm
Returns a string like "personal-firewall-1.2-68", which is an application package that requires iptables.

package "apache" of rpm as string
Returns a string with information about the package, such as "apache-1.3.23-88".

architecture of package "BESAgent" of rpm
On a SuSE Linux Enterprise Server 9.0, 64 bit, this will return x86_64, while on a Fedora Core 3, 32 bit, it will return i386.

conflict of package "openssh" of rpm
Returns a string, such as "nonfreessh". The openssh program is specifying a conflict with nonfreessh.

obsolete of package "mod_php4" of rpm
Returns a string such as "mod_php", which a capability that is obsoleted by the current package.

require of package "apache" of rpm
Returns a string such as "/bin/sh" to indicate a requirement of the package.


Patch

An object that exposes the properties of a Solaris patch, each of which has a base ID followed by a revision number, such as 123456-12. Here the base is 123456, which identifies the patch, and 12, which represents the revision of this particular patch.

Creation Methods

Key Phrase | Form | Description
patch <string> of <pkgdb> | Named | Returns the patch specified by <string> from the given Solaris package database. Sol:3.1
patch <string> of <pkginfo> | Named | Returns the requested patch object from the specified pkginfo. Typically used for existence tests. Sol:3.1
patch of <pkgdb> | Plain | Creates objects for all the patches in the specified package database. Sol:3.1
patch of <pkginfo> | Plain | Returns the patch(es) named in the specified pkginfo object. Sol:3.1

Properties

Key Phrase | Form | Return Type | Description
base of <patch> | Plain | <string> | Returns the base number of the given patch, which is a unique identifier for the file, as a string. Sol:3.1
greatest revision of <patch> | Plain | <string> | Returns the highest revision of the patch. Sol:4.1
least revision of <patch> | Plain | <string> | Returns the lowest revision of the patch. Sol:4.1
revision <string> of <patch> | Named | <string> | Returns the specified revision string from the given patch. Typically used for existence tests. Sol:3.1
revision of <patch> | Plain | <string> | Returns an additional revision number which modifies the base of the patch. Sol:3.1

Examples

exists patch "123456" of pkginfo "SUNWrdm" of pkgdb
Returns TRUE if this patch exists in the specified pkginfo of the package database.

exists revision "02" of patch "123456" of pkginfo "SUNWrdm" of pkgdb
Returns TRUE if the specified revision of the given patch in the given pkginfo exists in the package database.

exists patch whose (revision of it < "3") of pkgdb
Returns TRUE if there is a patch in the package database with a revision number less than 3.


Pkgdb

This is a database object created by BigFix to keep track of all the Solaris packages (pkginfos) that have been installed on this computer. The pkginfo object, in turn, contains Solaris patches, each with an ID and a revision number. The database essentially contains a comprehensive list of patches, allowing you to directly access a patch without going through pkginfo. The syntax is "patch of pkgdb", which can greatly simplify your relevance expressions.

Creation Methods

Key Phrase | Form | Description
pkgdb | PlainGlobal | Creates a top-level object containing a list of all the installed packages, in the form of pkginfos. Sol:3.1

Properties

Key Phrase | Form | Return Type | Description
patch <string> of <pkgdb> | Named | <patch> | Returns the requested patch from the package database. Typically used for existence tests. Sol:3.1
patch id <string> of <pkgdb> | Named | <string> | Returns the specified patch id string from the package database. Typically used for existence tests. Sol:3.1
patch id of <pkgdb> | Plain | <string> | Returns a space-delimited list of patch ids from the specified package database. Sol:3.1
patch of <pkgdb> | Plain | <patch> | Returns all the patches listed in the given pkgdb (package database). Sol:3.1
pkginfo <string> of <pkgdb> | Named | <pkginfo> | Returns the specified pkginfo from the package database. Typically used for existence tests. Sol:3.1
pkginfo of <pkgdb> | Plain | <pkginfo> | Returns all the packages (as pkginfos) in the given package database. Sol:3.1

Examples

exists patch "123456" of pkgdb
Returns TRUE if any revision of the patch with this ID exists in the package database.

exists patch "123456-12" of pkgdb
Returns TRUE if this exact patch ID (including the revision) exists in the package database.

exists patch id "123456-01 345678-23" of pkgdb
Returns TRUE if these patch ids exist in the package database.

exists patch id whose (it contains "123456-01") of pkgdb
Returns TRUE if the specified patch id exists in the package database.

patch id of pkgdb contains "123456"
Returns TRUE if the designated patch ID exists in the package database.

exists pkginfo "SUNWrdm" of pkgdb
Returns TRUE if the specified pkginfo exists in the package database.


Pkginfo

Pkginfo is an object containing information about Solaris packages, which are used to deliver patches. Pkginfo contains information about the category, the intended architecture, vendors, patch IDs and revision numbers. Other package information can be inspected using the "param" property which lets you access other parameters by name.

Creation Methods

Key Phrase | Form | Description
pkginfo <string> of <pkgdb> | Named | Returns the specified pkginfo from the package database. Typically used for existence tests. Sol:3.1
pkginfo of <pkgdb> | Plain | Creates an object containing all the packages (as pkginfos) in the given package database. Sol:3.1

Properties

Key Phrase | Form | Return Type | Description
<pkginfo> as string | Cast | <string> | Converts a pkginfo object into a string. Sol:3.1
arch of <pkginfo> | Plain | <string> | Returns a string representing the architecture of the package specified by the pkginfo object. Sol:3.1
category of <pkginfo> | Plain | <string> | Returns a string representing the category of the package specified by pkginfo. Sol:3.1
name of <pkginfo> | Plain | <string> | Returns the name of the package from the specified pkginfo object. Sol:3.1
param <string> of <pkginfo> | Named | <string> | Returns the value of the named parameter (specified by <string>) from the pkginfo object. Sol:3.1
patch <string> of <pkginfo> | Named | <patch> | Returns a named patch from the specified pkginfo. Sol:3.1
patch id <string> of <pkginfo> | Named | <string> | Returns the specified patch id string from the specified pkginfo of the package database. Typically used for existence tests. Sol:3.1
patch id of <pkginfo> | Plain | <string> | Returns a space delimited list of patch ids, e.g.: "123456-01 123456-02 200213-23 501234-02". This is the same list available from the PATCHLIST parameter of the pkginfo. Sol:3.1
patch of <pkginfo> | Plain | <patch> | Returns the patch object referenced in the pkginfo object. Sol:3.1
pkginst of <pkginfo> | Plain | <string> | Returns a short string used as an abbreviation for the package name given by the pkginfo object. Typically contains a vendor symbol and an ID, like "CSCOh007". Sol:3.1
vendor of <pkginfo> | Plain | <string> | Returns a string containing the name of the package vendor. This is the same as the VENDOR parameter of the pkginfo. Sol:3.1
version of <pkginfo> | Plain | <string> | Returns a version number for the specified pkginfo object. Not to be confused with revision numbers of patches. This is the same as the VERSION parameter of the pkginfo. Sol:3.1

Examples

param "INSTDATE" of pkginfo "SPROhtws" of pkgdb
Returns the install date as a string like "Jul 24 2003 09:45".

exists patch id "123456-01" of pkginfo "SUNWrdm" of pkgdb
Returns TRUE if the designated patch ID exists in the specified pkginfo of the package database.

version of pkginfo "SPROhtws" of pkgdb
Returns a version string like "8.0,REV=2003.04.02".


Port Mapping

Refers to a port mapping object for the built-in firewall.

Creation Methods

Key Phrase | Form | Description
port mapping of <internet connection firewall> | Plain | Creates a port mapping object for the built-in firewall. Win:4.1

Properties

Key Phrase | Form | Return Type | Description
enabled of <port mapping> | Plain | <boolean> | A boolean indicating whether or not the port mapping is enabled. Win:4.1
external port of <port mapping> | Plain | <integer> | Returns the external port number of the specified ICF port mapping. Win:4.1
internal port of <port mapping> | Plain | <integer> | Returns the internal port number of the specified ICF port mapping. Win:4.1
name of <port mapping> | Plain | <string> | Returns the name of the specified port mapping. Win:4.1
options of <port mapping> | Plain | <integer> | See port mapping at MSDN. Win:4.1
protocol of <port mapping> | Plain | <string> | Returns a string like "tcp" or "udp", corresponding to the protocol of the specified port mapping. Win:4.1
target ip address of <port mapping> | Plain | <ipv4 address> | Returns the target IP address of the specified port mapping. Win:4.1
target name of <port mapping> | Plain | <string> | Returns the target name of the specified port mapping. Win:4.1


Preference

These Inspectors provide access to application preference files.

Creation Methods

Key Phrase | Form | Description
preference <string> | NamedGlobal | The named set of preferences. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
array <string> of <preference> | Named | <array> | Get, from a preference file, an array keyed by the specified string. Mac:4.1
boolean <string> of <preference> | Named | <boolean> | Get, from a preference file, a boolean keyed by the specified string. Mac:4.1
date <string> of <preference> | Named | <time> | Get, from a preference, a date keyed by the specified string. Mac:4.1
dictionary <string> of <preference> | Named | <dictionary> | Get, from a preference, a dictionary keyed by the specified string. Mac:4.1
integer <string> of <preference> | Named | <integer> | Get, from a preference, an integer keyed by the specified string. Mac:4.1
string <string> of <preference> | Named | <string> | Get, from a preference, the string keyed by the specified string. Mac:4.1

Examples

boolean "autohide" of preference "com.apple.dock"
Returns TRUE if the autohide preference is set.

date "date" of dictionary "Timer" of dictionary "SUCheckSchedulerTag" of dictionary "com.apple.SoftwareUpdate" of dictionary "AbsoluteSchedule" of preference "com.apple.scheduler"
Returns the date of the specified dictionary.

integer "mod-count" of preference "com.apple.dock"
Returns the mod-count of the specified preference as an integer.

string "FXSearchFieldTarget" of preference "com.apple.finder"
Returns a string, such as Spcf.


Primary Language

A primary language identifier indicates the written/spoken language that is used by the system. However, to identify the language that is used in a country or region you must combine the primary language with a sub-language identifier to form language identifiers.

Creation Methods

Key Phrase | Form | Description
primary language of <language> | Plain | Extracts the primary language identifier from a language. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1

Properties

Key Phrase | Form | Return Type | Description
<primary language> as string | Cast | <string> | Returns the primary language. Win:4.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1

Examples

primary language of system locale
Returns "English" for an English-language system.


Process

When Unix launches a process, it assigns it a unique number called the process ID, or pid. The process object lets you inspect the properties of any running process, including its name and pid.

Creation Methods

Key Phrase | Form | Description
process | PlainGlobal | Returns all process objects currently running. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
process <integer> | NumberedGlobal | Returns the process object corresponding to the given integer pid. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
process <string> | NamedGlobal | Returns the process object corresponding to the name specified by <string>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
id of <process> | Plain | <integer> | Returns the integer ID of the specified process. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
name of <process> | Plain | <string> | Returns the name (as a string) of the specified process. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
pid of <process> | Plain | <integer> | Returns the integer process ID for the specified process. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
process id of <process> | Plain | <integer> | Returns the integer process ID for the specified process. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1

Examples

names of processes whose (pid of it < 20)
Returns a list of all process with an ID less than 20.


Processor

The processor object is used to identify the number and properties of processors in the system. You can identify the manufacturer of the CPU as well as the speed and other features. Many operating systems provide for multiple processors. You can inspect any one of them by their ordinal number.

Creation Methods

Key Phrase | Form | Description
main processor | PlainGlobal | Creates the object associated with the 'Primary' processor. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
processor | PlainGlobal | Iterates through the processors in the system. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
processor <integer> | NumberedGlobal | Creates the processor object for the number specified. The first processor is processor number 1. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
bogomips of <processor> | Plain | <integer> | Returns the Bogomips of the specified processor, which provides a rough indication of its speed. Lin:3.1
brand id of <processor> | Plain | <integer> | This inspector returns the integer known as the brand id, returned from the assembly language cpuid extended instruction. Win:6.0
brand string of <processor> | Plain | <string> | Returns the vendor-defined brand names for newer processors. Win:1.2
coma bug of <processor> | Plain | <boolean> | Returns TRUE if the specified processor is afflicted by the coma bug. The coma bug afflicts certain Cyrix CPUs, causing them to occasionally lock up. The affected CPUs include the Cyrix/IBM 6x86, 6x86L, and 6x86MX. Lin:3.1
cpuid level of <processor> | Plain | <integer> | Returns an integer corresponding to the cpuid level for the given processor. Lin:3.1
extended family of <processor> | Plain | <integer> | Integer representing the extended family of CPU. See the notes for the meaning of these numbers. Win:1.2
extended model of <processor> | Plain | <integer> | Integer representing the extended model of CPU. See the notes for the meaning of these numbers. Win:1.2
f00f bug of <processor> | Plain | <boolean> | Returns TRUE if the specified processor is afflicted by the f00f bug. This bug is named after the first two of a four-byte assembly language sequence that can freeze up x86 Pentium processors. Lin:3.1
family name of <processor> | Plain | <string> | Returns the family name of the CPU, dependent on the type of client computer, for instance Pentium, Sparc, PowerPC G4, etc. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
family of <processor> | Plain | <integer> | Returns an integer corresponding to the family of the client processor. Win:7.2
family of <processor> | Plain | <string> | A string representing the family of the CPU. Sol:6.0, AIX:6.0
fdiv bug of <processor> | Plain | <boolean> | Returns TRUE if the specified processor is afflicted by the fdiv bug, which occasionally causes incorrect floating point division answers. Lin:3.1
feature mask of <processor> | Plain | <integer> | Returns the feature flags from the CPUID instruction. The feature mask contains bits that identify extra features the processor may provide such as MMX support or if the Processor ID is enabled on the processor. Win:1.2
flag list of <processor> | Plain | <string> | Returns a string containing the processor flags. To check if a processor has a particular flag, use the ‘contains’ operator. Lin:3.1
fpu exception of <processor> | Plain | <boolean> | Returns TRUE if the fpu exception has occurred on this processor. Lin:3.1
fpu of <processor> | Plain | <boolean> | Returns TRUE if the specified processor contains a floating point unit. Lin:3.1
fputype of <processor> | Plain | <string> | Returns pi_fputypes, a string containing the comma-separated types of floating-point units (FPUs) attached to the processor. This string will be empty if no FPU is attached. Sol:3.1
hlt bug of <processor> | Plain | <boolean> | Returns TRUE if the specified processor is afflicted by the hlt bug. Lin:3.1
id of <processor> | Plain | <integer> | Returns an integer corresponding to the ID of the specified processor. Sol:6.0, AIX:6.0
index of <processor> | Plain | <integer> | Returns the ordinal number of the processor on a multi processor machine. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
model name of <processor> | Plain | <string> | Returns a string containing the name of the processor model. Lin:3.1
model of <processor> | Plain | <integer> | Returns the model number of the CPU. • Note: On Solaris, HPUX and AIX computers, this Inspector returns a <string> as of BES 6.0. Win:1.2, Lin:3.1
model of <processor> | Plain | <string> | Returns the model number of the CPU as a string. Sol:6.0, HPUX:6.0, AIX:6.0
sep bug of <processor> | Plain | <boolean> | Returns TRUE if the given processor improperly reports the value of its SEP (Sysenter/sysexit Present) flag. Lin:3.1
speed of <processor> | Plain | <hertz> | Returns the speed of the processor in Hertz. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
state of <processor> | Plain | <string> | Returns the current processor state, which can be "online", "offline", "poweroff", or "unknown". Sol:3.1, HPUX:4.0
stepping of <processor> | Plain | <integer> | Returns the stepping number of the processor. This item can be helpful in identifying very specific processor features or limitations. Win:1.2, Lin:3.1
type of <processor> | Plain | <integer> | Numeric type of the CPU. Values include: • 0 - standard • 1 - overdrive • 2 - dual CPU capable • 3 - reserved • Note: this Inspector returns a <string> type as of BES version 6.0 on Unix machines and version 5.1 on the Macintosh. Win:1.2
type of <processor> | Plain | <string> | Numeric type of the CPU. Values include: • 0 - standard • 1 - overdrive • 2 - dual CPU capable • 3 - reserved • Note: this Inspector returns a <string> type as of BES version 6.0 on Unix machines and version 5.1 on the Macintosh. Sol:6.0, AIX:6.0, Mac:5.1
vendor name of <processor> | Plain | <string> | The manufacturer of the CPU. Names include: • GenuineIntel • AuthenticAMD • CyrixInstead • CentaurHauls • AmbiguousCPU. Win:1.2, Lin:3.1
version of <processor> | Plain | <string> | The hardware version of the cpu. HPUX:4.0
wp of <processor> | Plain | <boolean> | Returns TRUE if the specified processor has the WP feature. Lin:3.1

Examples

number of processors > 1
Returns TRUE if the computer is a multi-processor system.

bit 18 of feature mask of main processor
Returns TRUE if the processor ID feature is enabled on this processor.

speed of main processor < 2000 * MHz
Returns TRUE is the cpu is slower than 2Ghz.

vendor name of main processor = "GenuineIntel"
Returns TRUE for an Intel processor chip.

number of processors whose (vendor name of it = "AuthenticAMD" or vendor name of it = "CyrixInstead" or vendor name of it = "CentaurHauls") = 1
Returns TRUE for a single processor system with the given vendors.

version of main processor
Returns a string like "PA-RISC 2.0".


Product

The product object contains properties (such as vendor and revision) of the associated software product.

Creation Methods

Key Phrase | Form | Description
product <string> of <object_repository> | Named | This is a named property of the object repository. AIX:4.1
product <string> of <software_depot> | Named | Direct access to specified installed software product. Use the product tag as the identifying name. HPUX:4.0
product of <bundle> | Plain | Returns the product and/or products contained in the bundle. HPUX:4.1
product of <fileset> | Plain | Returns the product corresponding to the specified fileset. AIX:4.1
product of <object_repository> | Plain | Returns a list of the products in the object repository. AIX:4.1
product of <software_depot> | Plain | Iterated access to any or all installed software products. HPUX:4.0

Properties

Key Phrase | Form | Return Type | Description
<product> as string | Cast | <string> | Brief text string identifying a product including the tag and version. HPUX:4.0, AIX:4.1
bundle of <product> | Plain | <bundle> | Returns the bundle to which the product belongs. HPUX:4.1
fileset of <product> | Plain | <fileset> | Returns a list of the filesets (installable software packages) in the specified product. AIX:4.1
name of <product> | Plain | <string> | Returns the name of the specified product. AIX:4.1
revision of <product> | Plain | <string> | Version identifier of installed software product. HPUX:4.0
tag of <product> | Plain | <string> | Short identifying name of installed software product. Tag is used as identifier in named product accessor. HPUX:4.0
title of <product> | Plain | <string> | Long identifying name of installed software product. HPUX:4.0
vendor of <product> | Plain | <string> | Text identifying the vendor of the installed software product. HPUX:4.0

Examples

exists product "OS-Core" of software depot
Returns TRUE if the specified software exists.

products whose (vendor of it is "BigFix") of software depot as string
Returns a list of the BigFix product(s) on the computer, such as "BESAgent 4.0.3.7".

product "BESAgent" of software depot as string
Returns the full name of the product, such as "BESAgent 4.0.3.7".

filesets of products "bos.terminfo" of object repository
Returns a list of the various versions of the specified program from the object repository.

revision of product "OS-Core" of software depot
Returns a string such as "B.11.00".

tag of product whose (vendor of it = "BigFix") of software depot
Returns a string such as "BESAgent 4.0.3.7".

title of product "OS-Core" of software depot
Returns a string such as "Core Operating System".

vendor of product "BESAgent" of software depot
Returns a string such as "BigFix".


Property

Some Inspectors look at the Relevance language itself, inspecting the Inspectors, so to speak. There are several aspects to view, including the types, properties, casts and operators. This group of Inspectors looks at the properties available from the Relevance language.

Creation Methods

Key Phrase | Form | Description
property | PlainGlobal | The inspectors invoked with phrases, but without the keyword "as". Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
property <string> | NamedGlobal | Returns the first inspector property whose name matches the given string. Note that there may be more than one property with a given name. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property <string> of <type> | Named | Returns the Inspector property of the specified string and type. Typically there is more than one property, so this is often used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property of <type> | Plain | Returns the Inspector property of the specified type. Typically there is more than one property, so this is typically used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property returning <type> | Index<type>Global | Produces a list of the Inspector properties that return the "file" type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property returning <type> of <type> | Index<type> | Returns Inspectors of the form <type> of <type>. Typically there is more than one property, so this is often used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<property> as string | Cast | <string> | A short description of the use of the property. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
direct object type of <property> | Plain | <type> | The type (if any) required after the keyword "of" in an expression using the property. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
index type of <property> | Plain | <type> | The type (if any) required before or without the keyword "of" in an expression using the property. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
multivalued of <property> | Plain | <boolean> | Can the property have more than one value for a single input?. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
plural name of <property> | Plain | <string> | The name of the property, in the plural. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <property> | Plain | <type> | The type that the property produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
singular name of <property> | Plain | <string> | The name of the property, in the singular. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
usual name of <property> | Plain | <string> | Returns the usual name of the specified property. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Ram

The ram object is used to inspect properties of the computer's random access memory.

Creation Methods

Key Phrase | Form | Description
ram | PlainGlobal | Creates the object that can be accessed to inspect the amount of ram on the machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
random access memory | PlainGlobal | Same as 'ram'. Win:1.2, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
available amount of <ram> | Plain | <integer> | Returns the amount of system ram that is currently available, in bytes. Lin:3.1
buffered amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently buffered, in bytes. Lin:3.1
cached amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently cached, in bytes. Lin:3.1
free amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently unused, in bytes. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
shared amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently shared, in bytes. Lin:3.1
size of <ram> | Plain | <integer> | Returns the number of bytes of random access memory on the current machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
total amount of <ram> | Plain | <integer> | Same as size of <ram>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
unavailable amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently unavailable, in bytes. Lin:3.1
used amount of <ram> | Plain | <integer> | Returns the amount of system RAM currently used, in bytes. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Examples

size of ram / (1024 * 1024)
Returns the size of RAM in megabytes.


Registry

These are the Inspectors that expose the Windows registry.

Creation Methods

Key Phrase | Form | Description
native registry | PlainGlobal | On 32 bit versions of windows, this returns the same as registry32 and registry. On 64 bit versions of windows, this returns the same as registry64. Win:6.0
registry | PlainGlobal | Creates an object for accessing the registry. Win:1.2
x32 registry | PlainGlobal | Returns a 32-bit registry object. This Inspector is equivalent to the ordinary registry Inspector. Win:6.0
x64 registry | PlainGlobal | Returns a 64-bit registry object. This Inspector is for 64-bit computers only; there is no 64-bit registry on a 32-bit computer. • Note that "x64 registry" and "native registry" on 64-bit machines do NOT provide the same view as the 64-bit version of regedit (the "physical" view). If you try to access the physical location of the 32-bit view keys using a 64-bit view, it will be mapped back to the equivalent location in the 64-bit view. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
application <string> of <registry> | Named | <application> | Returns an application object matching name provided. See application. Win:1.2
application folder <string> of <registry> | Named | <folder> | Returns the folder containing the matching name provided. See application. The application does not have to exist. The folder has to exist. Win:1.2
application of <registry> | Plain | <application> | Iterates through the properly installed applications. See application. Win:1.2
current user key <logged on user> of <registry> | Index<logged on user> | <registry key> | On 2000/2003/XP/Vista, this Inspector returns RegOpenCurrentUser. Under NT4, it uses HKEY_USERS\<sid>. On these systems, the Inspector may fail if run in a non-privileged context. Under Windows 9x, it returns HKEY_USERS\<username> if it exists. Otherwise it uses HKEY_USERS\Default. Win:7.0
device key <string> of <registry> | Named | <registry key> | Iterates through all the keys known to the configuration manager for active devices whose "DeviceDesc" matches the name provided. See registry key. Win:1.2
device key of <registry> | Plain | <registry key> | Iterates through all the keys known to the configuration manager for active devices. See registry key. Win:1.2
file extension <string> of <registry> | Named | <registry key> | Returns a key associated with the named extension. See registry key. Win:1.2
file type <string> of <registry> | Named | <registry key> | Returns a key associated the named file type. See registry key. Win:1.2
key <string> of <registry> | Named | <registry key> | Returns a key associated with the name provided. See registry key. Win:1.2

Examples

key "txtfile" of key "HKEY_CLASSES_ROOT" of the registry
Returns a key whose existence indicates that there is an application designated to process text files. Looks for the key under HKEY_CLASSES_ROOT.


Registry Key

The registry key objects represent Windows registry keys whose existence and properties can be inspected. Keys can be identified by name. There are several Inspectors that return keys from parts of the registry that store file associations and active device drivers.

Creation Methods

Key Phrase | Form | Description
current user key <logged on user> of <registry> | Index<logged on user> | On 2000/2003/XP/Vista, this Inspector returns RegOpenCurrentUser. Under NT4, it uses HKEY_USERS\<sid>. On these systems, the Inspector may fail if run in a non-privileged context. Under Windows 9x, it returns HKEY_USERS\<username> if it exists. Otherwise it uses HKEY_USERS\Default. Win:7.0
device key <string> of <registry> | Named | Iterates through all the keys known to the configuration manager for active devices whose "DeviceDesc" matches the name provided. Win:1.2
device key of <registry> | Plain | Iterates through all the keys known to the configuration manager for active devices. Win:1.2
driver key of <active device> | Plain | The key identified by adding the value of 'driver key value name of active device' to HKLM\System\CurrentControlSet\Control\Class\. Win:1.2
driver key of <registry key> | Plain | Uses the value of "Driver" of the key to indirectly return a key corresponding to HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\<value of Driver>. Win:1.2
file extension <string> of <registry> | Named | Creates a key object provided the registry indicates support for the named file extension. Win:1.2
file type <string> of <registry> | Named | Creates a key object provided the registry indicates support for the named file type. Win:1.2
key <string> of <registry key> | Named | Creates an object for the named sub-key of the key. Win:1.2
key <string> of <registry> | Named | Creates an object for the named key. The name may be a full path to a key of the form "HKEY_CLASSES_ROOT\Fixlet.Pool\". Win:1.2
key of <registry key> | Plain | Iterates through the sub-keys of a key. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
application <string> of <registry key> | Named | <application> | Returns the application associated with the named command. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file type. Win:1.2
application folder <string> of <registry key> | Named | <folder> | Returns the parent folder associated with the named application. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file type. Win:1.2
application folder of <registry key> | Plain | <folder> | Returns the parent folder associated with the named application. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file type. Win:1.2
application of <registry key> | Plain | <application> | Returns the application associated with the "open" command. Normally used with a sub-key of key HKEY_CLASSES_ROOT whose name is a file extension. Win:1.2
default value of <registry key> | Plain | <registry key value> | Returns the unnamed value associated with a key as a string. It does not necessarily exist. Win:1.2
driver key of <registry key> | Plain | <registry key> | Normally used as a property of a device key. Looks up the value of "Driver" of the key provided to indirectly return another key corresponding to HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class\<value of Driver>. Win:1.2
key <string> of <registry key> | Named | <registry key> | Returns a key for the named sub-key. Win:1.2
key of <registry key> | Plain | <registry key> | Iterates through the sub-keys of the key. Win:1.2
name of <registry key> | Plain | <string> | Returns the name of the key as a string. Win:1.2
security descriptor of <registry key> | Plain | <security descriptor> | Specifies the security descriptor associated with the specified registry key. Win:4.1
value <string> of <registry key> | Named | <registry key value> | Returns the named value stored under the key. See registry key value. Win:1.2
value of <registry key> | Plain | <registry key value> | Iterates through values stored under a key. Win:1.2

Note

The terminology of keys, values, default values and values that have names and data is chosen to match the convention's used by the Windows registry editor as well as the API's provided by the Windows operating system for accessing this information.
Top branches of the Windows registry include:
HKEY_CLASSES_ROOT
HKEY_LOCAL_MACHINE
HKEY_CURRENT_USER
HKEY_USERS
HKEY_CURRENT_CONFIG
HKEY_DYN_DATA
HKEY_PERFORMANCE_DATA (NT)
The trailing slashes on registry key names are optional.

File extensions, File types, and associated applications:
The following table represents a small part of the registry. It illustrates the relationship between the notions of file extension, file type, and the shell commands associated with the inspector keywords

Description | HKEY_CLASSES_ROOT\ | Default Value
File extension key | .txt | default value = txtfile
File type key | txtfile\shell\
Named command | txtfile\shell\open\command | default value = c:\windows\NOTEPAD.EXE %1
Named command | txtfile\shell\print\command | default value = c:\windows\NOTEPAD.EXE /p %1

Device Keys of the registry:
The Configuration Manager of the Windows 9x operating system maintains a list of active devices under the HKEY_DYN_DATA\Config Manager\Enum key of the registry. The items in the list contain values named "HardwareKey" which are the names of keys under HKEY_LOCAL_MACHINE\Enum. The value "DeviceDesc" contains a description of the device. The device key inspectors allow you to determine if a particular piece of hardware matching the Device Description is currently active.
Device key "Hardware ABC from Company XYZ" will only return a key if there is an entry under HKEY_DYN_DATA\Config Manager\Enum that points to it.

Examples

file extension ".txt" of the registry
Returns a key corresponding to the application that opens files with this extension. The dot is optional in the name provided.

name of application of file extension "html" of the registry = "iexplore.exe"
Verifies that the name of the application assigned to process html documents is Internet Explorer.

file type "txtfile" of the registry
Returns a key whose existence may indicate that there is an application designated to process files of this type. Looks for the key under HKEY_CLASSES_ROOT.

key "HKEY_CLASSES_ROOT\txtfile" of the registry
Returns a key whose existence indicates that there is an application designated to process text files.


Registry Key Value

This Inspector is used to access values stored within a registry key. All values have sizes and types. All of the values of a registry key have names except one, and it is called the 'default value'. The type of the data stored in the value determines what casting operations are allowed. We have implemented several casting Inspectors that you can use to extract values from the registry.

Creation Methods

Key Phrase | Form | Description
default value of <registry key> | Plain | Every key may have a default or unnamed value. This inspector returns the default value of the key. This value has the same properties as any other registry key value except that it does not have a name property. Win:1.2
value <string> of <registry key> | Named | Creates an object with the value of the key. The name property of the value will match the name provided. Win:1.2
value of <registry key> | Plain | Creates an object with all the values of a key. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
<registry key value> as application | Cast | <application> | If the data stored in the value is a string and it is the full pathname of an application that exists on disk, the application object is returned. Win:1.2
<registry key value> as file | Cast | <file> | If the data stored in the value is a string and it is the full pathname of a file that exists on disk, the file object is returned. Win:1.2
<registry key value> as folder | Cast | <folder> | If the data stored in the value is a string and it is the full pathname of a folder that exists on disk, the folder object is returned. Win:1.2
<registry key value> as integer | Cast | <integer> | Returns the value stored in the registry entry provided it can be fully represented as an integer. Win:1.2
<registry key value> as string | Cast | <string> | Returns a string if the data of the value is of type REG_SZ. Win:1.2
<registry key value> as system file | Cast | <file> | If the data stored in the value is a string and it is a relative pathname from the system folder of a file that exists on disk, the corresponding file object is returned. Win:1.2
<registry key value> as time | Cast | <time> | If the data stored in the value is a string in MIME compliant date format, this property will return a time object. If the data stored is a binary value and is 16 or more bytes in length, its first 16 bytes are interpreted as a SYSTEMTIME and the corresponding time object is returned. See time. Win:1.2
name of <registry key value> | Plain | <string> | Returns the name of the value as a string. (see escape of <string> for more information). Win:1.2
size of <registry key value> | Plain | <integer> | Returns the size of the data as an integer. Win:1.2
type of <registry key value> | Plain | <registry key value type> | Returns the type of the data of the value. See type of value of key or registry. Win:1.2

Operators

Key phrase | Return Type | Description
<registry key value> {cmp} <integer> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<registry key value> {cmp} <registry key value> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<registry key value> {cmp} <string> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2

Note

Eleven literal types are currently recognized. Future types may be handled as numeric types. The possible numeric values of each type and their string literal values include:

0 | REG_NONE
1 | REG_SZ
2 | REG_EXPAND_SZ
3 | REG_BINARY
4 | REG_DWORD
5 | REG_DWORD_BIG_ENDIAN
6 | REG_LINK
7 | REG_MULTI_SZ
8 | REG_RESOURCE_LIST
9 | REG_FULL_RESOURCE_DESCRIPTOR
10 | REG_RESOURCE_REQUIREMENTS_LIST

Examples

type of value "ProfileFlags" of key "HKEY_CURRENT_CONFIG" of registry = "REG_BINARY"
Returns TRUE when a value named ProfileFlags under the key "HKEY_CURRENT_CONFIG" exists and contains binary data.

value "AutoRewind" of key "HKEY_CURRENT_USER\Software\Microsoft \ActiveMovie\Control\Media Player" of registry = 1
Returns TRUE when the specified value of the key equals 1.

size of value whose (name of it = "ProfileFlags") of key "HKEY_CURRENT_CONFIG" of registry = 4
Returns TRUE when a value named ProfileFlags exists as a child of the key "HKEY_CURRENT_CONFIG" and the size of it is 4.


Registry Key Value Type

The type identifier of the data associated with a registry key value.

Creation Methods

Key Phrase | Form | Description
type of <registry key value> | Plain | Creates an integer designating the type of data stored in the registry key value. See the registry MS documentation for these numeric values, which correspond to the enumerated constants discussed in the "<registry key value type> as string" property. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
<registry key value type> as string | Cast | <string> | Returns the type of value as a string. One of REG_SZ, REG_NONE, REG_DWORD, REG_LINK, REG_BINARY, REG_MULTI_SZ, REG_EXPAND_SZ, REG_RESOURCE_LIST, REG_DWORD_LITTLE_ENDIAN, REG_DWORD_BIG_ENDIAN, REG_FULL_RESOURCE_DESCRIPTOR, REG_RESOURCE_REQUIREMENTS_LIST. Win:1.2

Operators

Key phrase | Return Type | Description
<registry key value type> {cmp} <integer> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<registry key value type> {cmp} <registry key value type> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2
<registry key value type> {cmp} <string> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2


Registrynode

These Inspectors provide access to the nodes of the IOKit Registry.

Creation Methods

Key Phrase | Form | Description
audio plane of <registryroot> | Plain | The audio plane of IOKit's registry. Mac:4.1
devicetree plane of <registryroot> | Plain | Returns the device tree plane of IOKit's registry. Mac:4.1
firewire plane of <registryroot> | Plain | The firewire plane of IOKit's registry. Mac:4.1
node <string> of <registrynode> | Named | The named node of the given node of the IOKit registry. Mac:4.1
node <string> of <registryroot> | Named | The named node of the root of the IOKit's registry. Mac:4.1
node of <registrynode> | Plain | The nodes of the given node of the IOKit registry. Mac:4.1
power plane of <registryroot> | Plain | The power plane of IOKit's registry. Mac:4.1
service plane of <registryroot> | Plain | The service plane of IOKit's registry. Mac:4.1
usb plane of <registryroot> | Plain | The usb plane of IOKit's registry. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
classname of <registrynode> | Plain | <string> | The class name of the IOKit registry node. Mac:4.1
dictionary of <registrynode> | Plain | <dictionary> | Returns a dictionary from a node in the IORegistry. Mac:4.1
name of <registrynode> | Plain | <string> | Name of the given IOKit registry node. Mac:4.1
node <string> of <registrynode> | Named | <registrynode> | The named node of the given node of the IOKit registry. Mac:4.1
node of <registrynode> | Plain | <registrynode> | The nodes of the given node of the IOKit registry. Mac:4.1
path of <registrynode> | Plain | <string> | Path of the node in the IOKit registry. Mac:4.1

Examples

name of devicetree plane of iokit registry
See: man ioreg or the Apple Developer documentation.

name of firewire plane of iokit registry
See: man ioreg or the Apple Developer documentation.

exists node "IOPowerConnection" of power plane of iokit registry
Returns TRUE if the specified node exists.

names of nodes whose (name of it contains "DMAEngine") of audio plane of iokit registry
Returns a list of nodes with names containing the specified string, such as Apple02DBDMAAudioDMAEngine.

exists (node "IORootParent" of iokit registry)
Returns TRUE if the specified node exists.

names of nodes of power plane of iokit registry
Returns a list of names, such as IOPowerConnection.

name of power plane of iokit registry
See: man ioreg or the Apple Developer documentation.

name of service plane of iokit registry
See: man ioreg or the Apple Developer documentation.

name of usb plane of iokit registry
See man ioreg or the Apple Developer documentation.

classname of service plane of iokit registry
Returns a classname, such as IOPlatformExpertDevice or IOUSBRootHubDevice.

classname of usb plane of iokit registry
Returns a classname for the specified registry.

name of power plane of iokit registry
Returns a string, such as IORootParent.

path of usb plane of iokit registry
Typically returns the string "IOUSB:/".


Registryroot

These are the Inspectors for the planes of the IOKit Registry

Creation Methods

Key Phrase | Form | Description
iokit registry | PlainGlobal | Returns the root of the IOKit registry. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
audio plane of <registryroot> | Plain | <registrynode> | The audio plane of IOKit's registry. Mac:4.1
devicetree plane of <registryroot> | Plain | <registrynode> | Returns the device tree plane of IOKit's registry. The device tree contains extensive information about devices in the system. Mac:4.1
dictionary of <registryroot> | Plain | <dictionary> | Returns a dictionary from the root of the IOKit registry. Mac:4.1
firewire plane of <registryroot> | Plain | <registrynode> | The firewire plane of IOKit's registry. Mac:4.1
node <string> of <registryroot> | Named | <registrynode> | The named node of the root of the IOKit's registry. Mac:4.1
power plane of <registryroot> | Plain | <registrynode> | The power plane of IOKit's registry. Mac:4.1
service plane of <registryroot> | Plain | <registrynode> | The service plane of IOKit's registry. Mac:4.1
usb plane of <registryroot> | Plain | <registrynode> | The usb plane of IOKit's registry. Mac:4.1

Examples

name of audio plane of iokit registry
Returns the name of the audio portion of the IOKit registry.

name of devicetree plane of iokit registry
Returns the name of the device tree.


Regular Expression

These Inspectors let you use regular expressions (or regexes) in relevance statements. They use the boost library implementation of the 'POSIX-Extended' regular expression syntax, as documented at Wikipedia using the search term "posix-extended regex".

Creation Methods

Key Phrase | Form | Description
case insensitive regex <string> | NamedGlobal | Creates a case-insensitive regular expression (regex) from the specified string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
case insensitive regular expression <string> | NamedGlobal | Same as case insensitive regex <string>. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
regex <string> | NamedGlobal | Creates a regex object from the given string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
regular expression <string> | NamedGlobal | Same as regex <string>. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Operators

Key phrase | Return Type | Description
<regular expression> = <string> | <boolean> | Returns TRUE if the regular expression is equal to the specified string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> = <regular expression> | <boolean> | Returns TRUE if the regular expression is equal to the specified string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> contains <regular expression> | <boolean> | Returns TRUE if the specified string contains the contents of the regular expression. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> ends with <regular expression> | <boolean> | Returns TRUE if the string ends with the contents of the regular expression. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> starts with <regular expression> | <boolean> | Returns TRUE if the string starts with the contents of the regular expression. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Examples

regex ".+match.+" = "We will win the match tonight"
Returns TRUE.

regex ".*PATH.*" = line 1 of file "/etc/profile"
Returns TRUE if the word "PATH" exists in line 1 of the given file.


Regular Expression Match

These Inspectors let you match regular expressions (or regexes) in relevance statements. They use the boost library implementation of the 'POSIX-Extended' regular expression syntax, as documented at Wikipedia using the search term "posix-extended regex". These objects are derived from substring objects.

Creation Methods

Key Phrase | Form | Description
first match <regular expression> of <string> | Index<regular expression> | Creates an object containing the first match to the regular expression in the given string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
match <regular expression> of <string> | Index<regular expression> | Creates an object containing all the matches to the regular expression in the given string. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
parenthesized part <integer> of <regular expression match> | Numbered | <substring> | Returns the nth parenthetical (given by <integer>) in the specified regular expression match. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
parenthesized part of <regular expression match> | Plain | <substring> | Returns the parenthetical part of the specified regular expression match. Win:6.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Examples

first match (regex "to.+") of "just too hot to handle"
Returns "too hot to handle".


Resfork

These Inspectors refer to the resource fork of a filesystem object.

Creation Methods

Key Phrase | Form | Description
resource fork of <file> | Plain | Returns information about the resource fork of the file. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
length of <resfork> | Plain | <integer> | The logical length of the resource fork of the file. Mac:4.1
size of <resfork> | Plain | <integer> | Returns the size of the resource fork. Mac:5.1


Root Server

These Inspectors refer to the root server that the Bes Client is currently connected to.

Creation Methods

Key Phrase | Form | Description
root server | PlainGlobal | Returns an object representing the root BES Server to which the client last registered. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
host name of <root server> | Plain | <string> | The host (DNS) name of the BES root server that the BES Client last registered with. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
id of <root server> | Plain | <integer> | The DSA Server ID of the BES root server that the BES Client last registered with. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1


Rope

The rope object is a way to efficiently concatenate long strings. String literals in the Relevence language are limited to 512 characters, but internally, they can be any length. Ropes provide a technique for concatenating string literals that is memory-efficient. In general, the Fixlet author will not need to worry about ropes, but they are useful for increasing efficiency.

Creation Methods

Key Phrase | Form | Description
rope <string> | NamedGlobal | Creates a rope object from the given string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<rope> as string | Cast | <string> | Converts a rope into a string object. Once converted, all the other string properties are available. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
length of <rope> | Plain | <integer> | Returns the number of bytes in the rope. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Operators

Key phrase | Return Type | Description
<rope> & <rope> | <rope> | Concatenates two ropes into a new rope. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<rope> & <string> | <rope> | Concatenates a rope and a string, producing a rope. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
<rope> contains <string> | <boolean> | Returns TRUE if the rope contains the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> & <rope> | <rope> | Concatenates a rope and a string, returning a new rope. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1


Rpmdatabase

These are the RPM Package Manager Inspectors. The RPM database contains entries for all the installed programs on this computer.

Creation Methods

Key Phrase | Form | Description
rpm | PlainGlobal | Creates an object representing the RPM database of the computer. Lin:3.1
rpm <string> | NamedGlobal | Creates an object representing a named RPM database of the computer. Lin:3.1

Properties

Key Phrase | Form | Return Type | Description
capability <string> of <rpmdatabase> | Named | <capability> | Returns a capability object matching this string if some package in the RPM database provides that capability. Lin:4.1
installed <string> of <rpmdatabase> | Named | <boolean> | Returns TRUE if some package in the RPM database provides the capability represented by this string. Lin:4.1
package <string> of <rpmdatabase> | Named | <package> | Returns the named package from the given RPM database. Lin:3.1
package conflicting with <capability> of <rpmdatabase> | Index<capability> | <package> | Returns a package in the RPM database that conflicts with this capability. If any packages are returned, then the rpm command will not allow any package providing this capability to be installed. Lin:4.1
package installing <capability> of <rpmdatabase> | Index<capability> | <package> | Finds the package that installed the specified capability. Lin:4.1
package of <rpmdatabase> | Plain | <package> | Returns all the packages in the given RPM database. Lin:3.1
package providing <capability> of <rpmdatabase> | Index<capability> | <package> | Returns a package in the RPM database that provides this capability. If no packages are returned, then the rpm command will not allow any packages requiring this capability to be installed. Lin:4.1
package requiring <capability> of <rpmdatabase> | Index<capability> | <package> | Returns a package in the RPM database that requires this capability. If any packages are returned, then the rpm command will not allow any installed package that provides this capability to be uninstalled. Lin:4.1

Examples

package conflicting with (capability "apache2") of rpm
Returns a string like "apache-1.3.23-88", indicating which package(s) conflict with the specified capability.

package installing (capability "/opt/BESClient/BESLib/libEngine.so") of rpm
Returns BESAgent-4.1.4.2-1, the package that installed the specified capability.

package providing (capability "ssh") of rpm
Returns a string like "openssh-3.0.2p1-162", indicating which package(s) provide the specified capability.

package requiring (capability "perl") of rpm
Returns a string like "apache-1.3.23-88", which is an application package that requires Perl.


Runlevel

The runlevel Inspectors refer to a mode of operation in various Unix systems. Typically, when a computer enters runlevel zero, it halts and when it enters runlevel six, it reboots. The intermediate runlevels differ widely among operating systems.

Creation Methods

Key Phrase | Form | Description
runlevel | PlainGlobal | Returns the current runlevel of the local machine. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
<runlevel> as string | Cast | <string> | Casts a runlevel object as a string. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
effective time of <runlevel> | Plain | <time> | Returns the time at which the runlevel was set to its current value. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
previous value of <runlevel> | Plain | <string> | Returns the previous value of the runlevel. In the case where the runlevel has not changed since the system booted, this property evaluates to the empty string. Lin:7.0
value of <runlevel> | Plain | <string> | Returns the current runlevel. It evaluates to a platform-dependent string indicating the current runlevel. For instance, on Linux the value '3' indicates runlevel 3 and 'S' indicates single user mode. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0


Scsibus

These Inspectors refer to the Small Computer System Interface bus components.

Creation Methods

Key Phrase | Form | Description
scsibus | PlainGlobal | An iterated property. When used without a number and not iterated it means SCSI bus 0. Mac:4.1
scsibus <integer> | NumberedGlobal | Returns a SCSI bus with the given number. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
scsidevice <integer> of <scsibus> | Numbered | <scsidevice> | Returns a SCSI device with the given number. Mac:4.1
scsidevice of <scsibus> | Plain | <scsidevice> | Returns a SCSI device associated with the given bus. Mac:4.1
version of <scsibus> | Plain | <version> | Version of the SCSI bus. Mac:4.1
wide16 scsi of <scsibus> | Plain | <boolean> | Whether wide16 is available for the given SCSI bus. Mac:4.1
wide32 scsi of <scsibus> | Plain | <boolean> | Whether wide32 is available for the given SCSI bus. Mac:4.1


Scsidevice

These Inspectors refer to the Small Computer System Interface devices connected to the Client computer.

Creation Methods

Key Phrase | Form | Description
scsidevice | PlainGlobal | An iterated property. It is derived from calls to the MacOS. Mac:4.1
scsidevice <integer> | NumberedGlobal | Returns a SCSI device with the given number. Mac:4.1
scsidevice <integer> of <scsibus> | Numbered | Returns a SCSI device with the given number. Mac:4.1
scsidevice of <scsibus> | Plain | Returns a SCSI device associated with the given bus. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
product of <scsidevice> | Plain | <string> | The product string for the given SCSI device. Mac:4.1
revision of <scsidevice> | Plain | <string> | The revision of the SCSI device. Mac:4.1
type of <scsidevice> | Plain | <string> | Returns a SCSI device type, such as: DISK, TAPE, PRINTER, CPU, WORM, CDROM, SCAN, DISK, or UNKNOWN. Mac:4.1
vendor of <scsidevice> | Plain | <string> | Vendor string for given SCSI device. Mac:4.1


Security Account

The security account type serves as a base type for the "user" and "local group" types and for properties common to users and groups.

Creation Methods

Key Phrase | Form | Description
security account <string> | NamedGlobal | This is a named Inspector that uses the LookupAccountName API function to return an object representing a user or group. Win:7.2

Properties

Key Phrase | Form | Return Type | Description
privilege of <security account> | Plain | <string> | Returns a string describing the privileges assigned to the specified security account. For more information, see the MSDN article on LsaEnumerateAccountRights. For a description of the possible constants that can be returned, see the articles on Account Rights Constants and Privilege Constants. Win:7.1
sid of <security account> | Plain | <security identifier> | Returns the Security ID (SID) associated with the specified security account. Win:7.1


Security Database

These Inspectors retrieve information from the security accounts manager (SAM) database or, in the case of domain controllers, the Active Directory. The Security database and its properties expose the NetUserModalsGet API, levels 0 and 3. For more information, see the NetUserModalsGet Function at the MSDN site: http://msdn.microsoft.com.

Creation Methods

Key Phrase | Form | Description
security database | PlainGlobal | Returns the security accounts manager (SAM) database or, in the case of domain controllers, the Active Directory. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
account lockout duration of <security database> | Plain | <time interval> | Returns the time interval corresponding to how long a locked account remains locked before it is automatically unlocked. For more information, see the MSDN article on NetUserModalsGet. Win:7.1
account lockout observation window of <security database> | Plain | <time interval> | Returns a time interval corresponding to the maximum time that can elapse between any two failed logon attempts before lockout occurs. For more information, see the MSDN article on NetUserModalsGet. Win:7.1
account lockout threshold of <security database> | Plain | <integer> | Returns an integer corresponding to the number of invalid password authentications that can occur before an account is marked 'locked out.' For more information, see the MSDN article on NetUserModalsGet. Win:7.1
force logoff interval of <security database> | Plain | <time interval> | Returns the time interval between the end of the valid logon time and the time when the user must log off the network. A value of zero indicates that the user must log off immediately as soon as the valid logon time expires. For more information, see the MSDN article on NetUserModalsGet. Win:7.1
maximum password age of <security database> | Plain | <time interval> | Returns a time interval corresponding to the maximum password age found in the specified security database. Win:7.1
minimum password age of <security database> | Plain | <time interval> | Returns a time interval corresponding to the minimum password age found in the specified security database. Win:7.1
minimum password length of <security database> | Plain | <integer> | Returns an integer corresponding to the minimum password length found in the specified security database. Win:7.1
password history length of <security database> | Plain | <integer> | Returns the integer length of the password history maintained by the security database. A new password cannot match any of the previous passwords in the specified history. For more information, see the MSDN article on NetUserModalsGet. Win:7.1


Security Descriptor

A structure and associated data that contains the security information for a securable object. A security descriptor identifies the object's owner and primary group. It can also contain a DACL that controls access to the object, and a SACL that controls the logging of attempts to access the object.

Creation Methods

Key Phrase | Form | Description
security descriptor of <file> | Plain | Specifies the security descriptor associated with the specified file. Win:4.1
security descriptor of <folder> | Plain | Specifies the security descriptor associated with the specified folder. Win:4.1
security descriptor of <network share> | Plain | Specifies the security descriptor associated with the specified network share. Win:4.1
security descriptor of <registry key> | Plain | Specifies the security descriptor associated with the specified registry key. Win:4.1
security descriptor of <service> | Plain | This Windows-specific Inspector returns a security descriptor for the specified service. Win:7.0

Properties

Key Phrase | Form | Return Type | Description
<security descriptor> as string | Cast | <string> | Returns the security descriptor in string format. Win:4.1
control of <security descriptor> | Plain | <integer> | Returns the integer property obtained by using the Microsoft Windows GetSecurityDescriptorControl API. This integer contains bits that indicate DACL behaviors as well as default behaviors. See the MSDN documentation of SECURITY_DESCRIPTOR_CONTROL for more information. Win:6.0
dacl of <security descriptor> | Plain | <discretionary access control list> | Returns the discretionary access control list (DACL) that identifies the users and groups who are allowed or denied access to the specified security descriptor. Win:7.1
group of <security descriptor> | Plain | <security identifier> | Returns the security identifier of the group of the specified security descriptor. Win:4.1
owner of <security descriptor> | Plain | <security identifier> | Returns the security identifier of the owner of the specified security descriptor. Win:4.1
sacl of <security descriptor> | Plain | <system access control list> | Returns the system access control list (SACL), an ACL that controls the generation of audit messages for attempts to access a securable object. Win:7.1


Security Identifier

A Security Identifier, or SID, is a data structure that identifies user, group, and computer accounts. Every account on a network is issued a unique SID when the account is first created. Internal processes in Windows refer to an account's SID rather than the account's user or group name.

Creation Methods

Key Phrase | Form | Description
group of <security descriptor> | Plain | Returns the SID of the group of the specified security descriptor. Win:4.1
owner of <security descriptor> | Plain | Returns the security identifier of the owner of the specified security descriptor. Win:4.1
sid of <logged on user> | Plain | Returns the Security ID (SID) of the user associated with the session's primary access token. With Windows 2003/XP/Vista, this is determined by WTSQueryUserToken. With NT4/2000 it is determined by the apparent shell process running in the given session. This Inspector may fail if run in a non-privileged context. The SID does not exist under Windows 9x. Win:7.0
sid of <security account> | Plain | Returns the Security ID (SID) associated with the specified security account. Win:7.1
trustee of <access control entry> | Plain | Returns the trustee to whom the specified ACE applies. Win:4.1
user sid of <event log record> | Plain | Returns the user security ID for the specified record in the event log. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<security identifier> as string | Cast | <string> | Returns the security identifier in string format. Win:4.1
account name of <security identifier> | Plain | <string> | Retrieves the name of the account for this SID and the name of the first domain on which this SID is found. Win:4.1
component string of <security identifier> | Plain | <string> | This Windows-specific inspector returns a string formatted using the ConvertSidToStringSid windows API, discussed at: http://msdn2.microsoft.com/en-us/library/aa376399(VS.85).aspx. Win:7.0
domain name of <security identifier> | Plain | <string> | Returns the domain name of the first domain on which the specified SID is found. Win:4.1

Operators

Key phrase | Return Type | Description
<security identifier> = <security identifier> | <boolean> | Tests two <security identifier> (SID) values for equality using EqualSid. Win:7.0


Selected Server

These Inspectors return information about the BES Server or BES Relay to which the BigFix agent or client reports.

Creation Methods

Key Phrase | Form | Description
selected server | PlainGlobal | The BES Server or BES Relay to which the agent reports. Returned as the "selected server" type. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
competition size of <selected server> | Plain | <integer> | The number of servers in the competition from which this server was selected. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
competition weight of <selected server> | Plain | <integer> | The total of the weights of the servers in the competition from which this server was selected. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
distance of <selected server> | Plain | <integer range> | The distance, in IP gateway hops, to the server. Among servers with the same priority, closer servers are preferred. Returns an integer range, since the exact distance may not be known. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
gateway address <integer> of <selected server> | Numbered | <ipv4 address> | The ip address of a gateway between the agent and the selected server at the given distance from the agent, if known. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
gateway address of <selected server> | Plain | <ipv4 address> | All known ip addresses of gateways between the agent and the selected server. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
ip address of <selected server> | Plain | <ipv4 address> | The ip address to which reports are sent. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
name of <selected server> | Plain | <string> | The DNS name of the server, if known. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
port number of <selected server> | Plain | <integer> | The port number to which reports are sent. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
priority of <selected server> | Plain | <integer> | The priority assigned to the server by the BES console. Servers with low priorities are preferred to servers with high priority. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
weight of <selected server> | Plain | <integer> | The weight assigned to the server by the BES console. Servers with the same priority and approximate distance compete to be chosen; servers with higher weights are more likely to be chosen. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Service

These Inspectors provide access to all services configured on Windows NT, 2K and XP systems. On a non-Windows system, expressions using these objects will fail gracefully instead of generating an error.

Creation Methods

Key Phrase | Form | Description
main gather service | PlainGlobal | Returns FALSE. Included for compatibility with Windows Inspectors. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
relay service | PlainGlobal | Returns a service object for the relay component of BES. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
running service | PlainGlobal | Creates objects corresponding to all the running services. Win:1.2
running service <string> | NamedGlobal | Creates the running service object for the specified name. Win:1.2
service | PlainGlobal | Creates objects for all the services. Win:1.2
service <string> | NamedGlobal | Creates the service object matching the specified name, regardless of its running state. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0

Properties

Key Phrase | Form | Return Type | Description
<service> as string | Cast | <string> | Returns a string containing the Service name, Display name, and State of the service. Win:1.2
can interact with desktop of <service> | Plain | <boolean> | Indicates the system is configured to allow the service to interact with the desktop. Win:1.2
checkpoint of <service> | Plain | <integer> | Service specific value indicating its checkpoint state. Win:1.2
display name of <service> | Plain | <string> | Returns the display name of the service. Win:1.2
file of <service> | Plain | <file> | Returns a file object corresponding to the specified <service>. Win:3.0
image path of <service> | Plain | <string> | Returns the full path to the service executable. Win:6.0
login account of <service> | Plain | <string> | Returns the login account under which the service is configured to run. Win:1.2
security descriptor of <service> | Plain | <security descriptor> | This Windows-specific Inspector returns a security descriptor for the specified service. Win:7.0
service name of <service> | Plain | <string> | Returns the name of the service. Win:1.2
service specific exit code of <service> | Plain | <integer> | Service specific exit code. Win:1.2
start type of <service> | Plain | <string> | Returns a string that represents the service startup configuration. It describes when the driver is loaded, which can be one of: • boot: started by OS loader (usually these are needed to launch the OS). • system: started during OS initialization (used by PnP drivers that do device detection after the loader is done). • auto: started by the Service Control Manager (SCM). • demand: started on demand, either by PnP manager when a device is enumerated or by the SCM in response to user demand. • disabled: can't be started (used to temporarily disable driver services). Win:3.0
state of <service> | Plain | <string> | Returns one of Continuing, Pausing, Paused, Running, Starting, Stopping, Stopped, Unknown. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0
win32 exit code of <service> | Plain | <integer> | Service specific Win32 exit code. Win:1.2

Examples

running services
Returns a list of all the currently running services.

expand environment string of ( image path of service "AudioSrv”)
Returns a path name for the Windows Audio service, such as C:\WINDOWS\System32\svchost.exe -k netsvcs.


Setting

A setting is a simple object with name and value properties. It is a property of a client, or a property of a site. Settings of a site are assigned by site authors. Settings of the client are assigned by the BES console operator.

Creation Methods

Key Phrase | Form | Description
administrator <string> of <client> | Named | Creates a setting with the given name on the given <client> computer. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
administrator of <client> | Plain | Creates a setting object consisting of the administrator for the given <client> computer. Win:3.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:6.0
setting <string> of <client> | Named | Returns the setting whose name matches the string provided from the client settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
setting <string> of <site> | Named | Returns the setting whose name matches the string provided from the site settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
setting of <client> | Plain | Returns one or more settings from the client settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
setting of <site> | Plain | Returns one or more settings from the site settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<setting> as string | Cast | <string> | Returns a string formatted as <name>=<value> for the setting. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
effective date of <setting> | Plain | <time> | Returns the date when the setting was last modified. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
enabled of <setting> | Plain | <boolean> | Returns TRUE if the specified setting is enabled. Win:7.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:6.0, Mac:4.1
name of <setting> | Plain | <string> | Returns the name of the setting. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
value of <setting> | Plain | <string> | Returns the value of the setting. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Examples

names of settings of site "actionsite"
Returns the names of all the settings of the site named "actionsite".


Site

A Site object is provided to access properties of Fixlet sites.

Creation Methods

Key Phrase | Form | Description
current site | PlainGlobal | Creates the site object corresponding to the site that provided the current Fixlet. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site | PlainGlobal | Iterates through all the sites. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site <string> | NamedGlobal | Creates the site object that corresponds to the name provided. The name is interpreted as a site locator and is therefore a URL. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
client folder of <site> | Plain | <folder> | The folder containing the site content on the client machine. Site content is gathered into this location. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
fixlet of <site> | Plain | <fixlet> | Iterates through the Fixlet messages of the specified site. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
gather schedule authority of <site> | Plain | <string> | Returns a string corresponding to the authority of the site schedule, e.g.: Publisher, Custom, Manual or Disabled. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
gather schedule time interval of <site> | Plain | <time interval> | Returns the time interval between automatic gathering of site content. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
group <integer> of <site> | Numbered | <site group> | Returns an object corresponding to the numbered group of the specified site. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
last gather time of <site> | Plain | <time> | Returns the time of last successful gathering from the site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
masthead of <site> | Plain | <file> | Each site has a masthead, and the masthead is saved into the site data folder upon successful creation. This property returns a file object that corresponds to the copy in the site data folder. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
name of <site> | Plain | <string> | The name of the site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
relevant fixlet of <site> | Plain | <fixlet> | Iterates through the Relevant Fixlet messages for the specified site. Win:5.0, Lin:5.0, Sol:5.0, HPUX:5.0, AIX:5.0, Mac:6.0
setting <string> of <site> | Named | <setting> | Returns the setting whose name matches the string provided from the Fixlet site settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
setting of <site> | Plain | <setting> | Returns one or more settings from the site settings. Win:2.0, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
site tag of <site> | Plain | <string> | Returns the last component of the specified site's url, eg. ‘actionsite’, ‘enteprisesecurity’, etc. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
site version list of <site> | Plain | <site version list> | Returns the last gathered site version list (manyversion) of the specified site. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
subscribe time of <site> | Plain | <time> | Returns the time that the current machine began subscribing to the site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
type of <site> | Plain | <string> | Returns one of the following 4 literal strings: • Master Action Site • Operator Site • Custom Site • Fixlet Site. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
url of <site> | Plain | <string> | Returns the Locator found in the masthead. A site locator is used to synchronize with the site. It normally contains the URL of a remote file system folder, or the URL of a cgi-bin program that provides a remote directory listing of the site. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
version of <site> | Plain | <integer> | Returns the version number of the site content. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

The 'as string' property yields a string formatted with the site name.

Examples

exists site "actionsite"
TRUE when the action site exists on the target machine.

exists file "siteicon.bmp" of client folder of current site
TRUE if the specified file exists in the client folder.

last gather time of current site > now - 30 * day
Return TRUE if it has been over 30 days since last gathering, or synchronizing, with the site.

last gather time of current site < time "4 Aug 1997 01:00 pdt"
Returns TRUE if the site was last synchronized before the specified date.

modification time of masthead of current site < time "4 Aug 1997 01:00 pdt"
Returns TRUE if the masthead of the current site is older than the specified date.


Site Group

These Inspectors return information on the automatic groups defined for a given site.

Creation Methods

Key Phrase | Form | Description
group <integer> of <site> | Numbered | Returns an object corresponding to the numbered group of the specified site. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
id of <site group> | Plain | <integer> | Returns the numeric ID of the specified site group. This is the number assigned to an automatic group when it is first defined. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
member of <site group> | Plain | <boolean> | Returns TRUE if the current computer is a member of the specified group. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Site Version List

These Inspectors examine the multidimensional version numbers (ManyVersions) that are used by the Database to reconcile reconnected sites after a DSA failback event.

Creation Methods

Key Phrase | Form | Description
<string> as site version list | Cast | Converts a string into a site version list. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
maximum of <site version list> | Plain | Returns the maximum value from a list of <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <site version list> | Plain | Returns the minimum value from a list of <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
site version list <string> | NamedGlobal | Returns a textual representation of a site version list ("manyversion"). Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
site version list of <site> | Plain | Returns the last gathered site version list (manyversion) of the specified site. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<site version list> as string | Cast | <string> | Converts a site version list to a string. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
component <integer> of <site version list> | Numbered | <integer> | Returns the nth element (as specified by <integer>) of the given site version list. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
extrema of <site version list> | Plain | <( site version list, site version list )> | Returns the minimum and maximum extreme values of the given list of <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <site version list> | Plain | <site version list> | Returns the maximum value from a list of <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <site version list> | Plain | <site version list> | Returns the minimum value from a list of <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <site version list> | Plain | <site version list with multiplicity> | Returns the unique values of a given list of <site version list> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<site version list> {cmp} <site version list> | <boolean> | Compares two site version lists, component by component, where {cmp} is one of: <, <=, =. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Site Version List with Multiplicity

These Inspectors deal with site-version-list arrays, allowing you to pluck out unique site-version-list values and count them. These objects are derived from ordinary site-version-list types.

Creation Methods

Key Phrase | Form | Description
unique value of <site version list> | Plain | Returns the unique values of a given list of <site version list> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <site version list with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <site version list> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Software_depot

Software depot uses the swlist INDEX to identify the collection of products installed on the machine.

Creation Methods

Key Phrase | Form | Description
software depot | PlainGlobal | Accesses the set of installed software and products. HPUX:4.0

Properties

Key Phrase | Form | Return Type | Description
bundle <string> of <software_depot> | Named | <bundle> | Returns the bundle object corresponding to the name provided. Useful for seeing if a bundle is installed. HPUX:4.1
bundle of <software_depot> | Plain | <bundle> | Returns a bundle object. Use the plural expression 'bundles of software depot' to return all of the bundles installed. HPUX:4.1
product <string> of <software_depot> | Named | <product> | Returns a descriptive string that identifies the CPU. HPUX:4.0
product of <software_depot> | Plain | <product> | Direct access to specified installed software product. Use the product tag as the identifying name. HPUX:4.0

Examples

exists software depot
Returns TRUE if the software depot exists on this computer.

model of main processor
Returns a string such as "PA8500".

exists product "OS-Core" of software depot
Returns TRUE if the specified software exists.


Sound Volume

These Inspectors are for inspecting the sound volume settings.

Creation Methods

Key Phrase | Form | Description
full volume | PlainGlobal | The maximum possible sound volume. Mac:4.1
zero volume | PlainGlobal | The quietest sound volume. Mac:4.1

Operators

Key phrase | Return Type | Description
<sound volume> {cmp} <sound volume> | <boolean> | Compares two sound volumes, where: • {cmp} is one of: =, <, <=. Mac:4.1
<sound volume> {cmp} <stereo volume> | <boolean> | Compares a sound and a stereo volume, where: • {cmp} is one of: =, <, <=. Mac:4.1
<sound volume> {op} <integer> | <sound volume> | Operates on a sound volume and an integer, returning a sound volume, where: • {op} is one of: *, /. Mac:4.1
<sound volume> {op} <sound volume> | <sound volume> | Operates on two sound volumes, returning another sound volume, where: • {op} is one of: +, -. Mac:4.1
<sound volume> {op} <stereo volume> | <stereo volume> | Operates on a sound volume and a stereo volume, returning a stereo volume, where: • {op} is one of: +, -. Mac:4.1
<stereo volume> {cmp} <sound volume> | <boolean> | Compares a stereo and a sound volume, where: • {cmp} is one of: =, <, <=. Mac:4.1
<stereo volume> {op} <sound volume> | <stereo volume> | Operates on a stereo volume and a sound volume, returning a stereo volume, where: • {op} is one of: +, -. Mac:4.1
<stereo volume> {op} <stereo volume> | <stereo volume> | Operates on two stereo volumes, returning another stereo volume, where: • {op} is one of: +, -. Mac:4.1

Examples

number of zero volume
Returns a number corresponding to the lowest possible sound volume.


Stage

These are for inspecting the stage portion of version numbers, which is the penultimate section of a version string: Major.Minor.ReleaseStageBuild.

Creation Methods

Properties

Key Phrase | Form | Return Type | Description
<stage> as string | Cast | <string> | A Macintosh version is of the form: Major.Minor.ReleaseStageBuild. The stage directly precedes the final (Build) number. Most versioning schemes use a period, but the Mac allows for d, a, b and f standing for Development , Alpha, Beta and Final. The period has a higher value than Final. The stage is used in version comparisons and is ranked higher than the build number. For instance, 7.1.2a43 is less than 7.1.2f42 because a is lower than f, even though the final number is bigger. Mac:7.1

Operators

Examples

stage of version “7.1.2b70”
Returns b.


Stereo Volume

These Inspectors are for inspecting the stereo volume settings.

Creation Methods

Key Phrase | Form | Description
default sound volume | PlainGlobal | The default sound volume. Mac:4.1
system beep volume | PlainGlobal | The system beep volume. Mac:4.1

Operators

Key phrase | Return Type | Description
<stereo volume> {cmp} <stereo volume> | <boolean> | Compares two stereo volumes, where: • {cmp} is one of: =, <, <=. Mac:4.1
<stereo volume> {op} <integer> | <stereo volume> | Operates on a stereo volume and an integer, returning a stereo volume, where: • {op} is one of: *, /. Mac:4.1

Examples

number of system beep volume
Returns the system beep volume.


String

A string literal is written within double quotes. Special characters must be inserted by using the percent sign followed by 2 hex digits. Special characters include those characters with ASCII codes less than the 'space' character (hex 20) or greater than 'tilde' character (hex 7f) as well as the percent character itself (25 hex). For example, to create a string containing a null character and a percent character use "a null is %00, the percent itself is %25". Conversion to upper and lower case is also provided. String works in combination with the string position and substring data types. A string position is a point within a string. It can be compared to an integer, but it also acts as a pointer within a string so that the preceding and following text can be extracted. A substring is a part of a larger string. All operations allowed on a string can be performed on a substring. There are two substrings "be" in the string "To be or not to be". The substrings only differ in their positions within the string.

Creation Methods

These string creation methods are in addition to the other properties that return the string type.

Key Phrase | Form | Description
<boolean> as string | Cast | Operates on a boolean to return a string. Possible values are "True" and "False". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<date> as string | Cast | Cast a date type as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<floating point> as scientific notation | Cast | Converts a floating point number into a string with scientific notation. Win:4.1, Mac:4.1
<floating point> as standard notation | Cast | Converts a floating point number into a string with standard notation. Win:4.1, Mac:4.1
<floating point> as string | Cast | Converts a floating point number into a string with standard notation. Win:4.1, Mac:4.1
<hertz> as string | Cast | Creates a string containing the number of hertz and the word hertz, e.g., (3 * hz) as string = "3 hertz". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<integer> as hexadecimal | Cast | Converts an integer into a hexadecimal string. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
<integer> as string | Cast | Creates a string formatted with the integer provided. (-22) as string = "-22". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as hexadecimal | Cast | Converts a string to a hexadecimal number. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
<string> as left trimmed string | Cast | Trims the leading spaces from a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as lowercase | Cast | Creates a lowercase version of the string provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as right trimmed string | Cast | Trims the trailing spaces from a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as string | Cast | Reflexive cast of string to string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as trimmed string | Cast | Trims the leading and trailing spaces off of the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as uppercase | Cast | Creates an uppercase version of the string provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time interval> as string | Cast | Returns a string formatted as • ddd days, HH:MM:SS.mmmmmm • For example, millisecond as string = " 00:00:00.001". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time zone> as string | Cast | Creates a string containing a time zone. See <time zone>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> as local string | Cast | Creates a string containing a time. See <time>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> as string | Cast | Creates a string containing a time. See <time>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> as universal string | Cast | Creates a string containing a time. See <time>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
character <integer> | NumberedGlobal | Creates a string containing the single ASCII character for the decimal number provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
concatenation <string> of <string> | Named | This inspector concatenates the string items in the second argument with a separator defined by the string argument. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
concatenation of <string> | Plain | Combines the supplied strings into a single string, end-to-end. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
download path <string> | NamedGlobal | This inspector is available in relevance subsitution action processing. It returns a string corresponding to the download path of the specified file. This Inspector (along with download folder and download file) is designed to be used during the prefetch process of action execution. This is equivalent to '(pathname of download folder) & pathseparator & "myfile"'. Win:7.2, Lin:7.2, Sol:7.2, HPUX:7.2, AIX:7.2, Mac:7.2
hexadecimal string <string> | NamedGlobal | Creates a string from the given hexadecimal value. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
machine name | PlainGlobal | Returns the machine name. The value is from a long enumeration of all Mac platforms. See the header file Gestalt.h or Apple's. Mac:4.1
parameter <string> | NamedGlobal | This Inspector is a synonym for the parameter <string> of <action>. It looks up the value of the action parameter specified by <string>. This is used in conjunction with the parameter set command. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
string <string> | NamedGlobal | Creates a string matching the name provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
two digit hour of <time of day with time zone> | Plain | Returns the hour of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
two digit minute of <time of day with time zone> | Plain | Returns the minute of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
two digit second of <time of day with time zone> | Plain | Returns the second of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
wake on lan subnet cidr string | PlainGlobal | Returns the subnet the client is in for Wake on Lan (WoL) purposes. The client sends information to the relay during registration that is used to decide which subnet the client is in. The relay returns the subnet to the client, which is the value this Inspector exposes. This value is used to send WoL commands to forwarders. To wake a machine by computer ID, the server looks up the mac address and subnet of that machine. It then tries to identify clients that have been configured as WoL forwarders within the same subnet and routes WoL commands to those forwarders, sending them the mac address of the machine that needs to be awoken. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<string> as boolean | Cast | <boolean> | Returns a boolean value for the string. All possible capitalization's of "TRUE" and "FALSE" will convert successfully. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as date | Cast | <date> | Casts a string as a date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as day_of_month | Cast | <day of month> | Casts a string as a day of the month (eg. 28). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as day_of_week | Cast | <day of week> | Casts a string as a day of the week. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as floating point | Cast | <floating point> | Converts the contents of a string into a floating point number. Win:4.1, Mac:4.1
<string> as hexadecimal | Cast | <string> | Converts a string to a hexadecimal number. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:5.1
<string> as html | Cast | <html> | Casts a string into html. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as integer | Cast | <integer> | Returns an integer value for the string provided. If the string contains anything but ASCII digits, the conversion will fail. Use numeric value for more liberal parsing rules. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as ipv6 address | Cast | <ipv6 address> | Converts a string representations of an IPv6 address (with colons and/or dots) as an IPv6 address type. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<string> as left trimmed string | Cast | <string> | Trims the leading spaces from a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as local time | Cast | <time> | Returns a local time object from a properly formatted string. See <time>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as local zoned time_of_day | Cast | <time of day with time zone> | Converts a string to a time of day with local time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as lowercase | Cast | <string> | Returns a lowercase version of the string provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as month | Cast | <month> | Converts a string into a month. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as right trimmed string | Cast | <string> | Trims the trailing spaces from a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as site version list | Cast | <site version list> | Converts a string into a site version list. Win:7.0, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.0, Mac:7.1
<string> as string | Cast | <string> | Returns the string provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as time | Cast | <time> | Returns a time object from a properly formatted string. See <time>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as time interval | Cast | <time interval> | Returns a time interval object from a properly formatted string. Expects strings formatted as • ddd days, HH:MM:SS.mmmmmm. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as time zone | Cast | <time zone> | Returns a time zone object from a properly formatted string. See <time zone>. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as time_of_day | Cast | <time of day> | Converts a string to a time_of_day type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as trimmed string | Cast | <string> | Trims the leading and trailing spaces off of the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as universal time | Cast | <time> | Returns a universal time object from a properly formatted string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as universal zoned time_of_day | Cast | <time of day with time zone> | Converts a string into a universal zoned time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as uppercase | Cast | <string> | Returns an uppercase version of the string provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as version | Cast | <version> | Returns a version if the string can be parsed as a version. The first numeric set of characters delimited with period, comma or comma-space is returned. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
<string> as windows display time | Cast | <time> | Returns a Windows display time object from a properly formatted string. See <Time>. Win:1.2
<string> as year | Cast | <year> | Converts a string into a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as zoned time_of_day | Cast | <time of day with time zone> | Converts a string into a zoned time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
abbr <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <abbr> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
abbr of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <abbr> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
acronym <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <acronym> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
acronym of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <acronym> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
address <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <address> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
address of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <address> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
anchor <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <a> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
anchor of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <a> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
b <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <b> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
b of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <b> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
base <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <base> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
base of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <base> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
big <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <big> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
big of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <big> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
blockquote <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <blockquote> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
blockquote of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <blockquote> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
body <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <body> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
body of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <body> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
caption <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <caption> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
caption of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <caption> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
character <integer> of <string> | Numbered | <substring> | Returns a string of length 1 made by taking the character identified by <integer> from the string. Numbering begins at zero. Example, Character 1 of "HI" is "I". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
character of <string> | Plain | <substring> | Returns the characters from the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
cite <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <cite> (citation) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
cite of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <cite> (citation) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
code <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <code> (fixed-width font) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
code of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <code> (fixed-width font) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
col <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <col> (column) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
col of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <col> (column) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
colgroup <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <colgroup> (column group) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
colgroup of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <colgroup> (column group) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
concatenation <html> of <string> | Index<html> | <html> | This inspector concatenates the string items in the second argument with a separator defined by the first argument. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
concatenation <string> of <string> | Named | <string> | This inspector concatenates the string items in the second argument with a separator defined by the string argument. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
concatenation of <string> | Plain | <string> | Combines the supplied strings into a single string, end-to-end. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
dd <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <dd> (definition) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
dd of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <dd> (definition) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
definition list <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <dl> (definition) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
definition list of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <dl> (definition) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
del <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <del> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
del of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <del> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
dfn <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <dfn> (definition) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
dfn of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <dfn> (definition) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
div <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <div> (division or section) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
div of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <div> (division or section) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
dt <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <dt> (definition) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
dt of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <dt> (definition) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
em <string> of <string> | Named | <html> | Emphasize the specified string inside an <em string></em> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
em of <string> | Plain | <html> | Emphasize the specified string inside an <em></em> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
escape of <string> | Plain | <string> | Returns a string containing a \\ for every \ character found. Useful for setting registry key values to strings in regset action commands. Win:1.2
expand environment string of <string> | Plain | <string> | Uses the Windows ExpandEnvironmentStrings API to translate a string containing special Windows environment variables. For example, %windir%\my.dll might expand to c:\winnt\my.dll. Win:1.2
first <integer> of <string> | Numbered | <substring> | Returns a substring containing the number of characters specified from the given string. For example, First 5 of "To be or not to be" is "To be". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
first <string> of <string> | Named | <substring> | Returns a substring containing the first occurrence of the name provided. See substring. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
h1 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h1> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h1 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h1> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h2 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h2> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h2 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h2> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h3 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h3> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h3 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h3> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h4 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h4> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h4 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h4> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h5 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h5> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h5 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h5> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h6 <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <h6> (header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
h6 of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <h6> (header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
head <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <head> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
head of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <head> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <html> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <html> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
html tag <string> of <string> | Named | <html> | Returns an HTML snippet with the second string enclosed in a tag specified by the first string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ins <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <ins> (insert) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ins of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <ins> (insert) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
italic <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <i> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
italic of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <i> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
kbd <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <kbd> (keyboard entry) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
kbd of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <kbd> (keyboard entry) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
last <integer> of <string> | Numbered | <substring> | Returns a substring containing the number of characters specified. For example, Last 5 of "To be or not to be" is "to be". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
last <string> of <string> | Named | <substring> | Returns a substring containing the last occurrence of the name provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
length of <string> | Plain | <integer> | Returns the number of characters in the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
li <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <li> (list) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
li of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <li> (list) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
link <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <link> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
link of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <link> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
meta <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <meta> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
meta of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <meta> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
numeric value of <string> | Plain | <integer> | Returns an integer for the first numeric value in the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
ol <string> of <string> | Named | <html> | Creates an ordered list out of <string2> with an optional style specified by <string1>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ol of <string> | Plain | <html> | Creates an ordered list out of the <string>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ordered list <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <ol><li> tag, where the <ol> tag is modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ordered list of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <ol><li> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
p <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <p> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
p of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <p> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
position <integer> of <string> | Numbered | <string position> | Returns a string position pointing to the character position specified. The first character is at position 0. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
position of <string> | Plain | <string position> | Returns the positions of the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
pre <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in an <pre> (preformatted) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
pre of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in an <pre> (preformatted) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
q <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <q> (quotation) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
q of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <q> (quotation) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
samp <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <samp> (sample) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
samp of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <samp> (sample) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
set of <string> | Plain | <string set> | Creates a set from the given list of semicolon-separated strings. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
small <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <small> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
small of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <small> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
span <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <span> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
span of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <span> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
strong <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <strong> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
strong of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <strong> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
sub <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <sub> (subscript) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
sub of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <sub> (subscript) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
substring <string> of <string> | Named | <substring> | Iterates through the string returning all the substrings matching the name given. For example, number of substrings "be" of "to be or not to be" = 2. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
substring after <string> of <string> | Named | <substring> | Returns the substrings that come after the first string delimiter. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring before <string> of <string> | Named | <substring> | Returns the substrings that come before the first string delimiter. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring between <string> of <string> | Named | <substring> | Returns the substring in the second string found between two instances of the first string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring separated by <string> of <string> | Named | <substring> | Returns a substring (or set of substrings) delimited by the first string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
sup <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <sup> (superscript) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
sup of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <sup> (superscript) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
table <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <table> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
table of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <table> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tbody <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <tbody> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tbody of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <tbody> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
td <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <td> (table cell) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
td of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <td> (table cell) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tfoot <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <tfoot> (table foot) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tfoot of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <tfoot> (table foot) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
th <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <th> (table header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
th of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <th> (table header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
thead <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <thead> (table header) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
thead of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <thead> (table header) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
title <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <title> tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
title of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <title> tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tr <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <tr> (table row) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tr of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <tr> (table row) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tt <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <tt> (teletype font) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
tt of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <tt> (teletype font) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ul <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <ul> (unordered list) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
ul of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <ul> (unordered list) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <string> | Plain | <string with multiplicity> | Returns the unique values of a given list of <string> types, removing duplicates and sorting by value. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
unordered list <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <ul><li> (unordered list item) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unordered list of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <ul><li> (unordered list item) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
var <string> of <string> | Named | <html> | Returns an HTML snippet with the specified string enclosed in a <var> (variable type) tag modified by the first given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
var of <string> | Plain | <html> | Returns an HTML snippet containing the specified string enclosed in a <var> (variable type) tag. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<html> & <string> | <html> | Concatenates a string with an HTML file, returning a new HTML file. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<rope> & <string> | <rope> | Concatenates a rope and a string, producing a rope. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<rope> contains <string> | <boolean> | Returns boolean TRUE if the rope contains the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string set> contains <string> | <boolean> | Returns TRUE if the specified set of strings contains the given string. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string> & <html> | <html> | Concatenates a string with an HTML file, returning a new HTML file. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> & <rope> | <rope> | Concatenates a rope and a string, returning a new rope. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> & <string> | <string> | Concatenates two strings, producing a new string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> {cmp} <string> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

Many Inspectors return string values from the operating system using a variety of APIs. For the most part, these strings are encoded as single-byte character sets (SBCSs) or multi-byte character sets (MBCSs) depending on the active code page. You can use the code page Inspectors to determine which page is currently active on the client.

Examples

floating point "600987.9" as scientific notation
Returns 6.009879e+5.

floating point "6.009e8" as standard notation
Returns 600900000.

255 as hexadecimal
Returns the string "ff".

concatenation of "light" & "year"
Returns "lightyear".

wait "{download path"update.exe"}"
In an Action script, this line causes the BES Client to perform relevance substitution to compute the full path to the downloaded file (previously collected by a download command in the same Action script). After relevance substitution, the Client launches the specified executable and waits for it to complete before moving on to other Action lines.

4.5 as floating point
Returns 4.5.

exists character whose (it is "z") of "Paul Cezanne"
Returns True.

concatenation "/" of ("a" ; "b" ; "c" )
Returns "a/b/c".

html tag "i" of "italic string"
Returns <i>italic string</i>.

preceding text of last "ab" of "abracadabra" is "abracad"
Returns True.

substrings after ":" of "definition: after the colon"
Returns " after the colon".

substrings before "<--" of "the item pointed to <--"
Returns "the item pointed to".

substrings between "*" of "the item *between* asterisks"
Returns "between".

substrings separated by "," of "1,2,3"
Returns the list of numbers separated by commas in the specified string.

multiplicities of unique values of ("steak"; "chop"; "rib"; "rib"; "rib")
Returns the multiplicity of (the number of times) each string in the list is used, namely, 1,3,1.
• Note that the multiplicities are based on the alphabetic order of the strings (chop, rib, steak), not their position in the list.

set of ("foo";"bar") contains "foo"
Returns TRUE.


String Position

String position works in combination with the string and substring data types. A string position is a point within a string. It can be compared to an integer (which it is derived from), but it also acts as a pointer within a string so that the preceding and following text can be extracted. A substring (a part of a larger string) is derived from a string object.

Creation Methods

Key Phrase | Form | Description
end of <substring> | Plain | Creates an object corresponding to the position in the string of the end of the substring. For example, end of first "be" of "To be or not to be" = 5. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
position <integer> of <string> | Numbered | Creates an index (zero based) into the string. For example, position 5 of "to be or not to be" = 5. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
position of <string> | Plain | Iterates through the string returning values for all possible positions within it. For example, number of positions of "hi" = 3. Note that the positions being counted here are 0, 1, and 2. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
start of <substring> | Plain | Creates the position of the substring within its containing string. For example, Start of substring "or" of "to be or not to be" = 6. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
following text of <string position> | Plain | <substring> | Returns the substring following the position in the string. For example, following text of position 5 of "0123456789" = "567890". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
preceding text of <string position> | Plain | <substring> | Returns the substring preceding the position in the string. For example, preceding text of position 5 of "0123456789" = "01234". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

String positions can be compared and combined with integers using the same operations that are available for integers.

Examples

preceding text of position 5 of "Four score and seven.."
Returns "Four".


String Set

These Inspectors deal with sets of strings, which are essentially lists or arrays with string elements. Think of them as mathematical sets: you can compare them, subtract them from other sets and form the union and intersection of multiple sets.
• Note: These Inspectors are not available on SUSE Linux systems.

Creation Methods

Key Phrase | Form | Description
union of <string set> | Plain | Returns a set of strings equal to the union of the specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
element of <string set> | Plain | <string> | Returns the unique elements of the specified <string set>, removing duplicates and sorting by value. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
intersection of <string set> | Plain | <string set> | Returns a set of strings equal to the intersection of the specified sets, aphabetized and with redundant elements stripped out. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
size of <string set> | Plain | <integer> | Returns the number of unique elements in the specified set. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
union of <string set> | Plain | <string set> | Returns a set of strings equal to the union of the specified sets, alphabetized and with redundant elements stripped out. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<string set> - <string set> | <string set> | Subtracts the elements in the second set from the elements in the first. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string set> * <string set> | <string set> | Returns the intersection of the specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string set> + <string set> | <string set> | Returns the union of the specified sets. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string set> = <string set> | <boolean> | Returns TRUE if the specified sets have identical contents. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string set> contains <string set> | <boolean> | Returns TRUE if the first set contains all the elements of the second set. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
<string set> contains <string> | <boolean> | Returns TRUE if the specified set of strings contains the given string. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1

Examples

elements of union of (set of ("to";"be"); set of ("or";"not";"to";"be"))
Returns the list: be,not,or,to.

elements of set of ("beta";"beta";"alpha";"gamma";"beta")
Returns the strings alpha, beta, gamma.

elements of intersection of (set of ("to";"be"); set of ("or";"not";"to";"be"))
Returns the list: be,to.

size of set of ("to";"be"; "or"; "not"; "to"; "be")
Returns 4, the number of unique strings in the set.

elements of union of (set of ("to";"be"); set of ("or";"not";"to";"be"))
Returns the list: be,not,or,to.

elements of (set of ("to";"be";"or") - set of ("not";"to";"be"))
Returns or.

elements of (set of ("fee";"fie";"foe") - set of ("fee") - set of("foe"))
Return "fie.".

elements of (set of ("to";"be";"or") * set of ("not";"to";"be"))
Returns the list: be,to.

elements of (set of ("lime";"pie") * set of ("pie";"face") * set of("pie";"in";"sky"))
Returns "pie.".

elements of (set of ("to";"be";"or") + set of ("not";"to";"be"))
Returns the list: be,not,or,to.

set of ("to";"be";"or";"not") contains set of ("to";"be")
Returns TRUE.

set of ("foo";"bar") contains "foo"
Returns TRUE.


String with Multiplicity

These Inspectors deal with arrays of strings, allowing you to pluck out unique strings and count them.

Creation Methods

Key Phrase | Form | Description
unique value of <string> | Plain | Given a list of strings, returns the count of each unique string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <string with multiplicity> | Plain | <integer> | Returns the multiplicity (quantity) of each element in a multiple string list. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Strverscmp Version

Uses the OS supplied strverscmp function, which may be useful for certain older-style version comparisons. For more information, see the man page for strverscmp.

Creation Methods

Key Phrase | Form | Description
<string> as strverscmp version | Cast | Converts a string to strverscmp version, which is compared to other versions using the OS supplied strverscmp function. Lin:4.1
strverscmp version <string> | NamedGlobal | Creates a strverscmp version, which is compared to other versions using the OS supplied strverscmp function. Lin:4.1

Operators

Key phrase | Return Type | Description
<string> {cmp} <strverscmp version> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison (based on the OS supplied strverscmp function), where: • {cmp} is one of: =, !=, <, <=, >, >= . Lin:4.1
<strverscmp version> {cmp} <strverscmp version> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison (based on the OS supplied strverscmp function), where: • {cmp} is one of: =, !=, <, <=, >, >= . Lin:4.1


Substring

A substring object is derived from a string object, so it has all the properties of a string. Substrings also have these additional properties:

Creation Methods

Key Phrase | Form | Description
character <integer> of <string> | Numbered | Creates the single character substring at the position given within the string. For example, character 2 of "abc" = "c". Note that numbering begins at zero. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
character of <string> | Plain | Iterates through the string (or substring) returning substrings that contain the individual characters of the string. For example, number of characters of string "abc" = 3. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
first <integer> of <string> | Numbered | Creates a substring for the given number of characters at the start of the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
first <string> of <string> | Named | Creates an object containing the first match of the given string. For example, first "be" of "to be or not to be" = "be". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
following text of <string position> | Plain | Creates an object containing the substring following the position in the string. For example, following text of position 5 of "0123456789" = "567890". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
following text of <substring> | Plain | Creates an object containing the string following the substring. For example, following text of last "." of "log.txt" = "txt". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
last <integer> of <string> | Numbered | Creates an object containing a substring from the last part of the string containing the number of characters specified. For example, Last 5 of "To be or not to be" is "to be". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
last <string> of <string> | Named | Creates a substring containing the last occurrence of the name provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
preceding text of <string position> | Plain | Creates the substring preceding the position in the string. For example, preceding text of position 5 of "0123456789" = "01234". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
preceding text of <substring> | Plain | Creates an object containing the string preceding the substring. For example, preceding text of last "." of "log.txt" = "log". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
substring <string> of <string> | Named | Iterates through the string returning all the substrings matching the name given. For example, number of substrings "be" of "to be or not to be" = 2. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
substring after <string> of <string> | Named | Returns the substrings that come after the first string delimiter. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring before <string> of <string> | Named | Returns the substrings that come before the first string delimiter. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring between <string> of <string> | Named | Returns the substring in the second string found between two instances of the first string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1
substring separated by <string> of <string> | Named | Returns a substring (or set of substrings) delimited by the first string. Win:5.1, Lin:5.1, Sol:5.1, HPUX:5.1, AIX:5.1, Mac:5.1

Properties

Key Phrase | Form | Return Type | Description
end of <substring> | Plain | <string position> | Returns the position of the substring within its containing string. For example, end of first "be" of "to be or not to be" = 5. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
following text of <substring> | Plain | <substring> | Returns the string following the substring. For example, following text of last "." of "log.txt" = "txt". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
preceding text of <substring> | Plain | <substring> | Returns the string preceding the substring. For example, preceding text of last "." of "log.txt" = "log". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
start of <substring> | Plain | <string position> | Returns the position within the string of the substring. For example, start of substring "or" of "to be or not to be" = 6. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

All the string operators can also be applied to substrings.

Examples

substrings after ":" of "definition: after the colon"
Returns " after the colon".

substrings before "<--" of "the item pointed to <--"
Returns "the item pointed to".

substrings between "*" of "the item *between* asterisks"
Returns "between".

substrings separated by "," of "1,2,3"
Returns the list of numbers separated by commas in the specified string.


Swap

This object lets you inspect the properties of your swap space.

Creation Methods

Key Phrase | Form | Description
swap | PlainGlobal | Creates an object containing information about the swap partition. Lin:3.1, HPUX:4.0, AIX:4.1

Properties

Key Phrase | Form | Return Type | Description
free amount of <swap> | Plain | <integer> | Returns the amount of the swap partition currently unused, in bytes. Lin:3.1, HPUX:4.0, AIX:4.1
size of <swap> | Plain | <integer> | Returns the size, in bytes, of the swap partition. Lin:3.1, HPUX:4.0, AIX:4.1
total amount of <swap> | Plain | <integer> | Same as size of <swap>. Lin:3.1, HPUX:4.0, AIX:4.1
used amount of <swap> | Plain | <integer> | Returns the amount of the swap partition currently in use, in bytes. Lin:3.1, HPUX:4.0, AIX:4.1


Symlink

Inspectors can analyze the file objects (files and folders) that symlinks point to by using the standard file Inspectors. The symlink Inspectors, on the other hand, allow you to analyze the properties of a symlink itself, not just the underlying file. There are many properties that symlinks have in common with files, such as name, pathname, parent folder, etc. In addition, a symlink has a value corresponding to the file object it points to. You can also determine if the file is available or not.

Creation Methods

Key Phrase | Form | Description
<filesystem object> as symlink | Cast | Casts a link in the form of a file into a symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
<symlink> as symlink | Cast | Casts a symlink, provided for completeness. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <filesystem object> | Index<filesystem object>Global | Creates a symlink from the specified filesystem object. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <string> | NamedGlobal | Creates a symlink from the specified string. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <string> of <folder> | Named | Returns the named symlink from the specified folder. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink <symlink> | Index<symlink>Global | Creates a symlink from the specified symlink path, even if the symlink is broken. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
symlink of <folder> | Plain | Returns the symlink(s) in the specified folder, whether or not they are broken. • NOTE: This behavior differs from looking for files in a folder. Although that returns links along with the files, it doesn't return broken links. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
<symlink> as file | Cast | <file> | Converts a symlink object into the file it points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
<symlink> as folder | Cast | <folder> | Converts a symlink object into the folder it points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
<symlink> as string | Cast | <string> | Casts a symlink object as a string. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
<symlink> as symlink | Cast | <symlink> | Casts a symlink, provided for completeness. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
accessed time of <symlink> | Plain | <time> | Returns the last accessed time of the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
ancestor of <symlink> | Plain | <folder> | Returns all ancestor folders (recursive parent folders) of the given symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
change time of <symlink> | Plain | <time> | Returns the last time the specified symlink was ‘changed’ by either writing it or setting its inode information. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
drive of <symlink> | Plain | <filesystem> | Returns the drive associated with the specified symlink as a <filesystem> object. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
filesystem of <symlink> | Plain | <filesystem> | Returns the filesystem on which the symlink resides. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
gid of <symlink> | Plain | <integer> | Returns the group ID of the given symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
group name of <symlink> | Plain | <string> | Returns the group name of the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
link count of <symlink> | Plain | <integer> | Returns an integer corresponding to the number of hard links attached to the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
location of <symlink> | Plain | <string> | Returns a string corresponding to the directory in which the symlink is located. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
modification time of <symlink> | Plain | <time> | Returns the time corresponding to the modification time of the specified symlink, not the file it points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
name of <symlink> | Plain | <string> | Returns a string that is the full path name of the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
parent folder of <symlink> | Plain | <folder> | Creates a folder object corresponding to the parent folder of the given symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
pathname of <symlink> | Plain | <string> | Returns a string that contains the full path name of the specified symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
uid of <symlink> | Plain | <integer> | The user ID of the user who owns this symlink. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
user name of <symlink> | Plain | <string> | Returns the symlink owner's (user's) name. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
value accessible of <symlink> | Plain | <boolean> | Returns TRUE if the pathname pointed to by the specified symlink is available. Returns FALSE if the file object is missing or unavailable with the current permissions. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0
value of <symlink> | Plain | <string> | Returns the pathname that the symlink points to. Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0

Examples

file "/example/link" as symlink
Returns the link (in file format) as a symlink object ("/example/link").

symlinks of folder "/example"
Returns a list of the symlink in the specified folder, whether or not they are broken. Note that this behavior is different from looking for files in a folder -- that will return links as well as files, but won't return broken links.

modification time of symlink "/example/link"
Returns the time corresponding to the modification time of the given symlink, not the file it points to.

modification time of file "/example/link"
Returns the time corresponding to the file object that the symlink is pointing to.


System Access Control List

These Inspectors retrieve information from the access control list that controls the generation of audit messages for attempts to access a securable object. The ability to get or set an object's SACL is controlled by a privilege typically held only by system administrators.

Creation Methods

Key Phrase | Form | Description
sacl of <security descriptor> | Plain | Returns the system access control list (SACL), an ACL that controls the generation of audit messages for attempts to access a securable object. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
<system access control list> as string | Cast | <string> | Converts the specified system access control list (SACL) into a string value in the Microsoft Security Descriptor String Format. Win:7.1


Time

A time object is used to identify a point in time. Time objects are used to represent important properties of objects such as the modification time of a file. You can create time objects from literal strings. The format of the string is defined by the MIME standard. The difference between two Time objects may be calculated by subtracting them and yields time intervals. Time intervals may be added or subtracted from time objects to obtain time objects.

Creation Methods

Key Phrase | Form | Description
<string> as local time | Cast | Local time creates a time object by parsing the string literal provided. The time zone is optional. If not present, the local time zone is assumed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as time | Cast | Parses the string. Time zone information must be provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as universal time | Cast | Parses the string. If time zone is not provided in the string, the universal time zone is assumed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<string> as windows display time | Cast | Parses the string. If time zone is not provided in the string, the current time zone in effect at the given time is assumed. Win:1.2
maximum of <time> | Plain | Returns the maximum time from a list of times. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
minimum of <time> | Plain | Returns the minimum time from a list of times. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
now | PlainGlobal | Creates an object for the current time. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time <string> | NamedGlobal | The time inspector creates a time object by parsing the string literal provided. The zone info is required. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
universal time <string> | NamedGlobal | The universal time inspector returns a time object by parsing the string literal provided. The time zone is optional. If not present, universal time is assumed. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
windows display time <string> | NamedGlobal | Creates an object for a string that may match the time shown in the Windows file system. Win:1.2

Properties

Key Phrase | Form | Return Type | Description
<time> as local string | Cast | <string> | Returns a string in MIME format of the given time object. The format is: ddd, DD mmm YYYY HH:MM:SS sZZZZ. The string is formatted using the local time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> as string | Cast | <string> | Same as above. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> as universal string | Cast | <string> | Returns a string in MIME format of the given time object. The format is: • ddd, DD mmm YYYY HH:MM:SS +0000 • The string is formatted using the universal time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
date <time zone> of <time> | Index<time zone> | <date> | Returns the date adjusted for the specified time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <time> | Plain | <( time, time )> | Returns the minimum and maximum extreme values of the given list of <time> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <time> | Plain | <time> | Returns the maximum time from a list of times. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
minimum of <time> | Plain | <time> | Returns the minimum time from a list of times. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
time <time zone> of <time> | Index<time zone> | <time of day with time zone> | Adjusts the specified time to the given time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <time> | Plain | <time with multiplicity> | Returns the unique values of a given list of <time> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<time interval> & <time> | <time range> | Concatenates a time interval with a time, returning a time range of the form time1 to time2. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time range> & <time> | <time range> | Concatenates a time with a time range, producing a new time range, in the form of: • <date> to <date>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time> & <time interval> | <time range> | Concatenates a time and a time interval, producing a time range object. Win:1.2, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time> & <time range> | <time range> | Concatenates a time and a time range, producing a new time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time> & <time> | <time range> | Concatenates two times into a time range, with the earliest date first and the latest date last. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time> {cmp} <time> | <boolean> | Returns a boolean TRUE/FALSE depending on the result of the comparison, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time> {op} <time interval> | <time> | Returns a <time> corresponding to the operator, where: • {op} is one of: +, -. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

The string format for a time object is given by the MIME standard. When output as a string, the format is:
ddd, DD mmm YYYY HH:MM:SS sZZZZ
where:

ddd | The day of the week. Abbreviations are Mon, Tue, Wed, Thu, Fri, Sat, Sun.
DD | The day of the month. A leading zero will be applied to make it two characters wide.
mmm | The Month. Abbreviations are Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec.
YYYY | The year.
HH | The hour of the day. It is always output at two digits. Possible values run from 0 to 23. The digits 00 are used to designate midnight.
MM | The minutes of the hour. It is always output as two digits. Possible values run from 0 to 59.
SS | The seconds of the minute.
s | A single character representing whether the time is east or west of Greenwich. The value of + means east of Greenwich while the value - means west of Greenwich.
ZZZZ | The number of minutes east or west of Greenwich.

To create a string from a literal, use the format:ddd,DD mmm YYYY HH:MM:SS zoneinfo
where:

ddd | The optional day of the week. Abbreviations are Mon, Tue, Wed, Thu, Fri, Sat, Sun. Case is not important in these names. If provided it must be correct. For example, time "Sat, 19 jun 1998 00:00:00 +0000" will fail since June 19, 1998 was a Friday.
DD | The day of the month. One or two digits are allowed.
mmm | The Month. Abbreviations are Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec. Case is not important.
YYYY | The year. A two, three or four digit year. If two digits are given a base of 1900 is assumed.
HH | The hour of the day. It is always input at two digits. Possible values run from 0 to 23. The digits 00 are used to designate midnight.
MM | The minutes of the hour. It is always output as two digits. Possible values run from 0 to 59.
SS | The seconds of the minute. Range from 0 to 59. This is optional. If seconds are not present, the preceding colon should also not be present
Zoneinfo | The time zone information. It is provided in one of these formats: Single character + or - followed by 4 digits. The 4 digits are interpreted as HHMM two digits of hours and two digits of minutes. Plus designates east of universal time while minus designates west of universal time. Three letters for the civilian name of the time zone. cdt, edt, mdt, pdt are the designations for central, eastern, mountain and pacific daylight savings time while cst, est, mst, pst are the designations for central, eastern, mountain and pacific standard time. gmt designates Greenwich mean time. A single letter military name of the time zone. Military time zones use single letters from a to z, excepting j. a-m represent offsets from universal time of -1 to -12 hours respectively. z represents 0 offset.

Examples

now
Returns the current time.


Time Interval

Time intervals are used in conjunction with the time object. Time intervals have a resolution of 1 microsecond.

Creation Methods

Key Phrase | Form | Description
<string> as time interval | Cast | Returns a time interval object from a properly formatted string. Expects strings formatted as • ddd days, HH:MM:SS.mmmmmm. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
absolute value of <time interval> | Plain | Creates the positive value of a time interval. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
day | PlainGlobal | Creates a time interval corresponding to 1 day. For example, 2 * day = 48 * hour. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
greatest time interval | PlainGlobal | Creates the largest time interval that can be represented on the current machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
hour | PlainGlobal | Creates a time interval corresponding to 1 hour. For example, day = 24 * hour. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
least time interval | PlainGlobal | Creates the largest negative time interval that can be represented on the current machine. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
maximum of <time interval> | Plain | Returns the maximum interval from a list of time intervals. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
microsecond | PlainGlobal | Creates a time interval corresponding to 1 microsecond. For example, 1000 * microsecond = 1 * millisecond. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
millisecond | PlainGlobal | Creates a time interval corresponding to 1 millisecond. For example, 1000 * millisecond = 1 * second. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
minimum of <time interval> | Plain | Returns the minimum interval from a list of time intervals. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
minute | PlainGlobal | Creates a time interval corresponding to 1 minute. For example, minute = 60 * second. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
second | PlainGlobal | Creates a time interval corresponding to 1 second. For example, 1000000 * microsecond = second. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time interval <string> | NamedGlobal | Creates a time interval from the string. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
week | PlainGlobal | Creates a time interval corresponding to 1 week. For example, 7*day = 1*week. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<time interval> as string | Cast | <string> | Returns a string formatted as • ddd days, HH:MM:SS.mmmmmm • For example, millisecond as string = " 00:00:00.001". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
absolute value of <time interval> | Plain | <time interval> | Returns positive value of the time interval. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
extrema of <time interval> | Plain | <( time interval, time interval )> | Returns the minimum and maximum extreme values of the given list of <time interval> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
maximum of <time interval> | Plain | <time interval> | Returns the maximum interval from a list of time intervals. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
minimum of <time interval> | Plain | <time interval> | Returns the minimum interval from a list of time intervals. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
unique value of <time interval> | Plain | <time interval with multiplicity> | Returns the unique values of a given list of <time interval> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
- <time interval> | <time interval> | The negative of a time interval. Win:2.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:5.1
<time interval> & <time> | <time range> | Concatenates a time interval with a time, returning a time range of the form time1 to time2. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time interval> {op} <integer> | <time interval> | Creates a time interval calculated as an integer operation on another time interval, where: • {op} is one of: *, / . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time interval> {op} <time interval> | <time interval> | Returns a calculated time interval, where: • {op} is one of: +, -, mod, / . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time interval> {op} <time zone> | <time interval> | Returns a calculated time interval, where: • {op} is one of: +, - . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<time interval> + <time of day with time zone> | <time of day with time zone> | Adds a time interval (days, hours, minutes, seconds) to a time of the day with time zone to create a new time of the day with time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time interval> + <time of day> | <time of day> | Adds a time interval (days, hours, minutes, seconds) to a time of the day to create a new time of the day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day with time zone> {op} <time interval> | <time of day with time zone> | Adds or subtracts a time interval and a specified 'time of day with time zone' object, where {op} is one of: -, +. Win:6.0
<time of day> {op} <time interval> | <time of day> | Adds or subtracts a time interval to provide a new time of day. Here {op} is one of: -, +. Win:6.0
<time> & <time interval> | <time range> | Concatenates a time and a time interval, producing a time range object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Time Interval with Multiplicity

These Inspectors deal with time-interval arrays, allowing you to pluck out unique time-interval values and count them. These objects are derived from ordinary time-interval types.

Creation Methods

Key Phrase | Form | Description
unique value of <time interval> | Plain | Returns the unique values of a given list of <time interval> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time interval with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time interval> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Time of Day

These Inspectors provide tools for dealing and calculating with time-of-day types, which are of the form HH:MM:SS, as in 12:59:59.

Creation Methods

Key Phrase | Form | Description
<string> as time_of_day | Cast | Converts a string to a time_of_day type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <time of day> | Plain | Returns the maximum value from a list of <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
midnight | PlainGlobal | Returns 00:00:00 as a time of day object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minimum of <time of day> | Plain | Returns the minimum value from a list of <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
noon | PlainGlobal | Returns 12:00:00 as a time of day object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
time of <time of day with time zone> | Plain | Returns the time of day, without the time zone information. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
time_of_day <string> | NamedGlobal | Creates a time of day object out of the given string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<time of day> as string | Cast | <string> | Casts the time of day as a string type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <time of day> | Plain | <( time of day, time of day )> | Returns the minimum and maximum extreme values of the given list of <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
hour_of_day of <time of day> | Plain | <integer> | Returns the hour section of the 'time of day' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <time of day> | Plain | <time of day> | Returns the maximum value from a list of <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <time of day> | Plain | <time of day> | Returns the minimum value from a list of <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minute_of_hour of <time of day> | Plain | <integer> | Returns the 'minutes after the hour' section of the 'time of day' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
second_of_minute of <time of day> | Plain | <integer> | Extracts the 'seconds after the minute' section of the 'tim of day' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
two digit hour of <time of day> | Plain | <string> | Extracts the 2-digit hour from the time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
two digit minute of <time of day> | Plain | <string> | Extracts the 2-digit minute from the time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
two digit second of <time of day> | Plain | <string> | Extracts the 2-digit second from the time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
unique value of <time of day> | Plain | <time of day with multiplicity> | Returns the unique values of a given list of <time of day> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<time of day> - <time of day> | <time interval> | Subtracts two times of day, returning a time interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day> & <time zone> | <time of day with time zone> | Concatenates a time of day with a time zone, returning a time of day with time zone type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day> {cmp} <time of day> | <boolean> | Compares two times of day, where {cmp} is one of: <, <=, =. Win:6.0
<time zone> & <time of day> | <time of day with time zone> | Concatenates a time of day with a time zone, returning a time of day with time zone type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Time of Day with Multiplicity

These Inspectors deal with time-of-day arrays, allowing you to pluck out unique time-of-day values and count them. These objects are derived from ordinary time-of-day types.

Creation Methods

Key Phrase | Form | Description
unique value of <time of day> | Plain | Returns the unique values of a given list of <time of day> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time of day with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time of day> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Time of Day with Time Zone

These Inspectors provide tools for dealing and calculating with time-of-day-with-time-zone types, which are of the form HH:MM:SS +ZZZZ, as in 12:59:59 -0400.

Creation Methods

Key Phrase | Form | Description
<string> as local zoned time_of_day | Cast | Converts a string to a time of day with local time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as universal zoned time_of_day | Cast | Converts a string into a universal zoned time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as zoned time_of_day | Cast | Converts a string into a zoned time of day. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current time_of_day | PlainGlobal | Returns the current time of day in the local time zone. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
current time_of_day <time zone> | Index<time zone>Global | Returns the current time of day in the specified time zone. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
time <time zone> of <time> | Index<time zone> | Converts the specified time to the given time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
zoned time_of_day <string> | NamedGlobal | Creates a 'zoned time of day' out of a string object in the form of HH:MM:SS +ZZZZ. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<time of day with time zone> as string | Cast | <string> | Converts a 'time of day with time zone' object into a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
hour_of_day of <time of day with time zone> | Plain | <integer> | Returns the hour section of the 'time of day with time zone' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
minute_of_hour of <time of day with time zone> | Plain | <integer> | Returns the 'minutes after the hour' section of the 'time of day with time zone' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
second_of_minute of <time of day with time zone> | Plain | <integer> | Returns the 'seconds after the minute' section of the 'time of day with time zone' object. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
time of <time of day with time zone> | Plain | <time of day> | Returns the time of day, without the time zone information. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
two digit hour of <time of day with time zone> | Plain | <string> | Returns the hour of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
two digit minute of <time of day with time zone> | Plain | <string> | Returns the minute of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
two digit second of <time of day with time zone> | Plain | <string> | Returns the second of the zoned time of day as text, with values less than 10 having a leading zero. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
unique value of <time of day with time zone> | Plain | <time of day with time zone with multiplicity> | Returns the unique values of a given list of <time of day with time zone> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
zone of <time of day with time zone> | Plain | <time zone> | Returns the zone associated with the specified time. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Operators

Key phrase | Return Type | Description
<date> & <time of day with time zone> | <time> | Concatenates a date with a time and a time zone for a complete time stamp. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day with time zone> - <time of day with time zone> | <time interval> | Subtracts two times of day (including time zones), returning a time interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day with time zone> & <time zone> | <time of day with time zone> | Concatenates a 'time of day with a time zone' and another time zone. The 'time of day with time zone' object that is produced is adjusted to fit the appended time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time of day with time zone> = <time of day with time zone> | <boolean> | Compares two times of day with time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time zone> & <time of day with time zone> | <time of day with time zone> | Converts a 'time of day with time zone' to the time in the specified time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1


Time of Day with Time Zone with Multiplicity

These Inspectors deal with time-of-day-with-time-zone arrays, allowing you to pluck out unique time-of-day-with-time-zone values and count them. These objects are derived from ordinary time-of-day-with-time-zone types.

Creation Methods

Key Phrase | Form | Description
unique value of <time of day with time zone> | Plain | Returns the unique values of a given list of <time of day with time zone> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time of day with time zone with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time of day with time zone> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Time Range

These Inspectors provide tools for dealing and calculating with time-range types, which are of the form <time> to <time>, such as Tue, 18 Apr 2006 16:46:07 -0400 to Wed, 19 Apr 2006 16:46:07 -0400

Creation Methods

Key Phrase | Form | Description
final part <time interval> of <time range> | Index<time interval> | Returns a time range with the specified interval, but ending on the final date of the time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
initial part <time interval> of <time range> | Index<time interval> | Returns a time range starting with the first date of the time range and lasting for the specified interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
range after <time> of <time range> | Index<time> | Returns a new time range, starting from the specified time and continuing through the end of the original range. The time must be within the range, or an error will result. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
range before <time> of <time range> | Index<time> | Returns a new time range, starting from the original time in the specified range and continuting to the specified time. The time must be within the range, or an error will result. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<time range> as string | Cast | <string> | Casts a time range as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
end of <time range> | Plain | <time> | Returns the end date of a time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
final part <time interval> of <time range> | Index<time interval> | <time range> | Returns a time range with the specified interval, but ending on the final date of the time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
initial part <time interval> of <time range> | Index<time interval> | <time range> | Returns a time range starting with the first date of the time range and lasting for the specified interval. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
length of <time range> | Plain | <time interval> | Returns the time interval (in days, hours, minutes, seconds) between the start and end date of a time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
range after <time> of <time range> | Index<time> | <time range> | Returns a new time range, starting from the specified time and continuing through the end of the original range. The time must be within the range, or an error will result. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
range before <time> of <time range> | Index<time> | <time range> | Returns a new time range, starting from the original time in the specified range and continuting to the specified time. The time must be within the range, or an error will result. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
start of <time range> | Plain | <time> | Returns the starting date of a time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
unique value of <time range> | Plain | <time range with multiplicity> | Returns the unique values of a given list of <time range> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<time range> & <time range> | <time range> | Returns the smallest range that contains both ot the specified ranges (same as <time range> + <time range>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time range> & <time> | <time range> | Concatenates a time with a time range, producing a new time range, in the form of: • <date> to <date>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time range> * <time range> | <time range> | Returns the intersection of the two specified time ranges, if one exists. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time range> + <time range> | <time range> | Returns the smallest range that contains both ot the specified ranges (same as <time range> & <time range>). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
<time range> = <time range> | <boolean> | Compares two time range types and returns TRUE if they are equal. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
<time> & <time range> | <time range> | Concatenates a time and a time range, producing a new time range. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0


Time Range with Multiplicity

These Inspectors deal with time-range arrays, allowing you to pluck out unique time-range values and count them. These objects are derived from ordinary time-range types.

Creation Methods

Key Phrase | Form | Description
unique value of <time range> | Plain | Returns the unique values of a given list of <time range> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time range with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time range> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Time with Multiplicity

These Inspectors deal with time arrays, allowing you to pluck out unique time values and count them. These objects are derived from ordinary time types.

Creation Methods

Key Phrase | Form | Description
unique value of <time> | Plain | Returns the unique values of a given list of <time> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Time Zone

Time zones are used in conjunction with the time object. Time zones have a resolution of 1 minute.

Creation Methods

Key Phrase | Form | Description
<string> as time zone | Cast | Creates a time zone object corresponding to the string provided. For example, "pst" as time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
local time zone | PlainGlobal | Creates a time zone object corresponding to the local time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
time zone <string> | NamedGlobal | Creates a time zone object corresponding to the string provided. For example, time zone "edt" as string = "-0400". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
universal time zone | PlainGlobal | Creates a time zone object corresponding to the universal time zone. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<time zone> as string | Cast | <string> | Returns a string corresponding to the time zone object provided. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
unique value of <time zone> | Plain | <time zone with multiplicity> | Returns the unique values of a given list of <time zone> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<time of day> & <time zone> | <time of day with time zone> | Concatenates a time of day with a time zone, returning a time of day with time zone type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time zone> & <time of day with time zone> | <time of day with time zone> | Converts a 'time of day with time zone' to the time in the specified time zone. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time zone> & <time of day> | <time of day with time zone> | Concatenates a time of day with a time zone, returning a time of day with time zone type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<time zone> {op} <time interval> | <time zone> | Returns a time zone object offset by a time interval, where: • {op} is one of: +, - . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Examples

local time zone - 2 * hour
Returns the time zone two hours away.


Time Zone with Multiplicity

These Inspectors deal with time zone arrays, allowing you to pluck out unique time zone values and count them. These objects are derived from ordinary time zone types.

Creation Methods

Key Phrase | Form | Description
unique value of <time zone> | Plain | Returns the unique values of a given list of <time zone> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <time zone with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <time zone> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Type

Some Inspectors look at the Relevance language itself, inspecting the Inspectors, so to speak. There are several aspects to view, including the types, properties, casts and operators. This group of Inspectors looks at the various type options available from the Relevance language.

Creation Methods

Key Phrase | Form | Description
direct object type of <property> | Plain | The type (if any) required after the keyword "of" in an expression using the property. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
index type of <property> | Plain | The type (if any) required before or without the keyword "of" in an expression using the property. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
left operand type of <binary operator> | Plain | The type required before the operator in an expression. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
operand type of <cast> | Plain | The type required before the keyword "as" in an expression using the cast. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
operand type of <unary operator> | Plain | The type required in an expression using the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
parent of <type> | Plain | The types (if any) whose properties are inherited by this type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <binary operator> | Plain | The type that the operator produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <property> | Plain | The type that the property produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <unary operator> | Plain | The type that the operator produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
right operand type of <binary operator> | Plain | The type required after the operator in an expression. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
type | PlainGlobal | The inspector types. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
type <string> | NamedGlobal | The type with the given name. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<type> as string | Cast | <string> | A string indicating the type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
cast from of <type> | Plain | <cast> | Returns the casts that can be created from the specified <type>. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
name of <type> | Plain | <string> | A string naming the type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
parent of <type> | Plain | <type> | The types (if any) whose properties are inherited by this type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
property <string> of <type> | Named | <property> | Returns the Inspector property of the specified string and type. Typically there is more than one property, so this is often used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property of <type> | Plain | <property> | Returns the Inspector property of the specified type. Typically there is more than one property, so this is often used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
property returning <type> of <type> | Index<type> | <property> | Returns Inspectors of the form <type> of <type>. Typically there is more than one property, so this is often used in the plural. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
size of <type> | Plain | <integer> | The number of bytes used in the internal representation of an object of the given type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Operators

Key phrase | Return Type | Description
<type> = <type> | <boolean> | Returns TRUE if both expressions denote the same type. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Unary Operator

Some Inspectors look at the Relevance language itself, inspecting the Inspectors, so to speak. There are several aspects to view, including the types, properties, casts and operators. This group of Inspectors looks at the various unary operators available from the Relevance language.

Creation Methods

Key Phrase | Form | Description
unary operator | PlainGlobal | The inspectors that have one parameter, and are invoked with punctuation marks or reserved phrases. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
unary operator <string> | NamedGlobal | Typically used in the plural, this inspector returns a list of objects that use the specified operator. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0
unary operator returning <type> | Index<type>Global | Returns a list of the unary operator inspectors (such as negative) that return the specified type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:6.0

Properties

Key Phrase | Form | Return Type | Description
<unary operator> as string | Cast | <string> | A short description of the use of the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
name of <unary operator> | Plain | <string> | A phrase naming the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
operand type of <unary operator> | Plain | <type> | The type required in an expression using the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
result type of <unary operator> | Plain | <type> | The type that the operator produces. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1
symbol of <unary operator> | Plain | <string> | A phrase or punctuation mark used to invoke the operator. Win:5.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1


Undefined

The "undefined" type is used as the result type of Inspectors that never return a value.

Creation Methods

Key Phrase | Form | Description
error <string> | NamedGlobal | Always fails; if an error message is generated, it is based on the given string. Win:4.1, Lin:4.1, Sol:4.1, HPUX:4.1, AIX:4.1, Mac:4.1

Examples

if FALSE then 1 else error "my error message"
Returns the string: User-defined error: my error message.


Usb

These are the Universal Serial Bus Inspectors.

Creation Methods

Key Phrase | Form | Description
usb | PlainGlobal | The Universal Serial Bus. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
isochronous of <usb> | Plain | <boolean> | The isochronous attribute of the USB installed. Taken from the Gestalt Manager. Mac:4.1
version of <usb> | Plain | <version> | The version of the USB installed in the system. Taken from the Gestalt Manager. Mac:4.1


User

These Inspectors allow you to list properties of all users, whether they are logged in or not.

Creation Methods

Key Phrase | Form | Description
current user | PlainGlobal | Creates an object corresponding to the current users, whether they are logged in or not. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1
user | PlainGlobal | Creates objects for all users, logged in or not. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
user <string> | NamedGlobal | Returns an object representing the user (logged in or not) specified by <string>. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
attribute <string> of <user> | Named | <user attribute> | Returns the specified named user attribute for the given user. These attributes are gathered from the LocalHost node of Apple’s OpenDirectory system. Mac:7.1
attribute of <user> | Plain | <user attribute> | Returns a list of attributes for the given user, logged in or not. These attributes are gathered from the LocalHost node of Apple’s OpenDirectory system. Mac:7.1
home directory of <user> | Plain | <folder> | Returns the dsAttrTypeStandard:NFSHomeDirectory attribute of the specified user. Mac:7.1
id of <user> | Plain | <string> | Returns the dsAttrTypeStandard:UniqueID attribute of the specified user. Mac:7.1
name of <user> | Plain | <string> | Returns the name of all the specified user, whether logged in or not. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:7.1
primary group id of <user> | Plain | <string> | Returns the dsAttrTypeStandard:PrimaryGroupID attribute for the specified user. Mac:7.1
tty of <user> | Plain | <string> | Returns the tty of the user. Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1

Examples

attributes of user “fizzle”
Returns a list of attributes, such as: dsAttrTypeStandard:RecordName: fizzle, dsAttrTypeStandard:UniqueID: 501, dsAttrTypeStandard:NFSHomeDirectory: /Users/fizzle...

names of users
Returns a list of all the users.


User Attribute

These Macintosh Inspectors provide information, such as user ID and home directory, of the specified user.

Creation Methods

Key Phrase | Form | Description
attribute <string> of <user> | Named | Returns the specified named user attribute for the given user. These attributes are gathered from the LocalHost node of Apple’s OpenDirectory system. Mac:7.1
attribute of <user> | Plain | Returns a list of attributes for the given user, logged in or not. These attributes are gathered from the LocalHost node of Apple’s OpenDirectory system. Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<user attribute> as string | Cast | <string> | Returns a list of user attributes. These can be inspected for value and key, but this Inspector concatenates them so the cast yields a string of the form “key: value”. These attributes are gathered from the LocalHost node of Apple’s OpenDirectory system (much like ActiveDirectory). For more information, see the Apple developer site. Mac:7.1
key of <user attribute> | Plain | <string> | Returns the key names of the specified user attribute, as specified by the LocalHost node of Apple’s OpenDirectory system. Mac:7.1
value of <user attribute> | Plain | <string> | Returns the value of the specified user attribute, as specified by the LocalHost node of Apple’s OpenDirectory system. Mac:7.1

Examples

attributes of user “fizzle”
Returns a list of attributes, such as: dsAttrTypeStandard:RecordName: fizzle, dsAttrTypeStandard:UniqueID: 501, dsAttrTypeStandard:NFSHomeDirectory: /Users/fizzle...

attribute “dsAttrTypeStandard:UniqueID” of user “fizzle”
Returns 501.

keys of attributes of user "fizzle"
Returns the key names of the specified attribute, such as: dsAttrTypeStandard:RecordName, dsAttrTypeStandard:UniqueID, dsAttrTypeStandard:NFSHomeDirectory.


Version

This is the numeric method of indicating the file version, which is compact, convenient and fast. It makes use of a short string to define the version number.

Creation Methods

Key Phrase | Form | Description
<string> as version | Cast | Turns a string into a version object. Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:5.1
<version> as version | Cast | Reflexive cast of version. Win:1.2
bundle version of <bundle> | Plain | Returns the version of the bundle corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
bundle version of <filesystem object> | Plain | Returns the version of the filesystem object corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
bundle version of <folder> | Plain | Returns the version of the folder corresponding to the CFBundleVersion string, as distinct from the CFBundleShortVersionString. Mac:5.1
file version of <file> | Plain | Creates a version object associated with the FILEVERSION property of the file. Win:1.2
maximum of <version> | Plain | Returns the maximum value from a list of <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <version> | Plain | Returns the minimum value from a list of <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
pad of <version> | Plain | Creates a version object which is padded with zero values. Win:1.2
product version of <file> | Plain | Creates a version object associated with the PRODUCTVERSION property of the file. Win:1.2
quickdraw version | PlainGlobal | Returns the version of QuickDraw installed. Mac:4.1
raw file version of <file> | Plain | Same as file version, but allows a workaround for anomalous behavior on Windows systems with the Windows language pack installed (the MUI). Win:4.1
raw product version of <file> | Plain | Same as product version, but allows a workaround for anomalous behavior on Windows systems with the Windows language pack installed (the MUI). Win:4.1
raw version of <file> | Plain | Same as version, but allows a workaround for anomalous behavior on Windows systems with the Windows language pack installed (the MUI). Win:4.1
release of <operating system> | Plain | The full version number of the operating system, of the form <major>.<minor>.<bug revision>. Mac:4.1
rom version | PlainGlobal | Returns the version of the system ROM. Mac:4.1
system version | PlainGlobal | Returns the version of MacOS. Mac:4.1
version <integer> of <file> | Numbered | Returns the nth version information from the "vers" resource of the given file. Typically n=1, but other information may be stored in "vers" resources greater than 1. Mac:4.1
version <string> | NamedGlobal | Creates a version object corresponding to the name provided. Syntax: version "1.2". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
version of <bundle> | Plain | Version of the given bundle. Mac:4.1
version of <client> | Plain | The product version of the BES application (BESClient or QnA). Lin:4.1, Sol:4.1, HPUX:4.0, AIX:4.1, Mac:7.1
version of <component> | Plain | The version of the component, as determined by the component maker. Mac:4.1
version of <current relay> | Plain | Returns a version object that is the version of the server or relay that the client last registered with. This may be a BES Relay or the BES root server. Win:7.0, Lin:7.0, Sol:7.0, HPUX:7.0, AIX:7.0, Mac:7.1
version of <file> | Plain | Shorthand for file version of <file>. Win:1.2, Mac:4.1
version of <fileset> | Plain | Returns the version of the specified fileset. AIX:4.1
version of <filesystem object> | Plain | This returns the version information from "vers" resource 1 of the file. It is usually present in applications, and may exist in data files as well. It corresponds to what appears in the "Get Info" box for the specified filesystem object. Mac:4.1
version of <folder> | Plain | Returns a version for a folder representing an application. Mac:4.1
version of <package> | Plain | Creates an object containing the version of the specified RPM package. Lin:3.1
version of <scsibus> | Plain | Version of the SCSI bus. Mac:4.1
version of <usb> | Plain | The version of the USB installed in the system. Taken from the Gestalt Manager. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
<version> as string | Cast | <string> | Turns a version type into a string of the form "1.2.3.4". Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<version> as version | Cast | <version> | Reflexive cast of version. Win:1.2
bug revision of <version> | Plain | <integer> | If the stage is present the bug revision is the number after the stage. If absent, zero is implied. Mac:4.1
build revision of <version> | Plain | <integer> | Returns the final component of a version (Major.Minor.RevisionStageBuild). Mac:7.1
extrema of <version> | Plain | <( version, version )> | Returns the minimum and maximum extreme values of the given list of <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
major revision of <version> | Plain | <integer> | The number before the first period in the version string. Mac:4.1
maximum of <version> | Plain | <version> | Returns the maximum value from a list of <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <version> | Plain | <version> | Returns the minimum value from a list of <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minor revision of <version> | Plain | <integer> | The number immediately after the first period in the version string. If absent, zero is implied. Mac:4.1
pad of <version> | Plain | <version> | Returns a version object which is padded with zero values. Win:1.2
unique value of <version> | Plain | <version with multiplicity> | Returns the unique values of a given list of <version> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<version> {cmp} <string> | <boolean> | Returns a boolean TRUE or FALSE, depending on the comparison operator, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1
<version> {cmp} <version> | <boolean> | Returns a boolean TRUE or FALSE, depending on the comparison operator, where: • {cmp} is one of: =, !=, <, <=, >, >= . Win:1.2, Lin:3.1, Sol:3.1, HPUX:4.0, AIX:4.1, Mac:4.1

Note

Using the numeric version data is better than identifying an application based on version block strings. If you know the numeric version information and that the developer has identified each release of his application uniquely, then this is the way to proceed. It requires far less overhead than the other method. Furthermore, if you know that the numeric version data is monotonically increasing then you can compare their values using the special comparison operators.

Examples

file version of file "Winsock.dll" of windows folder = "4.0.0.1111"
Returns TRUE if the dll has the specified version number.

pad of version "1.2" = version "1.2.0.0"
Returns TRUE.

release of operating system
Returns a version number, e.g. 10.3.8.

version of bundle of folder "iTunes.app" of applications folder
Returns the version of the specified folder bundle, such as 4.2.

version of client as string
Returns a string like "4.0.3.7".

build revision of version "7.1.2.70"
Returns 70.

extrema of (version "1.1"; version "2.3"; version "0.9")
Returns the minimum and maximum values of the set: 0.9, 2.3.

major revision of version of file "name" > 4
Returns TRUE if the major revision number is greater than the specified number.


Version with Multiplicity

These Inspectors deal with version arrays, allowing you to pluck out unique version values and count them. These objects are derived from ordinary version types.

Creation Methods

Key Phrase | Form | Description
unique value of <version> | Plain | Returns the unique values of a given list of <version> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <version with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <version> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Volume

The following Inspectors refer to the mounted drive volumes.

Creation Methods

Key Phrase | Form | Description
drive | PlainGlobal | Returns the volume corresponding to the drive. Typically used to return a list of the drives (volumes, filesystems) on the client computer. Drives, volumes and filesystems are treated the same on the Macintosh and return a <volume> type. Mac:6.0
drive <integer> | NumberedGlobal | Returns the volume corresponding to the numbered drive. Mac:6.0
drive <string> | NamedGlobal | Returns the volume corresponding to the named drive. Mac:6.0
drive of <file> | Plain | Returns the drive associated with the specified file. Mac:5.1
drive of <folder> | Plain | Returns the drive associated with the specified folder. Mac:5.1
filesystem | PlainGlobal | Returns the volume corresponding to the filesystem. Typically used to return a list of the filesystems (drives, volumes) on the client computer. Drives, volumes and filesystems are treated the same on the Macintosh and all return a <volume> type. Mac:6.0
filesystem <integer> | NumberedGlobal | Returns the volume corresponding to the numbered filesystem. Mac:6.0
filesystem <string> | NamedGlobal | Returns the volume corresponding to the named filesystem. Mac:6.0
filesystem of <file> | Plain | Returns the filesystem (volume or drive) containing the specified file. Drive, volume and filesystem are treated the same on the Mac. Mac:6.0
filesystem of <folder> | Plain | Returns the filesystem (volume or drive) containing the specified folder. Drive, volume and filesystem are treated the same on the Mac. Mac:6.0
volume | PlainGlobal | An iterated property. Examines all currently mounted volumes which will include the startup volume, CD-ROM, floppies and other removable media and file sharing volumes. Mac:4.1
volume <integer> | NumberedGlobal | A numbered property. Volume 1 is the startup volume. Others follow in sequence. Mac:4.1
volume <string> | NamedGlobal | A named property representing a volume. Mac:4.1
volume of <file> | Plain | The volume containing the file. Mac:4.1
volume of <folder> | Plain | The volume containing the specified folder. Mac:4.1

Properties

Key Phrase | Form | Return Type | Description
allocation block count of <volume> | Plain | <integer> | The number of allocation blocks, used or free, on the volume. Mac:4.1
directory count of <volume> | Plain | <integer> | The number of directories on the volume. Mac:4.1
file count of <volume> | Plain | <integer> | The number of files on the volume. Mac:4.1
flag of <volume> | Plain | <integer> | Returns the Mac-specific volume flags.More info on these flags can be found at the Apple developer site, under Carbon > Reference > File Manager. Mac:6.0
free percent of <volume> | Plain | <integer> | Returns the percentage of room available on the specified volume. Mac:6.0
free space of <volume> | Plain | <integer> | The number of free bytes on the volume. Mac:4.1
init date of <volume> | Plain | <time> | Returns the initialization date of a disk volume. Mac:4.1
modification time of <volume> | Plain | <time> | Creates a time object corresponding to the time the volume was last modified. Mac:5.1
name of <volume> | Plain | <string> | The name of the volume. Mac:4.1
size of <volume> | Plain | <integer> | Returns a number corresponding to the total number of bytes (used and unused) on the specified volume. Mac:6.0
total space of <volume> | Plain | <integer> | The total amount of space, used and free, on the volume. Mac:4.1
used percent of <volume> | Plain | <integer> | Returns the used percentage of room on the specified volume (or drive or filesystem). Mac:6.0
used space of <volume> | Plain | <integer> | Returns a number corresponding to the used bytes on the specified volume. Mac:6.0

Operators

Key phrase | Return Type | Description
<volume> = <volume> | <boolean> | Compare two volumes. Mac:4.1

Examples

filesystems
Returns a list of filesystems, eg., /, /Users/MyUserName, etc.

filesystem of folder "/Users/MyUserName/Library"
Returns /Users/MyUserName.

free percentage of volume 1
Returns a number between 0 and 100.

init date of volume of system folder
Returns the date the system folder was initialized.

size of volume 1
Returns the size of the specified volume in bytes, eg. 159697911808.

used percentage of volume 2
Returns a number between 0 and 100.


Volume Group

On AIX systems, physical disk volumes are organized into volume groups. The partition size of a physical volume is determined by the volume group that it belongs to. If multiple physical volumes belong to the same volume group, then they must all have the same partition size. A typical partition size might be 16 or 32 megabytes.

Creation Methods

Key Phrase | Form | Description
volume group <string> of <logical volume manager> | Named | On an AIX system, returns a volume group from the logical group whose name property matches the given string. AIX:7.0
volume group of <logical volume manager> | Plain | Returns the volume group corresponding to the given logical volume manager. AIX:7.0
volume group of <logical volume> | Plain | Returns the volume group that contains the given logical volume. AIX:7.0

Properties

Key Phrase | Form | Return Type | Description
<volume group> as string | Cast | <string> | Casts an AIX volume group as a string type. AIX:7.0
free partition count of <volume group> | Plain | <integer> | Returns the number of physical partitions within the specified volume group that are not currently allocated to any logical volume. AIX:7.0
logical volume <string> of <volume group> | Named | <logical volume> | Returns a logical volume within the specified volume group whose "name" property matches the given string. AIX:7.0
logical volume of <volume group> | Plain | <logical volume> | On an AIX system, returns the logical volume corresponding to the specified volume group. AIX:7.0
major number of <volume group> | Plain | <integer> | Returns the major number of the specified volume group. Each logical volume is represented by a device special file (located in directory /etc). The major number of the device special file is associated with the volume group containing the logical volume, and the minor number of the device special file is associated with the logical volume. AIX:7.0
name of <volume group> | Plain | <string> | Returns the name of the volume group, eg. "rootvg". AIX:7.0
partition size of <volume group> | Plain | <integer> | Returns the partition size of the specified volume group (in bytes). The partition size of the volume group represents the logical and physical partition sizes for all logical volumes and physical volumes contained within the specified volume group. AIX:7.0

Examples

volume groups of logical volume manager
Returns a list of the volume groups on an AIX system, such as joe, rootvg, etc.

volume group of logical volume "splat" of volume group "dave" of logical volume manager
Returns the name of the volume group corresponding to the specified volume, in this case, "dave".

free partition count of volume group "dave" of logical volume manager
Returns the number of free partitions in the specified volume group.

logical volumes of volume group "joe" of logical volume manager
Returns a list of the logical volumes in the specified volume group.

number of logical volumes of volume group "dave" of logical volume manager
Returns the number of logical volumes in the specified volume group.

logical volumes of volume groups of logical volume manager
Returns the list of all the logical volumes in the logical volume manager.

major number of volume group "dave" of logical volume manager
Returns the major number of the specified volume group.

name of volume group "dave" of logical volume manager
Returns "dave".

partition size of volume group "dave" of logical volume manager
Returns the partition size of the specified volume group (in bytes).


Wmi

A wmi object provides access to the WMI (Windows Management Instrumentation) query facility. This object provides access to a large amount of configuration and client-specific data.

Creation Methods

Key Phrase | Form | Description
full wmi <string> | NamedGlobal | Returns a wmi object which can retrieve all values, including system values. Win:2.0
rsop computer wmi | PlainGlobal | Provides access to the Resultant Set of Policy (RSoP) WMI classes via the RsopLoggingModeProvider. This is used to examine the state of the GPO (Group Policy object) security policies. Win:7.0
rsop user wmi <security identifier> | Index<security identifier>Global | Each user has its own RSoP (Resultant Set of Policy) namespace based on the user’s Security Identifier (SID). This Inspector returns the namespace specified by the <security identifier>. Win:7.0
wmi | PlainGlobal | Returns the wmi object corresponding to the "root\cimv2" namespace. Win:2.0
wmi <string> | NamedGlobal | Returns the wmi object corresponding to the namespace string provided. Win:2.0

Properties

Key Phrase | Form | Return Type | Description
select <string> of <wmi> | Named | <wmi select> | Returns the wmi select whose name matches the string provided. Win:2.0
select object <string> of <wmi> | Named | <wmi object> | Returns the desired property (specified by <string>) from the given wmi object. Win:6.0


Wmi Object

These Inspectors allow you to analyze the properties of WMI objects.

Creation Methods

Key Phrase | Form | Description
select object <string> of <wmi> | Named | Returns the desired property (specified by <string>) from the given wmi object. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<wmi object> as string | Cast | <string> | Casts the given wmi object as a string type. Win:6.0
property <string> of <wmi object> | Named | <wmi select> | Returns the Inspector properties of the form <string> of <wmi object>. Win:6.0
property of <wmi object> | Plain | <wmi select> | Returns the Inspector properties of the specified wmi object. Win:6.0


Wmi Select

A value returned as a result of a WMI select query. You can find more information at the MSDN Library (http://msdn.microsoft.com/library/) under WMI Classes. WMI Inspectors can provide you with useful information about your Client computers. For instance, to get the asset tag from a dell, use:
• string value of select "SerialNumber from Win32_systemenclosure" of wmi.

Creation Methods

Key Phrase | Form | Description
property <string> of <wmi object> | Named | Returns the Inspector properties of the form <string> of <wmi object>. Win:6.0
property of <wmi object> | Plain | Returns the Inspector properties of the specified wmi object. Win:6.0
select <string> of <wmi> | Named | Returns the wmi select whose name matches the string provided. Win:2.0

Note

Here are a few other examples of using the wmi Inspectors. Each of the examples below hands back dozens of settings:
Q: selects "* from Win32_ComputerSystem" of wmi
Q: selects "* from win32_keyboard" of wmi
Q: selects "* from win32_CDROMDrive" of wmi
Q: selects "* from win32_DiskDrive" of wmi
Q: selects "* from win32_BIOS" of wmi
Q: selects "* from win32_CacheMemory" of wmi
Q: selects "* from win32_DMIChannel" of wmi
Q: selects "* from win32_FloppyController" of wmi
Q: selects "* from win32_IDEController" of wmi
Q: selects "* from win32_IRQResource" of wmi
Q: selects "* from win32_MemoryDevice" of wmi
Q: selects "* from win32_MotherboardDevice" of wmi
Q: selects "* from win32_ParallelPort" of wmi
Q: selects "* from Win32_PNPDevice" of wmi
Q: selects "* from win32_Processor" of wmi
Q: selects "* from win32_SerialPort" of wmi
Q: selects "* from win32_SoundDevice" of wmi
Q: selects "* from win32_NetworkAdapter" of wmi
Q: selects "* from win32_NetworkAdapterSetting" of wmi
Q: selects "* from win32_Battery" of wmi
Q: selects "* from win32_PrinterPrinterDriver" of wmi
Q: selects "* from win32_PrinterSetting" of wmi

Properties

Key Phrase | Form | Return Type | Description
<wmi select> as string | Cast | <string> | Returns a string formatted as <name>=<value> for the wmi select. Win:2.0
boolean value <integer> of <wmi select> | Numbered | <boolean> | Returns the WMI value cast to boolean. Win:4.1
boolean value of <wmi select> | Plain | <boolean> | Returns the boolean value of a <wmi select> object (exists only for boolean objects). Win:2.0
integer value <integer> of <wmi select> | Numbered | <integer> | Returns the WMI value cast to an integer. Win:4.1
integer value of <wmi select> | Plain | <integer> | Returns the integer value of a <wmi select> object whose value is of type integer. Win:2.0
name of <wmi select> | Plain | <string> | Returns the name of the wmi select. Win:2.0
string value <integer> of <wmi select> | Numbered | <string> | Returns the numbered string of a WMI array value. Win:4.1
string value of <wmi select> | Plain | <string> | Returns the string value of the wmi select. Win:2.0
time value <integer> of <wmi select> | Numbered | <time> | Returns the numbered time of a WMI array value. Win:4.1
time value of <wmi select> | Plain | <time> | Returns the time value of the wmi select whose value is of type time. Win:2.0
type of <wmi select> | Plain | <integer> | Returns the type of data stored in the wmi select value. Possible values are: • 8 (VT_BSTR) • 11 (VT_BOOL) • 22 (VT_INT) • (See MSDN documentation for the meaning of additional values.). Win:2.0


X509 Certificate

X.509 is a public key infrastructure standard, specifying formats for public key certificates and revocations. These Inspectors interpret the certificate from a file in the PEM format. They can be used to analyze encryption credentials on decrypting relays or root servers.

Creation Methods

Key Phrase | Form | Description
encryption certificate of <license> | Plain | Provides the encryption certificate that is currently active and which will be used by clients to encrypt reports. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
pem encoded certificate of <file> | Plain | Reads and returns the certificate from a file in the PEM format. This can be used to analyze encryption credentials on decrypting relays or root servers. Win:7.1

Properties

Key Phrase | Form | Return Type | Description
invalid before of <x509 certificate> | Plain | <time> | Returns the date on which the certificate first becomes valid. This is useful for examining encryption certificates, where the 'invalid before date' is the time when the encryption credentials were generated. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
sha1 of <x509 certificate> | Plain | <string> | Returns the SHA1 hash of the given certificate, which uniquely identifies it. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Xml Dom Document

These are the Inspectors for the XML Document Object Module (DOM) for specified XML files. XML dom document objects are derived from XML dom node objects. The console uses MSXML 6.0 if it is available. Otherwise it falls back to 4.0. The console requires at least 4.0 since 3.0 does not provide XML schema validation.

Creation Methods

Key Phrase | Form | Description
owner document of <xml dom node> | Plain | Returns the name of the document that contains the specified node. Win:5.1
xml document of <file> | Plain | Returns the XML Document Object Module (DOM) for the specified file. Win:5.1
xml document of <string> | Plain | Returns an XML document object from the given <string>, typically a file name. Win:6.0


Xml Dom Node

These are the Inspectors for the XML Document Object Module (DOM) nodes. The console uses MSXML 6.0 if it is available. Otherwise it falls back to 4.0. The console requires at least 4.0 since 3.0 does not provide XML schema validation.

Creation Methods

Key Phrase | Form | Description
attribute <integer> of <xml dom node> | Numbered | Returns the numbered attribute of the specified XML DOM node. Win:5.1
attribute <string> of <xml dom node> | Named | Returns the named attribute of the specified node. Win:5.1
attribute of <xml dom node> | Plain | Returns the attribute(s) of the specified XML DOM node. Win:5.1
child node <integer> of <xml dom node> | Numbered | Returns the child node by number. Win:5.1
child node of <xml dom node> | Plain | By chaining this Inspector, you can find the child nodes of any given node. Win:5.1
first child of <xml dom node> | Plain | Returns the first child node in the specified node. When applied to an XML DOM file, it returns the first node in the file. Win:5.1
last child of <xml dom node> | Plain | Returns the last child node in the specified node. When applied to an XML DOM file, it returns the last node in the file. Win:5.1
next sibling of <xml dom node> | Plain | Returns the next child node after the current one. Win:5.1
parent node of <xml dom node> | Plain | Returns the parent node of the specified node. The top of the hierarchy is the document itself, so a phrase such as "exists parent node of xml dom document" will return FALSE. Win:5.1
previous sibling of <xml dom node> | Plain | Returns the child node before the one specified. Win:5.1
select <string> of <xml dom node> | Named | Uses an Xpath string to specify an XML DOM node. For instance, to select all elements BBB which are children of the root element AAA, use: • selects "/AAA/BBB" of xml dom document <string>. Win:6.0
xpath <( string, string )> of <xml dom node> | Index<( string, string )> | The iterated named property xpaths (<namespace>, <query>) provides a way of specifying the namespaces for the query. If the XML document you are querying over uses namespaces, you must use them in the query and use this property. Win:6.0
xpath <string> of <xml dom node> | Named | Returns an iterated list of matching xml dom nodes, given the xpath query specified by <string>. Win:6.0

Properties

Key Phrase | Form | Return Type | Description
<xml dom node> as text | Cast | <string> | Casts an xml document object module node as text. Win:6.0
<xml dom node> as xml | Cast | <string> | Casts an xml document object module node as xml. Win:6.0
attribute <integer> of <xml dom node> | Numbered | <xml dom node> | Returns the numbered attribute of the specified XML DOM node. Win:5.1
attribute <string> of <xml dom node> | Named | <xml dom node> | Returns the named attribute of the specified node. Win:5.1
attribute of <xml dom node> | Plain | <xml dom node> | Returns the attribute(s) of the specified XML DOM node. Win:5.1
child node <integer> of <xml dom node> | Numbered | <xml dom node> | Returns the child node by number. Win:5.1
child node of <xml dom node> | Plain | <xml dom node> | By chaining this Inspector, you can find the child nodes of any given node. Win:5.1
first child of <xml dom node> | Plain | <xml dom node> | Returns the first child node in the specified node. When applied to an XML DOM file, it returns the first node in the file. Win:5.1
last child of <xml dom node> | Plain | <xml dom node> | Returns the last child node in the specified node. When applied to an XML DOM file, it returns the last node in the file. Win:5.1
next sibling of <xml dom node> | Plain | <xml dom node> | Returns the next child node after the current one. Win:5.1
node name of <xml dom node> | Plain | <string> | Returns the name of the specified XML DOM node as a string. Win:5.1
node type of <xml dom node> | Plain | <integer> | Returns the numeric node type of the specified Document Object Module (DOM) node, 1-12 as shown in the creation Inspector. Win:5.1
node value of <xml dom node> | Plain | <string> | Returns the node value, which varies depending on the node type. If the standard interface produces a null type, the Inspector throws NoSuchObject. Win:5.1
owner document of <xml dom node> | Plain | <xml dom document> | Returns a document belonging to the owner of the specified node. Win:5.1
parent node of <xml dom node> | Plain | <xml dom node> | Returns the parent node of the specified node. Win:5.1
previous sibling of <xml dom node> | Plain | <xml dom node> | Returns the child node before the one specified. Win:5.1
select <string> of <xml dom node> | Named | <xml dom node> | Uses an Xpath string to specify an XML DOM node. For instance, to select all elements BBB which are children of the root element AAA, use: • selects "/AAA/BBB" of xml dom document <string>. Win:6.0
xpath <( string, string )> of <xml dom node> | Index<( string, string )> | <xml dom node> | The iterated named property xpaths (<namespace>, <query>) provides a way of specifying the namespaces for the query. If the XML document you are querying over uses namespaces, you must use them in the query and use this property. Win:6.0
xpath <string> of <xml dom node> | Named | <xml dom node> | Returns an iterated list of matching xml dom nodes, given the xpath query specified by <string>. Win:6.0

Note

Some of the examples in this section refer to test.xml, a structured file like this:
<?xml version ="1.0"?>
<a:Books xmlns:a="x-schema:bookschema.xml" >
<a:Book>
<title>Presenting XML</title>
<author>Richard Light</author>
</a:Book>
</a:Books>


Year

These Inspectors provide tools for dealing and calculating with year types, which are of the form YYYY, as in 2008.

Creation Methods

Key Phrase | Form | Description
<integer> as year | Cast | Casts an integer as a year type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<string> as year | Cast | Converts a string into a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
current year | PlainGlobal | Returns the current year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <year> | Plain | Returns the maximum value from a list of <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <year> | Plain | Returns the minimum value from a list of <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
year <integer> | NumberedGlobal | Creates a year object from the specified integer. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year <string> | NamedGlobal | Creates a year object from the specified string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year of <date> | Plain | The year derived from the given date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
year of <month and year> | Plain | Returns the year portion of the specified date (in month year format). Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
<year> as integer | Cast | <integer> | Casts a year as an integer. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> as string | Cast | <string> | Casts a year as a string. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
extrema of <year> | Plain | <( year, year )> | Returns the minimum and maximum extreme values of the given list of <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
leap of <year> | Plain | <boolean> | Returns a flag indicating whether or not the specified year is a leap year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
length of <year> | Plain | <time interval> | Returns the number of day in the specified year. Leap years have 366 days. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
maximum of <year> | Plain | <year> | Returns the maximum value from a list of <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
minimum of <year> | Plain | <year> | Returns the minimum value from a list of <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1
unique value of <year> | Plain | <year with multiplicity> | Returns the unique values of a given list of <year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Operators

Key phrase | Return Type | Description
<day of year> & <year> | <date> | Concatenates a day of the year with a year to create a complete date type. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<month> & <year> | <month and year> | Returns a date (in month year format) from the concatenation of a month and a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> - <year> | <number of months> | Subtracts two years and produces a time interval marked in months and years. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> & <day of year> | <date> | Concatenates a year with the day of the year, returning a full date. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> & <month> | <month and year> | Returns a date (in month year format) from the concatenation of a month and a year. Win:6.0, Lin:6.0, Sol:6.0, HPUX:6.0, AIX:6.0, Mac:7.1
<year> {cmp} <year> | <boolean> | Compares two years, where {cmp} is one of: <, <=, =. Win:6.0


Year with Multiplicity

These Inspectors deal with year arrays, allowing you to pluck out unique year values and count them. These objects are derived from ordinary year types.

Creation Methods

Key Phrase | Form | Description
unique value of <year> | Plain | Returns the unique values of a given list of <year> types, removing duplicates and sorting by value. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1

Properties

Key Phrase | Form | Return Type | Description
multiplicity of <year with multiplicity> | Plain | <integer> | Sorts the list and returns the multiplicity, or count, of each unique element in the specified list of multiple <year> types. Win:7.1, Lin:7.1, Sol:7.1, HPUX:7.1, AIX:7.1, Mac:7.1


Creating Action Scripts

You can create custom actions to fix problems or address issues across your network that are not covered by the standard content. Although the process is simple to describe, there are a large range of actions and targeting techniques at your disposal. To create a custom action:

  1. Log on to the BigFix Console as a Master Operator.
  2. Select Tools > Take Custom Action.
  3. The Take Action dialog pops up. At the top is a place to provide a Name for your custom action. This field can be sorted and filtered, so a good naming convention will let you get the most out of your reports.
  4. Under the Name field is the Preset pull-down menu that allows you pick a preset customized action, saving you time and ensuring accuracy. You can also save your current input as a preset for later use. The Preset interface includes these fields and buttons:
    • Preset: Select a preset from the pull-down menu.
    • Show only personal presets: Check this box to filter the list of presets to just your personal ones.
    • Save Preset: Save the current set of action options for later use. This button isn't active until you make a change to one of the options somewhere in this dialog. When you click this button, a dialog pops up prompting you for the name of your preset. A check box below that lets you save it as a public or private preset.
    • Delete Preset: Removes this preset from the selectable list. It brings up a confirmation dialog allowing you to cancel this command.
  5. Under the Presets, there are several tabs:
    • Target: Select the targets from the provided list, or use properties or a specific list of computers to target the action.
    • Execution: Specify the deployment options and constraints, including repeated application and failure recovery.
    • Users: Determine how this Action will respond to the presence or absence of users.
    • Messages: Provide a message to precede and accompany the Action.
    • Offer: Create an Action offering, allowing the user to choose whether or not to apply the Action.
    • Post-Action: Describe what actions need to be done to complete the action, including restarts or shutdowns.
    • Applicability: Allows you to override the original Action relevance.
    • Success Criteria: Create specific criteria that you can use to determine if your Action was successful.
    • Action Script: This tab allows you to create or modify an action script.
  6. Click on the Action Script tab and type in your script. This guide will help you with a description of the Action commands and multiple examples.
  7. Click on the Applicability tab if you would like to fine-tune the targeting of your action script. For more information about the Relevance language, see the BigFix Relevance Language Reference and the BigFix Inspector Guides.
  8. Click on the Execution, Users, Messages, Offer or Post-Action tabs to further customize your action.
  9. When you are ready to deploy your custom action, click OK.
  10. Your custom action will be distributed to all the computers that have been selected or targeted. The actions will be applied using whatever constraints and schedules you have specified.

You can also create actions when you Create Tasks or Create Fixlets. See the BigFix Console manual for more information on these topics.


Introducing Dynamic Downloads

A new feature called dynamic downloading has been added to version 7.2 of BigFix to extend the flexibility of Action scripts. To understand how it works, it is helpful to understand the existing static (pre-7.2) download method.

Static Downloading

Before it runs an Action, the BigFix client parses it, looking for download or prefetch commands. Static downloads include the URL, sha1 and size for each item as literal values in the action script. The literal values allows an operator to observe exactly what the action script is going to do. These literals are used to construct a numbered list of downloads associated with the action that is then stored on the BigFix server.

When an Action subsequently runs, it notifies the nearest BigFix relay of the need for downloads by requesting a URL ending in <actionid>/0, which in turn triggers the BigFix relay to download all the items corresponding to that specified Action. When they are ready, the BigFix relay pings the clients back with the Action ID. All the BigFix clients running that Action will then collect the files by asking for them one at a time as <actionid>/1, <actionid>/2, etc.

However, because the download information is represented by literal expressions, only those URLs already known when the Action is authored can be represented. This means that static downloads can't be used for those instances where the downloads change, but the Action script remains the same.

Dynamic Downloading

Dynamic downloads add the ability to use relevance clauses to specify downloads. These new commands must be embedded in a special segment of Action code called a prefetch block. For instance, if you created a file in the AV Fixlet site named download.spec containing a named variable in the first line such as:

name=update.exe sha1=123 size=456 url=http://site.com/download/patch.exe

You could then access this patch using relevance substitution in a prefetch block:

begin prefetch block

parameter "downloadFile"="{pathname of file "download.spec" of client folder of site "AV"}"

add prefetch item {line 1 of file (parameter "downloadFile")}

end prefetch block

This code block creates a variable named downloadFile that points to a file in the AV site. It then adds this file to the prefetch queue for subsequent downloading. In this way, a Fixlet message in the AV site could offer to keep something automatically updated and the download.spec file would be refreshed whenever a new version became available. Deploying the action from the Fixlet as a Policy Action would then execute the update whenever the download.spec file was changed.

Note that this code block terminates with an end prefetch block command, which ensures that the file is successfully downloaded before continuing with the rest of the Action script. A prefetch block must be the first executable code in the Action script, and it must be closed with the end prefetch block statement before the script can continue.

Another popular technique is to use a data file, or manifest, containing a list of multiple downloads, each with its own URL, sha1 and size. This manifest can change as often as necessary, making it easy to update spyware or anti-virus definitions. One way to implement this is to create a file named manifest.spec with a list of downloads such as

name=patch1.exe sha1=123 size=456 url=http://site.com/download/patch1.exe
name=patch2.exe sha1=234 size=567 url=http://site.com/download/patch2.exe
name=patch3.exe sha1=345 size=678 url=http://site.com/download/patch3.exe

You can then download these patches with a prefetch block that pulls these files from the manifest:

begin prefetch block

parameter "manifest"="{pathname of file "manifest.spec" of client folder of site "AV"}"

add prefetch item {concatentation " ; " of lines of file (parameter "manifest")}

end prefetch block

You can also use small executables to process files into a fresh manifest. This is accomplished with the execute prefetch plug-in command, as the following example illustrates:

begin prefetch block

add prefetch item name=myPlugIn.exe sha1=123 size=456 url=http://mysite/plugin.exe

// collect the plugin before continuing:

collect prefetch items

parameter "ini"="{file "prepass.ini" of site (value of setting "CustomSite") of client}"

execute prefetch plug-in "{download path "myPlugIn.exe"}" /downloads "{parameter "ini"}" "{download path "manifest"}"

add prefetch item {concatentation " ; " of lines of download file "manifest"}

end prefetch block

This prefetch block first adds the plug-in to the prefetch queue and then executes the collect prefetch items command. This forces the Action to wait for the items added to the prefetch queue to download before the execution continues. Once successfully downloaded, the plug-in is executed with arguments including the path for the data file and the manifest to be produced from it. The final add prefetch item command queues up the downloads specified in the freshly created manifest. A technique like this might also be used to decrypt a secure file into a plain-text manifest.

Dynamic downloads must specify files with the confirmation of a size or sha1. But the URL, size, and sha1 are allowed to come from a source outside of the Action script. This flexibility entails extra scrutiny. Since any client can use dynamic downloading to request a file, it creates an opportunity for people to use your server to host files indiscriminately. To prevent this, dynamic downloading uses a white-list. Any request to download from a URL (that isn’t explicitly authorized by use of a literal URL in the action script) must meet one of the criteria specified in a white-list of URLs on the BigFix server, located at <BES Server Install Path>\Mirror Server\Config\DownloadWhitelist.txt. This file contains a newline-separated list of regular expressions using a Perl regex format, such as the following:

http://.*\.sitename\.com/.*
http://software\.sitename\.com/.*
http://download\.sitename\.com/patches/JustThisOneFile\.qfx

The first line is the least restrictive, allowing any file at the sitename domain to be downloaded. The second line requires a specific domain host and the third is the most restrictive, limiting the URL to a single file named "JustThisOneFile.qfx". If a requested URL fails to match an entry in the white-list, the download immediately fails with status NotAvailable. A note is made in the Relay log containing the URL that failed to pass. An empty or non-existent white-list will cause all dynamic downloads to fail. A white-list entry of ".*" (dot star) will allow any URL to be downloaded.

Dynamic downloads allow conditional statements inside the prefetch block:

begin prefetch block

if {name of operating system = "Windows 2000"}

add prefetch item name=up.exe sha1=123 size=456 url=http://site.com/patch2k.exe

else

add prefetch item name=up.exe sha1=123 size=456 url=http://site.com/patch.exe

endif

end prefetch block

wait "{download path "up.exe"}"

This Action script branches on the existence of Win2K, but because the downloads are described statically (as literal text), both of the files will be requested for download even if only one of them is ultimately needed. A better solution is the following:

begin prefetch block

if {name of operating system = "Windows 2000"}

add prefetch item {"name=up.exe sha1=123 size=456 url=http://site.com/patch2k.exe"}

else

add prefetch item {"name=up.exe sha1=123 size=456 url=http://site.com/patch.exe"}

endif

end prefetch block

wait "{download path "up.exe"}"

By using relevance substitution in the prefetch block, with a properly configured white list file on the server, this code only fetches the necessary file, potentially improving bandwidth requirements and efficiency.

You can also branch execution based on the contents of a file, allowing you to automate updates. This can be especially useful for dealing with changing version numbers. For instance, you could create a file named 'manifest.txt' containing two named variables such as:

version=1234
download=name=update.exe sha1=123 size=456 url=http://site.com/download/patch.exe

Note that the download variable contains the name, sha1, size and URL of the patch file. You can then use relevance substitution to extract these variables with an expression such as:

parameter "ver"="{key "version" of file "{download path "manifest.txt"}"}"
parameter "filename"={key "download" of file "{download path "manifest.txt"}"}

By comparing the extracted version against some stored value, you can determine if and when you need to download the specified file. This technique can be expanded to include multiple versions and can even be used to distinguish between patches and full replacement updates.

No matter which technique is used, once the files have been downloaded, they can be examined with various Inspectors which may have different interpretations, depending on whether the Action is active or not. Before execution, these files are collected in a prefetch folder. During Action execution, they reside in the __Download folder. There are new Inspectors that can be used to locate the files before or during action execution:

  • download folder: During the prefetch parsing, this Inspector returns a folder object from the __Global\<sitename>\<actionid>\named folder. Once the Action is active and the download has completed, this Inspector returns the expected folder object from the __Download directory.
  • download path "pathname": This Inspector returns a string containing the full pathname to the specified file, whether it exists or not. The download filename is equivalent to "(pathname of download folder) & <pathseparator> & filename".
  • download file "filename": This Inspector returns a file object from the download folder or another named folder. The download filename is equivalet to "file 'filename' of download folder". If the file isn't yet in the download folder, the Inspector returns 'does not exist'.

It is up to the action script author to protect users of these actions and ensure that downloads and their checksums have not been compromised. An end-to-end authentication mechanism resistant to man-in-the-middle attacks is the best defense. When authoring a dynamic download action it is critical to craft the action so that it authenticates information before using it, typically by using a plug-in as described above. It is also wise to explicitly identify those steps in the action script that perform this authentication so that users of your action can audit the mechanism before deciding to trust it.

Notes:

Only one prefetch block is allowed per Action. When it is used, the begin prefetch block command must be the first executable in the script. Only blank lines and comments are allowed to precede it. An end prefetch block command is required for termination.

BES 7.2


Introducing the Prefetch Block

Prior to 7.2, Action scripts containing download commands were processed by scanning the action to deduce which downloads corresponded to which sha1’s and sizes. This was error prone because the download commands had to be correlated with continue if commands and the information was spread out throughout the action, comingled with other action logic. This made Actions harder to understand than was necessary. We introduced the prefetch block to resolve these issues.

The prefetch block must be the first entry in the Action script (other than comments or blank lines). It contains all the download prefetch logic needed to prepare for subsequent Action execution. As a consequence, Actions written with a prefetch block are easier to understand. Some of the methods that can be used in a prefetch block include:

  • Literal downloads. These are ordinary static downloads, which are still available.
  • Conditional downloads. Only those commands inside TRUE condition pathways are performed.
  • Variable Substitution. This includes downloads that use relevance substitution to determine which files to collect.
  • Custom logic. This takes advantage of a plug-in to create download manifests.

Unlike the pre-parsing algorithm used in the traditional downloading actions, prefetch block downloads can be viewed as a top-down approach: the prefetch block comes first and must successfully complete before the rest of the Action can continue. This provides greater control, flexibility and power. Over time, this richer paradigm is expected to subsume the interleaved solutions of the pre-7.2 version.

Notes:

Only one prefetch block is allowed per Action. When it is used, the begin prefetch block command must be the first executable in the script. Only blank lines and comments are allowed to precede it. An end prefetch block command is required for termination.

BES 7.2


Using Substitution

Substitution allows the Fixlet author to include relevance expressions in an Action. This is accomplished by placing the relevance expression in curly braces:

run "{pathname of regapp "excel.exe"}"

This example runs a program without knowing where it is located. A relevance expression evaluates the pathname automatically using the ‘regapp’ inspector.

pause while {exists running application "c:\updater.exe"}

This action pauses until a program finishes executing, using the ‘running application’ inspector.

Substitution is not recursive, although any particular command may have one or more expressions to evaluate before execution. The BigFix application is expecting to find a single expression inside the curly braces. If it sees another left brace before it encounters a closing right brace, it treats it as an ordinary character:

echo {"a left brace: {"}

would send this string to output:

a left brace: {

Therefore no special escape characters are necessary to represent a left brace. To output a literal right brace without ending the substitution, use a double character:

echo {"{a string inside braces}}"}

would send this string to output:

{a string inside braces}

Or consider this example:

appendfile {{ name of operating system } {name of operating system}

When this example is parsed, the double left braces indicate that what follows is not a relevance expression. Only a single right brace is necessary when it's outside of a relevance expression (inside a relevance expression, a double right brace is necessary to specify a literal one). This would output the following line to __appendfile:

{ name of operating system } WinXP

You can also use substitution with add prefetch item commands in prefetch blocks:

begin prefetch block

parameter "manifest"="{pathname of file "manifest.spec" of client folder of site "AV"}"

add prefetch item {concatenation " ; " of lines of file (parameter "manifest")}

end prefetch block


administrator add

This command lets you appoint specific people to administer specific BES Clients. This is accomplished by using a setting with an an effective date, passed as a parameter. The date is not optional. The effective date tests are the same as for ordinary settings.

Syntax

administrator add <administrator name> on <date>

Example

administrator add "bob" on "21 Aug 2002 17:39:14 gmt"

Allows the BES Console operator named bob to have administrative rights on the targeted computer(s), effective on the given date.

BES 5.1 and above


administrator delete

This command allows you to remove administrative rights for the specified administrator. This is accomplished by using a setting with an an effective date, passed as a parameter. The date is not optional. The effective date tests are the same as for ordinary settings.

Syntax

administrator delete <administrator name> on <date>

Example

administrator delete "bob" on "21 Aug 2002 17:39:14 gmt"

Removes the administrative rights of the BES Console operator named bob, effective on the given date.

BES 5.1 and above


module add

Adds the specified inspector library file to the set of inspector libraries to be used by the client. When replacing an inspector library, you must specify it in a module delete command as well as specifying it in the module add command. To complete the action you must issue a module commit command.

Syntax

module add "<module name>"

Example

module add "dellinspect.dll"

Note

For internal BigFix use only.

BES 5.1 and above


module commit

The add and delete commands set the stage for committing changes to the inspector libraries. The commit command performs the actual deletion and addition.

Syntax

module commit

Example

delete "dellinspect.dll"

copy "{pathname of client folder of site "dell"}\dellinspect.dll""dellinspect.dll"

module add "dellinspect.dll"

module commit

Note

For internal BigFix use only.

BES 5.1 and above


module delete

Marks the specified inspector library file for deletion. To complete the action you must issue a module commit command.

Syntax

module delete "<module name>"

Example

module delete "inspectors.dll"

Note

For internal BigFix use only.

BES 5.1 and above


double forwardslash

Lines beginning with // are comments and are ignored during action execution.

Syntax

//

Example

// The following command will replace the file on the C drive:

copy "{name of drive of windows folder}\win.com" "{name of drive of windows folder}\bigsoftware\win.com"

The double slashes allow you to comment your action scripts.

BES 5.1 and above


action launch preference low-priority

When this command is executed, subsequent Action commands that launch programs will do so with lower priority than normal. This will help to mitigate the impact of large patches or service pack upgrades.

low-priority preference only effects the launch priority of applications launched from the current action. This preference is maintained until the action completes or the client executes the action launch preference normal-priority command.

Syntax

action launch preference low-priority

Examples

action launch preference low-priority

run "{pathname of regapp "background_app.exe"}"

action launch preference normal-priority

This example lowers the launch priority before running background_app so that it will not dominate the system when it executes. It then sets the priority level back to normal.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

BES 6.0 and above -- Windows Only


action launch preference normal-priority

When this command is executed, subsequent Action commands that launch programs will do so with normal-priority. This statement is only needed to return the priority to normal after an action launch preference low-priority command.

Syntax

action launch preference normal-priority

Examples

action launch preference low-priority

run "{pathname of regapp "background_app.exe"}"

action launch preference normal-priority

This example lowers the launch priority before running background_app, then returns the priority to normal for subsequent launch statements.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

BES 6.0 and above -- Windows Only


dos

Issues a standard DOS command. If the DOS command fails, the action script that contains it is terminated.

Syntax

dos <DOS command line>

Example

dos rmdir /Q /S "{pathname of windows folder & "\temp\BigFixQ"}"

This example deletes an empty directory from a temporary folder in the windows directory.

dos scandisk.exe e:

In this example, e: is a parameter passed to the scandisk program.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

On a Windows system, this has the same effect as issuing a system (Dos command line syntax) statement from the Windows API. It is also the same as typing the DOS command line to a DOS prompt. The DOS command uses the PATH environment variable to try to locate the command on the user’s hard drive. As with any other DOS command, for other locations you must specify a complete pathname.

Be sure to use quotes if you have spaces in the filenames.

BES 5.1 and above -- Windows Only


notify client ForceRefresh

This command is equivalent to right clicking on a Client computer in the BES Console and selecting Send Refresh. This command may be necessary if the UDP connection to the BES Client is blocked.

Syntax

notify client ForceRefresh

BES 6.0.14 and above


run

Executes the indicated program. If the process can’t be created, the action script is terminated. Run does not wait for the process to terminate before executing the next line of the action script. The command line contains the name of the executable and may optionally contain parameters. If you wish to wait for one program to finish before starting another one, use the wait command.

Syntax

run <command line>

Examples

run "{pathname of regapp "wordpad.exe"}"

run "c:\winnt\ftp.exe" ftp.mycorp.net

run wscript /e:vbs x.vbs arg1 arg2

These examples show how you might run a script and pass it some arguments. Quotes around the command line are recommended, and necessary if there are spaces in file names.

Note

On a Windows computer, this command has the same effect as calling the CreateProcess API with <command line>. This is also the same as using <command line> in the Windows RUN dialog. See the Windows documentation on CreateProcess for a discussion of the method used to locate the executable from a <command line>.

BES 5.1 and above


rundetached

Rundetached is used to prevent pop-up DOS windows when you execute a program. It's the same as the run command, but the process created doesn't access the parent's console, which inhibits the distracting DOS window. Rundetached should not be used for running interactive programs. If this is done, the interactive program will not be able to show its user interface and may appear to be hung. This command is provided strictly for running programs that do not display a user interface.

Syntax

rundetached <command line>

Examples

rundetached "{pathname of regapp "background_app.exe"}"

rundetached "c:\winnt\ftp.exe" ftp.filesite.net

These examples show how you might run a program and pass it some arguments. Quotes around the command line are recommended, and necessary if there are spaces in file names.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

On a Windows computer, this command has the same effect as issuing a CreateProcess (CommandLine) statement from the Windows API. This is also the same as using CommandLine in the Windows RUN dialog. See the Windows documentation on CreateProcess for a discussion of the method used to locate the executable from a CommandLine.

BES 5.1 and above -- Windows Only


runhidden

This command uses CreateProcess to launch a command in a hidden window. It hides the window by setting the STARTUPINFO dwFlag to STARTF_USESHOWWINDOW and setting wShowWindow to SW_HIDE. After launching, the next action command line is executed. To wait for the launch to complete before continuing the action, use the waithidden command.

Syntax

runhidden <command line>

Examples

runhidden "{pathname of regapp "wordpad.exe"}"

runhidden "c:\winnt\ftp.exe" ftp.mycorp.net

runhidden wscript /e:vbs x.vbs arg1 arg2

These examples show how you might run a script in a hidden window and pass it some arguments. Quotes around the command line are recommended, and necessary if there are spaces in the file names.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

If the launched process requires user input, it will wait for it with its window hidden, unless the command explicitly shows its window.

On a Windows computer, this command has the same effect as calling the CreateProcess API with <command line> and setting the flags to hide the window. See the Windows documentation on CreateProcess for a discussion of the method used to locate the executable from a <command line>.

BES 6.0 and above -- Windows Only


script

Not to be confused with an action script, the script keyword executes an external script (created for a scripting language like JavaScript or Visual Basic) with the given name. The action script containing the script keyword will terminate if the appropriate scripting engine is not installed or if the script cannot be executed. The next line of the Action Shell Command is not executed until the specified script terminates.

Syntax

script <script name>

Example

script attrib.vbs

Runs the Visual BASIC script attrib.vbs.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

On a Windows computer, this command has the same effect as issuing a wscript "scriptName" statement from Windows, and then waiting for completion. This is also the same as using scriptName from the Windows RUN dialog. If you need to pass parameters to your script, use the run command instead.

BES 5.1 and above -- Windows Only


wait

The wait command behaves the same as the run command, except that it waits for the completion of the process or program before continuing.

Syntax

wait <command line>

Example

wait "scandskw.exe"

Runs the scandskw program and waits for the program to complete before continuing with the Action script. The use of quotes is recommended practice, and necessary if there are spaces in the file name.

Note

On a Windows computer, this has the same effect as issuing a CreateProcess <command line> statement from the Windows API, and then waiting for completion.

BES 5.1 and above


waitdetached

Waitdetached is used to prevent pop-up DOS windows when waiting for a program to complete. It's the same as the wait command, but the process created doesn't access the parent's console, inhibiting the distracting DOS window. Rundetached should not be used for running interactive programs. If this is done, the interactive program will not be able to show its user interface and may appear to be hung. This command is provided strictly for running programs that do not display a user interface.

Syntax

waitdetached <command line>

Example

waitdetached "scandskw.exe"

waitdetached wscript /e:vbs x.vbs arg1 arg2

This example shows how you might run a script, pass it some arguments and then wait for its completion before continuing the Action script.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

On a Windows computer, this has the same effect as issuing a CreateProcess (CommandLine) statement from the Windows API, and then waiting for completion.

BES 5.1 and above -- Windows Only


waithidden

This command is similar to the runhidden command and uses CreateProcess to execute a command in a hidden window. It hides the window by setting the STARTUPINFO dwFlag to STARTF_USESHOWWINDOW and setting wShowWindow to SW_HIDE. This action waits for the completion of the process before continuing with subsequent action commands.

Syntax

waithidden <command line>

Examples

waithidden "{pathname of regapp "notepad.exe"}"

waithidden "c:\winnt\ftp.exe" ftp.myurl.net

waithidden wscript /e:vbs x.vbs arg1 arg2

These examples show how you might run a script in a hidden window and pass it some arguments. Quotes around the command line are recommended, and necessary if there are spaces in the file names.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

If the launched process requires user input, it will wait for it with its window hidden, unless the command explicitly shows its window.

On a Windows computer, this command has the same effect as calling the CreateProcess API with <command line> and setting the flags to hide the window. See the Windows documentation on CreateProcess for a discussion of the method used to locate the executable from a <command line>.

BES 6.0 and above -- Windows Only


add nohash prefetch item

Adds a download item to the prefetch queue. This command must reside between a begin prefetch block and an end prefetch block command. This is a singular command -- it can only specify a single download at a time. Relevance substitution is not allowed, permitting the BigFix Server to cache the download when the Action is created. If the BigFix Client requests any ordinal files, the Relay will collect them all. The BigFix Client will only download the item if this command is in a TRUE condition block.

Syntax

add nohash prefetch item [name=<n>] [size=<s>] url=<u>

Where:

<n> is an optional name, limited to 32 characters (including alphanumerics, dashes, underlines and non-leading periods). If no name is explicitly specified, the name will be derived from the final component of the URL (following the final slash). Only one download item can be specified per command.

<s> is an optional file size. Although it is not required, when it is known and specified, the program can provide meaningful progress information.

<u> is a required url. If the name is not specified, then it will be derived from final component of the supplied URL.

Relevance substitution is not allowed with the arguments of this command. The arguments may be in any order desired, but unrecognized commands will generate a syntax error.

Clients and Relays will collect these files by Action ID and ordinal number. An sha1 is not allowed with this prefetch command. To use sha1, use the add prefetch item command. This technique is preferred because it identifies the exact file to use, rather than any file provided by the URL.

Example

begin prefetch block

add nohash prefetch item url=http://www.mysite/downloads/download25.exe

end prefetch block

wait {download path "download25.exe"}

This example uses a static download in a prefetch block and retrieves it without a hash. This technique is intrinsically insecure, but it uses a white-list on the BigFix server to validate the URL.

BES 7.2 and above


add prefetch item

Adds a download item to the prefetch queue. This command must reside between a begin prefetch block and an end prefetch block command. This is a plural command -- it can specify multiple downloads separated by semicolons.

The BigFix Server will cache the download when the Action is created, unless relevance substitution is employed. BigFix Relays only collect those files that the Clients request, and the Clients will only request a file if the command is inside a TRUE condition block.

Instead of listing the download items in the command line, you can put them in a file (one item per line) and then use a relevance substitution like the following:

{concatenation ";" of lines of file <your file>}

This is a common usage when specifying a file in a Fixlet site that contains the download information.

add prefetch item [name=<n>] sha1=<h> size=<s> url=<u> [; ...]

Where:

<n> is an optional name, limited to alphanumerics, dashes, underlines and non-leading period characters. If no name is explicitly specified, the name will be derived from the final component of the URL (following the final slash).

<h> is the required sha1 for the specified file.

<s> is the required file size.

<u> is a required url. If the name is not specified, then it will be derived from final component of the supplied URL.

[; ...] denotes that the command is plural; extra files can be specified, with each separated by a semicolon.

Relevance substitution is allowed with the arguments of this command; however when substitution is used, the BigFix Server can't cache the download item at action creation time.

The arguments may be in any order desired, and unrecognized arguments will be ignored.

When used without relevance substitution, BigFix clients and relays will collect these files by ActionID and ordinal. When used with relevance substitution, clients and relays will collect these files by URL and sha1. To specify a download without specifying the sha1, use the add nohash prefetch item command.

Example

begin prefetch block

if {name of operating system = "Windows 2000"}

add prefetch item {"name=up.exe sha1=12 size=45 url=http://ms.com/hot2k.exe"}

else

add prefetch item {"name=up.exe sha1=12 size=45 url=http://ms.com/hot.exe"}

endif

end prefetch block

wait {download path "up.exe"}

This example demonstrates a conditional download in a prefetch block. By checking the OS first, only the proper file will be prefetched, potentially saving considerable time and bandwidth.

BES 7.2 and above


appendfile

The appendfile command creates a text file named __appendfile in the site directory (by default C:\Program Files\BigFix\__Data\<site name>). Each time you invoke the command, it appends the specified text to the end of the file. This command may be useful for creating diagnostic files or dynamically building files that incorporate attributes of the end-user’s machine. This file is automatically deleted when the Action Shell Commands begin.

Syntax

appendfile <text>

Where text represents information to be placed in the file.

Examples

appendfile This file will contain details about your computer

appendfile Operating System={name of operating system}

appendfile Windows is installed on the {location of windows folder} drive

The above commands record the OS and Windows location in the append file

appendfile {("Disk " & name of it & ", free space=" & free space of it as string) of drives}

The above example records the name and the free space available for all the drives on the client PC.

Note

Use the appendfile command as part of an action that builds a script which is subsequently passed to a script interpreter. For example, you can use the following syntax to create an .ini file using BigFix Action commands:

appendfile [HKR]

appendfile HostBasedModemData\Parameters\Driver,ModemOn,1,00,00

delete {location of system folder}\smcfg.ini

copy __appendfile {location of system folder}\smcfg.ini

run smcfg

This same technique can be used to build .bat files, .cmd files, visual basic scripts, bash shell scripts, etc.

BES 5.1 and above


archive now

This command invokes the Archive Manager. If the Archive Operating Mode is set to manual, this command will trigger archiving and uploading of the configured set of files. To set the appropriate archive mode to manual, use this setting:

_BESClient_ArchiveManager_OperatingMode = 2

The archive now command will return a status of Failed if the operating mode is not set to manual. It will also return Failed if an existing archive is currently being uploaded.

Syntax

archive now

Examples

archive now

This command initiates archiving and uploading of the configured set of files.

BES 5.1 and above


begin prefetch block

Starts a set of commands to download files. Normally, when you download a file using BigFix actions, the checksum is evaluated to guarantee authenticity. However, if the target of your download is in flux, such as an anti-virus definition, that requirement may be too restricting. To handle a case like this, BigFix provides dynamic download commands, which are bracketed by begin prefetch block and end prefetch block. For more information, see Introducing the Prefetch Block and Introducing Dynamic Downloads.

This feature is tightly integrated with your BigFix relay structure, optimizing download speeds and bandwidth. When an Action requests a file, the relay checks its cache, and immediately forwards the file if available. Otherwise, the request is passed up the line until it reaches the BigFix server.

Dynamic downloading uses a white-list located at <BES Server Install Path>\Mirror Server\Config\DownloadWhitelist.txt to ensure that only trusted sites are accessed. This file contains a list of URLs formatted as regular expressions, such as http://.*\.mysite\.com/.*. The URL you provide in a prefetch statement must match an entry in the white-list before it can be downloaded. If the URL isn't found in the list, the command fails with NotAvailable error.

These existing commands are allowed within the prefetch block:

// comment lines and blank lines
if/elseif/else/endif
parameter
action parameter query (treated as a comment by the client)

The following new commands are allowed within the prefetch block, but are not allowed outside of it:

add prefetch item
add nohash prefetch item
collect prefetch items
execute prefetch plug-in

Syntax

begin prefetch block

Only one prefetch command block can be used in an Action script and it must be closed with an end prefetch block command.

Only comments or blank lines are allowed to precede this command. When processing actions with prefetch blocks, download, download as and prefetch are not allowed anywhere in the action script. The download now as command is allowed, but not inside or before the prefetch block.

Example

// action script to automatically update a URL manifest from a custom site

begin prefetch block

parameter "ini"="{file "server_bf.ini" of site (value of setting "MyCustomSite") of client}"

// prefetch the plug-in that provides the download list

add prefetch item name=plugin.exe sha1=123 size=12 url=http://www.mysite/downloads/myplugin.exe

// collect above prefetch file (needed to create a manifest composed of URLs)

collect prefetch items

// execute the plug-in that produces a manifest from the ini data file

execute prefetch plug-in "{download path "plugin.exe"}" /downloads "{parameter "ini"}" "{download path "urllist"}"

// URL manifest formatted as lines containing: name=<n> sha1=<h> size=<s> url=<url>

add prefetch item {concatentation " ; " of lines of download file "urllist"}

end prefetch block

// action is now active, update the files:

waithidden "{download path "plugin.exe"}" /update "{parameter "ini"}" "{location of download folder}"

This example downloads a plug-in that processes another file to produce a manifest containing a list of more files to download. When the prefetch block ends, the files have been downloaded and moved to the download folder and the rest of the Action can continue.

Notes:

Older consoles and clients will reject action scripts that use the new prefetch functionality and identify them as containing syntax errors. Older relays will not process dynamic download actions even if the server and clients can handle it.

Only one prefetch block is allowed in an Action script.

Certain commands must not appear anywhere in an Action script that contains a prefetch block: download, download as and prefetch. Download now may appear in the script, but it must come after the prefetch block.

Several new inspectors have been added to allow action script to reference download files using relevance substitution. These include download path “<name>”, download file “<name>”, and download folder. See the Inspector Guide for more information.

BES 7.2 and above


collect prefetch items

After items have been added to the prefetch queue by commands such as add nohash prefetch items and add prefetch items, this command collects those items from the BigFix Relay. The Action is suspended until all the specified files are collected. If the add prefetch command has provided the downloads with new names, they will be renamed at this point.

This command is typically used to retrieve a set of files that can subsequently be processed by a plug-in. In this case, a file is first added to the prefetch list, collected, and then processed by a subsequent execute prefetch plug-in command, which might create a file containing additional downloads. Each collect prefetch items command is treated as a synchronization point, causing the Action to wait for the files to download before proceeding. Once the files are available, the Action is reprocessed from the beginning. This allows the Action to compensate for any files that may have changed due to altered conditions on the machine. The next command in the action will be processed only after the collect prefetch items command is executed and all files in the prefetch list have been downloaded.

The end prefetch block command does an automatic collection, ensuring that subsequent Action commands will have the necessary files at hand.

Once the files have been collected, they can be examined with some new Inspectors which may have different interpretations, depending on whether the Action is active or not. For more information on these Inspectors, see Introducing Dynamic Downloads.

Syntax

collect prefetch items

Example

begin prefetch block

parameter "ini"="{file "server_bf.ini" of site (value of setting "MyCustomSite") of client}"

add prefetch item name=myPlugIn.exe sha1=12 size=12 url=http://mysite/plugin.exe

// collect the plugin before continuing:

collect prefetch items

execute prefetch plug-in "{download path "myPlugIn.exe"}" /downloads "{parameter "ini"}" "{download path "urllist"}"

add prefetch item {concatentation " ; " of lines of download file "urllist"}

end prefetch block

In this example, the collect statement ensures that the plug-in has been successfully downloaded before proceeding with the rest of the prefetch block.

BES 7.2 and above


copy

Copies the source file to the named destination file. An action script with the copy command terminates if the destination already exists or if the copy fails for any other reason (such as when the destination file is busy).

Syntax

copy <Source_FileName> <Destination_FileName>

Where Source_Filename and Destination_Filename are the names of the files to copy from and to respectively (typically enclosed in quotes).

Examples

copy "{name of drive of windows folder}\win.com" "{name of drive of windows folder}\bigsoftware\win.com"

This command copies the win.com file to the bigsoftware folder.

delete "c:\windows\system\windir.dll"

copy " __Download\windir.dll" "c:\windows\system\windir.dll"

This pair of Action Shell Commands deletes the target file (if it exists) before it performs the copy action.

BES 5.1 and above


createfile until

This command creates a text file named __createfile in the site directory. It allows you to fill a file with a series of statements up to a terminating string. The form of the command is as follows:

createfile until <end-delim-string>

line 1

line 2

...

end-delim-string

NOTE: make sure that the lines labeled 'line 1, line 2, …' do not unintentionally contain the end-delim-string. If they do, the action parser will begin looking for action commands after the first instance of the end-delim-string.

Syntax

createfile until <delimiter>

statements

delimiter

Examples

parameter "config" = "{pathname of folder (value of variable "tmp" of environment)}\config.txt"

createfile until end

Operating system = {name of operating system}

Processor count = {number of processors}

end

delete "{parameter "config"}"

copy __createfile "{parameter "config"}"

Defines a parameter named "config" that contains the pathname of a config file in the tmp folder, creates a new name=value file containing the operating system and processor count, deletes the config file from the tmp folder and replaces it with the new file.

BES 6.0 and above -- Windows Only


delete

Deletes the named file. Any Action script with the delete command will terminate if the file exists but cannot be deleted. This can happen due to write protection or an attempt to delete from a CD-ROM, for instance. If the file does not exist at all, however, the action script will continue to execute.

Syntax

delete <FileName>

Where FileName is the name of the file to delete (typically enclosed in quotes). Relevance substitution is performed on the arguments of delete action command lines.

Examples

delete "c:\program files\bigsoftware\module.dll"

delete "{name of drive of windows folder}\win.com"

These examples delete the specified files. Note that you can use variable substitution (in curly brackets) to specify pathnames.

Note

It’s good practice to enclose filenames in quotes to preserve spaces in the filenames. Without quotes, the file system will not be able to access those files with spaces in the path or file name.

BES 5.1 and above


download

Downloads the file indicated by the URL. This command is included for backward compatibility for the BigFix Client Edition, version 2.0 and it continues to be supported in BES 6.0 to properly handle existing BES actions. For all other applications, this command has been superseded by the download as and download now as commands.

After downloading, the file is saved in a folder named "__Download" (the folder name begins with two underscores) relative to the local folder of the Fixlet Site that issued the download command.

If the download fails, the action script terminates. The name of the file is derived from the part of the URL after the last slash.

For instance, consider the command:

download ftp://ftp.microsoft.com/deskapps/readme.txt

The action example above downloads the readme.txt file from the Microsoft site and automatically saves it in the local __Download folder as readme.txt.

The filename is derived from the URL. Everything after the final '/' or '\' character is considered to be the filename. This may occasionally generate a problematic filename, for instance:

URL: http://skdkdk.ddddd.com/cgi-bin/xyz?jjj=yyy

results in a file named xyz?jjj=yyy, which is not a valid filename. You can usually work around this inconvenience by adding a dummy argument to the end of the URL:

http://skdkdk.ddddd.com/cgi-bin/xyz?jjj=yyy?file=/ddd.txt

which will result in a file named ddd.txt being saved to the __Download directory. The download as and prefetch commands can also be used to address this situation.

Syntax

download [option] <File_URL>

Where the [options] preface can be one of two optional keywords:

open: calls the ShellExecute API, passing the resulting filename once the download completes.

now: tells the BES agent to start the download at that point in the execution of the action, as opposed to pre-fetching it before the action begins. The agent will attempt to collect the download directly from the specified URL instead of going through the relay system.

The File_URL is the location of the file to download.

Examples

download http://download.bigfix.com/update/bfxxxx.exe

Prefetches the bfxxxx.exe file from the BigFix site, and directs the downloaded file to the default site "__Download" folder.

download open http://download.bigfix.com/update/bfxxxx.exe

Prefetches and saves the bfxxxx.exe file to the default site "__Download" folder and executes the program once the download completes.

download now http://download.bigfix.com/update/bfxxxx.exe

Downloads the bfxxxx.exe file from the BigFix site as soon as the command is executed.

download "http://download.microsoft.com/download/prog.exe"

run "__Download\prog.exe"

This set of actions automates the download process, reducing the application of an executable patch to a single click. Note that the downloaded program is run from the ‘__Download’ directory of the Fixlet site, where the download command places it. The Fixlet site directory is the working directory for all commands and the __Download directory is located there.

Note:

Relevance substitution is NOT performed on the download action command lines. This is because these actions are scanned by other components that deliver the downloads and these other components run on different machines which do not share those client's evaluation context. This restriction, however, allows BES to prefetch downloads through a relay hierarchy to the clients.

BES 5.1 and above


download as

Downloads the file indicated by the URL and allows you to rename it. After downloading, the file is saved in a folder named "__Download" (the folder name begins with two underscores) relative to the local folder of the Fixlet Site that issued the download as command.

For instance, consider the command:

download as intro.txt ftp://ftp.microsoft.com/deskapps/readme.txt

The action example above downloads the readme.txt file from the Microsoft site and automatically saves it in the local __Download folder as intro.txt. If the download fails, the action script terminates.

This command, when accompanied by a continue if with an sha1 value, allows the file to be pre-fetched.

Syntax

download as <name> <url>

Where name is a simple filename, without special characters or path delimiters. If the name violates any of the following rules, the download command will fail:

  • Name must be 32 characters or less.

  • Name must only be composed of ASCII characters a-z, A-Z, 0-9, -, _, and non-leading periods.

    • Here url is the complete URL of the specified file.

    Examples

    download as myprog.exe http://www.website.com/update/prog555.exe

    Downloads the prog555.exe file from the specified folder on the web site, directs the downloaded file to the action site "__Download" folder and renames it to myprog.exe.

    download as patch1 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/q307869_f323efa52f460ea1e5f4201b011c071ea5b95110.exe

    continue if {(size of it = 813160 and sha1 of it = "92c643875dda80022b3ce3f1ad580f62704b754f") of file "patch1" of folder "__Download"}

    Downloads the specified file, renames it patch1 and continues only if the size and sha1 are correct.

    Note:

    Relevance substitution is NOT performed on the download as action command lines. This is because these actions are scanned by other components that deliver the downloads and these other components run on different machines which do not share those client's evaluation context. This restriction, however, allows BES to prefetch downloads through a relay hierarchy to the clients.

    BES 6.0 and above -- Windows Only


download now as

Downloads the file indicated by the URL and allows you to rename it. After downloading, the file is saved in a folder named "__Download" (the folder name begins with two underscores) relative to the local folder of the Fixlet Site that issued the download now as command.

If the download fails, the action script terminates.

For instance, consider the command:

download now as intro.txt ftp://ftp.microsoft.com/deskapps/readme.txt

The action example above immediately downloads the readme.txt file from the Microsoft site and automatically saves it in the local __Download folder as intro.txt.

Syntax

download now as <name> <url>

Where name is a simple filename, without special characters or path delimiters. If the name violates any of the following rules, the download command will fail:

  • Name must be 32 characters or less.
  • Name must only be composed of ASCII characters a-z, A-Z, 0-9, -, _, and non-leading periods.

    • Here url is the complete URL of the specified file.

    Examples

    download now as myprog.exe http://www.website.com/update/prog555.exe

    Immediately downloads the prog555.exe file from the specified folder on the web site, directs the downloaded file to the action site "__Download" folder and names it myprog.exe.

    download now as patch2 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/q310507_2f3c5854999b7c58272a661d30743abca15caf5c.exe

    continue if {(size of it = 845416 and sha1 of it = "c964d4fd345b6e5fd73c2235ec75079b34e9b3d2") of file "patch2.exe" of folder "__Download"}

    Immediately downloads the specified file from the web site, directs the downloaded file to the action site "__Download" folder and names it patch2. The action continues only if the size and sha1 are correct.

    Note:

    Relevance substitution is NOT performed on the download now as action command lines. This is because these actions are scanned by other components that deliver the downloads and these other components run on different machines which do not share those client's evaluation context. This restriction, however, allows BES to prefetch downloads through a relay hierarchy to the clients.

    BES 6.0 and above -- Windows Only


end prefetch block

Marks the end of a set of dynamic download commands (see begin prefetch block). This command must be present whenever the begin prefetch block command is specified. This command automatically performs a collect prefetch items command, meaning that all the files added to the prefetch queue will be available when the block is ended.

Syntax

end prefetch block

Only one prefetch command block can be used in an Action script and it must be bracketed by a begin prefetch block command and an end prefetch block command.

Only comments or blank lines are allowed to precede this command. When processing actions with prefetch blocks, download as and prefetch are not allowed anywhere in the action script. The download now command is allowed after the prefetch block, but not before or inside the prefetch block.

begin prefetch block

add prefetch item sha1=123 size=456 url=http://ms.com/downloads/hotfix123.exe

end prefetch block

wait {download path "hotfix123.exe"}

This code demonstrates static downloading in a prefetch block. Although it doesn't take advantage of dynamic relevance substitution, this is the preferred format for downloads in versions 7.2 and later. Note that the end prefetch block command also collects the file (hotfix123.exe), so that the subsequent wait command -- which runs and waits for completion -- is guaranteed to have the file available.

Note:

Older consoles and clients will reject action scripts that use the new prefetch functionality and identify them as containing syntax errors. Older relays will not process dynamic download actions even if the server and clients can handle it.

BES 7.2 and above


execute prefetch plug-in

This command passes arguments to a named command and then executes it. It is not intended for a lengthy executable and the client will only wait 60 seconds for its completion. This command can be used to authenticate or execute downloads. It can also be used to execute custom logic that can create inspectable values for subsequent add prefetch item commands.

For use cases such as updating anti-virus definitions, this command can be used to run code that processes a file to produce another file containing a set of URLs to be downloaded.

Syntax

execute prefetch plug-in "executable pathname" <args>

Where:

"executable pathname" is the full pathname for the plug-in to execute. This command is designed for executables that are fast to execute and return promptly. The BigFix Client will block out 60 seconds of time while it waits for the command to complete; only a shutdown request can interrupt this waiting period. After 60 seconds, the BigFix Client will log a message and disable the command. When it is disabled, any actions that use this command will not execute until after the client has been restarted. In general it is expected that the command will complete much faster -- if it takes longer than two seconds to execute, the client will log an appropriate message. Relevance substitution can be used to specify the pathname.

<args> are arguments passed to the executable.

The exit code of the execute perfetch plug-in application is important as it informs the client of failure or success, where 0 (zero) indicates success and all other exit codes are treated as failures and result in a failed Action attempt. For debugging purposes, the exit code is recorded in the client log.

Example

begin prefetch block

parameter "ini_file"={file "server_bf.ini" of site (value of setting "MyCustomSite") of client}

add prefetch item name=plugin.exe sha1=123 size=12 url=http://mysite/myplugin.exe

collect prefetch items

// execute the plug-in to produce a manifest from the ini_file:

execute prefetch plug-in "{download path "plugin.exe"}" /downloads "{parameter "ini_file"}" "{download path "manifest"}"

add prefetch item {concatentation " ; " of lines of download file "manifest"}

end prefetch block

This example downloads a plug-in that processes the ini_file to produce a manifest.

BES 7.2 and above


extract

Extracts files from the specified archive in the download folder (__Download) and leaves the results in the same folder.

An archive file is similar to a compressed tar file. BigFix uses a tool called Archivewriter to construct the archive. This can be useful for copying an entire directory to a computer, which is often required by installers that contain multiple files along with a setup executable. There is a wizard in the BES Console that facilitates the distribution of directories that use this kind of archive.

Syntax

extract <Archive File>

Examples

extract InstallMyApp

Extracts the constituent files of InstallMyApp in the __Download folder, places the results back in the __Download folder and deletes the original InstallMyApp file.

BES 5.1 and above


move

Moves the source file to the named destination file. This command also gives the action author the ability to rename a file. An action script with the move command terminates if the destination already exists, if the source file doesn’t exist, or if the move fails for any other reason.

Syntax

move <Source_FileName> <Destination_FileName>

Where Source_Filename and Destination_Filename are the names of the files to move from and to respectively (typically enclosed in quotes).

Examples

move "c:\program files\bigsoftware\module.dll" "c:\temp\mod.dll"

This command moves and renames the mod.dll file. Note that quotes are necessary for file names and folder names with spaces in them.

delete "c:\updates\q312456.exe"

move "__Download\q312456.exe" "c:\updates\q312456.exe"

The command lines above first delete the file, then move it back in place from another location.

BES 5.1 and above


prefetch

The prefetch command allows a file to be downloaded before the action begins. You do not need a matching continue if statement for the file to be downloaded and checked in advance. The prefetch command is preferred over the download command.

For instance, consider the command:

prefetch a.exe sha1:0123456789012345678901234567890123456789 size:11723 http://x/z.exe

The action example above prefetches the z.exe file from the specified site and automatically saves it in the local __Download folder as a.exe.

Syntax

prefetch <name> sha1:<value> size:<value> <url>

Where name is a simple filename, without special characters or path delimiters. If the name violates any of the following rules, the prefetch command will fail:

  • Name must be 32 characters or less.
  • Name must only be composed of ASCII characters a-z, A-Z, 0-9, -, _, and non-leading periods.

    • Here sha1:value represents the secure hash algorithm value, size:value represents the size of the file in bytes and url represents the location of the site, including the filename.

    Example

    prefetch patch3 sha1:92c643875dda80022b3ce3f1ad580f62704b754f size:813160 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/ q307869_f323efa52f460ea1e5f4201b011c071ea5b95110.exe

    This line of code prefetches the given file from the specified folder on the web site, directs the downloaded file to the action site "__Download" folder and renames it to patch3.

    if {name of operating system = "WinXP"}

    prefetch patch.exe sha1:92c643875dda80022b3ce3f1ad580f62704b754f size:813160 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/ q307869_f323efa52f460ea1e5f4201b011c071ea5b95110.exe

    else

    prefetch patch.exe sha1:c964d4fd345b6e5fd73c2235ec75079b34e9b3d2 size:845416 http://www.download.windowsupdate.com/msdownload/update/ v3-19990518/cabpool/q310507_2f3c5854999b7c58272a661d30743abca15caf5c.exe

    endif

    utility __Download\patch.exe

    wait __Download\patch.exe

    This code prefetches a file based on the operating system, saves the file to the utility cache as patch.exe and waits for its completion to continue the action.

    Note:

    Relevance substitution is NOT performed on the prefetch action command lines. This is because these actions are scanned by other components that deliver the downloads and these other components run on different machines which do not share those client's evaluation context. This restriction, however, allows BES to prefetch downloads through a relay hierarchy to the clients.

    BES 6.0 and above -- Windows Only


relay select

The relay select command forces the BES Client to select the nearest BES Relay if one is available. This command issues a request to the client to perform a relay selection at the next opportunity and always succeeds immediately, regardless of the success or failure of the pending relay selection.

Syntax

relay select

Examples

relay select

This command instructs the BES Client to search for and connect to the nearest relay.

BES 5.1 and above


utility

The utility command can be used to place commonly used programs into a special cache. As an example:

utility __Download/RunQuiet.exe

This places the common RunQuiet program into the utility cache to avoid downloading it multiple times.

The 6.0 clients maintain two disk caches; one for utility programs and another for action payloads. Files arriving in the action payload cache will not push files out of the utilities cache and vice versa.

The 6.0 clients use the sha1 value of an action download to locate any matching utility (such as ‘RunQuiet’) that already exists on the client.

An action-specific folder is created to contain downloads as they are pre-fetched. Existing files that match the sha1 values don't need to be downloaded again. Any other files will be pre-fetched from the parent relay. When all the downloads are available on the client, the files will be moved from the action-specific folder (this is a change from pre 6.0 client behavior) to the __Download folder of the action site and the action will be started.

When the action completes, any files left in the __Download folder that were pre-fetched with sha1 will be candidates for utility caching. These files will have their sha1 values re-computed and any files with matching sha1 values can be moved into the utility cache.

A least-recently used scheme is used to keep the cache within its size limits. For short intervals only, the cache limit may be exceeded by single files.

Syntax

utility <pathname>

Example

prefetch patch.exe sha1:92c643875dda80022b3ce3f1ad580f62704b754f
__size:813160 http://www.download.windowsupdate.com/msdownload/update/v3-
__19990518/cabpool/q307869_f323efa52f460ea1e5f4201b011c071ea5b95110.exe

utility __Download\patch.exe

wait __Download\patch.exe

This example prefetches a file, saves the file to the utility cache as patch.exe and waits for its completion to continue the action.

BES 6.0 and above -- Windows Only


action may require restart

When this command is executed, the client looks at the system for telltale signs that a restart is needed. If so, it sets the action completion status such that the action will appear as 'Pending Restart' in the console, until a restart occurs. Once the restart is completed, the action completion status of the action will take on the value of ‘success’ if the relevance of the action is no longer relevant, or ‘failed’ if it is still relevant.

If the telltale signs of restart are not present, the action completion status of the action will take on the value of ‘success’ if the relevance of the action is no longer relevant, or ‘failed’ if it is still relevant.

Syntax

action may require restart

Example

action may require restart

BES 5.1 and above


action parameter query

This allows data entry of parameters to be available via relevance during action execution. Parameter names may include blanks, and are case sensitive. The parameter name, description, and value must each be enclosed inside double quotation marks ("). Once entered, the user input becomes the default in subsequent invocations (for BES, the user is the console operator approving the action for deployment).

Syntax

action parameter query "<parameter name>" [with description "<description>"] [and] [with default [value] "<default value>"]

Where parameter name is the name of the relevance parameter and the with description option lets you present a prompt to the user. The and with default option lets you specify a default value for the parameter.

Examples

action parameter query "InstallationPoint" with description "Please enter the location of the shared installation point:"

action parameter query "Registry key" with description "Please enter your desired registry key" and with default value "null"

action parameter query "tips" with description "Enter ‘on’ or ‘off’ to control Fixlet tips." With default "on"
regset "[HKEY_CURRENT_USER\Software\BigFix]" "tips"="{parameter "tips" of action}"

Note

The parameter values input by the user may include %xx where xx stands for a two-digit hexadecimal number to specify the character you want to embed. To embed a percent sign, use %25. To embed a double quote, use %22.

While the action is executing, you can retrieve the action parameter value entered by the console operator. For example, in your action you could use relevance substitution: {parameter "parameter name" of action}.

Relevance substitution is NOT performed on the action parameter query command line itself. This is because the command is interpreted in the BES console before the action is sent out, allowing the Fixlet author to ask the operator for deployment-specific parameters needed to run the action.

BES 5.1 and above


action requires login

This command informs the client that the current action will not be completed until the computer is restarted and an administrator logs in. Once this action has been completed on a machine, the inspector pending login will return true.

Syntax

action requires login

Example

action requires login

Note

This Action is ignored by BES Unix agents.

BES 5.1 and above


action requires restart

This command informs the client that the current action will not be completed until the next restart completes. Once this action has been completed on a machine, the inspector ‘pending restart’ will return ‘True’. If there is an ‘action requires restart’ command in an action, the BigFix Enterprise Console will report ‘Pending Restart’ until the affected machine is restarted.

Syntax

action requires restart

Example

action requires restart

BES 5.1 and above


continue if

This command allows the next line in the script to be executed if the value provided as a parameter evaluates to true. It will stop without error if the specified value evaluates to false. You can use relevance substitution to compute the value. This command is useful in making sure that certain conditions are met to run the remainder of an action. The line number where the action script exited is reported to the console. Users of BES can use this line number to identify why an action is failing if you insert a continue if statement that identifies an invariant required by your action.

Syntax

continue if <true condition>

Where true condition represents a relevance expression to evaluate.

Examples

continue if {name of operating system = "Win2k"}

download now http://www.real-time.com/downloads/win98/dun40.exe

This example will download the dun40.exe file only if the operating system is Win 2000.

continue if {(size of it = 325 and sha1 of it = "013e48a5") of file "dun40.exe" of folder "__Download"}

wait __Download/dun40.exe /Q:A /R:N

This example will run the dun40.exe file only if the size and sha1 value are as specified.

BES 5.1 and above


if

if, elseif, else, endif

The if, elseif, else and endif commands allow conditional execution of your Action commands. These conditional statements operate on expressions in curly brackets as in the following schematic:

if {EXPR1}

statements to execute on EXPR1 = TRUE

elseif {EXPR2}

statements to execute on EXPR1 != TRUE and EXPR2 = TRUE

else

sstatements to execute when EXPR1 != TRUE and EXPR2 != TRUE

endif

In the action schematic above, if the expression in curly brackets following the if statement is true, the following statements (up to the endif statement) are evaluated. If blocks can be nested any number of levels deep.

Normal if block semantics are enforced. All statements up to an endif, elseif or else constitute a block. The elseif {EXPR} and else statements are optional. Any number of elseif statements may be used, but only one trailing else block.

A note about prefetching:

The BES Client parses Actions before it actually executes them, looking for downloads to prefetch. If the prefetching process doesn't parse properly, an action syntax error will be returned and the Action will not run. This can be problematic if you are creating Actions that work in multiple environments where only one branch of an if statement may parse correctly. For instance, you might want to load files that are unique to specific platforms. A script like this would seem to do the trick:

if {not exists key "foo" of registry}

prefetch windows_file ...

else if {not exists package "bar" of rpm}

prefetch unix_file ...

endif

Here a Windows registry key triggers the first prefetch, while a Unix package triggers the second. The problem is that the registry Inspector will fail on Unix systems, and the package Inspector will fail on Windows, causing the prefetch parser to throw an error in both cases. The answer here is to use cross-platform inspectors (such as "name of operating system") to make sure the wrong blocks are not evaluated:

if {name of operating system starts with "Win"}

if {not exists key "foo" of registry}

prefetch windows_file ...

endif

else if {name of operating system starts with "Redhat"}

if {not exists package "bar" of rpm}

prefetch unix_file ...

endif

Endif

By checking first for the proper operating system, you can avoid this type of prefetch parse error. However, sometimes there may be no way to avoid a potential error. For instance, an Action may create and access a file that doesn't yet exist in the prefetch phase:

wait chkntfs c: > c:\output.txt

if {line 2 of file "c:\output.txt" as lowercase contains "not dirty"}

regset "HKLM\Software\MyCompany\" "Last NTFS Check"="OK"

else

regset "HKLM\Software\MyCompany\" "Last NTFS Check"="FAIL"

endif

In this Windows example, the output file doesn't exist until the script is actually executed. The prefetch parser will notice that the file doesn't exist when it checks for its contents. It will then throw an error and terminate the Action. However, you can adjust the if-condition to allow the prefetch pass to succeed. One technique is to use the "not active of action" expression which always returns TRUE during the prefetch pass. You can use this to avoid the problematic block during the pre-parse:

wait chkntfs c: > c:\output.txt

if {not active of action OR (line 2 of file "c:\output.txt" as lowercase contains "not dirty")}

regset "HKLM\Software\MyCompany\" "Last NTFS Check"="OK"

else

regset "HKLM\Software\MyCompany\" "Last NTFS Check"="FAIL"

endif

By checking first to see whether the Action is being pre-parsed or executed, you get a successful prefetch pass and the desired behavior when the action is running.

Syntax

if {<expression>}

<statements>

endif

Example

if {name of operating system = "WinME"}

prefetch patch1.exe sha1:e6dd60e1e2d4d25354b339ea893f6511581276fd size:4389760 http://download.microsoft.com/download/whistler/Install/310994/WIN98MeXP/EN-US/WinXP_EN_PRO_BF.EXE

wait __Download\patch1.exe

elseif {name of operating system = "WinXP"}

prefetch patch2.exe sha1:92c643875dda80022b3ce3f1ad580f62704b754f size:813160 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/q307869_f323efa52f460ea1e5f4201b011c071ea5b95110.exe

wait __Download\patch2.exe

else

prefetch patch3.exe sha1:c964d4fd345b6e5fd73c2235ec75079b34e9b3d2 size:845416 http://www.download.windowsupdate.com/msdownload/update/v3-19990518/cabpool/q310507_2f3c5854999b7c58272a661d30743abca15caf5c.exe

wait __Download\patch3.exe

endif

This code snippet prefetches, renames and downloads a file, based on the operating system.

BES 6.0 and above


parameter

The parameter command can be used to create new action variables during the execution of the action. It takes the form:

parameter "x" = "{expression}"

This command allows you to access the parameter using the inspector parameter "x". The parameter is only inspectable within the current action. Parameters are initialized just prior to the startup of the action from headers added to the action by the BES Console.

You can't reset a parameter that already has a value. When this occurs, the client will abort the action at the line that is attempting to reset the parameter. Any errors that result from evaluating the expression will be handled by making the named parameter become undefined.

The rules of the parameter command are:

  • Parameter expressions will be coerced into strings.

  • Plural expressions that result in no values will result in an empty parameter value.

  • Plural expressions that result in a single value that can be coerced into a string will assign the value.

  • Plural expressions that result in more than one value will result in a failure of the action.

Syntax

parameter "<x>" = "<{expression}>"

Where x is the name of the parameter and expression is the value. Note that both the name of the parameter and the expression must be inside quotes.

Example

parameter "loc" = "{pathname of folder (value of variable "tmp" of environment)}"

createfile until end

Operating system = {name of operating system}

Processor count = {number of processors}

end

delete "{parameter "loc"}\config.txt"

copy __createfile "{parameter "loc"}\config.txt"

Defines a parameter named "loc" that contains the pathname of the tmp folder, creates a new name=value file containing the operating system and processor count, deletes the config file from the tmp folder and replaces it with new file.

BES 6.0 and above


pause while

The action will not continue to the next command while the relevance expression specified evaluates to true. It will continue and execute the next command of the Action as soon as the value evaluates to false or the value fails to evaluate. Use relevance substitution syntax to define the condition.

Syntax

pause while <true condition>

Where true condition represents a relevance expression to evaluate.

Examples

pause while {exists running application "updater.exe"}

pause while {not exists file "C:\70sp3\result.log"}

pause while {not exists section "ResponseResult" of file "C:\70sp3\result.log"}

BES 5.1 and above


restart

The restart command will restart the computer. If the optional <delay seconds> parameter is provided, the shutdown will happen automatically after the specified delay.

If a user is logged in, a dialog will be displayed that shows the delay counting down. In this case, the interface will have a Restart Now button instead of a Cancel button.

If the delay parameter is not specified, the user is prompted to press a button to restart the computer.

Syntax

restart [<delay seconds>]

Where delay seconds is an optional parameter to provide a lag before restarting.

Example

restart 180

Restarts the computer in three minutes.

Note

The delayed restart is a forced restart; it will not prompt the user to save changes to documents, etc. The machine will restart without further prompting.

BES 5.1 and above


set clock

Causes the client to re-register with the registration server, and to sets its clock to the time received from the server during the interaction. This is useful when the client’s clock is out of sync. This BES-only command is not available when the client is operating under an evaluation license.

Syntax

set clock

Example

set clock

BES 5.1 and above


shutdown

The shutdown command is similar to the restart command, but it simply shuts the computer down and does not reboot.

If the optional <delay seconds> parameter is provided, the shutdown will happen automatically after the specified delay.

If a user is logged in, a UI will be displayed that shows the delay counting down. In this case, the UI will have a Shutdown Now button instead of a Cancel button.

If the delay parameter is not specified, the user is prompted to press a button to shut down the computer.

Syntax

shutdown [<delay seconds>]

Where delay seconds is an optional parameter to provide a lag before shutting down.

Example

shutdown 180

This command will shut down the computer in three minutes.

Note

The delayed shutdown is a forced shutdown; it will not prompt the user to save changes to documents, etc. The machine will shut down without further prompting.

BES 5.1 and above


action lock indefinite

Turns on the action lock, starting on the effective date, which will never expire. The date is in MIME time format (as in 15 Mar 2007 12:42:51 -0700).

Syntax

action lock indefinite "<effective date>"

Example

action lock indefinite "{now}"

Turns on the action lock immediately.

BES 5.1 and above


action lock until

Locks actions from the effective date until the expiration date occurs. The expiration date is MIME time format (as in 19 Jul 2007 12:42:51 -0700). You can use substitution with an Inspector like {now}, which will evaluate the time and insert it into the string.

Syntax

action lock until "<expire date>" "<effective date>"

Example

action lock until "{now + 3*days}" "{now}"

Locks actions immediately, unlocking them in three days.

action lock until "{apparent registration server time + 10 * minutes}" "{apparent registration server time}"

Locks actions for 10 minutes, using the current apparent registration server time, which is based on the last time the Client registered with the server.

BES 5.1 and above


action unlock

Unlocks the client to act upon any actions. The effective date field is used to insure that locking and unlocking actions take place in the order in which they were created. The date is in MIME time format (as in 29 Nov 2008 12:42:51 -0700).

Syntax

action unlock "<effective date>"

Example

action unlock "{now}"

Unlocks actions immediately.

BES 5.1 and above


regdelete

Deletes a registry key value of the given name, regardless of whether it currently exists or not.

Syntax

regdelete "<registry key>" "<value name>"

Where registry key is the name of the key and value name is the value in the registry key you wish to delete.

Example

regdelete "[HKEY_CLASSES_ROOT\ShellScrap]" "NeverShowExt"

Deletes the NeverShowExt value from the specified registry key.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

In order to delete a non-empty registry key and all its sub-keys, you need to create a file, say del.reg, that looks like this:

REGEDIT4

[-HKEY_CURRENT_USER\keep\removethisandbelow]

There should be three lines in this file: the last line must be a blank. Note the dash (-) in front of the registry path. Now you can execute an action like this:

regedit /s del.reg

When this action is executed, the key named removethisandbelow, along with all its sub-keys, is deleted. You can use the appendfile command to build this .reg file.

If the specified key doesn't already exist, it will be created by this command.

BES 5.1 and above -- Windows Only


regset

Sets a registry key to the given name and value. If the key doesn’t already exist, this command creates the key with this starting value.

Syntax

regset "<registry key>" "<value name>"=<value>

Where registry key is the key of interest and value name is the key value to set to value. These values are entered just as they are in a REGEDIT4 registry file, in keeping with the rules for Regedit, the Windows program that edits the registry. String values are delimited by quotes, and the standard 4-byte integer (dword) is identified using dword: followed by the numeric value entered in hexadecimal (with leading zeroes) as shown below.

Examples

regset "[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Security]" "Level"=dword:00000002

This example sets the Level value of the specified registry to a double-word 2.

regset "[HKEY_CURRENT_USER\Software\BigFix Inc.]" "testString"="bob"

This example sets the testString value of the specified registry key to bob.

regset "[HKEY_CLASSES_ROOT\ShellScrap]" "AlwaysShowExt"=""

This example clears the data of the specified registry value.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

Notice in these examples that square brackets [ ] are used to enclose the name of the registry key. Again, this is in keeping with the rules for REGEDIT4 registry files. This syntax is necessary for the RegSet command, but not for registry Inspectors.

When you use the BigFix regset command, keep in mind that the BigFix client dynamically builds the .reg file that you would have had to create manually to update the registry and then it executes that resulting .reg file for you. One of the rules of the .reg file is that any \’s in the value field need to appear as double slashes, that is \\. So if you were trying to assign the value SourcePath2 of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion to c:\I386, the command that you would define would look like this:

regset "[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]" "SourcePath2"="c:\\I386"

regset "[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]" "SourcePath2"={escape of "c:\I386"}

The last example uses the escape relevance clause to automatically convert backslashes to double backslashes.

In situations where you need to issue many regset commands, you might consider using the appendfile or createfile until commands to build a properly formatted regedit file, and then run regedit silently:

Createfile until end-reg-edit-commands

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion] "SourcePath1"="c:\\I386"

"SourcePath2"="{escapes of pathname of windows folder}"

end-reg-edit-commands

move __createfile setup.reg

wait regedit /s setup.reg

If the specified key doesn't already exist, it will be created by this command.

BES 5.1 and above -- Windows Only


setting

Settings are named values that can be applied to individual Fixlet sites or to client computers. Each setting has a time associated with it. This time stamp is used to establish priority -- the latest setting will trump any earlier ones.

Settings can be created and propagated by BES Console Operators. Settings issued by the BES Console will be tagged with the current time and date. Settings are separated into groups, including one for each site and one for the client. Each group of settings is independent of the others and is persistent on the client.

Settings can also be created by Actions in Fixlet messages, and typically use the substitution {now}, which is evaluated when the action is executed. You can examine these settings and their time stamps with Inspectors such as "effective date of <setting>" (see the Inspector Guides for more information).

Syntax

setting "<name>"="value" on "<date>" for client

setting "<name>"="value" on "<date>" for site "<sitename>"

Where name=value describes the setting, and date is a time-stamp used to establish priority. These can be set for the client computers or for a named site.

Examples

setting "name"="Bob" on "31 Jan 2007 21:09:36 gmt" for client

Sets the name variable to Bob on the client machine with a MIME date/time stamp provided by the BES Console when this setting was created. It will supersede any other name setting with an earlier date.

setting "preference"="red" on "{now}" for site "color_site"

Upon execution of the Action containing this command, {now} is evaluated as a MIME date/time and substituted into the string. This command sets the "preference" variable to "red" for the specified Fixlet site. Note that unless there are multiple sites with the same name, you can specify the site without the full gather URL. You may have a different "preference" setting on each site.

setting "time"="{now}" on "{now}" for current site

Immediately sets the time variable to the current time on the current site.

setting "division"="%22design group%22" on "15 Mar 2007 17:05:46 gmt" for client

This example uses %xx to indicate special characters by their hexadecimal equivalent. In this case, %22 encloses the value of the variable in double quotes.

Note

When a client is reset, the effective dates of the settings are removed and any subsequent setting commands will overwrite them. There are several ways that clients can be reset, including computer-ID collisions (most often caused by accidentally including the computer ID in an image that gets copied to multiple systems), changing an Action site masthead to a new server, or instructing the client to collect a new ID.

The Actions that run next will establish a new effective date, but the setting values will be the same as before the reset. The values are retained because they contain information such as relay selections. That way, when a deployment reset occurs, you don’t have to issue new actions to reset your network relay structure.

BES 5.1 and above


setting delete

This action deletes a named setting variable on the client computer. It includes a time stamp which will be compared to the time stamp on the original setting. If the delete date is later than the setting date, the setting will be deleted. Otherwise, the delete command will be ignored.

Syntax

setting delete "<name>" on "<date>" for client

setting "<name>" on "<date>" for site "<site_url>"

Where name describes the setting to delete, and date is when the setting will be deleted. Settings can be deleted on the client computers or on a named site.

Examples

setting delete "name" on "14 Apr 2007 21:09:36 gmt" for client

Deletes the "name" variable on the client machine if the time-stamp is later than the corresponding setting time. Otherwise, the delete command is ignored.

setting delete "abc" on "{now}" for site "siteurl"

Immediately deletes the "abc" variable on the specified site.

setting delete "abc" on "{now}" for current site

Immediately deletes the "abc" variable on the current site.

BES 5.1 and above


site force evaluation

Causes the client to re-evaluate all Fixlet messages for the site. This is useful after updating files or settings, to make sure that the Fixlet's relevance is recomputed for the entire site as soon as possible.

Syntax

site force evaluation

Example

site force evaluation

BES 5.1 and above


site gather schedule disable

This command disables scheduled gathering from the current site. It is ineffective for action sites.

Syntax

site gather schedule disable

Example

site gather schedule disable

BES 5.1 and above


site gather schedule manual

This command enables manual gathering from the current site. It is ineffective for action sites.

Syntax

site gather schedule manual

Example

site gather schedule manual

BES 5.1 and above


site gather schedule publisher

This command sets the schedule for gathering from the current site to that specified in the masthead for the site.

Syntax

site gather schedule publisher

Example

site gather schedule publisher

BES 5.1 and above


site gather schedule seconds

This command sets the schedule for gathering from the origin site to the number of seconds specified.

Syntax

site gather schedule seconds <seconds>

Example

site gather schedule seconds 360

Sets the site gathering schedule to six minutes.

BES 5.1 and above


subscribe

Subscribes the client to the site identified in the masthead file. The BES console provides the Manage Sites dialog to automate site addition.

Syntax

subscribe "<masthead file name>"

Example

subscribe "__Download\Sitename.fxm"

Note

In BES this command returns an error unless it is executed as an action in the master action site. The command is useful for subscribing clients to Enterprise Fixlet sites and for updating the action site masthead file.

BES 5.1 and above


unsubscribe

Automatically unsubscribes from the current Enterprise Fixlet site.

Syntax

unsubscribe

Example

unsubscribe

BES 5.1 and above


action uses wow64 redirection

This command allows the client to get outside of the 32-bit world created for it by the Windows On Windows64 (Wow64) facility built into the new 64-bit versions of the Windows operating system, including Windows 2003 x64 and Windows XP Pro x64.

When this command is executed in an action on a 64-bit OS with a value of true, the client enables Wow64 redirection in any subsequent commands that involve filenames. This state continues until the action completes or the client executes the action uses wow64 redirection false command.

You can use Relevance substitution to supply the <true|false> value. The file system redirection provided by Wow64 is disabled using the Wow64DisableWow64FsRedirection and re-enabled using the Wow64RevertWow64FsRedirection Windows API.

The commands affected by this setting include:

  • dos

  • run, wait, rundetached, waitdetached, runhidden, waithidden

  • delete, copy, move, open

Syntax

action uses wow64 redirection <true|false>

Example

action uses wow64 redirection true

This example turns on Wow64 redirection.

action uses wow64 redirection false

This example turns off Wow64 redirection.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

BES 6.0 and above -- Windows Only


regdelete64

Regdelete64 uses the same syntax as the regdelete command, but places a call to Wow64DisableWow64FsRedirection before launching the 64-bit version of Regedit to set the registry, allowing you to use the 64-bit registry available on 64-bit machines. This command deletes a registry key value of the given name. If the value doesn’t already exist, this command will fail and all subsequent commands will not be executed.

Syntax

regdelete64 "<registry key>" "<value name>"

Where registry key is the name of the key and value name is the value in the registry key you wish to delete.

Example

regdelete64 "[HKEY_CLASSES_ROOT\ShellScrap]" "NeverShowExt"

Deletes the NeverShowExt value from the specified registry key.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

If the specified key doesn't already exist, it will be created by this command.

BES 6.0 and above -- Windows Only


regset64

Regset64 uses the same syntax as the regset command, but places a call to Wow64DisableWow64FsRedirection before launching the 64-bit version of Regedit to set the registry. This allows you to use the native 64-bit registry to set a registry key to the given name and value. If the key doesn’t already exist, this command creates the key with this initial value.

Syntax

regset64 "<registry key>" "<value name>"=<value>

Where registry key is the key of interest and value name is the key value to set to value. These values are entered just as they are in a REGEDIT4 registry file, in keeping with the rules for Regedit, the Windows program that edits the registry. String values are delimited by quotes, and the standard 4-byte integer (dword) is identified using dword: followed by the numeric value entered in hexadecimal (with leading zeroes) as shown below.

Examples

regset64 "[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Security]" "Level"=dword:00000002

This example sets the Level value of the specified registry to a double-word 2.

regset64 "[HKEY_CURRENT_USER\Software\BigFix Inc.]" "testString"="bob"

This example sets the testString value of the specified registry key to bob.

regset64 "[HKEY_CLASSES_ROOT\ShellScrap]" "AlwaysShowExt"=""

This example clears the data of the specified registry value.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

Notice in these examples that square brackets [ ] are used to enclose the name of the registry key. Again, this is in keeping with the rules for REGEDIT4 registry files. This syntax is necessary for the RegSet command, but not for registry Inspectors.

When you use the BigFix regset64 command, keep in mind that the BigFix client dynamically builds the .reg file that you would have had to create manually to update the registry and then it executes that resulting .reg file for you. One of the rules of the .reg file is that any \’s in the value field need to appear as double slashes, that is \\. So if you were trying to assign the value SourcePath2 of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion to c:\I386, the command that you would define would look like this:

regset64 "[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]" "SourcePath2"="c:\\I386"

regset64 "[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]" "SourcePath2"={escape of "c:\I386"}

The last example uses the escape relevance clause to automatically convert backslashes to double backslashes.

If the specified key doesn't already exist, it will be created by this command.

BES 6.0 and above -- Windows Only


script64

Script64 uses the same syntax as the script command, but places a call to Wow64DisableWow64FsRedirection before executing the script. This allows you to issue a native 64-bit script command, bypassing Windows 32-bit environment built on top of 64-bit processors.

The script keyword executes an external script (created in a scripting language like JavaScript or Visual Basic) with the given name. The action script containing the script keyword will terminate if the appropriate scripting engine is not installed or if the script cannot be executed. The next line of the Action Shell Command is not executed until the specified script terminates.

Syntax

script64 <script name>

Example

script64 attrib.vbs

Runs the Visual BASIC script attrib.vbs in native 64-bit mode.

Notes

This command is Windows-only. It will cause an action script to terminate on a Unix agent.

On a Windows computer, this command has the same effect as calling Wow64DisableWow64FsRedirection and then issuing a wscript "scriptName" statement from Windows.

BES 6.0 and above -- Windows Only